Table of Contents

Table of Contents............................................................................................................................. i
Preface......................................................................................................................................... xvii

Chapter 1: Introduction to AIM I
1.0 Introduction to AIM I.................................................................................................... 1-1
1.1 Prerequisites.................................................................................................................. 1-2
1.2 Hardware and Software Requirements ......................................................................... 1-2
1.3 Referenced Documents ................................................................................................. 1-3
1.4 Formal Classroom Training Materials Development Process ...................................... 1-3
   1.4.1 Personnel Performance Profile Methodology ................................................... 1-3
   1.4.1.1 The Planning Phase ............................................................................ 1-4
   1.4.1.2 Stage One Development..................................................................... 1-5
      1.4.1.2.1 PPP Table Development ................................................... 1-5
      1.4.1.2.2 Training Path System (TPS) Development ...................... 1-7
      1.4.1.2.3 Course Training Requirements Selection in the COI.... 1-13
   1.4.1.3 Stage Two Development .................................................................. 1-14
   1.4.2 Automating Training Materials Maintenance in AIM I .................................. 1-18
   1.4.3 Automating Training Materials Administration in AIM I .............................. 1-19
1.5 AIM I Privileges .......................................................................................................... 1-19
1.6 Using the Manual ........................................................................................................ 1-21
   1.7 Using the Help System........................................................................................... 1-22
      1.7.1 On-line Help........................................................................................... 1-22
         1.7.1.1 Contents ........................................................................................... 1-23
         1.7.1.2 Index ................................................................................................ 1-25
         1.7.1.3 Search ............................................................................................... 1-25
      1.7.2 User’s Manual............................................................................................. 1-26
      1.7.3 Changes in Release 5.0 ........................................................................... 1-27
      1.7.4 Frequently Asked Questions .................................................................. 1-27
      1.7.5 Documentation ........................................................................................ 1-27
      1.7.6 Demonstrations ........................................................................................ 1-27
1.8 Summary ................................................................................................................... 1-28

Chapter 2: Getting Started
2.0 Getting Started.............................................................................................................. 2-1
2.1 AIM I Software Conventions........................................................................................ 2-1
   2.1.1 Using AIM I Menus.................................................................................... 2-2
   2.1.2 Using the Keyboard....................................................................................... 2-3
## 2.2 Login Procedures

## 2.3 Main Menu Bar

- **2.3.1 Selecting Display Preferences**
- **2.3.2 Working with the Course Tree Structure**
- **2.3.3 Options Menu Item**
  - **2.3.3.1 GoTo**
  - **2.3.3.2 Edit Notes**
  - **2.3.3.3 Create Modification TPP**
  - **2.3.3.4 Create Cancellation TPP**
  - **2.3.3.5 Delete TPP**
  - **2.3.3.6 Preview Notes**
  - **2.3.3.7 Print Notes**
  - **2.3.3.8 Print Preview**
  - **2.3.3.9 Print**
  - **2.3.3.10 Generate HTML**
  - **2.3.3.11 Preferences**

## 2.3.4 View Menu Item

- **2.3.4.1 Notes, Summary**
- **2.3.4.2 Refresh**
- **2.3.4.3 Expand All**
- **2.3.4.4 Contract**

## 2.3.5 Window Menu Item

## 2.3.6 Pop-Up Menu

## 2.3.7 Toolbar

## 2.3.8 General

## 2.4 Standard Functions

- **2.4.1 Edit Function**
- **2.4.2 Print Function**
- **2.4.3 Print Preview Function**

## 2.5 Editors Used in AIM I

- **2.5.1 MS Word**
- **2.5.2 Styled Text Editor**
- **2.5.3 AIM I Text Editor**
- **2.5.4 High Edit**

## 2.6 Status Levels for AIM I Products

## 2.7 Developing and Maintaining Courses

## 2.8 Maximum Values for Text Fields

### Chapter 3: Training Project Plan Module

- **3.0 Training Project Plan (TPP)**
- **3.1 Elements of a TPP**
- **3.2 Using the AIM I TPP Module**
# Table of Contents

## Chapter 3: AIM I TPP Module

3.3 Overview of the AIM I TPP Module ................................................................. 3-3  
3.4 Creating a New TPP ......................................................................................... 3-6  
3.5 Creating a Revision TPP ................................................................................. 3-9  
3.6 Creating a Cancellation TPP ......................................................................... 3-11  
3.7 Creating a Modification TPP ......................................................................... 3-13  
3.8 Selecting a TPP .............................................................................................. 3-13  
3.9 TPP Options Menu Bar Item........................................................................... 3-14  
  3.9.1 Grant Privileges ....................................................................................... 3-15  
  3.9.2 Lock and Unlock ..................................................................................... 3-15  
  3.9.3 Print Preview .......................................................................................... 3-16  
  3.9.4 Print ....................................................................................................... 3-17  
3.10 TPP Contents Menu Bar Item ...................................................................... 3-17  
  3.10.1 Compensation ....................................................................................... 3-18  
  3.10.2 Course Overview/Comments ............................................................... 3-20  
  3.10.3 Course Status ....................................................................................... 3-21  
  3.10.4 Development Method ........................................................................... 3-21  
  3.10.5 Justification ............................................................................................ 3-23  
  3.10.6 Milestones .............................................................................................. 3-24  
  3.10.7 Safety Risks and Hazardous Materials ............................................. 3-26  
  3.10.8 Summary of Differences ...................................................................... 3-26  
  3.10.9 Selecting a Learning Site ....................................................................... 3-27  
    3.10.9.1 Identifying Resources for the CCMM Learning Site .................... 3-30  
      3.10.9.1.1 Facility ...................................................................................... 3-32  
      3.10.9.1.2 Funding ................................................................................... 3-32  
      3.10.9.1.3 Manpower ............................................................................. 3-33  
      3.10.9.1.4 RRL Items ............................................................................ 3-34  
  3.10.9.2 Select Additional Learning Sites .................................................... 3-36  
  3.10.9.3 Change the CCMM to Another Selected Site ................................. 3-37  
3.11 Deleting a TPP ............................................................................................ 3-38  
3.12 On-Line Help ............................................................................................... 3-39  
3.13 Summary ...................................................................................................... 3-39

## Chapter 4: The Test Module

4.0 The Test Module ............................................................................................ 4-1  
4.1 Getting Started ............................................................................................. 4-1  
  4.1.1 Test Module, TLOs Window .................................................................... 4-2  
    4.1.1.1 Test Development Option ............................................................. 4-4  
    4.1.1.2 Test Support Materials Option .................................................... 4-10  
    4.1.1.3 Test Administration Option ........................................................... 4-13
Chapter 5: The Personnel Performance Profile Module

5.0 Personnel Performance Profiles (PPPs) ................................................................. 5-1
5.1 PPP Status Levels and Privileges ............................................................................. 5-1
5.2 Table Types and Line Items ..................................................................................... 5-2
5.3 Working with PPP Tables ......................................................................................... 5-2
  5.3.1 Select the PPP Window .................................................................................... 5-2
  5.3.2 Create PPP Tables ............................................................................................. 5-4
    5.3.2.1 Creating an Equipment/Subsystem/System (ESS) PPP Table ........... 5-4
    5.3.2.2 Creating a Task/Function or Background PPP Table ........................ 5-9
  5.3.3 Select a PPP Table .......................................................................................... 5-14
  5.3.4 Work With Line Items .................................................................................... 5-17
    5.3.4.1 Adding Line Items to a PPP Table ................................................... 5-17
    5.3.4.2 Deleting Line Items from a PPP Table ............................................ 5-20
    5.3.4.3 Linking Skill Line Items ................................................................ 5-20
    5.3.4.4 Developing Test Items for a PPP Table Line Item ....................... 5-20
  5.3.5 Maintain a PPP Table ...................................................................................... 5-33
  5.3.6 Copy a PPP Table ........................................................................................... 5-35
  5.3.7 Delete a PPP Table .......................................................................................... 5-36
  5.3.8 Find a PPP Table ............................................................................................. 5-36
  5.3.9 Grant Privilege for a PPP Table ...................................................................... 5-37
  5.3.10 Lock and Unlock a PPP Table ....................................................................... 5-38
  5.3.11 List Related Materials ..................................................................................... 5-39
  5.3.12 Print Preview a PPP Table .............................................................................. 5-39
  5.3.13 Print a PPP Table ............................................................................................ 5-40
  5.4 Summary ..................................................................................................................... 5-41

Chapter 6: The Training Path System Module

6.0 The Training Path System (TPS) ................................................................................. 6-1
6.1 The TPS Explained ................................................................................................. 6-1
  6.1.1 The Relationship Between the TPS and the TPC ............................................. 6-1
  6.1.2 The Relationship Between the TPS and the TCCD .......................................... 6-1
  6.1.3 The TPC Explained........................................................................................... 6-2
  6.1.4 TPS Status Levels and Privileges ...................................................................... 6-2
  6.1.5 TPS Assumptions ............................................................................................ 6-3
6.2 Training Path System (TPS) Windows .................................................................... 6-4
  6.2.1 Create a TPS ................................................................................................. 6-5
    6.2.1.1 Create a TPC ...................................................................................... 6-6
    6.2.1.2 Create TLAs for the TPC ................................................................... 6-7
    6.2.1.3 Develop a Course List for the TPC .................................................. 6-10
  6.2.2 Modify the TPS Introduction ............................................................................. 6-11
  6.2.3 Maintain a TPS .............................................................................................. 6-12
  6.2.4 Deleting a TPS and Its Associated Elements ................................................... 6-13
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.2.4.1 Delete Courses from the TPC Course List</td>
<td>6-13</td>
</tr>
<tr>
<td>6.2.4.2 Delete TLAs from the TPC</td>
<td>6-14</td>
</tr>
<tr>
<td>6.2.4.3 Delete TPCs from the TPS</td>
<td>6-14</td>
</tr>
<tr>
<td>6.2.4.4 Delete a TPS</td>
<td>6-14</td>
</tr>
<tr>
<td>6.2.5 Find a TPS</td>
<td>6-15</td>
</tr>
<tr>
<td>6.2.6 Grant Privilege for a TPS</td>
<td>6-15</td>
</tr>
<tr>
<td>6.2.7 Lock and Unlock a TPS</td>
<td>6-16</td>
</tr>
<tr>
<td>6.2.8 Print Preview a TPS</td>
<td>6-16</td>
</tr>
<tr>
<td>6.2.9 Print a TPS</td>
<td>6-17</td>
</tr>
<tr>
<td>6.2.10 Change Package</td>
<td>6-18</td>
</tr>
<tr>
<td>6.2.11 Maintenance on an Approved Curriculum</td>
<td>6-18</td>
</tr>
<tr>
<td>6.2.12 Removing System Maintenance Flags</td>
<td>6-20</td>
</tr>
<tr>
<td>6.3 Summary</td>
<td>6-20</td>
</tr>
<tr>
<td>Chapter 7: The Training Course Control Document (TCCD) Module</td>
<td></td>
</tr>
<tr>
<td>7.0 The Training Course Control Document (TCCD) Module</td>
<td>7-1</td>
</tr>
<tr>
<td>7.1 Overview of the TCCD</td>
<td>7-1</td>
</tr>
<tr>
<td>7.2 The TCCD Module</td>
<td>7-1</td>
</tr>
<tr>
<td>7.2.1 The TCCD Window Cover Page</td>
<td>7-1</td>
</tr>
<tr>
<td>7.2.2 The TCCD Learning Sites</td>
<td>7-3</td>
</tr>
<tr>
<td>7.2.3 The TCCD Trainee Data</td>
<td>7-8</td>
</tr>
<tr>
<td>7.2.4 Printing the TCCD</td>
<td>7-10</td>
</tr>
<tr>
<td>7.2.5 The TCCD Foreword and Course Overview/Comments</td>
<td>7-12</td>
</tr>
<tr>
<td>7.2.6 Approving and Maintaining the TCCD, LP, and TG</td>
<td>7-13</td>
</tr>
<tr>
<td>7.3 Summary</td>
<td>7-16</td>
</tr>
<tr>
<td>Chapter 8: The Curriculum Outline of Instruction (COI) Module</td>
<td></td>
</tr>
<tr>
<td>8.0 The COI Module</td>
<td>8-1</td>
</tr>
<tr>
<td>8.1 Overview of the COI</td>
<td>8-1</td>
</tr>
<tr>
<td>8.2 The Part/Section/Topic Window</td>
<td>8-1</td>
</tr>
<tr>
<td>8.2.1 Part/Section/Topic Window Menu Bar Items</td>
<td>8-2</td>
</tr>
<tr>
<td>8.2.1.1 Part/Section/Topic Window Options Menu Item</td>
<td>8-2</td>
</tr>
<tr>
<td>8.2.1.2 Part/Section/Topic Window Contents Menu Item</td>
<td>8-3</td>
</tr>
<tr>
<td>8.3 Development of the COI</td>
<td>8-3</td>
</tr>
<tr>
<td>8.3.1 Selecting the Course Training Requirements</td>
<td>8-4</td>
</tr>
<tr>
<td>8.3.2 Selecting and Working with TLOs in a Topic</td>
<td>8-5</td>
</tr>
<tr>
<td>8.3.2.1 Joining TLO</td>
<td>8-7</td>
</tr>
<tr>
<td>8.3.2.2 Unjoining a TLO</td>
<td>8-7</td>
</tr>
<tr>
<td>8.3.2.3 Splitting a TLO</td>
<td>8-8</td>
</tr>
<tr>
<td>8.3.2.4 Deleting TLO</td>
<td>8-9</td>
</tr>
<tr>
<td>8.3.2.5 Viewing the TLA Links to the TLO</td>
<td>8-9</td>
</tr>
<tr>
<td>8.3.2.6 Creating Additional TLOs for a Topic</td>
<td>8-10</td>
</tr>
</tbody>
</table>
# Table of Contents

8.3.2.7 Resequencing TLOs ................................................................. 8-12
8.3.3 Entering TLO Test Item Numbers in the OAC for a TLO .......... 8-12
8.3.4 Selecting and Working With CLOs ........................................ 8-13
8.3.5 Joining Parts, Sections, and Topics ....................................... 8-15
8.3.6 Unjoining a Part ................................................................. 8-15
8.3.7 Splitting a Part, Section, or Topic ......................................... 8-16
8.3.8 Copy Part/Section/Topic from another Course .................... 8-17
8.3.9 Deleting a Part, Section, or Topic ......................................... 8-19
8.3.10 Resequencing Parts, Sections, and Topics ......................... 8-20
8.3.11 Print Preview Option .......................................................... 8-20
8.3.12 Print Option ........................................................................ 8-21
8.4 Summary ................................................................................. 8-22

Chapter 9: The Course Master Schedule Module

9.0 Course Master Schedule .......................................................... 9-1
9.1 Content of the Course Master Schedule .................................. 9-1
9.2 Using the AIM I CMS Module .................................................. 9-2
9.3 Completing the CMS ............................................................... 9-3
  9.3.1 Period Type ....................................................................... 9-3
  9.3.2 Topic Title ........................................................................ 9-4
  9.3.3 Entering Week and Day ...................................................... 9-4
  9.3.4 Editing Student-to-Instructor Ratio ................................. 9-4
  9.3.5 Bottlenecks ..................................................................... 9-5
9.4 CMS Options ................................................................. 9-6
  9.4.1 Duplicate CMS Period ...................................................... 9-6
  9.4.2 Delete CMS Period .......................................................... 9-6
  9.4.3 Print Preview ................................................................. 9-7
  9.4.4 Print ............................................................................... 9-8
  9.4.5 Explain Flag .................................................................... 9-8
  9.4.6 Remove Flag ................................................................. 9-8
9.5 CMS Events ................................................................. 9-8
  9.5.1 CMS Events Options ...................................................... 9-8
  9.5.2 CMS Events Columns ..................................................... 9-8
9.6 Help ....................................................................................... 9-9
9.7 Summary ................................................................................. 9-9

Chapter 10: The Lesson Plan (LP) Module

10.0 Lesson Plan ................................................................. 10-1
10.1 Introduction ................................................................. 10-1
  10.1.1 The Relationship Between the LP and TCCD ................. 10-3
  10.1.2 The Relationship Between the LP and the TG .......... 10-4
  10.1.3 LP Status Levels and Privileges .................................... 10-4
### Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.2 Getting Started</td>
<td>10-5</td>
</tr>
<tr>
<td>10.3 Lesson Plan Cover Page</td>
<td>10-5</td>
</tr>
<tr>
<td>10.3.1 Lesson Plan Window Options Menu Item</td>
<td>10-5</td>
</tr>
<tr>
<td>10.3.1.1 Print Options</td>
<td>10-6</td>
</tr>
<tr>
<td>10.3.1.2 Print Preview</td>
<td>10-6</td>
</tr>
<tr>
<td>10.3.1.3 Print</td>
<td>10-8</td>
</tr>
<tr>
<td>10.3.1.4 Change Package</td>
<td>10-8</td>
</tr>
<tr>
<td>10.3.2 Lesson Plan Window Contents Menu Item</td>
<td>10-9</td>
</tr>
<tr>
<td>10.3.2.1 AOIT Contents Menu Sub-item</td>
<td>10-9</td>
</tr>
<tr>
<td>10.3.2.2 The FAL Contents Menu Item</td>
<td>10-10</td>
</tr>
<tr>
<td>10.3.2.2.1 Adding a Fault to the FAL</td>
<td>10-10</td>
</tr>
<tr>
<td>10.3.2.3 How to Use LP Contents Menu Sub-item</td>
<td>10-13</td>
</tr>
<tr>
<td>10.3.2.4 Safety/Hazard Awareness Notice Contents Menu Sub-item</td>
<td>10-14</td>
</tr>
<tr>
<td>10.3.2.5 SCORM Metadata (Course)</td>
<td>10-14</td>
</tr>
<tr>
<td>10.3.2.6 COI Contents Menu Sub-item</td>
<td>10-16</td>
</tr>
<tr>
<td>10.3.2.6.1 Entering Trainee Preparation Materials</td>
<td>10-16</td>
</tr>
<tr>
<td>10.3.2.6.2 Entering Topic Time for the Class/Lab</td>
<td>10-18</td>
</tr>
<tr>
<td>10.3.2.6.3 SCORM Metadata (Topic)</td>
<td>10-18</td>
</tr>
<tr>
<td>10.3.2.6.4 DP/RIA Window</td>
<td>10-19</td>
</tr>
<tr>
<td>10.3.2.6.4.1 Adding DPs</td>
<td>10-21</td>
</tr>
<tr>
<td>10.3.2.6.4.2 Deleting DPs</td>
<td>10-22</td>
</tr>
<tr>
<td>10.3.2.6.4.3 Adding Notes, Cautions, and Warnings</td>
<td>10-23</td>
</tr>
<tr>
<td>10.3.2.6.4.4 Working with RIAs</td>
<td>10-23</td>
</tr>
<tr>
<td>10.3.2.6.4.5 Building an RIA</td>
<td>10-24</td>
</tr>
<tr>
<td>10.3.2.6.4.6 Adding/Selecting Instruction (TG) Sheets</td>
<td>10-26</td>
</tr>
<tr>
<td>10.3.2.6.4.7 Selecting a Fault</td>
<td>10-27</td>
</tr>
<tr>
<td>10.3.2.6.4.8 Selecting an IETM</td>
<td>10-27</td>
</tr>
<tr>
<td>10.3.2.6.4.9 Selecting an IMI</td>
<td>10-29</td>
</tr>
<tr>
<td>10.3.2.6.4.10 Adding Another RIA</td>
<td>10-30</td>
</tr>
<tr>
<td>10.3.2.6.11 Adding a Same Level RIA</td>
<td>10-30</td>
</tr>
<tr>
<td>10.3.2.6.12 Adding a Lower Level RIA</td>
<td>10-31</td>
</tr>
<tr>
<td>10.3.2.6.13 Deleting an RIA</td>
<td>10-31</td>
</tr>
<tr>
<td>10.3.2.6.14 Copying and Pasting an RIA</td>
<td>10-31</td>
</tr>
<tr>
<td>10.3.2.6.15 Resequencing DPs and RIAs</td>
<td>10-32</td>
</tr>
<tr>
<td>10.3.2.6.16 Linking DPs to the TLOs They Support</td>
<td>10-32</td>
</tr>
<tr>
<td>10.3.2.6.17 DP Spacing</td>
<td>10-33</td>
</tr>
<tr>
<td>10.4 Summary</td>
<td>10-34</td>
</tr>
</tbody>
</table>

Chapter 11: The Exercise Controller Guide (ECG) Module

Release 5.6
# Table of Contents

## Chapter 11: Exercise Controller Guide

11.0 Exercise Controller Guide
11.1 Overview
  11.1.1 Front Matter
11.2 Accessing the Exercise Controller Guide
11.3 ECG Options Menu Item
11.4 ECG Contents Menu Item
  11.4.1 Safety/Hazard Awareness Notice
  11.4.2 How to Use the ECG
  11.4.3 COI

## Chapter 12: The Trainee Guide (TG) Module

12.0 Trainee Guide
12.1 Overview
  12.1.1 Front Matter
  12.1.2 Instruction Sheets
  12.1.3 Editors Used In the TG
    12.1.3.1 MS Word
    12.1.3.2 Styled Text Editor
    12.1.3.3 High Edit
  12.2 TG Status Levels and Privileges
  12.3 Accessing the Trainee Guide (TG)
12.4 TG Options Menu Item
12.5 TG Contents Menu Item
  12.5.1 How to Use the TG
  12.5.2 Safety/Hazard Awareness Notice
  12.5.3 Security Awareness Notice
  12.5.4 TG Sheets
    12.5.4.1 TG Assignment Sheet
    12.5.4.2 TG Diagram Sheet
    12.5.4.3 TG Job Sheet
    12.5.4.4 TG Problem Sheet
    12.5.4.5 TG Information Sheet
    12.5.4.6 TG Outline Sheet

## Chapter 13: The Learning Object Module

13.0 Learning Object Module
13.1 Learning Object Module Menu Items
  13.1.1 Courses, Modules, Lessons, and Sections Contents Menu Item
  13.1.2 Sections Window
    13.1.2.1 Create a New Section
    13.1.2.2 Create a Section From AIM Data
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>13.1.2.3 Create an Element from AIM Data</td>
<td>13-13</td>
</tr>
<tr>
<td>13.1.2.3 Adding Test Items for a Section</td>
<td>13-14</td>
</tr>
<tr>
<td>13.1.2.4 Adding TG Sheets for an Instructor-Led Section</td>
<td>13-22</td>
</tr>
<tr>
<td>13.1.3 Lessons Window</td>
<td>13-29</td>
</tr>
<tr>
<td>13.1.4 Modules Window</td>
<td>13-33</td>
</tr>
<tr>
<td>13.1.5 Courses Window</td>
<td>13-35</td>
</tr>
</tbody>
</table>
APPENDICES

Appendix A: Glossary
Glossary ................................................................................................................................ A-1

Appendix B: AIM I Administration and Utilities
1.0 AIM I Administrative and Utility Functions .................................................................B-1
2.0 Utilities Menu Items .................................................................................................B-1
2.1 Change Password Utility .........................................................................................B-1
  2.1.1 Enter a New Password .....................................................................................B-2
2.2 Site Resource Requirements List Utility ....................................................................B-2
  2.2.1 Site Resource Requirements List Window Options Menu Item .......................B-3
    2.2.1.1 Add Resource .....................................................................................B-4
    2.2.1.2 Modify/View Resource .......................................................................B-6
    2.2.1.3 Delete a Resource ...............................................................................B-6
    2.2.1.4 Grant Privilege ..................................................................................B-7
    2.2.1.5 Replace an IMI Item ...........................................................................B-8
    2.2.1.6 Display Related Materials ..................................................................B-8
    2.2.1.7 Flag Related Materials for Maintenance Action ......................................B-9
    2.2.1.8 Display Unused Resources .....................................................................B-10
    2.2.1.9 Search the Site RRL for a RRL Item .....................................................B-10
    2.2.1.10 SCORM Metadata ............................................................................B-10
    2.2.1.11 Explain Flag .....................................................................................B-10
    2.2.1.12 Print Preview a Listing of all RRL Items of a Type ................................B-11
    2.2.1.13 Print a Listing of all Resource Items of a Type ....................................B-11
    2.2.1.14 Clearing a Conflicting State on an IMI ..............................................B-12
2.3 Graphics Utility ...........................................................................................................B-12
  2.3.1 Graphics Option Menu Item ...........................................................................B-12
    2.3.1.1 Add Graphic Option .........................................................................B-13
    2.3.1.2 Modify Graphic Option .......................................................................B-14
    2.3.1.3 Delete Graphic Option .......................................................................B-16
    2.3.1.4 Replace Graphic Option .....................................................................B-17
    2.3.1.5 View Graphic Option .........................................................................B-17
    2.3.1.6 Find Graphic Option ...........................................................................B-17
    2.3.1.7 Display Unused Graphics .....................................................................B-17
    2.3.1.8 Related Courses Option .....................................................................B-18
    2.3.1.9 SCORM Metadata .............................................................................B-18
2.4 Admin Utility................................................................................................. B-18
   2.4.1 Administration Utility Options Menu Item.............................................. B-19
   2.4.1.1 Importing IETM Extract Files............................................................ B-21
   2.4.1.2 Mapping the Location of the IETM Viewer........................................ B-23
   2.4.1.3 Grant Privilege.................................................................................. B-30
   2.4.1.4 Approve Training Material................................................................. B-31
   2.4.1.5 Clear In Use Flag.............................................................................. B-33
   2.4.1.6 Clear Conflict State......................................................................... B-34
   2.4.1.7 Unapprove Modification or Cancellation TPP.................................. B-34

2.5 Delete Proposed Training Material (TM) Utility........................................ B-35

2.6 Reporting..................................................................................................... B-36

2.7 RRL/Graphics Location Tool Utility............................................................. B-40
   2.7.1 Resource/Graphic Selection Window.................................................... B-40
   2.7.2 Resource Selection.............................................................................. B-41
   2.7.3 Graphic Selection................................................................................. B-42
   2.7.4 Reference Breakdown......................................................................... B-43
   2.7.5 IETM Breakdown................................................................................. B-44
   2.7.6 Related Courses Selection................................................................. B-44
   2.7.7 Search Results Window..................................................................... B-46
   2.7.8 Print Preview....................................................................................... B-47

2.8 Learning Site Utility.................................................................................... B-49
   2.8.1 Site Options Menu Item...................................................................... B-49
   2.8.1.1 Add Site......................................................................................... B-49
   2.8.1.2 Delete Site..................................................................................... B-50
   2.8.1.3 Modify Site.................................................................................... B-50
   2.8.1.4 Replace Site.................................................................................. B-51

2.9 Agency Utility............................................................................................. B-52
   2.9.1 Agency Options Menu Item................................................................. B-52
   2.9.1.1 Add Agency.................................................................................... B-52
   2.9.1.2 Delete Agency............................................................................... B-53
   2.9.1.3 Modify an Agency......................................................................... B-53
   2.9.1.4 Replace Agency............................................................................ B-54

2.10 Archive/Unarchive Utility......................................................................... B-55
   2.10.1 Archive/Unarchive Options Menu Item............................................ B-55
   2.10.1.1 Archive Training Material............................................................ B-55
   2.10.1.2 View Archive Information............................................................ B-56
   2.10.1.3 Unarchive Training Material......................................................... B-57
   2.10.1.4 Generate Archive IMI Report....................................................... B-58
# AIM I User’s Manual

## Table of Contents

2.11 Import/Export Utility .................................................................................................. B-59
  2.11.1 Rules for Import/Export Process ..................................................................... B-59
  2.11.2 Import/Export Options Menu Item ................................................................. B-60
    2.11.2.1 Export Training Material ..................................................................... B-61
    2.11.2.2 View Export Information ..................................................................... B-62
    2.11.2.3 Generate Import IMI Report ............................................................... B-62
    2.11.2.4 Import Training Material ..................................................................... B-63
2.12 User Utility .................................................................................................................. B-65
  2.12.1 User Administration Options Menu Item........................................................ B-65
    2.12.1.1 Add a User ....................................................................................... B-66
    2.12.1.2 Delete a User .................................................................................... B-67
    2.12.1.3 Clear User Password Option ............................................................ B-67
    2.12.1.4 Edit a User’s Information ................................................................. B-68
2.13 Relink PPP/TPS Utility ............................................................................................... B-69
2.14 Data Manager Utility................................................................................................... B-70

Appendix C: AIM Trouble Report and AIM Change Request

1.0 Trouble Report .............................................................................................................. C-1
  1.1 Users ............................................................................................................................. C-1
  1.2 Maintenance Action ...................................................................................................... C-1
  1.3 Trouble Reports ............................................................................................................ C-1
  1.4 Trouble Report Form .................................................................................................... C-1
  1.5 Trouble Report Instructions .......................................................................................... C-1
  1.6 AIM Change Request ................................................................................................ C-2
  1.7 AIM Change Request Form .......................................................................................... C-2
  1.8 AIM Change Request Form Instructions ...................................................................... C-2
  1.9 Sending the Database to NAVAIR Orlando ................................................................. C-4

Appendix D: Developing IETM Extraction Files

1.0 Introduction .................................................................................................................. D-1
2.0 SGML-based IETM ..................................................................................................... D-1
  2.1 Introduction ............................................................................................................... D-1
  2.2 Installing the SGML-based IETM Extraction Program .................................. D-2
  2.3 Running the SGML-based IETM Extraction Program ....................................... D-2
    2.3.1 Description of Registration (Information) File ........................................ D-11
      2.3.1.1 Example of Determining the Contents of the Registration File using the GD SWS IETM D-17
    2.3.2 Description of the Library File ............................................................... D-27
    2.3.3 Description of DDE Information File .................................................... D-29
# Table of Contents

## 3.0 Other IETMs

### 3.1 Introduction

### 3.2 ARCI IETM

#### 3.2.1 Introduction

#### 3.2.2 Installing the ARCI IETM Extraction Program

#### 3.2.3 Running the ARCI IETM Extraction Program

### 3.3 PDF Documents

#### 3.3.1 Introduction

#### 3.3.2 Installing the PDF Extraction Routine

#### 3.3.3 Running the PDF Extraction Routine

### 3.4 PMS Documents

#### 3.4.1 Introduction

#### 3.4.2 Installing the PMS Documents Extraction Routine

#### 3.4.3 Running the PMS Documents Extraction Routine

### 3.5 Raster Technical Manuals

#### 3.5.1 Introduction

#### 3.5.2 Installing the Raster Technical Manuals Extraction Routine

#### 3.5.3 Running the Raster Technical Manuals Extraction Routine

### 3.6 XML-Based IETMs

#### 3.6.1 Introduction

#### 3.6.2 Installing the XML-Based IETM Extraction Routine

#### 3.6.3 Running the XML-Based IETM Extraction Routine

### 3.7 S1000D IETMs

#### 3.7.1 Introduction

#### 3.7.2 Running the S1000D IETM Extraction Routine

## Appendix E: AIM I Version 5.0 Functional Changes

### AIM I Version 5.0 Functional Changes

## Appendix F: SCORM AND NILARS

### 1.0 Sharable Content Object Reference Model (SCORM) Overview

### 1.1 SCORM Content Model Components

### 2.0 Navy Integrated Learning Asset Repository System (NILARS) Overview

### 2.1 Potential Uses of AIM Data in NILARS Repository System

### 3.0 Developing SCORM Data

#### 3.1 Creating a SCORM Output

#### 3.2 SCORM Data Tabs Content

#### 3.3 Detailed Contents of the AIM-to-SCORM Output Package
# FIGURES

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1-1</td>
<td>Equipment PPP TLA for Performance Task Set</td>
<td>1-12</td>
</tr>
<tr>
<td>1-2</td>
<td>On-line Help, Help Topics Window</td>
<td>1-23</td>
</tr>
<tr>
<td>1-3</td>
<td>On-line Help, Hot Word Glossary Pop-up Box</td>
<td>1-24</td>
</tr>
<tr>
<td>1-4</td>
<td>On-line Help, Index Tab</td>
<td>1-25</td>
</tr>
<tr>
<td>1-5</td>
<td>On-line Help, Search Tab</td>
<td>1-26</td>
</tr>
<tr>
<td>2-1</td>
<td>Course Tree Structure Window</td>
<td>2-7</td>
</tr>
<tr>
<td>2-2</td>
<td>Media Location Window</td>
<td>2-12</td>
</tr>
<tr>
<td>2-3</td>
<td>AIM I Edit Menu Item</td>
<td>2-15</td>
</tr>
<tr>
<td>2-4</td>
<td>MS Windows Print Setup Window</td>
<td>2-16</td>
</tr>
<tr>
<td>2-5</td>
<td>Styled Text Editor for Introduction Fields</td>
<td>2-18</td>
</tr>
<tr>
<td>2-6</td>
<td>AIM I Text Editor for TCCD Course Overview/Comments</td>
<td>2-19</td>
</tr>
<tr>
<td>2-7</td>
<td>High Edit for Job Steps</td>
<td>2-21</td>
</tr>
<tr>
<td>3-1</td>
<td>TPP Main Window</td>
<td>3-2</td>
</tr>
<tr>
<td>3-2</td>
<td>Training Project Plan Window</td>
<td>3-4</td>
</tr>
<tr>
<td>3-3</td>
<td>Learning Site Summary Window</td>
<td>3-5</td>
</tr>
<tr>
<td>3-4</td>
<td>TPP Window with Prepared For Block Highlighted</td>
<td>3-8</td>
</tr>
<tr>
<td>4-1</td>
<td>AIM I Test Module, TLOs Window</td>
<td>4-2</td>
</tr>
<tr>
<td>4-2</td>
<td>Criticality Index Worksheet Window</td>
<td>4-3</td>
</tr>
<tr>
<td>4-3</td>
<td>Test Cover Page Window</td>
<td>4-5</td>
</tr>
<tr>
<td>5-1</td>
<td>Personnel Performance Profile Window</td>
<td>5-4</td>
</tr>
<tr>
<td>5-2</td>
<td>Create PPP Window</td>
<td>5-6</td>
</tr>
<tr>
<td>5-3</td>
<td>Create Sub-item</td>
<td>5-7</td>
</tr>
<tr>
<td>5-4</td>
<td>Create PPP View Window</td>
<td>5-8</td>
</tr>
<tr>
<td>5-5</td>
<td>Line Item Window with Link Skill Selected</td>
<td>5-12</td>
</tr>
<tr>
<td>5-6</td>
<td>Links Window</td>
<td>5-13</td>
</tr>
<tr>
<td>5-7</td>
<td>PPP Options Menu, Showing the Lock Option Highlighted</td>
<td>5-14</td>
</tr>
<tr>
<td>5-8</td>
<td>Maintenance Explanation Window</td>
<td>5-16</td>
</tr>
<tr>
<td>5-9</td>
<td>Add Line Item, Same Level</td>
<td>5-18</td>
</tr>
<tr>
<td>5-10</td>
<td>Test Items for Line Item Window</td>
<td>5-21</td>
</tr>
<tr>
<td>5-11</td>
<td>Fill-in-the-Blank Test Item for Line Item Window</td>
<td>5-23</td>
</tr>
<tr>
<td>5-12</td>
<td>Multiple Choice Test Item for Line Item Window</td>
<td>5-25</td>
</tr>
<tr>
<td>5-13</td>
<td>Select Site RRL Window</td>
<td>5-26</td>
</tr>
<tr>
<td>5-14</td>
<td>True/False Test Item for Line Item Window</td>
<td>5-28</td>
</tr>
<tr>
<td>5-15</td>
<td>Select Site RRL Window</td>
<td>5-28</td>
</tr>
<tr>
<td>5-16</td>
<td>Two Column Matching Test Item for Line Item Window</td>
<td>5-31</td>
</tr>
<tr>
<td>Figure</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
<td>------</td>
</tr>
<tr>
<td>5-17</td>
<td>Grant Option Selection</td>
<td>5-38</td>
</tr>
<tr>
<td>6-1</td>
<td>Training Path System (TPS) Window</td>
<td>6-4</td>
</tr>
<tr>
<td>6-2</td>
<td>TPCs Window</td>
<td>6-5</td>
</tr>
<tr>
<td>7-1</td>
<td>TCCD Window</td>
<td>7-2</td>
</tr>
<tr>
<td>7-2</td>
<td>Learning Sites Window</td>
<td>7-4</td>
</tr>
<tr>
<td>7-3</td>
<td>Trainee Data Window</td>
<td>7-9</td>
</tr>
<tr>
<td>8-1</td>
<td>Part/Section/Topic Window</td>
<td>8-2</td>
</tr>
<tr>
<td>8-2</td>
<td>TLOs Window</td>
<td>8-6</td>
</tr>
<tr>
<td>8-3</td>
<td>TLA Window</td>
<td>8-10</td>
</tr>
<tr>
<td>8-4</td>
<td>TLA Line Items Window</td>
<td>8-11</td>
</tr>
<tr>
<td>8-5</td>
<td>Test Items Window</td>
<td>8-12</td>
</tr>
<tr>
<td>8-6</td>
<td>CLOs Window</td>
<td>8-14</td>
</tr>
<tr>
<td>9-1</td>
<td>Course Master Schedule</td>
<td>9-2</td>
</tr>
<tr>
<td>10-1</td>
<td>FAL Window</td>
<td>10-11</td>
</tr>
<tr>
<td>12-1</td>
<td>Required and Optional Elements For a Section</td>
<td>12-3</td>
</tr>
<tr>
<td>B-1</td>
<td>Change Password Prompt</td>
<td>B-1</td>
</tr>
<tr>
<td>B-2</td>
<td>Administration Utility Window</td>
<td>B-19</td>
</tr>
<tr>
<td>B-3</td>
<td>IETM DDE Window for SGML-Based</td>
<td>B-24</td>
</tr>
<tr>
<td>B-4</td>
<td>IETM DDE Window for ARCI</td>
<td>B-25</td>
</tr>
<tr>
<td>B-5</td>
<td>IETM DDE Window for PDF Documents</td>
<td>B-26</td>
</tr>
<tr>
<td>B-6</td>
<td>IETM DDE Window for PMS Documents</td>
<td>B-27</td>
</tr>
<tr>
<td>B-7</td>
<td>IETM DDE Window for Raster Technical Manuals</td>
<td>B-28</td>
</tr>
<tr>
<td>B-8</td>
<td>Clear In Use Drop-Down Menu</td>
<td>B-34</td>
</tr>
<tr>
<td>B-9</td>
<td>AIM Reporting: Pre-formatted Reports</td>
<td>B-37</td>
</tr>
<tr>
<td>B-10</td>
<td>AIM Reporting: Custom Reports</td>
<td>B-38</td>
</tr>
<tr>
<td>B-11</td>
<td>Search Criteria Window With Field Drop-Down Menu Selected</td>
<td>B-38</td>
</tr>
<tr>
<td>B-12</td>
<td>AIM Reporting: Data Output</td>
<td>B-39</td>
</tr>
<tr>
<td>B-13</td>
<td>RRL/Graphics Location Tool: Select Data</td>
<td>B-40</td>
</tr>
<tr>
<td>B-14</td>
<td>RRL/Graphics Location Tool: Resource Selection</td>
<td>B-41</td>
</tr>
<tr>
<td>B-15</td>
<td>RRL/Graphics Location Tool: Graphic Selection</td>
<td>B-42</td>
</tr>
<tr>
<td>B-16</td>
<td>RRL Breakdown for Reference</td>
<td>B-43</td>
</tr>
<tr>
<td>B-17</td>
<td>IETM Breakdown</td>
<td>B-44</td>
</tr>
<tr>
<td>B-18</td>
<td>Related Courses</td>
<td>B-45</td>
</tr>
<tr>
<td>B-19</td>
<td>Search Results</td>
<td>B-46</td>
</tr>
<tr>
<td>B-20</td>
<td>Print Preview Results</td>
<td>B-48</td>
</tr>
<tr>
<td>B-21</td>
<td>User Administration Window</td>
<td>B-65</td>
</tr>
<tr>
<td>D-1</td>
<td>IETM Extraction Utility</td>
<td>D-3</td>
</tr>
<tr>
<td>D-2</td>
<td>Extraction Output</td>
<td>D-4</td>
</tr>
<tr>
<td>D-3</td>
<td>SGML-based IETM Extraction</td>
<td>D-5</td>
</tr>
<tr>
<td>D-4</td>
<td>IETM DDE</td>
<td>D-7</td>
</tr>
<tr>
<td>D-5</td>
<td>HTML based IETM DDE</td>
<td>D-8</td>
</tr>
<tr>
<td>D-6</td>
<td>Dynatext-based IETM DDE</td>
<td>D-9</td>
</tr>
<tr>
<td>D-7</td>
<td>AIMSS 3.x based IETM DDE</td>
<td>D-10</td>
</tr>
<tr>
<td>D-8</td>
<td>Guide Reader-based IETM DDE</td>
<td>D-11</td>
</tr>
<tr>
<td>D-9</td>
<td>Select Data Source</td>
<td>D-34</td>
</tr>
<tr>
<td>D-10</td>
<td>IETM Viewer Type</td>
<td>D-35</td>
</tr>
<tr>
<td>D-11</td>
<td>PDF IETM Extraction</td>
<td>D-36</td>
</tr>
<tr>
<td>D-12</td>
<td>PDF Extraction Destination File</td>
<td>D-37</td>
</tr>
<tr>
<td>D-13</td>
<td>PDF Extraction Output Location</td>
<td>D-38</td>
</tr>
<tr>
<td>D-14</td>
<td>PMS Database File</td>
<td>D-40</td>
</tr>
<tr>
<td>D-15</td>
<td>PMS Viewer Location</td>
<td>D-41</td>
</tr>
<tr>
<td>D-16</td>
<td>PMS Extraction Output</td>
<td>D-42</td>
</tr>
<tr>
<td>D-17</td>
<td>Raster Tech Manual Files</td>
<td>D-43</td>
</tr>
<tr>
<td>D-18</td>
<td>INTERFAC Extraction Viewer</td>
<td>D-44</td>
</tr>
<tr>
<td>D-19</td>
<td>Raster Extraction Output</td>
<td>D-45</td>
</tr>
<tr>
<td>D-20</td>
<td>XML Extraction Files</td>
<td>D-48</td>
</tr>
<tr>
<td>D-21</td>
<td>XML Extraction Viewer</td>
<td>D-49</td>
</tr>
<tr>
<td>D-22</td>
<td>Launch XML Viewer</td>
<td>D-50</td>
</tr>
<tr>
<td>D-23</td>
<td>HTML Files Directory</td>
<td>D-51</td>
</tr>
<tr>
<td>D-24</td>
<td>HTML Files Directory (complete)</td>
<td>D-52</td>
</tr>
<tr>
<td>D-25</td>
<td>IETM Selection</td>
<td>D-53</td>
</tr>
<tr>
<td>D-26</td>
<td>PM File Selection</td>
<td>D-54</td>
</tr>
<tr>
<td>D-27</td>
<td>NSIV Viewer Selection</td>
<td>D-55</td>
</tr>
<tr>
<td>D-28</td>
<td>S1000D Extraction Output</td>
<td>D-56</td>
</tr>
<tr>
<td>D-29</td>
<td>S1000D Extraction Summary</td>
<td>D-57</td>
</tr>
<tr>
<td>F-1</td>
<td>AIM Input and Output with SCORM</td>
<td>F-3</td>
</tr>
</tbody>
</table>
## TABLES

<table>
<thead>
<tr>
<th>Table</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1-1</td>
<td>AIM User Privilege Levels at a Glance</td>
<td>1-20</td>
</tr>
<tr>
<td>2-1</td>
<td>Common MS Windows Features Used In AIM I</td>
<td>2-1</td>
</tr>
<tr>
<td>2-2</td>
<td>Common AIM I Menu Conventions</td>
<td>2-2</td>
</tr>
<tr>
<td>10-1</td>
<td>Instruction Sheets, Divisions, and Associated Elements</td>
<td>10-1</td>
</tr>
<tr>
<td>12-1</td>
<td>Required and Optional Elements for a Section</td>
<td>12-3</td>
</tr>
<tr>
<td>C-1</td>
<td>ACR Form Instructions</td>
<td>C-3</td>
</tr>
</tbody>
</table>
Preface

This manual (Document Identification No. AIM I SUM 00005) was developed for the AIM System Support Office (SSO) to support the computer software configuration item identified as PPP-based Authoring Instructional Materials (AIM I). It was prepared in accordance with DOD-STD-2167A, Data Item Description DI-MCCR-80019A.

The AIM SSO is responsible for all aspects of the AIM Program management and support. It is the initial point of contact for all matters dealing with the AIM Program or specific hardware or software issues.

AIM users can call the AIM Help Desk at the following numbers:

SSO Help Desk: (407) 381-8620 The DSN prefix is 960
SSO FAX: (407) 380-4519
SSO Email ETEHELPDESK@navy.mil

Mail should be addressed to:

NAVAIR Orlando
12350 Research Parkway
Orlando, Florida 32862-3275
ATTN: AIM SSO

The goals and objectives of the SSO are to:

- Be the Navy expert on AIM application software.
- Support the use of AIM by all authorized government and commercial users of AIM.
- Operate the SSO
  - Assist the AIM Program Manager in developing, maintaining, and executing the Milestone IV System Decision Paper, including considerations of the impact of new technology
  - Document and maintain the hardware, software, and documentation baseline configurations for AIM
  - Develop, operate, and maintain a Trouble Report/Engineering Change Proposal (TR/ECP) tracking and status system
  - Provide configuration status accounting
  - Establish and operate the AIM Help Desk
  - Respond to trouble calls
  - Coordinate problem reports and other input from end users
  - Respond to user requests for improvements and/or enhancements to AIM
Research inputs from users and make recommendations to the AIM Project Manager.

Support the AIM Program Manager in presenting change proposals and other information to the Configuration Review Board.

Incorporate approved changes to AIM application software, hardware, and/or documentation as approved by the Configuration Control Board and tasked by the AIM Program Manager.

Conduct tests and assessments to validate that the changes meet the requirements and ensure that the changes are incorporated with a minimal impact on users.

Prepare and distribute updated AIM application software and documentation.

Assist new user sites by helping to identify hardware/software requirements, providing hardware/software procurement support, and providing system setup/testing assistance.

Provide hardware maintenance and commercial off the shelf software license and maintenance support for all NAVEDTRACOM and other AIM sites, as directed and funded by the resource sponsors.

Provide AIM training, as required and tasked by the AIM Program Manager, using the NETC-approved curriculum.

Serve as technical liaison with other Navy programs and with other services on AIM-related issues at the direction of the Program Manager.
CHAPTER 1

INTRODUCTION TO AIM I

1.0 Introduction to AIM I
1.1 Prerequisites
1.2 Hardware and Software Requirements
1.3 Referenced Documents
1.4 Formal Classroom Training Materials Development Process
   1.4.1 Personnel Performance Profile Methodology
      1.4.1.1 The Planning Phase
      1.4.1.2 Stage One Development
         1.4.1.2.1 Personnel Performance Profile (PPP) Development
         1.4.1.2.2 Training Path System (TPS) Development
         1.4.1.2.3 Course Training Requirements Selection in the COI
      1.4.1.3 Stage Two Development
   1.4.2 Automating Training Materials Maintenance in AIM I
   1.4.3 Automating Training Materials Administration in AIM I
1.5 AIM I Privileges
1.6 Using the Manual
1.7 Using the Help system
   1.7.1 On-Line help
      1.7.1.1 Contents
      1.7.1.2 Index
      1.7.1.3 Find
   1.7.2 User’s Manual
   1.7.3 Changes in Release 5.1
   1.7.4 Frequently Asked Questions
   1.7.5 Documentation
   1.7.6 Demonstrations
1.8 Summary
1.0 Introduction to AIM I

Authoring Instructional Materials (AIM I) software provides two methods for developing training material. The first method provides all the training material elements for developing formal classroom materials in accordance with Personnel Performance Profile (PPP) Based methodology. The second method provides material elements for developing Integrated Learning Environment (ILE) training materials for Instructor-Led and Self-Paced presentation.

The PPP Based AIM software is an application software for developing and maintaining PPP-based curriculum products that adhere to the curriculum development standards set forth in the Naval Education and Training Command Personnel Performance Profile Based Curriculum Development Manual (NAVEDTRA 131B).

The system is designed to operate in the MS Windows environment on either a stand-alone personal computer or a local area network.

AIM I partially automates the development and maintenance of the following training material products when developing a PPP Based curriculum for the formal classroom:

• Training Project Plan (TPP)
• Personnel Performance Profile (PPP)
• Training Path System (TPS)
• Test Materials
• Training Course Control Document (TCCD)
  o Curriculum Outline of Instruction (COI)
  o Course Master Schedule (CMS)
  o Resource Requirements List (RRL)
  o Profile Item-to-Topic Objective Assignment Chart (OAC)
  o Fault Applicability List (FAL)
• Lesson Plan (LP)
• Trainee Guide (TG)

AIM I partially automates the development and maintenance of the following training material products when developing ILE Based training materials for Instructor-Led and Self-Paced training from the Learning Object module:

• Course
• Modules
• Lessons
• Sections

The Learning Object module has been designed to allow the authoring of new training material, import training material developed in the Content Planning Module (CPM) from a link to the Enterprise Data Environment (EDE), and re-develop training material that already exists in AIM for the ILE environment.
Visual Basic Professional Edition was chosen as the developer’s tool because it offers efficient and rapid design and modification of the programming logic as well as user interface, thus affording potential savings in software life-cycle expenses. The foundation of AIM I is the MS Access Relational Database Management System (RDBMS) engine; however, the program is flexible enough to accommodate virtually any RDBMS.

There are a multitude of benefits to be realized during development of software with the AIM I tool set; most importantly:

- The inherent What-You-See-Is-What-You-Get (WYSIWYG) Graphical User Interface (GUI) allows for on-screen display of all reports and products, including integrated text and graphics, in their final form, thereby reducing print time requirements.
- Features have the familiar look and feel consistent in all MS Windows applications (Point and Click, Cut/Copy/Paste).
- Interface with other MS Windows application software (e.g., PowerPoint, Excel, Word for MS Windows, WordPerfect for MS Windows, any RDBMS) maximizes the ability to tailor existing data for applications other than formal training materials development.
- Built-in hypertext-based Help and references, coupled with the intrinsic friendliness of the environment, reduce the requirements for expensive instructor-led training.

1.1 Prerequisites

This User's Manual was written for training commands, training experts, subject matter experts, and contractors, who develop, maintain, administer, and manage training materials. More specifically, it was written for persons who are well versed in Instructional Systems Design (ISD) and:

- Have acquired equivalent experience in PPP or ILE-based training material development.
- Have experience in operating a computer in an MS Windows environment.

1.2 Hardware and Software Requirements

The minimum hardware requirement for a computer running AIM I is a 700MHz Pentium processor and 128MB RAM, with Windows XP (with Service pack 2) or Windows NT 4 (with Service Pack 6). The recommended hardware is a Pentium 4 or better processor, with 256 MB RAM, running Windows NT 4, Windows 2000 or Windows XP.

The hard drive requirement for installing AIM depends on how you are installing AIM. A full install requires approx. 400MB for the software. A Minimal Install requires at least 300MB.
We recommend that the database and all its associated files and sub-directories be stored together in one place (the Database folder). The Database folder can be separate from the AIM folder, whether in another directory, on another drive, or on a network server. 500MB is a good starting point as a minimum space required for the database directory. If you are planning on keeping many courses or extensively using IMM or Graphics features of AIM you should start out with 2GB which will give you room to grow.

The Graphics and Media sub-directories can be put onto separate drives if there is a lack of space on any particular drive.

1.3 Referenced Documents

The following documents are applicable to this User's Manual:
- Navy ILE Learning Objective Statements Specifications and Guidance MPT&ECIOSWIT-ILE-SPEC-1B, 15 September, 2007
- Navy ILE Content Developer’s Handbook MPT&ECIOSWIT-ILE-HDBK-1C, 01 May 2009

1.4 Formal Classroom Training Material Development Process

A complete understanding of Training Management Material development is essential for the development of curricula. The following paragraphs have been created to act as a review of the process and to help the developer understand the construction and the terminology involved.

1.4.1 PPP Methodology

The PPP approach to curriculum development is broken down into a Planning phase, five Stages of development, and an Evaluation phase. AIM I provides the tools necessary to develop the training materials that are divided into two basic categories; management materials and curriculum materials.
• **Planning** identifies resources requirement and sequence of events in the development process. The product is the *Training Project Plan* (TPP). The TPP is submitted to the Curriculum Control Authority (CCA) for review and approval. When approved, the TPP becomes the authorization to undertake the course development project and initiate resource procurement.

• **Stage One** consists of determining job tasks, supporting skills and knowledge, and level of performance. The products are the *Personnel Performance Profile* (PPP) *Table* and the *Training Path System* (TPS). The PPP Tables and the TPS are submitted to the CCA for review and approval. Approval of the PPP Tables and TPS provides authorization to develop the Training Course Control Document and all of its Annexes.

• **Stage Two** determines the skills and knowledge that must be taught and produces the course learning objectives and an instructional sequence. The product is the *Training Course Control Document* (TCCD). The preliminary TCCD is submitted to the CCA for approval. Preliminary approval of the TCCD provides authorization to develop the Curriculum materials (Lesson Plan and Trainee Guide).

• **Stage Three** produces the instructional materials for the instructor and the trainee. The products are the *Lesson Plan* (LP) and the *Trainee Guide* (TG). The developing agency will submit a Ready for Pilot letter to the CCA when Stage Three is completed. The CCA can request an instructional materials cross section for review.

• **Stage Four** begins when the Curriculum Control Authority (CCA) has approved the Stage Three materials for pilot and ends with the submittal of the *Pilot Course Monitoring Report*.

• **Stage Five** begins after the incorporation of the results of the pilot course (“red-line”) into smooth management materials and curriculum, and ends with the Curriculum Control Authority’s Letter of Promulgation that approves the material for use in support of training. The product is approved management materials (PPP Tables, TPS, and TCCD) and approved Curriculum (LP and TG) which is authorized for distribution.

• **Evaluation** is the surveillance, evaluation, change and revision of the training materials and the performance of the graduates.

### 1.4.1.1 The Planning Phase

During the Planning phase the developer will create the Training Project Plan (TPP).

There are three types of Training Project Plans:

1. A **NEW TPP** that is used to define the resources required for the development of a new course or defines the resources required to teach a course never taught at the training facility,
2. A **Revision TPP** that is used to define the additional resources required to revise an existing course, and
3. A **Cancellation TPP** that is used to identify the disposition of resources that support the course being cancelled.
The TPP will identify:
- Who will develop and approve the course
- The mission of the course
- Prerequisite knowledge and skills to attend the course
- Where the training will be conducted
- Resource requirements to support the course, including manpower, funding and facility data
- Course Data that includes how long the course will be, the minimum and maximum class capacities, how many times it will be taught in a year, and how many students are expected to attend in a year
- Justification for the course
- The training materials that will be developed in support of the course
- Milestones for planning that identifies when the training material products will be developed and when events will occur
- An overview of the course and comments

1.4.1.2 Stage One Development

During Stage One the developer will create the Personnel Performance Profile (PPP) Table(s) and the Training Path System (TPS).

1.4.1.2.1 Personnel Performance Profile (PPP) Table Development

PPP Tables can be broken down into two groups, hardware and non-hardware. The hardware tables consist of three types; Equipment, Subsystem, and System (E/S/S) tables. The non-hardware tables consist of two types; Task or Function (T/F) tables and Background (B/G) information tables.

Developing a PPP table starts by performing a task analysis to determine all the skills and knowledge areas that must be covered to; perform operation and maintenance of an Equipment, Subsystem, or System; perform a task or function; or receive background information required for further training.

AIM I contains an algorithm of questions for the development of ESS Tables. The Subject Matter Expert (SME) responds to the questions using yes/no responses and supplies breakdown information, usually available from technical manuals, to provide information to the database for the software to construct an ESS PPP Table. The construction of the table is performed automatically as a result of saving the responses to all the questions in the algorithm.

All Equipment, Subsystem, and System PPP tables are constructed the same way and contain the same categories. The categories of an ESS table look familiar to the technician because they follow the same format as technical manuals.
All tables are split into two areas: Knowledge and Skill. The Knowledge categories and line items are preceded by the number “1” and Skill categories are and line items are preceded by the number “2”.

The categories for an ESS table are:

<table>
<thead>
<tr>
<th>Knowledge</th>
<th>Skill</th>
</tr>
</thead>
<tbody>
<tr>
<td>1-1 General</td>
<td>2-1 Operation</td>
</tr>
<tr>
<td>1-2 Physical</td>
<td>2-2 Maintenance</td>
</tr>
<tr>
<td>1-3 Functional</td>
<td></td>
</tr>
<tr>
<td>1-4 Interface</td>
<td></td>
</tr>
<tr>
<td>1-5 Operation</td>
<td></td>
</tr>
<tr>
<td>1-6 Maintenance</td>
<td></td>
</tr>
<tr>
<td>1-7 Documentation</td>
<td></td>
</tr>
</tbody>
</table>

It is important to remember the categories for development of other training material. AIM uses the categories to develop Topic titles and the line items under each category to develop Topic Learning Objectives. The PPP table and the proper title will become a Part number and Part title in the Curriculum Outline of Instruction (COI) and in the LP/TG.

In the development of all PPP tables the Skill line items must be linked to at least one directly supporting knowledge line item. The “2-1. Operation” category skills are linked to the “1-5. Operation” category knowledge line items. The “2-2 Maintenance” skills are linked to the “1-6 Maintenance” knowledge line items. When AIM initially creates an ESS table all skills are linked to their directly supporting knowledge line items. However, if additional skills are added later, they must be linked manually.

Task/Function (T/F) PPP tables have categories and are divided into Knowledge and Skill areas like the ESS tables. The category names and the number of categories are dependent on the subject matter. There is no algorithm in AIM for a T/F table and the task analysis for the task or function must be completed before data is entered into the AIM database.

Development of a T/F PPP table always starts with the Skills. After the Skills are developed there is a Copy Skills option that will copy the Skill categories and line items into the Knowledge area. Simple editing of the verbs in the knowledge area will produce accurate knowledge line items. The copied line items are the Knowledge line items that are linked to and provide direct support for the Skill line items. Additional Knowledge categories and line items can be added to the T/F table as required.

Background PPP tables are created when the task analysis of who is to be trained and on what has identified background information necessary to understand the subject matter. For example: Basic Physics, Math, etc. The construction of the Background table is simple because there are no categories. There are only Knowledge and Skill line items. As with the T/F table development, the skill line items are developed first and when complete the developer will exercise the Copy Skills option to create the directly supporting Knowledge line items. Indirectly supporting knowledge line items can be added after the Copy Skills option has been exercised.
Once a PPP table has been developed in AIM it can have one of the following Status indicators:

- Locked (L)
- Complete (C)
- Incomplete (I)
- Approved (A)
- Suspended (S)

Unlocked PPPs are under development. A locked PPP has been fully developed but has not yet been approved. A locked PPP appears in the TPS module for your selection to create TLAs. A locked PPP can be unlocked and modified at any time prior to its approval.

A complete PPP is a PPP in which every Skill line item is linked to at least one Knowledge line item. In the case of Equipment/Subsystem/System (ESS) PPPs, AIM I automatically links Skill line items to their corresponding Knowledge line items. However, if you add Skill line items after you save your answers to the questions, you will have to link the line items manually. The status level of Incomplete will appear on your computer screen if you have not linked each Skill line item with at least one Knowledge line item.

If you do not complete the question-and-answer portion when you create an ESS PPP, but you want to save the work that you have completed, you have the option of suspending development of the PPP. The Suspend status will change to Complete when you finish answering the required questions.

An Approved PPP is one that is approved for use and cannot be modified unless a change or revision is created.

### 1.4.1.2.2 Training Path System (TPS) Development

A TPS is a management tool that allows you to identify who will be trained, what they will be trained to do, the depth of training they will receive, and where they will receive the training. The TPS can be complex, detailing all training required for an entire career field, or simple, detailing all training required for a single course. In other words, the TPS can be tailored to suite the developer’s needs.

**The TPS Introduction:**

The TPS contains an Introduction area that explains all the parts of the TPS and definitions of all the Task Sets and their related Training Objective Statements (TOS). The Introduction can be edited to define the content of the TPS being developed.

Task Sets define who is going to complete the tasks and their related TOS will define the depth of coverage the training will support. There are three Task Sets to identify the personnel involved in the completion of a task:
1. The **Coordinate** Task Set defines those personnel who will coordinate all operation and maintenance of an Equipment/Subsystem/System or a Task or Function.

2. The **Direct** Task Set defines those personnel who will direct the operation and maintenance of an Equipment/Subsystem/System or a Task or Function.

3. The **Perform** Task Set defines those personnel who will perform the operation and maintenance of an Equipment/Subsystem/System or a Task or Function.

Each Task Set has Training Objective Statements (TOS) that define the type of training received and depth of coverage for individual line items of a Personnel Performance Profile table.

**COORDINATE TASK SET TOS are:**

Background TOS for the Coordinate Task Set includes:

**S** **Background Skill:** Completion of training provides the prerequisite (Background), Physical or Mental skills necessary to support follow-on training in Coordinating operation or maintenance of a system, subsystem, or equipment, a task/function, or further background training

**B1** **Background Knowledge:** Completion of the training provides the knowledge required to support follow-on training in Coordinating the operation or maintenance of a system, subsystem, or equipment, a task/function, or further background training

**B2** **Background Comprehension:** Completion of the training provides the comprehension required to support follow-on training in Coordinating the operation or maintenance of a system, subsystem, or equipment, a task/function, or further background training

Task/Function (T/F) TOS for the Coordinate Task Set includes:

**J** **Task/Function Skill:** Completion of training provides the Physical and/or Mental skills required to Coordinate the task or function

**Q** **Task/Function Knowledge:** Completion of the training provides the knowledge required to Coordinate the task or function

Equipment, Subsystem, and System (ESS) TOS for the Coordinate Task Set includes:

**F1** **Knowledge:** Completion of training provides familiarity with the:

a. Purpose, operational concepts, location, capabilities, and limitations of an equipment/subsystem/system

b. Organization, content, and use of the technical documentation provided for use with the equipment/subsystem/system

**O1** **Skill:** Completion of training provides the ability to coordinate operation and maintenance

**T1** **Knowledge:**

a. Completion of training provides the knowledge to coordinate operation and maintenance

b. Organization, content, and use of the technical documentation provided for use with the equipment/subsystem/system
DIRECT TASK SET TOS are:

Background TOS for the Direct Task Set includes:

**S Background Skill:** Completion of training provides the PREREQUISITE (Background), PHYSICAL or MENTAL Skills necessary to support follow-on training in DIRECTING the operation or maintenance of a system, subsystem, or equipment, a task/function, or further background training

**B1 Background Knowledge:** Completion of training provides the knowledge required to support follow-on training in DIRECTING the operation or maintenance of a system, subsystem, or equipment, a task/function, or further background training

**B2 Background Comprehension:** Completion of training provides the comprehension required to support follow-on training in DIRECTING the operation or maintenance of a system, subsystem, or equipment, a task/function, or further background training

Task/Function (T/F) TOS for the Direct Task Set includes:

**J Task/Function Skill:** Completion of training provides the PHYSICAL AND/OR MENTAL Skills required for DIRECTING the job or task/function

**Q Task/Function Knowledge:** Completion of training provides the knowledge required for DIRECTING the job or task/function

Equipment, Subsystem, and System (ESS) TOS for the Direct Task Set Includes:

**F1 Knowledge:** Completion of training provides familiarity with the:
   a. Purpose, operational concepts, location, capabilities and limitations of a system/subsystem/equipment
   b. Organization, content, and use of the technical documentation provided for use with the system/subsystem/equipment

**O1 Normal Operation Skill:** Completion of training provides the ability to direct normal operations

**O2 Abnormal and Casualty Operation Skill:** Completion of training provides the ability to direct:
   a. Normal operations requiring advanced analysis
   b. Abnormal operations (defined as casualty/degraded/not full mission capable)

**M1 Maintenance Skill:** Completion of training provides the ability to direct maintenance

**T1 Knowledge:** Completion of training provides:
   a. the knowledge to direct normal operations
   b. Organization, content, and use of the technical documentation provided for use with the system/subsystem/equipment

**T2 Knowledge:** Completion of training provides the knowledge to direct:
   a. Normal operations requiring advanced analysis
   b. Abnormal operations (defined as casualty/degraded/not full mission capable)
   c. Maintenance
PERFORM TASK SET TOS are:

Background TOS for the Perform Task Set Category - Includes:

- **S Background Skill**: Completion of training provides the PREREQUISITE (Background), PHYSICAL or MENTAL Skills necessary to support follow-on training in PERFORMING the operation or maintenance of a system, subsystem, or equipment, a task/function, or further background training.

- **B1 Background Knowledge**: Completion of training provides the knowledge required to support follow-on training in PERFORMING the operation or maintenance of a system, subsystem, or equipment, a task/function, or further background training.

- **B2 Background Comprehension**: Completion of training provides the comprehension required for supporting follow-on training in PERFORMING the operation or maintenance of a system, subsystem, or equipment, a task/function, or further background training.

Task/Function (T/F) TOS for the Perform Task Set:

- **J Task/Function Skill**: Completion of training provides the PHYSICAL AND/OR MENTAL Skills required to PERFORM the job or function.

- **Q Task/Function Knowledge**: Completion of training provides the knowledge required for supporting the performance of the skills required in PERFORMING the job or task/function.

Equipment, Subsystem, and System (ESS) TOS for the Perform Task Set Includes:

- **F1 Knowledge**: Completion of training provides familiarity with the:
  a. Purpose, operational concepts, location, capabilities and limitations of a system/subsystem/equipment
  b. Organization, content, and use of the technical documentation provided for use with the system/subsystem/equipment

- **O1 Skill**: Completion of training provides the skill to perform normal operations

- **O2 Skill**: Completion of training provides the skill to perform:
  a. Normal operations requiring advanced analysis
  b. Abnormal operations (defined as casualty/degraded/not full mission capable)

- **P1 Skill**: Completion of training provides the skill to perform preventive maintenance

- **C1 Maintenance Skill**: Completion of training provides the skill to perform basic corrective maintenance, to the authorized maintenance level, using systematic fault isolation procedures

- **C2 Maintenance Skill**: Completion of training provides the skill to perform to the authorized maintenance level:
  a. Systematic fault isolation procedures that require advanced analysis
  b. Authorized techniques to isolate faults that cannot be isolated using procedures contained in prescribed documentation
C3  **Maintenance Skill:** Completion of training provides the skill and knowledge to perform diagnosis of equipment malfunctions, fault isolation, and all repairs without supervision. This level of skill cannot be trained in the formal school setting. This skill is acquired only through on-the-job experience, and reflects a continuous learning process that is supported by the skills and knowledge taught in the formal school environment. The Applicability Code "1" will always be used to show this skill is acquired via "operational experience," i.e., shipboard performance.

T1  **Knowledge:**
   a. Completion of training provides the knowledge to perform normal operations
   b. Organization, content, and use of the technical documentation provided for use with the system/subsystem/equipment

T2  **Knowledge:** Completion of training provides the knowledge to perform:
   a. Normal operations requiring advanced analysis
   b. Abnormal operations (defined as casualty/degraded/not full mission capable)
   c. Preventive maintenance
   d. Basic corrective maintenance

T3  **Knowledge:** Completion of training provides the knowledge to perform advanced corrective maintenance

The Training Path Chart (TPC)

A TPS can contain one or more Training Path Charts (TPCs). A TPS can be used to identify the training path for many career paths, a single career path, or a specific job. If it were to be used to identify the training required for multiple career paths there would be a TPC for each career. A TPC defines:

- Who will be trained,
- What Task Set will be applied,
- The ESS, T/F and BG PPP tables used to train them
- What level of training they will receive, and
- Where the training will take place.

The TPC is given a designator and title, to identify the personnel performing the job and a single Task Set is selected. The developer will then begin development of Training Level Assignments (TLAs) for the TPC by selecting the PPP tables that will be used to train them. Once a PPP table is selected the software applies the TOS of the Task Set selected for the TPC. All line items of the PPP table are placed in a grid so the developer can identify where the line item will be taught and to what depth of coverage.
The example above is a TLA that the software presented to the developer after the developer selected an Equipment PPP table for a TPC that has the Perform Task Set selected. The task of the developer is to identify where each line item will be taught and to what level by using Applicability Codes and entering them at the TOS level desired for each line item.

Applicability Codes characters R, A, B, 0, 1, 2, 3, 4, or 5 identify where the training will be conducted. The characters are defined as follows:

- **R** Replacement/Conversion/Intermediate Level Maintenance (ILM) Training Courses
- **A** Advanced Training Course
- **B** Both Replacement and Advanced Training Course
- **0** Training hardware does not exist at the appropriate facility and operational constraints precluded onboard training.
- **1** Operational experience is the only means to accomplish the specified training level.
- **2** Training hardware does not exist to accomplish training at the appropriate facility and onboard training is permitted.
- **3** Training hardware exists to accomplish training at a facility; onboard training is permitted; and training is accomplished onboard.
- **4** Training is received by the individual outside of the cognizant Training Program.
- **5** Background training is received by the individual as a part of the Navy Training Program.

Figure 1-1. Equipment PPP TLA for Perform Task Set
When developing a TLA the Applicability Codes are first added to the Skill “2” line items. When the PPP table was developed, each skill line item was linked to its directly supporting knowledge line item. Thus, when an Applicability Code is added to a TLA for a skill line item, AIM automatically adds the appropriate Applicability Code for the linked knowledge line item at the required TOS.

After developing TLAs for each PPP table that will be used for the training of the personnel identified in the TPC, the developer needs to identify the Courses that the individuals will attend to receive this training. A designator, title, revision/change maintenance level, and the type identify the Courses (Background, Replacement, Advanced, or Conversion).

When the Course is selected for a TPC and all TLAs are developed in the TPC that will be used in the Course, the developer can develop the Training Course Control Document (TCCD) Curriculum Outline of Instruction (COI).

The Applicability Codes identified in the TLAs developed for the TPC will be used when selecting the training requirements for each Course identified in the Course List for the TPC.

The output products of the TPS include:
- TPS Cover Page
- TPS Introduction
  For each TPC in the TPS:
  - TPC Cover Page
  - *Table Assignment Chart
  - *Curricula Index
  - PPP Table Index
  - Table Assignment Matrix
  - TLA for each PPP table selected

* The Table Assignment Chart and the Curriculum Index for each TPC cannot be completed until the training requirements have been selected for each course identified in the TPCs Course List.

In order to select training requirements for a course the following actions must be completed:
- The Course must be selected in a TPC Course list,
- The associated Training Project Plan (TPP) must have been locked at least once, and
- The associated Training Course Control Document must be unlocked.

### 1.4.1.2.3 Course Training Requirements Selection in the Curriculum Outline of Instruction (COI)

The last step that is required to complete Stage 1 of development is to select the training requirements for the courses identified in the TPS. This will provide the links in the database between the training requirements selected in the course, the TLAs in the originating TPC, and the TPC Course List.
When the Course is selected and the COI is selected the developer can begin by selecting the Contents menu item and the Training Requirements sub-menu item. AIM will present a list of all the TLAs that were developed in the originating TPC. The developer will select the TLAs that are applicable to the course and select the desired Applicability Codes as Training Requirements for the Course. The Applicability Codes displayed by the software for Training Requirement selection are dependent on the type of course:

- For a Background Course the TLAs will only reveal the number 5 for selection.
- For a Replacement Course the TLAs will only reveal the letters R and B for selection.
- For an Advanced Course the TLAs will only reveal the letters A and B for selection.
- For a Conversion Course the TLAs will only reveal the letters A, R, and B for selection.

When the Training Requirements have been selected from a TLA, and the information is saved to the database, AIM will create the following:

- A Part for each TLA, which is identified by the PPP table number and title from which the TLA was created,
- Sections for each TOS selected in the TLA,
- Topics for each Section identified by the category in the PPP table that contains the line items at the TOS selected,
- A Topic Learning Objective (TLO) for each line item selected with the behavior (identified in the PPP table line item) and the condition (identified by the TOS). The standard is assumed to be 100% unless otherwise stated and the TLO is editable.

This completes the analysis of Stage One development. The PPPs and TPS are deliverables. When the Curriculum Control Authority (CCA) approves these training management materials that is authorization to commence Stage 2 and design the Course.

1.4.1.3 Stage Two Development

During Stage Two the developer will complete the Training Course Control Document (TCCD) and its annexes. The TCCD contains the following data:

- *Learning Site Data,
  - Identification of Course Curriculum Model Manager (CCMM)
  - Course Data
  - Learning Site Resource Requirements List (RRL),
- Instructor/Support Manning requirements
- Trainee Data
- *Course Overview/Comments
- Curriculum Outline of Instruction (COI)
- Course Master Schedule (CMS)
- Profile Item-to-Topic Objective Assignment Chart (OAC)
- **Fault Applicability List (FAL)

* Indicated items were originally developed in the Training Project Plan (TPP) and copied to the TCCD when the TPP was initially locked.
** The Fault Applicability List is actually developed in the Lesson Plan (LP) but is an Annex of the TCCD

At the completion of Stage One the COI had been created by the software and can now be accessed so the developer can arrange the Parts, Sections, Topics and Topic Learning Objectives (TLOs) in the order that they will be taught for the Pilot. The software provides the functionality for joining, unjoining, splitting, and resequencing Parts, Sections, Topics and TLOs. Titles, CLOs and TLOs can be edited to reflect the course content. Both CLOs and TLOs contain “boilerplate” statements from the database that reflect the TOS statements. Generally, editing requires deleting phrases that do not apply to the course being developed.

The RRL data copied to the TCCD from the TPP needs to be modified to indicate the quantities of material required for the Instructor, Trainee and Class. AIM Automatically defaults the quantities to “1” per category.

The Trainee Data is added to identify any physical requirements, security clearance requirements, and contractual obligations that may be required of the trainee prior to attending the course. It also lists job codes that could result from completion of the training.

In the TCCD front matter space is provided to add a Foreword if desired.

The Course Master Schedule (CMS) initially indicates one period for each Topic identified in the COI. All periods are initially identified as Class Periods. The developer is required to:
- Identify which periods are Lab periods,
- Enter the week and day each Topic will be taught,
- Add Bottleneck information to identify if there are any conflicts in the Labs with equipment or require additional instructors for Special and Lab periods,
- Duplicate each period as many times as required to indicate how long each Topic will require instruction (one period = 50 minutes of instruction and 10 minutes of break time),
- Create Special Periods where required to indicate time spent that is not actual instruction time, but required for class completion.

If this course is not going to train the student about preventive or corrective maintenance or how to recognize and/or repair equipment using faults inserted into the equipment, a Fault Applicability List (FAL) is not required and this completes Stage Two development.

If a FAL is required, the TCCD can be locked and the developer can create and select the Lesson Plan for the course. From the LP Contents menu item the developer can select the FAL sub-menu item. For each fault required the developer will:
- Identify the Part and Section of the LP that the fault will be exercised,
- Enter the fault name,
- Enter a description of the fault,
- Identify the equipment the fault will be inserted into,
- Identify the documentation that will direct the instructor for its insertion,
- Identify the TOS level that the fault will exercise,
• Identify whether the fault is a required fault and will be cited in a Related Instructor Activity (RIA) in the LP,
• Identify the fault type – Pre-faulted Module (PFM), Fault Insertion Device (FID), or Controlled Fault, and
• Identify the equipment required if the fault is a PFM or FID.

Additional faults, faults that will not be cited in the RIAs of the LP, can be added to the FAL and can be used if time and personnel support exist. The FAL will print out as an Annex of the TCCD. When printed, the required faults are indicated with an asterisk (*).

**This completes Stage Two development, the design phase, and the development of training management material.**

The LP creates all the other elements of the curriculum, including; Allocation of Instructional Time (AOIT), Discussion Point (DP) place markers which contain TLO text to initiate the outline; Related Instructor Activity (RIA) fields for each DP, and all the front matter required by the Military Standards. Together, the COI and the LP make up the actual programmed instruction that is printed, packaged, and used in platform teaching settings.

The RRL is a comprehensive list of all resources (publications, equipment, etc.) that are required to support a course. The RRL, which AIM I automatically develops and maintains, is based on selections made during development of the course. Each specific RRL item is linked to an RIA.

**NOTE:** A Discussion Point (DP) is a teaching point identified to support a specific TLO.

Before AIM I, a major task of curriculum developer/maintainers was to ensure that the RRL reflected all materials required for the curriculum. The challenge was to ensure that:

• The RRL contained all items that were required
• The RRL did not contain items that were not required

Validation of the RRL is no longer a concern for the developer/maintainer because AIM I has total control over the RRL. When a required item is called out in a RIA, AIM I automatically adds the item to the RRL. Likewise, when an item is removed from the curriculum, AIM I updates the RRL to reflect the removal of the item. The developer/maintainer can then focus on which items to use in the curriculum and where to use them.

The AIM I main menu LP option/icon uses the TLOs from the COI in the form of an outline, with the objectives separated into Parts, Sections, and Topics.

• A Part is developed for each PPP Table.
• A Section is developed for each TOS level of the TLA.
• A Topic is developed for each category of the PPP selected for the TOS of the Section.
The TLOs are the learning objectives developed from the PPP line items selected at the specified TOS in the TPS and turned into training requirements in the COI. One DP to support each of the TLOs are automatically generated, which contain partial text of the TLO and provides a place marker to begin outlining the TLO and starts the formation of the Discussion Demonstration Activity (DDA) pages. As necessary, RIAs are added to a DP to direct instructor actions during the instruction of the curriculum. As the LP is being developed, supporting training materials can be created and added to the RRL for the entire site.

The initial structure of the TG is actually created from the LP RIAs. The developer can initiate the process by selecting TG Sheets as the RRL Type in the RIA column and create the following types of instruction sheets: Information, Diagram, Job, Assignment, Outline, and Problem Sheets.

Their content is further developed through the TG module. Each of the sheets is currently developed by one of two methods:
- By entering data manually
- By copying it from another source, such as MS Word (using the standard MS Windows copy and paste functions).

AIM I provides the user with a menu-driven interface that requires much less expertise in the detailed requirements of the training system than manual methods. The RDBMS on which AIM I is built greatly reduces the laborious manual cross-referencing of many elements of both training requirements and training material documents. Overall, AIM I makes the development and maintenance of materials much more efficient and effective.

AIM I's ability to capture the relationship between the training statements in the PPP table and the TLOs provides an audit trail from initial analysis to evaluation of the effectiveness of the training. Knowledge and Skills identified in the PPP table required to perform a job have a link to the TPS and its TPC TLAs. The line items selected from the TLAs in the COI as training requirements for the course are linked to the Part, Section, Topic, TLOs, and ultimately to the test items. AIM I serves as a means of tracking interrelationships of PPP line items, objectives, test items, reference materials, and resources, as shown below.

PPP -> TPS -> TCCD COI/Test Items/RRL (Reference Material) -> LP (DDA) -> TG

Reference material is linked to the TCCD, the RIAs, and the TG instruction sheets. It can therefore be determined where particular references are used in the training. This provides a more efficient process for revising training materials when technical references are updated.

AIM I allows the developer to concentrate on the contents of the material, vice the format.
1.4.2 Automating Training Materials Maintenance in AIM I

The software's greatest strength lies in the automation of the life-cycle maintenance process: creating changes and revisions for training management materials (PPP, TPS, and TCCD) and curriculum materials (LP and TG) developed in or converted to the AIM I format.

Maintenance of a curriculum product is an integral part of the surveillance process. Maintenance actions are required to keep the training current; e.g., to ensure that they reflect changes to equipment, manning, and mandates by higher authority. Any modifications to an approved curriculum require the development of a change or revision. The basic design concept for AIM I maintenance is to assist the user in developing a maintenance product by copying the approved material and allowing the user to modify the new material.

Training materials modification is the result of surveillance and involves actual alterations to approved training materials. Alterations range from changes, such as the correction of clerical errors and insertion of titles; to revisions in course length, changes to the Course Mission Statement, or a shift from one instructional strategy to another.

AIM I does not distinguish between Interim and Technical Changes.

In PPP-based curricula, the user has two options for maintenance:
- To develop a change
- To develop a revision

The development of a change or revision to a curriculum product is streamlined by the fact that AIM I uses a relational database that provides embedded links among various training materials to narrow the focus of the developer to items specifically affected by the change or revision. Because of those links, AIM I can flag the training material that is affected by the maintenance action, thus saving the developer significant time in surveillance of training materials.

In accordance with NAVEDTRA 131B, a new TPP is required to support a new course, revision, or cancellation. Since AIM I treats the TPP as the foundation of the curriculum development process, the user must initiate all modifications to approved curricula from the TPP module for new development, revisions to an approved curriculum, or cancellation of an approved curriculum.

AIM I maintenance functions can be used to develop Changes and Revisions for all approved training material, with the exception of Training Project Plans (TPPs) and RRL items. AIM I automatically increments the alpha character for the Revision field and the numerical character for the Change field. The user can edit neither field. When a change or a revision is being developed, AIM I copies the approved version to make the revision or change. The approved version cannot be modified in any way and continues to reside within the database until a later version is approved and the AIM Administrator archives the previously approved version.
1.4.3 Automating Training Materials Administration in AIM I

The AIM Administrator has two primary administrative responsibilities:
- To control the access of users to the AIM I database
- To maintain the data with the following utility functions:
  - Change Password
  - Site RRL
  - Graphics
  - Admin Utility
  - Delete Proposed TM
  - Reporting
  - RRL/Graphics Location Tool
  - Learning Site
  - Agency
  - Archive/Unarchive
  - Import/Export
  - User
  - Relink PPP/TPS
  - Data Manager

During the development or maintenance of training material, the user can select many items in the AIM I database. Those items are presented from a menu of items. If an item is not on a list, the AIM Administrator can add it to the database.

1.5 AIM I Privileges

AIM I uses two kinds of privileges to provide access to the AIM I database:
- AIM User
- AIM Administrator
- In AIM User can view all the training materials and can be assigned privilege to perform specific functions on training material by the AIM Administrator. An AIM User can create training material and has the following default privileges for materials created under their login and password unless modified by an AIM Administrator:
  - Edit
  - Add Notes
  - Lock
  - Grant
  - Clear In Use
  - Maintain/Delete

A person with AIM Administrator privileges has access to all training materials and Utility functions of AIM I.
<table>
<thead>
<tr>
<th>Level</th>
<th>Allows a User to . . .</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>View Test Items and Tests in the Testing Module.</td>
<td>This privilege only exists for the Testing module. A user without view privilege cannot access the Testing Module.</td>
</tr>
<tr>
<td>Edit</td>
<td>Edit a given training material item.</td>
<td>Edit privilege is a default privilege assigned by the software to an AIM User who creates a training material item. A user with Grant privilege can give another user Edit privilege. Note: Users with Edit privilege are granted Add Notes privilege by default. Edit can also be granted to an AIM User to develop Test Items for an approved PPP table.</td>
</tr>
<tr>
<td>Add Notes</td>
<td>Add Public and Private Notes to a training material item.</td>
<td>Add Notes privilege is a default privilege assigned by the software to an AIM User who creates a training material item. A user with Grant privilege can give another user Add Notes privilege.</td>
</tr>
<tr>
<td>Lock</td>
<td>Lock or unlock a given training material item.</td>
<td>Lock privilege is a default privilege assigned by the software to an AIM User who creates a training material item. A user with Grant privilege can give another user Lock privilege</td>
</tr>
<tr>
<td>Grant</td>
<td>Grant or change privilege levels of other users for a given training material item.</td>
<td>Grant privilege is a default privilege assigned by the software to an AIM User who creates a training material item. A user who has Grant privilege for a given training material item can grant other AIM Users the privilege to Edit, Lock, Grant, and Add Notes.</td>
</tr>
<tr>
<td>Approve</td>
<td>Approve a given training material item.</td>
<td>Approve privilege assigned to an AIM User by an AIM Administrator. For the Testing Module the privilege is called Approve/Unapprove.</td>
</tr>
<tr>
<td>Remove Flag</td>
<td>Remove System (@) and Maintenance (X) Flags.</td>
<td>Remove Flag privilege assigned to an AIM User by an AIM Administrator. Note: Users with Remove flag privilege are granted Edit privilege by default.</td>
</tr>
<tr>
<td>Clear In Use</td>
<td>Clear an In-Use Flag for a training material item in the Admin Utility.</td>
<td>Clear In-Use privilege is a default privilege assigned by the software to an AIM User who creates a training material item.</td>
</tr>
<tr>
<td>Maintain/Delete</td>
<td>Create a Change or a Revision for a training material item and delete the item.</td>
<td>Maintain/Delete privilege is a default privilege assigned by the software to an AIM User who creates a training material item.</td>
</tr>
</tbody>
</table>
The AIM Administrator can also assign one or more of the privilege levels shown in Table 1-1 to an AIM User for specific training materials via the AIM I Administration utility. Having any one privilege does not allow the AIM User to perform any other privilege. The AIM I User who created a training material item can also maintain that training material once it is approved. If an AIM User is tasked to perform maintenance on a training material that he/she did not create nor have Maintain/Delete privilege, the AIM Administrator has to initiate the change/revision for the training material item and grant the privileges required for the AIM User.

On initial installation, the initial default user accounts that are established are based on site requirements. The initial default AIM Administrator accounts are established by the AIM System Support Office (SSO) or support personnel.

1.5.1 Central Site Considerations

For AIM I Central Site installations there is a third privilege, the Curriculum Manager. The Curriculum Manager is also assigned a Developing Authority. The CM is best described as a Developing Authority Administrator. They have Admin rights on all users and Courses associated to their developing authority. (So, basically, the CM can create users, import/export courses, reset in use, approve stuff, etc, but only on courses within their realm). AIM Administrators can perform administrative functions for all Developing Authorities.

There are also two additional privilege levels; "Lock for Review" and "Unlock for Review". These additional privilege levels allow Administrators to lock-out various Developing Authorities from working on the selected Course. A Curriculum Manager can also use "Lock for Review" to lock out users from his Developing Authority, but not other DAs.

1.6 Using the Manual

AIM I takes advantage of the user-friendliness of MS Windows, which gives users concurrent access to the development, maintenance, and administration/utility functions for a given training material item from an integrated main menu.

To eliminate redundancy and more closely reflect the format of the AIM I software itself, the AIM I User's Manual presents development and maintenance procedures within the same modules; for example, development and maintenance of PPPs are presented in Chapter 4 of the user’s manual, which corresponds to the PPP module of the AIM I software.

For easy reference, AIM I’s Administration and Utility functions are explained in Appendix B.

For users who are not yet familiar with basic MS Windows conventions, Chapter 2 introduces techniques for moving around in AIM I. Experienced users of MS Windows may turn directly to Section 2.2 of Chapter 2 for login instructions and orientation to AIM I’s standard functions.

The remaining chapters correspond to the modules of the AIM I software:
• Chapter 3: The Training Project Plan Module
• Chapter 4: The Testing Module
• Chapter 5: The Personnel Performance Profile Module
• Chapter 6: The Training Path System Module
• Chapter 7: The Training Course Control Document Module
• Chapter 8: The Curriculum Outline of Instruction Module
• Chapter 9: The Course Master Schedule Module
• Chapter 10: The Lesson Plan Module
• Chapter 11: The Trainee Guide Module
• Chapter 12: The Learning Object Module
• Appendix A: Glossary (and a list of acronyms)
• Appendix B: Administration and Utilities
• Appendix C: TR/ACR Process
• Appendix D: Developing IETM Extraction Files
• Appendix E: Functionality Changes for AIM I Version 5.0
• Appendix F: SCORM and NILARS
1.7 USING THE HELP SYSTEM

AIM I Version 5.1 includes complete documentation in an accessible help system that includes searchable on-line help files, .pdf-based documents, and media-enhanced demonstrations of certain AIM I functions.

1.7.1 On-line Help

The On-line Help item under the Help menu provides three different methods for accessing information:

- Contents – shows the table of contents for the Help files
- Index – shows the information in alphabetical order
- Search – allows you search for keywords or phrases

Each of these methods may be accessed by clicking on the appropriate tab in the Help Topics window. (Figure 1-2).
1.7.1.1 Contents

The Contents tab of the On-line Help lists all the available information in a table of contents format. Main topics are indicated with a purple book. These main topics may be expanded by double-clicking on them.

At the top of the content window the following buttons are available to help you navigate through the Help information:

- **Hide/Show** – Hides or Shows the Contents
- **Back** - Brings you back to the previous Help Topic menu

---

**Figure 1-2. On-line Help, Help Topics Window**

**Introduction to AIM I**

The Personnel Performance Profile (PPP) Based Authoring Instructional Materials (AIM I) software is an application software for developing and maintaining PPP-based curriculum products that adhere to the curriculum development standards set forth in the Naval Education and Training Command Personnel Performance Profile Based Curriculum Development Manual (NAVEDTRA 131A). The system is designed to operate in the MS Windows environment on either a stand-alone personal computer or a local area network.

AIM I partially automates the development and maintenance of the following training material products:

- Training Project Plan (TPP)
- Personnel Performance Profile (PPP)
- Training Path System (TPS)
- Training Course Control Document (TCCD)
  - Curriculum Outline of Instruction (COI)
  - Course Master Schedule (CMS)
  - Resource Requirements List (RRL)
  - Profile Item-to-Topic Objective Assignment Chart (OAC)
  - Fault Applicability List (FAL)
- Lesson Plan (LP)
- Trainee Guide (TG)

Visual Basic Professional Edition was chosen as the developer’s tool because it offers efficient and rapid design and modification of the programming logic as well as user interface, thus affording potential savings in software life-cycle expenses. The foundation of AIM I is the MS Access Relational Database Management System (RDBMS) engine, however, the program is flexible enough to accommodate virtually any RDBMS.

- There are a multitude of benefits to be realized during development of software with the AIM I toolset; most importantly:
  - The inherent What-You-See-Is-What-You-Get (WYSIWYG)
Print - Prints the content window
Options – Options to hide tabs, search, and internet options for Web-based help.

Also in the content window, hot words are designated by blue, underlined text. These hot words indicate that a word or phrase may be clicked on to view the glossary definition. (Figure 1-3)
1.7.1.2 Index

The **Index** tab of the On-line Help lists all the available information alphabetically. To access information quicker, you may type in the first few letters of the word or phrase in the field provided. *(Figure 1-4)*

![Figure 1-4. On-line Help Index Tab](image)

1.7.1.3 Search

The **Search** tab of the On-line Help allows you to search the entire contents of the Help files for a particular word or phrase by typing it in or clicking a topic. *(Figure 1-5)*
1.7.2 User’s Manual

The User’s Manual item under the Help menu is a navigable AIM I Version 5.1 User’s Manual in Adobe Acrobat .pdf file format. This User’s Manual has all Chapters, Appendices, and Paragraphs Bookmarked for finding information quickly.

The User’s Manual may also be printed from this location.
1.7.3 Changes in Release 5.1

The **Changes in Release 5.1** item under the **Help** menu is a navigable document in Adobe Acrobat .pdf file format which provides quick reference to the major changes in this Version of AIM I.

1.7.4 Frequently Asked Questions

The **Frequently Asked Questions** item under the **Help** menu is a navigable document in Adobe Acrobat .pdf file format, which provides answers to Frequently Asked Questions on AIM I. The main topics in this document are:

- General FAQs
- Course Tree Structure FAQs
- Printing FAQs
- Training Project Plan (TPP) FAQs
- Lesson Plan FAQs

1.7.5 Documentation

The documentation listed under the Help menu item uses PDF format and will open in Adobe Acrobat. The documents included in AIM are:

- ISD/SAT Handbook
- Development of Interactive Multimedia Instruction (IMI) Handbook
- Glossary for Training Handbook
- NAVEDTRA 131B
  - Developer’s Guide
  - Sample Products
  - Manager’s Guide

1.7.6 Demonstrations

The **Demonstrations** item under the **Help** menu expands to further topics:

- Linking Skill to Knowledge Line Items in a PPP
- Selecting Later TLA for a TPC
- Modifying a Graphic
- Working With IETMs

When each of these items are clicked, an .avi movie file automatically opens which shows a screen demonstration in AIM I of the corresponding topic. When the demonstration is finished, simply close the window it opened in.
1.8 SUMMARY

Chapter 1 reviewed the PPP-based curriculum development process and explained how AIM I automates that process. Chapter 1 also described the manual’s organization into chapters that correspond directly to the AIM I modules used in the development of various training material products. Additionally, Chapter 1 illustrated the different components you have available to you in the Help System.
(This Page Intentionally Left Blank)
CHAPTER 2
GETTING STARTED

2.0 Getting Started
2.1 AIM I Software Conventions
   2.1.1 Using AIM I Menus
   2.1.2 Using the Keyboard
2.2 Login Procedures
2.3 Main Menu Bar
   2.3.1 Selecting Display Preferences
   2.3.2 Working with the Course Tree Structure
   2.3.3 Options Menu Item
   2.3.4 View Menu Item
   2.3.5 Window Menu Item
   2.3.6 Pop-Up Menu
   2.3.7 Toolbar
   2.3.8 General
2.4 Standard Functions
   2.4.1 Edit Function
   2.4.2 Print Function
      2.4.2.1 Printing Modules Except TG to a File
      2.4.2.2 Printing the TG to a File
      2.4.2.3 Printing the TG to a File (non-NMCI)
   2.4.3 Print Preview Function
2.5 Editors Used In AIM I
   2.5.1 MS Word™
   2.5.2 Styled Text Editor
   2.5.3 AIM I Text Editor
   2.5.4 High Edit
2.6 Status Levels for AIM I Products
2.7 Developing and Maintaining Courses
2.8 Maximum Values for Text Fields
2.0 GETTING STARTED

AIM I is an MS Windows-based application that employs icons (pictures), drop-down menus, and fill-in data screens to facilitate the development and maintenance of PPP-based curriculum products.

NOTE: If you are familiar with MS Windows conventions, you may wish to turn directly to paragraph 2.2, which addresses AIM I login procedures.

2.1 AIM I Software Conventions

In this User's Manual, fill-in data screens are referred to as windows. Because AIM I is based on MS Windows, you can run more than one application at a time and transfer information from one application to another. This feature is especially useful when you want to copy large amounts of text from a word processor into the AIM I program.

Some of the most common MS Windows features that AIM I uses are listed in Table 2-1.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pointing</td>
<td>Moving the mouse to position the arrow on the screen to a desired object.</td>
</tr>
<tr>
<td>Clicking</td>
<td>Pressing the mouse button and releasing it immediately. You click on an object after you have pointed to it.</td>
</tr>
<tr>
<td>Double Clicking</td>
<td>Pressing the mouse button twice in rapid succession. Double-clicking is usually a shortcut for making a selection. For example, when you are selecting a course to work on from any of the modules, you can click on the course title and then click on the Select option. Alternatively, you can double click on the course title.</td>
</tr>
<tr>
<td>Dragging</td>
<td>Pressing the mouse button and holding it down while moving the mouse.</td>
</tr>
<tr>
<td>Dropping</td>
<td>Releasing the mouse button after you have dragged it to the position in the window where you want to place it.</td>
</tr>
<tr>
<td>Highlighting</td>
<td>Pointing to an object and clicking the mouse once to make an object that you have selected stand out from the rest of the screen. Highlighting lets you see what you have selected so that you can then perform some other action, such as saving or dragging.</td>
</tr>
<tr>
<td>Minimizing</td>
<td>Reducing a window to an icon (picture). When MS Windows-based applications are reduced to icons, they continue to run, but their windows do not take up space on the screen. To reduce an application to an icon, click on the Minimize button in the upper right corner of the window.</td>
</tr>
</tbody>
</table>
Table 2-1 (continued). Common MS Windows Features Used in AIM I

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximizing</td>
<td>Enlarging a window to its maximum size. To enlarge a window to its maximum size, click on the Maximize button in the upper right corner of the window. The Maximize button will be replaced by the Restore button. Click on the Restore button to return the window to its original size.</td>
</tr>
</tbody>
</table>
| Scrolling | Pointing to the arrows within a screen and clicking on them. Scrolling moves the text on the screen in the direction of the arrows. Scrolling is available for viewing portions of material that you are working on if the material is too lengthy to be seen in its entirety through the available window.  
  - *Scroll bars* are generally located on the right side and at the bottom of a window. Every scroll bar has a scroll arrow at either end, and most scroll bars contain a small square box called a *scroll box*.  
  - *Scroll arrows* point in the direction in which you can move the text in the window: right and left or up and down. To move in *small steps*, click on the arrows.  
  - *Scroll boxes* represent your location in the document. To move in *large jumps*, drag a scroll box. |

2.1.1 Using AIM I Menus

All the windows in AIM I have menus that execute your commands. The row of words across the top of each window constitutes the *menu bar*, or simply the *menu*. Each of the words on the menu bar has a drop-down menu attached to it. For example, in some windows, you will see the word *Options* on the menu bar. If you click on the word *Options*, a menu will drop down to provide the specific commands that you can execute. Some common menu conventions are listed in Table 2-2.

Table 2-2. Common AIM I Menu Conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimmed Option</td>
<td>Indicates that the command is unavailable at the current time. Usually, it means that you need to select an object or have some data for AIM I to work on. For example, you cannot highlight and use the <em>Edit</em> option in some windows if you have not yet typed in data.</td>
</tr>
<tr>
<td>Ellipsis (. . .)</td>
<td>Indicates that there are more options or commands that you can use after you select a menu option.</td>
</tr>
<tr>
<td>Underlined letters</td>
<td>Indicates the letter that you should type while depressing the <em>Alt</em> key to select an option using the keyboard.</td>
</tr>
<tr>
<td>Icons</td>
<td>Gives you another way of choosing AIM I modules. Icons are pictures that represent the modules you can select. The row of icons that appears below a menu bar is sometimes called the <em>button bar</em>.</td>
</tr>
</tbody>
</table>
2.1.2 Using the Keyboard

You can use your keyboard to perform many of the functions your mouse performs. The following conventions are useful keyboard alternatives to mouse functions:

- The **Alt** key plus the underlined letter of the option executes the AIM I main menu command (the keyboard alternative to clicking on the command with your mouse).
- The **Tab** key moves you from the various fields on the windows. The tab key moves you forward through the fields.
- **Shift + Tab** moves you in the opposite direction.
- An **Arrow** key moves you in the direction in which the arrow points.

**NOTE:** Arrows generally are active within a field. The **Tab** key moves you from field to field.

2.2 Login Procedures

To login to AIM I from MS Windows double click on the AIM I icon.

When the AIM I title window opens, you can enter AIM I by logging in with a valid user name and password.¹

If your user name and password are valid, AIM I will log you in and give you access to all services and resources to which you have been granted privileges by your AIM Administrator.

The first time you log into AIM I, you will have no password. To gain access to AIM I, press **Enter** or click on the **OK** button when the cursor moves to the password field. You can choose a password using the Password Utility. Thereafter, you must use that password to gain access to AIM I. You may cancel the login procedure at any time by clicking on the Cancel button.

If you forget your password, the AIM Administrator can clear your old password by using the **Clear User Password** option from the **User** Utility. This option will retain your privileges for training materials assigned using the old password.

2.3 Main Menu Bar

When you have logged in successfully, the AIM I main menu bar will appear.

Three methods are available for selecting options from the AIM I main menu:

1. Clicking on the menu bar and again on the item of choice from the drop-down menu
2. Clicking on the associated icon
3. Using the **Alt** key and keying in the underlined letter of an item on the AIM I main menu bar.

¹ Your AIM I Administrator is responsible for entering user names into the system.
NOTE: The default setup for Windows 2000 has the option “Hide Keyboard Navigation Indicators” selected. This option must be deselected under Control Panel, Display, and Effects to use the Alt key and display the underlined letter of each menu item.

Within an AIM I sub-menu, you may initiate a command in one of three following ways:

- Keying in the underlined letter of a sub-menu item
- Scrolling to highlight the item using the keyboard arrow keys and pressing Enter
- Clicking on the sub-menu item

Items that appear to be dimmed on the screen are options that are not currently available to you. Either they do not apply to the task you are performing or you do not have the privilege to access those options. To move among the various fields within a window, use your mouse or the Tab key.

When, for example, you select Course from the AIM I main menu bar, the Course drop-down menu appears. To work on an existing course, click on Select. To develop a new course, click on New.

If the AIM Administrator has assigned you the privilege of AIM User, you can:

- Develop or maintain your own training materials
- View training materials that were created by others
- Add items to the Site Resource Requirements List (RRL)
- Add graphics to the Graphics Library
- Change your own password
- Delete Proposed Training Material you created

Your AIM Administrator can grant you additional privileges to work on training materials that have been created by another user. For further information about AIM User and Administrator privileges, see Chapter 1, Section 1.4.

The User Utility provides the AIM Administrator the flexibility to designate individuals who will only be allowed to create training materials in the Learning Object Module by opening the User Information window and un-checking the Show Courses block. This will limit the icons and functionality to the Learning Object module.
2.3.1 Selecting Display Preferences

The first thing to look at is the **Options**-menu item and the **Preferences** sub-menu item. This allows you to change several aspects of how AIM works on a user-by-user basis. The first tab (**Display**) lists options to change the size of the Toolbar buttons and color scheme (large icons and Windows colors are the defaults). There are also options to maximize each form on display and bold the display text on the screen. The second tab (**Courses**) gives the user the option to remember the recently selected Courses (up to 9 can be remembered). These will be listed under the Course menu item in AIM. The checkbox "Open last Course on login" will, if checked, cause AIM to automatically select the last Course you had selected when you login. Note that changes made to these properties should take effect immediately. The option "Return to highlight position which, when selected, will return you to the last item you were on in the interface. For example, you were checking out the data in the TCCD Funding section of a site when you closed the Course window. The next time you open the Course, your highlight will move back to TCCD Funding, rather than having you search your way for it. The third tab, **Advanced**, gives you the option to use Metadata Specifications for SCORM or NSCORM. SCORM version 2004 or v1.2 can be selected for creating SCORM compliant files. SCORM 2004 is the only selection for creating NSCORM compliant files. It also provides the option for the user to use SLC grouping for Sections (Learn, Explore, and Practice) in the Learning Object Module. The fourth tab, **CPM**, gives the user the ability to add the User Name and Password, issued by the Content Planning Module Administrator, for accessing the CPM when developing Learning Object Module materials.

Selection of the **Course** menu item from the AIM I main window causes the course drop-down menu to appear. The drop-down menu contains two sub-menu items and a list of courses previously selected. To work on a course that exists in the database, click on **Select** and AIM will open the Course Select window from which you can select the desired course. To develop a new course, click on **New** and AIM will open the Training Project Plan (TPP) window where you will start the development process for a new course.

**Developing a new course or TPP:**

Development or redevelopment of a course that does not exist in AIM I is commenced with the development of a TPP.

**Step 1** Select the **Course** menu item and the **New** sub-menu item or click on the New Course icon.

**Step 2** A blank TPP window will open where you can identify the development project. Refer to Chapter 3 for the development of the TPP.

**Selecting an existing course:**

**Step 1** Select the **Course** menu item and the **Select** sub-menu item or click on the Select Course icon.
Step 2  The software will open the Course Select window from which you can highlight the desired course, select the **Options** menu item, and perform various options on the course or select the course highlighted by double clicking on the course or clicking on the **Select** menu item.

Step 3  When a course is selected the Course tree structure is listed in a hierarchy for which the user can navigate as if it was Windows Explorer.

Once selected, and the Course interface is displayed, that Course will be listed as the most recent Course under the Course menu (the list appears in a Last-Selected-Shows-First ordering). Two Course Tree Structure menu items also appear after the course is selected: **Options** and **View**. The **View** menu allows you to toggle on or off the **Summary** and **Notes** display grids in the Course window. The Note display shows all notes for the item if any. The Summary display shows a read-only version of the data for the element selected. Note that this may be the actual data or a summarized version of the data.

The **Options** menu item allows you to edit/view notes for the currently selected element in the tree (left hand side). Selecting **GoTo**, or clicking on the corresponding icon, will open the window for the item highlighted. Selecting the **Preview** and **Print** options, or clicking on the corresponding icons, either preview or print the contents of the folder you have selected.

All forms work independently of each other, which means if you want to display several screens at once and edit the data therein, you can.

As the Course displays are done in a separate window, you can open several Courses at one time. Clicking a button or choosing an item from the **Documents** menu item causes AIM to act as if you said "**GoTo**" on the main module item in the tree.

The **Windows** menu item contains options to move the windows in standard Windows fashion, tile, cascade, and arrange icons.

AIM will only open one instance of a module per Course, or, for utilities, only one instance. Therefore, if you click on TPP for a Course, do some work in it, but leave it open, return to AIM, and click the TPP button again, the existing TPP comes forward. However, different Courses will cause different instances of TPP to run.

### 2.3.2 Working with the Course Tree Structure

Once you’ve selected a Course, the Course is displayed in a Course window inside the AIM window. Since all Course information is contained within this single window, you can easily select and work with multiple Courses at one time, each with its own Course window.
The Course window has up to four parts. On the left hand side is the Course structure. This is a representation of the main elements of the Course. The right side lists information regarding the element currently highlighted in the Course structure. On the top is a list of all child elements of the highlighted element (for example, all Topics in the current Section). Below that is a display of data summarizing the current element (for example, highlighting TPP->Milestones in the Course structure displays the Milestone data. Below the summary is a display of all Notes attached to the current element. If there is no data to display in a particular section, it will not be displayed. So, if TPP Milestones has no Notes attached, then the “Notes” section is hidden from view. This allows more room for the other sections to display their data. Of the three sections, only Summary will display on every element, unless the summary display has been turned off.

Refer to Figure 2-1 below. Besides the display of the Course Structure and Summary, there are a few other details to look at. First, you may notice folder icons with little red flags on them. These indicate the element (or one of its child elements) is flagged. Bold lettering of the folder title indicates it has a note attached to it. The TPP, PPP, TPS, and TCCD icons will show a letter to indicate the current status of that document.

Figure 2-1. Course Tree Structure Window
2.3.3 Options Menu Item

The Options menu item contains nine items:

- **GoTo**
- **Edit Notes**
- **Create Modification TPP**
- **Create Cancellation TPP**
- **Preview Notes**
- **Print Notes**
- **Print Preview**
- **Print**
- **Generate HTML**
- **Preferences**

With the exception of the Generate HTML option (enabled for LP/TG only) and Create Modification/Cancellation TPP (enabled for TPP only) the above menu items work on either the current element of the Course structure, or the highlighted element in the child list, whichever one you last clicked. For example, if you were to choose **GoTo** from the **Options** menu, it would go to the window for the folder that is currently open in the Course Tree Structure.

### 2.3.3.1 GoTo

The **GoTo** option allows the user to automatically go to the screen to display/edit the current element. **GoTo** can also be initiated by double-clicking an element in the child element list on the right-hand side of the screen.

**NOTE:** There are currently four elements for which GoTo does not work: The main Course element (top-most item in the Course structure), the LP/TG element, and the Instructor Preparation and Trainee Preparation elements of each Topic. There is no screen that directly correlates to these elements. Currently, double-clicking these nodes acts as if you selected that element in the Course structure.

### 2.3.3.2 Edit Notes

The **Edit Notes** option is available to all users, and can be used on any element in the Course structure. This menu displays the Notes screen, which allows the user to view all public notes on the specified element, and allows adding of new notes. The user can delete their own notes, but not any notes belonging to another user. There are two types of notes, Public and Private. Only the user who entered it sees a Private note. A Public note is displayed to all users.
2.3.3.3 Create Modification TPP

The Create Modification TPP option allows the user to highlight the folder of an approved TPP and create a Modification TPP in the Course Tree Structure that can be used to keep track of the changes that occur in the lifecycle of changes in the course until a Revision is approved. Modification TPPs can be approved and unapproved in the Admin Utility.

2.3.3.4 Create Cancellation TPP

The Create Cancellation TPP option allows the user to highlight the folder of an approved TPP and create a Cancellation TPP for the Course. Cancellation TPPs created with this option can be approved and unapproved in the Admin Utility.

2.3.3.5 Delete TPP

The Delete TPP option allows the user to delete a Modification or Cancellation TPP that has been created in the Course Tree Structure for an approved TPP.

2.3.3.6 Preview Notes

This option, when available, allows you to Preview Notes for the selected folder. Preview Notes is only available on folders in the Course Tree Structure (not PPP or TPS).

2.3.3.7 Print Notes

This option, when available, allows you to Print Notes for the selected folder, as if you performed this task from the module itself. Preview Notes is only available on folders in the Course Tree Structure (not PPP or TPS).

2.3.3.8 Print Preview

This option allows you to Print Preview the contents of the open folder in the Course Tree Structure.

2.3.3.9 Print

This option allows you to Print the contents of the open folder in the Course Tree Structure.
2.3.3.10 Generate HTML

The software generates HTML file format of an LP/TG that can be used as needed (for example, you can display the HTML file in a web browser).

The HTML file format also provides active hyperlinks from the LP Topic Page and RIA entries in the LP and Instruction Sheets in the TG citing IMM resources, allowing a viewer of the HTML version of the LP/TG to click on a link to see the corresponding file. This could be used to review an LP/TG and its related media files, without searching for the media cited. When you view the HTML file, that contains the IMM file, in a web browser, hyperlinks will appear for the IMIs. When you click on the link, the associated media file will be displayed.

The HTML output for the TG that has been developed in Word can contain hyperlinks to the IMM selected in the Instruction Sheets. High Edit does not provide this functionality.

To generate an HTML file for the LP or TG:

Step 1 In the Course Tree Structure open the LP or TG folder.

Step 2 Select the **Options** menu item and the **Generate HTML** option.

Step 3 Identify the directory where you want to save the HTML file and click on the **Save** button.

Step 4 AIM will present the prompt “Do you want media files associated to IMIs to be copied with the creation of the HTML file?” Click on the **Yes** button to copy the IMM files for distribution with the HTML file or click on the **No** button and AIM will not make copies of the IMM for the HTML file.

Step 5 AIM will generate the HTML output file and open the Media Link Information for Course window that lists the files linked and copied and files linked and not copied in the HTML output. You can print this information for your records if desired.

Step 6 Select the **Exit** menu item to return to the AIM main menu.

For SSP, a HTML file can be created for training materials in which the IMI/Transparency files are not contained in the AIM database and the AIM.INI file contains ‘Prompt for External Media for HTML=Yes’.

When creating an HTML file for an LP with ‘Prompt for External Media for HTML=Yes’ to software will prompt you with “HTML output of the LP has the capability to create hyperlinks in the RIAs to IMM and Transparencies, but only if you have followed SSP guidelines in the naming of your RRL items and the associated files. This has no effect on IMM entries associated to files within AIM. Do you want to specify the location of the files used by IMIs and Transparencies?”
Resource/File Naming
The software must know the name of the file in order to set up the hyperlinks. It determines the name of the file from the Resource’s designator and title information, and, in the case of Transparencies, the Transparency number in the RIA.

IMI
File names are derived from the IMIs (Interactive Multimedia Instructions) designator. The software takes the text up to the first space (if there is one, otherwise it will take the entire text) to be the file name. It searches for the file name in the Media directory specified on the Media Location window. If the file is found it will set up a hyperlink.

Transparencies
File names for transparencies are derived using several different techniques in the following order:

First, the software looks at the end of the title field of the Transparency. If the title ends with text in parenthesis, the software will use the text inside the parenthesis (up to any comma) and check to see if a file exists with that name in the Transparency directory.

If a file could not be found or there was no text in parenthesis in the Transparency title, then the software will try to determine a valid file name from where the Transparency is used in the course (for SP this will use the D5 Backfit File-Naming Conventions). By taking the course’s CIN and Revision, the Part, Section, and Topic containing the RIA citing the Transparency, and the Transparency sequence, the software generates a file name and searches for that (with any extension) in the Transparency directory.

If a file is found, then a hyperlink will be created.

To generate HTML files for SSP curriculum:

Step 1 In the Course Tree Structure open the desired LP or TG folder.

Step 2 Select the Options menu item and the Generate HTML option.

Step 3 The software will provide a file name based on the CIN and Rev and the file selected. You can edit the file as necessary. Click on the Save button.

Step 4 Once you have selected a file name for output the software will prompt you with “HTML output of the LP has the capability to create hyperlinks in the RIAs to IMM and Transparencies, but only if you have followed SSP guidelines in the naming of your RRL items and the associated files. This has no effect on IMM entries associated to files within AIM. Do you want to specify the location of the files used by IMIs and Transparencies?” Click on Yes.
Step 5  AIM will open the Media Location window (Figure 2-2) in which you can identify the directories that contain your IMM and Transparency resources, copy the files to be packaged with the HTML file and click on the OK button. If there are no hyperlinks required simply click on the Cancel button and the software will proceed to the next prompt.

![Media Location Window](image)

**Figure 2-2. Media Location Window**

Step 6  If links were made in Step 5 the software will generate a “Media link information” report. The report displays the course that was output, the IMM and Transparency files that were found (and copied if the Copy Files block was checked), followed by a list of all IMIs and Transparencies that were cited in RIAs, but for which no file could be found. This report can be printed.

Step 7  AIM will present the prompt “Do you want media files associated to IMIs to be copied with the creation of the HTML file? Copying the files allows you to distribute the HTML file with the media. Otherwise, the hyperlinks in the HTML file will reference the files in the AIM Media directory.” Click on the Yes button to copy the IMM files for distribution with the HTML file or click on the No button and AIM will not make copies of the IMM for the HTML file.

2.3.3.11 Preferences

The **Preferences** option takes you to the User Preferences screen. On this screen, you can change different aspects of AIM to suit your needs. All preferences are User specific and do not affect other users.

**Display**

The **Display** tab allows you to specify whether to use large or small buttons for the main toolbar, and whether the colors used on the screens are the old-style AIM colors, or should follow the Windows color scheme of the running computer. The Maximize option, when set, will automatically maximize each form on display. The Bold display text on the screen option will present all text entries in AIM in bold.
Courses
The Courses tab gives the user the option to remember the recently selected Courses (up to 9 can be remembered). These will be listed under the Course menu item in AIM. The checkbox "Open last Course on login" will, if checked, cause AIM to automatically select the last Course you had selected when you login. Note that changes made to these properties should take effect immediately. The option "Return to highlight position which, when selected, will return you to the last item you were on in the interface. For example, you were checking out the data in the TCCD Funding section of a site when you closed the Course window. The next time you open the Course, your highlight will move back to TCCD Funding, rather than having you search your way for it.

Advanced
The Advanced tab gives you the Metadata Spec option to implement SCORM or NSCORM. SCORM version 2004 or v1.2 can be selected for creating SCORM compliant files. SCORM 2004 is the only selection for creating NSCORM compliant files. It also provides the option for the user to use the SLC (Submarine Learning Center) grouping (Learn, Explore, Practice) for development of Sections in the Learning Object Module.

CPM
The CPM tab gives the user the ability to add the User Name and Password, issued by the Content Planning Module Administrator, for accessing the CPM when developing Learning Object Module materials.

2.3.4 View Menu Item
The View menu item contains five items: Notes, Summary, Refresh, Expand All and Contract.

2.3.4.1 Notes, Summary
These sub-menu items toggle whether the Note and Summary displays in the Course screen should be displayed. These settings are Course specific, so turning off summary in one Course will not turn off their display in other Courses. These settings are also saved in the database, so the next time you select this Course, the settings you had previously will be restored.

2.3.4.2 Refresh
This sub-menu item allows the user to refresh the Course structure and summary information manually. Usually making changes in AIM will automatically cause the data to refresh, but changes made by other users will not show up without a manual refresh. (Note: A quicker way to refresh just the summary data would be to click the element in the Course Structure).
2.3.4.3 Expand All

This sub-menu item expands the entire Course structure for the highlighted element. Two possible uses for this would be to aid in the hunt for flagged Topics or items with Notes without having to click the + boxes next to every element.

2.3.4.4 Contract

This sub-menu item will contract the sub-folders into the highlighted folder that contains a “-box” to the left of the folder.

2.3.5 Window Menu Item

The Window menu contains the standard set of options with multiple window applications. Note that most of these options will only work (or at least make sense) if you have more than one Course window open. Underneath these options is a list of all open Course windows. Selecting one brings that window forward.

2.3.6 Pop-up Menu

If you right-click on an element in the Course Structure or Child list, a small pop-up menu is displayed, giving options for that element. These options are **GoTo**, **Edit Notes**, **Preview Notes**, **Print Notes**, **Print Preview**, **Print**, and **Generate HTML**. They work the same as when selected from the Options menu item.

2.3.7 Toolbar

This toolbar has buttons for **GoTo**, **Edit Notes**, **Preview**, **Print**, **View Notes**, and **View Summary**. These options work exactly like their menu counterparts.

2.3.8 General

- You can only open one instance of a module. If Agency is already running, and you attempt to use the Utilities-Agency menu again, AIM will display the currently running module, rather than starting up a new instance of the existing one. For Course modules, this is Course specific (AIM will only open one instance of a TPP per Course).
- For modules, which are broken down into several sub-elements in the Course structure (TPP, TPS, TCCD, LP, and TG), the individual elements work independently of one another, allowing you to edit/view different pieces of the same Course at the same time. For example, you can bring up for view/edit the Justification and the Development Method of a TPP at the same time. You can also modify the RRL of two different sites at the same time, or edit the DPs in two separate Topics in the same LP.
• The above independent editing also works if you go through AIM in the original v3.0 way, as well as through the Course structure. If you go to TPP through the Document menu, then choose Justification from the Contents menu, you no longer are prevented from returning to the TPP screen while Justification remains open. You can keep Justification open and return to the main TPP screen to go to another part of TPP, or just edit some of the cover info.

2.4 Standard Functions

In AIM I, there are a number of standard commands that function in the same manner from module to module; for example, Edit (Save and Cancel), Print, Print Preview, Exit, and Help.

2.4.1 Edit Function

Many windows offer the Edit option (Figure 2-3) with a drop-down menu including Save and Cancel (unless otherwise stated).
There are other AIM I windows, other than the AIM Text Editor windows, that contain an Edit menu item that includes Cut, Copy, and Paste. These sub-menu items have a different application than the text editing applications. When these sub-menu items are selected, the text of the entire field is copied or cut, even if you only highlighted selected text. If you want to copy or cut selected text on these windows you must double click the cell, highlight the desired text, and use the standard MS Windows keystrokes: Cut (Control + X), Copy (Control + C), Paste (Control + V).

### 2.4.2 Print Function

The initial printer is dependent on the printer selected as default in Windows. AIM I can be configured to print out on almost any printer. The initial installation will, most likely, be set up for Hewlett Packard Laser Jet. To install additional printers, update printer drivers, or modify the existing printer configuration by adding the desired printer through the Windows Control Panel.

**NOTE:** A Default Printer with printer drivers must be established in Windows to perform Print Preview.

#### 2.4.2.1 Printing Modules except TG to a file

Generating PDF output of a course Lesson Plan can be accomplished by following these steps:

1. Right click on the desired folder in the tree structure.
2. Select Print Preview from the drop-down menu.
3. In the Printer Setup pop-up box select the desired options and click the Ok button.
4. From the Print Preview Menu bar select Options.
5. From the Options menu select Save to PDF.
6. In the Browse box select the location and file name.
7. Exit the Print Preview screen.

#### 2.4.2.2 Printing the TG to a file

To generate PDF output of the TG a software application capable of producing PDF files must be installed on the computer. For NMCI computers Snagit is the suggested application, a full version of Adobe Acrobat will also work. For non-NMCI computers see the next section. Generating PDF output of a course Trainee Guide can be accomplished by following these steps:

1. Right click on the TG folder in the tree structure.
2. Select Print Preview from the drop-down menu.
3. In the Printer Setup pop-up box select the desired options and click the Ok button.
4. From the Print Preview Menu bar select the Print option.
5. From the Print pop-up box select the application that will generate the PDF file from the Name drop-down menu. If the application is not listed it must be installed. Click the Ok button.
6. Close the Print Preview Screen.
7. When printing is complete open the application to review the PDF file.

2.4.2.3 Printing the TG to a file (non-NMCI)

For non-NMCI users or users without a PDF generating software application there is a free PDF print drivers available:

doPDF (http://www.dopdf.com) is a free download. Once installed follow the steps above for Printing the TG to a file, select doPDF as the printer.

2.4.3 Print Preview Function

Selection of the Print Preview causes the software to prepare the TPP for Print Preview. When prepared, the first page of the TPP is displayed. The following menu items are available:

- **Options** - Contains the options to **Print** or **Save to PDF**. **Print** opens the Print window, which allows you to select the printer, range of pages, print to file, and number of copies. **Save to PDF** allows you to save the document as a PDF file to the desired location.
- **Go To** - Allow moving to the previous, next, first, last, or desired page.
- **Exit** - Returns to the Lesson Plan window.
- **Help** - Provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- **Previous** - Allows moving to the previous page.
- **Next** - Allows moving to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page of Page** - Displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Allows you to access the page desired by typing in the page number in the first field and depressing **Enter**.
- **Actual Page** - Displays the actual page number, as shown on the page. Allow you to access the page desired by typing in the page number in the field and depressing **Enter**.

The right and left mouse buttons allow you to zoom in and out by double clicking on the page and allows you to view multiple pages. Double click the left mouse button to zoom in to a single page display and double click the right mouse button to zoom out. Double click the right mouse button on a single page display and two pages will be displayed. Double clicking on the right mouse button again will preview up to 30 pages of the document. Double clicking on the left mouse button will decrease the number of pages previewed.
Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

### 2.5 Editors Used In AIM I

#### 2.5.1 MS Word™

MS Word™ is the default editor for the major text entry portions of the TG, which includes:

- Safety/Hazard Awareness Notice
- How to Use the TG
- Assignment Sheet - Study Questions
- Diagram Sheet - Diagram
- Information Sheet - Information
- Job Sheet - Job Steps
- Outline Sheet - Topic Outline
- Problem Sheet – Problem

However, in previous versions of AIM I, MS Word™ was not available and High Edit was used as the editor. AIM I offers the user a choice of which editor to use when maintaining curricula that was previously developed using High Edit. High Edit will still be used for approved materials that were originally developed using High Edit. If MS Word™ is not available the user will be required to use High Edit for the Instruction Sheets and a basic text editor for the Safety/Hazard Awareness Notice and How to use the TG.

NMCI users that are working with older courses may need to convert the embedded Word files within each course. To convert the older Word files, .doc file format, to the newer .docx file format a conversion application can be found in the AIM directory. When running the converter (ConvertWordContent1 or 2) the user will be asked whether to convert a single export file or the entire database. The user will then be asked which format to convert to, either Word 2003 or Word 2007+. If the user is using Word 2010 they must check the Trust Center to verify their system has not been blocked from using older files.

#### 2.5.2 Styled Text Editor

The Styled Text Editor *(Figure 2-5)* is used for the LP in the Safety/Hazard Awareness Notice, How to Use the LP, Discussion Points (DPs), and the After Text portion of Related Instructor Activities (RIAs). It is also used in the TG Instruction Sheets that contain an Introduction field and provides the developer with the ability to change font, pitch, center, and justify the text.
2.5.3 AIM I Text Editor

The AIM I Text Editor (Figure 2-6) is used in the Training Project Plan (TPP), Training Path System (TPS), and Training Course Control Document (TCCD) where large amounts of text need to be stored. Although you may type in as much data as you choose, using the MS Windows cut-and-paste option from an existing application or selecting the Import Text File option is a time-saving alternative to re-typing narrative sections in the Text Editor. There are no options in the AIM I Text Editor to change fonts, underline, bold, center text, etc., it is a simple text entry window.
To copy and paste to or from any MS Window-based word processor or any field in AIM I:

Step 1   Select the text to be cut or copied by highlighting it in the original document. (Use either the keyboard or mouse.)

Step 2   Press Control + C to copy the selected text to the clipboard.

Step 3   Position your cursor on the location in which you want the copied text to be pasted.

Step 4   Press Control + V to paste a copy of the text at the location of the cursor. Because the same information will remain in the buffer, you can paste it repeatedly until new text is copied to the buffer or the computer is powered down.
To cut text from any MS Window-based word processor or any field in AIM I:

Step 1   Highlight the text you wish to cut.

Step 2   Press Control + X.

**To edit undo:** Press the Control key + Z.

Other features of the AIM Text Editor are straightforward. The Options menu lets you import a text (.txt) file and print or print preview documents; the Edit menu allows you to spell check highlighted text or an entire document; to search forward or backward through text for words or characters that you specify; to replace words or characters that you specify; to spell check the entire document or selected text; and to save or cancel changes you make to text in Text Editor.

The Exit and Help menus are self-explanatory.

### 2.5.4 High Edit

AIM High Edit *(Figure 2-7)* function, which is available for editing Trainee Guide (TG) Instruction Sheets, offers more formatting features than those available in the AIM I Text Editor and can be used when MS Word is not available. The High Edit menu bar offers six choices: **File, Edit, Format, Options, Table, Exit**, and **Help**.
The menu bar's **File** drop-down menu provides the options to print or print preview text, and add or delete graphics for an instruction sheet, and import a text file.

The **File** drop-down menu provides the following options:

- **Add Graphic** - Allows you to select a graphic from the Graphic Utility portion of the database. The width and height of the graphic can be adjusted to size the graphic for the instruction sheet when selected in the Graphics library. When this information is saved in the Graphics library the file name of the graphic and it's sizing information is placed on the Instruction Sheet where the cursor was located when the **Add Graphic** option was selected.

- **Delete Graphic** - Placing the cursor on the same line as the graphic, in the instruction sheet and selecting this option will delete the graphic from the Instruction Sheet and unlink the graphic from the Graphics library.

- **Import Text File** - If the required text has already been created in a word processor and saved as a Rich Text Format (.rtf) or Text (.txt) file the entire contents of the file can be imported into the Instruction Sheet at the location of the cursor by selecting this option and selecting the appropriate file.

- **Export to File** - This option allows you to export the contents of the editor window to either a Rich Text Format (.rtf) or Text (.txt) file.
• **Print** - This option allows you to print the entire Instruction Sheet for review. The software does not calculate the actual position of the Instruction Sheet in the TG and each printout starts with the page number 1.

• **Print Preview** - This option allows you to preview and print the **Current Page**, **Range of Pages**, and **Entire Document** for review of the Instruction Sheet. The software does not calculate the actual position of the Instruction Sheet in the TG and each printout reflects the page number contained in the document starting with the page number 1.

The menu bar's **Edit** drop-down menu offers the standard windows **Cut**, **Copy**, and **Paste** options, which can be selected by the following key stroke options:

- **Cut** = \text{Ctrl} + X
- **Copy** = \text{Ctrl} + C
- **Paste** = \text{Ctrl} + V.

The Edit menu offers a number of other options:

- **Undo (Ctrl + Z)**: Allows cancellation of a command, a keystroke, or a series of keystrokes, one at a time, in reverse order, beginning with the command, keystroke, or series of keystrokes entered most recently.
- **Clear (Del)**: Deletes the character to the right of the cursor or any highlighted text.
- **Select All**: Highlights all text within a TG sheet.

**NOTE**: Find and Find and Replace options exercised on an entire AIM Editor window of text will not examine the contents of a Graphic.

- **Find (Ctrl + F)**: Takes the cursor, either forward or backward, to the text (a word or string of words) that is specified in a window the command calls up.
- **Find Next (F3)**: Allows the software to continue a search.
- **Find and Replace (Ctrl + R)**: Allows the software to replace the text (a word or string of words) entered in the ”Replace with” field. High Edit allows replacement of the next occurrence of the text, either forward or backward, or all occurrences of the text.
- **Spell Check Entire Document (Shift + F2)**: Identifies possibly misspelled words, suggests substitutes, and allows you to replace or ignore possibly misspelled words throughout the text.
- **Spell Check From Cursor Down**: Identifies possibility of a highlighted word being misspelled. Suggests substitutes, and allows you to replace or ignore possibly misspelled word from the position of the cursor to the end of the file.
- **Save (Ctrl + S)**: Saves the editing completed for the selected portion of the instruction sheet.
- **Cancel**: Cancels all editing accomplished since last save.

High Edits **Format** drop-down menu offers formatting features. Options available from the **Format** drop-down menu include the following character attributes:

- **Normal**: Changes highlighted boldface or italic text to normal.
- **Bold (Ctrl + B)**: Makes highlighted text boldface (e.g., **boldface text**).
- **Underline (Ctrl + U)**: Draws a line under highlighted text (e.g., *underlined text*).
• **Italic (Ctrl + I)**: Makes highlighted text italic (e.g., *italic* text).
• **Strike Thru**: Draws a line through highlighted text (e.g., delete text).
• **Superscript**: Makes a highlighted character superscript (e.g., 2 becomes \(2^2\)).
• **Subscript**: Makes a highlighted character subscript (e.g., H\(_2\)O becomes H\(_2\)O).

**Format** menu options also include the following text attributes:

- **Align Left**: Gives highlighted text flush left and ragged right margins. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Center**: Centers text. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Align Right**: Gives highlighted text ragged left and flush right margins. If text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Justify**: Lines up both left and right margins of highlighted text. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Spacing**: Provides a sub-menu with items "Single", "One and a Half" and "Double". Inserts empty line spaces between each line of highlighted text.
- **Paragraph Spacing**: Provides the option to control the spacing for paragraphs within the document and allows you to select sub-menu items "Single", "One and a Half" and "Double".
- **Color**: Provides the option to change the color of highlighted text from a palette of 16 font colors (including black and white).
- **Font**: Provides the option to alter the appearance of highlighted text for viewing and printing, including size, typeface, color, and font attributes such as bold or italic.

**NOTE:** Use of Tabs with Center or Justify format can cause portions of text to be uneditable.

From the **Options** drop-down menu, the following options are available:

- **Indent**: Provides for indentation of the text on the line of the cursor and subsequent lines before the next hard return. The document indenture has default of "1". Placing the cursor at the desired location, selecting the Indent option can change the indenture, by entering the value desired for left, right, and first line indentures.
- **Bullets Numbering**: Opens a Bullets and Numbering window from which you can select from either 8 different styles of bullets or numbering for selection to indent the highlighted text in your file.
- **Toggle Page Break**: Inserts or deletes a page break at the location of the cursor.
- **Tab visible**: Inserts an arrow (\(\rightarrow\)) in TG sheet text wherever a tab has been entered.
- **Line Feed Visible**: Inserts a paragraph mark (¶) in TG sheet text wherever a hard return has been entered.
- **Space Visible**: Inserts a centered dot (●) in TG sheet text wherever a space character has been entered.
- **Nroff Translation**: Converts the nroff codes of UNIX, which were migrated from AIM 3.X, to font codes and indentures used within AIM I High Edit that results in formatted text. This option is only enabled if nroff codes exist in the document and should only be used once on a file. Adding nroff codes to the file after performing Nroff Translation and selecting Nroff Translation again may cause errors.
From the **Table** drop-down menu, the following options are available:

- **Create Table**: Will create a table with the number of rows and columns specified. Will default to a grid table unless you desire to change the properties of the table.
- **Border Style**: Will allow you to change the border of the cells highlighted to No border, Box, or Shadow. This screen will also allow you to create a 3-D effect through use of raised and sunken lines and allow you to change the line characteristics.
- **Cell Dimension**: Will allow you to change the row height to Auto, At Least, and Exactly. Auto will expand the height of the row automatically as text is entered, At Least will establish the height of the row in a cell until the text expands it. Exactly will limit the amount of text a cell can display in a given row. You can also select the indenture from the left for each row, change the width of a column, and change the space between columns. All measurements are in centimeters, which correspond to the ruler bar.
- **Insert Table Row**: Adds a row above the row containing the cursor.
- **Append Table Row**: Adds a row to the bottom of the table.
- **Delete Table Row**: Deletes the row containing the cursor.
- **Insert Table Column**: Adds a column to the left of the column containing the cursor.
- **Append Table Column**: Adds a column to the far right of the table.
- **Delete Table Column**: Deletes the column containing the cursor.

### 2.6 Status Levels for AIM I Products

The status levels for AIM I-related products that will appear on the screen are:

- **Incomplete (I)**: The minimum information required to develop a product has not been supplied.
- **Suspended (S)**: Used only in the PPP module. When a user wishes to exit from AIM I while he/she is in the process of building a PPP (i.e., has not yet completed the questions required for building the PPP), the user may select the Suspend option from the Create PPP window. The Suspend status level is used only in the PPP module.
- **Complete (C)**: The minimum information required to develop a product has been supplied.
- **Locked (L)**: The product is tentatively complete. In the case of the TPP and TCCD, the first time the product is locked, the information it contains will be copied to the database and will form the foundation for follow-on products.
- **Approved (A)**: The product is ready to be promulgated. No further actions/modifications will be permitted to the product in the development mode. To modify the product, you will have to generate a change or revision (as appropriate).

The Personnel Performance Profile (PPP) table must be locked before it can be selected to develop or maintain it's associated TLA in the TPS. The Training Course Control Document (TCCD) must be unlocked in order to work on the COI and CMS, and must be locked to work on the LP and TG.
2.7 Developing and Maintaining Courses

From AIM I main menu, you can begin creating a new course or maintaining an approved course by selecting the **Course** menu item.

A new course is defined as a course that does not exist in the AIM I database. There may be instances that you are required to develop a Revision for a course that does not exist in the AIM I database. You would accomplish this task by selecting a new TPP and entering the revision letter for the course in the Rev field. The software enables the same functionality for Revisions and new development, with the exception of flagging criteria. Since this Revision will be a new course to the AIM I database, flagging criteria does not apply to the new training material being entered.

To initiate development of a new course follow the instructions that begin in *Chapter 3: The Training Project Plan Module*.

To initiate development of a Change or Revision of an approved course in AIM I, begin by:

- Highlighting an approved Course from the list shown in the Course Select window
- Select the **Options** menu item and the **Maintain** option. Selecting the **Maintain** option provides you with the option of either creating a Revision or a Change.

**NOTE:** If you select a Course that has not been approved, you will not be able to perform maintenance on it; the Maintain option will be disabled.

If you select **Change** from the two Maintain options offered, AIM I will:

- Place a copy of the approved Course in the AIM I database
- Repeat the Course title in the list of Courses that appears in the Course Select window
- Assign the copy of the Course a Change number
- Enter a “C” for Complete in the Status column, adjacent to the new Change’s title in the Course Select window.

When AIM I creates a Change, its Training Course Control Document (TCCD) is initially unlocked.

- If you wish to make changes that require access to the Resource Requirements List, the Course Data, Curriculum Outline of Instruction (COI), or Course Master Schedule, the TCCD module is unlocked and the TCCD is ready for editing.
- If you wish merely to make changes to material in the Course’s Lesson Plan (LP) or Trainee Guide (TG), you can lock the TCCD and go to the LP or TG module (select TG or LP from the AIM I main menu’s Document drop-down menu) to make those changes.

For additional instructions, see *Chapter 6: The Training Course Control Document (TCCD)*.

If you select **Revision** from the two Maintain options offered, AIM I will:

- Place a copy of the approved Course in the AIM I database
- Repeat the Course title in the list of Courses that appears in the Course Select window
- Assign the copy of the Course a Revision letter
- Enter a ‘C’ for Complete in the Status column, adjacent to the new Revision’s title in the Course Select window.
If you are creating a Revision to a Course, you will more than likely begin with the COI. For information about COI maintenance, see Chapter 7: The COI Module.

### 2.8 Maximum Values for Text Fields

The database of AIM I is only limited in size by the amount of hard disk space available for use with the database. However, there are program-coding limitations imposed on the database for long fields (60,000 and 30,000 characters) and certain text fields (960 characters).

**30,000 Character limitation for:**
- Training Project Plan (TPP) Justification Reason and Impact

**3,000 Character limitation for:**
- Training Path System (TPS) Introduction
- Safety/Hazard Awareness Notice
- How to Use LP
- How to Use TG
- Course Learning Objectives
- Course Mission
- Foreword
- Course Overview

**960 Character limitation for:**
- PPP Line Items
- Titles for Parts, Sections, and Topics
- TLO, DP, and RIA text
- Security Awareness Notice
- Instruction Sheet Introduction field

#### Number of Characters per field for equipment in the Site RRL:

<table>
<thead>
<tr>
<th>Title of field</th>
<th>Number of characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nomenclature</td>
<td>40</td>
</tr>
<tr>
<td>Part Number</td>
<td>32</td>
</tr>
<tr>
<td>NSN</td>
<td>16</td>
</tr>
<tr>
<td>ACC</td>
<td>1</td>
</tr>
<tr>
<td>QTY Auth</td>
<td>4</td>
</tr>
<tr>
<td>Unit</td>
<td>2</td>
</tr>
<tr>
<td>Unit Price</td>
<td>12</td>
</tr>
<tr>
<td>Cage</td>
<td>5</td>
</tr>
<tr>
<td>SM&amp;R</td>
<td>6</td>
</tr>
<tr>
<td>Reference</td>
<td>25</td>
</tr>
</tbody>
</table>
CHAPTER 3

THE TRAINING PROJECT PLAN (TPP) MODULE

3.0 Training Project Plan (TPP)
3.1 Elements of a TPP
3.2 Using the AIM I TPP Module
3.3 Overview of the AIM I TPP Module
3.4 Creating a New TPP
3.5 Creating a Revision TPP
3.6 Creating a Cancellation TPP
3.7 Creating a Modification TPP
3.8 Selecting a TPP
3.9 TPP Options Menu Bar Item
  3.9.1 Grant Privileges
  3.9.2 Lock and Unlock
  3.9.3 Print Preview
  3.9.4 Print
  3.9.5 Developing Authorities (Central Site)
3.10 TPP Contents Menu Bar Item
  3.10.1 Compensation
  3.10.2 Course Overview/Comments
  3.10.3 Course Status
  3.10.4 Development Method
  3.10.5 Justification
  3.10.6 Milestones
  3.10.7 Safety Risks and Hazardous Materials
  3.10.8 Summary of Differences
  3.10.9 Selecting a Training site
3.11 Deleting a TPP
3.12 On-Line Help
3.13 Summary
(This Page Intentionally Left Blank)
### 3.0 TRAINING PROJECT PLAN (TPP)

A curriculum development project begins with planning, i.e., the gathering of information and the building of a plan for training material development, revision, or cancellation. The output product of curriculum development planning is the Training Project Plan (TPP), which upon approval becomes the authorization to undertake a new course development project or a course revision and to initiate resource requisitions.

There are five types of TPPs that can be developed in AIM I.

- **New TPP** – For the development of a plan to create a new, Rev 0 Change 0, course.
- **Revision TPP** – For the development of a plan to revise an existing (approved) course.
- **Modification TPP** – For keeping track of all the changes made to the course until it is revised.
- **Cancellation TPP** – For development of a plan to cancel a course.
- **Deactivation TPP** - For development of a plan to cancel a course at one or more, but not all Training Sites.

Course development and, often, course revision require resources that fall into four broad categories:

- Facilities
- Funding
- Manpower
- Material.

All four categories require long lead-time planning. An approved TPP is the authority to submit requests for resources.

In the case of a course cancellation, the TPP provides justification for the action and a blueprint for reallocation of resources.

### 3.1 Elements of a TPP

A TPP consists of the following elements (as applicable):

- Cover Page
- Table of Contents
- Justification
- Impact if the course development, revision, or cancellation is not undertaken
- Course Data Page
- Safety Risks and Hazardous Materials exposure
- Curriculum development method recommended
- Milestones
- Resources Requirements/Changes.
3.2 Using the AIM I TPP Module

The AIM I TPP module provides all the tools necessary to develop a TPP within a series of windows, each of which contains a menu bar across the top.

From a menu bar, you can select an option in one of two ways:

- By pressing the **Alt** key and typing the underlined letter of the option; then selecting the option by typing the underlined letter
- By highlighting the correct option with a mouse and clicking the left mouse button.

Both methods will bring up windows that will allow you to enter the data necessary to complete a TPP.

![Figure 3-1. TPP Main Window](image)

When you begin working on a new TPP, for the development of a new course or the development of a Revision for a course that doesn't exist in the AIM I database, all window fields are blank, as shown in *Figure 3-1*. You must provide the appropriate information by either typing the information in the correct space or selecting the information from a series of drop-down menus.
If you are working on a TPP that is in progress or has been completed, you can edit existing data and/or enter new data, provided that you have the privilege to work on the TPP.\(^1\)

### 3.3 Overview of the AIM I TPP Module

You can start a new TPP by:
- Selecting **Course, New** on the AIM I main menu bar,
- Clicking on the New icon from the button bar, or
- Creating a Course in the TPC Course List of a TPS.

If you are working on an existing TPP, choose **Course, Select** from the main menu bar or click on the Select icon. A list of available courses will appear. Select the course to work on from the list.

Once you have selected a course, AIM I will display the Course Tree Structure and you can access the TPP Cover Page (*Figure 3-2*) by opening the TPP folder and selecting the GoTo option or button on the toolbar, or by clicking on the TPP icon.

\(^1\) For an explanation of AIM I privilege levels, see Chapter 1, Section 1.4.
Figure 3-2. Training Project Plan Window

For a new course, AIM I will show blank fields in the window; for an existing course, data will appear in the fields. After completing or modifying the data in the window, you must select **Edit** and then **Save** to save the changes. If you do not wish to save your changes, you may select **Cancel**. You must either save or cancel before proceeding further. From the TPP main window, you can select **Options** or **Contents** to continue developing the TPP.

To identify where the proposed course will be taught, you will select **Contents, Training Sites** from the menu bar. AIM I will provide the Training Site Summary window (Figure 3-3) in which you can enter the Course Data Processing (CDP) code, Course length, class minimum and maximum capacities, class convening, student throughput, and total manpower for each site.

**NOTE**: The CDP code denotes a Course and a location for NITRAS processing. The code may not be available at this point in the development process. This entry is optional.
After you have entered the Course Data in the Training Site Summary window, you can select the RRL menu item to access the TPP Resource Requirements List (RRL). From the TPP RRL, you can select RRL items to be used in the course. Selecting Resource allows you to select RRL types as well as to enter Manpower, Funding, and Facility data.

The first Training site selected will become the Course Curriculum Model Manager (CCMM). AIM I will allow you to use the Course Data, Manpower, and Funding from the CCMM for subsequent sites. This option will become available when another site is selected.

Returning to the TPP window, you can select Contents to provide the compensations, course overview/comments, course status, development method, justification, milestones, safety risks and hazardous materials, summary of differences, and Training sites.
When you have finished providing data for the TPP, you must use the Edit menu to save your data. You can also cancel your input from the Edit menu. You can lock your TPP from the Options menu.

NOTE: When the TPP is locked; the Cover Page, Course Overview/Comments, Training site(s), and Course Data and RRL materials for each site selected are copied to the Training Course Control Document (TCCD) module.

### 3.4 Creating a New TPP

A New TPP is required for the development of a new course. If you have identified the course for development in the TPS before creating the TPP, AIM I will create a TPP Cover Page for the course. A Revision TPP for a course that exists in the AIM I database can only be initiated from the Course Module by selecting the Maintain/Revision options, and AIM I will automatically create a TPP Cover Page for the Revision TPP.

**To create a new TPP:**

1. From the AIM I main window, select the **Course** menu bar item and the **New** sub-menu item or click on the **New** icon on the button bar.

   AIM I will open the TPP window. The TPP window consists of a title bar labeled Training Project Plan (TPP), a menu bar, and a Cover Page.

   The TPP menu bar contains the following menu items:
   - **Options**
   - **Contents**
   - **Edit**
   - **Exit**
   - **Help**

   Your cursor will now be in the first field, which is blank. Use the **Tab** key to move from field to field.

**To complete the TPP window:**

1. Type the Course Identification Number (CIN). The CIN text entry box will accept both numerical and character data, which will be used to identify a particular TPP.

   When you complete entry of the TPP Cover Page data and save that data to the database, AIM I will verify that the CIN entered does not already exist in database.
If the CIN already exists, a message box will pop up to advise you that the CIN entered exists in the database and AIM I will not accept the input data. You must enter a new CIN in order to proceed.

**After each entry, press the Tab key to advance to the next field.** The Rev and Chg fields are automatically skipped to preclude inadvertent entries. However, these fields can be edited when redeveloping a curriculum in AIM I. If an alpha character is added to the Rev field the TPP type will automatically change to Revision.

**Step 2** Select Prepared By from the drop-down menu. You can use the down arrow to scroll through the available options. Select the correct agency by clicking the left mouse button on the agency desired. The Prepared By drop-down box will contain a list of all agencies in the AIM I database. The agencies will be listed in alphabetical order.

Select the agency that reflects the site that is preparing the TPP.

If the agency you want does not appear in the drop-down box for Prepared By or Prepared For, ask your AIM I Administrator to add the agency via the Agency Utility.

**Step 3** Select Prepared For from the drop-down menu. Selecting the down arrow will let you scroll through the available options. Select the correct agency by placing the cursor on the agency desired and clicking on the left mouse button. The agencies will be listed in alphabetical order (*Figure 3-4*).
Step 4  In the Course Title text input box type the complete course title. The Course Title text input box will accept both numerical and character data. Do not use abbreviations.

Step 5  Enter the Purpose of Course Statement. Use the following questions as guidelines:

- Who is to be trained?
- What job will the person be trained to perform?
- What is the degree of qualification, or how well will the person be able to perform the job?
- Where will the person utilize the training?
- What are the conditions under which the graduate will perform on the job?

A Purpose of Course Statement is a required entry for saving the TPP.

**CAUTION:** Ensure the entries made in the TPP cover page are correct. Once the information on the cover page is saved to the database the Rev and Chg fields cannot be edited.

Step 6  Click on **Edit** menu item and the **Save** sub-menu item.
3.5 Creating a Revision TPP

How you create a Revision TPP in AIM I depends on whether or not the approved version of the course is already in the AIM database.

To create a Revision TPP for an approved course contained in the AIM I database:

Step 1 From the AIM I main menu, select the Course menu item and the Select sub-menu item, or click on the Select Course icon.

Step 2 From the Course Select window highlight the approved curriculum that you want to maintain.

Step 3 Click on the Options menu item and select the Maintain option. A sub-menu will offer you the choice of creating a Revision or a Change.

Step 4 Select the Revision sub-menu item. AIM I will prompt you to confirm your selection. After confirmation the software will create a Revision for the course.

Step 5 After the Revision has been developed and appears in the Course Select list, highlight the course and click on the Select menu item. This action will close the course select window and the Course Tree Structure for the Revision will appear.

Step 6 Open the TPP folder in the Course Tree Structure, right click on the folder, and select the Go To menu item. AIM will open the TPP Cover Page. The TPP has been created in AIM from the approved TCCD. The TPP can now be edited to reflect the changes required for the Revision. The Summary of Differences folder is only enabled for a Revision.
To create a Revision TPP for an approved course **NOT** contained in the AIM I database:

**Step 1** From the AIM I main window, select the **Course** menu bar item and the **New** sub-menu item or click on the **New** icon on the button bar.

**Step 2** Type the Course Identification Number (CIN). The CIN text entry box will accept both numerical and character data, which will be used to identify a particular TPP.

When you complete entry of the TPP Cover Page data and save that data to the database, AIM I will verify that the CIN entered does not already exist in database.

If the CIN already exists, a message box will pop up to advise you that the CIN entered exists in the database and AIM I will not accept the input data. You must enter a new CIN in order to proceed.

**Step 3** Click in the Rev field and enter the alpha character of the Revision. Observe that the TPP Type has changed from New to Revision.

**Step 4** Select Prepared By from the drop-down menu. You can use the down arrow to scroll through the available options. Select the correct agency by clicking the left mouse button on the agency desired. The Prepared By drop-down box will contain a list of all agencies in the AIM I database. The agencies will be listed in alphabetical order.

Select the agency that reflects the site that is preparing the TPP.

If the agency you want does not appear in the drop-down box for Prepared By or Prepared For, ask your AIM I Administrator to add the agency via the Agency Utility.

**Step 5** Select Prepared For from the drop-down menu. Selecting the down arrow will let you scroll through the available options. Select the correct agency by placing the cursor on the agency desired and clicking on the left mouse button. The agencies will be listed in alphabetical order.

**Step 6** In the Course Title text input box type the complete course title. The Course Title text input box will accept both numerical and character data. Do not use abbreviations.

**Step 7** Enter the Purpose of Course Statement. Use the following questions as guidelines:

- Who is to be trained?
- What job will the person be trained to perform?
- What is the degree of qualification, or how well will the person be able to perform the job?
- Where will the person utilize the training?
• What are the conditions under which the graduate will perform on the job?

A Purpose of Course Statement is a required entry for saving the TPP.

CAUTION: Ensure the entries made in the TPP cover page are correct. Once the information on the cover page is saved to the database the Rev and Chg fields cannot be edited

Step 8 Click on Edit menu item and the Save sub-menu item.

3.6 Creating a Cancellation/Deactivation TPP

How you create a Cancellation TPP in AIM I depends on whether or not the approved version of the course is already in the AIM database. For an approved course contained in the AIM I database the Cancellation TPP folder will appear in the Course Tree Structure as a sub-folder under the TPP folder from which it was created and in the upper right hand pane when the TPP folder is open. The Cancellation TPP can be approved and unapproved from the Admin Module.

To create a Cancellation/Deactivation TPP for an approved course contained in the AIM I database:

Step 1 From the AIM I main menu select the Course menu item and the Select sub-menu item.

Step 2 From the Course Select window highlight the desired course and click on the Select menu item. Click on the approved TPP In the Course Tree Structure.

Step 3 From the AIM I main menu select the Options menu item and the Create Cancellation/Deactivation TPP option. The Cancellation/Deactivation TPP folder will appear in the Course Tree Structure as a sub-folder under the TPP folder and in the upper right hand pane when the TPP folder is open.

To create a Cancellation/Deactivation TPP for an approved course NOT contained in the AIM I database:

Step 1 From the AIM I main window, select the Course menu bar item and the New sub-menu item or click on the New icon on the button bar.

Step 2 Type the Course Identification Number (CIN). The CIN text entry box will accept both numerical and character data, which will be used to identify a particular TPP.
When you complete entry of the TPP Cover Page data and save that data to the database, AIM I will verify that the CIN entered does not already exist in database.

If the CIN already exists, a message box will pop up to advise you that the CIN entered exists in the database and AIM I will not accept the input data. You must enter a new CIN in order to proceed.

Step 3 Click in the Rev field and enter the alpha character of the Revision of the course. Observe that the TPP Type will change from New to Revision.

Step 4 Click in the Chg field and enter the change number of the course.

Step 5 Select Prepared By from the drop-down menu. You can use the down arrow to scroll through the available options. Select the correct agency by clicking the left mouse button on the agency desired. The Prepared By drop-down box will contain a list of all agencies in the AIM I database. The agencies will be listed in alphabetical order.

Select the agency that reflects the site that is preparing the Cancellation TPP.

If the agency you want does not appear in the drop-down box for Prepared By or Prepared For, ask your AIM I Administrator to add the agency via the Agency Utility.

Step 6 Select Prepared For from the drop-down menu. Selecting the down arrow will let you scroll through the available options. Select the correct agency by placing the cursor on the agency desired and clicking on the left mouse button. The agencies will be listed in alphabetical order.

Step 7 Click on the arrow for the Type field and select Cancellation.

Step 8 In the Course Title text input box type the complete course title. The Course Title text input box will accept both numerical and character data. Do not use abbreviations.

Step 9 Enter the Purpose of Course Statement.

A Purpose of Course Statement is a required entry for saving the TPP.

CAUTION: Ensure the entries made in the TPP cover page are correct. Once the information on the cover page is saved to the database the Rev and Chg fields cannot be edited. If the TPP Type was changed to a Cancellation TPP, the Cover Page information saved, and the TPP was exited, further selection of the Cancellation TPP will not permit editing.

Step 10 Click on Edit menu item and the Save sub-menu item.
3.7 Creating a Modification TPP

A Modification TPP can be created for a course to keep a historical record of the course and identify the maintenance actions completed until the next revision is created. A Modification TPP can only be created from an approved TPP and will be identified in the Course Tree Structure and folders of the TPP from which it originated. The Revision and Change fields of a modification TPP will always be Rev 0 Chg 0. The Modification TPP can be approved and unapproved from the Admin Utility. When a Modification TPP is unapproved the latest TCCD data is copied from the TCCD to the TPP.

To create a Modification TPP:

Step 1 From the AIM I main menu select the Course menu item and the Select sub-menu item.

Step 2 From the Course Select window highlight the desired approved course and click on the Select menu item. Click on the TPP folder in the Course Tree Structure.

Step 3 From the AIM I main menu select the Options menu item and the Create Modification TPP option.

3.8 Selecting a TPP

Once the TPP window fields have been saved to the AIM I database, you can exit the TPP and return to it later for editing or modification.

There are four different ways to access a New/Revision or Cancellation (Cancellation TPP for a course not contained in AIM) TPP window after the course has been selected from the Course Select menu:

1. From the AIM I main menu select the Document menu item and the Training Project Plan (TPP) sub-menu item.
2. Click on the TPP icon.
3. From the course tree structure click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TPP element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.
4. From the course tree structure click on the TPP folder, select the **Options** menu item and the **GoTo** sub-menu item. Opening the TPP folder can provide Summary or Note data on the right hand portion of the course tree grid if the **View** menu sub-items (**Note** or **Summary**) have been checked. Summary data includes the information contained in the TPP window and Note data contains Personal and/or Private Notes recorded by developers.

To access a Cancellation (Cancellation TPP for a course contained in AIM) or Modification TPP, select the course that the Cancellation or Modification TPP was created from and open the TPP folder in the Course Tree Structure. The Cancellation or Modification sub-folder will appear and can be opened from the Course Tree Structure by selecting Go-To or double clicking on the folder in the upper right hand pane.

If the TPP window cover page is complete and you desire to work on an element within the TPP you can either select the element from the Contents menu item in the TPP window or double-click on the TPP folder in the course tree structure. Double-clicking the TPP folder or clicking on the “+” box next to the TPP will expand the tree information to include the contents of the TPP. Once the tree has been expanded you can click on the element desired and can exercise **Options** menu sub-items (**Edit Note** and **GoTo**) and **View** menu sub-items (**Note** and **Summary**).

If the Status field of the course selected from the Course Select window is Incomplete you can modify all of the data in the window except the CIN, Rev, Chg, and Status fields. If the status of the course selected is Locked you will have to select the TPP window **Options** menu item and the **Unlock** option to edit the fields. Once Unlocked, the Status field will change to Complete which signifies the TPP can be edited but the information will not be copied to the TCCD. To save your changes to the TPP window you must select the **Edit** menu item and the **Save** sub-menu item. (If you do not save the cover page data after editing, you will not be able to access the **Options** or **Contents** menu.)

Once a TPP has been created and saved, it is entered into the AIM I database and the CIN, Rev, and Chg information will be displayed in the AIM I title bar. You can select the TPP for editing or deletion as long as it is not approved and you have the proper privilege.

### 3.9 TPP Options Menu Bar Item

The **Options** menu bar item provides various commands for working with the TPP. It contains the following options:
- **Grant Privileges**
- **Lock**
- **Unlock**
- **Print Preview**
- **Print**
3.9.1 Grant Privileges

The TPP Grant Privileges option is used when the originator of the TPP or an AIM Administrator needs to grant privilege to other users to work on highlighted TPP.

To grant privilege to an AIM User:

Step 1 Select the desired course and open the TPP window using one of the following methods:
   a. Open the TPP folder in the Course Tree Structure and click on the Go button on the toolbar,
   b. Select the Document menu item and the Training Project Plan (TPP) submenu item, or
   c. Click on the TPP icon.

Step 2 Select the Options menu item and the Grant Privileges option.
AIM I will present the Grant Privilege window, which contains a list of AIM Users and a list of the privileges a User can be assigned.

Step 3 Highlight the User and click on the blocks for the privileges desired.

Step 4 Select the Exit menu item and click on the Yes button to save your selection.

3.9.2 Lock and Unlock

The TPP Lock and Unlock options provide means for you to place a TPP into a Locked status that will not permit the TPP to be altered in any way. The TPP can be unlocked for modification.

To lock or unlock a TPP, you must first have the correct privilege. The TPP must be in the Complete status to lock the TPP and a Locked status to unlock the TPP.

- When you select the Lock or Unlock option from the Options menu item, AIM I will check your privilege level for the selected TPP.
- If you have only Edit or View Only privilege for the select TPP, a message box will pop open to inform you that you do not have the necessary privilege level.
- If your privilege is AIM Administrator or if you have AIM I Approve, Grant, or Lock/Unlock privilege, the selected TPP will become:
  o Locked if unlocked
  o Unlocked if locked.

When you have completed developing the TPP and you are ready to use the TPP information to develop other training materials, you must lock the TPP. Locking the TPP maintains the integrity of the baseline data; from which all other related training materials are built.

Every time the TPP is locked, shared data is copied to the TCCD. The data will be used as the foundation of the TCCD.
To lock the TPP:

Step 1  Click on **Options** from the main TPP window.

Step 2  Select the **Lock** option.

The TPP is now locked, and you cannot make changes to it unless you unlock the TPP.

To unlock the TPP:

Step 1  Click on **Options** from the main TPP window.

Step 2  Select the **Unlock** option.

### 3.9.3 Print Preview

Selection of **Print Preview** will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting **OK** will present the default printer selected. Selecting **OK** from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- **Options** - Contains the options to **Print** or **Save to PDF**. **Print** opens the Print window, which allows you to select the printer, range of pages, print to file, and number of copies. **Save to PDF** allows you to save the document as a PDF file to the desired location.
- **GoTo** - Allow moving to the previous, next, first, last, or desired page.
- **Exit** - Returns to the TPP window.
- **Help** - Provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- **Previous** - Allow moving to the previous page.
- **Next** - Allow moving to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - Displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Allows you to access the page desired by typing in the page number in the first field and depressing **Enter**.
- **Actual Page** - Displays the actual page number, as shown on the page. Allow you to access the page desired by typing in the page number in the field and depressing **Enter**.
The right and left mouse buttons allow you to zoom in and out by double clicking on the page and allows you to view multiple pages. Double click the left mouse button to zoom in to a single page display and double click the right mouse button to zoom out.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

**To print preview the TPP:**

1. From the TPP window; select the **Options** menu item and the **Print Preview** option.
2. From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.
3. Click on the **OK** to print preview.

**3.9.4 Print**

Selection of the **Print** option allows the entire document to be printed:

**To print the entire TPP:**

1. Select the **Options** menu item and the **Print** option.
2. From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.
3. Click on the **OK** to print.

**3.9.5 Developing Authorities (Central Site)**

In addition to the previous options Central Site Administrators and Curriculum Managers have the **Developing Authorities** option. This option allows Administrators and Curriculum Managers the ability to select which site can work on the course.

**3.10 TPP Contents Menu Bar Item**

After selecting a TPP, you can edit or create the TPP **Contents**. The elements of the TPP Contents menu are **Distribution Statement**, **Compensation**, **Prerequisite**, **Occupational Classification**, **Course Overview/Comments**, **Course Status**, **Development Method**, **Justification**, **Milestones**, **Safety Risks and Hazardous Materials**, **Summary of Differences**, and **Training Sites**.
3.10.1 Distribution Statement

The Distribution Statement menu option is to allow the user to input official distribution statements that will be printed on the cover page of the TPP.

![Distribution Statement Screen](image)

**Figure 3-5: Distribution Statement Screen**

The first field, *Type*, lists the distribution statements. Selecting a statement displays the text in the field below (this field is NOT editable). Under the *Distribution Statement* field are fields for *Reason*, *Date of Determination*, and *Controlling DoD Office*. Which of these fields display depends on the statement selected; for example, Distribution Statement X does not have a reason.

The *Reason* field is another drop-down that list the pre-defined reasons (see below). If one of the pre-defined reasons does not suffice, *Free Text* can be selected, and the user can enter whatever text they want in the *Reason Text* field (not shown).

The other two fields on the screen are plain text fields and can contain whatever text the user wants to enter (the date field will not be validated as a date, in case the user needs or wants to put in values like *January, 2014* or *2059*).

The following are the default distribution statements with insertion points for the reason, date of determination, and controlling DOD office.

**Distribution Statement A**

Approved for public release; distribution is unlimited.

**Distribution Statement B**

Distribution authorized to U.S. Government Agencies only [reason] [date of determination]. Other requests for this document shall be referred to [controlling DoD office].
Distribution Statement C

Distribution authorized to U.S. Government Agencies and their contractors [reason] [date of determination]. Other requests for this document shall be referred to [controlling DoD office].

Distribution Statement D

Distribution authorized to the Department of Defense and U.S. DoD contractors only [reason] [date of determination]. Other requests shall be referred to [controlling DoD office].

Distribution Statement E

Distribution authorized to DoD Components only [reason] [date of determination]. Other requests shall be referred to [controlling DoD office].

Distribution Statement F

Further dissemination only as directed by [controlling DoD office] [date of determination] or higher DoD authority.

Distribution Statement X

Distribution authorized to U.S. Government Agencies and private individuals or enterprises eligible to obtain export-controlled technical data in accordance with reference (c) [date of determination]. Controlling DoD office is [controlling DoD office].

The following are the default reasons for a distribution statement. Selection of any of these (except Other) will hard-code the reason text into the distribution text. (Table taken from the web site Distribution Statements & Their Corresponding Reasons for Use)

<table>
<thead>
<tr>
<th>&quot;REASON FOR RESTRICTION&quot;</th>
<th>MAY BE USED ON DISTRIBUTION STATEMENT:</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMINISTRATIVE OR OPERATIONAL USE. To protect technical or operational data or information from the automatic dissemination under the International Exchange Program or by other means. This protection covers publications required solely for official use or strictly for administrative operational purposes. This statement may be applied to manuals, pamphlets, technical orders, technical reports, and other publications containing valuable technical or operational data.</td>
<td>B C D E</td>
</tr>
<tr>
<td>Reason for Classification</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>CONTRACTOR PERFORMANCE EVALUATION.</td>
<td>To protect information in management reviews, records of contractor performance evaluation, or other advisory documents evaluating programs of contractors.</td>
</tr>
<tr>
<td>CRITICAL TECHNOLOGY.</td>
<td>To protect information and technical data that advance current technology or describe new technology in an area of significant or potentially significant military application or that relate to a specific military deficiency of a potential adversary. Information of this type may be classified or unclassified. When unclassified, technology is export-controlled and subject to the provisions of DoD Directive 5230.25.</td>
</tr>
<tr>
<td>DIRECT MILITARY SUPPORT.</td>
<td>The document contains export-controlled technical data of such military significance that release for purposes other than direct support of DoD-approved activities may jeopardize an important technological or operational military advantage of the United States. Designation of such data is made by competent authority in accordance with DoDD 5230.25.</td>
</tr>
<tr>
<td>FOREIGN GOVERNMENT INFORMATION.</td>
<td>To protect and limit distribution in accordance with the desires of the foreign government that furnished the technical information. Information of this type normally is classified at CONFIDENTIAL level or higher in accordance with DoD 5200.1-R.</td>
</tr>
<tr>
<td>PREMATURE DISSEMINATION.</td>
<td>To protect patentable information on systems or processes in the developmental or concept stage from premature dissemination.</td>
</tr>
<tr>
<td>PROPRIETARY INFORMATION.</td>
<td>To protect information not owned by the U.S. Government and protected by a contractor’s “limited rights” statement, or received with the understanding that it not be routinely transmitted outside the U.S. Government.</td>
</tr>
<tr>
<td>SOFTWARE DOCUMENTATION.</td>
<td>Releasable only in accordance with DoD Instruction 7930.2.</td>
</tr>
<tr>
<td>TEST AND EVALUATION.</td>
<td>To protect results of test and evaluation of commercial products or military hardware when such disclosure may cause unfair advantage or disadvantage to the manufacturer of the product.</td>
</tr>
<tr>
<td>SPECIFIC AUTHORITY.</td>
<td>To protect information not specifically included in the above reasons and discussions, but which requires protection in accordance with valid documented authority such as Executive Orders, classification guidelines, DoD or DoD Component regulatory documents. When filling in the reason, cite “Specific Authority (identification of valid documented authority).”</td>
</tr>
</tbody>
</table>

Legend: B = Document, C = File, D = Label, E = Report, F = Label
ELIGIBLE TO RECEIVE EXPORT-CONTROLLED DATA. 
Distribution Statement X shall be used on unclassified documents 
when distribution statements B, C, D, E, or F do not apply, but the 
document does contain technical data as explained in DoD 
Directive 5230.25.

OTHER: Free text entry.

If none of these apply, the user will have an option to enter free text.

3.10.2 Compensation

Use the Compensation window to provide a recommended source of compensation for 
manpower, funding, and facility. Identify possible course cancellations/reductions, cross-
utilization of instructors, etc.

To enter TPP Compensation data:

Step 1 Open the TPP Manpower/Funding Compensation window by performing one of 
the following:
  a. With the TPP folder open in the Course Tree Structure; double click on the 
Compensation - Funding or Compensation - Manpower folder in the upper 
right hand panel.
  b. Expand the TPP and open the Compensation - Funding or Compensation - 
Manpower folder in the Course Tree Structure and click on the Go button on 
the toolbar,
  c. After selecting the course, access the TPP window by either selecting the 
Document menu item and the Training Project Plan (TPP) sub-menu item 
or click on the TPP icon. Select the Contents menu item and the 
Compensation and Funding or Manpower sub-menu items.

To enter TPP Manpower Compensation data:

Step 1 In the Site Name field, click on the down arrow and select the site from the drop 
down list provided or type in the name of the Training site.

After each entry, press the Tab key to advance to the next field. You can use 
Shift + Tab to move backward. You can also use your mouse to select the 
desired field.

Step 2 Enter the Number/Type of Billets (e.g., 2/E-6 4245). Use Ctrl and Enter to add 
Number/Type of Billets entries to the same field.

Step 3 Type in the source of the funding (e.g., CPATS document number) by positioning 
the cursor in the Source field and typing in the information.
Step 4 Estimate the manpower shortfall, if any, and enter the shortfall.

**NOTE**: The Tab key allows you to advance to the next field or line without having to save each entry.

Step 5 Select **Edit**.

Step 6 Select **Save** or **Cancel**. To return to the TPP main window or the Course Tree structure, select **Exit**.

**NOTE**: You will be allowed to enter each site only once. To enter more than one entry in the Number/Type Billets category, position the cursor at the end of the first entry in that field. Hold down the Ctrl key and press Enter.

**To enter the TPP Funding or Facility Compensation data:**

Step 1 In the Site Name field, click on the down arrow and select the site from the drop down list provided or type in the name of the Training site.

Step 2 Enter the dollar amount. When you enter whole numbers, AIM I automatically formats them as currency entries that include two decimal places.

Step 3 Type in the name of the funding source.

Step 4 Estimate the funding shortfall, if any, and enter the amount.

Step 5 Click on **Edit**.

Step 6 Click on **Save** or **Cancel** to update your entries. Repeat this procedure for each Training site. To return to the TPP Summary window or the Course Tree structure, click on **Exit**.

**To add another TPP Funding or Facility Compensation entry:**

Step 1 Select **Options** from the TPP Funding Compensation menu.

Step 2 Click on **Add** from the drop-down menu and follow Steps 2 through 7 above.

**To delete a TPP Funding or Facility Compensation entry:**

Step 1 Using your mouse highlight the entry that you want to delete.

Step 2 Select **Options** from the TPP Funding Compensation menu.

Step 3 Click on **Delete** from the drop-down menu.

AIM I will ask you to confirm your choice.
Step 4  Click on **Yes**.

Step 5  To return to the TPP Summary window, click on **Exit**. The program will ask you to save the new Compensation data.

Step 6  Click on **Yes**.

### 3.10.3 Prerequisite

The prerequisites required of the trainee that are scheduled to attend the course. Prerequisites may be equipment, rate or rating specific, basic skills, or course specific. Prerequisites normally relate to prior training or skills, not ASVAB scores.

### 3.10.4 Occupational Classification

Applicable rank, rate designator, NEC or NOBC, of the intended input population, and the NEC, NOBC, or MOS earned by course graduates.

### 3.10.5 Course Overview/Comments

The Course Overview/Comments option allows you to enter information to describe the training that will take place in the course.

Your TPP should contain a listing of course subjects. Note any changes from any previous Project Plan. For a new course, the Course Overview/Comments will be a description of the skills and knowledge to be attained. It is not intended to be the equivalent of a Curriculum Outline or to contain objectives. The Overview will help the Training Agency see what the course will actually contain.

**To enter Course Overview/Comment information:**

Step 1  Open the Course Overview/Comments window by performing one of the following:
   a. With the TPP folder open in the Course Tree Structure; double click on the Course Overview/Comments folder in the upper right hand panel,
   b. Expand the TPP and open the Course Overview/Comments folder in the Course Tree Structure and click on the **Go** button on the toolbar,
   c. After selecting the course, access the TPP window by either selecting the **Document** menu item and the Training Project Plan (TPP) sub-menu item or click on the TPP icon. Select the **Contents** menu item and the Course Overview/Comments sub-menu item.

Step 2  From the AIM I Text Editor, enter the desired text.

Step 3  After entering/modifying the text; you can choose one of two ways to exit:
First Method:
- Select the **Edit** menu bar item.
- Select **Save** to save your text and exit. Or, select **Cancel** to delete your new data entries and return to the AIM I Text Editor window.

Second Method:
- Select the **Exit** menu bar item. If the text has been entered/modified, AIM I will prompt, *Edit Text has been modified. Would you like to save new data?* If there is no new data, selecting **Exit** will return you to the TPP main window or the Course Tree structure.
- Select **Yes** to save the new data, select **No** to return to the AIM I Text Editor window, or select **Cancel** to exit to the TPP main window or the Course Tree structure.
3.10.6 Course Status

The Course Status option allows you to input information to describe the course status prior to the creation of a Revision TPP.

To enter course status:

Step 1 Open the Course Status window by performing one of the following:
   a. With the TPP folder open in the Course Tree Structure; double click on the Course Status folder in the upper right hand panel,
   b. Expand the TPP and open the Course Status folder in the Course Tree Structure and click on the Go button on the toolbar,
   c. After selecting the course, access the TPP window by either selecting the Document menu item and the Training Project Plan (TPP) sub-menu item or click on the TPP icon. Select the Contents menu item and the Course Status sub-menu item.

Step 2 From the AIM I Text Editor, enter the desired text.

Step 3 After entering/modifying the text; you can choose one of two ways to exit:

First Method:
   • Select the Edit menu bar item.
   • Select Save to save your text and/or select Cancel to delete your new data entries and return to the AIM I Text Editor window.
   • Select the Exit menu bar item. AIM I will return you to the TPP window or the Course Tree Structure.

Second Method:
   • Select the Exit menu bar item. If the text has been entered/modified, AIM I will prompt, Edit Text has been modified. Would you like to save new data?

If there is no new data, selecting this item will return you to the TPP main window or the Course Tree Structure.

3.10.7 Development Method

The Development Method option allows you to select the documents that are planned for development/revision and describe how the course will be taught.

- Documents produced/revised for this course:
  o Training Project Plan
  o Personnel Performance Profile
  o Training Path System
  o Training Course Control Document
NOTE: The Navy uses different systems for developing training programs. AIM I is programmed to the specifications in NAVEDTRA 131B: Personnel Performance Profile Based Curriculum Development Manual, and the options presented are tailored to this method.

To enter Development Method information:

Step 1  Open the TPP Development Method window by performing one of the following:
   a. With the TPP folder open in the Course Tree Structure; double click on the Development Method folder in the upper right hand panel,
   b. Expand the TPP and open the Development Method folder in the Course Tree Structure and click on the Go button on the toolbar,
   c. After selecting the course, access the TPP window by either selecting the Document menu item and the Training Project Plan (TPP) sub-menu item or click on the TPP icon. Select the Contents menu item and the Development Method sub-menu item.

The cursor will now be in the Sel/Unsel box for the TPP Document Selection field.

Step 2  Double click on the Sel/Unsel box to select/unselect a document. Click on the Sel/Unsel block next to the document(s) that apply to your TPP.

Step 3  Type in Mode of Instruction. The entry should describe how the instruction could best be implemented. Address such issues as the use of lecture, group-paced or individualized instruction; laboratory periods; problem-solving sessions; and any other instructional methodology that you project should be used in the proposed course.

In front of the text you enter, AIM I will automatically insert, The primary mode of instruction. To enter the text to identify the mode of instruction, click on the text block in the upper left-hand corner and enter the text required.

Step 4  After entering/modifying the TPP Development Method information, you can exit in one of two ways:

First Method:
   • Select the Edit menu bar item.
   • Select Save to save your entries/modifications and exit. Select Cancel to delete your new data entries and return to the TPP Development Method window or the Course Tree structure.
Second Method:

- Select the Exit menu bar item. If the TPP Development Method information has been entered/modified, AIM will prompt, **TPP Method has been modified. Would you like to save new data?** If there is no new data, selecting Exit will return you to the TPP main window or the Course Tree structure.
- Select Yes to save the new data, select No to return to the TPP Development Method window, or select Cancel to exit to the TPP main window or the Course Tree structure.

3.10.8 Justification

The Justification option allows you to input information for:

- References for the TPP
- Reason/Source of Information for the TPP
- Impact if not approved.

There must be a reason (or reasons) to undertake the development of a new course, or revision/cancellation of an existing course. The justification for initiating the development of a new course or the revision of existing training materials may come from:

- Navy Training Plans (NTPs) (OPNAVINST 1500.8)
- Tasking by higher authority
- Internal course reviews and local command initiatives
- External course reviews
- Surveillance and external feedback
- Training appraisal.

To enter Justification information:

Step 1  TPP Justification can be accessed three different ways:

a. With the TPP folder open in the Course Tree Structure; double click on the Justification folder in the upper right hand panel,

b. Expand the TPP and open the Justification folder in the Course Tree Structure and click on the Go button on the toolbar,

c. After selecting the course, access the TPP window by either selecting the Document menu item and the Training Project Plan (TPP) sub-menu item or click on the TPP icon. Select the Contents menu item and the Justification sub-menu item.

The cursor will now be in the References field of the TPP Justification window.

Step 2  Enter the References information.
Step 3 Tab to the Reasons for and Anticipated Benefits of the Proposed Project field and enter the appropriate text for the TPP.

Step 4 Tab to the Impact If Not Approved field and enter text explaining what the impact will be if the TPP is not approved.

After entering/modifying the TPP Justification information, you may exit in one of two ways:

First Method:

Step 1 Select the **Edit** menu bar item.

Step 2 Select **Save** to save your entries/modifications and exit. Or, select **Cancel** to delete your new data entries and return to the TPP Justification window.

Second Method:

Step 1 Select the **Exit** menu bar item. If the TPP Justification information has been entered/modified, AIM will prompt, *TPP Justification has been modified. Would you like to save new data?*

Step 2 Select **Yes** to save the new data or select **No** to return to the TPP Justification window. Or, select **Cancel** to remain in the TPP Justification window.

### 3.10.9 Milestones

The Milestones function allows you to input information for:

- Milestones
- Start Date
- Completion Date.

Milestones are a time-phased narrative commencing with TPP approval. Your milestones should identify major developmental products or events relating to the training materials development method selected, and end with implementation. For each event, you will enter a start date and a projected completion date.

**To enter Milestones information:**

Step 1 Open the TPP Milestones window by performing one of the following:

a. With the TPP folder open in the Course Tree Structure; double click on the Milestones folder in the upper right hand panel,

b. Expand the TPP and open the Milestones folder in the Course Tree Structure and click on the **Go** button on the toolbar,
c. After selecting the course, access the TPP window by either selecting the Document menu item and the Training Project Plan (TPP) sub-menu item or click on the TPP icon. Select the Contents menu item and the Milestones sub-menu item.

Step 2 For the first milestone (if blank), click on the upper left corner of the Milestones field and enter the text for the milestone.

Step 3 Today's date will be entered as the default start date. You can Tab to the next field or type over/select another start date. To enter a different date using the calendar icon:
   a. Click on the Date Start field and a calendar icon will appear.
   b. Click on the calendar icon and the currently selected calendar will appear.
   c. Click on the month down arrow and select the desired month.
   d. Click on the year down arrow and select the desired year.
   e. Click on the desired day and the date will be entered into the Start Date field.

**NOTE:** A date can be deleted in the Date Start/Completed columns by highlighting the date and pressing the delete key or by using the backspace key.

Step 4 Type in the projected end date in the Date Complete field. To enter a different date using the calendar icon:
   a. Click on the Date Complete field and a calendar icon will appear.
   b. Click on the calendar icon and the currently selected calendar will appear.
   c. Click on the month down arrow and select the desired month.
   d. Click on the year down arrow and select the desired year.
   e. Click on the desired day and the date will be entered into the Date Complete field.

Step 5 Select the **Edit** menu bar item and the **Save** option to save the new milestone.

Step 6 To enter the remaining milestones:
   a. Select the **Options** menu bar item and the **Add** option to add the next sequential number to the Num column and dates to the Date Start and Date Complete columns.
   b. Click on the Milestones block to enter text and add the text describing the next milestone.
   c. Click on **Date Start** to select the block. Click on it again to modify the entry as necessary.
   d. Click on **Date Complete** to select the block. Click on it again to modify the entry as necessary.
   e. Select the **Edit** menu bar item and the **Save** option to save the new milestone.

Step 7 To delete a milestone:
   a. Click on the milestone number of the milestone no longer required.
   b. Select the **Options** menu bar item and the **Delete** option to delete all the data for the milestone selected.
Step 8 After you enter/modify the TPP Milestones information, you can choose one of two ways to exit:

**First Method:**
- Select the **Edit** menu bar item.
- Select **Save** to save your Milestones entries/modifications and exit. Or, select **Cancel** to delete your new data entries and return to the TPP Milestones window.

**Second Method:**
- Select the **Exit** menu bar item. If the TPP Milestones information has been entered/modified, AIM will prompt, *TPP Milestone data has been modified. Would you like to save new data?* If there is no new data, selecting **Exit** will return you to the TPP main window or the Course Tree structure.
- Select **Yes** to save the new data, select **No** to return to the TPP Development Method window, or select **Cancel** to exit to the TPP main window or the Course Tree structure.

### 3.10.10 Safety Risks and Hazardous Materials

**To enter data in the Safety Risks and Hazardous Materials field:**

**Step 1** TPP Safety Risks and Hazardous Materials can be accessed three different ways:
- a. With the TPP folder open in the Course Tree Structure; double click on the Safety Risks and Hazardous Materials folder in the upper right hand panel,
- b. Expand the TPP and open the Safety Risks and Hazardous Materials folder in the Course Tree Structure and click on the **Go** button on the toolbar,
- c. After selecting the course, access the TPP window by either selecting the **Document** menu item and the **Training Project Plan (TPP)** sub-menu item or click on the TPP icon. Select the **Contents** menu item and the **Safety Risks and Hazardous Materials** sub-menu item.

**Step 2** From the TPP window; select the **Contents** menu item and the **Safety Risks and Hazardous Materials** sub-menu item. AIM II will open the Safety Risks and Hazardous Materials window, which contains the AIM Text Editor, and two check-box options for Safety Risks and two check-box options for Hazardous Materials.
Step 3 Enter in the identified Safety Risks and Hazardous Materials or if there are none, the Editor is unavailable and a statement indicating no Safety Risks or Hazardous Materials will be automatically generated.

Step 4 Select the Edit menu item and the Save sub-menu item. Then select the Exit option to save your text and return to the TPP main window.

3.10.11 Summary of Differences

The Summary of Differences sub-menu item is used when you are developing a TPP for a revision to a course. It allows you to summarize the differences between the current baseline of the TCCD, LP, and TG and the planned revision of the course.
To enter Summary of Differences:

Step 1  Open the Summary of Differences window by performing one of the following:
   a. With the TPP folder open in the Course Tree Structure; double click on the Summary of Differences folder in the upper right hand panel,
   b. Expand the TPP and open the Summary of Differences folder in the Course Tree Structure and click on the Go button on the toolbar,
   c. After selecting the course, access the TPP window by either selecting the Document menu item and the Training Project Plan (TPP) sub-menu item or click on the TPP icon. Select the Contents menu item and the Summary of Differences sub-menu item.

Step 2  From the AIM Text Editor enter the desired text.

Step 3  After entering/modifying the text you can choose one of two ways to exit:

First Method:
   • Select the Edit menu bar item.
   • Select Save to save your text and/or select Cancel to delete your new data entries and return to the AIM I Text Editor window.
   • Select the Exit menu bar item. AIM I will return you to the TPP window or the Course Tree Structure.

Second Method:
   • Select the Exit menu bar item. If the text has been entered/modifed, AIM I will prompt, Edit Text has been modified. Would you like to save new data? If there is no new data, selecting this item will return you to the TPP main window or the Course Tree Structure.

3.10.12 Selecting a Training site

To select a Training site:

Step 1  Open the Training site Summary window by performing one of the following:
   a. With the TPP folder open in the Course Tree Structure; double click on the Training sites folder in the upper right hand panel,
   b. Expand the TPP and open the Training sites folder in the Course Tree Structure and click on the Go button on the toolbar,
   c. After selecting the course, access the TPP window by either selecting the Document menu item and the Training Project Plan (TPP) sub-menu item or click on the TPP icon. Select the Contents menu item and the Training sites sub-menu item.
The Training site Summary window contains the following menu items:

- **Options** to select/unselect a site, selecting a site as CCMM, and show only selected sites.
- **RRL** to create the RRL for the CCMM and note differences for other sites
- **Edit** to save or cancel modifications
- **Exit** to return to the TPP window
- **Help**.

Once the site has been selected, you can input the following current/planned information from the Cover Page:

- CDP for each site
- Course Length
- Class min. Capacity
- Class max. Capacity
- Class Convenings
- Average on Board (automatically calculated by AIM I)
- Student Throughput
- Manpower Totals
- Site considerations.

The Training site Summary **RRL** menu bar item allows you to select and enter the following data:

- Facility
- Funding
- Manpower
- Calibration
- Computers
- Consumables
- Equipment (Equipment identified in the Fault Applicability List)
- Equipment Refurbished
- Films
- Hand Tools
- IETM
- IMM
  - Animation
  - Audio
  - Graphic
  - Internet
  - Power Point
  - Video
- Miscellaneous Trainers
- Miscellaneous Materials
- Ordnance
- Photographs
- Prefaulted Modules
In developing a TPP, you must select all Training sites at which the proposed course will be taught. The first Training site you select will be identified as the CCMM. Once you have selected a site, you can add the Course Data and the RRL data for that site.

**CAUTION:** Complete entries for all Course Data for the CCMM before selecting additional sites. The Course Data, Manpower, and Funding information entered for the CCMM can be used by AIM I to complete the requirements for additional sites; therefore, you won’t have to enter the same information more than once.

**NOTE:** The TCCD will allow you to print all sites or one site individually.

**NOTE:** Training sites are added to the list through AIM I Utilities. If you do not see the Training site that you want to select, ask your AIM I Administrator to add it via the Training site utility.

**Step 2** Click on the desired Training site. It will be highlighted.

**Step 3** Select the **Options** menu item and the **Select Site** option or double-click on the highlighted site.

**NOTE:** AIM I will prompt, *This site will also be selected as the CCMM. Continue?*

**Step 4** Click on **Yes** if the highlighted site will become the CCMM or click on **No** to terminate the selection. Highlight the site that will be the CCMM and click on **Yes**.

**Step 5** Type the Course Data Processing Code (CDP). You can enter four characters. The software will check for duplicate entries. If the CDP is not known, it can be left blank and an entry made when assigned.
After each entry, press the Tab key to advance to the next field.

Step 6 Type in the Course Length in instructional days. Fields are provided for both the current and planned course lengths. Both should be completed if you are working on a Revision.

Step 7 Type in the minimum and maximum class capacities, both current and planned.

Step 8 Type in the number of classes per year for each site, both current and planned.

Step 9 Type in the annual student throughput. AIM I will verify that the student throughput is:
- Equal to or greater than the class minimum capacity multiplied by the class convenings
- Less than or equal to the class maximum capacity multiplied by the class convenings.

**NOTE:** AIM I will automatically calculate the Average On Board (AOB).

Step 10 Type in the Manpower Totals, both current and planned.

Step 10 Type in the Site Consideration if applicable.

Step 11 Select the **Edit** menu item.

Step 12 Select the **Save** option to save your entries or the **Cancel** option to remove your entries.

An X will appear in the Sel column next to the site that you selected to indicate that it should be included in the TPP. If the selected site is the CCMM, an X will appear in the CCMM column.

**NOTE:** Repeat Steps 2 through 13 of this procedure for each Training site that you select.

### 3.10.12.1 Identifying Resources for the CCMM Training site

Provide a best estimate of the known and anticipated resources necessary to implement the training for the CCMM. This part of the TPP is the Resource Requirements List (RRL).

**To build an RRL:**

Step 1 Open the Training site Summary window by performing one of the following:
   a. With the TPP folder open in the Course Tree Structure; double click on the Training sites folder in the upper right hand panel,
b. Expand the TPP and open the Training sites folder in the Course Tree Structure and click on the Go button on the toolbar,
c. After selecting the course, access the TPP window by either selecting the Document menu item and the Training Project Plan (TPP) sub-menu item or click on the TPP icon. Select the Contents menu item and the Training sites sub-menu item.

Step 2 From the Site Select window use your mouse to highlight the CCMM Training site that you want to work on. The site must have an X in the Sel column to indicate that it has been selected.

Step 3 Select the RRL menu item.

After you have selected the RRL menu item from the Training site Summary window, AIM I will present the TPP RRL window, which contains the following menu bar items:

- Options
- Resource
- Site RRL
- Edit
- Exit
- Help

When you select a Resource item from the RRL, AIM I will present a drop-down list that contains the following items:

- Facility
- Funding
- Manpower
- Calibration
- Computers
- Consumables
- Equipment (Equipment identified in the Fault Applicability List)
- Equipment Refurbished
- Films
- Hand Tools
- IETM
- IMM
- Maintenance Trainers
- Miscellaneous Materials
- Ordnance
- Photographs
- Prefaulted Modules
- References
- Slides
- Software
- Special Tools
3.10.12.1.1 Facility

Identify requirements for MILCON or special projects for facilities modification. Such requirements are highly situation-specific. See OPNAVINST 11102.1 and NETCINST 11102.2 for detailed facilities documentation requirements.

To enter Facility data for the Training site:

Step 1 From the TPP RRL window select the Resource menu item.

Step 2 Select the Facility option from the drop-down menu.

Step 3 Add the required information in the AIM I Text editor. If no information is required, leave blank and this heading will not print out as part of the TPP.

Step 4 When you are finished, select the Edit menu item.

Step 5 Select the Save option to save your entries or the Cancel option to remove your entries.

Step 6 To return to the TPP RRL window, select the Exit menu item.

3.10.12.1.2 Funding

For your TPP, you should identify, by appropriation source [e.g.; O&MN (Operations and Maintenance, Navy), OPN (Other Procurement Navy)] the Activity Group/Sub Activity Group (AG/SAG) and the initial or recurring costs. For existing Courses, identify only the additional costs required to implement training.

The Appropriation source, AG/SAG, and Expense fields are required fields. After entering the initial costs for the first fiscal year, the remaining fiscal years will indicate the amounts required in addition to or less than the initial cost. When a negative precedes an amount (-), AIM I will place the amount in parentheses ($1000.00) to indicate that it is a negative amount. If there are no parentheses, you can assume the amount is positive.
To enter the Funding data for the Training site:

Step 1 From the TPP RRL window select the Resource menu item.

Step 2 Select the Funding option from the drop-down menu.

Step 3 Select the Options menu item and the Add option. You will automatically be placed in the Appropriation field. Type in the appropriation.

You can use the Tab key to advance through the fields. To go backward through the fields, press Shift + Tab. You can also use the arrow keys. If you hit the Tab key at the end of the last year, a new line will be created.

Step 4 In the Approp column type in the Appropriation source.

**NOTE:** The appropriation source, AG/SAG, and expense are required entries, which you can find in NAVSUP 437 or the MILSTRIP/MILSTRAP Desk Guide.

Step 5 Type in the AG/SAG and the expense.

Step 6 Under the year enter the dollar amount. When you enter whole numbers, AIM I automatically formats them as currency entries that include two decimal places.

Step 7 In the bottom pane of the window there is a Note field where you can add comments about the funding entries.

Step 8 When you have completed entering the data, select the Edit menu item.

Step 9 Select the Save option to save your entries or the Cancel option to remove your entries. To return to the TPP RRL window, select the Exit menu item.

3.10.12.1.3 Manpower

For new Courses or Revisions, you should identify Officer, Enlisted, Civilian, Contractor, and Support billets required, the number of billets authorized, the number of compensated billets that can be provided, and the difference (if any). For Cancellations, identify all billets that will be offered up. Specify differences if there are any.

To enter the Manpower data for the Training site:

Step 1 From the TPP RRL window select the Resource menu item.

Step 2 Select the Manpower item from the RRL drop-down list. AIM I will present the TPP Manpower window.
Step 3  Use your mouse to highlight the field in which you will enter data.

**NOTE:** The Tab key will move you from field to field, but you must use the mouse or arrow keys to move from line to line.

Step 4  For Officer, Enlisted, Civilian, Contractor, and Support personnel, type the number of billets required, number of billets authorized, number of compensated billets, and number of billets available that can be provided. Type the differences in the delta field.

Step 5  In the bottom pane of the window there is a Note field where you can add comments about the manpower entries.

Step 6  When you have completed entering the data, select the Edit menu item.

Step 7  Select the Save option to save your entries or the Cancel option to remove your entries. To return to the TPP RRL window, select the Exit menu item.

### 3.10.12.1.4 RRL Items

AIM I lists the RRL items that have been entered in the Site RRL via the Site Utility. For your TPP RRL, you must select items that already appear in the Site RRL.

**Use one of the two following methods for adding an RRL item to the Training site:**

**First Method:**

Step 1  From the TPP RRL window select the Resource menu item.

Step 2  Select any discrete item from the drop-down menu listed below Manpower.

In the lower portion of the window, you will see the items that appear in the Site RRL.

Step 3  Double click on the Site RRL item desired. AIM I will add it to the TPP RRL list for your TPP. The item will appear in the upper (Course RRL) portion of the window.

Step 4  Highlight the field for Quantity on Hand and enter the quantity on hand at the Training site.

Use the Tab key to advance from the Quantity on Hand field to the Quantity Required field.

Step 5  Type in the Quantity Required.
Step 6  Repeat Steps 3 through 5 for each item desired.

Step 7  If the Resource item required is not listed in the Site RRL, you can add the item to the Site RRL by performing the following:

**NOTE:** An IETM RRL item can only be added to the Site RRL from the Admin Utility. To Add/Modify/Delete an IETM RRL item in the Site RRL contact the AIM Administrator.

- Select the **Site RRL** menu item from the TPP RRL window.
- Highlight the appropriate Resource type.
- Select the **Options** menu item and the **Add Resource** option or right click on the Resource folder and click on the **Add** menu item.
- Add the appropriate data in the fields presented to identify the item. Exit and save your entry.
- Exit the Site RRL window to return to your TPP RRL.

Step 8  Select the **Save** option to save your entries or the **Cancel** option to remove your entries.

Step 9  To return to the main TPP Site Summary window, select the **Exit** menu item.

**Second Method:**

Step 1  From the TPP RRL window select the **Resource** menu item.

Step 2  Select any discrete item from the drop-down menu listed below **Facility**.  
In the lower portion of the window, you will see the items in the Site RRL.

Step 3  Click on the Site RRL item required.

Step 4  Select the TPP RRL **Options** menu item.

The **Options** menu item contains the following options:

- **View RRL:** Allows you to view all the data recorded in the Site RRL for the highlighted TPP RRL or Site RRL item.
- **Select TPP RRL:** Allows you to add the highlighted Site RRL item to the TPP.
- **Unselect TPP RRL:** Allows you to delete a TPP RRL item previously selected for your TPP.
- **Explain Flag:** Allows you to view the explanation for the flag if the item contains a flag in the Flag column.
- **Remove Flag:** Allows the AIM Administrator to remove the flag for the highlighted item.

Step 5  Select the **Select TPP RRL** option.
Step 6  Click on Quantity on Hand field and enter the quantity on hand at the Training site.

Step 7  Use the Tab key to advance from the Quantity on Hand to the Quantity Required field and type in the Quantity required.

Step 8  Select the **Save** option to save your entries or the **Cancel** option to remove your entries.

Step 9  Repeat Steps 3 through 8 for each item required.

Step 10 If the Resource item required is not listed in the Site RRL, you can create the item by performing the following:

**NOTE:** An IETM RRL item can only be added to the Site RRL from the Admin Utility. To Add/Modify/Delete an IETM RRL item in the Site RRL contact the AIM Administrator.

- Select the **Site RRL** menu item from the TPP RRL window. Highlight the appropriate Resource type.
- Select the **Options** menu item and the **Add Resource** option or right click on the Resource folder and click on the **Add** menu item.
- Add the appropriate data in the fields presented to identify the item. Exit and save you entry.
- Exit the Site RRL window to return to the TPP RRL.
- Repeat the sub-steps described above for each item added to the Site RRL that is required in the TPP.

Step 11  To return to the main TPP Site Summary window, select the **Exit** menu item.

### 3.10.12.2 Select Additional Training sites

**To select additional Training sites:**

**NOTE:** If only the selected Training site(s) appear in the Training site Summary window select the **Options** menu item and click on the **Show Selected Sites Only** option to remove the check mark. All sites available from the Training site Utility will appear for selection.

Step 1  Open the Training site Summary window by performing one of the following:

a. With the TPP folder open in the Course Tree Structure; double click on the Training sites folder in the upper right hand panel,

b. Expand the TPP and open the Training sites folder in the Course Tree Structure and click on the **Go** button on the toolbar,

c. After selecting the course, access the TPP window by either selecting the **Document** menu item and the **Training Project Plan (TPP)** sub-menu item
or click on the TPP icon. Select the **Contents** menu item and the **Training sites** sub-menu item.

**NOTE:** Training sites are added to the list through the AIM I Utilities module. If you do not see the Training site that you want to select, ask your AIM Administrator to add it via the Site Administration Utility.

Step 2  
Click on the desired Training site.

Step 3  
Select the **Options** menu item and the **Select Site** option.

Step 4  
AIM I will prompt “Copy CCMM data to this selected Site?” Perform one of the following:  
- Click on **Yes** to copy the CCMM Course Data, and RRL Manpower and Funding data to the data fields of the site highlighted.  
- Click on **No** to enter data in the blank fields provided.  
- Click on **Cancel** to terminate the **Select Site** option.

Step 5  
If you selected **Yes** AIM I will prompt “Copy RRL data from the CCMM site to this selected site?” If you want to create a separate RRL for each site click on **Yes**, if not click on **No**.

Step 6  
After answering the prompts, enter the CDP for the selected site and modify the Course Data and Resources as necessary.

3.10.12.3 **Change the CCMM to Another Selected Site**

**To change the CCMM to another selected site:**

Step 1  
Open the Training site Summary window by performing one of the following:  
- With the TPP folder open in the Course Tree Structure; double click on the Training sites folder in the upper right hand panel,  
- Expand the TPP and open the Training sites folder in the Course Tree Structure and click on the **Go** button on the toolbar,  
- After selecting the course, access the TPP window by either selecting the **Document** menu item and the **Training Project Plan (TPP)** sub-menu item or click on the TPP icon. Select the **Contents** menu item and the **Training sites** sub-menu item.

**NOTE:** Training sites are added to the list through the AIM I Utilities module. If you do not see the Training site that you want to select, ask your AIM Administrator to add it via the Site Administration Utility.

Step 2  
Click on the site desired for CCMM.

Step 3  
Select the **Options** menu item and the **Select CCMM** option.
Step 4  AIM I will prompt, *This Site is selected as the new CCMM. CCMM data from old CCMM Site will replace this Site’s data. Continue?*

Step 5  Click on **Yes** to select the highlighted site as the new CCMM, or click on **No** to terminate the option.

Step 6  If you selected a new CCMM modify the Course and RRL data fields as necessary. AIM I will copy all RRL data to the new CCMM.

### 3.11 Deleting a TPP

Deleting a course from the Course Select window will delete the associated TPP.

The Course Select window **Delete** option can be used to remove a New, Cancellation (for a course not contained in the AIM database), or Revision TPP from the AIM I database. When you highlight a TPP from the Course Select window and select the **Delete** option from the **Options** menu bar item, AIM I will check your privilege level for the highlighted TPP and the status (locked or unlocked) of the highlighted TPP.

- Your privilege level is checked to verify that you have the proper privilege level to delete the selected TPP.
- If your privilege level is not Maintain/Delete a message box will pop open to advise that you do not have the privilege level required to delete the selected TPP. The message box will also tell you whom to contact for assistance.
- If your user privilege level is AIM Administrator or if you were the developer of the TPP, AIM I will check the status of the highlighted TPP.
- If the TPP highlighted is locked, a message box will pop open to advise you that the TPP is locked and cannot be deleted.
- If the TPP highlighted is unlocked, AIM I will ask you to confirm the deletion of the selected TPP or to cancel the deletion.
- If the course is selected in a TPS, you cannot delete the TPP. AIM I will prompt, *Course is in use cannot delete*. The course must be deleted from the Course List in the TPC before the associated TPP can be deleted.

**To delete a New, Cancellation (for a course not contained in the AIM database) or Revision TPP:**

- **Step 1**  Select **Course** from the AIM I main window menu bar and click on the **Select** sub-menu item.
- **Step 2**  Use your mouse to highlight the TPP you want to work on.
- **Step 3**  Select **Options** from the Course Select window menu bar and click on the **Delete**
To delete a Cancellation (for a course contained in the AIM database) or Modification TPP:

Step 1 Select Course from the AIM I main window menu bar and click on the Select sub-menu item.

Step 2 From the Course Select window click on the course that contains the Cancellation or Modification TPP and click on the Select menu item.

Step 3 From the Course Tree Structure Expand the TPP folder and click on the Cancellation or Modification folder.

Step 4 Right click and select the Delete TPP sub-menu item. AIM will ask for confirmation.

3.12 On-Line Help

AIM I includes complete documentation in an accessible help system that includes searchable on-line help files, .pdf-based documents, and media-enhanced demonstrations of certain AIM I functions.

The On-line Help item under the Help menu provides three different methods for accessing information:

- Contents – shows the table of contents for the Help files
- Index – shows the information in alphabetical order
- Find – allows you search for keywords or phrases

Each of these methods may be accessed by clicking on the appropriate tab in the Help Topics window. Refer to Chapter 1 paragraph 1.7 for more information about On-line Help.

3.13 Summary

Chapter 3 provided instruction on creating a new TPP and on selecting a TPP that already exists. It explained how to complete the contents of a TPP by writing a justification, listing safety risks and hazards, identifying the development methods and compensation, planning milestones, and writing a course overview or comments. It also provided options for selecting the Training sites at which the course will be taught and identifying the resources required to teach the course at each site. Other options that Chapter 3 addressed included locking and unlocking a TPP and
printing. Once the TPP is Locked and the information is copied to the TCCD you can proceed to the TCCD and develop the TCCD front matter, RRL for the Course, COI, and CMS.
CHAPTER 4

THE TEST MODULE

4.0 THE TEST MODULE
4.1 GETTING STARTED
  4.1.1 Test/Learning Objectives Window
    4.1.1.1 Passing Criteria
    4.1.1.2 Criticality Index
    4.1.1.3 Test Items Option
  4.1.2 Test Support Materials
    4.1.2.1 Testing Plan
    4.1.2.2 Instructions for the Proctor
    4.1.2.3 Instructions for the Trainee
  4.1.3 Test Development
(This Page Intentionally Left Blank)
4.0 THE TEST MODULE

Developing a test using AIM I is a multi-part process beginning with developing the written test items for the line items in the PPP module that link to the TLOs in the COI. All test items developed will be linked to the TLOs they support, the associated reference, and any graphics and saved to the database with these links intact. After the test items have been built and locked or approved in the PPP module they can be selected to develop a test for your course in the Test Module.

The test items are inherently linked to each PPP Table line item in support of the Instructional Systems Design (ISD) process.

Completion of the AIM I Testing Module is not required to make the course status complete or prevent the TCCD from being locked.

This version of AIM I does not support performance testing.

4.1 GETTING STARTED

Test developers can access the AIM I Test Module from within a specific course for which they have privilege in AIM I and develop test materials for that course. An AIM Administrator can grant an individual up to seven privileges for the Testing Module associated with a course through the AIM I Administration Menu.

- View
- Edit
- Lock
- Grant
- Approve/Unapprove
- Remove Flag
- Maintain/Delete Tests

The AIM User that develops a course has the default privileges of View, Edit, Lock, Grant, and Maintain/Delete Tests and can use the Grant Privilege option to grant other users privilege to View, Edit, Lock, and Grant. The user that has been granted Approve/Unapprove privilege by the AIM I Administrator can approve/unapprove test items and tests. Users can also be granted privilege to develop test items for approved PPP tables by the AIM Administrator.
The AIM I Test Module is accessed from the AIM I menu by selecting the Document menu item and the Testing sub-menu item or by clicking on the Test icon.

The Test module is accessed from the AIM I menu, after selecting the applicable course, by selecting the Document menu item and the Testing sub-menu item, by clicking on the Test icon or opening the Testing folder in the Course Tree Structure, right click of the mouse and selecting GoTo.

When the Test module is selected the Tests window opens for the course selected (Figure 4-1).

![Tests Window](image)

Figure 4-1. Tests Window

After test questions have been created and approved for the PPP Table line items you can Add tests for your course. To develop Test Items for PPP table line items refer to Chapter 5, The Personnel Performance Profile (PPP) Module, paragraph 5.3.4.4.

The Tests window contains Options, Contents, Edit, Exit and Help Menu items.

The Options menu item contains the following options:

- **Modify/View** – edit or view the highlighted test in the list
- **Add** – add a new test to the list
- **Delete** – delete the highlighted test from the list
- **Copy** - copy the highlighted test to create a new test
- **Create New Version** – create a new version of the test highlighted
- **View/Resequence Test Items** – view and resequence the test item identified on the highlighted test.
- **Grant Privilege** – change privilege(s) for individuals to control access to Tests, Test Items, Testing Plan and Instructions for the Proctor and Trainee.
- **Print Preview** – viewing, printing, and developing PDF files for the highlighted test.
- **Print** – printing the highlighted test.
- **Explain Flag** – view the explanation for the Maintenance (X) flag or System generated (@) flag which can appear in the Flag column of the Tests window.
- **Remove Flag** – remove the Maintenance/System flag.

The **Contents** menu item contains a sub-menu with the following items:
- **Test Items** – opens the Test/Learning Objectives window to **Modify/View** test questions, identifying the Criticality Index and assign a Passing Criteria for a TLO.
- **Testing Plan** – opens the Test Plan window from which you can also create a Test Plan Matrix to identify all Tests that will be developed to support the course.
- **Instructions for the Proctor** – opens a boilerplate set of instructions for the Proctor that can be edited.
- **Instructions for the Trainee** - opens a boilerplate set of instructions for the Trainee that can be edited.

### 4.1.1 Test/Learning Objectives Window

Selecting the Tests window **Contents** menu item and the **Test Items** sub-menu item opens the Test/Learning Objectives window that displays a menu bar that contains **Options, Edit, Exit**, and **Help** menu items (*Figure 4-2*).
The left hand grid of the Test/Learning Objectives window contains the structure of the course. Opening the Part, by clicking on the ‘+’ block, displays the Sections of the Part and opening a Section displays the Topics. Opening a Topic folder displays the TLOs contained in the Topic in the right hand grid.

The right hand grid of the Test/Learning Objectives window contains the TLO Number, the number of test questions written for the PPP table line item, TLO text, Passing Criteria, Criticality Index, and Flag column for each objective.
The Test/ Learning Objectives window **Options** menu item provides the following options:

a. **Test Items** - Allows you to select the Test Items for TLO window for the highlighted TLO. From this window you can Modify/View Fill-in-the-blank, Multiple Choice, True/False, and Two Column Matching test questions that have been developed for the line item in the PPP table that is linked to the TLO. *To develop Test Items for PPP table line items refer to Chapter 5, The Personnel Performance Profile (PPP) Module, paragraph 5.3.4.4.*

b. **Criticality Index** - Allows you to select the Criticality Index WorkSheet window for the highlighted TLO.

c. **Print Preview** – Allows you to view all the test items written for a TLO, as they would appear on a test, print, and save to a PDF file.

d. **Print** - Allows you to print all the test items for the highlighted TLO.

e. **Explain Flag** - Allows you to view the Maintenance Record for the TLO flagged. The Maintenance flag "X" can indicate that the test item was added, deleted, or modified. The System flag (@) can indicate that the TLO/resource/graphic linked to the Test Item was modified and is an alert that the Test Item may require a maintenance action.

e. **Remove Flag** - Allows an individual with Remove Flag privilege or the AIM Administrator to remove the flag and maintenance record from the item prior to approving associated test items.

### 4.1.1.1 Passing Criteria

**Passing Criteria** - The default value for this field is 100%. The field is intended as a reminder to the test developer as to the minimum passing level of responses to questions based on this TLO. All safety items should be tested at 100%. The test developer can modify the default value by clicking in the Passing Criteria field, delete the existing data and replace it with the new/updated information.

### 4.1.1.2 Criticality Index

**Criticality Index** - The Criticality Index is a combination of three factors: (1) Criticality, (2) Difficulty, and (3) Course Relation. Each Criticality Index entry will include one number (0-3) from each of the three factors. The higher the number the more critical this learning objective is to the overall objectives of the course. During test development the TLOs will be displayed in order of Criticality Index from the highest to the lowest.

To enter the Criticality Index double click in the Criticality Index box or select Criticality Index from the **Options** drop-down menu. The Criticality Index Work Sheet window will open for the highlighted TLO (*Figure 4-3*).
Select the appropriate value for Criticality, Difficulty, and Course Relation, 0-3. The sum total of the three values will be saved as the Criticality Index for the Enabling Objective.

**NOTE:** All safety related items should automatically be rated as a 9.

### 4.1.1.3 Test Items Option

Selecting the **Test Items** option opens the Test Items for TLO window, which contains a list of the current test items for the selected TLO (*Figure 4-4*).
The Test Items for TLO window contains:

- TLO Text field which contains the text of the TLO selected
- The PPP table and line item number linked to the test item
- Type column which identifies the type of questions that have been created for the EO:
  - Fill-in-the-Blank
  - Multiple Choice
  - True False
  - Two Column Matching
  - Performance
- Sequence column that identifies the number of test questions written for each type of question.
- Item Text column which displays the text of the stem of the question.
- Status column - which can contain:
  - I - Incomplete - Not all required information, noted by an asterisk (*) in the field, is included.
  - C - Complete - All required information has been included. Can be edited by individuals with Edit privilege. Can be Locked by individuals with Lock privilege.
  - L – Locked. – Cannot be edited by individuals that do not have Lock/Unlock privilege.
A - Approved – If you have Approve/Unapprove privilege the test item can be can be Approved for use in a test or Unapproved to remove it from a test, which also unapproves the test it was selected in.

- Flag Column - A maintenance flag (X) in this column will inform you if any test item, has been modified. A system generated flag (@) will inform you if any material linked to the TLO has been modified and no maintenance action has been completed on the test item.

The Test Item for TLO window contains the following menu items:

- **Options** menu item contains the following options:
  - **Add** option to develop **Fill-in-the blank, Multiple Choice, True/False, Two Column Matching** and **Performance** type questions. *This option is only enabled in the PPP module.*
  - **Modify/View Test Item** option to modify the highlighted test item or view a locked or approved test item.
  - **Copy** option to copy the highlighted question to make another. *This option is only enabled in the PPP module.*
  - **Delete** option to delete the highlighted test item if it is unlocked or incomplete. *This option is only enabled in the PPP module.*
  - **Print Preview** option to view the test question written for the EO as it would appear when printed. When the **Print Preview** option is selected the Printer Setup window will open, which permits you to add ‘Page X of Y’ for page accountability, Setup Header/Footer for a classified test, and select the Graphic location.
  - **Print** option to print the test item to the default printer. When the **Print** option is selected the Printer Setup window will open, which permits you to add ‘Page X of Y’ for page accountability, Setup Header/Footer for a classified test, and select the Graphic location.
  - **Explain Flag** option to retrieve the maintenance explanation for a flagged test item.
  - **Remove Flag** option to allow an individual with Remove Flag privilege to remove a flag from a test item prior to approval of the item.

- **Exit** menu item to return to the Test/TLOs window.
- **Help** menu item to retrieve the Test Module On-Line Help menu.
4.1.2 Test Support Materials

The test support materials can be developed from the Tests window by selecting the Contents menu item and the sub-menu items; Testing Plan, Instructions for the Proctor and Instructions for the Trainee. The Testing Plan lists all of the evaluation instruments that will be used to determine satisfactory completion of desired learning outcomes and details remediation and retest criteria allowed. Completion of these materials is optional. These materials are not required to complete or lock any materials in AIM I. They also are not required to complete the development of tests using the AIM I Testing Module.

4.1.2.1 Testing Plan

To create a Testing Plan:

Step 1 From the Tests window; select the Contents menu item and the Testing Plan sub-menu item. AIM I will open the Testing Plan window.

Step 2 If you are revising a previously approved testing plan enter the appropriate alpha/numeric character in the Version field.

Step 3 Click on the arrow for the Status field and click on the appropriate status. Options include:

(1) Incomplete - This status is the default status. When all required fields (fields containing an asterisk) have been filled out the status automatically changes to Complete.

(2) Complete – All required fields contain an entry. This status can be changed to Locked or Approved by the Testing Plan developer.

(3) Locked - This signifies that the Testing Plan is ready for review by the Testing Administrator. The Testing Plan cannot be edited until the status is changed back to Complete.

(4) Approved - This version of this Testing Plan has been Approved. When the Status of the Testing Plan has been changed to Approved, the login name of the Testing Administrator will automatically be inserted into the Approval field. To modify an Approved Testing Plan, the status must be changed back to Complete by the Approval authority.

Step 4 The Date field is editable. It automatically reflects the date when the Testing Plan window was first accessed. When the Status changes, click on the date field and enter the date that corresponds to the change in Status.
Step 5  Click on the Purpose field and enter the purpose of the Testing Plan.

**NOTE:** The Course Overview field reflects the Course Overview developed in the TPP and is not editable.

Step 6  Click on the Minimum Passing Grade field and enter the alpha/numeric passing grade (e.g., SAT, 70, etc.). You may also enter individual grade requirements if more than one standard applies across the course.

Step 7  Click on the Justification and/or Comments field and enter the rationale for establishing a Minimum Passing Grade that deviates from the Naval Education and Training Command (NETC) standard.

Step 8  Click on the Test Procedures and/or Constraints field and enter text describing any situation that prevents testing of the objectives and explain what actions have been taken to eliminate the constraints. Examples could include local modifications to the CCMM Approved Testing Plan due to substituting Training Unique Equipment (TUE) for Technical Training Equipment (TTE).

Step 9  Enter the Developer and Reviewer authority names as the Testing Plan completes the associated phase.

Step 10 Select the **Contents** menu item and the **Test Plan Matrix** sub-menu item. AIM I will open the Test Plan Matrix window.

Step 11 Select the **Options** menu item and the **Add** option.

Step 12 For the Test Type field, click on the arrow and select from the drop-down menu.

Step 13 Enter the minimum grade.

Step 14 Enter the percent that the test applies toward the student's total grade. This adds to the Total Weight, which can be viewed from the Testing Plan cover page. When all test percentages are added they must equal 100% for the Test Matrix to be complete.

Step 15 If there are retest criteria click on the Retest field and the arrow and select Yes from the drop-down menu. The Retest field defaults to a No entry.

Step 16 Click on the Retest Criteria, if applicable, and describe the review, remediation, and retesting procedures.
Step 17 Select the Edit menu item and the Save sub-menu item.

Step 18 Select the Exit menu item to return to the Testing Plan Window.

Step 19 Select the Exit menu item to return to the Tests window.

4.1.2.2 Instructions for the Proctor

To create instructions for the proctor:

Step 1 From the Tests window; select the Contents menu item and the Instructions for the Proctor sub-menu item.

Step 2 If there are no instructions saved to the database, AIM I will inform you and ask if you want to create them. Click on "Yes" to continue. AIM I will open the Test Instructions for the Proctor window, which is an AIM I text editor window containing boilerplate information that can be edited as necessary.

Step 3 To import a text file; select the Options menu item and the Import Text File option. This will open the Import Text File window and you can specify the path and location of the file. Click on OK and the text file will be imported into the AIM I text editor.

Step 4 Enter the required text in accordance with your specifications.

NOTES:

(1) Sample text files for Instructions for the Proctor and Trainee have been included in the default AIM I directory. They can be selected by selecting the Import Text File option from the Options drop-down menu.

(2) Only ASCI Text files can be imported. Word processed or (.wri) files must be converted to ASCI prior to being imported using the Import Text File Option.

Step 5 Select the Edit menu item and the Save sub-menu item.

Step 6 Select the Exit menu item to return to the Tests window.
4.1.2.3 Instructions for the Trainee

To create test instructions for the trainee:

Step 1  
From the Tests window; select the **Contents** menu item and the **Instructions for the Trainee** sub-menu item.

Step 2  
If there are no instructions saved to the database, AIM I will inform you and ask if you want to create them. Click on "Yes" to continue. AIM I will open the Test Instructions for the Trainee window, which is an AIM I text editor window containing boilerplate information and can be edited as necessary.

Step 3  
To import a text file; select the **Options** menu item and the **Import Text File** option. This will open the Import Text File window and you can specify the path and location of the file. Click on OK and the text file will be imported into the AIM I text editor.

Step 4  
Enter the required text in accordance with your specifications.

Step 5  
Select the **Edit** menu item and the **Save** sub-menu item.

Step 6  
Select the **Exit** menu item to return to the Tests window.

4.1.3 Test Development

AIM I gives you the option of manually selecting the test items or letting AIM I randomly generate a test. You will also have the option of developing another test based on the original. This is referred to as **Create a New Version**.

**Create a New Version** develops an alternate test for the original one selected by selecting test items from those available in the database that correspond to the same TLO as the original and are in the same TLO order as the original. AIM I will not duplicate the original test items as long as a sufficient amount of alternate corresponding test items are available in the database.

Selecting the **Add** or **Modify/View** option from the Tests window opens the Test Information window in which you will enter the title of the test, select the type of test (open or closed book, or combination of the two), enter the number of test items the test will include, and enter the time the test will take to complete. From this window you have the option to have AIM I automatically create a test based on the selected TLOs or manually generate a test based on the test items you select for each desired TLO. The Automatic/Manual Select windows contain the
options to select/unselect an individual TLO/Item and unselect all TLOs/Items. Both windows contain Flag columns to indicate when an TLO or test item has been maintained and the options to review the maintenance records for the flagged items. Since all System Flags must be removed from a course before it is approved, the Remove System Flag option is also included.

Tests cannot be approved if any of the test items cited on the test are not approved. When viewed in Print Preview or Printed the test will have “Draft” in all four corners of each page until the test is approved.

To generate a test automatically:

Step 1  From the Tests window; select the Options menu item and the Add option. AIM I will open the Test Information window (Figure 4-5).

Step 2  Enter the Title of the Test.

Step 3  Click on the Type field arrow and select "Open", "Closed", or "Combination" from the drop-down menu to indicate the type of test.

Step 4  In the Duration field enter the number of minutes the students will have to complete the test.

Step 5  In the Required Number of Items in Test field enter the number of questions to be selected for the test.

Figure 4-5. Test Information Window
NOTE: The Date field is filled in automatically by the software and indicates the date of development. The date can be edited until the test is approved.

Step 6  If there are any amplifying notes required for the test enter the text in the Note field.

Step 7  Select the Options menu item and the Select Test Items Automatically option. AIM I will open the Automatic Select window which contains the course structure on the left grid and a right grid with a split window containing the TLOs on the top and the approved test questions for the highlighted TLO on the bottom portion of the window.

Step 8  For each TLO that is to be tested:
   a. In the left grid open the desired Part, by clicking on the ‘+’ block, Section, and open the appropriate Topic folder.
   b. Click on the desired TLO in the top portion of the window.
   c. Select the Options menu item and the Select option. An "X" will appear in the TLO "#" column to indicate the TLO is selected.

Step 9  Select the Options menu item and the Generate option. AIM I will randomly select the test items for the TLO selected and the number of test questions will be reflected in the ‘# Sel’ column next to the TLO and in the Required Number of Items in Test field on the Test Information window.

NOTE: Two Column Matching test items count as a minimum of 4 individual test items. The actual number is based on the number of required matching entries (entries in the left column).

Step 10 Select the Edit menu item and the Save sub-menu item to save the test items to the database.

Step 11 Repeat Steps 8 through 10 for each TLO to be tested.

Step 12 When the selected Test Items field equals the quantity of the Required Items field the note under the TLO text field will change from red to black and state “# out of a required # test items selected”. Select the Edit menu item and the Save sub-menu item. Select the Exit menu item to return to the Test Information window.
Step 13 If no further editing of the test is required; select the Status field down arrow and click on the Lock/Approve status. The status down arrow will not be visible until the correct number of test questions have been selected and there are no residual items.

Step 14 Select the Edit menu item and the Save sub-menu item to save the Test Information to the database.

Step 15 Select the Exit menu item to return to the Tests window.

Step 16 Repeat Steps 1 through 14 for each additional automatically generated test required.

To generate a test manually:

Step 1 From the Tests window; select the Options menu item and the Add option. AIM I will open the Test Information window.

Step 2 Enter the Title of the Test.

Step 3 Click on the Type field arrow and select "Open", "Closed", or "Combination" from the drop-down menu to indicate whether the test is an open book or closed book test, or a combination of the two.

Step 4 In the Required Number of Items in Test field enter the number of questions that will be selected for the test.

Step 5 In the Duration field enter the number of minutes the students will have to complete the test.

NOTE: The Date field is filled in automatically by the software and indicates the date of development. The date can be edited until the test is approved.

Step 6 If there are any amplifying notes required for the test enter the text in the Note field.

Step 7 Select the Options menu item and the Select Test Items Manually option. AIM I will open the Manual Selection window which contains the course structure on the left grid and a right grid with a split window containing the TLOs on the top and the approved test questions for the highlighted TLO on the bottom portion of the window.
Step 8 For each TLO that is to be tested:
a. In the left grid open the desired Part, by clicking on the ‘+’ block, Section, and open the appropriate Topic folder.
b. Click on the desired TLO in the top left grid of the window.
c. Click on the test item desired for the highlighted TLO and select the **Options** menu item and the **Select Test Item** option, or alternatively double-click on the test items desired. The number of test items selected for each TLO will be indicated in the "#" column.

Step 9 When the selected Test Items field equals the quantity of the Required Items field the note under the TLO text field will change from red to black and state “# out of a required # test items selected”. Select the **Edit** menu item and the **Save** sub-menu item.

Step 10 Select the **Exit** menu item to return to the Test Information window.

Step 11 If no further editing of the test is required; select the **Status** field down arrow and click on the Lock/Approve status. The status down arrow will not be visible until the correct number of test questions have been selected and there are no residual items.

Step 12 Select the **Edit** menu item and the **Save** sub-menu item to save the test information to the database.

Step 13 Select the **Exit** menu item to return to the Tests window.

Step 14 Repeat Steps 1 through 13 for each additional manual generated test required.

**To generate an alternate test from an existing test**

This process allows you to generate an alternate series test from a baseline-approved test. The alternate test will have the following attributes compared to the original:

1. Same number of test items
2. Same amount of time (duration)
3. Same Learning Objectives in the same order
4. Different test items, from the original, when available.
To generate the alternate test:

Step 1  In the Tests window, highlight the test that you desire to make an alternate version. The original test must have been Approved.

Step 2  Select **Options**, then **Create New Version**.

Step 3  The alternate version test can be created automatically or manually and when the required number of test items have been selected the test will have a status of Complete and numbered as the next version (vX).

To resequence test items on a test:

This action can only be performed on tests that are not locked or approved.

Step 1  From the Tests or Test Information window; select the **Options** menu item and the **View/Resequence Test Items** option.

Step 2  Click on the test items and drag them to the desired locations. The test item numbers will be automatically updated.

Step 3  Select the **Edit** menu item and the **Save** sub-menu item.

Step 4  Select the Exit menu item to return to the Tests window.

To print preview/print a test:

A Test can be print previewed/printed from the Tests window or from the Test Information window. The Print Preview and Print options have the same functionality from either window. When printing an unapproved test the word “**DRAFT**” is printed in all four corners.

Step 1  From the Tests window, highlight the Test you desire to print preview/print and select the **Options** menu item. Select the **Print Preview/Print** option.

Step 2  From the Printer Setup window (*Figure 4-6*), select from the following:
• **Print ‘Page X of Y’**: used to number the pages of the test. Required for a classified test.

• **Setup Header/Footer**: used to enter one line of text in the header and up to three lines of text in the footer. Required to enter classification of the test in header and footer for a classified test.

• **Graphics on the Current Page**: used when you want to display/print the graphic associated with a test item on the same page as the question.

• **Graphics on the Next Page**: used when you want to display the graphic associated with a test item on the next page after the question.

• **Graphics at the End**: used when you want to display the graphic associated with the test items on the test at the end of the test.

• **Print Answers**: Will display/print the answer key.

**Step 3**  
Click on the OK button after selections have been made on the Printer Setup window.

**Step 4**  
The Print Preview window allows you to view the entire test and/or report and has the **Options** menu item which allows you to select either **Print** or **Save as PDF**. If you select the option to save the test/answers to a PDF file the software will require you to select the directory in which the file will be placed and name the file.

**Step 5**  
If the **Print** option has been selected, select the windows default printer. If multiple copies are desired click on the Properties button and enter the quantity required and click on OK. Click on OK to print.
CHAPTER 5

THE PERSONNEL PERFORMANCE PROFILE (PPP) MODULE

5.0  Personnel Performance Profiles (PPPs)
5.1  PPP Status Levels and Privileges
5.2  Table Types and Line Items
5.3  Working with PPP Tables
   5.3.1  Select the PPP Window
   5.3.2  Create PPP Tables
   5.3.3  Select a PPP Table
   5.3.4  Work with Line Items
   5.3.5  Maintain a PPP Table
   5.3.6  Copy a PPP Table
   5.3.7  Delete a PPP Table
   5.3.8  Find a PPP Table
   5.3.9  Grant Privilege for a PPP Table
   5.3.10 Lock and Unlock a PPP Table
   5.3.11 List Related Materials
   5.3.12 Print Preview a PPP Table
   5.3.13 Print a PPP Table
5.4  Summary
5.0 PERSONNEL PERFORMANCE PROFILES (PPPs)

The AIM I main menu PPP option and icon will help you build the foundation of the training system: the Personnel Performance Profile (PPP). A PPP is a list of the minimum skills and knowledge required to operate and maintain an equipment, subsystem, or system; to perform a task or function; or to obtain background knowledge and skills to support further training.

Because the PPP is arranged and printed in tabular form, it is often called a PPP table.

5.1 PPP Status Levels and Privileges

Status levels and privileges are assigned to a PPP to provide a level of administrative security. Privileges minimize unauthorized use of the system by specific users. Status levels limit the type of actions that a user can perform on a PPP.

The status levels for PPPs and the identifiers that will appear on the screen are:

- Locked (L)
- Complete (C)
- Incomplete (I)
- Approved (A)
- Suspended (S)

Unlocked PPPs are under development. A locked PPP has been fully developed but has not yet been approved. A locked PPP appears in the TPS module for your selection to create TLAs. A locked PPP can be unlocked and modified at any time prior to its approval.

A complete PPP is a PPP in which every Skill line item is linked to at least one Knowledge line item. In the case of Equipment/Subsystem/System (ESS) PPPs, AIM I automatically links Skill line items to their corresponding Knowledge line items. However, if you add Skill line items after you save your answers to the questions, you will have to link the line items manually. The status level of Incomplete will appear on your computer screen if you have not linked each Skill line item with at least one Knowledge line item.

If you do not complete the question-and-answer portion when you create an ESS PPP, but you want to save the work that you have completed, you have the option of suspending development of the PPP. The Suspend status will change to Complete when you finish answering the required questions.

An Approved PPP is one that is approved for use and cannot be modified unless a change or revision is created. There are two basic privilege levels in AIM I: AIM Administrator and AIM User.

- **AIM Administrator**: Enables you to exercise every option within the AIM I software, including the Grant option.
• **AIM User**: Enables you to develop material and view other users materials. As an AIM User, you can only access the Change Password, Site RRL, Graphics, Admin, and Delete Proposed Training Material modules of the Administration and Utilities area of AIM I.

The AIM Administrator maintains the second privilege structure, which controls who can perform what functions on each TPP, PPP table, TPS, and Course. The AIM Administrator executes the Grant Privilege option (located in the Utilities main menu under the Admin/Utility option) and assigns the privilege levels required for each AIM User.

The privilege levels granted to a user determine what actions the user may perform. Eight levels of privileges are used in the PPP module.

For more information about AIM User and Administrator privileges, see Chapter 1, paragraph 1.5 and Table 1-1.

### 5.2 Table Types and Line Items

There are three types of PPP tables: Equipment/Subsystem/System (ESS), Task/Function (T/F), and Background (BG).

You create ESS PPPs by answering a series of questions. The questions and answers form an analysis of the operational and maintenance requirements of specific equipment, a group of equipment functioning as a subsystem, or a group of subsystems functioning as a system. Task/Function and Background tables are created via direct user input, without any questions.

The PPP is composed of line items. Line items are statements of overt behaviors that a trainee could perform. The statements are divided into two broad classifications: Skill and Knowledge. When you create an ESS PPP, AIM I automatically generates both the necessary Skill and Knowledge line items from your answers to the system-generated questions. The program stores the relationship between the Skill line items and their Knowledge counterparts for use later in the program. When you create a Task/Function or Background table, AIM I automatically links the skills to the Knowledge line items that are created as a result of copying the skills.

### 5.3 Working with PPP Tables

#### 5.3.1 Select the PPP Window

**To select the PPP window:**

- **Step 1** Click on the AIM I icon and login using your login name and password.
Step 2  
Select the **Document** menu item and the **Personnel Performance Profile** option or click on the PPP icon. AIM I will present the PPP window, which is divided into three sections:

- A list of the PPPs in the AIM I database, which includes the PPP Number, Revision, and Change data; the PPP Title; the PPP Type; the PPP Status; and Flags. The Status field indicates that a table is approved, locked, complete, incomplete, or suspended. The Flag field indicates with an "X" that the table has been revised or changed.
- A Cover Page for the PPP currently highlighted contains fields for the PPP Table Number, Revision and Change Designator, Title, Table Type, Short Title, Developing Agency, Approving Agency, Approval Date, Modification Data, and Drawing Number.
- A menu bar, which lists **Options**, **Edit**, **Exit**, and **Help** menu items. The **Options** menu item provides the following options:
  - **Create**: For developing a new PPP table.
  - **Maintain**: For developing a change or revision to an approved PPP table.
  - **Select**: For selecting the line items of the highlighted PPP table.
  - **Copy**: For developing a PPP table that is very similar to an existing PPP table and will require only minor editing to complete.
  - **Delete**: For deleting the highlighted PPP table.
  - **Find**: For finding the desired PPP table in the list.
  - **Grant**: For granting privilege levels to users, for the highlighted PPP table, by users who have been given the Grant privilege by the AIM I Administrator or by the user who originated the PPP table. Grant can be used by the AIM I User to grant privileges to other AIM I Users to Edit, Lock, and Grant.
  - **Lock**: For locking a PPP table, limiting access to users with Lock/Unlock and higher privilege. (The user must have Lock privilege.)
  - **Unlock**: For unlocking a locked PPP table. (The user must have Lock privilege.)
  - **Related Materials**: For determining the training materials (TPS, TPC, and Course) that cite the PPP table highlighted.
  - **Print Preview**: For looking at the product on the monitor, as it would appear when printed.
  - **Print**: For printing the PPP table or selected pages of the table.
5.3.2 Create PPP Tables

5.3.2.1 Creating an Equipment/Subsystem/System (ESS) PPP Table

AIM I will assist you in creating PPPs. The way that PPPs are created will depend on the type of PPP table to be created and the amount of analysis required. To create a new PPP table that analyzes an equipment, subsystem, or system, AIM I uses interactive questions and answers. If an existing PPP is similar to the one you wish to create, you may copy it.

To create an ESS PPP table from the AIM I main menu:

Step 1 Select the **Document** menu item and the **Personnel Performance Profile** option or click on the PPP icon. AIM I will present the PPP window (*Figure 5-1*).

![Figure 5-1. Personnel Performance Profile Window](image)

Step 2 Select the **Options** menu item and the **Create** option.

Step 3 AIM I will provide you with a blank Cover Page to create your PPP table. Perform the following:

**WARNING:** After you save the Cover Page information, you may not change the Table Type, or Short Title.
• Enter the PPP Table Number in the PTN field.
• Enter the PPP Table Title.
• Select the Table Type (Equipment, Subsystem, or System).
• Edit the Short Title, which will be used in each PPP line item statement.
• Select the Development Agency from the list in the database. If your agency is not on the list, ask your AIM I Administrator to enter the agency via AIM I's Agency utility.
• Select the Approval Agency from the list in the database. If your agency is not on the list, ask your AIM I Administrator to enter the agency via AIM I's Agency utility.
• Leave the Approval Date blank until you receive an Approval Authorization from the Approving Agency.
• Enter any modification the ESS has undergone (e.g., SPALT, ORDALT, SHIPALT).
• Enter the appropriate Drawing Number(s) for the ESS.

Step 4  
Select the **Edit** menu item and the **Save** option to save the Cover Page information. AIM I will present the Create PPP window (*Figure 5-2*), which contains questions derived from the algorithm in NAVEDTRA 131B, Volume 1, Supplement, for PPP table development.

When you are developing ESS tables, you will answer questions in the following categories. The categories appear in the order shown below.

1-7  Documentation  
2-1/1-5  Operation/Operational Description  
2-2/1-6  Maintenance/Maintenance Description  
1-1  General Description  
1-2  Physical Description  
1-3  Functional Description  
1-4  Interface Description
For questions that require a Yes response, click on the question to change the answer from a No to a Yes response. Or, click on the N with the mouse to change it to a Y.

**NOTE:** The questions may also lead you to enter item text for the creation of sub-items. If you do not want to create sub-items at this time, you can add them later after AIM I has constructed the PPP table. AIM I will still create the main line item based on your Yes reply to the question. Select the **Exit** menu item to return to the questions if no sub-items are desired.

- To develop a sub-item, click on the item to enter the Item Text and type in the necessary information. For Technical Documentation you can either type the text or select the Reference from the Site RRL. The item will become a sub-item of the line item created by AIM I *(Figure 5-3).*
If additional items are required, repeat the sub steps set forth above until all items have been entered.

After you have completed entering the sub-item(s) desired, select the Exit menu item and select the Yes button to save the sub-item(s) to the database.

Step 5 While you are answering the questions, you can view the line items created by AIM I as a result of your responses by selecting the View menu item. When you want to return to the questions, select the Exit menu item from the View window (Figure 5-4).
Step 6  After answering all of the questions, select the Save menu item in the Create PPP window. AIM I will automatically develop the line items and sub-items based on your response to the questions. AIM I will return you to the PPP window.

**NOTE:** The preceding six steps do not conclude the development of an ESS PPP table. Refer to NAVEDTRA 131B and select the line items to ensure they are stated correctly for the ESS you created. If they are not correctly stated, modify them as necessary. You may need to add/delete line items or sub-items of the categories to cover Skills/Knowledge that the questions did not address or to correct an incorrect response to a question that may have generated a line item you do not need. Refer to section 5.3.4 for instructions on working with line items.
Step 7 If it becomes necessary to add a Skill line item:

- From the PPP window highlight the desired table; then select the **Options** menu item and the **Select** option. AIM I will retrieve the line items.
- Click on the Skill line item that is at the location where the new skill is to be added.
- Select the **Options** menu item and the **Add** option.
- Select **Same Level** or **Lower Level** as desired.
- Enter the desired text in the Item Text field.
- Select the **Edit** menu item and the **Copy** option to copy the text of the skill to create a knowledge line item that directly supports the skill.
- Click on the Knowledge line item at the location where the new knowledge line item is to be added.
- Select **Same Level** or **Lower Level** as desired.
- Select the **Edit** menu item and the **Paste** option.
- Click on the Item Text field for the Knowledge line item you just created and edit the text to change it to a Knowledge line item.
- Select the **Options** menu item and the **Link Skill** option.
- In the Links window, click on the newly added skill; then click on the directly supporting Knowledge line item you just added. Verify that an X appears in the Link column to indicate that it is linked.
- Select the **Edit** menu item and the **Save** option.
- Select the **Exit** menu item to return to the Line Items window.

5.3.2.2 Creating a Task/Function or Background PPP Table

To create a Task/Function or Background PPP table:

Step 1 Select the **Document** menu item and the **Personnel Performance Profile** option or click on the PPP icon. AIM I will present the PPP window.

Step 2 Select the **Options** menu item and the **Create** option.

**NOTE:** Use the Tab key to move from field to field or click on the desired field with your mouse. You can select an item in a pop-up menu by clicking on the item with the mouse or highlighting the item with the arrow keys.

**WARNING:** After you save the Cover Page information, you may not change the PTN, Table Type, or Short Title.

Step 3 AIM I will provide a blank Cover Page on which to create your PPP table. Perform the following:

- Enter the PPP Table Number (PTN) in the PTN field. Background PTNs start with the prefix A, and Task Function PTNs start with the prefix B.
- Enter the PPP Table Title.
- Select the Table Type (Background or Task/Function).
• Edit the Short Title that is to be used in each PPP line item statement.
• Select the Development Agency from the list in the database. If your agency is not on the list, ask your AIM I Administrator to enter the agency via AIM Is Agency utility.
• Select the Approval Agency from the list in the database. If your agency is not on the list, ask your AIM I Administrator to enter the agency via AIM Is Agency utility.
• Leave the Approval Date blank until you receive an Approval Authorization from the Approving Agency.

**NOTE:** Since tables developed for background information, tasks, or functions are not equipment related, entries in the Modification and Drawing Number fields are not required.

**Step 4** Select the **Edit** menu item and the **Save** option to save the Cover Page information. AIM I will present you with the Create PPP window.

If you are developing a Background table, you must develop a list of Skills and supporting Knowledge line items. The numbering scheme for line items will be:

1.
1-1.
1-1-a.
1-1-a- (1)
1-1-a- (1)-(a)

Example:

1. BACKGROUND KNOWLEDGE
   1-1. Describe the basic construction . . .
   1-1-a. Gate
   1-1-a- (1) hinge
   1-1-a- (1)-(a) hinge pin

If you are developing a Task/Function table, the numbering scheme for line items will be:

1.
1-1.
1-1-1.
1-1-1-a.
1-1-1-a-(1)
1-1-1-a-(1)-(a)
Example:

1. KNOWLEDGE
   1-1. BASIC DRIVING
   1-1-1. Describe vehicle inspection points and criteria.
   1-1-1-a. Bumpers
   1-1-1-b. Headlights

Step 5 The Skill line items (2’s) are developed first for Background and Task/Function PPP tables. Highlight the Skill heading and select the Options menu item and the Add option. Select Lower Level to add the first Skill line item for a Background PPP table, or the first category for a Task/Function PPP table.

Step 6 Click on the highlighted Item Text field and enter the text required.

Step 7 It is not necessary to select the Edit menu item and the Save option after adding each line item, but it is prudent to save your entries periodically. To add another line item, sub-item, or category, select the Options menu item, the Add option, and Same Level or Lower Level as desired.

Step 8 Repeat Step 7 until the Skill portion of your PPP table is complete. Select the Options menu item and the Copy Skills option. AIM I will copy your Skill text to the Knowledge portion of the PPP table and give each item a corresponding number. AIM I will automatically link each Knowledge line item to the Skill line item from which it was derived.

Step 9 Edit a Knowledge line item by highlighting the item, clicking on the item, and editing the text as desired. Example: Edit Perform . . . to read Describe . . .

Step 10 If it becomes necessary to add a Skill line item after the Copy Skills option has been completed and the directly supporting Knowledge line items have been edited:

- Click on the Skill line item that is at the location where the new skill is to be added.
- Select the Options menu item and the Add option.
- Select Same Level or Lower Level as desired.
- Enter the desired text in the Item Text field.
- Select the Edit menu item and the Copy option.
- Click on the Knowledge line item above the location where the new Knowledge line item will be added to support the skill added above.
- Select Same Level or Lower Level as desired.
- Select the Edit menu item and the Paste option.

**NOTE:** The Copy and Paste Edit options do not allow you to copy more than one line item/sub-item at a time. If the skill you created has sub-items this procedure must be repeated for each sub-item.
• Click on the Item Text field for the Knowledge line item you just created and edit the text to change it to a Knowledge line item.
• Select the **Options** menu item and the **Link Skill** option (*Figure 5-5*).

![Figure 5-5. Line Items Window with Link Skill Selected]

• In the Links window (*Figure 5-6*), click on the newly added Skill; then click on the directly supporting Knowledge line item that you just added. Verify that an X appears in the Link column.
Step 11 When you are done editing the directly supporting Knowledge line items, you can add the indirectly supporting Knowledge line items required following the process set forth in Step 7.

Step 12 When your PPP table is complete, select the **Exit** menu item and save your entries to the database. **Exit** will return you to the PPP window. Your table should have a status of Complete. If your table is incomplete, perform the following:

- From the PPP window, select the **Options** menu item and the **Select** option to retrieve the Line Items window.
- From the Line Items window, select the **Options** menu item and the **Link Skill** option.
- In the Links window, click on the newly added skill; then click on the directly supporting Knowledge line item you just added. Verify that an X appears in the Link column to indicate that it is linked.
- Verify that all Skill line items are linked to at least one supporting Knowledge line item.
- Select the **Edit** menu item and the **Save** option.
- Select the **Exit** menu item to return to the Line Items window.

### Figure 5-6. Links Window

- Select the **Edit** menu item and the **Save** option.
- Select the **Exit** menu item to return to the Line Items window.

<table>
<thead>
<tr>
<th>Skill</th>
<th>Link</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td></td>
</tr>
<tr>
<td>2-1</td>
<td></td>
</tr>
<tr>
<td>2-1-1</td>
<td>X</td>
</tr>
<tr>
<td>2-1-2</td>
<td>X</td>
</tr>
<tr>
<td>2-1-2-a</td>
<td>X</td>
</tr>
<tr>
<td>2-1-2-b</td>
<td>X</td>
</tr>
<tr>
<td>2-1-2-c</td>
<td>X</td>
</tr>
<tr>
<td>2-2</td>
<td></td>
</tr>
<tr>
<td>2-2-1</td>
<td>X</td>
</tr>
<tr>
<td>2-2-2</td>
<td>X</td>
</tr>
<tr>
<td>2-2-3</td>
<td>X</td>
</tr>
<tr>
<td>2-2-4</td>
<td>X</td>
</tr>
<tr>
<td>2-3</td>
<td></td>
</tr>
<tr>
<td>2-3-1</td>
<td>X</td>
</tr>
</tbody>
</table>
Step 13 Select the **Options** menu item and the **Lock** option to lock your PPP table, which makes it available for use in developing or maintaining a TPS/TCCD.

### 5.3.3 Select a PPP Table

Once a PPP table has been created, it can be selected. What the PPP table can be selected for depends upon its status. If the PPP table is:
- **Approved**: The PPP table can be selected for use in developing a TPS, viewing a TPS, or maintaining a TPS (creating a change or revision).
- **Locked**: The PPP table can be selected only for viewing or developing a TPS (Figure 5-7).
- **Unlocked and Complete or Incomplete**: The PPP table can be selected for viewing, editing, or granting privileges to other users for the selected PPP.
- **Suspended**: The questions for creating a PPP can be selected.

To select a PPP table:

**Step 1** From the list of PPPs in the PPP window, highlight the desired PPP by clicking on the table in the list or select the **Options** menu item and the **Find** option and enter the PPP table number desired. View the Status column for the PPP table highlighted.
Step 2  If the Status column indicates that the PPP table is locked and you want to select the PPP table for modification, select the **Options** menu bar item and the **Unlock** option. You will be able to unlock the PPP table only if you have the correct privilege for that table.

Step 3  To find out whether or where the PPP table is cited in other training materials in the database, select the **Options** menu item and the **Related Materials** option. **Related Materials** provides three choices: Training Path System (TPS), Training Path Chart (TPC), and Course (Course). Select each one to view where the PPP table is cited. The **Related Materials** option allows you to determine what training materials will be affected by the modifications you make to the table.

Step 4  To select the PPP table line items, select the **Options** menu item and the **Select** option to retrieve the Line Items window. The **Options** menu item for the Line Items window contains the following options:

- **Add**: To add new line items at the same level as the line item highlighted or at a lower level.
- **Find**: To find a specific line item in the PPP table.
- **Delete**: To delete the line item highlighted.
- **Link Skill**: To link the Skill line items to their directly supporting Knowledge line items.
- **Copy Skills**: Enabled during development of Background and Task/Function PPP tables. To copy all the Skills developed into the Knowledge portion of the table and link the Knowledge line items to their corresponding Skills. The text of the copied Skills can then be modified to address the Knowledge requirement (e.g., modify *Perform . . .* to read *Describe . . .*)
- **Show Test Item Information** – Allows you to toggle the test item information for all line items in the table. Checking this option will display, under the line item number in parenthesis (0), the number of test questions created for each line item in the table.
- **Test Items** - Allows you to select the Test Items for Line Item window for the highlighted PPP table line item. From this window you can add Multiple Choice, True/False, Fill-in-the-blank, Two Column Matching and Performance test questions, and modify, delete, lock, unlock, print/print preview the highlighted test item. When locked the test item can be approved in the Test Module and used to develop a course test. The test items are linked to the Topic Learning Objectives (TLOs) at the Training Objective Statement (TOS) developed in a course.
• **Explain Flag:** To view the maintenance history for the highlighted line item that is flagged. Flags are generated during development of Changes or Revisions to approved PPP tables. Flags are not generated for tables being created. The **Explain Flag** option (Figure 5-8) contains a complete maintenance record of all maintenance actions that have been performed on the flagged line item since the Rev 0 Chg 0 table was approved. It includes the action performed (Added, Modified, Deleted), the individual who performed it, the date on which it was performed, and the revision or change for which it was performed.

![Figure 5-8. Maintenance Explanation Window](image)

• **Remove Flag:** Enabled during creation of a revision or change to an approved PPP table. The **Remove Flag** option allows the AIM I Administrator to return a line item that was modified to its baseline configuration and removes a user maintenance flag. This is accomplished during the review process when higher authority does not concur with the user’s change to a line item. The associated maintenance record will include both of the actions but will not be visible until another user maintenance flag is generated. Once the flag is removed, the associated change bar on the printout for the item will also be removed.
WARNING: Once a line item has been deleted, it cannot be restored to its baseline configuration; and if you remove a flag from the (Deleted) line item, the flag cannot be regenerated. If the deletion was made in error, delete the PPP table change and re-create the change.

If you want to view the line items, scroll through the table by clicking on the right side button bar. If you want to view a specific line item, use the Find option and enter the line item number desired. The Line Items window will highlight the line item you selected.

Step 5 If no modification is necessary; select the Line Items window Exit menu item to return to the PPP window.

5.3.4 Work With Line Items

5.3.4.1 Adding Line Items to a PPP Table

The PPP table is composed of line items. Line items are statements of overt behaviors that a trainee could perform. The statements are divided into two broad classifications: Skill and Knowledge. When you create an ESS PPP, AIM I automatically generates the necessary Skill and Knowledge line items. The program stores the relationship between the Skill line items and their Knowledge counterpart for later use in the program. When you create a Task/Function or Background table, you must manually create the line items and link them as well. All line item functions can be performed by adding, deleting, linking, and modifying.

Changes are not final until you select either the Edit menu item and the Save option, or the Exit menu and Yes to save the modifications. If errors were made, you can exit without saving to restore the PPP table to its previous configuration.

Line items can be created at different levels. The levels are equal to the number of levels of sub-items. Background tables have five levels because only line items are added under the Skill and Knowledge headings.

Example:
  Level 1 = 1.
  Level 2 = 1-1.
  Level 3 = 1-1-a.
  Level 4 = 1-1-a-(1)
  Level 5 = 1-1-a-(1)-(a)

ESS tables have six levels due to the use of categories. Task/Function tables are created using the same numbering scheme.
Example:
Level 1 = 1.
Level 2 = 1-1.
Level 3 = 1-1-1.
Level 4 = 1-1-1-a.
Level 5 = 1-1-1-a- (1)
Level 6 = 1-1-1-a- (1)-(a)

Line item levels are important when you are adding line items. The type of PPP determines how each line item is numbered.

When you are developing a PPP table or creating a revision for the PPP table, all new line items are added below the current line that is highlighted. There are two Add options.

- To add at the **Same Level**, insert a new line item (or sub-item) with the same numbering scheme as the highlighted PPP line item (*Figure 5-9*).

*Figure 5-9. Add Line Item, Same Level*

- Example: If 1-2-1 is highlighted and you select the **Add** and **Same Level** options, AIM I will open a line for line item 1-2-2. If there was already a line item 1-2-2, it will become 1-2-3.

To add a sub-item to an existing PPP line item or line items to new categories, add at a **Lower Level**. Example: If 1-2-1 is highlighted and you select the **Add** and **Lower Level** options, AIM I will open a line for line item 1-2-1-a.
If it becomes necessary to add a Skill line item:

Step 1  Click on the Skill line item that is at the location where the new skill is to be added.

Step 2  Select the **Options** menu item and the **Add** option.

Step 3  Select **Same Level** or **Lower Level** as desired.

Step 4  Enter the desired text in the Item Text field.

Step 5  Select the **Edit** menu item and the **Copy** option.

Step 6  Click on the Knowledge line item that is at the location where the new Knowledge line item will be added that directly supports the Skill line item you just created.

Step 7  Select **Same Level** or **Lower Level** as desired.

Step 8  Select the **Edit** menu item and the **Paste** option.

Step 9  Click on the Item Text field for the Knowledge line item you just created and edit the text to change it to a Knowledge line item.

Step 10 Select the **Options** menu item and the **Link Skills** option.

Step 11 In the Links window, click on the newly added skill; then click on the directly supporting Knowledge line item you just added. Verify that an X appears in the Link column to indicate that it is linked.

Step 12 Select the **Edit** menu item and the **Save** option.

Step 13 Select the **Exit** menu item to return to the Line Items window. Save your modifications to the database and Exit to the PPP window.

When you are creating a change for an existing PPP table, AIM I will add the line item/sub-item to the end of the list and will not resequence the subsequent line items.

Example:
If 1-2-1 is highlighted and there are line items 1-2-1 through 1-2-6, selecting the **Add** menu item and the **Same Level** option will open a line for line item 1-2-7.
5.3.4.2 Deleting Line Items From a PPP Table

When you are creating a new PPP table or a revision to an existing PPP table and you must delete a line item, highlight the line item for deletion; then select the Options menu item and the Delete option. AIM I will ask for confirmation and, with a Yes response will delete the line item and resequence subsequent line items/sub-items. When deleting a skill line item you will be asked whether the directly supporting (linked) knowledge line item should be deleted, a Yes response will delete the skill and knowledge item concurrently.

When you are creating a change for an existing PPP table, AIM I will ask for confirmation and, with a Yes response will:

- Delete the text for the line item
- Insert (Deleted) in the text field.

Subsequent line items will not be resequenced. You cannot delete or modify a (Deleted) entry.

5.3.4.3 Linking Skill Line Items

To link the Skill line items to their directly supporting Knowledge line items:

Step 1 From the Line Items window; select the Options menu item and the Link Skill option.

AIM I will present the Links window, which contains the menu bar, Skill line item numbers, Knowledge line item numbers and text, and (at the bottom of the window) the text for the Skill line item highlighted.

Step 2 Highlight the Skill line item number that requires linking; then highlight the Knowledge line item that you want to link to it. An X will appear in the Link columns for both the Skill and the Knowledge line items.

Step 3 Repeat Step 2 for each Skill line item that requires a link. All Skill line items must be linked before the table will achieve Complete status.

Step 4 Select the Exit menu item when you are done and save your links.

5.3.4.4 Developing Test Items for a PPP Table Line Item

Test items can be developed for an approved or unapproved PPP table by a user that has edit privilege for a PPP table. Selecting the Test Items option opens the Test Items for Line Item window (for an approved table AIM will ask for confirmation), which will either be blank or contain a list of the current test items for the highlighted line item (Figure 5-10).
Figure 5-10. Test Items for Line Item Window

The Test Items for Line Item window contains:

- Line Item text field which contains the text of the line item selected.
- Type column which contains the types of test questions written for the line item and consists of the following:
  - Fill-in-the-Blank
  - Multiple Choice
  - True/False
  - Two Column Matching
- Sequence number identifying how many test questions of each type have been written.
- TOS column that contains an alpha designator identifying the Training Objective Statement that the test item supports.
- Item Text column which is the text of the test item.
- Status Column - which can contain:
  - I - Incomplete - Not all required information is included.
  - C - Complete - All required information has been included. Can be Locked.
  - L - Locked - Can be reviewed under the Test Administration/Test Item option for approval purposes in the Test Module.
  - A - Approved - Can be used in a test in the Test Module.
- Flag column - A flag (@/X) in this column will inform you if a test item, associated TLO, or Resource linked to the test item has been modified.
The menu contains:

- **Options** menu item that contains the following options:
  - **Add Test Item** option to develop Fill-in-the blank, Multiple Choice, True/False, and Two Column Matching type questions.
  - **Modify/View Test Item** option to modify the highlighted incomplete or unlocked test items or view a locked or approved test item.
  - **Copy** option to copy the highlighted test question for development of another test item of the same type that uses the same reference information.
  - **Delete Test Item** option to delete the highlighted test item if it is unlocked or incomplete.
  - **Print Preview** option to view all the test questions written for the line item as they would appear when printed. When the **Print Preview** option is selected the Printer Setup window will open, which permits you to add 'Page X of Y' for page accountability and Setup Header/Footer for a classified test.
  - **Print** option to print the entire document to the default printer. When the **Print** option is selected the Printer Setup window will open, which permits you to add 'Page X of Y' for page accountability and Setup Header/Footer for a classified test.
  - **Explain Flag** option to retrieve the maintenance explanation for a flagged test item.
  - **Remove Flag** option to allow an individual with Remove Flag privilege to remove a flag from a test item.
- **Exit** menu item to return to the Line Items window.
- **Help** menu item to retrieve the Test Item On-Line Help menu.

**To develop Fill-in-the-blank questions:**

**Step 1**
From the Test Items for Line Item window; select the **Add Test Item** option.

**Step 2**
Select the **Fill-in-the blank** sub-menu item. The Test Item for Line Item window will open *(Figure 5-11).*
Step 3  Click on the Resource tab. Select the Options menu item and the Select Resource option.

AIM I will open the Select Site RRL window that displays the Publications or IETM contained in the Site RRL.

Step 4  Click on the publication that contains the test question information and select the Select menu item. AIM I will enter the publication identifier in the Resources tab of the Fill-in-the-blank Test Item for Line Item window. You may also double click on the desired publication to select it.

Step 5  Enter the publication breakdown information (e.g., Volume, Part, Chapter, etc.) in the publication breakdown fields.

Step 6.  Click on the TOS down arrow and select the appropriate TOS for the question.

Step 7  Click on the K Level field down arrow and from the drop-down menu select the appropriate level of learning for the question.

Step 8  Click on the Q&A tab. Click on the Stem field and enter the text of the question. Use the underline feature to enter the blank line.
Step 9  Click on the Answer field and enter the text of the answer.

Step 10 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 11 If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform with the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 12 Select the Edit menu item and the Save sub-menu item to save the Fill-in-the-blank question to the database.

Step 13 A down arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 14 Repeat Steps 1 through 13 for each additional Fill-in-the-blank question required for the line item selected.

Step 15 Select the Exit menu item to return to the Test Items for Line Item window. You can select the Options menu item and the Modify/View Test Item option to edit the test item or select the Delete Test Item option to delete it until it's status is Locked or Approved.

To develop Multiple Choice questions:

Step 1 From the Test Items for Line Item window; select the Add Test Item option.
Step 2  Select the **Multiple Choice** sub-menu item. AIM I will open the Multiple Choice Test Item for Line Item window *(Figure 5-12).*

![Multiple Choice Test Item for Line Item Window](image)

*Figure 5-12. (Multiple Choice) Test Item for Line Item Window*

Step 3  Click on the Resource tab. Select the **Options** menu item and the **Select Resource** option.

AIM I will open the Select Site RRL window *(Figure 5-13)* that displays the Publications or IETM contained in the Site RRL. A publication must be selected as the basis for each test item.
Step 4  Click on the publication that contains the test question information and select the **Select** menu item. AIM I will enter the publication identifier in the Resource tab of the Test Item for Line Item window. You can also double click on the desired publication to select it.

Step 5  Enter the publication breakdown information (e.g., Volume, Part, Chapter, etc.) in the publication breakdown fields.

Step 6  Click on the TOS down arrow and select the appropriate TOS for the question.

Step 7  Click on the K Level field down arrow and from the pop-up menu select the appropriate level of learning for the question.

   K1 - Recognize (Only applicable for T/F type Test Items)
   K2 - Recall
   K3 - Comprehend
   K4 - Analyze
   K5 - Evaluate

Step 8  Click on the Q&A tab. In the Stem field add the text of the question.

Step 9  In the Answer/Distractor fields enter the text of the distractors and answer. At least four entries must be made to save the question to the database.

Step 10  Click on the Answer text and select the **Options** menu item and the **Set Answer** option or double click on the Correct Answer column adjacent to the answer. An “X” will appear in the column adjacent to the answer.
Step 11 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 12 If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform with the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 13 Select the Edit menu item and the Save sub-menu item to save the multiple-choice question to the database.

Step 14 A down arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 15 Repeat Steps 1 through 13 for each additional multiple-choice question required for the line item selected. Entries in the Answer/Distractor column can be resequenced using the click and drag method.

Step 16 Select the Exit menu item to return to the Test Items for Line Item window. You can select the Options menu item and the Modify/View Item option to edit the test item or select the Delete Test Item option to delete it until its status changes to Locked or Approved.

To develop True/False questions:

Step 1 From the Test Items for Line Item window; select the Add Test Item option.

Step 2 Select the True/False sub-menu item. AIM I will open the Test Item for Line Item window (Figure 5-14).
Step 3  Click on the Resource tab. Select the **Options** menu item and the **Select Resource** option. AIM I will open the Select Site RRL window that displays the Publications or IETM contained in the Site RRL (*Figure 5-15*).

![Figure 5-15. Select Site RRL Window](image)

**Figure 5-15. Select Site RRL Window**
Step 4  Click on the publication that contains the test question information and select the Select menu item. AIM I will enter the publication identifier in the Resource tab of the Test Item for Line Item window.

Step 5  Enter the publication breakdown information (e.g., Volume, Part, Chapter, etc.) in the publication breakdown fields.

Step 6.  Click on the TOS down arrow and select the appropriate TOS for the question.

Step 7  Click on the K Level field down arrow and from the pop-up menu select the appropriate level of learning for the question.

   K1 - Recognize (recommended selection for T/F Test Items)  
   K2 - Recall  
   K3 - Comprehend  
   K4 - Analyze  
   K5 - Evaluate

Step 8  Click on the Stem field and enter the text of the question.

Step 9  Identify the correct answer by clicking on the box next to either TRUE or FALSE. An "X" will appear in the box to indicate the correct answer.

Step 10 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 11 If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform with the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 12  Select the Edit menu item and the Save sub-menu item to save the True/False question to the database.
Step 13  A down arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 14  Repeat Steps 1 through 13 for each additional True/False question required for the line item selected.

Step 15  Select the Exit menu item to return to the Test Items for Line Item window. You can select the Options menu item and the Modify/View Item option to edit the test item or select the Delete Test Item option to delete it until its status is Locked or Approved.

To develop Two Column Matching test questions:

Two column matching test items are actually four to eight individual test items in one question. To develop a two-column matching test item you will enter data in two parallel columns that correspond to each other. The left column (stimulus) will contain four to eight entries. The right column (responses) will contain six to ten entries. The right column MUST have two more entries than the left column. These two additional entries are provided to prevent the trainees from being able to guess at the last few matching items after having ruled the ones that they know. The entries in the columns can be resequenced using the click and drag method.

Step 1  From the Test Items for Line Item window; select the Add Test Item option.

Step 2  Select the Two Column Matching sub-menu item. The Test Item for Line Item window will open (Figure 5-16).
Step 3  Click on the Resource tab. Select the **Options** menu item and the **Select Resource** option. AIM I will open the Select Site RRL window that displays the Publications or IETM contained in the Site RRL.

Step 4  Click on the publication that contains the test question information and select the **Select** menu item. AIM I will enter the publication identifier in the Resource tab of the Two Column Matching Test Item for Line Item window.

Step 5  Enter the publication breakdown information (e.g., Volume, Part, Chapter, etc.) in the publication breakdown fields.

Step 6  Click on the TOS down arrow and select the appropriate TOS for the question.

Step 7  Click on the K Level field down arrow and from the pop-up menu select the appropriate level of learning for the question.

Step 8  Click on the Q&A tab. Click on the Stem field and enter the text of the directions for the Column Matching Test Item.

Step 9  Select the **Options** menu item and the **Add Left Entry** option, or click in the desired location to add an entry.
Step 10  Enter the text for the first item of the left column.

Step 11  Repeat Steps 9 and 10 for each item to be added to the left column. AIM I will permit up to 8 entries. After four entries in either column you will need to manually add entries using the Options drop-down menu.

Step 12  Select the **Options** menu item and the **Add Right Entry** option, or click in the desired location to add an entry.

Step 13  Enter the text for the first item in the right column.

Step 14  Repeat Steps 12 and 13 for each item to be added to the right column. AIM I will permit up to 10 entries for the right column. The right column must have two more entries than the left column.

Step 15  Click on the Answer column for the first item in the left column and select the letter of the matching item in the right column. You can use an answer once, more than once or not at all.

Step 16  Repeat Step 15 for each item in the left column.

Step 17  The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 18  If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the **Options** menu item and the **Select Graphic** option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the **Options** menu item and the **Select** option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform with the 6.5 width and 8.5 height maximum values.
   c. Select the **Edit** menu item and the **Save** sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 19  Select the **Edit** menu item and the **Save** sub-menu item to save the Two Column Matching question to the database.
Step 20  A down arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 21  Repeat Steps 1 through 20 for each additional Two Column Matching question required for the line item selected.

Step 22  Select the Exit menu item to return to the Test Items for Line Item window. You can select the Options menu item and the Modify/View Test Item option to edit the test item or select the Delete Test Item option to delete it until it's status is Locked or Approved.

5.3.5  Maintain a PPP Table

When a change is created for a PPP table, the printout of all pages will indicate the change number created. If a line item is deleted, AIM I does not remove the line item from the database. It deletes the text and inserts (Deleted). The reason for the (Deleted) entry is to prevent the subsequent line items from renumbering, which would cause renumbering of the TPCs associated TLAs, and the OACs of TCCDs that use the PPP table.

Example:
If a line item is added (e.g., 1-X for a Background table or 1-1-X for an ESS PPP table or T/F table), it will be added after the last line item of the Knowledge or Skill category.

If a sub-item is added, it will be added after the last sub-item of the Knowledge or Skill line item.

When a revision is created for a PPP table, the printout of all pages will indicate the revision letter. A revision will automatically delete the (Deleted) line items and renumber the subsequent line items. For this reason, revisions to PPP tables are rarely created. Revisions do not create change bars to indicate what information has changed. Line items can be deleted, and subsequent line items are renumbered automatically. Line items can be added wherever you wish, and subsequent line items will automatically renumber.

When a revision or a change is created for a PPP table, flags (X) will appear in the Flag column of the PPP window for the PPP modified and the Line Item window for the line item modified. A flag has two purposes:
• It indicates that a maintenance action has been performed on the PPP table or line item. When the maintenance action is saved, it is recorded in the maintenance database, which will be displayed when the Explain flag option is accessed. A running history of all maintenance actions performed on the line item (i.e., which maintenance action was performed, who performed the maintenance action, and what revision and change the maintenance action was performed under) will also be displayed.
• When all maintenance actions have been completed and the table is locked, the flags will be forwarded to the TPS module. The flags and their associated explanations will be displayed whenever a change is created for the TPS that uses the PPP table that was modified. The only exception occurs when a line item that has not been assigned an applicability code in the TPS/TPC TLA is deleted from the PPP table. In such cases, there is no flag; (Deleted) appears for the line item.

When the Revision/Change has been approved for use by the CCA, an Approval Date must be added to the PPP window Cover Page for the PPP table. The Admin Utility is used to approve the PPP table Revision/Change.

To create a revision or change:

Refer to NAVEDTRA 131B, Volume III (Managers Guide), for revision and change criteria.

Step 1 Select the Document menu item and the Personnel Performance Profile option, or click on the PPP icon. AIM I will present the PPP window.

Step 2 Highlight the PPP table that requires maintenance.

Step 3 Select the Options menu item and the Maintain option. The Maintain option will present two sub-menu items from which you may select either change or revision.

Step 4 AIM I will update the Cover Page Rev and Chg fields automatically. You can now edit the fields on the Cover Page with the exception of PTN, Rev, Chg, Short Title, Table Type, and for a Task/Function Table, the Drawing Number.

Step 5 Select the Edit menu item and the Save option to save the Cover Page information; at the very least the Rev/Chg fields have changed.

Step 6 Select the Options menu item and the Select option to retrieve the Line Items window.

Step 7 Refer to paragraph 5.3.4 to add, delete, link skills, or modify the line items.

Step 8 When you have completed the required maintenance actions, select the Exit menu item and save your entries to the database. AIM I will return you to the PPP window. Your table should have a status of Complete. If your table is incomplete, refer to paragraph 5.3.4.3 and finish linking the Skill line items.

Step 9 Select the Options menu item and the Lock option to lock your PPP table. Locking the table makes it available for use in developing or maintaining a TPS/TCCD.
5.3.6 Copy a PPP Table

Because you cannot change the PPP table number after saving the Cover Page information, there are occasions when the Copy option is useful. When you are developing a PPP table for the first time, you may not have the approved PTN from the CCA. This does not preclude your developing the PPP.

When the PTN has been issued by the CCA, you can use the Copy option, add the new PTN number, and save your table; then you can delete the original PPP table with the made-up (local) PTN.

The Copy option is also useful when you have to create a PPP table for equipment that shares many characteristics with an existing Equipment PPP table. In such cases, you can change the PTN, change the Cover Page information, and possibly modify the line items to complete the table. The Copy option saves you time.

When a PPP table is copied, the new PPP table will be Rev 0, Change 0. This is a newly developed table in the AIM I database.

To copy a PPP table:

Step 1 Select the Document menu item and the Personnel Performance Profile option or click on the PPP icon. AIM I will present the PPP window.

Step 2 Highlight the PPP table that you want to copy.

Step 3 Select the Options menu item and the Copy option. AIM I will present a Cover Page with a blank PTN field. The rest of the fields will contain the same information as the PPP table you selected.

Step 4 Modify the Cover Page fields as necessary for the new PPP table. Delete the Approval Date and ensure that the Modifications and Drawing Number fields contain the pertinent data.

Step 5 Select the Edit menu item and the Save option. AIM I will record the modifications and copy the PPP table selected.

Step 6 Now you can select the PPP table to work on the line items in accordance with paragraphs 5.3.3 and 5.3.4 above.
5.3.7 Delete a PPP Table

A PPP table can be deleted as long as it is not cited in a current TPS. The **Delete** option is most commonly used to delete:

- PPP tables that were developed for training
- PPP tables that have locally assigned numbers and have since been copied and assigned a CCA-approved PTN.

If you want to remove a PPP table because there is a later approved version, ask your AIM Administrator to archive the PPP table via the AIM I Archive Utility. (Archiving stores a compressed file of the PPP Table in another location and removes it from the AIM I database).

**To delete a PPP table:**

Step 1  Select the **Document** menu item and the **Personnel Performance Profile** option or click on the PPP icon. AIM I will present the PPP window.

Step 2  Highlight the PPP table that you want to delete.

Step 3  Select the **Options** menu item and the **Delete** option. AIM I will check the status of the PPP table to make sure it is not cited in a current TPS. AIM I will then ask you to verify that you intend to delete the table.

Step 4  Click on **Yes** to confirm the delete action. AIM I will delete the PPP table from the database and the PPP table listing.

5.3.8 Find a PPP Table

In a very large database that contains many PPP tables, it is easier to use the **Find** option to highlight the desired PPP table than to page through the list in the PPP window.

**To find a PPP table:**

Step 1  Select the **Document** menu item and the **Personnel Performance Profile** option or click on the PPP icon. AIM I will present the PPP window.

Step 2  Select the **Options** menu item and the **Find** option. AIM I will present the Find window.

Step 3  Enter the PTN desired in the Find PPP field. Notice that the field contains a wildcard (*). As you enter the number, the PPP tables that start with that number up to the * are displayed in the list below.

Step 4  When you have identified the desired PPP table, you can select it one of two ways:
• Click on the **Select** menu item. AIM I will return you to the PPP window, and the selected PPP table will be highlighted.

• From the list below the Find PPP field, double click on the desired PPP table. AIM I will return you to the PPP window, and the selected PPP table will be highlighted.

### 5.3.9 Grant Privilege for a PPP Table

The **Grant** option is used when the originator of the PPP or the AIM Administrator needs to grant privilege to other users to Edit, Lock, Grant, Approve, Remove Flag, Reset In Use, Maintain/Delete PPP, or Add Notes for a highlighted PPP table.

**To grant privilege to an AIM User:**

**Step 1** Select the **Document** menu item and the **Personnel Performance Profile** option or click on the PPP icon. AIM I will present the PPP window.

**Step 2** Highlight the PPP table for which you want to grant a user privilege.

**Step 3** Select the **Options** menu item and the **Grant** option (*Figure 5-17*). AIM I will present the Grant Privilege window, which contains a list of the AIM Users.

**NOTE:** Users who have been designated as AIM Administrators will not appear on the list.
Step 4   Click on the desired AIM User.

Step 5   AIM I presents a list of the privileges for selection. Click on the fields for the desired privileges.

Step 6   Select the Exit menu item and save the privileges selected to the database.

5.3.10   Lock and Unlock a PPP Table

In addition to being an option, Lock is a privilege. The developer of a PPP table has Lock privilege for the PPP table being developed. All AIM Users can view the PPP but cannot lock or unlock the PPP table unless they are granted Lock privilege level via the Grant option.

The Lock/Unlock options are subject to the following conditions:

- If a PPP table is Incomplete (all skills have not been linked to at least one supporting Knowledge line item), the PPP table cannot be locked.
- When a PPP table is Suspended, it cannot be locked. The user has to answer all the questions for development and save the responses in order to achieve Complete status. When a PPP table is Approved, it cannot be unlocked or locked. Users can view the Approved PPP table or maintain it.
- When a PPP table is Unlocked, the Status column of the PPP table indicates that the PPP table is Complete.
To lock/unlock a PPP table:

Step 1  Select the **Document** menu item and the **Personnel Performance Profile** option or click on the PPP icon. AIM I will present the PPP window.

Step 2  Highlight the PPP table that you want to lock/unlock.

Step 3  Select the **Options** menu item and the **Lock/Unlock** option. AIM I will change the Status column of the PPP list for the PPP table highlighted to Lock/Complete.

5.3.11 List Related Materials

A single PPP table can be selected in multiple Training Path Systems (TPSs), Training Path Charts (TPCs), and courses. When a PPP table is initially being developed, it is not cited in any other training material. Consequently, any modification made to the PPP table does not have any effect on any other piece of training material in AIM I. Once the PPP table is cited in a TPC or course, the modifications to the PPP can affect the training material in which it is cited. Using the **Related Materials** option, you can ascertain the possible training material affected by a modification to a PPP table.

To find the related training materials that cite a PPP table:

Step 1  Select the **Document** menu item and the **Personnel Performance Profile** option or click on the PPP icon. AIM I will present the Personnel Performance Profile (PPP) window.

Step 2  Highlight the PPP table for which you want to find the related materials.

Step 3  Select the **Option** menu item and the **Related Materials** option. AIM I will produce a sub-menu containing **TPS**, **TPC**, and **Course**.

Step 4  Click on the desired training material. AIM I will produce a list of the types of training material selected that cite the PPP table highlighted.

5.3.12 Print Preview a PPP Table

Selection of **Print Preview** will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.
Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- **Options** - Contains the options to Print or Save to PDF. Print opens the Print window, which allows you to select the printer, range of pages, print to file, and number of copies. Save to PDF allows you to save the document as a PDF file to the desired location.
- **Go To** - Allows moving to the previous, next, first, last, or desired page.
- **Print** - Allows the current page, range of pages, or the entire document to be printed.
- **Exit** - Returns to the Personnel Performance Profile (PPP) window.
- **Help** - Provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- **Previous** - Allows moving to the previous page.
- **Next** - Allows moving to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - Displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Allows you to access the page desired by typing in the page number in the first field and depressing Enter or Tab).
- **Actual Page** - Displays the actual page number, as shown on the page. Allows you to access the page desired by typing in the page number in the field and depressing Enter or Tab.

The right and left mouse buttons allow you to zoom in and out. Double click the left mouse button to zoom in and double click the right mouse button to zoom out. The inspect toolbar button also allows you to zoom in on the page and allows you to view multiple pages.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

**To print preview the PPP:**

**Step 1** From the Personnel Performance Profile (PPP) window; select the **Options** menu item and the **Print Preview** option.

**Step 2** From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

**Step 3** Click on the **OK** to print preview.

**5.3.13 Print a PPP Table**

Selection of the **Print** option allows the entire document to be printed:
To print the entire PPP:

Step 1  Select the **Options** menu item and the **Print** option.

Step 2  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3  Click on the **OK** to print.

### 5.4  Summary

Chapter 5 explained PPP table status and privilege levels, defined the five types of PPP tables, and provided detailed instructions on working with PPP table.
CHAPTER 6

THE TRAINING PATH SYSTEM (TPS) MODULE

6.0 The Training Path System (TPS)
6.1 The TPS Explained
   6.1.1 The Relationship Between the TPS and the TPC
   6.1.2 The Relationship Between the TPS and the TCCD
   6.1.3 The TPC Explained
   6.1.4 TPS Status Levels and Privileges
   6.1.5 TPS Assumptions
6.2 Training Path System (TPS) Windows
   6.2.1 Create a TPS
   6.2.2 Modify the TPS Introduction
   6.2.3 Maintain a TPS
   6.2.4 Delete a TPS and Its Associated Elements
   6.2.5 Find a TPS
   6.2.6 Grant Privilege for a TPS
   6.2.7 Lock and Unlock a TPS
   6.2.8 Print Preview a TPS
   6.2.9 Print a TPS
   6.2.10 Change Package
   6.2.11 Maintenance on an Approved Curriculum
   6.2.12 Removing System Maintenance Flags
6.3 Summary
6.0 THE TRAINING PATH SYSTEM (TPS)

6.1 The TPS Explained

The Training Path System (TPS), in its finished form, is a compilation of various reports which together provide a management tool that designates the training requirements for Navy personnel for an NEC/NOBC, a particular training program, or a course.

Creating a TPS is a decision-making process in which a series of questions fundamental to curriculum development are answered and recorded, thus establishing the training requirements of the curricula. An understanding of the ISD process is prerequisite to using the AIM I system in general, and the TPS module in particular. In formulating and deriving reports based on the data that you provide, AIM I will ensure that necessary relationships among TPS elements are developed. However, you must supply the thought and analysis to develop a valid TPS.

6.1.1 The Relationship Between the TPS and the TPC

The TPS can be viewed as an umbrella under which you will find Training Path Charts (TPCs). Each TPC contains two related but separate entities: the Training Level Assignments (TLAs) and the Course List. Once the TLAs and Course List have been created for each TPC within a TPS and training requirements have been selected for each of the TPCs courses, you can generate the following printouts:

- TPS Cover Page
- List of Effective Elements
- TPS Introduction and Training Objective Statements (TOSs)
- TPC Cover Page(s)
  - Curricula Index
  - Table Assignment Chart (TAC)
  - PPP Table Index
  - Table Assignment Matrix (TAM)
  - TLAs

6.1.2 The Relationship Between the TPS and the TCCD

Designing a TPS involves defining courses that will be required to accomplish the training. It is not necessary to know the specific details of a course; you complete that process in the AIM I TCCD module. However, you must define the course within a TPC before you can develop the course structure in the TCCD module. You must select the training requirements in the TCCD Curriculum Outline of Instruction (COI) for the Courses identified in the Course List to complete the TPC and Curricula Index.
6.1.3 The TPC Explained

Each TPC has five elements that, together, describe a particular training path for a category of individuals: the TAC, Curricula Index, PPP Index, TAM, and TLAs.

The TAC shows a training path for a category (NEC/NOBC) of personnel by listing courses in the path, the type of course (Background, Replacement, Conversion, Advanced), and the TOS levels associated with the course. Information for the TPC is automatically generated from the AIM I database. In order to produce a TAC, you must have at least one course defined and selected in the TPC Course List, at least one TLA completed, and training requirements selected for the course.

The TAC is a table that shows the complete training pipeline for a category of personnel. The TAC identifies the knowledge and skills personnel should acquire during their training by grouping PPP table numbers within courses. It lists all course identification numbers, titles of formal curricula covered by a particular TAC. The applicable TOS codes are also listed beside each PPP tables listed.

The Curricula Index, which contains all the curricula in the TPC, is automatically generated in AIM I when the training requirements for each of the courses have been selected.

The TLAs are a tabular listing in PPP number sequence that imposes training levels for the PPP items and indicates the environment in which training for a particular PPP will take place.

The PPP Table Index lists the PPP tables selected for a particular TPC. The list, which is arranged in ascending order of PPP number, gives the complete title of the PPP. AIM I derives this information from the TLAs developed from each PPP table in the TPC.

The TAM is a table that shows the PPPs that are used in the TPC (listed down the left column) and the training levels (listed across the top). The training levels vary, depending on the Task Set that the TPC is addressing (Direct, Coordinate, or Perform). AIM I derives TAM information from the TLAs. On the basis of the Applicability Codes you entered for a TLA, AIM I places an X in the applicable training level column adjacent to the PPP table number.

The TLAs are a tabular listing of PPPs in table number sequence that imposes training levels for specific PPP line items and identifies the environment where training for a particular PPP line item will take place.

6.1.4 TPS Status Levels and Privileges

Status levels and privileges are assigned to the TPS in order to provide a level of administrative security. Privileges minimize unauthorized use of the system by specific users. Status levels limit the types of actions that a user can perform on a TPS.

The status levels for a TPS and the corresponding identifiers that can appear on your computer screen are:
A Complete TPS signifies that a TPS Cover Page has been created. A Locked TPS has been developed, revised, or changed but has not yet been approved. It can be unlocked and modified, even after a TCCD has been constructed. An Approved TPS is approved for use and cannot be modified without creating a change or revision.

The privilege levels granted to a user by the AIM Administrator determine what actions can be performed. Refer to Chapter 1, paragraph 1.5, Table 1-1 for the list of privileges in AIM I.

The developer of a TPS has the default privileges; Edit, Lock, Grant, Maintain/Delete, and Add Notes. Additionally the creator of a TPS may grant Edit, Lock, and Grant privileges to any other AIM I user. If the AIM Administrator can grant a user privileges for a particular TPS via the Admin Utility portion of the Utilities module of AIM I.¹

When the Learning Site wishes to maintain a document in steady state for further development but not permit changes, the AIM Administrator can deselect the privileges assigned to all AIM Users for the TPS. If you have Lock privilege, you may also unlock a locked TPS but require Edit privilege to edit the TPS.

### 6.1.5 TPS Assumptions

The following information is provided to help you understand the assumptions used in AIM I:

- A TPS may have one or more TPCs.
- For each TPC, there is only one Task Set (Coordinate, Perform, or Direct).
- There can be only one Task Set for a course(s) in a TPC.
- Revision and change numbers refer to the entire TPS. All of the TPS elements should have the same revision and change numbers.
- A TPC contains a TAC, TAM, PPP Table Index, Curricula Index, and one or more TLAs.
- The TAC, TAM, PPP Table Index, and Curricula Index are automatically generated.
- A course has only one originating TPS/TPC. Modifications to a TLA cited in a course must be accomplished through the originating TPS/TPC. A course can be selected by more than one TPC. The TPCs may be in the same TPS, or they may be in different TPSs.

¹ For additional information about privileges, see Chapter 1, paragraph 1.5.
6.2 Training Path System (TPS) Windows

To access the TPS module from the AIM I window, select the **Document** menu item and the **Training Path Systems (TPS)** option. Or, click on the TPS icon. AIM I will present the TPS window (*Figure 6-1*). The TPS window contains the following menu items:

- **Options**
- **Contents**
- **Edit**
- **Exit**
- **Help**

*Figure 6-1. Training Path System (TPS) Window*

The TPS **Options** menu item contains the following options:

- **Create**: Allows you to create a new TPS by entering the information for the TPS in the fields provided on the TPS window for TPS Number, TPS Title, Developing Agency, Approving Agency, and Issue Date.
- **Maintain**: Allows you to create a revision or a change for the highlighted and approved TPS.
- **Select**: Allows you to select the highlighted TPS's TPC window.
- **Delete**: Allows you to delete the highlighted TPS, provided it contains no TPC or TCCD.
- **Find**: Allows you to find a TPS in the list by entering the TPS Number.
- **Grant**: If you initiated the TPS, allow you to grant the privileges of Edit, Lock, and Grant to other users.
- **Lock**: Allows you to lock the TPS so the information can be used in the development or maintenance of a TCCD.
The TPS window Contents menu item contains the following selections:

- **Intro:** Opens the AIM I Text Editor window, which contains an Introduction file, which contains the boilerplate Task Set and TOS explanations and definitions located in NAVEDTRA 131B. The boilerplate introduction can be tailored to describe the items that constitute your TPS and explain how to use the TPS. The boilerplate text can be edited to delete Task Sets that may not be used in the TPS and add the Applicability Codes. A numeric designator is required if the definitions for 0 through 5 are not adequate to identify where and how training will be conducted for specific line items in the TLAs.

- **TPC:** Opens the Training Path Charts (TPCs) window (Figure 6-2) for the development or maintenance of TPCs.

6.2.1 Create a TPS

To create a TPS:

Step 1 Select the TPS window Options menu item and the Create option.

Step 2 AIM I provides you with a blank Cover Page to create your TPS.
NOTE: Use the Tab key to move from field to field or click on the desired field with your mouse. You can select an item in a pop-up menu by clicking on the item with the mouse or highlighting the item with the arrow keys.

Perform the following:

- Enter the TPS Number in the TPS field.
- Enter the TPS Title.
- Select the Development Agency from the list in the database. If your Agency is not in the list, ask your AIM Administrator to enter it via the Agency portion of the Utilities module.
- Select the Approval Agency from the list in the database. If your agency is not in the list, ask your AIM Administrator to enter it via the Agency portion of the Utilities module.
- Leave the Issue Date blank until you receive authorization from the Approving Agency.

Step 3 Select the Edit menu item and the Save option to save the Cover Page information and add the TPS to the list of TPSs.

6.2.1.1 Create a TPC

The TPC window Options menu item contains the following options:

- **Create**: Allows you to create a new TPC by entering the information for the TPC in the fields provided on the TPC window for TPC Number, NEC/NOBC, TPC Title, and Task Set.
- **Delete**: Allows you to delete the highlighted TPC, provided it is not cited in a TPS.
- **Print Preview**: Allows you to preview the entire TPC or specific pages of the TPC in MS-Windows prior to printing the document.
- **Print**: Allows you to print the entire TPC.
- **Explain Flag**: Allows you to view an explanation of the maintenance flag by opening the Maintenance Explanation window and viewing the text generated by AIM I that explains who performed the maintenance action, when the maintenance action was performed, and what maintenance action was performed.
- **Remove Flag**: Allows you to remove the maintenance flag of a highlighted TPC.

The TPC window Contents menu item contains the following selections:

- **Course List**: Opens the Course List window allowing you to add or delete courses from the TPC as well as initiating new courses.
- **TLAs**: Opens the TLAs window allowing you to select any PPP that is Locked or Approved, for inclusion into your TPC.

To create a TPC for the TPS:

Step 1 Select the TPS window Contents menu item and TPC.
Step 2 Select the TPC window **Options** menu item and the **Create** option.

Step 3 Enter the TPC Number, TPC Title, and NEC/NOBC, if applicable, in the fields provided on the Cover Page.

Step 4 Select the applicable Task Set by clicking on the arrow box and clicking on the desired Task Set. No, click on the Task Set field and use the arrow key to select the desired Task Set.

Step 5 Select the TPC **Edit** menu item and the **Save** option to add the TPC to the list.

Step 6 Repeat steps 2 through 5 for each addition TPC required.

### 6.2.1.2 Create TLAs for the TPC

AIM I determines the format of the TLA from the Task Set you selected for the TPC and the type of PPP table you select.

- The TLAs for Background tables support the TOS of B1, B2, and S and are the same for all Task Sets.
- The TLAs for Task/Function tables support the TOS of Q and J and are the same for all Task Sets.
- The TLAs for ESS tables support the TOS of the specific Task Set selected as follows:
  - **Coordinate**: F1, T1, O1
  - **Direct**: F1, T1, T2, O1, O2, M1
  - **Perform**: F1, T1, T2, T3, O1, O2, P1, C1, C2, C3

The development/maintenance of TLAs involves adding/deleting/modifying Applicability Codes in the TLA for line items at the desired TOS. This will indicate where each line item at the TOS specified will be taught.

The Applicability Codes for AIM I are as follows:

- **R** Replacement/Conversion/ILM Training Courses
- **A** Advanced Training Courses
- **B** Both Replacement and Advanced Training Courses
- **0** Training hardware does not exist at the appropriate facility, and operational constraints preclude onboard training.
- **1** Experience is the only means to accomplish training at the specified training level.
- **2** Training hardware does not exist to accomplish training at the appropriate facility, and onboard training is permitted.
- **3** Training hardware exists to accomplish training at a facility; onboard training is permitted; and training is accomplished on board.
- **4** Training is received by the individual outside the cognizant training program.
- **5** Background training is received by the individual as a part of the Navy Training Program.
The number 5 is unique in AIM I because it is used in the TOS columns of a TLA to denote a Background training course.

When you select training requirements from the TLAs in the COI, AIM I retrieves the Applicability Codes that are applicable to the type of course selected, as follows:

- **Advanced:** A or B
- **Conversion:** A, B, or R
- **Replacement:** R or B
- **Background:** 5

When you enter an Applicability Code in a TLA for a line item that has sub-items, you have to think about how the line item will be taught. The following questions and corresponding answers will provide you with the flexibility you need to later develop the COI and have the items accurately reflected in the Profile Item-to-Topic Objective Assignment Chart (OAC).

**Question 1** Is it possible that the sub-items for the line item could be split up and taught as more than one line item?

**Answer:** If yes, enter the Applicability Codes for the sub-items only. If no, enter the Applicability Code at the main line item and leave the sub-items blank.

**Question 2** Could each of the sub-items be taught in different topics?

**Answer** If yes, enter the Applicability Codes for the sub-items only. This will allow AIM I to accurately show where each sub-item is taught in the OAC. If no, enter the Applicability Code at the main line item and leave the sub-items blank.

**Question 3** Is it impossible to teach the line item without covering all the sub-items in the same topic?

**Answer:** If yes, enter the Applicability Code at the stem of the line item and leave the sub-items blank. The OAC will indicate the main line item as a whole (e.g., 1-4-1) and will not indicate the sub-items, even if the line item is split.

**Question 4** Is there doubt on how to enter the Applicability Code for the line item with sub-items?

**Answer:** If yes, enter the Applicability Codes for the main line item and the sub-items. The main as well as each sub-item will be indicated in the OAC and if the resulting TLO is split at a later date the OAC will reflect the location of each TLO that covers each of the sub-items.
To create TLA(s) for a TPC:

Step 1  From the TPC window, highlight the TPC in the TPC List that requires TLAs and select the Contents menu item and the TLAs option. Or, double click on the highlighted TPC in the TPC List. AIM I will present the TLAs window, which contains two lists:

- **Non-Related PPP Tables:** A list of all locked or approved PPP tables in the AIM I database.
- **Related PPP Tables:** A list of the PPP tables that have been selected from the Non-Related PPP List for development of TLAs.

The TLAs window Options menu item contains the following options:

- Modify TLA
- Add TLA
- Select Later TLA
- Delete TLA

Step 2  From the Non-Related PPP List; highlight the PPP table that will be used to develop the TLA.

Step 3  Highlight the desired Non-Related PPP and select the TLAs window Options menu item and the Add TLA option. Or, double click on the highlighted Non-Related PPP. AIM I will present the Line Items window, which will place the PPP line items in the appropriate TLA for the type of PPP table and Task Set selected.

The Line Items window Options menu item contains the following options:

- View Line Item Text
- Print Preview
- Print
- Explain Flag
- Remove Flag

Step 4  Scroll down the TLA to the first Skill line item. Select the Options menu item and the View Line Item Text option. Review the line item text and select the Exit menu item. Enter the Applicability Code required for the Skill line item at the TOS required. AIM I will automatically add the appropriate Applicability Code at the required TOS to the directly supporting Knowledge line item that was linked to the skill during the development of the PPP table.

**CAUTION:** If an Applicability Code is deleted from a Skill line item in the TLA, the Applicability Code that is contained in the Knowledge line item that directly supports the skill is not automatically deleted. AIM I will ask you if you want to delete the linked knowledge Applicability Code.

Step 5  Perform Step 4 for the remaining Skill line items.
Step 6  Scroll to the top of the TLA and enter the Applicability Code at the desired TOS for each of the indirectly supporting Knowledge line items.

Step 7  After all line items has been identified with the Applicability Code at the appropriate TOS, select the Line Items window Edit menu item and the Save option to return you to the TLAs window.

Step 8  Repeat Steps 2 through 7 for each additional TLA required.

Step 9  When you have finished your TLAs, select the TLAs window Exit menu item to return to the TPC window.

6.2.1.3 Develop a Course List for the TPC

To develop a Course List for the TPC:

Step 1  Select the TPC window Contents menu item and the Course List option. AIM I will present the Course List window, which contains two lists:
   - **Non-Related Courses**: A list of all courses in the database that originate from other TPCs/TPSs or TPPs that have not been associated with a TPC (Orphan) which can be selected for the TPC.
   - **Related Courses**: A list of all courses that have been designated as in the training path for the TPC NEC/NOBC.

Step 2  To add a course from the Non-Related Courses List to the Related Courses List, highlight the desired course, select the Options menu item, and select the Add Course option. AIM I will transfer all the information from the Non-Related Courses List to the Related Courses List. There will be no X entry in the Originator column if this course originated from another TPC. If the Course selected is an Orphan (has been identified in a TPP but has never been associated with a TPC) the CIN and Title of the course will appear in the fields on the bottom of the window. You are required to select the course Type, and select the Edit menu item and the Save sub-menu item. Once the course type has been entered into the database the course can be added to the TPC. Once added, an "X" in the Originator column will indicate that this TPC is the originating TPC for the course and the TLAs developed within this TPC will be the ones from which training requirements for the course will be selected.

Step 3  To delete a course from the Related Courses List, highlight the course in the Related Courses List, select the Options menu item and select the Delete Course option. This option can only be performed on courses that were added to the TPC Course List from the Non-Related Courses List and originated in another TPC. It does not delete the course; it merely deletes the course from the TPC Related Courses List.
Step 4  To create a new course for the TPC:

- Select the **Options** menu item and the **Create Course** option.
- Enter the Course Identification Number (CIN) in the CIN field.

**NOTE:** Use the Tab key to move from field to field or click on the desired field with your mouse. You can select items in a pop-up menu by clicking on the item with your mouse or highlighting the item with the arrow keys.

- Click on the Course Type field scroll bar arrow and click on the type desired. Or, use the up/down arrow keys on the keyboard to make your selection.
- Enter the title of the course in the Course Title field.
- Select the **Edit** menu item and the **Save** option. The course will be added to the Related Courses List. The Originator column will contain an X to indicate that the TPC is the originating TPC the course. This method of creating a Course also creates the cover page for the TPP.
- Repeat the sub-steps above, as applicable, to complete the Related Courses List for the TPC.
- Select the Course List window **Exit** menu item to return to the TPC window.
- Select the TPC window **Exit** menu item to return to the TPS window.

### 6.2.2 Modify the TPS Introduction

After the TPCs have been developed for your TPS, you can edit the TPS Introduction to describe the content of your TPS. The introduction presented to you by AIM I is boilerplate text extracted from NAVEDTRA 131B. The boilerplate text defines all Task Sets, the TOS for each Task Set, and the Applicability Codes that can be used. You will need to delete text that does not apply to your TPS and add the definitions of any numeric Applicability Codes you may have added in addition to the ones present.

**To edit the TPS Introduction:**

Step 1  In the TPS window, highlight the desired TPS and select the **Contents** menu item.

Step 2  Select the **Intro** sub-menu item. AIM I will present the Introduction window, which contains a Text Editor screen that allows you to tailor the boilerplate text.

Step 3  Edit the text, as necessary. When you are finished, select the **Exit** menu item from the Introduction and save your changes by clicking on the **Yes** button. AIM I will return you to the TPS window.
6.2.3 Maintain a TPS

When a change is created for a TPS, the printout will indicate the change number created. When a revision is created for a TPS, the printout of all pages will indicate the revision letter. When a revision or a change is created for a TPS, flags will appear in the Flag column of the TPS, TPC, TLAs, and Line Item windows. There are two types of flags:

- **User Maintenance Flag (X).** Indicates that the person maintaining the TPS has performed a maintenance action on the TPS, TPC, TLAs, or line items. When the maintenance action is saved, it is recorded in the maintenance database, which will be displayed when the Explain Flag option is accessed, along with a running history of all maintenance actions performed on the TPC or TLA line item (which maintenance action was performed, who performed the maintenance action, and what revision or change the maintenance action was performed under). The Explain Flag option is available from the **Option** menu items in the TPC and Line Items windows.

- **System Maintenance Flag (@).** In the creation of a change or revision for the TPS if a later version of the PPP table is selected for a TLA, system maintenance flags will appear in the TLA formed from the later version of the PPP table. If a maintenance action is performed on an item that contains a system maintenance flag, the flag will change to a user maintenance flag. When all maintenance actions have been completed and you have locked the TPS, system maintenance flags will be forwarded to the TCCD module. These flags and their associated explanations will be displayed when a Change/Revision is created for the TCCD that uses the TPS that was modified.

**NOTE:** When selecting a later PPP table for the creation of a change or revision to a TLA, review the PPP table line items for new line items. System maintenance flags (@) are not generated for added line items.

**CAUTION:** When developing a change or revision for a TPS using PPP tables that are of a different version than the ones cited in the TPS, and imported from another site or platform, ensure that the AIM Administrator has re-linked the PPP tables using the Relink PPP/TPS Utility. Failure to do so will result in a blank TLA and the previous applicability codes will not be reflected (reference Appendix B, paragraph 2.13, Relink PPP/TPS Utility).

To create a revision or a change:

Refer to NAVEDTRA 131B Volume III (Manager’s Guide) for revision and change criteria.

Step 1 Select the **Document** menu item and the **Training Path System Profile** option, or click on the TPS icon. AIM I will present the TPS window.

Step 2 Highlight the TPS that you want to select for the development of a revision or change.

Step 3 Select the **Options** menu item and the **Maintain** option.

Step 4 AIM I will update the Cover Page Rev or Chg field automatically. You can now edit all the fields on the Cover Page except the TPS Number.
Step 5 Select the **Edit** menu item and the **Save** option to save the Cover Page information.

Step 6 Select the **Contents** menu item and the selection desired for modification. All further actions are the same as those for the development paragraphs described above.

Step 7 When you have completed the required maintenance actions, select the **Exit** menu item and save your entries to the database. AIM I will return you to the TPS window. Your TPS will have a status level of Complete.

**CAUTION:** When changing the originating TPC for a course to the TPS/TPC that is under maintenance there is no means for changing the originating TPC back to the previous Rev/Chg should the TPS not be approved by the approval authority.

Step 8 Select the **Options** menu item and the **Lock** option to lock your TPS. Locking your TPS makes it available for use in developing or maintaining a TCCD.

### 6.2.4 Delete a TPS and its Associated Elements

If the Approving Agency does not concur with a new TPS, a revision, or a change after its creation, you may have to delete the TPS.

All TPCs in the TPS must be deleted from the TPS before you can delete the TPS. If there are courses listed in the TPC Course List that have training requirements selected from the TLAs in the TPC, you will be prompted, *TPC contains TLAs associated with a course, cannot delete.*

#### 6.2.4.1 Delete Courses from the TPC Course List

**To delete a course from the TPC Course List:**

- **Step 1** Click on the TPS icon to retrieve the TPS window.
- **Step 2** If the TPS is locked, select the **Options** menu item and the **Unlock** option.
- **Step 3** Select the **Contents** menu item and the **TPCs** sub-menu item.
- **Step 4** From the TPCs window select the **Contents** menu item and the **Course List** sub-menu item.
- **Step 5** If the TPC contains courses in the Related Courses List of the Course List window and a course originated from the TPC that you are trying to delete (identified by an X in the Related Course Originator column), the AIM Administrator must delete the course from the database using the **Delete Proposed Training Material (TM) Utility** if the course is unapproved or using the **Archive/Unarchive Utility** if the course is approved.
Step 6 If the course originated from another TPC:
- Highlight the course.
- Select the Course List window’s Options menu item and the Delete Course option. AIM I will remove the course from the Related Courses List and restore it to the Non-Related Courses List.
- Delete all courses from the Related Courses List before attempting to delete the TPC.
- Select the Exit menu item to return to the TPCs window.

### 6.2.4.2 Delete TLAs from the TPC

**To delete TLAs from the TPC:**

Step 1 From the TPCs window select the Contents menu item and the TLAs sub-menu item.

Step 2 Highlight the TLA to be deleted.

Step 3 From the TLAs window select the Options menu item and the Delete TLA option. If a TLA is cited in one of the TPC’s courses with training requirements selected from the TLA, that Part of the course must be deleted before the TLA can be deleted from the TLAs Related PPP List.

Step 4 Select the Exit menu item to return to the TPCs window.

### 6.2.4.3 Delete TPCs from the TPS

**To delete a TPC:**

Step 1 From the TPCs window highlight the TPC to be deleted.

Step 2 Select the Options menu item and the Delete option. As long as there are no courses identified in the TPCs Course List Related Courses List, AIM I will delete the highlighted TPC and its associated TLAs.

Step 3 Delete all TPCs before attempting to delete the TPS.

Step 4 Select the Exit menu item to return to the TPSs window.

### 6.2.4.4 Delete a TPS

**To delete a TPS:**

Step 1 From the TPSs window highlight the TPS for deletion.
Step 2 Select the Options menu item and the Delete option. As long as there are no TPCs in the TPS, AIM I will delete the TPS from the list.

6.2.5 Find a TPS

In a large database, it is often easier to use the Find option to locate and highlight a TPS than to page through the entire database.

To find a TPS:

Step 1 From the TPSs window select the Options menu item and the Find option.

AIM I will present a Find window, and the cursor will be in the Find TPS field that contains an asterisk as a wild card. As you enter the TPS number in the field, the TPS List will be updated to include all TPSs that start with the alphanumeric designator that you have typed in.

Step 2 Enter the TPS alphanumeric designator desired.

Step 3 If you have entered a partial alphanumeric designator and see the TPS in the list, double click on the TPS to select it.

Step 4 If you have entered the entire TPS alphanumeric designator, AIM I will highlight the TPS in the Find List. Click on the Select menu item, and AIM I will highlight the TPS in the TPSs window.

6.2.6 Grant Privilege for a TPS

The Grant option is used when the originator of a TPS is required to grant privilege to other AIM Users work on the highlighted TPS.

To grant privilege to an AIM User:

Step 1 Select the Document menu item and the Training Path System sub-menu item or click on the TPS icon. AIM I will present the TPS window.

Step 2 Highlight the TPS for which you want to grant the user a privilege.

Step 3 Select the Options menu item and the Grant option. AIM I will present the Grant Privilege window, which contains a list of the AIM Users.

Step 4 Click on the desired AIM User.

Step 5 Click on the desired privileges for the AIM User.

Step 6 Select the Exit menu item and click on Yes to save your selection.
6.2.7 Lock and Unlock a TPS

Lock is a privilege, as well as options. The developer of a TPS has Lock privilege for the TPS being developed. The AIM Administrator has Approve privilege for all training material and thus has Lock/Unlock privilege as well. All other AIM Users can only view the highlighted TPS and therefore cannot lock or unlock the TPS unless they are granted this privilege level using the Grant option. The Lock/Unlock options are subject to the following conditions:

- If the required TPS Cover Page information has not been saved to the database, the TPS cannot be locked.
- When a TPS is approved, it cannot be unlocked or locked. All users can only view or maintain the approved TPS.
- When a TPS is unlocked, the Status column of the TPS indicates that the TPS is Complete.

To lock/unlock a TPS:

Step 1 Select the Document menu item and the Training Path System sub-menu item or click on the TPS icon. AIM I will present the TPS window.

Step 2 Highlight the TPS that you want to lock/unlock.

Step 3 Select the Options menu item and the Lock/Unlock option. AIM I will change the Status column of the TPS List for the TPS highlighted to Lock/Complete.

6.2.8 Print Preview a TPS

Selection of Print Preview will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items: Options - Contains the options to Print or Save to PDF. Print opens the Print window, which allows you to select the printer, range of pages, print to file, and number of copies. Save to PDF allows you to save the document as a PDF file to the desired location.

- Go To - Allow moving to the previous, next, first, last, or desired page.
- Print - Allows the current page, range of pages, or the entire document to be printed.
- Exit - Returns to the Training Path System (TPS) window.
- Help - Provides text to explain how to use the Print Preview option.
The following buttons and fields are available on the control bar:

- **Previous** - Allows moving to the previous page.
- **Next** - Allows moving to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - Displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Allows you to access the page desired by typing in the page number in the first field and depressing **Enter** or **Tab**.
- **Actual Page** - Displays the actual page number, as shown on the page. Allow you to access a page by typing in the page number in the field and depressing **Enter** or **Tab**.

The right and left mouse buttons allow you to zoom in and out. Double click the left mouse button to zoom in and double click the right mouse button to zoom out. The inspect toolbar button also allows you to zoom in on the page and allows you to view multiple pages.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

To print preview the TPS:

**Step 1**
From the Training Path System (TPS) window; select the **Options** menu item and the **Print Preview** option.

**Step 2**
From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

**Step 3**
Click on the **OK** to print preview.

**6.2.9 Print**

Selection of the **Print** option allows the entire document to be printed:

To print the entire TPS:

**Step 1**
Select the **Options** menu item and the **Print** option.

**Step 2**
From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

**Step 3**
Click on the **OK** to print.
6.2.10 Change Package

The Change Package option is only enabled for a TPS that has a Change Number greater than zero (0). Selection of the Change Package option provides the user with two sub-menu items:

- Print Preview
- Print

The Print Preview option will permit you to view the Change Package (only those pages effected by the change) or print current page, range of pages, or the entire Change Package.

6.2.11 Maintenance on an Approved Curriculum

The following maintenance actions assume the following:

- The TPS Change/Revision, that will be used to develop the Course Change/Revision, was created on the same server/PC as the previous version, or
- The imported TPS Change/Revision has been re-linked to its previous version by the AIM Administrator (reference Appendix B, paragraph 2.14, Relink PPP/TPS Utility).

Since system maintenance flags are not visible until maintenance actions are accomplished on the Course(s) that are affected by the TPS maintenance actions, the next step is to create a Change/Revision for the affected course(s) in the TPC(s).

To perform maintenance on an approved curriculum:

- **Step 1** From the AIM I main menu, select the Course menu item and the Select sub-menu item or click on the Select Course icon.

- **Step 2** From the Course Select window highlight the approved curriculum that you want to maintain.

- **Step 3** Click on the Options menu item and select the Maintain option. A sub-menu will appear to give you the choice of creating a Revision or a Change.

- **Step 4** Refer to NAVEDTRA 131B, Volume III, Manager’s Guide, Chapter 9, for revision and change criteria. Click on the appropriate choice. AIM I will display messages that it is creating a change/revision and retrieving TPP, COI, LP, and TG information and copying course data to the database. When completed, AIM I will update the Course Select window with the next change/revision of the course.

- **Step 5** Highlight the change/revision you just created and click on the Select menu item. AIM I will return you to the main menu.

- **Step 6** Select the Document menu item and the Curriculum Outline of Instruction (COI) menu item or click on the COI icon for the course selected. AIM I will retrieve the Parts/Sections/Topics window for the course selected.
Step 7  Select the **Contents** menu item and click on the Training Requirements sub-menu item. AIM I will retrieve the TPC window for the course. From there, you can select the latest change/revision created for your TPC to create the change/revision to your course.

Step 8  Click on the latest Rev/Chg to your TPC that will contain a flag, and select the **Options** menu item and the **Select Later TPC** option. AIM I will compare the OAC records to the new TPC and update the TLAs for the course with the new information, along with system maintenance flags.

**NOTE:** If you select the No response for the Select Later TPC "Do you want to continue?" AIM will use the previous TPS version TPC/TLAs for the development of the course change/revision.

Step 9  Highlight a flagged TLA and click on the **Select** menu item. AIM I will retrieve the TLA. Applicability Codes that were added, deleted, or modified and PPP table line items that were modified will be flagged to inform you of impending user maintenance actions. The Applicability Codes that were added can be selected for the course as training requirements, if appropriate.

Step 10  Highlight each flagged item and review the maintenance record by selecting the Options menu item and the **Explain Flag** option. Return to the Line Items window by selecting the Maintenance Explanations window **Exit** menu item.

Step 11  For line items that were modified or deleted, no training requirements maintenance actions are required in the Line Items window. The TLOs will be flagged for modification or deletion. For Applicability Codes that were added, if you desire to select these items as training requirements for this course, highlight the Applicability Code desired and double click on it. An X will appear where the Applicability Code was to indicate that it will be selected as a training requirement once your modifications to the TLA have been saved to the database.

Step 12  Select/unselect Applicability Codes as necessary by double clicking on the X or Applicability Codes. All maintenance actions on your part will be recorded in the Maintenance Explanations record of the database, and the line item will indicate a user maintenance flag.

Step 13  When you complete your modifications select the **Exit** menu item and save your training requirements modifications to the database. This will return you to the TLA window.

Step 14  Repeat Steps 9 through 13 for each TLA that is flagged.

Step 15  From the TLA window select the **Exit** menu item to return to the Parts/Sections/Topics window.
NOTE: The Topics affected by the training requirements modifications have been flagged.

Step 16 Select the CLOs for the course and the TLOs for each Topic flagged and review the explanation for each flagged item. Perform the appropriate maintenance action for each flagged item. Refer to COI, Chapter 7, of the User's Manual for specific direction on each of the COI functions.

6.2.12 Removing System Maintenance Flags

In order to approve a TPS change or revision, the system-generated flags that remain must be removed. It is important not to remove the flags that affect curricula until changes/revisions have been created for the curricula. If flags are removed prematurely, they cannot be generated to the linked material in the database.

The Remove System Flags option should be performed only when the CCA has given approval authorization.

To remove system maintenance flags:

Step 1 Select the Document menu item and the Training Path System (TPS) sub-menu item or click on the TPS icon. AIM I will present the Training Path System (TPS) window.

Step 2 Highlight the desired TPS.

Step 3 Unlock the TPS in accordance with paragraph 6.2.7.

Step 4 From the TPS window select the Options menu and the Remove System Flags option. This option will remove all of the system maintenance (@) flags in the entire TPS. The user maintenance (X) flags will remain as a permanent part of the Maintenance record.

Step 5 Lock the TPS in accordance with paragraph 6.2.7.

Step 6 Select the Exit menu item to return to the AIM I main menu.

6.3 Summary

Chapter 5 explained the relationships between the TPS and the TPC and between the TPS and TCCD. It also described the key elements of a TPC, defined TPS status levels, and provided instructions for creating a TPS and a TPC, as well as performing related functions within the TPS module. If a Course was created in the TPC Course List, a TPP exists for the Course.
CHAPTER 7

THE TRAINING COURSE CONTROL DOCUMENT (TCCD) MODULE

7.0 The Training Course Control Document (TCCD) Module
7.1 Overview of the TCCD
7.2 The TCCD Module
   7.2.1 The TCCD Window Cover Page
   7.2.2 The TCCD Learning Sites
   7.2.3 The TCCD Trainee Data
   7.2.4 Printing the TCCD
   7.2.5 The TCCD Foreword and Course Overview/Comments
   7.2.6 Approving and Maintaining the TCCD, LP, and TG
   7.2.7 Central Site Options
7.3 Summary
# The Training Course Control Document (TCCD)

## Overview of the TCCD

In AIM I, the normal method of creating a TCCD assumes that a Training Project Plan (TPP) has been developed for the course and the course has been selected in a Training Path System's (TPS) Training Path Chart (TPC) Course List. If the TPP has been locked, the information developed for the TPP is copied by AIM I to the TCCD. You will then be required to develop the information required for the following:

- Instructor/Support Manning
- Course Foreword
- Trainee Data
- Learning Sites RRL Quantity Information
- Curriculum Outline of Instruction (COI)
- Course Master Schedule (CMS)
- Fault Applicability List (FAL) for maintenance course if applicable.

The TCCD Module of AIM I aids in the development of the Foreword, Course Data, Trainee Data, and the RRL Annex portions of the TCCD. Because of their complexity, the COI with Profile Item-to-Topic Objective Assignment Chart (OAC) and Fault Applicability (FAL) Annexes, and the CMS portions are developed separately.

## The TCCD Module

During the development of a TCCD, you have the opportunity to modify the CIN, RRL, and Course Data for each Learning Site that was entered when the TPP was developed. For example:

If a TPP was developed for a new course and there was no CIN, you fabricated a CIN to develop the TPP. When you develop the TCCD, you will modify the CIN to the number assigned by the CCA. By modifying the CIN, AIM I will automatically change the number in the Course Select List and the Course List of the TPS and in the TPP. The number will be linked to the fabricated number identified in the TPP in the database.

### The TCCD Window Cover Page

To access the TCCD module from the AIM I window:

There are four different ways to access the TCCD window after the course has been selected from the Course Select menu:

1. From the AIM I main menu select the **Document** menu item and the **Training Course Control Document (TCCD)** sub-menu item.
2. Click on the TCCD icon.
3. From the course tree structure click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TCCD element in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.

4. From the course tree structure click on the TCCD folder, select the **Options** menu item and the **GoTo** sub-menu item. Opening the TCCD folder can provide Summary or Note data on the right hand portion of the course tree grid if the **View** menu sub-items (**Note** or **Summary**) have been checked. Summary data includes the information contained in the TCCD window and Note data contains Personal and/or Private Notes recorded by developers. A

AIM I will present the CINs TCCD window (*Figure 7-1*).
The TCCD window contains the following menu items:
- Options
- Contents
- Edit
- Exit
- Help

Step 1  To modify a field on the Cover Page, click on that field and edit as necessary. The Tab key can also be used to move from field to field.

**NOTE:** As long as the TCCD is in the Incomplete or Complete status, the course Cover Page information can be modified. The TCCD will remain in the incomplete status as long as Training Requirements haven’t been selected in the COI.

Step 2  Enter the Instructor/Support Manning information required in the last field.

Step 3  Select the Edit menu item and the Save option to save your modifications, or Cancel to cancel your entries.

### 7.2.2 The TCCD Learning Sites

When the TPP for the selected course was locked, the Course Data and Learning Site data were copied to the TCCD by AIM I. The Learning Sites identified in the TPP may have changed, or the information relating to the Learning Sites may need to be modified.

**To access the TCCD Learning Sites:**

There are three different ways to access the Learning Sites window of the TCCD after the TCCD window has been selected:

1. Select the Document menu item and the Training Course Control Document (TCCD) sub-menu item or click on the TCCD icon to open the TCCD window. From the TCCD window select the Contents menu item and the Learning Sites sub-menu item.
2. Double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the Learning Sites folder and can exercise Options menu sub-items (Edit Note and GoTo) and View menu sub-items (Note and Summary).
3. From the course tree structure, click on the TCCD folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the Learning Sites element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.

AIM I will present the Learning Sites window, which contains a list of all Learning Sites in the AIM I database (Figure 7-2) if the Show Selected Sites Only option has not been selected. The sites that contain an X in the Select column are the sites selected to teach the course. The site that contains an X in the CCMM column is the Course Curriculum Model Manager responsible for developing changes and revisions to the course.
To modify the Learning Site information for a selected Learning Site:

Step 1  Highlight the desired Learning Site and select the Learning Site window **Options** menu item. Select the **Modify** option, and AIM I will present the Course Data information for the highlighted site.

Step 2  Edit the fields for CDP, Course Length, Class Min. and Max. Capacities, Class Convening, Student Throughput, and Site Considerations as required. When changing the Max Class Capacity you will be asked if you want to update all CMS periods with the new Instructor/Student ratio for the course.

Step 3  Select the **Edit** menu item and the **Save** option to save your modifications or **Cancel** to cancel your entries.

**NOTE:** The TPP contained RRL item fields for Quantity on Hand and Quantity Required. The required information for each item in the TCCD is contained in the fields Per Class, Per Trainee, and Per Instructor, which are pre-loaded by the software with number one (1) in each field. Certain resources only contain a Per Class fields for quantity information because this is the only field that prints in the TCCD RRL for quantity. You must modify these fields to indicate the quantity required.

Step 4  Select the **RRL** menu item and each type of Resources cited in the TPP. Verify the quantity information is correct for each item. Modify the quantity required information as necessary and select the **Edit** menu item and the **Save** option to save your modifications.
**NOTE:** An IETM RRL item can only be added to the Site RRL from the Admin Utility. To Add/Modify/Delete an IETM RRL item in the Site RRL contact the AIM Administrator.

Step 5 When all modifications to the Learning Site RRL are complete, select the **Exit** menu item, save your entries, and return to the Learning Site window.

**To add additional resources to the Learning Site RRL:**

Step 1 From the Learning Sites window highlight the desired Learning Site and select the **Options** menu item and the **Modify** option, and AIM I will present the Course Data information for the highlighted site.

Step 2 Select the **RRL** menu item. AIM will open the Learning Site RRL window.

Step 3 Select the **Resources** menu item and click on the type of resource desired.

Step 4 From the Site RRL (bottom grid) highlight the item desired.

Step 5 Select the **Options** menu item and the **Select Course RRL** option.

Step 6 AIM will enter a quantity of “1” in the quantity fields for the item selected. Edit the fields to reflect the quantities actually required.

**NOTE:** Certain resources only contain a Per Class fields for quantity information because this is the only field that prints in the TCCD RRL for quantity. You must modify these fields to indicate the quantity required.

Step 7 When all modifications to the Learning Site RRL are complete, select the **Exit** menu item, save your entries, and return to the Learning Site window.

**NOTE:** When an RRL item is added to the Learning Site RRL a flag (‘X’ Maintenance Flag) will appear to inform all users that the item was added to the TCCD and may not appear in the TPP RRL for the site. A System Flag (‘@’) will also be generated and appear on the Learning Site window for the Learning Site selected.

**To unselect resources from the Learning Site RRL:**

Step 1 From the Learning Sites window highlight the desired Learning Site and select the **Options** menu item and the **Modify** option, and AIM I will present the Course Data information for the highlighted site.

Step 2 Select the **RRL** menu item. AIM will open the Learning Site RRL window.

Step 3 Select the **Resources** menu item and click on the type of resource no longer required.
Step 4 Highlight the item and select the **Options** menu item and the **Unselect Course RRL** option. The item will return to the bottom grid.

Step 5 When all modifications to the Learning Site RRL are complete, select the **Exit** menu item, save your entries, and return to the Learning Sites window.

**To replace an existing Course RRL item with another RRL item:**

**NOTE:** The **Replace** option can be performed only on RRL items of the same type (i.e., replace a Reference with another Reference, Computer with another Computer, etc.).

Step 1 From the Learning Sites window highlight the desired Learning Site and select the **Options** menu item and the **Modify** option, and AIM I will present the Course Data information for the highlighted site.

Step 2 Select the **RRL** menu item. AIM will open the Learning Site RRL window.

Step 3 Select the **Resources** menu item and click on the type of resource desired.

Step 4 Highlight the Course RRL item that you want to replace and select the **Options** menu item and the **Replace** option.

Step 5 The software will ask for confirmation. Click on the **Yes** button to confirm.

Step 6 At the prompt “Select an RRL to replace it.” click on the **OK** button. From either the Learning Site RRL (Top Grid) or the Site RRL (bottom grid) highlight the item that will be used to replace the RRL item selected for replacement.

Step 7 Select the **Options** menu item and the **Replace with…** option.

Step 8 The software will ask for a final confirmation. Click on **Yes** to complete the replacement, **No** to select another item to replace it with, or **Cancel** to terminate the **Replace** option.

**To add a later version of an IETM to a Learning Site RRL:**

Step 1 From the Learning Sites window, click on the CCMM site and select the **Options** menu item and the **Modify** option.

Step 2 From the Course Data window select the **RRL** menu item.

Step 3 From the Learning Site RRL window click on the **Resources** menu item and the **IETM** sub-menu item.

Step 4 Click on the new IETM identifier in the Site RRL and select the **Options** menu item and the **Select Later IETM** option.
Step 5 When prompted with "This is a later version of a currently selected IETM. All RIA/TG Sheets will be updated to reflect the use of the new IETM. These changes will be saved now and you will not be able to undo this action. Continue?" click on the **Yes** button. AIM will flag the updated RIAs and TG Sheets with System Flags to indicate the reference has been updated to a later version IETM and the IETM has been modified or deleted.

**To add additional Learning Sites:**

**NOTE:** If only the selected Learning Site(s) appear in the Learning Sites window select the **Options** menu item and click on the **Show Selected Sites Only** option to remove the check mark. All sites available from the Learning Site Utility will appear for selection.

---

Step 1 From the Learning Sites window, highlight the desired Learning Site, select the **Options** menu item, and select the **Select Site** option. AIM I will prompt, *Copy CCMM data to this selected site?*

Perform one of the following:

- Click on **Yes** to copy the CCMM Course Data, RRL Manpower and Funding data to the data fields of the site highlighted.
- Click on **No** to enter Course Data and Resources in the blank fields provided.
- Click on **Cancel** to terminate the **Select Site** option.

Step 2 If you selected **Yes** AIM I will prompt "*Copy RRL data from the CCMM site to this selected site?*" If you want to create a separate RRL for each site with the same information as the CCMM click on **Yes**, if not click on **No**.

Step 3 After answering the prompts, enter the CDP for the selected site and modify the Course Data and Resources as necessary.

**To change the CCMM to another selected site:**

Step 1 Select the **Contents** menu item on the TCCD main window, and click on the **Learning Sites** sub-menu item. A list of Learning Sites will appear.

**NOTE:** Learning Sites are added to the list through the AIM I Utilities module. If you do not see the Learning Site that you want to select, your AIM Administrator can add them.

---

Step 2 Highlight/click on the site desired for CCMM.

Step 3 Select the **Options** menu item and the **Select CCMM** option.

Step 4 AIM I will prompt; *This Site is selected as the new CCMM. CCMM data from old CCMM Site will replace this Site's data. Continue?*

Step 5 Click on **Yes** to select the highlighted site as the new CCMM. Click on **No** to terminate the option.
Step 6  If you selected a new CCMM, enter the CDP for the selected site and modify the course and RRL data fields as necessary. Refer to the previously outlined steps for modifying Learning Site information.

To unselect a Learning Site, highlight the Learning Site no longer required, and select the Options menu item and the Unselect option. AIM I will unselect the Learning Site, the course data, and all related RRL data.

When you have completed the Learning Site modifications, select the Learning Sites window Exit menu item, save your entries, and return to the TCCD window.

7.2.3 The TCCD Trainee Data

The Trainee Data portion of the TCCD is used to record:

- The Personnel Physical Requirements, Security Clearance, and Obligated Service required of the trainee to attend the course
- The NOBC/NEC/MOS the trainee earns at the completion of the course.

To enter trainee data:

Step 1  Perform one of the following to identify the trainee data required for the course:
   a. From the TCCD window, select the Contents menu item and the Trainee Data sub-menu item. The Trainee Data window will open.
   b. From the course structure tree click on the TCC folder and expand the tree by clicking on the ‘+’ block. Click on the Trainee Data folder and select the Options menu item and the GoTo option or double-click on the Trainee Data folder on the upper right hand grid.

Use the TAB key to advance forward through the fields. To go backwards through the fields, press Shift + Tab. You can also use the arrow keys.

AIM I will present the Trainee Data window, which contains fields for entry of trainee requirements (Figure 7-3).

**NOTE:** Defaults of None and 00 months are recorded in the fields if the entries are not applicable to the course. Edit only the fields required.
Step 2 Click on the Personnel Physical Requirements field and enter the requirements per applicable directives.

**NOTE:** Use the **Tab** key to move from field to field or click on the desired field with your mouse. You can select items in a pop-up menu by clicking on the item with your mouse or highlighting the item with the arrow keys.

Step 3 Enter the Security Clearance required for attending the course.

Step 4 Enter the Obligated Service in months.

Step 5 Enter the NOBC/NEC/MOS that will be awarded at the completion of the course (the field will accept up to 15 characters).

Step 6 Select the **Edit** menu item and the **Save** option to save your modifications or the **Cancel** option to cancel your entries and remain in the Trainee Data window.

Step 7 When all modifications to the Trainee Data are completed, select the **Exit** menu item to return to the TCCD window or the Course Tree Structure.
7.2.4 Printing the TCCD

The two options available for printing the TCCD are **Print Preview** and **Print**. The **Print Preview** option allows you to view the contents of the TCCD and print the current page displayed, range of pages, or the entire document, and save the TCCD as a PDF file. The **Print** option allows you to print the entire document without viewing. For either option the user has the ability to view/print the RRLs for either all Learning Sites or a selected Learning Site.

The entire TCCD printout will consist of:
- TCCD Cover Page
- Table of Contents
- Place holder for the Letter of Promulgation
- Foreword
- Course Data
- Trainee Data
- Curriculum Outline of Instruction
- Annexes:
  - Profile Item-to-Topic Objective Assignment Chart (OAC)
  - Resource Requirements List (RRL) for a selected site or all sites
  - Course Master Schedule (CMS)
  - Fault Applicability List (FAL)

The RRL will contain the Transparencies and Slides added in the TCCD. If an LP has not been created or the Transparencies/Slides have not been selected in RIAs their number will be blank.

**Print Preview of a TCCD**

Selection of **Print Preview/Print** and either of the sub-menu items will open the Printer Setup window where you have the functionality to add:
- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting **OK** will present the default printer selected. Selecting **OK** from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:
- **Options** - contains the options to **Print** or **Save to PDF**. **Print** opens the Print window, which allows you to print a page, range of pages, the whole document, print to file, and number of copies. **Save to PDF** saves the document as a PDF file to the desired location.
- **Go To** - moves to the previous, next, first, last, or desired page.
- **Exit** - returns to the TCCD window.
- **Help** - provides text to explain how to use the Print Preview option.
The following buttons and fields are available on the control bar:

- **Previous** - moves to the previous page.
- **Next** - moves to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Access the page desired by typing in the page number in the first field and depressing **Enter**.
- **Actual Page** - displays the actual page number, as shown on the page. Access the page desired by typing in the page number in the field and depressing **Enter**.

The right and left mouse buttons allow you to zoom in and out by double clicking on the page and allows you to view multiple pages. Double click the left mouse button to zoom in to a single page display and double click the right mouse button to zoom out.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

**To print preview all sites:**

1. Select the **Options** menu item and the **Print Preview** option.
2. Select the **View TCCD of All Sites** sub-menu item.
3. From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the **OK** button and AIM will prepare the TCCD for print preview and display the first page of the TCCD in the window.
4. Exercise the Print Preview options noted above and when completed select the **Exit** menu item to return to the TCCD window.

**To print preview selected sites:**

1. Select the **Options** menu item and the **Print Preview** option.
2. Select the **View TCCD of Selected Site** sub-menu item.
3. Double click on the desired Learning Site for print preview.
4. From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the **OK** button and AIM will prepare the TCCD for print preview and display the first page of the TCCD in the window.
Step 5  Exercise the Print Preview option noted above, as desired and when complete select the Exit menu item to return to the TCCD window.

**To print all sites:**

Step 1  Select the Options menu item and the Print option.

Step 2  Select the Print TCCD of All Sites sub-menu item.

Step 3  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the OK button AIM will open the Print window where you can select the printer desired.

Step 4  After the printer selection has been made click on the OK button. AIM will prepare the TCCD for printing and send the printout to the printer.

**To print selected sites:**

Step 1  Select the Options menu item and the Print option.

Step 2  Select the Print TCCD of Selected Site sub-menu item.

Step 3  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the OK button AIM will open the Print window where you can select the printer desired.

Step 4  Highlight the desired site and click on the Select menu item for print. AIM will open the Print window where you can select the printer desired.

Step 5  After the printer selection has been made click on the OK button. AIM will prepare the TCCD for printing and send the printout to the printer.

**7.2.5 The TCCD Foreword and Course Overview/Comments**

There are three different ways to access the TCCD Course Foreword or Courses Overview/Comments window after selecting the Course from the Course Select window:

1. Select the Document menu item and the **Training Course Control Document (TCCD)** sub-menu item or click on the TCCD icon to open the TCCD window. From the TCCD window select the Contents menu item and the Foreword or Course Overview/Comments sub-menu item.
2. From the course tree structure, double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the Foreword or the Course Overview/Comments folder and can exercise **Options** menu sub-items (**Edit Note** and **GoTo**) and **View** menu sub-items (**Note** and **Summary**).

3. From the course tree structure, click on the TCCD folder. This will identify the elements of the TCCD in the upper right hand grid. Either double-click on the Foreword or Course Overview/Comments folder in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.

4. The TCCD window **Contents** menu item contains the options to select **Foreword** or **Course Overview/Comments**. When either option is selected, AIM I will present the AIM I Text Editor screen for text entry. For information on using the Text Editor, see Chapter 2, Section 2.5.

The Foreword describes the training the course is designed to provide. The Course Overview/Comments, which was provided from the TPP, is used to describe the contents of the course.

### 7.2.6 Approving and Maintaining the TCCD, LP, and TG

When development of the TCCD, LP, and TG has been completed and a Letter of Promulgation has been received from the CCA, the curriculum can be approved from the Utilities and Admin portion of the AIM I database. Approval of the course approves the TCCD, LP, and TG. All system-generated flags must be removed and all RRL items cited in the course must be approved before the course can be approved.

Magenta is the color used in the Course Select menu to indicate that a Course contains maintenance records that have been generated AFTER the Course was approved. The flagging can be a result of exercising the Site RRL option of **Flag Related Materials** on an approved course or, if the course contains Parts/Sections/Topics copied from another course that is linked to the course being maintained, the originating course material has changed. The flags and their explanations can only be seen after creating a new change or revision to the Course.

After creating a change to the magenta course, you can examine all the system flags and see what changes were made and determine whether those changes affect the magenta course. If none of the changes affect this Course (say some spelling was fixed in a source document), you could then decide to delete the change, as there's nothing to really warrant creating one. Once a change is made to a Course in magenta, the color is reset.

If later on the user decides to make a change to the Course (perhaps its magenta again because some other source material was modified) and the user selects "Maintenance->Create Change", they have the option of selecting to either include the flags they've already viewed (and deemed insufficient reason to create a change), or exclude them, as they already deemed them as having no bearing on the Course.
To initiate maintenance of an approved course, this includes the TCCD, LP, and TG:

**Step 1** From the AIM I main menu, select the **Course** menu item and the **Select** sub-menu item, or click on the Select Course icon.

**Step 2** From the Course Select window highlight the approved curriculum that you want to maintain.

**Step 3** Click on the **Options** menu item and select the **Maintain** option. A sub-menu will offer you the choice of creating a **Revision** or a **Change**.

**Step 4** AIM I will display a series of messages that report it is creating a change/revision; retrieving TPP, COI, LP, and TG information; and copying Course Data to the database. When completed, AIM I will update the Course Select window with the next change/revision of the course.

**Step 5** Highlight the change/revision you just created and click on the **Select** menu item. AIM I will return you to the main menu.

**NOTE:** The TCCD is unlocked, and you can perform the maintenance actions required to modify the structure of the course in the COI, modify the CMS, or modify the data in the TCCD module. To maintain the LP or TG, you must lock the TCCD.

Once a change or revision has been created for a course, AIM I looks to see if a later change or revision has been made to the Training Path Chart (TPC) from which the approved course originated. If a change or revision to the TPC exists, the TLAs that were used to select training requirements for the course may have changed. If the TLAs have changed, selection of the later TPC will forward System maintenance flags to the TCCD, along with their maintenance records, to aid you in developing the change/revision for the course.

If a later change/revision exists for the originating TPC, continue with Step 6; if not, refer to the appropriate chapter of the AIM User's Manual to determine the elements that require maintenance.

**Step 6** Select the Document menu item and the **Curriculum Outline of Instruction (COI)** menu item, click on the COI icon, or open the COI folder in the Course Tree Structure and select the **GoTo** option for the course selected. AIM I will retrieve the Parts/Sections/Topics window for the course selected.

**Step 7** Select the **Contents** menu item and click on the **Training Requirements** sub-menu item. AIM I will retrieve the TPC window for the course. From there, you can select the latest change/revision created for your TPC to create the change/revision for your course.

**NOTE:** The TPC window will not appear if there has been no change to the TPC.
Step 8 Click on the Latest Rev/Chg to your TPC, which will contain a flag. Select the **Options** menu item and the **Select Later TPC** option. AIM I will compare the OAC records with the new TPC and update the TLAs for the course with the new information, along with System flags.

Step 9 Highlight a flagged TLA and click on the **Select** menu item. AIM I will retrieve the TLA. Applicability Codes that have been added, deleted, or modified and PPP table line items that have been modified will be flagged to inform you of impending maintenance actions. The Applicability Codes that were added can be selected for the course as training requirements, if appropriate.

Step 10 Highlight each flagged item and review the maintenance record by selecting the **Options** menu item and the **Explain Flag** option. Return to the Line Items window by selecting the Maintenance Explanations window **Exit** menu item.

Step 11 For line items that were modified or deleted, no training requirements maintenance actions are required in the Line Items window. The TLOs will be flagged for modification or deletion. For Applicability Codes that were added, if you want to select them as training requirements for this course, highlight the Applicability Code desired and double click on it. An X will appear where the Applicability Code was to indicate that it will be selected as a training requirement once your modifications to the TLA have been saved to the database.

Step 12 Select/unselect Applicability Codes as necessary by double clicking on the X or Applicability Codes. All maintenance actions on your part will be recorded in the Maintenance Explanations record of the database, and the line item will indicate a user maintenance flag.

Step 13 When you have completed your modifications select the **Exit** menu item and save your training requirements modifications to the database. AIM I will return you to the TLA window.

Step 14 Repeat Steps 9 through 13 for each TLA that is flagged.

Step 15 From the TLA window select the **Exit** menu item to return to the Parts/Sections/Topics window.

**NOTE:** The Topics affected by the training requirements modifications have been flagged.

Step 16 Select the CLOs for the course and the TLOs for each Topic flagged, and review the explanations for each flagged item. Perform the appropriate maintenance action for each flagged item. Refer to the COI Module, Chapter 7, for specific direction on each of the COI functions.
7.2.7 Central Site Options

For Central Sites there are two additional option located on the Options drop-down menu:

- **Developing Authorities**: This is used in the same manner as the Developing Authorities option for the TPP, to add sites that will work on the course.
- **Lock for Review**: This option is used to Lock site from working on a course while it is being reviewed. Administrators and Curriculum Managers can select which Developing Authorities are locked. There is no "Unlock for Review" to unlock a site select "Lock for Review" then unselect the desired site.

7.3 Summary

The TCCD module aids in the development of the Foreword, Course Data, Trainee Data, and the RRL Annex portions of the TCCD.

Chapter 6 provided instructions on completing the Cover Page; on modifying and adding Learning Site information; on changing the CCMM; on recording Trainee Data; and on preparing the Foreword and Course Overview/Comments. It also provided instructions on approving and maintaining the Course (TCCD, LP, and TG).
CHAPTER 8

THE CURRICULUM OUTLINE OF INSTRUCTION
(COI) MODULE

8.0 The COI Module
8.1 Overview of the COI
8.2 The Part/Section/Topic Window
  8.2.1 Part/Section/Topic Window Menu Bar Items
8.3 Development of the COI
  8.3.1 Selecting the Course Training Requirements
  8.3.2 Selecting and Working With TLOs in a Topic
  8.3.3 Entering TLO Test Item Numbers in the OAC for a TLO
  8.3.4 Selecting and Working With CLOs
  8.3.5 Joining Parts, Sections, and Topics
  8.3.6 Unjoining a Part
  8.3.7 Splitting a Part, Section, or Topic
  8.3.8 Copy Part/Section/Topic from another Course
  8.3.9 Deleting a Part, Section, or Topic
  8.3.10 Resequencing Parts, Sections, and Topics
  8.3.11 Print Preview Option
  8.3.12 Print Option
8.4 Summary
8.0 The COI Module

8.1 Overview of the COI

The Curriculum Outline of Instruction (COI) module is part of the Training Course Control Document (TCCD). The TCCD must be unlocked to work on the COI. During development of a curriculum, there is no structure to the COI until you select the training requirements for the course. Once training requirements have been selected, the COI will contain Course Learning Objectives (CLOs), Parts, Sections, Topics, and Topic Learning Objectives (TLOs).

The preliminary COI is a developer’s best guess of the CLOs, TLOs, and organization of the Parts, Sections, and Topics. The preliminary COI is used by the Curriculum Control Authority (CCA) to determine whether the developer is on track for meeting course and topic objectives.

The final COI contains the actual CLOs, TLOs, and structure of the course from the approved course pilot and reflects the approved curriculum. When the course is approved, the TCCD (which includes the COI, Course Master Schedule, and Annexes), Lesson Plan (LP), and Trainee Guide (TG) are approved. Once approved, these items can only be viewed, and maintenance can only be accomplished by creating a change or revision to the course. Refer to Chapter 7, paragraph 7.2.6, for directions on maintaining a course.

8.2 The Part/Section/Topic Window

The Part/Section/Topic window (Figure 8-1) allows you to develop CLOs, along with the structure of the course in Parts, Sections, Topics, and TLOs.

The Part/Section/Topic window contains:

- A title bar that displays the CIN (Course Identification Number), REV (Revision), CHG (Change Number), and menu bar items.
- A data grid that shows the Parts, Sections, and Topics that are created initially from selecting training requirements for the course.

A flag column, which can contain System Maintenance flags (@) and User Maintenance (X) flags if the course is being maintained (Change or Revision). The system maintenance flags can be generated from user maintenance actions performed on the originating Training Path Chart (TPC) TLA(s) cited in the course, and User Maintenance flags can be generated by maintenance actions a user performs in the COI.
8.2.1 Part/Section/Topic Window Menu Bar Items

The Part/Section/Topic window menu bar consists of:

- **Options**
- **Contents**
- **Edit**
- **Exit**
- **Help**.

8.2.1.1 Part/Section/Topic Window Options Menu Item

The Options menu provides functions that enable you to manipulate the Parts, Sections, and Topics, as well as to view and print the COI.

The Options menu contains the following options:

- **Join**: Allows you to join Parts, Sections, and Topics.
- **Unjoin**: Allows you to unjoin previously joined Parts.
- **Split**: Allows you to split Parts, Sections, and Topics.
- **Copy Part/Section/Topic from another Course**: Allows you to copy training material from other courses in the database into your course.
AIM I USER’S MANUAL THE COI MODULE

- **Delete**: Allows you to delete the highlighted Part, Section, or Topic.
- **Find**: Allows you to find a specific Part/Section/Topic.
- **Print Preview**: It allows you to print the current page that is displayed, a range of pages, or the entire COI.
- **Print**: Allows you to print the COI.

8.2.1.2 The Part/Section/Topic Window Contents Menu Item

The **Contents** menu item allows you to access the Training Requirements, CLOs, TLOs, and Test Items windows, which provide the functions to:

- Select the Training Level Assignments (TLAs) required for the course and select the **Training Requirements** from each TLA
- Edit the Course Learning Objectives (CLOs), after the training requirements have been selected, for modification
- Edit the AIM I-generated Topic Learning Objectives (TLOs) for the highlighted Topic and add additional TLOs from other TLAs
- Enter **Test Item** numbers for each TLO identified in the Profile Item-to-Topic Objective Assignment Chart (OAC).

8.3 Development of the COI

Initially, there is no course structure because the TLAs and the training requirements have not been selected for the course. When you access the Part/Section/Topic window of the COI, the fields are blank. The starting place for developing a COI is in the selection of TLAs and training requirements.

There are four different ways to access the COI after the course has been selected:

1. From the AIM I main menu select the **Document** menu item and the **Curriculum Outline of Instruction (COI)** sub-menu item.
2. Click on the COI icon.
3. From the course tree structure click on the COI folder, select the **Options** menu item and the **GoTo** sub-menu item. The **View** menu item contains sub-menu items for **Note** (Public and Private) and **Summary** data. When these sub-menu items are checked the Note/Summary data will be displayed in the right hand grids of the Course tree structure. Opening the COI folder will provide Summary data that identifies the Course Learning Objectives (CLOs) after the Training Requirements have been selected.
4. From the course tree structure, click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the COI element in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.
8.3.1 Selecting the Course Training Requirements

To select the course training requirements:

Step 1 Select the COI. If the TCCD is locked, you will have to unlock it to work on the COI.

NOTE: The COI menu item or icon is enabled only after the course has been assigned to a TPS/TPC.

Step 2 From the Part/Section/Topic window; select the Contents menu item and the Training Requirements sub-menu item.

Step 3 AIM I will present a list of the TLAs from the Course’s originating TPS and TPC. Highlight the desired TLA from the column “Non-Used TLA” and click on the Select menu item. AIM I will present the TLA for selection of training requirements. If the PPP Table associated with the TLA is not locked or approved the software will prompt you with the question “TLA is not Locked or Approved. You can view the selected information but cannot make changes. Continue?” Click on the Yes or No button to proceed.

NOTE: The Applicability Codes presented will depend on the type of course you are developing. For a Replacement course, the TLA will only contain Applicability Codes of R/B. For an Advanced course, the TLA will only contain B/A. For a Conversion course, the TLA will only contain R/B/A. For a Background course, the TLA will only contain 5s. If a TPC’s TLA does not contain the Applicability Codes that are applicable to the type of course you have selected, the Applicability Codes will not appear in the TLA window for selection.

Step 4 There are two ways that you can select the Applicability Codes at the desired TOS as training requirements for your course:

- To select all of the codes for your course: Select the TLA Line Items window Options menu item and the Select All option.
- To select individual codes for your course: Double click on the desired codes.
- To read the entire line item select the Options menu item and the View Line Item Text option.

NOTE: Once an Applicability Code is selected, the code will change from an R/B/A/5 to an X to indicate that the line item at the TOS selected is a training requirement for the course.

Step 5 There are two ways to unselect an Applicability Code:

- To unselect all of the codes for your course: Select the TLA Line Items window Options menu item and the Unselect All option.
- To unselect individual codes for your course: Double click on the X.

NOTE: Once an X is unselected, the X will change to the R/B/A/5 Applicability Code.
Step 6  Select **Exit** and click on the **Yes** button to save the selected training requirements to the database and return to the TLAs window. If the TLA was selected from the “Non-Used TLA” column it will now appear in the “Used TLA” column.

Step 7  Repeat Steps 3 through 6 for each additional TLA required for the course.

**NOTE:** The software will develop a Part for each TLA selected. A Section will be developed for each TOS level identified as a training requirement. A Topic will be developed within each Section for each category the line items selected were part of in the PPP table. TLOs will be developed for each of the Topics from line items selected in each category at the Sections TOS level. CLOs will be developed from the training requirements at the highest-level TOS selected.

Step 8  Select the TLAs window **Exit** menu item to return to the Part/Section/Topic window.

Before the training requirements were selected for the course, the COI was blank. With the selection of training requirements, AIM I developed:

- CLOs
- An OAC
- A course structure of Parts, Sections, and Topics, and TLOs.

The developer’s task for the completion of the COI is:

- To put the Parts, Sections, Topics, and TLOs in the order that they will be taught in the classroom
- To edit the CLOs, Section and Topic titles, and TLOs to reflect the course content.

There are several options available to aid in editing, resequencing, joining, unjoining, and splitting the various items.

### 8.3.2 Selecting and Working With TLOs in a Topic

There are two ways to select the TLOs in a Topic:

- In the Part/Section/Topic window, highlight the Topic Number desired and select the **Contents** menu item and the **TLOs** sub-menu item. AIM I will present the TLOs window (*Figure 8-2*), in which you can work on the TLOs for the Topic highlighted.
In the Part/Section/Topic window, highlight the Topic Number desired in the Part/Section/Topic No. column and double click. AIM I will present the TLOs window, in which you can work on the TLOs for the Topic highlighted.

The TLOs window contains the following menu items:
- **Options**
- **Edit**
- **Exit**
- **Help**

The **Options** menu item contains the following options:
- **Join**: Allows you to join two TLOs together.
- **Unjoin**: Allows you to unjoin previously joined TLOs.
- **Split**: Allows you to split a TLO for the purpose of clarifying a complex TLO and to ensure that AIM I will generate more than one Discussion Point (DP) for the TLO.
- **Delete**: Allows you to delete the highlighted TLO.
- **TLA Links**: Allows you to view the TLA TOS level and the PPP table line item that is linked to the TLO. It also allows you to delete the link if the TLO is linked to more than one line item in the TLA. This option is of particular importance when performing maintenance on a TLO that has sub-items or if it has been joined with another TLO. You can view the current links, if any and edit the TLO appropriately.
- **Other Table**: Allows you to create TLOs from the training requirements selected in the TLAs for the course.
- **Explain Flag**: Allows you to view the reason a TLO is flagged.
- **Remove Flag**: Allows you to remove the flag from the database.

### 8.3.2.1 Joining TLOs

**To join two TLOs:**

1. Step 1: Highlight the primary TLO and select the **Options** menu item.
2. Step 2: Select the **Join** option. AIM I will direct you to **Click a TLO to join with**. Click on the **OK** button.
3. Step 3: Highlight the TLO that you want to be joined with the primary item selected.
4. Step 4: AIM I will prompt, *Are you sure you want to join?* Click on the **Yes** button to continue; click on the **No** button to cancel the Join operation.
5. Step 5: If you continued the Join operation, AIM I will:
   - Perform the join
   - Append the second TLO identified to the first TLO identified in the join
   - Update the TLO Text column.

Click on the resultant text of the new item, which contains text from both items joined and edit, as necessary.

### 8.3.2.2 Unjoining a TLO

The Unjoin option unjoins a previously joined TLO. To unjoin a previously joined TLO:

1. Step 1: Highlight the TLO to unjoin and select the **Options** menu item and the **Unjoin** option.

   **NOTE**: AIM I will then determine whether the item was previously joined. If the item was not previously joined, AIM I will prompt, *Cannot unjoin, TLO not joined*. Clicking on **OK** will cancel the option.

2. Step 2: AIM I will present a window that displays the PPP Table Number (PTN), Revision and Change, and Line Item Numbers that were originally used by AIM to make the TLO. Highlight the line item desired for the TLO and select the **Options** menu item and the **Select** option. An X will appear in the column to the left of the PTN to indicate the line item has been selected for unjoining.
8.3.2.3 Splitting a TLO

The Split option allows you to split a TLO. Split takes a TLO that has not been *joined* and creates a second TLO. You identify the appropriate content for each item split.

**To split a TLO:**

Step 1 Highlight the TLO to split, and select the **Options** menu item and the **Split** option. AIM will split the TLO, creating a duplicate TLO immediately following the TLO selected.

Step 2 By double clicking on the TLO text, modify the text of each of the resultant TLOs, as necessary, to reflect the portions of the original TLO you want in each.

Step 3 Select the **Edit** menu item and the **Save** option to save the TLOs.

**To split a TLO that has sub-items, perform the following:**

Step 1 Highlight the TLO to split and select the **Options** menu item and the **Split** option. AIM I will present you with a list of the sub-items to select for the first TLO.

Step 2 Select the **Options** menu item and the **Select** option for the sub-item highlighted or double click on each sub-item desired for the first TLO. An X will appear in the select column.

Step 3 Select the Edit menu item and the Save option to save the TLOs. The sub-items not selected for the first TLO will default to the second TLO.

Step 4 If the original TLO had only two sub-items, join the sub-item into the main TLO text for each of the resultant TLOs in accordance with paragraph 7.3.2.1.
8.3.2.4 Deleting TLOs

If you are deleting the only TLO that exists to support a training requirement in a TLA, the training requirement will also be Unselected from the TLA when the TLO is deleted. If, however, the training requirement is supported by a TLO elsewhere in the course as a result of using the Split or Other Table option, the training requirement will remain.

To delete a TLO:

Step 1 Highlight the TLO and select the Options menu item and the Delete option. AIM will prompt, Are you sure you want to delete this TLO?

Step 2 Click on Yes to delete the TLO; click on No to cancel the delete option.

NOTE: If the course is in Development, deletion of a TLO will not result in deletion of the DPs linked to it, nor will the DPs be marked with system-generated flags. If the course is in Maintenance (Revision or Change), deletion of a TLO will not result in the deletion of the DPs linked to it, but the DP will be marked with system-generated flags.

8.3.2.5 Viewing the TLA Links to the TLO

During development of TLOs it may be necessary to view the TLA, TOS, or PPP table line item that the TLO was initially created from and linked to in the software. This is helpful when two or more TLOs have been joined together or when splitting TLOs apart.

During maintenance a TLO can be flagged for maintenance action because modifications were made to the PPP table line item it is linked to or modifications were made to the TOS in the TLA. This option allows you to view the current text of the PPP table line item without leaving the COI module. This option also permits you to ascertain the correct maintenance action required if the TLO flagged contains sub-items or if the TLO is linked to more than one TLA item and an item was modified/deleted.

To view the TLA links for a TLO:

Step 1 Highlight the TLO and select the Options menu item and the TLA Links option. AIM I will open the TLA Links window that will display the PTN, Rev/Chg, Line Item number, TOS selected in the TLA, and the text of the PPP table line item.

Step 2 Select the Exit menu item to return to the TLOs window.

To delete a TLA link for a TLO that is linked to multiple line items:

Step 1 Highlight the TLO and select the Options menu item and the TLA Links option. AIM I will open the TLA Links window that will display the PTN, Rev/Chg, Line Item number, TOS selected in the TLA, and the text of the PPP table line item.
Step 2  Highlight the applicable TLA line item number/TOS link that is no longer required.

Step 3  Select the **Options** menu item and the **Delete** option.

**NOTE:** If only one TLA Link exists for the item highlighted the software will prompt you that the link cannot be deleted. In this case the TLO itself, or TLO sub-item, must be deleted to delete the training requirement link.

Step 4  Select the **Exit** menu item to return to the TLOs window.

### 8.3.2.6 Creating Additional TLOs for a Topic

AIM I creates a single TLO for each training requirement you selected in the TLA. If that training requirement needs to be reflected in more than one Topic (e.g., if you split a Skill Topic and need another TLO for *Adhere to personnel and equipment safety precautions . . .*), you will need to create the additional TLOs required. The Other Table option allows you to select the TLA and the training requirement desired to create a TLO for a Topic.

To create additional TLOs for a Topic:

Step 1  Select the TLOs window **Options** menu item and the **Other Table** option.

![Figure 8-3. TLA Window](image-url)
Step 2  AIM I will present the TLAs window (Figure 8-3). Highlight the TLA that contains the training requirement you want to select and click on the Select menu item to retrieve the TLA.

Step 3  AIM I will present the TLA Line Items window (Figure 8-4). Highlight the training requirement for the line item and TOS level desired for the creation of a TLO.

![Figure 8-4. TLA Line Items Window](image)

Step 4  Select the Options menu item and the Select option. AIM I will create a TLO for the Topic from which you entered.

**NOTE:** When the applicability code or 'X' is red, the bottom portion of the TLA Line Items Window displays a list of the Cited Courses that contain this training requirement.

Step 5  Repeat Steps 3 and 4 for additional TLOs required from the TLA.

Step 6  Select the TLA Line Items window Exit menu item to return to the TLA window.
Step 7  Repeat Steps 2 through 6 to create additional TLOs from other TLAs.

Step 8  Select the TLA window Exit menu item to return to the TLOs window and observe that the newly created TLOs appear after the pre-existing TLOs.

8.3.2.7 Resequencing TLOs

To resequence the TLOs in the order they will be presented in the Lesson Plan (LP):

Step 1  Highlight the TLO that you want in a different location.

Step 2  Click on the TLO, holding the left mouse button down, and drag it where desired.

Step 3  Drop and release the left mouse button when the hand is positioned at the TLO number that you want.

8.3.3 Entering TLO Test Item Numbers in the OAC for a TLO

To enter Test Item numbers in the OAC:

Step 1  From the Part/Section/Topic window select the Contents menu item and the Test Items sub-menu item. AIM will retrieve the OAC.

Step 2  From the Test Items window (Figure 8-5) highlight the Part, Section, Topic, and TLO for which a Test Item number is to be entered.

Figure 8-5. Test Items Window
Step 3  Highlight and click on the Test Item No. column and type in the Test Item number that relates to the TLO highlighted. The Test Item No. field will accommodate 15 characters.

Step 4  Select the Edit menu item and the Save sub-menu item to save your entry.

Step 5  Repeat Steps 2 through 4 for each additional Test Item number entry required.

Step 6  Select the Exit menu item to return to the Part/Section/Topic window.

8.3.4 Selecting and Working with CLOs

Each time you change the selection of training requirements for the course, the CLOs that are tied to the TLA are rewritten. It is therefore prudent to make editing the CLOs the last step in working on a COI. The alphanumeric Part designators determine the sequence in which the CLOs are presented.

During development of a new curriculum the Options menu sub-item Delete PPP is enabled. The flag options are used when developing revisions and changes. However, the CLOs can be edited to reflect the contents of the course.

To edit the CLOs:

Step 1  From the Part/Section/Topic window select the Contents menu item and the CLOs sub-menu item. AIM I will present the CLOs window (Figure 8-6).
Step 2 Highlight the CLO that needs editing and double click on the CLO text field.

Step 3 Edit, as necessary, and select the **Edit** menu item and the **Save** sub-menu item.

Step 4 Repeat Steps 2 and 3 for each CLO that requires editing.

Step 5 Select the **Exit** menu item to return to the Part/Section/Topic window.

During Maintenance, if training requirements have been Unselected, the CLO and its associated PPP table title will be flagged in the Flag column. The **Options** menu sub-items of the CLOs window will be enabled as follows:

- **Delete PPP**: Allows you to delete the highlighted CLO if all training requirements supporting the CLO have been Unselected. If the CLO references more than one PPP, only the PPP highlighted and flagged for deletion, on the bottom grid portion of the window, will be deleted and the CLO will remain in support of the remaining PPPs.

- **Explain CLO Flag**: Allows you to view the contents of the maintenance record that will record who deleted the associated TOS from the TLA(s) and the date the maintenance action was completed. The PPP titles flagged on the bottom grid portion of the window will reflect the TLAs in which training requirements have been modified.

- **Remove CLO Flag**: Allows you to remove a System or Maintenance generated CLO flag on the top grid portion of the window.
- **Remove PPP Flag**: Allows you to remove the System generated flag, on the bottom grid portion of the window, for the PPP table titles which reflect the TLAs in which training requirements have been modified.

### 8.3.5 Joining Parts, Sections, and Topics

**To join two Parts, Sections, or Topics:**

**Step 1** From the Part/Section/Topic window, highlight the primary Part, Section, or Topic and select the **Options** menu item.

**Step 2** Select the **Join** option. AIM I will direct you to *Click on element to join with.* Click on the **OK** button.

**Step 3** Highlight the Part, Section, or Topic that you want to be joined with the primary item selected.
- AIM I will ensure that you are joining like item types; i.e., Part-to-Part, Section-to-Section or Topic-to-Topic.
- If AIM I detects that you are attempting to join unlike item types, you will be advised that only like item types can be joined. AIM I will then allow you to select a second item for joining.

**Step 4** AIM I will prompt, *Are you sure you want to join?* Click on the **Yes** button to continue or the **No** button to cancel the join operation.

**Step 5** If you continue the join operation, AIM I will:
- Perform the join
- Append the title of the second item identified to the title of the first item identified in the join
- Update the Part/Section/Topic data grid to reflect the joining of the two items.

Highlight and click on the resultant text of the new item, which contains text from both items joined, and edit, as necessary.

### 8.3.6 Unjoining a Part

The Unjoin option unjoins a secondary Part from a primary Part.

**To unjoin a previously joined Part:**

**Step 1** Highlight the primary Part that was a result of joining two or more Parts. Select the **Options** menu item and the **Unjoin** option.
AIM I will determine whether the Part was previously joined.
- If the Part was not previously joined, AIM I will display a message stating that the Part is not a joined item and end the unjoining.
- If the Part was previously joined, AIM I will determine whether the item had been joined more than once.

Step 2 AIM I will present the Unjoin Part window, which contains a list of all secondary Parts that were previously joined to the highlighted primary Part. Highlight the secondary Part you want to unjoin from the primary Part and click on the Select menu item.

Step 3 AIM I will present the Select Sections for Original Part window. Highlight the Section(s) that will remain in the primary Part and select the Options menu item and the Select option. AIM I will place an X in the select column to denote the Sections that are to remain in the primary Part after the Unjoin process.

Step 4 Select the Edit menu item and the Save sub-menu item to unjoin the secondary Part.

Step 5 AIM I will return you to the Part/Section/Topic window. When the Part is unjoined, it will immediately follow the Part from which it was unjoined.

8.3.7 Splitting a Part, Section, or Topic

The Split option allows you to split a Part, Section, or Topic. Split takes a Part, Section, or Topic and creates a second Part (e.g., E3310/2), Section, or Topic. You identify the appropriate content for each item split.

To split a Part:

Step 1 Highlight the desired Part to split in the Part/Section/Topic data grid.

Step 2 Select the Options menu item and the Split option. AIM I will then present a list of the Sections for you to select for the original part.

Step 3 Highlight the Section(s) that are desired in the first Part and select the Options menu item and the Select option. An X in the Select column will indicate the Sections that will be part of the first Part.

Step 4 Select the Edit menu item and the Save sub-menu item to save your selection and begin the Split operation.

To split a Section:

Step 1 Highlight the desired Section to split in the Part/Section/Topic data grid.
Step 2 Select the **Options** menu item and the **Split** option.

Step 3 AIM I will present a Split Section window that contains a list of the Topics contained in the Section selected. Double click on the Topic(s) desired for the first Section (an X will appear in the Select column).

Step 4 Select the **Edit** menu item and the **Save** sub-menu item to save your selection and commence the split operation.

Step 5 AIM I will return you to the Part/Section/Topic window. You will now have two Sections, with the first Section containing the Topics selected above. Double click on each of the Section titles and edit them to reflect their new content.

Step 6 Select the **Edit** menu item and the **Save** sub-menu item to save the new titles.

**To split a Topic:**

Step 1 Highlight the desired Topic to split in the Part/Section/Topic data grid.

Step 2 Select the **Options** menu item and the **Split** option.

Step 3 AIM I will present a Split Topic window that contains a list of the TLOs contained in the Topic selected. Double click on the TLOs desired for the first Topic (an X will appear in the Select column).

Step 4 Select the **Edit** menu item and the **Save** sub-menu item to save your selection and begin the Split operation.

Step 5 AIM I will return you to the Part/Section/Topic window. You will now have two Topics, with the first Topic containing the TLOs selected above. Highlight and click on each of the Topic titles and edit them to reflect their new content.

Step 6 Select the **Edit** menu item and the **Save** sub-menu item to save the new titles.

**8.3.8 Copy Part/Section Topic from another Course**

The Copy Part/Section/Topic option allows you to add material to your course from other courses residing in the AIM database. When this option is performed the software will add the TLA information, of the course being copied, to the Originating TPC of the course in the COI. For this reason the TPS containing the Originating TPC for the course you are copying information to must be unlocked.

**NOTE:** If the TPS containing the Originating TPC is Approved you will have to create a Change/Revision for the TPS and select the later TPC in the COI before selecting Copy Part/Section/Topic.
The LP is not created for a New Course until the COI is developed, the TCCD is locked and the LP Cover Page is saved. The DP, RIA and TG Sheets of the copied material will not be added to the LP/TG if the Copy Part/Section/Topic option is conducted prior to the LP creation.

Creating at least one Part for the COI, locking the TCCD and saving the cover page for the LP will create the LP. Unlocking the TCCD, selecting the COI and executing the Copy Part/Section/Topic option will then copy the DPs, RIAs and TG Sheets of the Part/Section/Topic copied to the LP/TG.

**To Copy Part/Section/Topic from another course into the COI:**

Step 1  From the AIM I main menu click on the **Document** menu item and the **Training Path System (TPS)** submenu item or click on the TPS icon.

Step 2  From the TPS menu highlight the TPS that contains the Originating TPC for the Course from which you will copy information to in the COI.

Step 3  Select the **Options** menu item and the **Unlock** option.

Step 4  Select the **Exit** menu item to return to the AIM main menu.

Step 5  Select the **Course** menu item and the **Select** submenu item.

Step 6  From the Course Select menu highlight the Course that you will be copying information into.

Step 7  Click on the **Select** menu item. The software will open the Course Tree Structure for the Course.

Step 8  Click on the **Document** menu item and the **Training Course Control Document (TCCD)** submenu item or click on the TCCD icon.

Step 9  Select the **Options** menu item and the **Unlock** option.

Step 10 Select the **Exit** menu item to return to the AIM I main menu.

Step 11 From the AIM main menu select the **Document** menu item and the **Curriculum Outline of Instruction (COI)** submenu item or click on the COI icon.

Step 12 Select the **Options** menu item and the **Copy Part/Section/Topic from another Course** option.

Step 13 From the Select Course window highlight the course you want to copy information from and click on the **Select** menu item or double-click on the desired course.
If the information being copied is from a course that was migrated from a UNIX version of AIM and the destination course wasn’t, the software will prompt you with the question “Do you want to continue?”. Clicking on Yes will merge the TOS column data and clicking on No will terminate the Copy Part/Section/Topic option.

Step 14 The Copy Parts/Sections/Topics window opens and displays the course you are copying information from in the top grid and the course you are copying information to in the lower grid.

Step 15 In the top grid click on the Part/Section/Topic you want to copy.

Step 16 In the bottom grid click on the Part/Section/Topic where you want the copied information to follow.

NOTE: Alternatively, you can select the Part/Section/Topic in the top grid and drag and drop it on the Part/Section/topic in the bottom grid. It will be placed after the item you drop it on.

Step 17 Select the Options menu item and the Copy option.

The software will ask you if you want to keep a link from the copied material to its originating source. Answer ‘Yes’ if you do. This will allow changes in the original Course to flag the Course the data was copied into.

NOTE: If you’ve already copied data between two courses and kept the links, the software will assume this should be the case on any subsequent copies, and won’t prompt you again.

Step 18 Select the Edit menu item and the Save sub-menu item to copy the selected information to the course.

Step 19 When the message “Copy succeeded!” appears click on the OK button.

You can copy data from more than one Course into your Course. Also, any particular item in your Course can be linked to multiple original items (for example, if two Topics were copied from two separate Courses, and you joined the Topics, the resulting Topic would have links to both of the original Topics.

8.3.9 Deleting a Part, Section, or Topic

This option should be exercised with caution because deleting a Part during development deletes the Sections, Topics, Topic Learning Objectives (TLOs), Discussion Points (DPs), and Related Instructor Activities (RIAs). Deleting a Section or a Topic deletes all subsequent material. During maintenance this option Flags all subsequent material that has been resequenced.
To delete a Part, Section, or Topic:

Step 1 Highlight the Part, Section, or Topic that you want to delete in the Part/Section/Topic data grid.

Step 2 Select the **Options** menu item and the **Delete** option.

Step 3 The software will prompt you with the question: “Are you sure you want to delete this Part, Section, or Topic?”

Step 4 Click on **Yes** and the software will delete the Part, Section, or Topic highlighted.

### 8.3.10 Resequencing Parts, Sections, and Topics

The Resequence option allows you to resequence Parts, Sections, or Topics in any order.

To resequence a Part, Section, or Topic:

Step 1 Highlight the Part, Section, or Topic that you want to move up.

Step 2 Click on the item and hold the left mouse button down. A hand will appear when you move the mouse up.

Step 3 Position the hand over the location where you want the item and drop (release the mouse button) the item where desired.

### 8.3.11 Print Preview Option

Selection of **Print Preview** will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting **OK** will present the default printer selected. Selecting **OK** from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- **Options** - Contains the options to **Print** or **Save to PDF**. **Print** opens the Print window, which allows you to select the printer, range of pages, print to file, and number of copies. **Save to PDF** allows you to save the document as a PDF file to the desired location.
- **Go To** - Allow moving to the previous, next, first, last, or desired page.
- **Print** - Allows the current page, range of pages, or the entire document to be printed.
Exit - Returns to the Curriculum Outline of Instruction (COI) window.
Help - Provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- Previous - Allows moving to the previous page.
- Next - Allows moving to the next page.
- Find – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- Page _ of Page - Displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Allows you to access the page desired by typing in the page number in the first field and depressing Enter or Tab).
- Actual Page - Displays the actual page number, as shown on the page. Allow you to access the page desired by typing in the page number in the field and depressing Enter or Tab.

The right and left mouse buttons allow you to zoom in and out. Double click the left mouse button to zoom in and double click the right mouse button to zoom out. The inspect toolbar button also allows you to zoom in on the page and allows you to view multiple pages.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

To print preview the COI:

Step 1 From the Curriculum Outline of Instruction (COI) window; select the Options menu item and the Print Preview option.

Step 2 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3 Click on the OK to print preview.

8.3.12 Print Option

Selection of the Print option allows the entire document to be printed:

To print the entire COI:

Step 1 Select the Options menu item and the Print option.

Step 2 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3 Click on the OK to print.
8.4 Summary

Chapter 7 noted the difference between a preliminary COI and a final COI, introduced the components of the COI Parts/Section/Topic Window, and provided instructions on developing a COI via the COI module.
CHAPTER 9

THE COURSE MASTER SCHEDULE (CMS) MODULE

9.0 Course Master Schedule
9.1 Content of the Course Master Schedule
9.2 Using the AIM I CMS Module
9.3 Completing the CMS
  9.3.1 Period Type
  9.3.2 Topic Title
  9.3.3 Entering Week and Day
  9.3.4 Editing Student-to-Instructor Ratio
  9.3.5 Bottlenecks
9.4 CMS Options
  9.4.1 Duplicate CMS Period
  9.4.2 Delete CMS Period
  9.4.3 Print Preview
  9.4.4 Print
  9.4.5 Explain Flag
  9.4.6 Remove Flag
9.5 CMS Events
  9.5.1 CMS Events Options
    9.5.1.1 Add
    9.5.1.2 Add Missing Topics
    9.5.1.3 Delete
    9.5.1.4 Print Preview/Print
    9.5.1.5 Explain Flag/Remove Flag
  9.5.2 CMS Events Columns
9.6 Help
9.7 Summary
9.0 COURSE MASTER SCHEDULE

By completing the Curriculum Outline of Instruction (COI) in the previous module, you have enough data to prepare the Course Master Schedule. In this module, you will place the lesson topics of the COI into a time schedule, thus creating the Course Master Schedule (CMS) for the new/revised course.

The CMS is a management tool that provides the planned period-by-period subject matter for a course, time allocated to each subject, time specified for theory and laboratory instruction, detailed sequence of the instructional program, and maximum student-to-instructor ratio for each period. The CMS is an annex of the Training Course Control Document (TCCD). The CMS is part of the Design phase of curriculum development.

9.1 Content of the Course Master Schedule

The CMS places lesson topics of the COI into a time schedule. Give consideration to grouping topics to provide continuity of instruction. For example, a practical application session is best if it is carried through to its conclusion on the same day.

Closely related lessons topics should be grouped so that one topic is not left to the next day or over a weekend.

The normal scheduled technical training workweek for a student is 40 hours (periods) of approved technical training topics. Time allocated to non-technical training requirements, such as General Military Training, is in addition to this requirement.

Approved non-technical training subjects scheduled outside the 40-hour (period) technical training workweek are included in the Master Schedule if technical training instructors are required to do the training. Physical training and medical or dental time directly related to or required for the technical course completion, or required as a prerequisite for follow-on technical training, may be included in Master Schedules only if technical training instructors not in a duty or watch status are required to participate in those evolutions.¹

The time that you designate for topics should reflect the time required to present the Lesson Topic. The times should not include testing. The total course length is the sum of the lesson topic periods, testing periods, and authorized administrative periods.

¹ This information is derived from CNETINST 5310.4 (Series). Refer to this instruction for further explanation and details on CMS requirements. Since contents of instructions are subject to update or revision, the most recent guidance on CMS development should be verified.
9.2 Using the AIM I CMS Module

There are four different ways to access a CMS after the course has been selected:

1. From the AIM I main menu select the Document menu item and the Course Master Schedule (CMS) sub-menu item.
2. Click on the CMS icon.
3. From the course tree structure click on the CMS folder, select the Options menu item and the GoTo sub-menu item. The View menu item contains sub-menu items for Note (Public and Private) and Summary data. When these sub-menu items are checked the Note/Summary data will be displayed in the right hand grids of the Course tree structure. Opening the CMS folder can provide Summary data that identifies the total number of periods and weeks and the total instructional time for the course.
4. From the course tree structure, click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the CMS element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.

The AIM I CMS module provides all of the tools necessary to complete the CMS for a new or revised course. AIM I will present the window shown in Figure 9-1. Options include Duplicate CMS Period, Delete CMS Period, Print Preview, Print, Explain Flag and Remove Flag.

![Figure 9-1. Course Master Schedule](image)

Selecting Edit on the CMS menu bar allows you to Save or Cancel.
9.3 Completing the CMS

The CMS defaults to the following information provided by other modules of the AIM I software:

- The Number refers to the Part/Section/Topic number.
- The Period Type defaults to class.
- The fields for Week and Day are blank.
- The field for Ratio reflects the Class max. Capacity planned for the Course Curriculum Model Manager (CCMM), which you provided in the TPP module. If there is no CCMM selected in the TPP AIM I defaults to a ratio of 12:1. When the TPP is Locked and the information is copied to the TCCD the Class max. Capacity defaults to the TCCD.
- The field for Bottleneck is blank.

You may edit the CMS data by changing the type of period, specifying the week and day that the topic will be taught, edit the student-to-instructor ratio, and add the bottleneck information for Special and Lab periods if required. You may add a period to the CMS or delete a period that you added from the CMS. You cannot modify or delete the last remaining period that supports a topic in the COI.

9.3.1 Period Type

Examples of Period Types are Classroom, Laboratory, and Special.

Any period type that is not Classroom or Laboratory should be indicated as Special. A Special period may also consist of a formal graduation ceremony, provided it does not exceed one period.

Individual medical and dental time, overseas interviews, ceremonies, administrative time, and command time not directly related to technical training are NOT included in the Master Schedule.

To edit the Period Type:

Step 1 Click on the field for Type. An arrow will appear in the right portion of the field.

Step 2 Click on the arrow. This will present a drop-down menu of three options: Class, Lab, and Special. Click on the type of environment that is appropriate for presentation of the Lesson Topic.

NOTE: Use Special for any session that needs to be scheduled that is not a regular class lesson or laboratory.

Step 3 You can continue to change the Period Types in this manner.
9.3.2 Topic Title

The topic titles provided in the CMS are based on the titles in the COI. Only Special periods may be edited. If the period type is changed from Special to either Class or Lab, the Topic title will be restored.

9.3.3 Entering Week and Day

The fields for Week and Day are blank. You enter the time (week and day) at which the topic will be taught. The normal scheduled training day consists of 8 hours (periods) of approved technical training topics, exclusive of meal hours. The normal training period is 60 minutes, whether or not break times are included. Ideally, a period should consist of 50 minutes of technical instruction and a 10-minute break; however, local-training situations may preclude strict adherence to this ideal for some courses. Guidance on entering variations to the normal workday and week can be found in the latest NETCINST on preparing the CMS.

To enter the week and day:

Step 1 Click on the field for Week or Day. AIM I will highlight the field.

Step 2 Type in the week and day.

Step 3 Select Edit.

Step 4 Select Save to update your entries or Cancel to delete the changes to your entries. To return to the AIM I main menu, click on Exit.

9.3.4 Editing Student-to-Instructor Ratio

The student-to-instructor ratio is expressed as a ratio. The ratio of students per instructor for each instructional situation must be based on space and equipment constraints that yield the highest possible ratio without serious detriment to training quality. A student-to-instructor ratio of 25:1 is the planning standard for formal theory (classroom, lecture, written tests, etc.) work. But this standard is not inflexible since space configurations or other factors sometimes dictate variation. If such factors do not allow a ratio of 25:1, the ratio listed should be the maximum possible.

NOTE: You should not adjust a ratio simply because the actual student input is less than planned.

You should base Laboratory (shop, line, performance testing, field instruction, etc.) ratios on a review of each topic to determine the highest ratio of students-to-instructors in consideration of equipment, safety, and teaching effectiveness for the particular instructional situation.
**To edit the student-to-instructor ratio:**

**Step 1** Using your mouse, highlight the Ratio field. Type in the student-to-instructor ratio. (Number of students - : - Number of instructors; e.g., 12:1).

**NOTE:** The actual number of instructors required can be entered (e.g., 12:5)

**Step 2** Click on **Edit** and select **Save** from the drop-down menu.

---

**9.3.5 Bottlenecks**

When equipment or space limits exist, situations can arise in which only a portion of the students can advance through a period together. The usual procedure for overcoming such bottlenecks is to split the class so that one group receives the required curriculum period while the other group stands by, waiting to rotate through the bottleneck.

To indicate the bottleneck for a particular lab or special period, the bottleneck ratio would be the number of students who can progress through the bottleneck together with the instructor. A course with a maximum class size of 25 students going through a lab which can accommodate 5 students at a time would show a student-to-instructor ratio of 25:1 for the course and a bottleneck ratio of 5/1 for lab or special periods. If additional instructors are required for the Lab or Special period it would be noted as the ratio of the number of students to the number of instructors (example: 5/2, where only 5 students can be accommodated at a time and two instructors are required).

**AIM I does not allow a bottleneck entry for class periods.**

**To enter the bottleneck ratio:**

**Step 1** Using your mouse, highlight the bottleneck field. Type in the bottleneck ratio. (Number of students - / - Number of instructors, e.g., 5/2). Note the use of the "/" vice the colon ":" which is used for the Student/Instructor ratio for the course. This field can contain up to six characters.

**Step 2** Click on **Edit** and select **Save** from the drop-down menu.

**NOTE:** For unique bottleneck situations, refer to NETCINST 5310.4 (Series).
9.4 CMS Options

The CMS Options menu item includes:

- Duplicate CMS Period
- Delete CMS Period
- Print Preview
- Print
- Explain Flag
- Remove Flag

9.4.1 Duplicate CMS Period

To facilitate construction of the CMS, AIM I allows you to duplicate and delete CMS periods.

To duplicate a CMS period:

Step 1 Click on the CMS period that you want to duplicate.

**NOTE:** When a period is added, it will be added to the end of the list.

Step 2 Select the Options menu item and the Duplicate CMS Period option.

**NOTE:** You cannot insert a different topic between CMS periods.

Step 3 Enter the number of additional periods to insert in the Duplicate CMS Period window and click on the OK button.

Step 4 Click on Edit.

Step 5 Click on Save or Cancel to save or cancel your entries. Select the Exit menu item to exit the CMS.

9.4.2 Delete CMS Period

To delete a CMS period:

Step 1 Click on the CMS period that you want to delete.

Step 2 Click on the Options menu item and select the Delete CMS Period option from the drop-down menu. You will be asked to confirm each deletion. The entry will be deleted.

**NOTE:** You cannot delete the only entry for a topic in the CMS.

Step 3 You can continue to delete CMS periods in this manner.
Step 4  Select **Edit**.

Step 5  Select **Save** to update your entries or **Cancel** to cancel your entries. Select the **Exit** menu item to exit the CMS.

### 9.4.3 Print Preview

Selection of **Print Preview** will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting **OK** will present the default printer selected. Selecting **OK** from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- **Options** - Contains the options to **Print** or **Save to PDF**. **Print** opens the Print window, which allows you to select the printer, range of pages, print to file, and number of copies. **Save to PDF** allows you to save the document as a PDF file to the desired location.
- **Go To** - Allow moving to the previous, next, first, last, or desired page.
- **Print** - Allows the current page, range of pages, or the entire document to be printed.
- **Exit** - Returns to the Course Master Schedule (CMS) window.
- **Help** - Provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- **Previous** - Allows moving to the previous page.
- **Next** - Allows moving to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - Displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Allows you to access the page desired by typing in the page number in the first field and depressing **Enter** or **Tab**.
- **Actual Page** - Displays the actual page number, as shown on the page. Allow you to access the page desired by typing in the page number in the field and depressing **Enter** or **Tab**.

The right and left mouse buttons allow you to zoom in and out. Double click the left mouse button to zoom in and double click the right mouse button to zoom out. The inspect toolbar button also allows you to zoom in on the page and allows you to view multiple pages.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.
To print preview the CMS:

Step 1  From the Course Master Schedule (CMS) window; select the **Options** menu item and the **Print Preview** option.

Step 2  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3  Click on the **OK** to print preview.

### 9.4.4 Print

Selection of the **Print** option allows the entire document to be printed:

**To print the entire CMS:**

Step 1  Select the **Options** menu item and the **Print** option.

Step 2  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3  Click on the **OK** to print.

### 9.4.5 Explain Flag

The Explain Flag allows you to view and print the maintenance record for the highlighted and flagged Period. The maintenance record states what type of maintenance action was performed to the item (added, modified, and deleted), the Revision and Change of the item, who performed the maintenance action (by login name), and when the maintenance action was performed.

**To read the maintenance record for a flagged Period:**

Step 1  Click on the flagged item

Step 2  Select the **Options** menu item and the **Explain Flag** option. AIM I will open the Maintenance Record window for the item.

Step 3  Click on the **Exit** menu item to return to CMS window.

### 9.4.6 Remove Flag

The flags are used for review purposes. The **Remove Flag** option will remove the flag and the maintenance record for the highlighted Period.
To remove a flag from a Period:

Step 1 Click on the flagged item

Step 2 Select the **Options** menu item and the **Remove Flag** option. AIM I will remove the flag.

### 9.5 CMS Events

The CMS Events Module allows the user to manage the CMS using training events instead of Topics and Periods. In the CMS Events Module a Period length is 60 minutes, this is not adjustable. The Total Periods column is a calculated entry based on the Num Periods, Students, Instructors, Bottleneck Students, and Bottleneck Instructors.

There is no restriction on the order in which events can be placed. The Events will be displayed in the order specified by the user, not necessarily in the order of the Topics within the COI. Events may also be resequenced, a warning will be given if an Event is out of sequence.

When creating a new Event, the user has the option of associating it to a Topic, the Topic association can be changed at any point. Theory and Lab Events must be associated with Topics.

Each Learning Site can have its own CMS, if a CMS has not been specifically created for a Learning Site, the default CMS will be used, the CMS for the CCMM is the default CMS.

Events can only be added and/or deleted within the CCMM CMS.

#### 9.5.1 CMS Events Options

##### 9.5.1.1 Add

To Add Events to the CMS complete the following steps:

Step 1 From the **Options** menu select **Add**.

Step 2 From the Units/Topics screen select the Topic that the Event will be associated with by either highlighting the Topic and selecting **Select** from the menu bar or double-clicking on the desired Topic, if there is no Topic associated with the Event select **Exit**.

Step 3 If a topic was selected then the Topic #, Event Title, Students, and Instructors columns will be filled in. If no Topic was selected the a blank line will be generated.

##### 9.5.1.2 Add Missing Topics

To add missing Topics to the CMS select the **Add Missing Topics** option from the Options
menu. All Topics not already included in the CMS will be added.

9.5.1.3 Delete

The Delete option is used to delete highlighted Topics. Highlight the desired Topic and select the Delete option from the Options menu.

9.5.1.4 Print Preview/Print

The Print Preview and Print options work as they do elsewhere in AIM, select Print Preview to preview the CMS in printed format. Select Print to begin printing of the CMS.

9.5.1.5 Explain Flag/Remove Flag

The Explain Flag and Remove Flag options work as they do elsewhere in AIM, select Explain Flag to see a brief explanation of the flag. Select Remove Flag to remove the flag.

9.5.2 CMS Events Columns

There are 11 columns on the CMS Events screen. Following is a brief description of each column.

- **Topic #:** The Topic # column designates the associated Topic number with the Event. Not all Events require Topic numbers.
- **Event Title:** The description or title of the Event, if associated with a Topic the default will be the Topic title.
- **Event Type:** There are 26 different Event Types to choose from, this column is a drop-down list with the different types listed.
- **Num Periods:** This is the number of periods require for the Event.
- **Students:** Standard number of students for the Event.
- **Instructors:** Standard number of instructors for the Event.
- **Bottleneck Students:** Number of students because of Bottleneck for the Event.
- **Bottleneck Instructors:** Number of instructors because of Bottleneck for the Event.
- **Total Periods:** Calculated based on Number of Students and Number of Instructors or Bottleneck Students and Bottleneck Instructors if present.
- **Justification:** Justification of a Bottleneck Event.
- **Flag:** Maintenance Flag indication column.

9.6 Help

AIM I Version 5.0 includes complete documentation in an accessible help system that includes searchable on-line help files, .pdf-based documents, and media-enhanced demonstrations of certain AIM I functions.
The **On-line Help** item under the **Help** menu provides three different methods for accessing information:

- **Contents** – shows the table of contents for the Help files
- **Index** – shows the information in alphabetical order
- **Find** – allows you search for keywords or phrases

Each of these methods may be accessed by clicking on the appropriate tab in the Help Topics window. Refer to Chapter 1 paragraph 1.7 for more information about On-line Help.

### 9.7 Summary

An accurate CMS will show the correct student-to-instructor ratio and include any bottleneck ratios. It will show the curriculum hours accomplished and yield the correct number of instructor contact hours.
CHAPTER 10
THE LESSON PLAN (LP) MODULE

10.0 Lesson Plan
10.1 Introduction
  10.1.1 The Relationship Between the LP and the TCCD
  10.1.2 The Relationship Between the LP and the TG
  10.1.3 LP Status Levels and Privileges
10.2 Getting Started
10.3 Lesson Plan Cover Page
  10.3.1 Lesson Plan Window Options Menu Item
  10.3.2 Lesson Plan Window Contents Menu Item
10.4 Summary
10.0 LESSON PLAN

The AIM I Lesson Plan (LP) module will assist you in building an actual LP that will be used in the classroom. As you create an LP, you will be defining an intricate network of relationships among all of the elements of the associated training materials.

10.1 Introduction

In creating an LP, you will be establishing relationships:

- Between Resource Requirements List (RRL) items and Related Instructor Activities (RIAs) and Topic Pages
- Between Discussion Points (DPs) and Topic Learning Objectives (TLOs)
- Between Instruction Sheets and the RRL.

Because AIM I stores the relationships that you establish, the need for elaborate paper trails is greatly reduced. AIM I also reduces the need for extensive word processing or retyping of existing material since it generates the formatting and some of the basic texts. The heart of the LP lies in the Discussion Demonstration Activity (DDA) pages, which contain the Discussion Points (DPs) and Related Instructor Activities (RIAs). The LP is designed to provide specific definition and direction to the instructor on TLOs, equipment, and instructional media requirements and on the conduct of training. Proper development of the LP is extremely important since the LP will serve as the instructor’s primary teaching aid. Teaching techniques, methods, exercises, and applications that will enhance the learning process should all be included in the LP.

The LP module of AIM I contains the tools necessary to create and sequence the DPs and to form the foundation for Trainee Guide (TG) sheets.

Component parts of the LP include the following:

- Front Matter
  - Cover Page (optional)
  - Title Page
  - List of Effective Elements
  - Letter of Promulgation (optional)
  - Change Record
  - Table of Contents
  - Security Awareness Notice
  - Safety/Hazard Awareness Notice
  - How to Use the Lesson Plan (optional)
  - Allocation of Instructional Time (optional)
  - Course Learning Objectives

- Parts
  - Tab Divider
  - Section Pages
The capabilities of the LP module enable you to create the following:

- Allocation of Instructional Time (AOIT)
- Trainee Preparation Material requirements
  - Support Materials (identification of Instruction sheets and Trainee Assignment directions for the instructor)
  - Reference Publications (identification of RRL documentation and Trainee Assignment directions for the instructor)
- Fault Applicability List (FAL)
  - Prefaulted Modules (PFMs)
  - Controlled Faults
  - Fault Insertion Devices (FIDs)
- DPs to outline the TLOs
  - Notes, Cautions, and Warnings
  - RIAs to support the DPs
    - Identification of RRL items and directions for the instructor

The default LP contains:

- A Part for each Training Level Assignments (TLA) that has training requirements selected for the course
- A Section for each Training Objective Statement (TOS) level selected in the TLA
- A Topic for each category of the PPP table from which the line item was selected at the Section’s TOS
- TLOs derived from the PPP table line items selected from the category of the Topic which reflect the TOS of the Section

AIM I will automatically insert a DP for each TLO and add:

- Review and Summary for each Knowledge Topic
- Assignment DP and Make study assignment if required RIA for all Topics
- Safety and Critique DPs for each Skill Topic
The Lesson Plan:

- Provides specific definition and direction to the instructor on training objectives, equipment and support material requirements, and course conduct
- Programs the use of all other training materials
- Contains TLOs that reflect the skills and knowledge to be attained upon successful completion of the course
- Provides an outline of instructional materials to be taught in a logical and efficient manner
- Provides specific equipment and support material requirements, and guidance for conducting the course

AIM I prints a placeholder for the Letter of Promulgation.

The List of Effective Elements (LOEE) is a report that tells which elements of a curriculum have undergone a change. Any front matter report, reference report, or curricula element will be the Change 0 level for development or revision of a curriculum.

The purpose of the Change Record is to record the entry of changes into binders that hold the curriculum, AIM I will automatically generate a blank form for that use.

The Table of Contents is automatically generated by AIM I. The Table of Contents lists the titles and page numbers of the Front Matter, Parts, Sections, Topics, and Reference Material in the LP. Since changes made to the curriculum in the LP module do not involve the structure of the course, the table of contents will change only if you unlock the Training Course Control Document (TCCD) and change the structure in the Curriculum Outline of Instruction (COI) module. In such cases, AIM I will simply generate a new Table of Contents based on the new structure.

10.1.1 The Relationship Between the LP and the TCCD

The TCCD module contains the structural features of a curriculum in the COI, such as the design and structure of the Parts, Sections, Topics, and TLOs.

The LP module contains the tools necessary to create and sequence the DPs for each Topic within the curriculum in the order desired for presentation. Links are established between the DPs in the LP module and the TLOs in the TCCD module to provide the capability for AIM I to flag (X or red flags and @ or blue flags) items that have undergone maintenance actions once the course is approved for use.

As with any system that has a hierarchy of materials, it is recommended that you complete as much of your course as possible before beginning work on your LP. Anytime you make changes to the structure of your course, you can intentionally or unintentionally have drastic impacts on your LP.
Where needed, the ability to Add Notes, Cautions, and Warnings has been programmed into AIM I and documented in this User's Manual. However, the best way to avoid a mishap is to conscientiously apply sound curriculum development techniques when you are constructing your training materials. Build the foundations solidly before proceeding to the next step.

The RRL in the TCCD provides the Related Instructor Activities (RIAs) and Instruction Sheets with items for selection. Unlike the TCCD, only those items selected in the LP's RIAs and Instruction Sheets will print in the LP's RRL.

### 10.1.2 The Relationship Between the LP and the TG

Just as an LP must first be outlined in the COI module, the TG instruction sheets must first be defined in the LP.

With AIM I, as soon as you select a TG sheet (instruction sheet) in an RIA, a TG is created. As you create RIAs, you will select TG sheets as materials for use. When you do so, you will define the type of TG sheet and its place in the presentation of the topic material. This action will generate a TG sheet sequentially numbered in the TG. To develop the TG sheets, select the TG module from the AIM I main menu. The original title of the instruction sheet is created in the LP; thereafter it can be edited in the LP or the TG.

### 10.1.3 LP Status Levels and Privileges

Status levels and privileges are assigned to the Course (which includes the TCCD, LP, and TG) in order to provide a level of administrative security. Privileges minimize unauthorized use of the system by specific users. Status levels limit the types of actions that can be performed on an LP. The privileges include; Edit, Lock, Grant, Approve, Remove Flag, Clear In-Use, Maintain/Delete Course, and Add Notes. As a developer/maintainer, when you create training materials you automatically have Edit, Lock, Grant, Maintain/Delete, Clear In-Use, and Add Notes privileges for those training materials. To initiate a Change or a Revision for the course you must have Maintain/Delete privilege.

Because of the intrinsic relationship between the TCCD and the LP/TG, the privilege you have for a course will be the privilege of the LP/TG. If you have Edit Privilege for the course and the TCCD is unlocked you cannot edit the LP/TG until the TCCD is locked. If you have privilege to log in to AIM I, you may view any of the LPs, but you may not modify them. The AIM Administrator can grant an individual privilege to edit, lock, grant privilege, approve, delete, remove flags, clear In-Use flags, maintain and delete, and add notes.

If the course development is complete (the TCCD is locked), your LP will have all the necessary training elements in the correct order; but there may be instances when you will need to unlock the course and add or delete Topics/TLOs. You should, however, be aware that a seemingly innocent deletion in the Curriculum Outline of Instruction (COI) could delete a large portion of your LP.
The TCCD must be locked before you can work on an LP. The act of unlocking the TCCD removes access to the LP for anything but viewing. Unlocking the TCCD permits you to add or delete Topics/TLOs and add, delete, or modify unapproved RRL items if you have Edit privilege for the course.

10.2 Getting Started

To access the LP portion of AIM I:

There are three different ways to access a Lesson Plan window after the course has been selected from the Course Select menu:

1. From the AIM I main menu select the Document menu item and the Lesson Plan (LP) sub-menu item.
2. Click on the LP icon.
3. From the course tree structure double-click on the LP/TG or click on the “+” to expand the tree, click on the LP folder, and select the Options menu item and the GoTo sub-menu item. Opening the LP folder will display the elements in the LP in the upper right hand pane (AOIT, FAL, How to Use the LP, and Safety/Hazard Awareness Notice), which can be accessed by double clicking on the element. You can provide Summary or Note data on the right hand portion of the course tree grid if the View menu sub-items (Note or Summary) have been checked. Summary data includes; CIN, Rev, Change, Title, and Status from the LP window. Note data contains Personal and/or Private Notes recorded by developers.

NOTE: In order to work on the LP, the associated TCCD must be locked.

10.3 Lesson Plan Cover Page

Selecting Lesson Plan (LP) opens the Lesson Plan window, which contains text entry fields for modification of the Preparation Date and Security Awareness Notice. The fields for the CIN/Rev/Chg and Title are derived from the TCCD and cannot be modified in the LP module.

All the required information in the Lesson Plan window was previously filled in from the TCCD module. The cursor will default to the Prep. Date field and allow you to modify the entry in this field. You may also edit the contents of the Security Awareness Notice at this time. You can come back to the Security Awareness Notice for further editing at any time prior to approval.

10.3.2 Lesson Plan Window Options Menu Item

The Options menu item allows you to select the type of print or print preview functionality and the material you want to print or print preview as follows:
10.3.1 Security Markings

From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:

1. Right click and Go To the appropriate location on the course tree (left pane).
2. From the menu bar click Options.
3. From the Options dropdown menu click Security Markings.

This will display the screen show in the figure below.

The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that can have security markings and the current marking assigned. The lower portion of the screen is broken into the following three sections:

- Classification: The available classifications that can be assigned, the options are:
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN
- Modifier: This is an additional security modifier to the classification, the options are:
  - (None)
- COMINT
- Talent Keyhole
- COMINT/Talent Keyhole

- Release Ability: This is an additional restriction on who the document may be released to, the options are:
  - (None)
  - NOFORN
  - For Official Use Only
  - REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

### 10.3.2.1 Print Options

Selection of the Print Options option opens the Print Options window that allows you to select or unselect, by clicking on the appropriate button, the following items for your printout and/or print preview:

- **How To Use the Lesson Plan** - selected as default
- **Allocation of Instructional Time** - not selected as default
- **Course Master Schedule** - selected as default
- **Reference Materials (Back Matter)** - selected as default

### 10.3.2.2 Print Preview

Selection of the Print Preview option opens the LP Print Options window that allows you to select or unselect items, by clicking on the appropriate box or button. The following headings are presented for your printout and/or print preview:

**Elements to Preview/Print:**
- **Front Matter**
- **Parts/Sections/Topics**
- **Reference Materials (Back Matter)**

**Main DP Printing Options:**
- **DP per Page** - which prints a major DP (e.g. 1, 2, 3, etc., which, along with its sub-DPs, can encompass a number of pages) starting on a new page for use by the instructor on the
podium (this minimizes the size of a change package and therefore the amount of re-
personalization required for a topic when in receipt of a change).

- **Continuously** - which prints DPs continuously for draft and review copies. Change Packages printed out using the Continuous DP method may not reflect the correct Change in Effect for the individual major DPs as noted in the LOEE.

**DP Spacing:**

- **Number of blank lines between DPs (1-10):** - provides a field in which you can change the default of 5 to close down or open up the space between all the DPs in the LP.

- **Override Specified DP Spacing** - overrides individual DP spacing, added in the DP/RIA window for each Topic, to the number of blank lines entered in the “Number of blank lines between DPs (1-10)” field in the LP Print Options window for all DPs in the LP.

**IMI Options:**

- **Create hyperlinks for IMM entries** – used when Print Preview is selected to view the IMM that has been selected in the LP on the Topic Pages and in the RIAs.
After selecting the LP Print Options, the Printer Setup window gives you the functionality to add Page X of Y on each page of the document, for page accountability when printing classified training management material, and one line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document.

Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- **Options** - Contains the options to Print or Save to PDF. Print opens the Print window, which allows you to select the printer, range of pages, print to file, and number of copies. Save to PDF allows you to save the document as a PDF file to the desired location.
- **Go To** - Allow moving to the previous, next, first, last, or desired page.
- **Print** - Allows the current page, range of pages, or the entire document to be printed.
- **Exit** - Returns to the Lesson Plan (LP) window.
- **Help** - Provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- **Previous** - Allows moving to the previous page.
- **Next** - Allows moving to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - Displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Allows you to access the page desired by typing in the page number in the first field and depressing Enter or Tab).
- **Actual Page** - Displays the actual page number, as shown on the page. Allow you to access the page desired by typing in the page number in the field and depressing Enter or Tab.

The right and left mouse buttons allow you to zoom in and out. Double click the left mouse button to zoom in and double click the right mouse button to zoom out. The inspect toolbar button also allows you to zoom in on the page and allows you to view multiple pages.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

**To print preview the LP:**

**Step 1** From the Lesson Plan window select the Options menu item and the Print Preview option. AIM I will open the LP Print Options window and you can select what and how you want to print preview. Click on the OK button when complete.

**Step 2** From the Printer Setup window select Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.
Step 3  Click on the **OK** to print preview. The first page of the LP is displayed in the Print Preview window, use the Print Preview options as desired and when complete select the **Exit** menu item to return to the Lesson Plan window.

### 10.3.2.3 Print

Selection of the **Print** option allows you to print the entire document after selecting the elements you want to print and how you want the DPs to print from the LP Print Options window. The Printer Setup window gives you the functionality to add Page X of Y on each page of the document, for page accountability when printing classified training management material, and one line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document.

**To print the entire LP:**

- **Step 1** Select the **Options** menu item and the **Print** option. AIM I will open the LP Print Options window and you can select what and how you want to print. Click on the OK button when complete.

- **Step 2** From the Printer Setup window select Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

- **Step 3** Click on the **OK** to print. While the software is preparing the LP for print, you can select Cancel and AIM I will only print the number of pages noted when cancel was selected.

### 10.3.2.4 Change Package

The **Change Package** option is only enabled for an LP that has a Change Number greater than zero (0). Selection of the **Change Package** option provides the user with two sub-menu items:

- **Print Preview**
- **Print**

The **Print Preview** option will permit you to view the Change Package (only those pages effected by the change) or print the Change Package or save it to a PDF file. Selection of the Print Preview option will open the DP Print Options window for selection of DP per Page or Continuous.

The **Print** option will permit you to print the Change Package. Selection of the Print option will open the DP Print Options window for selection of DP per Page or Continuous. Ensure that DP per page is selected because Change Packages printed out using the Continuous DP method may not reflect the correct Change in Effect for the individual major DPs as noted in the LOEE.
10.3.3 Lesson Plan Window Contents Menu Item

Selecting the **Contents** menu item will allow you to:
- Display the drop-down menu
- Develop the **Allocation of Instructional Time** (AOIT)
- Develop/maintain the **FAL**
- Modify the **How to Use LP** or **Safety/Hazard Awareness Notice**
- Access to the Course Aggregate **SCORM Meta-Data** tabs (Refer to Appendix F)
- Access the **COI** Lesson Plan (LP) window

10.3.3.1 AOIT Contents Menu Sub-item

The AOIT (Allocation of Instructional Time) is an optional element of the LP. If desired as part of the LP printout, it must be selected as one of the Print Options.

The AOIT receives Topic Class/Lab periods from the Topic Time entries recorded on the Topic Pages of the LP (refer to paragraph 10.3.2.5.2). The Topic Times can also be entered in the AOIT and will be recorded on the Topic Page. A period is considered to be one hour in duration.

The following fields can be viewed in the AOIT and are not editable:
- Part No. - Part Number
- Section No. - Section Number
- Topic No. - Topic Number
- Sec. Totals - Summation of Class and Lab hours for a Section
- Inst. Time Total - Summation of Section Totals
- Course Total - Summation of entries contained in the Sec. Totals, Final Eval, Testing Time Total, and Review Time Total

The following fields can be edited:
- Class Hrs. - Class Hours (Number of Class Periods entered in the Topic Time Window for the Topic)
- Lab Hrs. - Lab Hours (Number of Lab Periods entered in the Topic Time Window for the Topic)
- Final Eval. - For Student Course Critique
- Testing Time Total
- Student/Instructor Ratio - For Lab Periods
- Review Time Total
- Actual Class Size

**To edit the AOIT:**

1. From the Lesson Plan window select the **Contents** menu item and the **AOIT** sub-item. The AOIT window will open.
2. Click on the fields that require editing and enter the desired values.
Step 3  Select the **Edit** menu item and the **Save** sub-menu item to save your entries.

Step 4  Select the **Exit** menu item to return to the Lesson Plan window.

### 10.3.3.2 The FAL Contents Menu Item

Some Courses use faults to train personnel to identify problems with an ESS for casualty operation, and preventive and corrective maintenance. The faults are identified on Fault Description Sheets (FDSs), which contain the data necessary to add the fault to the FAL for the course.

There are three types of faults:
- **Prefaulted Modules (PFMs)**: Faulted modules designed to be inserted into a piece of equipment, in accordance with the FDS at specific locations to cause error indications.
- **Fault Insertion Devices (FIDs)**: Pieces of equipment (jumper cables, extender modules, faulty fuses, etc.) that are used in accordance with the FDS to simulate faults in an ESS.
- **Controlled Faults**: Procedures to simulate a fault that does not require a PFM or equipment.

All three types of faults can be identified in the FAL. When the FAL is complete, it will list:
- All the faults that are required for the course (which will be identified with an * on the printout)
- Faults that can be used if time and personnel are available.

To start adding faults to the FAL, you must have previously added the following material to the course RRL:
- PFMs added to the Prefaulted Modules RRL type,
- Equipment that the fault is to be inserted into and equipment used as Fault Insertion Devices (FIDs) in the Equipment RRL type, and
- Supporting documentation for the fault such as Fault Insertion Guide or Fault Description Sheet to the References RRL type.

Only those faults that have been identified as **Required** for the course in the FAL will be available for selection in the RIAs.

#### 10.3.3.2.1 Adding a Fault to the FAL

**To add a fault to the FAL:**

Step 1  Select the **Contents** menu item and the **FAL** submenu item. AIM I will retrieve the FAL window, which has two columns for identification of the Fault No. and Function Faulted (*Figure 10-1*).
Step 2  Select the Options menu item and the Add option. AIM I will open the FAL Contents window (Figure 10-2) for entry of the FDS information.

<table>
<thead>
<tr>
<th>Fault No.</th>
<th>Function Faulted</th>
</tr>
</thead>
<tbody>
<tr>
<td>3B2-1</td>
<td>Drive Inoperative</td>
</tr>
</tbody>
</table>
Step 3  Click on the Part field. AIM I will present a list of the Part titles contained in the course. Select the Part in which the fault will be used.

Step 4  AIM I will present a list of the Sections contained in the Part selected. Select the Section in which the fault will be used.

Step 5  Click on the Equipment field. AIM I will present a list of the equipment identified in the TCCD RRL. Select the equipment into which the fault will be inserted.

Step 6  Click on the Document field. AIM I will present a list of the documents identified in the TCCD RRL. Select the document that contains the procedures for identifying the fault.

Step 7  Click on the Fault No. field and enter the Fault Number from the FDS.

Step 8  Click on the Function Faulted field and enter the Function Faulted information from the FDS.

Step 9  Click on the Type field and select the type of fault (PFM, FID, or Controlled).
Step 10 Click on the Required (Y/N)? field and select:
  • Yes if the fault will be called out in an RIA
  • No if the fault will not be called out in an RIA and is not mandatory for course completion

Step 11 Select the TOS that this fault can be used to exercise as listed on the FDS.

Step 12 Select the Edit menu item and the Save sub-menu item.

Step 13 Repeat Steps 2 through 12 for each fault required for the FAL.

Step 14 After all faults have been added to the FAL, select the Exit menu item and return to the FAL window.

For each PFM and FID fault added to the FAL:

Step 1 Highlight one of the newly added PFM/FID.

Step 2 Select the Required Equipment menu item. For a fault you identified as a PFM, AIM I will provide a list of the PFMs from the TCCD “Prefaulted Modules” RRL type. For a fault you identified as an FID, AIM I will provide a list of the equipment from the “Equipment” TCCD RRL type.

Step 3 Highlight the desired PFM/equipment and select the Options menu item and the Select option. An X will appear in the Select column.

Step 4 For each equipment required for the FID, highlight the desired Prefaulted Modules/Equipment and select the Options menu item and the Select option.

Step 5 Select the Exit menu item and Save the entries to the database. Repeat the procedure for each PFM/FID added to the FAL.

10.3.3.3 How to Use LP Contents Menu Sub-item

How to Use the Lesson Plan is an optional portion of the LP. It is an AIM I Styled Text Editor window for entering the description of the composition, function, and use of the LP and for providing curriculum support directions. See Chapter 2, Section 2.5.2, for details about the Styled Text Editor.

To enter How to Use LP text:

Step 1 From the Lesson Plan window; select the Contents menu item and the How to Use LP sub-menu item. AIM I will open the How to Use LP window, which contains the AIM I Styled Text Editor.

Step 2 Edit the boilerplate text as required.
Step 3 When you complete your text entry, select the **Exit** menu item and save the entry to the database.

### 10.3.3.4 Safety/Hazard Awareness Notice Contents Menu Sub-item

The Safety/Hazard Awareness Notice is used to identify:

- The safety risks and hazardous materials that were noted in the Training Project Plan (TPP) for the course
- Measures necessary to ensure the safety of the class (i.e., Training Time Out and Drop On Request). AIM I provides a Styled Text Editor window for entry of required text. See Chapter 2, Section 2.5.2, for details about the Styled Text Editor.

**To enter Safety/Hazard Awareness Notice information:**

**Step 1** From the Lesson Plan window select the **Contents** menu item and the **Safety/Hazard Awareness Notice** submenu item. AIM I will open the Safety/Hazard Awareness window, which contains the AIM I Styled Text Editor.

**Step 2** Edit the boilerplate text as required.

| NOTE: Modification to the Safety/Hazard Awareness Notice in the LP does not modify the Safety/Hazard Awareness Notice in the TG. If you want them to be identical, highlight and copy the modified text of the LP, delete the boilerplate in the TG and paste the copied text. |

**Step 3** When you complete your text entry, select the **Exit** menu item and save the entry to the database.

### 10.3.3.5 SCORM Metadata (Course)

Sharable Content Object Reference Model (SCORM) is a set of specifications published by Advanced Distributed Learning (ADL) for developing, packaging and delivering high-quality education and training materials wherever and whenever they are needed. SCORM compliant courses leverage course development investments by ensuring that compliant courses are Reusable, Accessible, Interoperable and Durable.

The SCORM Data information represents the information required for development of metadata (data about data) files. Metadata files provide a common nomenclature enabling learning resources to be described in a common way. Metadata can be collected in a catalog, as well as directly packaged with the learning resource it describes. Learning resources that are described with meta-data can be systematically searched for and retrieved for use and reuse. Aggregation (course) and SCO (topic) have certain metadata fields that are required. Asset (TG graphic) has only a small subset of those same fields required.
Assets, Sharable Content Objects (SCOs), and Content Aggregations are components that are considered specifications of learning resources.

- **Assets**: electronic representations of media, text, images, sound, Web pages, assessment objects or other pieces of data that can be delivered to a Web client. The mechanism for binding Assets to Asset Metadata (data about data) is the Content Package. In the current AIM-to-SCORM output, the graphics used in TG sheets, Transparencies, and Test Items are the assets that are the output along with the entire course package. The repository will be able to identify these as separate assets and store them for reuse, independent of the course package (aggregation) or any of the SCOs (Topics) in which they are used.

- **Sharable Content Object (SCO)**: SCO represents a collection of one or more Assets that include a specific launchable asset that utilizes the SCORM Run-time Environment to communicate with Learning Management Systems (LMSs). A SCO represents the lowest level of granularity of learning resource that can be tracked by an LMS using the SCORM Run-Time Environment. The topic is the SCO in the current SCORM output from AIM.

- **Content Aggregation**: A content aggregation is a map (content structure) that can be used to aggregate learning resources into a cohesive unit of instruction. AIM aggregates all the Topics (SCOs) in a course into the output package (aggregation), which has course level metadata.

AIM provides default information for the mandatory information for SCORM or ILE Metadata specifications using SCORM version 1.2 or 2004.

The specification and version can be selected from the AIM main menu by selecting the **Options** menu item and the **Preferences** option. The **Advanced** tab contains the Metadata Specification and version selection.

The course Tabs can be edited from Lesson Plan window (Cover Page) by selecting the **Contents** menu item and the **SCORM Metadata** sub-item. The bolded items are required for the Metadata Specification and version selected.

The Tabs for individual Topic Sharable Content Objects (SCOs) can be edited from the Units/Topics window by highlighting the desired Topic, selecting the **Contents** menu item and clicking on the **SCORM Metadata** sub-menu item. Test item data is stored with the topic it’s associated with and graphics used in test items appear in the list of graphics in the course.

Functionality for editing the Tabs for the course, topics, and graphics and generating a SCORM Output is also provided to the developer by selecting the desired course in the Course Select menu and selecting the **Document** main menu item and the **SCORM Data** sub-menu item or by clicking on the SCORM icon. The browser in the left pane allows you to open the Course, Topic, or Graphic folder to edit the associated Tabs. The SCORM-compliant output of AIM is an XML-based SCOs packaged at the course topic level that can be viewed using Internet Explorer. **Refer to Appendix F to generate SCORM Output.**
To edit the Metadata for the course:

Step 1  From the Lesson Plan window select the **Contents** menu item and the **SCORM Metadata** sub-menu item. AIM will open the SCORM Metadata window.

Step 2  Click on the Category that requires entry. An Explanation field is provided to describe the content requirements. Edit as necessary. Bolded categories require data entry and all other categories are optional.

Step 3  When editing has been completed select the **Edit** menu item and **Save**.

Step 4  Select the **Exit** menu item to return to the Lesson Plan window.

10.3.3.6  **COI Contents Menu Sub-item**

Selecting **COI** from the LP **Contents** drop-down menu opens the Lesson Plan (LP) window.

- Click on the **Contents** Menu item and the **COI** sub-menu item. AIM I will retrieve the COI and open the Lesson Plan (LP) window.
- Highlight the desired Topic and select the **Contents** menu item. AIM I will present the following sub-menu items:
  - **Trainee Preparation**
    - **Trainee Support Material**
    - **Reference Publications**
    - **IE TMs**
    - **IMI**
  - **Topic Time**
  - **SCORM Metadata**, to edit Topic Sharable Content Object (SCO) information (Refer to Appendix F)
  - **DP/RIA**

10.3.3.6.1  **Entering Trainee Preparation Materials**

Trainee Preparation Materials is a heading on the Topic Page printout; it is divided into two categories: **Trainee Support Materials**, which are TG sheets; and **Reference Publications**, **IE TMs**, and IMM which are RRL items listed in the Course RRL.

When the trainee is required to prepare for the Topic prior to its commencement, an entry is required in at least one of these areas. AIM I records the entry on the Topic Page printout under the heading of Trainee Preparation.

**To enter Support Materials for Trainee Preparation:**

Step 1  From the Lesson Plan window select the Contents menu item and the COI sub-menu item. AIM I will open the Lesson Plan (LP) window that contains the COI structure developed in the TCCD.
Step 2  Highlight the desired Topic in the Lesson Plan (LP) window and select the Contents menu item and the Trainee Preparation/Trainee Support Material sub-menu items.

Step 3  To create a new Instruction Sheet, select the Options menu item and the Create option. A sub-menu will open that contains all the types of instruction sheets.

- From the pop-up list, select the type of TG sheet desired.
- Enter the TG sheet title in the Sheet Title column.
- Enter the before text desired by selecting the arrow and one of the selections from the pop-up menu.
- Enter the instructions that the instructor will impart to the trainee in the After Text field.
- Select Edit and the Save sub-menu item to save the TG sheet to the RRL.

Step 4  To select an Instruction Sheet from the existing list, select the Options menu item and the Add option. AIM I will open the TG Sheets window that will display the Instruction Sheets that have been developed in the RIAs of the Topic selected.

- Click on the desired Instruction Sheet and select the Options menu item and the Select option.
- Enter the before text desired by selecting the arrow and one of the selections from the pop-up menu.
- Enter the instructions that the instructor will impart to the trainee in the After Text field.
- Select Edit and the Save sub-menu item to save the TG sheet to the RRL.

Step 5  To delete an Instruction Sheet from the existing list, click on the Instruction sheet and select the Options menu item and the Delete option.

Step 6  Repeat Steps 2 through 4 for each additional Support Material entry required.

**NOTE:** When an Instruction sheet is created in the Support Materials window, it will precede all Instruction sheets identified in the RIAs and will be numbered accordingly.

Step 7  Select the Exit menu item to return to the Lesson Plan (LP) window.

To enter Reference Publications, IETMs, or IMIs for Trainee Preparation:

Step 1  Highlight the desired Topic in the Lesson Plan (LP) window and select the Contents menu item and the Trainee Preparation menu item.

Step 2  Select Reference Publication, IETMs, or IMM as appropriate.

Step 3  AIM I will open the Reference Publications, IMI, or IETMs window, which contains a list of References, IMIs, or IETMs from the Course RRL. Highlight the desired item and click on the Select field to select it. An X will appear in the select column.
Step 4  Click on the Before Text column and the down arrow. From the list provided, click on the appropriate Before text.

Step 5  Double click on the After Text column and type in the directions the instructor must give the trainee.

Step 6  Select the Edit menu item and the Save sub-menu item to save the Topic Page entry.

Step 7  Repeat Steps Two through Five for each additional Reference Publication, IETMs, or IMIs entry required.

Step 8  Select the Exit menu item to return to the Lesson Plan (LP) window.

10.3.3.6.2 Entering Topic Time

The Topic Time option is used to edit information about the Topic that will appear in the CMS. To edit this information select Topic Time from the Contents menu on the Units/Topics screen. Once the Events screen appears editing information is done the same way as the Events screen in the CMS Module. Refer to the CMS section of this manual for more information.

10.3.3.6.3 SCORM Metadata (Topic)

Refer to paragraph 10.3.2.5 for an explanation of SCORM and Metadata information.

The information for individual Topic Sharable Content Objects (SCOs) can be edited from the Lesson Plan (LP) window by highlighting the desired Topic, selecting the Contents menu item and clicking on the SCORM Metadata sub-menu item. Test item data is stored with the topic it’s associated with and graphics used in test items appear in the list of graphics in the course.
To edit the Metadata information for the Topic:

Step 1  From the Lesson Plan (LP) window, highlight the Topic desired, select the **Contents** menu item and the **SCORM Metadata** sub-menu item. AIM will open the SCORM Metadata window.

Step 2  Click on the Category that requires entry. An Explanation field is provided to describe the content requirements. Edit as necessary. Bolded categories require data entry and all other categories are optional.

Step 3  When editing has been completed select the **Edit** menu item and **Save**.

Step 4  Select the **Exit** menu item to return to the Lesson Plan (LP) window.

10.3.3.6.4 DP/RIA Window

Selecting **DP/RIA** from the **Contents** menu item in the Lesson Plan (LP) window opens the DP/RIA window. Discussion Point text can be entered in either the field adjacent to the DP number or the field provided at the bottom of the window, that displays the contents of the highlighted DP. The DP field allows you to develop Rich Text Format (RTF) text entries using the Font buttons in the toolbar. The After Text field in the Build RIA window provides the same RTF capability for the RIA.

The **Options** menu item for the DP/RIA window contains the following:

- **Add Same Level DP** (Ctrl+A): Allows you to create a DP at the same level as the DP currently highlighted (i.e., if DP 1 was highlighted you would create DP 2 and all subsequent DPs would be renumbered automatically).
- **Add Lower Level DP** (Ctrl+L): Allows you to create sub-items for the DP highlighted (i.e., if DP 1 was highlighted you would create DP 1a).
- **Delete DP** (Ctrl+D): Allows you to delete the DP highlighted, its sub-items, and all associated RIAs. Subsequent DPs will be renumbered automatically. When maintaining approved materials and creating Changes, this option will insert "(Deleted)" to prevent renumbering subsequent DPs. However the "(Deleted)" DP can be deleted and subsequent DPs will be renumbered if desired.
- **Build RIA** (Ctrl+B): Opens the Build RIA window and allows you to create an RIA for a DP and select and link RRL items for the RIA. Any RRL item linked to the RIA will print out on the Topic Page and the RRL when the LP is printed. Items identified in the "Before Text" and "After Text" fields are not linked to the RIA from the RRL and will not be identified on the Topic Page or RRL printout of the LP.
- **Add Another RIA** (Ctrl+R): Allows you to create another statement for the RIA highlighted.
- **Add Same Level RIA**: Allows you to create another RIA at the same level as the RIA highlighted (i.e.: If DP/RIA 1a was highlighted, RIA 1b would be created), provided an RIA is present and a DP of the same number does not exist.
- **Add Lower Level RIA**: Opens the Build RIA window and allows you to create a sub-item for the RIA highlighted, provided a DP sub-item does not exist of the same number.
- **Delete RIA**: Allows you to delete the highlighted RIA and all its links to the RRL, Instruction Sheets, and Notes, Cautions, and Warnings created from the RIA.
- **Copy RIA**: Allows you to copy the highlighted RIA, along with its RRL links, into a buffer.
- **Paste RIA**: Allows you to paste the contents of the buffer containing the copied RIA to any RIA field. If the field contains an RIA you will be prompted for confirmation.
- **Add Warning**: Allows you to add a Warning before or after the currently highlighted RIA.
- **Add Caution**: Allows you to add a Caution before or after the currently highlighted RIA.
- **Add Note**: Allows you to add a Note before or after the currently highlighted RIA.
- **Display Media**: This is enabled when the current RIA is citing an IMI. It displays the IMM in a full screen window.
- **Show IMM Preview**: A toggle which allows the IMM selected for a highlighted RIA to be displayed in the bottom pane of the DP/RIA window.
- **TLO Link**: Allows you to view the TLO that the DP supports, or if the DP is not linked to a TLO it allows you to make the link to the appropriate TLO. During maintenance, if a TLO is added/modified/deleted, the DP that is linked to it will be flagged for maintenance action.
- **DP Spacing**: Allows you to increase or decrease the spacing between individual DPs within a Topic to accommodate personalization of LP by the instructors.
- **Explain Flag**: Allows you to view/print preview/print the Maintenance Explanation for either the highlighted DP or associated RIA.
- **Remove Flag**: Allows an AIM Administrator to remove a System (@) or Maintenance (X) flag from the DP or RIA. System flags that remain in an LP after all maintenance actions have been performed must be removed prior to approving the Course/LP/TG. System generated flags can be removed individually using this option or can be removed from the entire course simultaneously using the Course Select window, Remove System Flag option.

The Flag column in the DP/RIA window can indicate that one or more of the following maintenance actions have been performed when a change or revision is created for the course:
- The TLO to which the DP is linked was modified/added/deleted, and maintenance action may be required (@ System Maintenance flag).
- The TLO to which the DP is linked was joined to another TLO (@ System Maintenance flag).
- The DP has been resequenced, in the development of a Change, by the deletion of a “(Deleted)” DP (X User Maintenance flag).
- The DP has been modified or added (X User Maintenance flag).
- The DP's associated RIA has been added, modified, or deleted (X User Maintenance flag).
- A RRL item related to a RIA has been modified (X User Maintenance flag).
- A FAL item related to a RIA has been modified (X User Maintenance flag).
- The Explain Flag option for the DP/RIA window will indicate the origin of the flag and explain what was done to generate it. The Remove Flag option is an AIM Administrator task. All System Maintenance flags must be removed from the TCCD, LP, or TG before the change or revision for the curriculum can be approved. User Maintenance flags remain as part of a change.

The **Edit** menu item of the DP/RIA window is always enabled to allow you to **Cut**, **Copy**, and **Paste** a highlighted DP. When a DP or RIA has been added, modified, or deleted the **Edit** menu item allows you to **Save** or **Cancel** all modifications made to the DP/RIA window since the last time it was saved.

10.3.3.6.4.1 Adding DPs

- The default DPs include:
  - A Safety DP for each Skill topic
  - A DP for each TLO
  - A Review and Summary DP for each Knowledge Topic
  - A Critique DP for each Skill topic
  - An Assignment DP for all topics

**To add DPs during new development or for a Revision:**

Step 1  Position your cursor at the point at which you want to add a DP.

Step 2  Select **Options**, then **Add Same Level DP** (Ctrl + A) or **Add Lower Level DP** (Ctrl + L), as desired.

Example:

- If you highlight DP 1 and add at the same level, you will add a new DP 2.
- If you highlight DP 1.a and add at the same level, you will add a new DP 1.b.
- If you highlight DP 1.a (1) and add at the same level, you will add a new DP 1.a. (2).

Example:

- If you highlight DP 1 and add at the lower level, you will add a new DP 1.a.
- If you highlight DP 1.a and add at the lower level, you will add a new DP 1.a (1).
- If you highlight DP 1.a (1) and add at the lower level, you will add a new DP 1.a. (1(a).

**NOTE:** AIM I currently supports up to six levels of DPs.
Step 3 Type in the text of the DP.

To add DPs during creation of a change:

New DPs will be added to the end of the list of DPs at the level highlighted. After adding the DP, it can be resequenced as desired and the Explain Flag option will note where it was originally added and subsequent DPs will note that they have been resequenced.

Example:
- If there are 8 major DPs and you highlight any major DP and add at the same level, you will add a new DP 9.
- If there are sub-DPs a. through f. and you highlight any of the sub-DPs and add at the same level, you will add a new DP .g.

To edit the contents of a DP:

Step 1 Click on the DP to be edited.

Step 2 Edit the text of the DP, as you desire.

10.3.3.6.4.2 Deleting DPs

A DP cannot be deleted if it is the only DP that supports an existing TLO. When deleting a DP during development or revision of an LP, the DP and its associated RIA(s) will be deleted and subsequent DPs will be renumbered. During creation of a change, AIM I will insert "(Deleted)" at the location of the DP deleted and the deleted DP will be indicated in the LOEE as deleted for the change being developed. The (Deleted) DP can be deleted, but this will resequence subsequent DPs and they will be flagged.
Step 1  Position your cursor on the DP number to be deleted.

Step 2  Select **Options**, then select **Delete DP or** (Ctrl + D). All DPs at a level lower than the DP being deleted will also be deleted.

**10.3.3.6.4.3 Adding Notes/Cautions/Warnings**

AIM I gives you the flexibility to add Notes, Cautions, and Warnings before and after all RIAs. To add a Note, Caution, or Warning, a RIA entry must exist. The Note, Caution, or Warning is linked to the RIA and, if the RIA is deleted, the Note, Caution, or Warning associated with the RIA is also deleted.

Step 1  Click on the RIA to which you would like to add a Note, Caution, or Warning.

Step 2  Select **Options**, then select **Add Note/Caution/Warning**. The Options menu will give you the choice of placing the Note, Caution, or Warning before or after the highlighted RIA.

**NOTE:** The Styled Text Editor field on the bottom portion of the window provides the use of the Font and pitch menu bar items as well as the Cut, Copy, Paste, Bold, Italics, Underline, Strikethrough, Superscript and Subscript buttons. The Styled Text Editor employs a spell-as-you-type capability.

**WARNING:** Ensure the font selected is a standard font that resides on all PCs that will be used to print and view the LP. If the course is imported into a system that does not contain the selected font, Windows ™ will interpret the font to a font that may not match.

Step 3  Type in the text of the Note, Caution, or Warning, as you desire.

**10.3.3.6.4.4 Working With RIAs**

From the DP/RIA window’s Options menu item, the following RIA options are available:

- **Build RIA or (Ctrl+B):** Allows you to create an RIA in a blank RIA field, modify an existing RIA, or view the contents of an RIA.

- **Add Another RIA or (Ctrl+R):** Allows you to open a new RIA field for the same DP/RIA under the RIA field highlighted and enter a new RIA statement.

- **Add Same Level RIA:** Allows you to highlight a numbered RIA and add another RIA at the same level as the RIA highlighted. (For example, if you select this option when RIA 2-a is highlighted and there is no DP 2-a, AIM I will generate a field for RIA 2-b.)

- **Add Lower Level RIA:** Allows you to enter the RIA at a lower level than the RIA highlighted. (For example, if you select this option when the RIA for DP 2-b is highlighted and there is no DP 2-b-1, AIM I will generate an RIA 2-b-1 to enter RIA data only.)
• **Delete RIA:** Allows you to delete an RIA entry. (Deleting the entry will also delete any Note, Caution, or Warning that was created using the RIA.)

• **Copy RIA:** Allows you to copy the contents of a highlighted RIA into a buffer.

• **Paste RIA:** Allows you to paste the contents of the buffer into the highlighted RIA field.

The build and add options open the Build RIA window. The **Options** menu item of the Build RIA window provides the following options:

• **Copy RRL from previous saved RIA:** Will copy the information from the previously saved RIA in this Topic if it was linked to an RRL item. This option is primarily designed to copy Publications used to develop an RIA and will copy the Before Text, RRL Type, RRL Item, and Volume/Part breakdown. The software will blank out the Sub Part Type and subsequent fields for the new RIA.

• **View IETM Structure:** Allows the developer to examine the structure of an IETM selected in an RIA. It opens the IETM Browser and highlights the selected IETM.

• **Launch/View IETM:** Allows the developer to view the contents of the IETM selected from the location where the IETM is stored.

• **Display Media:** Allows the developer to view the IMM selected using the full screen. This option also exists on the DP/RIA window to view the IMM full screen without having to go to the Build RIA window.

10.3.3.6.4.5 **Building a RIA**

The Build RIA option has two purposes: to create a RIA in a blank RIA field and modify an existing RIA.

**NOTE:** The Styled Text Editor field in the After Text portion of the window provides the use of the Font and pitch menu bar items as well as the Cut, Copy, Paste, Bold, Italics, Underline, Strikethrough, Superscript and Subscript buttons. The Styled Text Editor employs a spell-as-you-type capability.

**WARNING:** Ensure the font selected is a standard font that resides on all PCs that will be used to print and view the LP. If the course is imported into a system that does not contain the selected font, Windows ™ will interpret the font to a font that may not match.

From the DP/RIA window the entire contents of the RIA can be viewed in the bottom grid when the RIA is highlighted. If the RRL type is an IMM it will be displayed in a preview pane.

**To build a RIA:**

Step 1 Click on the RIA block desired.

Step 2 Select the Options menu item and the Build RIA option. Or, double click on the RIA field. AIM I will present the Build RIA window.
Step 3  If the contents of the RIA will be the same as the previously saved RIA, with minor editing corrections: Select the Build RIA window Options menu item and the Copy RRL from the previously saved RIA option. The software will prompt you with the question “Do you wish to replace the entire contents of this RIA with the Before Text, RRL Type, RRL item, and Volume/Part breakdown from the previously saved RIA?” Click on OK to copy the previously saved RIA and edit as necessary.

Step 4  If you did not copy the previously saved RIA: Position the cursor in the RRL Type field and click on the down arrow to select from the RRL Types available.
- To add/select an Instruction Sheet refer to paragraph 10.3.2.6.4.6.
- To select a Fault refer to paragraph 10.3.2.6.4.7.
- To select an IETM refer to paragraph 10.3.2.6.4.8.
- To select an IMM refer to paragraph 10.3.2.6.4.9

Step 5  If only a text entry is desired for the RIA entry and the RIA does not require an RRL item selection enter your text in the After Text field (which allows you to enter up to 954 characters, including spaces and punctuation). If text entries were made in the Before text field (which allows up to 50 characters) it will be joined into a single sentence/paragraph for the RIA entry. Only the After Text field permits format editing.

Step 6  If the RIA entry requires an RRL item, scroll through the list and click on the type of RRL item desired. For all items except TG sheets and Faults, AIM I will present the Course RRL window, which contains a split screen with the Course RRL items on the top and the Site RRL items on the bottom. Perform one of the following steps:
- **Step 6a:** If the item desired is contained in the Course RRL List, highlight the item and select the Options menu item and the Select RRL for RIA option.
- **Step 6b:** If the item desired is contained in the Site RRL List, highlight the item, select the Options menu item, and the Select Course RRL option. Alternatively, click and drag the item from the Site RRL and drop it in the Course RRL. Enter the quantity information in the Per Trainee, Per Instructor, and Per Class fields and select the Edit menu item and the Save sub-menu item. Perform the preceding step (Step 6a) to select the item for the RIA.
- **Step 6c:** If the item desired does not appear in either the Course RRL or Site RRL, select the Site RRL menu item. AIM I will open the Site RRL window. Perform the following:

**NOTE:** Additional items can be added to the Course RRL from the Site RRL. If the Item is not contained in the Site RRL, it can be added and then selected in the Course RRL. An IETM RRL item can only be added to the Site RRL from the Admin Utility. To Add/Modify/Delete an IETM RRL item in the Site RRL contact the AIM Administrator.
From the list of RRL types, highlight the type of RRL item required. Select the **Options** menu item and the **Add RRL** option. AIM I will open the RRL Type window.

Enter the required information in the fields provided and select the **Exit** menu item and save the information to the Site RRL.

From the Site RRL window select the **Exit** menu item to return to the Course RRL window. Perform Steps 6a and 6b for the new Site RRL item.

Step 7 Enter text to inform the instructor what is to be done with the RRL item selected, in the Before Text field (text that will precede the title of the RRL item selected) and After Text field (text that will follow the title of the RRL item selected). The Before text field also has a menu selection of Before Text phrases to choose from.

Step 8 Select the **Exit** menu item and save the information to the RIA.

**10.3.3.6.4.6 Adding/Selecting Instruction (TG) Sheets**

To add/select Instruction sheets:

Step 1 Double click the RIA Text field. You will be placed in the LP - Build RIA screen.

Step 2 Click anywhere in the RRL Type field to display a list of RRL types.

Step 3 Select TG Sheets as the RRL type. AIM I will present you with the TG Sheets window, which will:

- Be blank if no TG sheets have been created
- Contain a list of all the TG Sheets in the Course RRL

To select an existing TG sheet:

Step 1 Click on the TG Sheet desired for the RIA and select the **Options** menu item and the **Select** option.

**WARNING:** Care should be exercised in the selection of existing TG Sheets. The list of TG Sheets contains all the TG Sheets created in the course, not just the Topic selected.

To identify a new TG sheet:

Step 1 Select the **Options** menu item and the **Create** option. AIM I will display a menu of the different types of TG sheets available.

Step 2 Click on the desired TG sheet. AIM I will add an Instruction sheet to the list of the types selected and place the cursor in the Sheet Title field.
Step 3 Enter the Sheet Title and select the **Edit** menu item and the **Save** sub-menu item.

Step 4 To select the TG sheet for the RIA, click on the TG sheet and select the **Options** menu item and the **Select** option.

Step 5 Enter Before Text and After Text, as required, and select the **Edit** menu item and the **Save** sub-menu item to save your RIA entry.

**NOTE:** Identifying a single Instruction Sheet will create a TG. TGs are discussed in more detail in Chapter 11.

### 10.3.3.6.4.7 Selecting a Fault

**To select a fault:**

Step 1 Double click the RIA Text column. AIM will open the Build RIA window.

Step 2 Click anywhere in the RRL Type field to display a list of RRL types.

Step 3 Select Faults as the RRL type. AIM I will present the FAL window, which contains a list of faults from the Fault Applicability List (FAL) that were designated as required for the course.

Step 4 Click on the desired fault and click on the **Select** menu item.

Step 5 Enter Before Text and After Text, as required, and select the **Edit** menu item and the **Save** sub-menu item to save your RIA entry.

### 10.3.3.6.4.8 Selecting an IETM

Once an IETM Extraction file has been added to the Site RRL by the AIM Administrator using the Admin Utility, you can add that IETM to the Course RRL. AIM I contains browsers for the IETMs from which you can expand the menu of the IETM and select the item desired for the RIA.

**To select an IETM:**

Step 1 From the DP/RIA window double click on the RIA Text field for the appropriate DP. You will be placed in the Build RIA window.

Step 2 Click anywhere in the RRL Type field to display a list of Resource types.

Step 3 Select IETM as the Resource type. AIM I will open the Course RRL window, which contains a list of IETMs selected for the course and will also allow you to select an IETM from the Site RRL for the course and enter the appropriate quantity information.
NOTE: An IETM RRL item can only be added to the Site RRL from the Admin Utility. To Add/Modify/Delete an IETM RRL item in the Site RRL contact the AIM Administrator.

Step 4 Click on the desired IETM from the Course RRL and select the **Options** menu item and the **Select RRL for RIA** option.

AIM will connect the IETM to the database and the IETM Browser window will open. Clicking on the "+" blocks next to the titles in the IETM Browser will expand the menu and clicking on the "-" blocks next to the titles will reduce the menu.

Step 5 Select the **Options** menu item and the **Find** option. AIM I will open the Find window. Enter the name of the item desired or scroll through the list and click on the item. Click on the **Select** and **Exit** menu items to return to the browser. The item selected will be highlighted.

NOTE: If the item selected has an icon between the box and the title, it can be selected for the RIA. If an icon is not present, this represents a menu title and not an accessible IETM data element. To view the IETM you may have to have the IETM browser running.

Step 6 Select the Options menu item and the View option. View the IETM to ensure you have selected the correct information for your reference.

**CAUTION:** If you browse the IETM to a different location and decide this is the information you really wanted, the AIM browser is still pointing to the original data element where you entered the IETM, and you must therefore move the AIM browser to point to the selected information before proceeding to Step 7. You can use your Alt-Tab keys to return to the IETM browser and proceed with Step 6.

Step 7 Select the **Options** menu item and the **Select** option. AIM I will return you to the Build RIA window and the IETM selected will be identified in the RRL field.

Step 8 Enter Before Text and After Text as required, and select the **Edit** menu item and the **Save** sub-menu item to save your RIA entry.

**To select multiple IETM links in a RIA:**

The range of IETMs you select for an RIA must be under the same branch of the Table of Contents in the browser. From the IETM Browser window highlight the item to start the range, then hold down the shift key and click on the node to end the range. Select the Options menu item and the Select option to select the range of IETMs for the RIA.
10.3.3.6.4.9  Selecting an IMI

Interactive Multimedia Instructions (IMI) resources have been divided into five different folders within the Site RRL:

- Animation
- Audio
- Graphic
- Internet
- Power Point
- Video

The Build RIA window displays the IMM selected so that you can view/hear your selection. A viewer will open to play a video. The slides will be presented for a Power Point presentation and you can also select the slide/s applicable to the RIA. When the IMM is selected for a RIA AIM creates hot-links to the IMM for the RIA and Topic Page. The hot-links are used for development of HTML and SCORM files for the LP. When Print Preview is selected for an LP containing IMI, hyperlinks are created for the Trainee Preparation, Instructor Preparation, and RIAs citing the IMI.

**NOTE:** When selecting a Power Point Slide presentation as an IMM for a RIA the software contains fields for the user to add the starting and ending slide number(s). The starting and ending slide numbers are appended to the IMM title in the RIA to inform the instructor which slides are required to teach the DP. After the field entries have been saved to the database AIM does not restrict you to the slides selected.

**To select a Power Point Presentation for an RIA:**

**Step 1**  In the DP/RIA window click on the RIA field where the Power Point Presentation slide will be identified, select the **Options** menu item and the **Build RIA** option or double-click on the RIA field, to open the Build RIA window.

**Step 2**  Click on the arrow for the RRL Type to open the course resource selection menu and click on the IMM resource.

**Step 3**  From the Course RRL click on the desired Power Point Presentation. Select the **Options** menu item and select the **Select RRL for RIA** option. AIM will open the Power Point Presentation and display it in the Build RIA window. The display will also show you how many slides are contained in the presentation.

**Step 4**  Select the Slide Range by entering the number of the first slide to be presented in the From field and the last slide to be presented in the Through field. If only one slide is required enter this slide number in the From field and leave the Through field blank.

**NOTE:** When additional RIAs are built using the same Power Point Presentation AIM will automatically present the next sequential slide in the presentation for selection. However, you can select any slide(s) to build the RIA.
Step 5 Click on the arrow for the Before Text entry and select the appropriate direction for the instructor or type the direction in the field provided.

Step 6 If there are additional instructions for the instructor to direct the discussion of the slides selected enter the direction in the After Text field.

Step 7 Select the Edit menu item and the Save submenu item to save your RIA. AIM will return you to the DP/RIA window and the first slide selected in the From field of the Build RIA window will be displayed in the lower right when the RIA is highlighted.

**NOTE:** The IMM will only be displayed in the DP/RIA window if the Show IMM Preview option has been selected in the DP/RIA window. When you Print Preview the Topic containing the IMM it will be displayed on the Topic Page under Instructor Preparation/Training Materials Required and in the RIAs as a blue hot link. This is also how it will appear in a Generated HTML file output for the Web, less headers and footers.

### 10.3.3.6.4.10 Adding Another RIA

A RIA entry must exist for the DP before you can add another RIA sentence for a DP. The Add Another RIA option is not available when the RIA field highlighted is blank.

**To add another RIA:**

1. Step 1 Click on the RIA field that you want the new RIA to follow.
2. Step 2 Select Options; then select the Add Another RIA option. AIM will open a new field to build a RIA statement.
3. Step 3 Perform the steps listed in Section 10.3.2.6.4.5 to build an RIA.

### 10.3.3.6.4.11 Adding a Same Level RIA

The Add Same Level RIA option can only be used if there is no DP for the RIA highlighted. AIM will generate an RIA at the same sub-item level of the RIA that is highlighted. (For example, if RIA 2-c is highlighted AIM will generate a field for RIA 2-d.) Text cannot be entered in the DP field for this RIA. If DP text is desired, you must use the Add Lower Level DP option before building the associated RIA.

**To add a same level RIA:**

1. Step 1 Click on the RIA field that you want the new RIA to follow.
2. Step 2 Select Options; then select the Add Same Level RIA option. AIM will open a new field in which to build a RIA statement.
Step 3 Perform the steps listed in Section 10.3.2.6.4.5 to build an RIA.

10.3.3.6.4.12 Adding a Lower Level RIA

The Add Lower Level RIA option can be used only if the DP of the RIA highlighted does not have a sub-item at the same level as the RIA that you want to create. AIM I will generate an RIA at the level below the RIA that is highlighted. (For example, if RIA 2-c is highlighted, AIM I will generate a field for RIA 2-c-1.) Text cannot be entered in the DP field for this RIA. If DP text is desired, you must use the Add Lower Level DP option before building the associated RIA.

To add a lower level RIA:

Step 1 Click on the RIA field that you want the new RIA to follow.

Step 2 Select Options; then select the Add Lower Level RIA option. AIM I will open a new field to build an RIA statement.

Step 3 Perform the steps listed in Section 10.3.2.6.4.5 to build an RIA.

10.3.3.6.4.13 Deleting a RIA

The Delete option can be used to delete:
- A single RIA that has no sub-items
- A RIA, including all its sub-items

Deletion of the RIA also deletes any Notes, Cautions, or Warnings that were developed using that RIA. Deletion of an RIA does not delete the RRL item or the TG sheet that was called out in the RIA; they can be selected for other RIAs.

To delete a RIA:

Step 1 Click on the RIA that you want to delete and select the Options menu item.

Step 2 Select the Delete RIA option. AIM I will delete the RIA and any associated sub-items, Notes, Cautions, or Warnings.

10.3.3.6.4.14 Copying and Pasting a RIA

The Copy and Paste options can save time in building RIAs if you have returned to an RRL item that has been referenced previously in an RIA.

To copy and paste a RIA:

Step 1 Click on the RIA that you want to copy and select the Options menu item.
Step 2 Select the Copy RIA option. AIM I will place the RIA in a buffer.

Step 3 Highlight the RIA field in which the copied RIA will be pasted and select the Options menu item and the Paste RIA option. AIM I will maintain the links established with the RRL item selected.

10.3.3.6.4.15 Resequencing DPs and RIAs

When DPs are resequenced, their associated RIAs are resequenced with them. When RIAs are resequenced, their associated Notes/Cautions/Warnings are resequenced with them. The only criterion is that the DP/RIA to be resequenced must be of the same indenture as the DP/RIA it will replace. For example, DP 3 can be resequenced to DP 5. DP 3 cannot be resequenced to DP 5-a because 5-a is a different level of indenture. Notes/Cautions/Warnings can be resequenced only within the RIA, and location (bottom or top) from which they were developed.

To resequence a DP:

Step 1 Position the mouse arrow on the text of the DP you want to move and click on the text, holding the left mouse button down.

Step 2 Move the mouse, and a hand will appear in place of the arrow. Drag the text to the location desired and release the left mouse button. AIM I will resequence the DP to its new location and renumber subsequent DPs.

10.3.3.6.4.16 Linking DPs to the TLOs They Support

To indicate an association of items in the AIM I database, it is often necessary to link items together. Linking makes surveillance of items for maintenance easier when you are developing Changes and Revisions to training materials.

If a TLO is modified during maintenance, the DP that it is linked to will be flagged to alert you that:

- A maintenance action has been performed.
- The DP may require a maintenance action as a result.

If the DP is not linked to the TLO, a flag will not be generated, and the curriculum may be in error.

Example:

If a TLO is deleted, its associated DP will be flagged for deletion. If there is no flag, there is a chance that the maintainer will not delete the DP, and the instructor will teach information that is no longer required or is in error.
Since AIM I creates a DP for each TLO, it also automatically links the DP to the TLO. However, any DP that you add to complete the outline is not linked to the TLO. If you create sub-items for a DP the first DP added at a lower level will be linked to the same TLO but subsequent DPs will require linking. The TLO Link option allows you to link the DP to the TLO it supports.

To link a DP to the TLO it supports:

1. From the DP/RIA window highlight the DP to be linked.
2. Select the Options menu item and the TLO Link option. AIM I will open the Links to TLOs window.
3. Double click on the TLO(s) that you want to link/unlink the DP to/from.
4. Select the Exit menu item and save the TLO links for the DP to the database. AIM I will return you to the DP/RIA window.

10.3.3.6.4.17 DP Spacing

The default spacing between DPs is 5 spaces. When printing an LP the user can elect to change this default for the entire LP (1 to 10 spaces). To adjust the amount of space between selected DPs (1 to 10 spaces) in a Topic the user must select the DP Spacing option. When printing the LP the user can also elect to print all DPs with the individual spacing entered in the database or override the spacing and use the default.

To adjust the spacing between selected DPs:

1. Select the Options menu item and the DP Spacing option. AIM I will open the DP Spacing window that contains columns for the DP Number, Spacing, and DP Text.
2. For the DPs that require a different spacing than the default, click on the spacing field and enter the number (1 to 10) of the spaces required.
3. Depress Enter, if the Edit menu item is not enabled. Select the Edit menu item, and the Save sub-menu item to save your entries to the database.
4. Select the Exit menu item to return to the DP/RIA window.

The DP/RIA window will not display the spacing modifications entered. To view the spacing, exit the DP/RIA window to return to the Lesson Plan (LP) window and select the Print Preview option for the Topic modified.

To reset a DP spacing to the LP default:

1. Select the DP/RIA window Options menu item and the DP Spacing option. AIM I will open the DP Spacing window that contains columns for the DP Number, Spacing, and DP Text.
Step 2  Click on the Spacing field for the desired DP.

Step 3  Select the DP Spacing window **Options** menu item and the **Reset Spacing** option. The Spacing field will blank out which will instruct the software to use the default specified in the Print Options for the LP.

Step 4  Select the **Exit** menu item to return to the DP/RIA window.

10.4  Summary

Chapter 10 provided instructions on inserting, editing, deleting, resequencing, and linking DPs and on adding Notes, Cautions, and Warnings to the DP outline. It also explained how to define a location in the TG each time you select the TG as the RRL type.
CHAPTER 11

THE EXERCISE CONTROLLER GUIDE (ECG) MODULE

11.0 Exercise Controller Guide
11.1 Overview
    11.1.1 Front Matter
11.2 Accessing the Exercise Controller Guide (ECG)
11.3 ECG Options Menu Item
11.4 ECG Contents Menu Item
    11.4.1 How to Use the ECG
    11.4.2 Safety/Hazard Awareness Notice
    11.4.3 COI
11.0  EXERCISE CONTROLLER GUIDE

The Exercise Controller Guide (ECG) is a set of exercises for use as part of a formal curriculum programmed by a Lesson Plan (LP). The exercises in the ECG consist of operational scenarios and selected training procedures designed to accomplish specific, predetermined training objectives as contained within the topics in the LP that the exercises are used. The ECG is not built until the first Exercise is created in the Lesson Plan (LP).

You cannot work on an instruction sheet in the ECG module without first creating and selecting the Exercise in the Related Instructor Activity (RIA).

11.1  Overview

The ECG module is located on the course tree on the main course screen just under the LP module. It also has an icon on the top bar between the LP and TG icons. Finally, the ECG module can also be selected from the Documents Drop-down menu. An ECG is arranged in two basic divisions: the Front Matter and the exercises. Any references that are used in the exercises are included in the Resource Requirements List (RRL).

11.1.1  Front Matter

The Front Matter of a ECG provides general information about a particular ECG. AIM I generates the following Front Matter elements automatically:

- **Title Page:** Identifies the title of the course, the Course Identification Number (CIN), the Revision and Change Number, the words "Exercise Controller Guide", centered below the course title, the preparation date from the Lesson Plan, and "PUBLISHED BY center name" centered in the footer.
- **List of Effective Elements:** Tells the user which instruction sheets have undergone a change. All Front Matter elements and exercises are tracked by change level. In development, such tracking is not necessary since all elements are at the Revision 0, Change 0, level.
- **Change Record Page:** Records the entry of changes into the ECG. It also identifies, by initials, who entered each change and when.
- **Safety/Hazard Awareness Notice:** Initially it is identical to the Safety/Hazard Awareness Notice in the LP. It can be edited in the ECG and will not affect the contents of the LP.
- **Table of Contents:** Lists the Front Matter and the exercises. It is identical to the LP Table of Contents, except that exercises are listed instead of Parts, Sections, and Topics, and there is no Reference Material section.
- **How to Use Your Exercise Controller Guide:** This section should be tailored to meet the needs of the exercises in the ECG and should contain the following information:
  1. **Introduction:** The introduction includes an overview of the specific training equipment and associated training materials to be used with the ECG. This paragraph includes a description of the composition, function, and use of the ECG.
  2. **Exercise Selection:** This paragraph presents the procedures for selecting
exercises contained within the ECG.

3. Locally Prepared Exercises: This paragraph provides directions for the development of new exercises, or the modification or expansion of existing exercises, if such development is not prohibited by promulgating authority. Detailed information on the use of blank exercise sheets contained in the ECG should be provided in this paragraph.

4. Security: This paragraph contains a reminder to the instructor concerning the security measures that must be observed in the use of the ECG.

5. Safety Precautions: This paragraph contains a reminder to the instructor concerning the safety measures that must be observed in the use of equipment and the ECG.
11.2 Accessing the Exercise Controller Guide (ECG)

There are three different ways to access a Exercise Controller Guide (ECG) window after the course has been selected from the Course Select menu:

1. From the AIM I main menu select the Document menu item and the Exercise Controller Guide (ECG) sub-menu item.
2. Click on the ECG icon.
3. From the course tree structure double-click on the LP/ECG/TG or click on the “+” to expand the tree, click on the ECG folder, and select the Options menu item and the GoTo sub-menu item. Opening the ECG folder can provide Summary or Note data on the right hand portion of the course tree grid if the View menu sub-items (Note or Summary) have been checked. Summary data includes: CIN, Rev, Change, Title, and Status from the LP window. Note data contains Personal and/or Private Notes recorded by developers.

Selecting Exercise Controller Guide (ECG) opens the Exercise Controller Guide (ECG) window. The ECG window contains a text field for the CIN, Revision, Change, Course Title, Published by, and Security Awareness Notice. The only editable field is Published By.

The Security Awareness Notice block of the Exercise Controller Guide (ECG) window contains the same information that has been entered into the Lesson Plan (LP) and cannot be edited from the ECG. When the LP is initially created AIM I enters the default phrase “This course does not contain any classified material.” which can be edited in the LP for both the LP and ECG.

There are two ways of selecting an individual Exercise, one way is to select it starting from the Exercise Controller Guide (ECG) window and the other is to use the course tree structure.

To select an Exercise from the course tree structure:

Step 1 Expand the LP/ECG/TG, Part, Section, and Topic folders.

Step 2 Open the desired Exercise folder and select the Options menu item and the GoTo option.

To select an Exercise from the Exercise Controller Guide (ECG) window:

Step 1 Click on the Contents menu of the Exercise Controller Guide (ECG) window and select the COI sub-menu item. AIM I will open the ECG COI window, which contains a list of Parts/Sections/Topics.

Step 2 Select the Topic with the desired exercise by either double-clicking on the topic or single-clicking and selection Exercises from the Contents Drop-down menu.

Step 3 Select the desired exercise by either double-clicking on the exercise or single-clicking and selecting Select Exercise from the Options Drop-down menu.
11.3 ECG Options Menu Item

The ECG Options menu item contains the following options:

**Delete Unused Exercises**

To delete an unused exercise from the course follow these steps:

1. Right Click **ECG** from the expanded tree in the left pane.
2. Click **Options** to access the Options drop-down menu.
3. Click **Delete Unused Exercises** from the Options drop-down menu.
4. Highlight the desired exercise.
5. Click **Options** to access the drop-down menu.
6. Click **Delete** to delete the selected exercise.
11.4 ECG Contents Menu Item

Highlight a topic to develop, and then select the Contents menu item, which displays a sub-menu. From the sub-menu, you can select Safety/Hazard Awareness Notice, How to Use the ECG, or COI.

11.4.1 Safety/Hazard Awareness Notice

The Safety/Hazard Awareness Notice initially is the same as contained in the LP. If desired, it can be edited and when saved will be unique to the ECG. Editing will be accomplished using Word if selected as default or the AIM I Text Editor if Word is not selected as default.

To edit the Safety/Hazard Awareness Notice:

Step 1 From the Exercise Controller Guide (ECG) window, click on the Contents menu item and the Safety/Hazard Awareness Notice sub-menu item. AIM I will open the ECG Safety Awareness Notice window.

Step 2 If the text required is contained in an existing text (.txt) file, delete the existing text, select the Options menu item, and select the Import Text File. Locate the file and select it for import. The file contents will be imported into the ECG Safety Awareness Notice window.

Step 3 Edit the imported or existing text as necessary and select the Edit menu item and the Save sub-menu item.

Step 4 Select the Exit menu item to return to the Exercise Controller Guide (ECG) window or the Course Tree Structure.

11.4.2 How to Use the ECG

The How to Use the ECG sub-menu item contains boilerplate information that can be edited for the trainee. Editing will be accomplished using Word if selected as default or the AIM I Text Editor if Word is not selected as default.

To edit the How to Use the ECG:

Step 1 From the Exercise Controller Guide (ECG) window, click on the Contents menu item and the How to Use the ECG sub-menu item. AIM I will open the How to Use the ECG window.

Step 2 If the text required is contained in an existing text (.txt) file, delete the existing text, select the Options menu item, and select the Import Text File. Locate the file and select it for import. The file contents will be imported into the How to Use ECG window.
Step 3  Edit the imported or existing text as necessary and select the **Edit** menu item and the **Save** sub-menu item.

Step 4  Select the **Exit** menu item to return to the Exercise Controller Guide (ECG) window or the Course Tree Structure.

11.4.3  COI

The **COI** sub-menu item displays a list of Part/Section/Topics. From this screen topics containing Exercises can be selected, so that individual Exercises may be developed.

**Developing an Exercise from a selected Topic from the COI:**

Step 1  Select the Topic containing the desired Exercise by either double-clicking on the Topic or single-clicking and choosing **Exercises** from the **Contents** Drop-down menu.

Step 2  Select the desired Exercise by either double-clicking on the Exercise or single-clicking and choosing **Select Exercise** from the **Options** Drop-down menu.

Step 3  The selected Exercise front page is displayed. The Exercise front page contains the following input boxes:

- **Title:** The title of the Exercise.
- **Difficulty Type:** This is a Drop-down box where level of difficulty (Basic, Intermediate, or Advanced) is chosen.
- **Length in Minutes:** Length of the Exercise in minutes.
- **TOS:** The appropriate TOS level of the Exercise.
- **Training Approach:** The training approach used in the Exercise, such as Group or individual performance training.
- **Special Instructions:** Any special instructions to the instructor for conducting the Exercise.

Step 4  Once the Exercise front page information has been completed, select **Event Activity** from the **Contents** Drop-down menu.

Step 5  The Event Activity screen has two text boxes, Topic Number and Topic Title. There are also four columns; No., Time/Event Text, RIA Text, and RTA Text. No. is number of the particular item, number is done the same way as with the LP (i.e. 1, 1-a, 1-a-1, etc.). RIA Text is for Related Instructor Activity text and RTA is for Related Trainee Activity text. RIAs and RTAs are built the same way RIAs are built in the LP.

Step 6  Once all information has been entered, select **Save** from the **Edit** Drop-down menu.
Other options available from the Event Activity screen Options Drop-down menu

Like the LP Module, the Event Activity screen has the following options:

- Adding Same Level or Lower Level Time/Event
- Deleting Time/Event
- Building a RIA/RTA
- Adding Another RIA/RTA
- Adding Same Level or Lower Level RIA/RTA
- Copy and Paste RIA/RTA
- Adding Warnings, Cautions, or Notes
- Displaying Media
- Show IMI Preview
(This Page Intentionally Left Blank)
CHAPTER 12

THE TRAINEE GUIDE (TG) MODULE

12.0 Trainee Guide
12.1 Overview
  12.1.1 Front Matter
  12.1.2 Instruction Sheet
  12.1.3 Editors Used In The TG
    12.1.3.1 MS Word™
    12.1.3.2 Styled Text Editor
    12.1.3.3 High Edit AIM Editor
12.2 TG Status Levels and Privileges
12.3 Accessing the Trainee Guide (TG)
12.4 TG Options Menu Item
12.5 TG Contents Menu Item
  12.5.1 How to Use the TG
  12.5.2 Safety/Hazard Awareness Notice
  12.5.3 Security Awareness Notice
  12.5.4 TG Sheets
12.0 TRAINEE GUIDE

The Trainee Guide (TG) is a compilation of Instruction Sheets that are designed to be used by the trainee to increase the effectiveness of the instruction. The TG is not built until the first instruction sheet is created in the Lesson Plan (LP).

You cannot work on an instruction sheet in the TG module without first creating and selecting the instruction sheet in the Related Instructor Activity (RIA).

12.1 Overview

A TG is arranged in two basic divisions: the Front Matter and the instruction sheets. Any references that are used in the instruction sheet are included in the Resource Requirements List (RRL). The six types of instruction sheets are listed in Table 11-1.

<table>
<thead>
<tr>
<th>Table 11-1. Instruction Sheets, Divisions, and Associated Elements</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Front Matter</strong></td>
</tr>
<tr>
<td>Trainee Name Page*</td>
</tr>
<tr>
<td>Title Page</td>
</tr>
<tr>
<td>List of Effective Elements</td>
</tr>
<tr>
<td>Letter of Promulgation</td>
</tr>
<tr>
<td>Change Record</td>
</tr>
<tr>
<td>Security Awareness Notice</td>
</tr>
<tr>
<td>Safety/Hazard Awareness Notice</td>
</tr>
<tr>
<td>Table of Contents</td>
</tr>
<tr>
<td>How to Use Your Trainee Guide</td>
</tr>
<tr>
<td>Course Learning Objectives*</td>
</tr>
<tr>
<td>Course Master Schedule*</td>
</tr>
</tbody>
</table>

* NAVEDTRA 131B optional items

12.1.1 Front Matter

The Front Matter of a TG provides general information about a particular TG. AIM I generates the following Front Matter elements automatically:

- **Title Page**: Identifies the title of the course, the Course Identification Number (CIN), the Revision and Change Number, the Approval Agency, and the Promulgation Date. Any special graphics need to be created outside AIM I.
- **Trainee Name Page**: The Trainee can enter their name and class number on this page to identify ownership.
• **List of Effective Elements:** Tells the user which instruction sheets have undergone a change. All Front Matter elements and instruction sheets are tracked by change level. In development, such tracking is not necessary since all elements are at the Revision 0, Change 0, level.

• **Letter of Promulgation:** AIM I automatically generates a blank page for the Letter of Promulgation.

• **Change Record Page:** Records the entry of changes into the TG. It also identifies, by initials, who entered each change and when.

• **Safety/Hazard Awareness Notice:** Initially it is identical to the Safety/Hazard Awareness Notice in the LP. It can be edited in the TG and will not affect the contents of the LP.

• **Security Awareness Notice:** Is identical to the Security Awareness Notice in the LP. If you need to add any information, you should go to the LP module and edit the Security Awareness Notice there.

• **Table of Contents:** Lists the titles and the page numbers of all instruction sheets arranged by Part, Section, and Topic number. If, at any time, you go back to the LP and add or delete instruction sheets, you will need to reprint your TG Table of Contents.

• **How to Use Your Trainee Guide:** Information for the trainee on the composition, function and use of Instruction Sheets and what the trainee can expect on examinations and quizzes in the course. It can be tailored for the course being developed.

• **Course Learning Objectives:** Are identical to the Course Learning Objectives in the COI module.

• **Course Master Schedule:** Is identical to the Course Master Schedule in the CMS module.

### 12.1.2 Instruction Sheets

The TG module provides automated assistance for you in producing the six types of instruction sheets for your TG:

- Assignment Sheets
- Job Sheets
- Information Sheets
- Problem Sheets
- Outline Sheets
- Diagram Sheets

Assignment Sheets are used to assign necessary assignments and identify the Topic Learning Objectives (TLOs) that the assignments are prepared to cover. An Assignment Sheet usually includes study questions for the trainee to answer.

Job Sheets are step-by-step procedures that the trainee must follow in the performance of operation or maintenance tasks and include a listing of the equipment and references necessary to perform the Job Sheet.
Information Sheets provide additional, amplifying, or background information essential to the trainee’s thorough understanding of a Topic and include a list of the references from which the information was obtained.

Problem Sheets are developed to assist the trainee in developing problem-solving skills. Because Problem Sheets may be developed in any format, all the options available for the other instruction sheets are available during development of Problem Sheets.

Outline Sheets are provided to assist the trainee in taking notes to support the current topic.

Diagram Sheets are graphic representations provided for the trainee to use for notes. The interface with the AIM I Graphics utility (in the AIM I Utilities module) is where an actual graphic is entered. The TG module then allows the user to select a graphic from the graphics library in the database for the Diagram Sheet.

Answer Sheets are part of the LP; they are created when you work on an Assignment, Job, or Problem Sheet in the TG. Answer Sheets are printed as part of the Back Matter of the LP. The text for the answers to the questions created in the Assignment, Job, or Problem Sheet is recorded on the Answer Sheet portion of the LP back matter.

12.1.3 Editors Used In The TG

12.1.3.1 MS Word™

MS Word™ is the default editor for the major text entry portions of the TG, which includes:

- Safety/Hazard Awareness Notice
- How to Use the TG
- Assignment Sheet - Study Questions
- Diagram Sheet - Diagram
- Information Sheet - Information
- Job Sheet - Job Steps
- Outline Sheet - Topic Outline
- Problem Sheet - Problem

However, in previous versions of AIM I, MS Word™ was not available and High Edit was used as the editor. AIM I offers the user a choice of which editor to use when maintaining curricula that was previously developed using High Edit. High Edit will still be used for approved materials that were originally developed using High Edit. If MS Word™ is not available the user will be required to use High Edit for the Instruction Sheets and a basic text editor for the Safety/Hazard Awareness Notice and How to use the TG. Word 97 is also an option for those facilities that have not upgraded Word. Once Word has been selected as the desired editor and an Instruction Sheet is developed using Word and saved to the database you cannot change to High Edit.
**AIM is affected by the security settings in Word:**
AIM has included macros for Word to allow the software to bring up the Graphics Selection and IMM programs. The macros are required to add graphics from the AIM graphics library to the instruction sheet and hyperlink IMM to the Instruction Sheets for generation of HTML and XML files. It is not required for viewing or printing the TG. Microsoft has security built in to Word to prevent unwanted macros from running.

Word has a process known as digital signing to identify who created macros. This signs a macro with a certificate coming from some trusted source (the Graphics Selection macro comes from *Verisign*). If the macro is altered in any way, the certificate becomes invalid, which prevents tampering. When a document or template, that contains said signed macro, is opened by Word they can tell who created the macro and display that information to the user.

Early versions of Word 97 will just say: “This file contains macros, do you want to accept them?” This is an all or nothing proposition. It doesn’t tell you who wrote the macro, or whether it has been signed. In order for the user to avoid seeing this message every time AIM opens a Word document (and it will show up many times during one print cycle) the user will have to turn off “macro virus protection”. To turn this off, click the “Tools-> Options menu, go to the General tab, and uncheck the “macro virus protection” option.

Updated versions of 97, and all later versions of Word, have a more robust protection scheme. Word offers three levels of protection: Low, Medium, and High. [You can check your current settings through the Tools->Macros->Security menu. The first tab is your security level. The second tab shows your trusted sources.

Low protection is actually No protection. Files with macros are opened without warning.

Medium protection will inform users of unsigned macros and suggest they don’t accept them. Signed macros will be displayed and the user has the option to accept macros from the source. If selected, any new documents opened with a macro from that source are accepted and enabled without prompting.

High protection will disable unsigned macros without notification. Signed macros offer the same accept/deny prompt as in medium above, except the user MUST accept all macros from that source before they can enable the macros. High security will disable AIM macros.

For Word 2000 (and some 97) users, it is recommended that you use the “Medium” security level. No Macro will be disabled without warning.

For Word 97 users, you must turn off macro virus warnings.

**To enable the Graphics and IMM macros manually:**
- Go to the AIM directory on your computer (default location is C:\Program Files\AIM I).
- Inside the AIM directory, open the directory Data Files
- Double-click to open the file named setup.doc.
- You should be asked to enable macros. Click the "Always trust..." check box and click Enable.
- The Insert Graphic/IMI icons and sub-menu items should now appear in Word.
12.1.3.2 Styled Text Editor

The Styled Text Editor is used for the instruction sheet Introduction fields and provides the developer with the ability to change font, pitch, center, and justify the text. Right click on the mouse and a pop-up menu appears with Cut/Copy/Paste options. The Styled Text Editor also employs spell-as-you-type capability. A pop-up menu with “Add to User Dictionary” appears when you right click on a misspelled word, as well as suggestions for changing the word.

12.1.3.3 High Edit

When using AIM editors there is no timed backup. Save your materials frequently.

AIM's High Edit function, which is available for editing Trainee Guide (TG) Instruction Sheets, offers more formatting features than those available in AIM I's Text Editor. The High Edit menu bar offers six choices: File, Edit, Format, Options, Table, Exit, and Help.

The menu bar's File drop-down menu provides the options to print or print preview text, and add or delete graphics for an instruction sheet, and import a text or rich text formatted file.

The File drop-down menu provides the following options:

- **Add Graphic** - Allows you to select a graphic from the Graphic Utility portion of the database. The width and height of the graphic can be adjusted to size the graphic for the instruction sheet when selected in the Graphics library. When this information is saved in the Graphics library the file name of the graphic and its sizing information is placed on the Instruction Sheet where the cursor was located when the Add Graphic option was selected.

- **Delete Graphic** - Placing the cursor on the same line, as the graphic in the instruction sheet and selecting this option will delete the graphic from the Instruction Sheet and unlink the graphic from the Graphics library.

- **Import Text File** - If the required text has already been created in a word processor and saved as a Rich Text Format (.rtf) or Text (.txt) file the entire contents of the file can be imported into the Instruction Sheet at the location of the cursor by selecting this option and selecting the appropriate file.

- **Export to File** - This option allows you to export the contents of the editor window to either a Rich Text Format (.rtf) or Text (.txt) file.

- **Print** - This option allows you to print the entire Instruction Sheet for review. The software does not calculate the actual position of the Instruction Sheet in the TG and each printout starts with the page number 1.

- **Print Preview** - This option allows you to preview and print the Current Page, Range of Pages, and Entire Document for review of the Instruction Sheet. The software does not calculate the actual position of the Instruction Sheet in the TG and each printout reflects the page number contained in the document starting with the page number 1.

The menu bar's Edit drop-down menu offers the standard windows Cut, Copy, and Paste options, which can be selected by the following keystroke options:
Cut  = Ctrl + X
Copy  = Ctrl + C
Paste = Ctrl + V.

The Edit menu offers a number of other options:

- **Undo (Ctrl + Z)**: Allows cancellation of a command, a keystroke, or a series of keystrokes, one at a time, in reverse order, beginning with the command, keystroke, or series of keystrokes entered most recently.
- **Clear (Del)**: Deletes the character to the right of the cursor or any highlighted text.
- **Select All**: Highlights all text within a TG sheet.

**NOTE**: Find and Find and Replace options exercised on an entire AIM Editor window of text will not examine the contents of a Graphic.

- **Find (Ctrl + F)**: Takes the cursor, either forward or backward, to the text (a word or string of words) that is specified in a window the command calls up.
- **Find Next (F3)**: Allows the software to continue a search.
- **Find and Replace (Ctrl + R)**: Allows the software to replace the text (a word or string of words) entered in the "Replace with" field. High Edit allows replacement of the next occurrence of the text, either forward or backward, or all occurrences of the text.
- **Spell Check Entire Document (Shift + F2)**: Identifies possibly misspelled words, suggests substitutes, and allows you to replace or ignore possibly misspelled words throughout the text.
- **Spell Check From Cursor Down**: Identifies possibility of a highlighted word being misspelled. Suggests substitutes, and allows you to replace or ignore possibly misspelled words from the position of the cursor to the end of the file.
- **Save (Ctrl + S)**: Saves the editing completed for the instruction sheet.
- **Cancel**: Cancels all editing accomplished since last save.

High Edits Format drop-down menu offers formatting features. Options available from the Format drop-down menu include the following character attributes:

- **Normal**: Changes highlighted boldface or italic text to normal.
- **Bold (Ctrl + B)**: Makes highlighted text boldface (e.g., boldface text).
- **Underline (Ctrl + U)**: Draws a line under highlighted text (e.g., underlined text).
- **Italic (Ctrl + I)**: Makes highlighted text italic (e.g., italic text).
- **Strike Thru**: Draws a line through highlighted text (e.g., delete text).
- **Superscript**: Makes a highlighted character superscript (e.g., 22 becomes $2^2$).
- **Subscript**: Makes a highlighted character subscript (e.g., H2O becomes H$_2$O).

Format menu options also include the following text attributes:

- **Align Left**: Gives highlighted text flush left and ragged right margins. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Center**: Centers text. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Align Right**: Gives highlighted text ragged left and flush right margins. If text is not highlighted the command lines up only the text on the line on which the cursor rests.
• **Justify**: Lines up both left and right margins of highlighted text. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.

• **Spacing**: Provides a sub-menu with items "Single", "One and a Half" and "Double". Inserts empty line spaces between each line of highlighted text.

• **Paragraph Spacing**: Provides the option to control the spacing for paragraphs within the document and allows you to select sub-menu items "Single", "One and a Half" and "Double".

• **Color**: Provides the option to change the color of highlighted text from a palette of 16 font colors (including black and white).

• **Font**: Provides the option to alter the appearance of highlighted text for viewing and printing, including size, typeface, color, and font attributes such as bold or italic.

**NOTE**: Use of Tabs with Center or Justify format can cause portions of text to be uneditable.

From the **Options** drop-down menu, the following options are available:

• **Indent**: Provides for indentation of the text on the line of the cursor and subsequent lines before the next hard return. The document indenture has default of "1". Placing the cursor at the desired location, selecting the Indent option can change the indenture, by entering the value desired for left, right, and first line indentures.

• **Bullets Numbering**: Opens a Bullets and Numbering window from which you can select from either 8 different styles of bullets or numbering for selection to indent the highlighted text in your file.

• **Toggle Page Break**: Inserts or deletes a page break at the location of the cursor.

• **Tab visible**: Inserts an arrow (→) in TG sheet text wherever a tab has been entered.

• **Line Feed Visible**: Inserts a paragraph mark (¶) in TG sheet text where a hard return has been entered.

• **Space Visible**: Inserts a centered dot (•) in TG sheet text wherever a space character has been entered.

• **Nroff Translation**: Converts the nroff codes of UNIX, which were migrated from AIM 3.X, to font codes and indentures used within AIM I High Edit, which results in formatted text. This option is only enabled if nroff codes exist in the document and should only be used once on a file. Adding nroff codes to the file after performing Nroff Translation and selecting Nroff Translation again may cause errors.

The High Edit **Indent** function in AIM I version 3.X works different than in versions 2.1 and earlier. The following procedure will allow you to format a Hanging Indent (as it is called in Microsoft Word97). For example purposes, formatting of a job step from a Job Sheet will be described. (NOTE: There are several different ways to format a hanging indent. The following procedure is only one of the methods.)

**To create a Hanging Indent:**

Step 1  Position the cursor where you want to create the paragraph with a Hanging Indent.

Step 2  Select **Indent** from the **Options** drop-down menu.
Step 3 Type "3" in the Left box and "1.5" (minus 1.5) in the First Line box, then click OK. (Note: Ensure that the entry in the Right box is 0 (zero).

Step 4 Type "Step 1." And press the Tab key, and then type the text of the step. The text will now wrap to the start of the text following "Step 1."

From the Table drop-down menu, the following options are available:

- **Create Table**: Will create a table with the number of rows and columns specified. Will default to a grid table unless you desire to change the properties of the table. *To create a table refer to paragraph 10.5.4.6 (TG Diagram Sheet).*

- **Border Style**: Will allow you to change the border of the cells highlighted to No border, Box, Grid or Shadow. This screen will also allow you to create a 3-D effect through use of raised and sunken lines and allow you to change the line styles.

- **Cell Dimension**: Will allow you to change the row height to Auto, At Least, and Exactly. Auto will expand the height of the row automatically as text is entered, At Least will establish the height of the row in a cell until the text expands it. Exactly will limit the amount of text a cell can display in a given row. You can also select the indenture from the left for each row, change the width of a column, and change the space between columns. All measurements on the ruler bar are in centimeters.

- **Insert Table Row**: Adds a row above the row containing the cursor.

- **Append Table Row**: Adds a row to the bottom of the table.

- **Delete Table Row**: Deletes the row containing the cursor.

- **Insert Table Column**: Adds a column to the left of the column containing the cursor.

- **Append Table Column**: Adds a column to the far right of the table.

- **Delete Table Column**: Deletes the column containing the cursor.

To save an edited TG sheet, select **Edit** and **Save** on the AIM Editor window menu bar. Alternatively, enter Control + S. If you have edited text and attempt to exit via the Exit option on the menu bar, AIM I will prompt, *Text has been modified. Would you like to save?*

Holding down the Alt key and repeatedly depressing the Tab key will show you how many windows you have open. You can switch to a different window and copy text or characters required for you document then again open the TG window and paste the text or characters at the position desired.

### 12.2 TG Status Levels and Privileges

Status levels and privileges are assigned to the TG to provide a level of administrative security. Privileges minimize unauthorized use of the system by specific users. Status levels limit the type of actions that can be performed on a TG.

Because of the intrinsic relationship between the LP/TG and the Course, the privilege granted to you in the Admin module by the AIM Administrator for the Course is the same for the LP and TG. If you have Edit privilege for a Course, you can edit the TG. For additional information about privileges, see Chapter 1, paragraph 1.5.
12.3 Accessing the Trainee Guide (TG)

There are three different ways to access a Trainee Guide (TG) window after the course has been selected from the Course Select menu:

1. From the AIM I main menu select the **Document** menu item and the **Trainee Guide (TG)** sub-menu item.
2. Click on the TG icon.
3. From the course tree structure double-click on the LP/TG or click on the “+” to expand the tree, click on the TG folder, and select the **Options** menu item and the **GoTo** sub-menu item. Opening the TG folder can provide Summary or Note data on the right hand portion of the course tree grid if the **View** menu sub-items (**Note** or **Summary**) have been checked. Summary data includes: CIN, Rev, Change, Title, and Status from the LP window. Note data contains Personal and/or Private Notes recorded by developers.

There are two ways of selecting an individual Instruction Sheet, one way is to select it starting from the Trainee Guide (TG) window and the other is to use the course tree structure.

**To select an instruction sheet from the course tree structure:**

Step 1 Expand the LP/TG, Part, Section, and Topic folders.

Step 2 Open the desired Instruction Sheet folder and select the **Options** menu item and the **GoTo** option.

**To select an instruction sheet from the Trainee Guide (TG) window:**

Step 1 From the Trainee Guide (TG) window highlight the Topic that contains the Instruction Sheet that you want to edit.

Step 2 Click on the **Contents** menu of the Trainee Guide (TG) window and select the **TG Sheets** sub-menu item. AIM I will open the TG Sheet window, which contains a list of instruction sheets in the highlighted Unit/Topic.

Step 3 Click on the TG sheet that requires editing and select the **Options** menu item and the **Select TG Sheet** option.

Selecting **Trainee Guide (TG)** opens the Trainee Guide (TG) window. Until the default font has been saved to the database the software will prompt you with "The default font size has not yet been set. Do you want to set it now?" A Yes response will open the Print Options window where you can select either 10 or 12-point font for the TG. The TG window contains a text field for the Security Awareness Notice and a three-column table from which you can select the Part/Section/Topic and access the TG Sheets window, which contains a list of all the instruction sheet(s) in the topic selected.

The Security Awareness Notice block of the Trainee Guide (TG) window contains the same information that has been entered into the Lesson Plan (LP) and cannot be edited from the TG. When the LP is initially created AIM I enters the default phrase “This course does not contain any classified material.” which can be edited in the LP for both the LP and TG.
Help is available from all screens by clicking on the Help Icon or by pressing <F1>. See Chapter 2 for a detailed discussion of Help options, as well as Print and Print Preview options and use of the AIM Editors.

12.4 TG Options Menu Item

The TG **Options** menu item contains the following options:

- **Find TG Sheet**: Opens the Find TG Sheet window that contains a list of all TG Sheets sited in RIAs in the LP by sheet type, number, and title. The TG sheets are listed by the Part, Section, Topic, and sequence number. The Find field contains a wild card and allows you to find the TG Sheet by entering the title. The Select menu item opens the Part/Section/Topic that contains the TG Sheet.

- **Delete Unused TG Sheets**: Opens the Unused TG Sheets window which lists all the TG Sheets in the Course RRL that have not been selected for a Related Instructor Activity (RIA) in the LP. Highlighting the Instruction Sheet not required and selecting the **Delete** option from the **Options** menu item will delete the Instruction Sheet from the Course RRL.

- **TG Options**: The default for printing is 10 point and if printing to a file AIM will generate one file for the TG. By using the Print Options you can change the font for the TG to 12 point, for all areas not utilizing Word or High Edit, and the output can print elements of the TG as separate files. The default editor is Microsoft Word unless the document was previously created in High Edit. If the user desires High Edit it can be selected as the editor of choice by checking the block adjacent to the statement *Don’t use Microsoft Word as the default editor.*

- **Print Preview Entire TG or Part/Section/Topic TG Sheets**: Displays the entire TG or the TG Sheets in the highlighted Part, Section, or Topic or the Entire TG, depending on the sub-menu item selected; **Entire TG or Part/Section/Topic TG Sheets**. TG Print Preview window displays the total number of pages, current page from the cover, actual page number, and allows you to find an Instruction Sheet by typing the Part, Section, Topic, and sequence number of the sheet. The Print menu item contains the option to print the Current Page, Range of Pages, and Entire Document. Selection of the **GoTo** menu item allows you to select the previous, next, first, last, or desired page. Clicking on the page with the left mouse button allows you to zoom in on the page. Clicking on the page with the right mouse button allows you to zoom out. Selecting **Exit** will exit the TG Print Preview window and return you to the Trainee Guide (TG) window.

- **Print**: Allows you to print the entire TG or the TG Sheets in the highlighted Part, Section, or Topic depending on the sub-menu item selected: **Entire TG or Part/Section/Topic TG Sheets**.

- **Print Change Package**: Allows you to Print/Print Preview the entire TG Change Package or a Part/Section/Topic of the Change Package.
To produce Portable Document Format (PDF) files for the TG:

In order to produce correctly formatted PDF files as output of AIM I products, you must have the Adobe Acrobat Standard/Professional program installed, either on your local PC or accessible via a LAN server. If you do not have access to Adobe Acrobat Standard/Professional, see your local system administrator about either buying the program or giving you access to the program already on the LAN.

Once you have access to Acrobat Standard/Professional, the most accurate way to render the TG into PDF files is as follows:

Step 1  Add a print-to-file printer definition on your PC for use with AIM. Select PostScript printer definition in Windows. (If you don't already have a PostScript printer definition on your system, you may be prompted to insert the Windows 95/98/2000 CD/diskette as part of the process.) When creating (or modifying) the PostScript definition in Windows, choose Local Printer (rather than Network) and FILE output (rather than LPT 1). Name the printer something that will remind you it is a file output; e.g., AIM File Output. Select the PostScript definition as default for your system.

Step 2  Within AIM I, from the Trainee Guide (TG) window:
   a. Select the Options menu item and the Print/Preview Entire TG option.
   b. Select the Print menu item from the Print/Preview window and select Entire Document - AIM I will ask for verification. Click on the Yes button to print or the No button to return to the Print/Preview window.
   c. Windows will prompt you for a path and filename for the output files.

Step 3  Once you have generated the PostScript output files, start the Acrobat Distiller program (one of several components installed in the Adobe Acrobat Standard/Professional Program). When you start Distiller, from the File menu, select the Open menu option to process the PostScript output file you created at Step 2. Distiller will then prompt you to define a PDF output file name. The default will be the same as the PostScript file you selected to Distill but with a .PDF suffix to identify it as a Portable Document Format file. You can put the PDF file produced by Distiller in any directory you wish. The default is the last directory in which a PDF file was placed. Distiller will then process the PostScript file and create the PDF format with the filename and in the directory you specify. This process should take from 15 seconds to several minutes, depending on the speed of your PC and the size and complexity of the files you are distilling.

NOTE: It is also possible to create a PDF directly from within AIM I by selecting the PDF Writer printer definition which is created when Adobe Acrobat Standard/Professional is installed. This definition, however, may cause some formatting problems because it is not fully supported by the AIM print routines. The three-step process outlined above, to create a PostScript output file which is then Distilled to PDF, is more reliable in producing PDF files which exactly mirror the format of AIM I hardcopy output products.
12.5 TG Contents Menu Item

Highlight a topic to develop, and then select the Contents menu item, which displays a sub-menu. From the sub-menu, you can select How to Use the TG, Safety/Hazard Awareness Notice, Security Awareness Notice, or TG Sheets.

12.5.1 How to Use the TG

The How to Use the TG sub-menu item contains boilerplate information that can be edited for the trainee. Editing will be accomplished using Word if selected as default or the AIM I Text Editor if Word is not selected as default.

To edit the How to Use the TG:

- **Step 1** From the Trainee Guide (TG) window, click on the Contents menu item and the How to Use the TG sub-menu item. AIM I will open the How to Use the TG window.

- **Step 2** If the text required is contained in an existing text (.txt) file, delete the existing text, select the Options menu item, and select the Import Text File. Locate the file and select it for import. The file contents will be imported into the How to Use TG window.

- **Step 3** Edit the imported or existing text as necessary and select the Edit menu item and the Save sub-menu item.

- **Step 4** Select the Exit menu item to return to the Trainee Guide (TG) window or the Course Tree Structure.

12.5.2 Safety/Hazard Awareness Notice

The Safety/Hazard Awareness Notice initially is the same as contained in the LP. If desired, it can be edited and when saved will be unique to the TG. Editing will be accomplished using Word if selected as default or the AIM I Text Editor if Word is not selected as default.

To edit the Safety/Hazard Awareness Notice:

- **Step 1** From the Trainee Guide (TG) window, click on the Contents menu item and the Safety/Hazard Awareness Notice sub-menu item. AIM I will open the TG Safety Awareness Notice window.

- **Step 2** If the text required is contained in an existing text (.txt) file, delete the existing text, select the Options menu item, and select the Import Text File. Locate the file and select it for import. The file contents will be imported into the TG Safety Awareness Notice window.
Step 3  Edit the imported or existing text as necessary and select the **Edit** menu item and the **Save** sub-menu item.

Step 4  Select the **Exit** menu item to return to the Trainee Guide (TG) window or the Course Tree Structure.

12.5.3 Security Awareness Notice

The **Security Awareness Notice** sub-menu item is provided for the trainee and is generated from the LP. If it requires editing you must do so from the LP Cover Page.

12.5.4 TG Sheets

To select an Instruction Sheet from the Trainee Guide (TG) window:

Step 1  Highlight the desired Part/Section/Topic and select the **Contents** menu item and the **TG Sheets** sub-menu item to open the TG Sheets window. AIM I will list all the TG Sheets contained in that Topic.

Step 2  Highlight the desired Instruction Sheet and select the Options menu item and the **Select TG Sheet** option.

*OR*

Step 1  Select the **Options** menu item and the **Find TG Sheet** option.

Step 2  AIM I will list all the TG Sheets contained in the TG. Highlight the desired Instruction Sheet and click on the **Select** menu item.

To select an Instruction Sheet from the Course Tree Structure:

Step 1  Expand the LP/TG folder and the Part, Section, and Topic folders. The Instruction Sheet folders contained in the Topic will be displayed.

Step 2  Open the desired Instruction Sheet and select the **Options** menu item and the **GoTo** option or click on the GoTo button on the toolbar.

12.5.4.1 TG Assignment Sheet

Double clicking on an Assignment Sheet from the TG Sheets window will display the TG Assignment Sheet window for the Assignment Sheet selected.

The Title can be edited if desired.
NOTE: Some elements of instruction sheets are not permitted to be modified until the Introduction field is filled in and saved. The Introduction field uses the Styled Text Editor.

To enter information in the TG Assignment Sheet window:

Step 1 Position the cursor in the Sheet Title or Introduction field.

Step 2 Type in the desired information.

Step 3 Select Edit; then select Save.

Selecting the Contents menu item produces a drop-down menu that contains TLO Links, Study Assignment, Study Questions, and Answers. The Study Questions sub-menu item will either use High Edit or Word, whichever is selected as default, and the Answers sub-menu item will present the AIM I Text Editor for development of the Answer Sheets in the LP. When you are done, select File and Save, then select Exit to return to the Assignment Sheet window.

NOTE: Enter the number of the question when entering the answer. The Answer Sheets will print out as the last page(s) of the LP.

To select the TLOs that the Assignment Sheet will exercise:

Step 1 Select the Contents menu item and the TLO Links sub-menu item. AIM I will retrieve a list of the TLOs in the Topic.

Step 2 Select the Options menu item and the Select All option if all the TLOs are covered in this Assignment Sheet. If all the TLOs are not covered, consecutively highlight each TLO that the Assignment Sheet will cover and select the Options menu item and the Select option until all TLOs desired have been selected. An X in the select column will indicate that the TLO is selected.

NOTE: Selecting any TLO sub-item will automatically select the main TLO.

Step 3 Select the Exit menu item and save your changes to the database. AIM I will return you to the TG Assignment Sheet window.

To create Study Assignments:

Step 1 Select the Contents menu item and the Study Assignment sub-menu item. AIM I will present the Study Assignment window for your Assignment Sheet.

Step 2 Click on the Type column arrow and select the type of document (Reference, TG Sheet, or IETM) you want to direct the trainee to use for the assignment.

Step 3 What do you want the trainee to do with the Reference, TG Sheet, or IETM? Click on the Before Text column and the arrow button. Click on a Before Text verb from the list provided (Read, Review, Scan, Study, or Complete).
Step 4 Click on the Document field and select the **Options** menu item. Click on the **Select RRL/TG/IETM for Document** option that corresponds to the selection made in Step 2. AIM I will retrieve the References, TG Sheets, or IETMs from the Course RRL.

Step 5 Highlight the desired item and select the **Options** menu item and the **Select** option.

If the item selected was an IETM perform the following:

<table>
<thead>
<tr>
<th>NOTE: AIM will connect the IETM to the database and the IETM Browser window will open. Clicking on the &quot;+&quot; blocks next to the titles in the IETM Browser will expand the menu and clicking on the &quot;-&quot; blocks next to the titles will reduce the menu.</th>
</tr>
</thead>
</table>

a. Select the **Options** menu item and the **Find** option. AIM will open the Find window. Enter the name of the item desired or scroll through the list and click on the item. Click on the **Select** and **Exit** menu items to return to the browser. The item selected will be highlighted.

<table>
<thead>
<tr>
<th>NOTE: If the item selected has an icon between the &quot;-&quot; box and the title, it can be selected for the document. If an icon is not present, this represents a menu title and not an accessible IETM.</th>
</tr>
</thead>
</table>

b. Select the **Options** menu item and the **Select** option. AIM will return you to the Study Assignment window and the IETM selected will be identified in the Document field.

Step 6 Highlight and click on the After Text field and enter directions on exactly what to Read, Review, Scan, Study, or Complete in the document selected.

Step 7 Add additional assignments as required by selecting the **Options** menu item and the **Add** option and repeating Steps 2 through 6. When you are done, select the **Exit** menu item and save your entries to the database and exit to the TG Assignment Sheet window.

Step 8 Select the **Exit** menu item, save all your entries to the database, and return to the TG Sheets window or the Course Tree Structure.

### 12.5.4.2 TG Diagram Sheet

Double clicking on a Diagram Sheet from the TG Sheets window displays the TG Diagram Sheet window for the Diagram Sheet selected.

Selecting the **Contents** menu item and the **Diagram** sub-menu item from the TG Diagram Sheet window opens either Word or High Edit. The **File** menu item of High Edit and the **Insert** menu item in Word allows you to select the **Add Graphic** option which presents a list of the graphics contained in the Graphics library in the AIM I database.
NOTE: This procedure is identical for entering graphics into any High Edit text field, regardless of the type of Instruction Sheet.

The original title of the instruction sheet is created in the LP, but can be edited in the TG.

To add a graphic into a text field from the AIM Editor:

Step 1 For High Edit select the File menu item and the Add Graphic option. For Word select the Insert menu item and the Add Graphic sub-menu item.

Step 2 The software will present a list of graphics identified in the Graphics Utility. If you know the Description of the graphic desired you can select the Options menu item and the Find option to locate the graphic. Highlight the desired graphic and select the Options menu item and the Select option.

NOTE: The list of graphics presented will be all that are currently in the AIM I Graphics database. To add additional graphics to the database, refer to Appendix B, Utilities.

NOTE: If the selected graphic appears unacceptable for use in the Trainee Guide, try exporting the same graphic from your graphics workstation in Encapsulated Post Script (EPS) format using "EPS No header or Preview" which may sharpen the graphic to an acceptable quality.

Step 3 For High Edit enter the Print width (maximum 6.5) and Print height (maximum 8.5) desired for the graphic in the TG Sheet.

NOTE: Modifications to width and height must be proportional to maintain graphic integrity, i.e., prevent distortion. For example: increasing print width by 10% must be accompanied by a 10% increase in print height.

Step 4 Select Edit, then select Save. The software will return you to the AIM I High Edit window and will display the graphic file designator and sizing information. In Word the actual graphic will be displayed.

Step 5 To center the graphic in High Edit place the cursor on the same line as the graphic designator, select the Font menu item, and click on the Center sub-menu item. The graphic can be positioned vertically by inserting hard returns before the graphic designator.

Step 6 When complete, select the Edit menu item and the Save sub-menu item to save your data to the database.

Step 7 Select the Exit menu item to return to the TG Diagram Sheet window.

Step 8 Select the Exit menu item from the TG Diagram Sheet window and return to the TG Sheets window or the Course Tree Structure.
To modify an existing graphic from High Edit:

Step 1 Position the cursor on the line of the graphic and select the **File** menu item and the **Modify Graphic** option.

The Graphic Resize window will open, which displays the Graphic Width and Height of the graphic at the cursor position in the AIM I High Edit.

Step 2 To resize the graphic select the **Options** menu item and the following options will appear:
- **Increase 5%** - increases the width and height of the graphic 5%
- **Decrease 5%** - decreases the width and height of the graphic 5%
- **Original** - enabled only when the Graphic Resize window is open and will return the graphic's width and height to the values that were present when the window was initially opened.

Step 3 Select the appropriate option and select **OK** when complete. The window will close and the graphic resize information will appear on the graphic line in the AIM I High Edit.

To create a table from High Edit:

Step 1 Select the **Table** menu item and the **Create Table** sub-menu item.

Step 2 In the **Columns** and **Rows** fields enter the desired numbers by clicking on the arrows or typing the number in the appropriate field.

Step 3 Click on the **OK** button. AIM I will display the prompt "Do you want to change properties of the table?" A **No** response will provide a standard Grid table with borders for the entire table and each cell. A **Yes** response will open the Table Border and Shading window that allows you to select the following options:
- **Grid** - Lines define all cells and rows.
- **None** - Table has no borders. The borders in the AIM Editor window will display the table rows and columns with dashes but will not print out the dashes.
- **Box** - Preset that only has a border on the perimeter of the table and no border inside for cell division. The AIM Editor window will display the table rows and columns internal to the box with dashes but will not print out the dashes.
- **Shadow** - Preset that appears when the **Sunken** or **Raised** 3D Effect is selected and replaces the **Grid** preset.
- **Color** - Allows you to change the color of the perimeter of the highlighted area.
- **Style** - Allows you to change the line style of the borders. You can select the style for individual grids by selecting the desired style and click in the **Border** display on the appropriate grid lines.
• **3D Effect** - Allows you to give the item highlighted a **Sunken** or **Raised** appearance.

• **Shading Tab** - The Shading tab allows you to customize the **Foreground** and **Background** shading for the item highlighted in the table.

**Step 4**  When selecting more than one of the options, to remain in the Table and Borders Shading window click on the **Apply** button for each option selected. This will allow you to stay in this window and select various options and switch between the tabs.

**Step 5**  When completed with your selections: click on the **OK** button to return to the AIM Editor window.

**12.5.4.3 TG Job Sheet**

Double clicking on a Job Sheet from the TG Sheets window displays the TG Job Sheet window for the Job Sheet selected.

The Job Sheet window contains **Options**, **Contents**, **Edit**, **Exit**, and **Help** menu items and contains fields for the entry or modification of the Sheet Title, Introduction, and Self Test Questions. The original title of the instruction sheet is created in the LP, but can be edited in the TG.

**To enter information in the TG Job Sheet window:**

1. **Step 1**  Position the cursor in the Sheet Title or Introduction field. The Introduction field uses the Styled Text Editor.

2. **Step 2**  Type in the desired information.

3. **Step 3**  Select **Edit**, and then **Save**.

The **Contents** menu item contains the options for **Equipment** for development of the Equipment heading of the Job Sheet, **References** and **IETM** selection from the RRL for the References heading, **Self Test Questions** for development of the Self Test Questions heading of the Job Sheet, **Job Steps** in Word or High Edit for the Job Steps heading, and **Answers** in the Styled Text Editor for the back matter of the LP. Select **Edit** and **Save** to save your work. **Exit** returns you to the previous window selected.

**To identify the equipment required for the performance of the Job Sheet:**

1. **Step 1**  From the Job Sheet window, select the **Contents** menu item and the **Equipment** option and perform the following:
a. The software will open the TG Job Sheet Equipment Selection window. This window defaults to the Equipment RRL type. All equipment related RRL types can be selected. If the item you desire is not contained under the Equipment heading select the Resources menu item and click on the type containing the equipment desired.

b. Highlight the desired equipment and select the Options menu item and the Select option. The View RRL option is an aid to help you select the correct equipment and allow you to view all the information contained in the Site RRL for the item.

c. Select the Exit menu item and save the selection to the database. The software will return you to the TG Job Sheet window.

To identify the references required for the performance of the Job Sheet:

Step 1  Select the Contents menu item and the References or IETM option. The software will open the References or IETM for Job Sheet window.

**NOTE:** The References window is used for Assignment, Information, and Problem Sheets. The After Text field can be used to identify the exact portion of the document (Volume, Part, Chapter, etc.) if desired.

Step 2  Select the Options menu item and the Select RRL for Document or Select IETM for Document option as applicable.

Step 3  Highlight the document required for the performance of the Job Sheet and select the Options menu item and the Select option.

Step 4  If the Select IETM for Document option was selected perform the following:

**NOTE:** AIM will connect the IETM to the database and the IETM Browser window will open. Clicking on the "+" blocks next to the titles in the IETM Browser will expand the menu and clicking on the "-" blocks next to the titles will reduce the menu.

a. Select the Options menu item and the Find option. AIM I will open the Find window. Enter the name of the item desired or scroll through the list and click on the item. Click on the Select and Exit menu items to return to the browser. The item selected will be highlighted.

**NOTE:** If the item selected has an icon between the "-" box and the title, it can be selected for the document. If an icon is not present, this represents a menu title and not an accessible IETM.

b. Select the Options menu item and the Select option. AIM I will return you to the Information Sheet window and the IETM selected will be identified in the References portion of the Job Sheet when printed.

Step 5  If more than one Reference/IETM is required, select the Options menu item and the Add option. Repeat Steps 2 through 4 as applicable.
Step 6  When all documents have been identified, select the Exit menu item and save the selection(s) to the database. The software will return you to the TG Job Sheet window.

To enter Job Steps for the performance of the Job Sheet:

Step 1  From the TG Job Sheet window select the Contents menu item and the Job Steps sub-menu item. AIM I will open the AIM I High Edit window or Word, whichever is selected as default, where you can add the Job Steps required. When complete, select the Edit menu item and the Save sub-menu item to save your data to the database.

Step 2  Select the Exit menu item to return to the TG Job Sheet window.

Step 3  From the TG Job Sheet window select the Exit menu item and return to the TG Sheets window or the Course Tree Structure.

12.5.4.4 TG Problem Sheet

Double clicking on a Problem Sheet from the TG Sheets window displays the TG Problem Sheet window for the Problem Sheet selected.

The Problem Sheets window contains Options, Contents, Edit, Exit, and Help menu items.

The Problem Sheet window Sheet Title and Introduction fields are text entry fields. The original title of the instruction sheet is created in the LP, but it can be edited in the TG.

NOTE: The cursor defaults to the Introduction field of the window. Some elements of instruction sheets are not permitted to be modified until the Introduction field is filled in and saved. The Introduction field uses the Styled Text Editor.

To enter information in the TG Problem Sheet window:

Step 1  Position the cursor in the Introduction field and enter the text that describes the purpose of the Problem Sheet for the trainee.

Step 2  Select the Edit menu item and the Save sub-menu item to save the Introduction to the database.

NOTE: If Equipment is required for the performance of the Problem Sheet perform Steps 3, if References are required perform Steps 4 through 7, if IETMs are required perform Steps 8 through 12.

Step 3  From the Problem Sheet window: select the Contents menu item and the Equipment option and perform the following:
a. The software will open the TG Problem Sheet Equipment Selection window. This window defaults to the Equipment RRL type. All equipment related RRL types can be selected. If the item you desire is not contained under the Equipment heading select the Resources menu item and click on the type containing the equipment desired.

b. Highlight the desired equipment and select the Options menu item and the Select option. The View RRL option is an aid to help you select the correct equipment and allow you to view all the information contained in the Site RRL for the item.

c. Select the Exit menu item and save the selection to the database. The software will return you to the TG Problem Sheet window.

Step 4 From the Problem Sheet window: select the Contents menu item and the References option. The software will open the References for Problem Sheet window.

NOTE: The References window is used for Assignment, Information, Problem, and Job Sheets. With the exception of the Assignment Sheet, “Before Text” is not required. The After Text field can be used to identify the exact portion of the document (Volume, Part, Chapter, etc.) if desired.

Step 5 Select the Options menu item and the Select RRL for Document option.

Step 6 Highlight the document required for the performance of the Problem Sheet and select the Options menu item and the Select option.

Step 7 If more than one RRL document is required, select the Options menu item and the Add option and repeat Steps 6 and 7.

Step 8 From the Problem Sheet window select the Contents menu item and the IETM option.

Step 9 From the IETM for Problem Sheet window select the Options menu item and the Select IETM for Document option.

Step 10 Highlight the desired IETM in the IETMs window, select the Options menu item and the Select option.

NOTE: AIM will connect the IETM to the database and the IETM Browser window will open. Clicking on the “+” blocks next to the titles in the IETM Browser will expand the menu and clicking on the “-” blocks next to the titles will reduce the menu.

a. Select the Options menu item and the Find option. AIM will open the Find window. Enter the name of the item desired or scroll through the list and click on the item. Click on the Select and Exit menu items to return to the browser. The item selected will be highlighted.
NOTE: If the item selected has an icon between the "-" box and the title, it can be selected for the document. If an icon is not present, this represents a menu title and not an accessible IETM.

b. Select the **Options** menu item and the **Select** option. AIM I will return you to the Information Sheet window and the IETM selected will be identified in the References portion of the Problem Sheet when printed.

Step 11 If more than one IETM document is required, select the **Options** menu item and the **Add** option and repeat Steps 9 and 10.

Step 12 When all equipment/references/IETMs have been identified, select the **Exit** menu item and save the selection(s) to the database. The software will return you to the TG Problem Sheet window.

Step 13 From the TG Problem Sheet window select the **Contents** menu item and the **Problem** sub-menu item. AIM I will open the AIM I High Edit window or Word, whichever is selected as default, where you can add the problem text and headings and text for Given, Initial Conditions, and Final Conditions. When complete, select the **Edit** menu item and the **Save** sub-menu item to save your data.

Step 14 Select the **Exit** menu item to return to the TG Problem Sheet window.

Step 15 Select the **Contents** menu item and the **Answers for Problem Text** sub-menu item. AIM I will open the AIM I Editor window, where you can enter the answers for any questions you asked the trainee in the Required Responses portion of the Problem. Make sure the number of the answer corresponds to the number of the question. When you are done, select the **Edit** menu item and the **Save** sub-menu item to save your answers to the buffer.

NOTE: Enter the number of the question when entering the answer. The Answer Sheets will print out as the last page(s) of the LP.

Step 16 Select **Exit** and AIM I will return to the TG Problem Sheet window.

Step 17 From the Problem Sheet window, select the **Exit** menu item, save your entries to the database, and return to the TG Sheets window or the Course Tree Structure.

### 12.5.4.5 TG Information Sheet

Information Sheets provide additional, amplifying, or background information essential for the trainee but not contained, or easily found, in technical manuals or other official documentation. The original title of the instruction sheet is created in the LP, but can be edited in the TG.
To enter text in the TG Information Sheet window:

Step 1  Double click on the Information Sheet from the TG Sheets window. The software will display the TG Information Sheet window for the Information Sheet selected.

NOTE: The cursor defaults to the Introduction field. Some elements of instruction sheets are not permitted to be modified until the Introduction field is filled in and saved. The Introduction field uses the Styled Text Editor.

Step 2  Enter the Introduction text to explain the purpose of the instruction sheet to the trainee. Select the Edit menu item and the Save sub-menu item.

Step 3  Select the Options menu item.

Step 4  Select the Select Reference for Document or Select IETM for Document menu item.

Step 5  Highlight the Document or IETM that provided the information for the Information Sheet and select the Options menu item and the Select option.

Step 6  If you selected an IETM in Step 5, perform the following:

NOTE: AIM will connect the IETM to the database and the IETM Browser window will open. Clicking on the "+" blocks next to the titles in the IETM Browser will expand the menu and clicking on the "-" blocks next to the titles will reduce the menu.

a. Select the Options menu item and the Find option. AIM will open the Find window. Enter the name of the item desired or scroll through the list and click on the item. Click on the Select and Exit menu items to return to the browser. The item selected will be highlighted.

NOTE: If the item selected has an icon between the "-" box and the title, it can be selected for the document. If an icon is not present, this represents a menu title and not an accessible IETM.

b. Select the Options menu item and the Select option. AIM I will return you to the Information Sheet window and the IETM selected will be identified in the References portion of the Information Sheet when printed.

Step 7  If more than one document is required to compile the information for the Information Sheet, select the Options menu item and the Add Reference option and repeat Steps 3 through 6 as applicable.

Step 8  When all documents have been identified, select the Edit menu item and the Save sub-menu item.
Step 9  Select the **Contents** menu item and the **Information** sub-menu item. AIM I will open MS Word or the High Edit window. When you are done, select the **Edit** menu item and the **Save** sub-menu item to save the information to the database.

Step 10 Select the **Exit** menu item to return to the Information Sheet window.

Step 11 From the TG Information Sheet window select the **Exit** menu item and return to the TG Sheets window or the Course Tree Structure.

### 12.5.4.6 TG Outline Sheet

The Outline Sheet lists all the TLOs and provides a brief outline of what the instructor will present during the Topic. The Title can be edited if desired.

**To enter an Introduction in the TG Outline Sheet window:**

- **Step 1** Position the cursor in the Introduction field.
- **Step 2** Type in the desired information using the Styled Text Editor.
- **Step 3** Select **Edit**; then select **Save**.

**To select the TLOs covered in the Topic:**

- **Step 1** Select the **Contents** menu item and the **TLO Links** sub-menu item. AIM I will retrieve a list of the TLOs in the Topic.
- **Step 2** Select the **Options** menu item and the **Select All** option. An X in the select column indicates that a TLO is selected.
- **Step 3** Select the **Exit** menu item and save your changes to the database. AIM I will return you to the TG Outline Sheet window.

**To enter the Topic Outline for the Topic:**

- **Step 1** Select the **Contents** menu item and the **Topic Outline** sub-menu item. AIM I will retrieve either MS Windows or High Edit for text entry of your outline. If there is no sheet text you will be prompted whether to have the DPs for the current Topic inserted into the sheet text. If the answer is "Yes", the main level DPs will be inserted as the default text. You can modify the text as desired.
- **Step 2** Enter the text required outlining the main points that will be covered in the Topic for each TLO. When you are done, select the **Edit** menu item and the **Save** sub-menu item to save the Topic Outline to the database.
- **Step 3** Select the **Exit** menu item to return to the TG Outline Sheet window.
Step 4  Select the Exit menu item when you are done with the Outline Sheet. AIM I will return you to the TG Sheets window or the Course Tree Structure.
CHAPTER 13

THE LEARNING OBJECT MODULE

13.0 Learning Object Module
13.1 Learning Object Module Menu Items
  13.1.1 File Options
  13.1.2 Resource Options
  13.1.3 Sheets Options
  13.1.4 Courses, Modules, Lessons, and Sections Contents Menu Item
  13.1.5 Sections window
    13.1.5.1 Create a New Section
    13.1.5.2 Create a Section From AIM Data
    13.1.5.3 Creating an Elements List from AIM Data
    13.1.5.4 Adding Test Items for a Section
    13.1.5.5 Adding TG Sheets for an Instructor-Led Section
  13.1.6 Lessons Window
  13.1.7 Modules Window
  13.1.8 Courses Window
13.0 LEARNING OBJECT MODULE

AIM addresses two methodologies for assembling Web-based training material. The default method uses Course/Module/Lessons supported by Sections that contain elements. The second method, in support of ILE and the Submarine Learning Center (SLC), of creating Course/Module/Lessons and Sections in which the Sections contain three folders (Learn, Explore, and Practice) which house the elements.

The SLC method can be used by selecting the AIM main menu Options menu item and the Preferences option. Under the Advanced tab of the User Preferences window you can check the block to use the SLC grouping for a Section. The Section window in the Learning Object Module includes three subcategories for a Section (Learn, Explore, and Practice). The required and optional elements for a Concept, Fact, Principle, Procedure, and Process Section are the same as the default method.

The Course contains at least one Module, Lessons and Sections. A Module contains at least one Lesson and Sections. The Course, Module and Lesson are packaged with overview and summary information. The Lessons also contain instructional content (Sections).

The Course and Module structure are provided to allow the creation of Instructor-Led training in accordance with the ILE architecture.

A Lesson is a Terminal Learning Object that supports a single Terminal Objective Statement.

A Section is an Enabling Learning Object (ELO) that supports a single Enabling Objective Statement (EOS). Normally the Sections are created first, then the Lesson would be developed and the supporting Sections would be selected for the Lesson in the order that they will be presented. When a Module is created, the Lesson(s) that support the Module are selected and Module(s) selected for a Course. AIM presents you with four windows, Courses, Modules, Lessons and Sections, which can be selected from the Contents menu item of the Learning Object Module or from the AIM main menu Document menu item and the Learning Object Module sub-menu item. From the Courses, Modules and Lessons windows you can develop the Overview and Summary elements, and select the Modules that support the Course, the Lessons that the support the Modules, and the Sections that will support the Lesson. From the Sections window you can develop any of the five types of Sections: Concept, Fact, Principle, Procedure, and Process.

Sections, Lessons, Modules and a Course can be developed from scratch in the Learning Object Module. A Curriculum Outline of Instruction for a course, developed in the Content Planning Module (CPM) and exported to the Enterprise Data Environment (EDE), can be imported into the Learning Object module from the EDE. A Section can be created from a Topic Learning Objective in the COI or DPs linked to the Topic Learning Objective using the Options menu item and the Create Section from AIM Data option.

Only courses, modules, lessons, and section that were imported from CPM can be versioned in AIM LO Module, after the content has been approved in CPM. The status of a course, module,
lesson, section is maintained in both CPM and AIM LO Module simultaneously.

13.1 Learning Object Module Menu Items

The Courses, Modules, Lessons and Sections windows have the following menu items:

- **File**: Allows you to Import or generate Output files.
- **Options**: Contains options applicable to Courses, Modules, Lessons, or Sections.
- **Resources**: Allows you to manage Resources.
- **Contents**: Allows you to select the windows for development of a Course, Module, Lesson, or Section and launch the Content Planning Module (CPM).
- **Edit**: Allows you to save your editing to the database or cancel the editing accomplished since the last time you saved.
- **Exit**: Allows you to exit to the AIM main menu.
- **Help**: Allows you to retrieve the Learning Object Module HTML On-Line Help.

13.1.1 File Options

The following options are available under the File drop-down menu.

- **Import Learning Object**: Allows you to Import a SCORM Output file, created in AIM I or AIM II, into the database.
- **Import from EDE**: Imports a Course from Enterprise Data Environment (EDE) that was originally designed and exported from CPM.
- **Update from EDE**: Updates the Section with the latest EDE information.
- **CBT**
  - **Update Display Pages**: Update the Display Pages associated with recently updated CBT content.
  - **Store Runtime Packages**: Stores the Runtime Package associated with CBT content.
  - **Store Source File Package**: Stores the Source Files associated with CBT content.
  - **Retrieve Runtime Package**: Retrieves previously stored Runtime Packages.
  - **Retrieve Source File Package**: Retrieves previously stored Source File Packages.
  - **Delete Runtime Package**: Deletes a previously stored Runtime Package.
  - **Delete Source File Package**: Deletes a previously stored Source File Package.
- **Generate Output Package**
  - **SCORM**: This output uses the Metadata Specification and SCORM version selected from the AIM main menu **Options>Preferences** in the Advanced tab. It Allows you to create an AIM export file that can be:
    - Imported into another AIM I or AIM II database
    - Unzipped and used as a standalone preview of the Course/Module/Lesson/Section.
• Imported into self paced authoring tools for the development of interactive ILT or Self-Paced Sections.
• Imported into Enterprise Data Environment (EDE).
• Tested with the ADL test suite to verify it is a valid SCORM package
  o **Elite**: Allows you to create a Section or Lesson output that can be imported into the electronic classrooms that employs Elite software. This output uses SCORM Version 1.2, regardless of the version selected under AIM main menu **Options>Preferences** in the Advanced tab.
• **Export RRL to EDE**: Allows the user to Export RRL data to the EDE, this RRL data can then be Imported into the Content Planning Module (CPM).
• **Preview**
  o **Course Level Preview**:
    At the course level the preview options are:
    • LP (or LP Change Package if available)
    • TG (or TG Change Package if available)
    • TPP from EDE
    • TCCD from EDE
  o **Module Level Preview**:
    At the Module level the preview options are:
    • LP
    • TG
  o **Lesson and Section Level Preview**:
    • **Web**: For Self-Paced Sections
    • **Developer**
    • **Student**
    • **Storyboard**
    • **LP**: This option will output a Course in the classic AIM/LP format when a Course is highlighted.
    • **Sheets**: For Instructor-Led Sections that contain Instruction Sheets.

**NOTE:**
At the Course level, when LP is selected from the Preview menu
the following dialog box appears:
The **Section Printing Options** includes check boxes for not including Self-Paced Sections as these are not Instructor-led Sections, Excluding Section Front Matter as it may be redundant to the Lesson Front Matter, and Excluding Information Sheet References.

**NOTE:**
If Exclude Section Front Matter is selected no Section Front Matter will be displayed, including Information Sheet References.
The top section allows the user to select page control printing and Header/Footer editing.

The **Course Matter Items** allows the user to select additional; course materials to be Printed/Previewed, is includes Front Matter, Content, and Reference Materials.

There is a check box to exclude Self-Paced sections, if unchecked Self-Paced sections will be included in the Print/Preview.

The **Main DP Printing Options** allows the Discussion Points to either be Printed/Previewed one per page or Continuously.

**DP Spacing** allows the user to specify the number of blank lines between discussion points. There is also a checkbox that, when checked, will override any specified spacing that may have been used during development.

**NOTE:**

At the Module, Lesson, and Section levels, when LP is selected from the Preview menu the following dialog box appears:

![Printer Setup Dialog Box]

The top section allows the user to select page control printing and Header/Footer editing.

There is a check box to exclude Self-Paced sections, if unchecked Self-Paced sections will be included in the Print/Preview.

The **Main DP Printing Options** allows the Discussion Points to either be Printed/Previewed one per page or Continuously.

**DP Spacing** allows the user to specify the number of blank lines between discussion points. There is also a checkbox that, when checked, will override any specified spacing that may have been used during development.
Generate Test Questions Package: Allows you to create a Questionmark QML file/package from the test items developed for the Section that can be imported into the Questionmark software. Practice and Assessment Items may be printed for review by selecting either "Practice Item to PDF" or "Assessment Item to PDF" from the Generate Test Items submenu. When selecting either practice items or assessment items the user will then have various printing options depicted in the figure below.

Regardless of which print option is selected the output will have a header of "For Review Only - Not a Test", as actual tests should be generated using a QML package.

- **Submit Content**: Sets the status of the selected course, module, lesson, or section to Submitted. Submitting a course, If the course was imported from CPM via the EDE the status will also be set to Submitted in CPM; any changes to the COI in CPM will reset the status to New in CPM and Complete in AIM LO Module.

- **Accept Content**: Sets the status of submitted content to Accepted. If the course was imported from CPM via the EDE, the status will also be set to Accepted in CPM. Note: Accepted content can only be approved or rejected in CPM. Approved content cannot be changed in AIM LO Module and a new version must be created in CPM, the course exported from CPM and updated from EDE in AIM LO Module. When content is rejected in CPM, a message is displayed stating that. The reason for a rejection can be viewed in CPM under the History for the content.

- **Reject Content**: Sets the status of submitted content back to Complete. If the course was imported from CPM via the EDE, the status will reset to New in CPM.

**13.1.2 Resource Options**

The following options are available from the Resources drop-down menu, these options will vary
depending on which level is highlighted (Course, Module, Lesson, Section, or Element):

- **Add Resource**: Allows you to add a resource from the Site RRL Utility to the Resources Tab of the Element you have open.
- **Add Graphic**: Allows you to add a graphic from the Graphics Utility to the Resources Tab of the Element you have open.
- **Add Sheet**: Allows the user to add Instructional Sheets as a Resource.
- **Add Fault**: This option brings up the Function Faulted box where users can Create Faults to an Element.
- **Add Exercise Controller Guide (ECG)** When Section title is highlighted allows the user to create an Exercise. When an Element is highlighted allows the user to select a previously created Exercise. The Exercises created for a course will collectively create an Exercise Controller Guide which will have Front Matter similar to a Lesson Plan and Trainee Guide.
- **Add Free Text**: Allows the user to add free text to be used in a RIA.
- **Delete Resource**: Allows you to delete a resource from the Resources Tab of the Element you have open.
- **Copy Resource**: Allows the user to copy a resource that is already used by an Element.
- **Paste Resource**: Used to Paste a previously Copied Resource in an Element.
- **Replace Resource**: Used to replace one Resource with a different Resource.
- **No-Change Change**: Used to update to a later version of an IETM, the later version must first be imported into the AIM database.
- **Select Later IETM**: Used to select a later version of an existing IETM.
- **View IETM Structure**: Allows you to open the browser with the structure of the IETM.
- **Launch/View IETM**: Allows you to view the IETM identified in the Resources.
- **View RRL**: Allows you to see what information is entered about a resource when highlighting a resource or graphic cited by a Section’s Element.
- **Display Media**: Allows you to display an IMM full screen.
- **Modify/View Fault**: Used to edit existing Faults.

### 13.1.3 Sheets Options

Instructional Sheets are added at the Section level and are only available for Instructor-Led Sections. Outline sheets may be added at the Course, Module and Lesson level, all other Sheets can only be added at the Section level. Lesson sheets may only be assigned to the Lesson’s RIAs under Overview/Summary. Section sheets may only be cited within the RIAs or Assessment/Practice items of the section.

The options from the Sheet drop-down menu are:

- **Add Sheet**: Allows you to add Instruction Sheets to a Section when the Section Title is highlighted.
  - **Assignment**
  - **Diagram**
  - **Information**
• Job
• Outline
• Problem
• **Modify/View Sheet**: Allows you to modify and view the highlighted TG Sheet in the Sheets tab of the Section.
• **Delete Sheet**: Allows you to delete the highlighted TG Sheet in the Sheets tab of the Section.
• **Copy Sheet**: Copies the highlighted sheet for pasting into a different Section.
• **Paste Sheet**: Pastes a previously Copied Sheet into the desired Section.

### 13.1.4 Courses, Modules, Lessons and Sections Contents Menu Item

When the Learning Object Module is selected from the **Document** menu item, choose the type of material you are developing: Course, Module, Lesson, or Section. Clicking on the Learning Object Module icon will open the Courses window by default. The **Contents** menu item provides selection of Courses, Modules, Lessons, Sections or Launch CPM (Content Panning Module).

### 13.1.5 Sections Window

A Section is a self-contained chunk of information built to accomplish a single enabling objective statement. Sections are the instructional content selected for the Lesson. They are combined to form the **Lesson**. A Section is referred to as a “topic” within the Lesson. The Section content (elements) varies depending on the type of Section selected.

There are five types of Sections:

- **Concept** – A class of items that shares common key features and is known by a common name.
- **Fact** – Unique, one-of-a-kind types of information.
- **Procedure** – A sequential set of steps to be followed by one individual to accomplish a task or make decisions. Actions within the procedure must be done the same way each time within a given situation.
- **Process** – A series of actions, changes, or functions that achieve an end result. It often is used when you need to illustrate a flow of events that describes how something works.
- **Principle** – A procedural job task that requires judgment or when guidelines must be applied to a situation.

Each type of Section has different elements. The Table 12-1 illustrates the Section types and the elements that are required and optional. Each element is presented on one screen for E-Learning content.

<table>
<thead>
<tr>
<th>ELEMENTS</th>
<th>SECTION TYPE</th>
</tr>
</thead>
</table>

13-8 Release 5.6
<table>
<thead>
<tr>
<th>Section Review</th>
<th>Concept</th>
<th>Fact</th>
<th>Principle</th>
<th>Procedure</th>
<th>Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>R</td>
<td>R</td>
<td>R</td>
<td>R</td>
<td>R</td>
</tr>
<tr>
<td>Definition</td>
<td>R</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fact-Image, List, or Table</td>
<td>O</td>
<td>R</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>Example</td>
<td>R</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Non-Example</td>
<td>O</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Analogy</td>
<td>O</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Principle Statement</td>
<td>O</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Guidelines</td>
<td>R</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Decision, Procedure or Combined Table</td>
<td>R</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Demonstration</td>
<td>O</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Practice Questions</td>
<td>R</td>
<td>R</td>
<td>R</td>
<td>R</td>
<td>R</td>
</tr>
<tr>
<td>Process</td>
<td>R</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Section Review</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>Assessment</td>
<td>R</td>
<td>R</td>
<td>R</td>
<td>R</td>
<td>R</td>
</tr>
<tr>
<td>Interaction</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>Glossary</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>Safety Information</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>Security Information</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
</tbody>
</table>

NOTE: R=Element is required and O=Element is optional.

Table 13-1. Required and Optional Elements for a Section

When developing each type of Section the Elements that are required will be identified in **bold**. The optional elements can be deleted if not desired by highlighting the element on the Sections window, selecting the **Options** menu item and the **Delete** option.

Additional Elements can be added to a Section by selecting the **Options** menu item, the **Add Element** option. The Elements presented and available for selection are dependent on the type of Section being developed.
The Sections window options are as follows:

- **Create Section**: Allows you to add a Section, of one of the types selected below, to the Section list. If there is doubt about the type a Decision Wizard is provided. Answering the questions in Decision Wizard will produce a suggested type by percentage.
  - Concept
  - Fact
  - Principle
  - Procedure
  - Process
  - Decision Wizard
- **Copy Elements**: With a Section highlighted all elements of the Section are copied.
- **Paste Elements**: Allows the user to paste previously copied elements into a Section. After selecting Paste Elements the user will see a pop-up box like the one below. Users can select the type of elements that will be pasted into the current Section.

![Paste Options](image)

- **Copy/Paste Element**: To copy and paste single elements, highlight the element, select Copy Element from the Option drop down menu, move the cursor to the location to paste the element, select Paste Element from the Option menu drop down.
- **Create Section from AIM Data**: Allows you to select the desired course, the COI and TLO, or DP in AIM I to initiate the development of a Section.
- **Create an Elements List from AIM Data**: Allows you to select DP/RIAs from an existing AIM course.
- **Create Student Sheet From AIM Data**: Allows you to create an entire Instruction Sheet from an Instruction Sheet that exists in a course in the AIM database when the Section Title is highlighted.
- **Add Element**: Allows you to add additional elements that are dependent on the type of Section being developed. Elements are automatically numbered when they are created.
• **Add Note/Caution/Warning Element:** These can be placed after any existing Section Element or sub-element.
  o Note
  o Caution
  o Warning
• **Re-sequence Elements:** Allows you to re-sequence the elements of the Section to put them in the order desired for presentation to the student.
• **Storyboard:** Allows the developer to detail concepts and add materials for the Storyboarding of Self-Paced Sections. The following tabs accept input in Rich Text Format (RTF) with the exception of the Comments tab that is used to add Notes and ISD Comments. ISD Comments are added in CPM and imported from the EDE into the LO Module. ISD Comments are not editable in the LO Module
  o Display
  o Narration
  o Animation
  o Storyboard Notes
  o Table Text
  o Interaction
  o Comments
• **Copy:** Allows you to duplicate a Section in the respective window.
• **Create New Version:** Allows you to create a new version of an approved Section.
• **Delete:** Allows you to delete a Section in the respective window.
• **Add Test Item:** Allows you to add a test item for Practice or Assessment Elements.
  o Fill-in the-blank
  o Multiple Choice
  o True/False
  o Two-Column Matching
  o Performance
• **Modify/View Test Item:** Allows you to modify or view a test item for a Practice or Assessment Element.
• **Delete Test Item:** Allows you to delete a test item for a Practice or Assessment Element.
• **Trainee Preparation Materials:** This option is used to identify any preparation materials the student may need to review before the Section.
• **ISD Considerations:** Considerations are entered into the Content Planning Module (CPM) and are brought over to the LO Module on import of a course. They are only editable in the CPM. This item will be hidden from the menu for non-imported content.
• **Security Markings**
  From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:
  1. Right click and Go To the appropriate location on the course tree (left pane).
  2. From the menu bar click Options.
  3. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.
The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that can have security markings and the current marking assigned. The lower portion of the screen is broken into the following three sections:

- **Classification**: The available classifications that can be assigned, the options are:
  
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier**: This is an additional security modifier to the classification, the options are:
  
  - (None)
  - COMINT
  - Talent Keyhole
  - COMINT/Talent Keyhole
• **Release Ability:** This is an additional restriction on who the document may be released to, the options are:
  
  o (None)
  
  o NOFORN
  
  o For Official Use Only
  
  o REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

• **Find Section:** Allows you to enter text to find a Section.

• **Check Spelling:** Allows you to check the spelling of a Section or an Element.

• **Show:** Allows you to select a specific type of Sections and list them. Default is **All**.
  
  o **All**
  
  o **Concept**
  
  o **Fact**
  
  o **Principle**
  
  o **Procedure**
  
  o **Process**

• **Grant Privileges:** Allows you to grant the privileges you have to another AIM User.

• **Show In Use Information:** If the In Use flag is set this option will display information regard which use caused the flag to be set.

• **Reset In-Use:** This option is used to rest the In Use flag, allowing the user to edit the data.

• **Explain Flag**

• **Remove Flag**

**Select the SCORM Metadata specification and the version of SCORM that will be used to develop the material in the Learning Object Module.**

**Step 1** From the AIM main menu, select the **Options** menu item and the **Preferences** option.

**Step 2** Click on the **Advanced** tab.

**Step 3** In the Metadata Specification field, click on the down-arrow, and select one of the following:
  
  • NSCORM
  
  • SCORM

**Step 4** In the SCORM version field, click on the down-arrow, and select one of the following:
13.1.5.1 Create a New Section

To create a new Section in the Learning Object Module:

Step 1 From the AIM main menu, select the Document menu item, the Learning Object Module sub-menu item and Section or click on the Learning Object Module icon and when the Courses window opens select the Contents menu item and the Sections sub-menu item.

Step 2 From the Sections window, select the Options menu item and the Create Section option for a Section that will be developed from data not present in the AIM database.

Step 3 Select one of the types of Section (Concept, Fact, Principle, Procedure, or Process).

NOTE
Select the Decision Wizard option if the type has not been determined. The Wizard will provide the type based on the answers you provide to the questions.

Step 4 AIM will add the New (Type) Section to the tree structure in the left-hand pane. Expand the structure of the Section by clicking on the + block. This will reveal the required elements (in Bold) and optional elements of the Section.

Step 5 With the New (Type) Section highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Section titled General, Job, Skills Data, Info, Sheets for an Instructor-Led Section, Resources, and Metadata. Add/identify the following information for each tab and select the Edit menu item and the Save sub-menu item when completed with each tab.

- **General** – Enter the Title, Identification Number and Objective in the fields provided. The Identification Number will be assigned for generating an output file for SCORM, NLCOM or AICC and if unknown can remain blank until assigned. Click on the down arrows for Section Type, Status, and Classification and select the appropriate information. Identify the Instruction Type by selecting Self-Paced or Instructor-Led. If the Section content is not releasable to foreign nationals, check the NOFORN block. Enter the Class/Lab/PA Time in minutes for an Instructor-Led Section or IMM Time in minutes for a Self-Paced Section.
- **Job** – Enter the Duty and Job Task that the Section supports in the fields.
provided. Click on the down arrows for Category (Knowledge or Skill) and select the appropriate entry. If the Section is created using the Create Section from AIM Data option the CIN, Learning Objective, and DP Number fields will have content from the material copied.

- **Skills List** – Skills data identifies Task/Knowledge/Skill/Tools/Resources by and ID, Type and Text. If the Skills data is available in the EDE the Skill List data will automatically be entered when importing from EDE.

- **Info** – The Information tab can contain information about who the author and owner is, the date the Section was created, published, and an expiration date. Keywords can be added to facilitate searching the database for the Section. Click on the down arrows for Cognitive level (Remember or Apply) and select the appropriate entry.

- **Sheets** – Instruction Sheets can be added to support a Section. The TG Sheets are identified by Sequence, Type and Title in this tab. A TG Sheet is added by highlighting the Section title, selecting the **Sheets** menu item and the **Add Sheet** option.

- **Resources** – Resources that support the entire Section will be identified in this tab. Resources cannot be added directly into this tab. Resources can be added to Element folders from the Site RRL by selecting the **Resources** menu item and the **Add Resource** option when developing the Element folders of the Section.

- **Metadata** – Each of the folders in the metadata structure contain fields to enter appropriate information for SCORM specification and version selected. Bolded folders indicate that data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected.

### Step 6
Develop each Element of the Section. Each Element contains an **Element** tab, a **RIA** tab is present if Section is identified as Instructor-Led, and **Metadata** tabs. The Element tab contains the Styled Text Editor that you can use to create information and to paste information saved as RTF. The **Search AIM Data** option can be used to access data for the Elements and RIA tab. The RIA tab works in conjunction with the **Resources** menu item and the **Add Resource, Add Graphic, Add Sheet, Add Fault, Add Free Text** and **Delete Resource** options. The Metadata tab contains folders and fields to enter key words for the Element. Add/identify the information for each element and select the **Edit** menu item and the **Save** sub-menu item when completed with each element. Refer to Table 1 above to determine the required and optional elements for the type of Section being developed.

### 13.1.5.2 Create a Section from AIM Data

The Create Section from AIM Data option allows you to select the desired course, COI or DP, Part, Section, and Topic desired to build any of the types of Sections. If the type of Section is not readily identifiable, the Decision Wizard option can be used to determine the type of Section.
If test questions have already been developed (for the PPP line item the TLO and DP are linked to) in the database they can be selected for the Practice or Assessment Elements in the Section by using the Search AIM Data option in the Learning Object Module after the TLO or DP has been selected and the Section created.

Step 1  From the AIM main menu, select the Document menu item, the Learning Object Module sub-menu item and Section or click on the Learning Object Module icon and when the Courses window opens select the Contents menu item and the Sections sub-menu item.

Step 2  From the Sections window select the Options menu item and the Create Section from AIM Data option.

Step 3  From the Select Course window click on the desired course containing the Topic Learning Objective (TLO) or Discussion Point (DP) that the Section will be converted from and then click on the Select menu item.

Step 4  From the Create Section from CIN window you can select either the DP or COI. You can create a Section from a TLO in the COI, if the COI is selected, or from a DP in the LP if DP is selected. For the purpose of this explanation click on the down arrow and select DP.

Step 5  From the Course Structure in the left-hand pane open the desired Part and Section, to reveal the topics in the Section.
Step 6  Click on the desired Topic to reveal the DPs for the Topic in the right-hand pane.

Step 7  Click on the desired DP and click on the Create menu item. A sub-menu will appear and you can select the type of Section to be created from the DP. If it is unclear which type the DP should become, the Decision Wizard should be selected. When you have answered all questions in the Decision Wizard AIM will bold the type of Section based on your answers and provide a percentage for each type. Click on the appropriate type.

Step 8  AIM will return you to the Sections window where you can develop your Section after selecting the appropriate type of Section.

Step 9  The Section converted from the DP is added to the tree structure in the left-hand pane. Expand the structure of the Section by clicking on the + block. This will reveal the required (in **Bold**) and optional Elements of the Section. If using the SLC method, the Learn, Explore, and Practice folders will contain the Elements that are required and optional.

Step 10  With the Section highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Section titled General, Job, Skills Data, Info, Sheets for Instructor-Led Section, Resources, and Metadata. Add/identify the following information for each tab and select the Edit menu item and the Save sub-menu item when completed with each tab.

- **General** – Enter the Title, Identification Number and Objective in the fields provided. The Identification Number will be assigned for generating an output file for SCORM, NLCOM or AICC and if unknown can remain blank until assigned. Click on the down arrows for Section Type, Status, and Classification and select the appropriate information. Identify the Instruction Type by selecting Self-Paced or Instructor-Led. If the Section content is not releasable to foreign nationals, check the NOFORN block. Enter the Class/Lab/PA Time in minutes for an Instructor-Led Section or IMM Time in minutes for a Self-Paced Section.

- **Job** – Enter the Duty and Job Task that the Section supports in the fields provided. Click on the down arrows for Category (Knowledge or Skill), and select the appropriate entry. If the Section is created using the Create Section from AIM Data option, the CIN, Learning Objective, and DP Number fields will have content from the material copied.

- **Skills List** – Skills data identifies Task/Knowledge/Skill/Tools/Resources by ID, Type and Text. If the Skills data is available in the EDE the Skill List data will automatically be entered when importing from EDE.

- **Info** – The Information tab can contain information about who the author and owner is, the date the Section was created, published, and an expiration date. Keywords can be added to facilitate searching the database for the Section. Click on the down arrows for Cognitive level (Remember or Apply) and select the appropriate entry.
• **Sheets** – Instruction Sheets can be added to support a Section. The TG Sheets are identified by Sequence, Type and Title in this tab. A TG Sheets is added by highlighting the Section title, selecting the **Sheets** menu item and the **Add Sheet** option.

• **Resources** – Resources that have been selected for the Elements of the Section will appear in the Resources tab. Resources cannot be added directly to this tab.

• **Metadata** – Each of the folders in the metadata structure contain fields to enter appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected.

**Step 12** Develop each Element of the Section. Each Element contains Element, Instructor Activity for Instructor-Led Sections, Resource, and Metadata tabs.

• The Element tab contains the Styled Text Editor that you can use to create information and to paste information saved as RTF. The **Search AIM Data** options can be used to access DP and RIA information linked to the objective used to create the Section or from other courses and topics. DP and RIA information can be copied into the Element tab and resources selected in the RIA will be added to the Resources tab.

• The Instructor Activity tab will be present for Instructor-Led Sections. Enter the instructions for the instructor detailing how to teach the element.

• The Storyboard option will be present for Self-Paced Sections. Enter storyboard development concepts to be used in any self-paced content authoring tool that is XML aware and has the ability to translate AIM XML outputs.

• The Resource tab works in conjunction with the **Resources** menu item and the **Add Resource**, **Add Graphic**, and **Delete Resource** options. These options allow you to add items from the Site RRL and Graphics Utility.

• The Metadata tab contains folders in the metadata structure with fields to enter key words for the Section and appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected. Add/identify the bolded information for each item and select the **Edit** menu item and the **Save** sub-menu item when completed with each Element.

Refer to Table B-1 above to determine the required and optional elements for the type of Section being developed.
12.1.5.3 Creating an Element List from AIM Data

The Creating Element List from AIM Data option is used to copy DP/RIA information from an existing AIM course. To copy DP/RIAs follow the steps below:

Step 1 From the Learning Object Module main menu select the Section icon, fourth icon from the left.

Step 2 Select Option, Create Section, Fact.

Step 3 In the Instruction Type select Instructor-Led from the drop-down menu.

Step 4 Highlight the Section titled New Fact Section.

Step 5 Click the '+' sign next the New Fact Section to expand the section and show the elements contained in the section.

Step 6 Select Options, Create Element List from AIM Data.

Step 7 From the Select Course box, select the desired course to copy DP/RIA information from.

Step 8 Click the '+' sign next to the desired Unit to expand the unit and show the Topics list.

Step 9 Highlight the desired topic.

Step 10 Click in the Sel column of the desired DP.

Step 11 Select Options.

Step 12 Select either Select, to select the main DP only, or Select With Children to select main DP and Sub-DPs.

Step 13 In the Element Type column of the main DP select the desired type (Fact-Image, Fact-List, Fact-Table, Section Review, Practice, or Interaction). Element types for Sub-DPs cannot be selected.

Step 14 Select Edit, Save. The main DP will now be listed as the Element Type selected (DP text will be in the text box of the Element tab), Sub-DPs can be viewed by clicking the '+' sign next to the new element.
13.1.5.4 Adding Test Items for a Section

If test questions have already been developed for the PPP table line item linked to the TLO/DP in the database they can be selected for the Assessment item in the Section by using the Search AIM Data option in the Lesson/Section Utility after the TLO/DP has been selected and the Section created. The Test Items for the Section can then be edited as necessary.

To add new Test Items for a Section:

Step 1 From the AIM main menu, select the Document menu item, the Learning Object Module sub-menu item and Section or click on the Learning Object Module icon and when the Courses window opens select the Contents menu item and the Sections sub-menu item.

Step 2 Click on the Resource tab. Select the Resources menu item and the Select Resource option.

Step 3 Click on the Resource that contains the test question information, and select the Select menu item. Resource options are IETM, IMM, Sheet, or Publication. Sheets are available from the current Section only.

Step 4 Enter the required resource information as determined by the resource selected.

Step 5 In the left-hand pane, click on the desired Section, and open it (click on the “+” block) to reveal the content items. Click on the Practice or Assessment element. If using the SLC method, the Practice folder will contain the Practice and Assessment elements of the Section.

To develop Fill-in-the-blank questions:

Step 1 From the Sections window select the Options menu item and the Add Test Item option. Select Fill-in-the-blank from the sub-menu.

Step 2 Click on the Resource tab. Select the Resources menu item and the Select Resource option.

Step 3 Click on the Resource that contains the test question information, and select the Select menu item. Resource options are IETM, IMM, Sheet, or Publication. Sheets are available from the current Section only.

Step 4 Enter the required resource information as determined by the resource selected.

Step 5 Click on the TOS down arrow, and select the appropriate TOS for the question.
Step 6 Click on the K Level field down arrow, and from the drop-down menu select the appropriate level of learning for the question.

Step 7 Click on the Q&A tab. Click on the Stem field, and enter the text of the question. Use the underline feature to enter the blank line.

Step 8 Click on the Answer field, and enter the text of the answer.

Step 9 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 10 If there is an associated graphic to be used in conjunction with the test item, perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic, and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 11 Select the Edit menu item and the Save sub-menu item to save the Fill-in-the-blank question to the database.

Step 12 A down-arrow will appear in the Status field when the required information has been added to the fields and tabs, and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 13 Select the Exit menu item to return to the Sections window.

To develop Multiple Choice questions:

Step 1 From the Sections window, select the Options menu item and the Add Test Item option. Select Multiple Choice from the sub-menu.

Step 2 Click on the Resource tab. Select the Resources menu item and the Select Resource option.
Step 3 Click on the Resource that contains the test question information, and select the **Select** menu item. Resource options are IETM, IMM, Sheet or Publication. Sheets are available from the current Section only.

Step 4 Enter the required resource information as determined by the resource selected.

Step 5 Click on the TOS down arrow, and select the appropriate TOS for the question.

Step 6 Click on the K Level field down arrow, and from the pop-up menu select the appropriate level of learning for the question.
- K1 - Recognize (recommended selection for T/F Test Items)
- K2 - Recall
- K3 - Comprehend
- K4 - Analyze
- K5 - Evaluate

Step 7 Click on the Q&A tab. In the Stem field, add the text of the question.

Step 8 In the Answer/Distractor fields, enter the text of the distractors and answer. At least four entries must be made to save the question to the database.

Step 9 Click on the Answer text, select the **Options** menu item and the **Set Answer** option, or double-click on the column adjacent to the answer. An “X” will appear in the Correct Answer column adjacent to the answer.

Step 10 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 11 If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the **Options** menu item and the **Select Graphic** option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the **Options** menu item and the **Select** option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.
   c. Select the **Edit** menu item and the **Save** sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 12 Select the **Edit** menu item and the **Save** sub-menu item to save the multiple-
choice question to the database.

Step 13 A down arrow will appear in the Status field when the required information has been added to the fields and tabs, and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 14 Select the Exit menu item to return to the Sections window.

To develop True/False questions:

Step 1 From the Sections window select the Options menu item and the Add Test Item option. Select True/False from the sub-menu.

Step 2 Click on the Resource tab. Select the Resources menu item and the Select Resource option.

Step 3 Click on the Resource that contains the test question information, and select the Select menu item. Resource options are IETM, IMM, Sheet or Publication. Sheets are available from the current Section only.

Step 4 Enter the required resource information as determined by the resource selected.

Step 5 Click on the TOS down arrow and select the appropriate TOS for the question.

Step 6 Click on the K Level field down arrow, and from the pop-up menu, select the appropriate level of learning for the question.
- K1 - Recognize (recommended selection for T/F Test Items)
- K2 – Recall
- K3 - Comprehend
- K4 – Analyze
- K5 - Evaluate

Step 7 Click on the Stem field and enter the text of the question.

Step 8 Identify the correct answer by clicking on the box next to either TRUE or FALSE. An "X" will appear in the box to indicate the correct answer.
Step 9  The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item, and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 10  If there is an associated graphic to be used in conjunction with the test item, perform the following:
a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
b. Click on the desired graphic, select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.
c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 11  Select the Edit menu item and the Save sub-menu item to save the True/False question to the database.

Step 12  A down arrow will appear in the Status field when the required information has been added to the fields and tabs, and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 13  Select the Exit menu item to return to the Sections window.

To develop Two-Column Matching test questions:

Two column matching test items are actually four to eight individual test items in one question. To develop a two-column matching test item you will enter data in two parallel columns that correspond to each other. The left column (stimulus) will contain four to eight entries. The right column (responses) will contain six to ten entries. The right column MUST have two more entries than the left column. These two additional entries are provided to prevent the trainees from being able to guess at the last few matching items after having ruled out the ones that they know. The entries in the columns can be re-sequenced using the click-and-drag method.

Step 1  From the Sections window select the Options menu item and the Add Test Item option. Select Two-Column Matching from the sub-menu.
Step 2  Click on the Resource tab. Select the **Resources** menu item and the **Select Resource** option.

Step 3  Click on the Resource that contains the test question information, and select the **Select** menu item. Resource options are IETM, IMM, Sheet, or Publication. Sheets are available from the current Section only.

Step 4  Enter the required resource information as determined by the resource selected.

Step 5  Click on the TOS down arrow, and select the appropriate TOS for the question.

Step 6  Click on the K Level field down arrow, and from the pop-up menu, select the appropriate level of learning for the question.

Step 7  Click on the Q&A tab. Click on the Stem field and enter the text of the directions for the Column Matching Test Item.

Step 8  Select the **Options** menu item, and the **Add Left Entry** option, or click in the desired location to add an entry.

Step 9  Enter the text for the first item of the left column.

Step 10 Repeat Steps 8 and 9 for each item to be added to the left column. AIM I will permit up to eight entries. After four entries in either column, you will need to manually add entries using the Options drop-down menu.

Step 11 Select the **Options** menu item and the **Add Right Entry** option, or click in the desired location to add an entry.

Step 12 Enter the text for the first item in the right-hand column.

Step 13 Repeat Steps 11 and 12 for each item to be added to the right-hand column. AIM I will permit up to 10 entries for the right-hand column. The right-hand column must have two more entries than the left-hand column.

Step 14 Click on the Answer column for the first item in the left-hand column and select the letter of the matching item in the right column. You can use an answer once, more than once, or not at all.

Step 15 Repeat Step 14 for each item in the left column.
Step 16 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item, and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 17 If there is an associated graphic to be used in conjunction with the test item, perform the following:
   a. Click on the Graphic tab. Select the **Options** menu item and the **Select Graphic** option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic, and select the **Options** menu item and the **Select** option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.
   c. Select the **Edit** menu item and the **Save** sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description field from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 18 Select the **Edit** menu item and the **Save** sub-menu item to save the Two Column Matching question to the database.

Step 19 A down-arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 20 Select the **Exit** menu item to return to the Sections window.

To develop Performance questions:

Step 1 From the Sections window select the **Options** menu item and the **Add Test Item** option. Select **Performance** from the sub-menu.

Step 2 Click on the K Level field down arrow, and from the drop-down menu select the appropriate level of learning for the question.

Step 3 Click on the Performance tab and enter the title of the Performance scenario in the Title field.

Step 4 Click in the text field below the Title and add the text for the Performance scenario.
AIM I will open the Select Site RRL window that contains the Publications that are contained in the Site RRL.

Step 5 Click on the Resources tab. Click on the Options menu item and the Select Resource option.

AIM I will open the Select Site RRL window that contains the Publications that are contained in the Site RRL.

Step 6 Click on the publication that supports the Performance scenario and select the Select menu item. AIM I will enter the publication identifier in the Resources tab of the Performance Test Item for Line Item window. You may also double-click on the desired publication to select it.

Step 7 Enter the publication breakdown information (e.g., Volume, Part, Chapter) in the publication breakdown fields.

Step 8 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 9 If there is an associated graphic to be used in conjunction with the test item, perform the following:

a. Select the Options menu item and the Add Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.

b. Click on the desired graphic, and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.

c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 10 Select the Edit menu item and the Save sub-menu item to save the Performance question to the database.

Step 11 A down-arrow will appear in the Status field when the required information has been added to the fields and tabs, and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.
Step 12 Select the Exit menu item to return to the Sections window.

13.1.5.5 Adding TG Sheets for a Section

When developing a Section you can create Instruction Sheets (TG Sheets) for the students. There are six types of Instruction Sheets:

- Assignment
- Diagram
- Information
- Job
- Outline
- Problem

To develop an Assignment Sheet:

Step 1 From the Sections window click on the Instructor-Led Section Title.

Step 2 Select the Sheets menu item and the Add Sheet option.

Step 3 Select Assignment.

Step 4 Add the Assignment Sheet Title and Introduction in the designated fields. The Section Title will be the default title of the Assignment Sheet and it can be edited.

Step 5 Select the Contents menu item and the Study Assignments sub-menu item.

Step 6 From the Sheet References window select the Options menu item and the Add option.

Step 7 Select the Options menu item and either “Select Reference for Document” or “Select IETM for Document”.

Step 8 From the Select Site RRL window click on the desired Reference or IETM and click on the Select menu item.

**NOTE:** If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser and select the Options menu item and the Select option.

**NOTE:** The Type field will automatically be identified, depending on your selection of Reference or IETM.

Step 9 Click on the Before Text field and click on the down arrow. Select the desired verb.

Step 10 In the After Text field add the required text for the Assignment. (Example: Chapter 15, paragraphs 15.2.3 through 15.2.8.)
Step 11  Repeat Steps 6 through 9 for each additional assignment.

Step 12  After adding the last assignment select the Exit menu item.

Step 13  Select the Contents menu item and the Study Questions sub-menu item. Number and add the desired study questions to the Word document.

Step 14  Select the File menu item and the Save sub-menu item when finished adding study questions.

Step 15  Select the File menu item and the Exit sub-menu item to return to the Assignment Sheet window.

Step 16  Select the Contents menu item and the Answer sub-menu item.

Step 17  Number and add the answers to the questions added in Step 12.

Step 18  Select the Edit menu item and the Save sub-menu item to save your answers.

Step 19  Select the Options menu item and the Print Preview option to view and review your Assignment Sheet.

Step 20  From the Preview window select the File menu item and the Exit sub-menu item.

Step 21  When completed with the Assignment Sheet select the Exit menu item to return to the Sections window.

To develop a Diagram Sheet:

Step 1  From the Sections window click on the Instructor-Led Section Title.

Step 2  Select the Sheets menu item and the Add Sheet option.

Step 3  Select Diagram.

Step 4  Add the Diagram Sheet Title in the designated field.

Step 5  Select the Contents menu item and the Diagram sub-menu item.

Step 6  Select the Insert menu item and the AIM Graphic, or AIM IMM sub-menu item.

Step 7  If AIM Graphic was selected, click on the desired graphic from the Select Graphic window. Select the Options menu item and the Select option. This will place the graphic in the position of your cursor in your Word document.
If AIM IMM was selected, click on the desired IMM from the IMM Selection window. Select the Options menu item and the Select option. This will place a hot link to the IMM in the position of your cursor in your Word document.

Step 8   Select the File menu item and the Save sub-menu item when finished adding graphics/IMI.

Step 9   Select the Options menu item and the Print Preview option to view and review your Diagram Sheet.

Step 10  From the Preview window select the File menu item and the Exit sub-menu item.

Step 11  When completed with the Diagram Sheet select the Exit menu item to return to the Sections window.

To develop an Information Sheet:

Step 1   From the Sections window click on the Instructor-Led Section Title.

Step 2   Select the Sheets menu item and the Add Sheet option.

Step 3   Select Information.

Step 4   Add the Information Sheet Title and Introduction in the designated fields.

Step 5   Select the Contents menu item and the References sub-menu item.

Step 6   From the Sheet References window select the Options menu item and either “Select Reference for Document” or “Select IETM for Document”.

Step 8   From the Select Site RRL window click on the desired Reference or IETM and click on the Select menu item.

**NOTE:** If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser and select the Options menu item and the Select option.

**NOTE:** The Type field will automatically be identified, depending on your selection of Reference or IETM.

Step 9   In the After Text field add the required text for the Information. (Example: Chapter 15, paragraphs 15.2.3 through 15.2.8.)

Step 10  Repeat Steps 6 through 9 for each additional document.

Step 11  After adding the last document select the Exit menu item.
Step 12 Select the **Contents** menu item and the **Information** sub-menu item. Add the required text to the Word document.

Step 13 Select the **File** menu item and the **Save** sub-menu item when finished adding information.

Step 14 Select the **File** menu item and the **Exit** sub-menu item to return to the Information Sheet window.

Step 15 Select the **Options** menu item and the **Print Preview** option to view and review your Information Sheet.

Step 16 From the Preview window select the **File** menu item and the **Exit** sub-menu item.

Step 17 When completed with the Information Sheet select the **Exit** menu item to return to the Sections window.

**To develop a Job Sheet:**

Step 1 From the Sections window click on the Instructor-Led Section Title.

Step 2 Select the **Sheets** menu item and the **Add Sheet** option.

Step 3 Select **Job**.

Step 4 Add the Job Sheet **Title** and **Introduction** in the designated fields.

Step 5 Select the **Contents** menu item and the **Equipment** sub-menu item.

Step 6 AIM opens the Equipment folder of the Site RRL for selection of the equipment for performance of the Job Sheet. Since there are 18 folders in the Site RRL that contain equipment, you can select the **Resources** menu item and select the equipment desired from any of the equipment related folders.

Highlight the desired item and select the **Options** menu item and the **Select** option. When all the equipment items have been selected select the **Exit** menu item to return to the Job Sheet window.

Step 7 Select the **Contents** menu item and the **References** sub-menu item.

Step 8 From the Sheet References window select the **Options** menu item and the **Add** option.

Step 9 Select the **Options** menu item and either “Select Reference for Document” or “Select IETM for Document”.
Step 10 From the Select Site RRL window click on the desired Reference or IETM and click on the **Select** menu item.

**NOTE:** If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser and select the **Options** menu item and the **Select** option.

**NOTE:** The **Type** field will automatically be identified, depending on your selection of Reference or IETM.

Step 11 In the **After Text** field add the required text for the Job. (Example: Chapter 15, paragraphs 15.2.3 through 15.2.8.)

Step 12 After selecting all the references required select the **Exit** menu item.

Step 13 Select the **Contents** menu item and the **Self Test Questions** sub-menu item. Number and add the desired study questions to the Word document.

Step 14 Select the **File** menu item and the **Save** sub-menu item when finished adding self test questions.

Step 15 Select the **File** menu item and the **Exit** sub-menu item to return to the Job Sheet window.

Step 16 Select the **Contents** menu item and the **Safety Precautions** sub-menu item. Add the required safety precautions for performance of the Job Sheet to the Word document.

Step 17 Select the **File** menu item and the **Save** sub-menu item when finished adding safety precautions.

Step 18 Select the **File** menu item and the **Exit** sub-menu item to return to the Job Sheet window.

Step 19 Select the **Contents** menu item and the **Job Steps** sub-menu item. Number and add the desired job steps to the Word document.

Step 20 Select the **File** menu item and the **Save** sub-menu item when finished adding job steps.

Step 21 Select the **File** menu item and the **Exit** sub-menu item to return to the Job Sheet window.

Step 22 Select the **Contents** menu item and the **Answer** sub-menu item.

Step 23 Number and add the answers to the self test questions added in Step 13.
Step 24  Select the *Edit* menu item and the *Save* sub-menu item to save your answers.

Step 25  Select the *Options* menu item and the *Print Preview* option to view and review your Job Sheet.

Step 26  From the Preview window select the *File* menu item and the *Exit* sub-menu item.

Step 27  When completed with the Job Sheet select the *Exit* menu item to return to the Sections window.

**To develop an Outline Sheet:**

Step 1  From the Sections window click on the Instructor-Led Section Title.

Step 2  Select the *Sheets* menu item and the *Add Sheet* option.

Step 3  Select *Outline*.

Step 4  Add the Outline Sheet *Title* and *Introduction* in the designated fields. The Section Title will be the default title of the Outline Sheet and it can be edited.

Step 5  Select the *Contents* menu item and the *Section Outline* sub-menu item. Add the required text to the Word document.

Step 6  Select the *File* menu item and the *Save* sub-menu item when finished adding the outline.

Step 7  Select the *File* menu item and the *Exit* sub-menu item to return to the Outline Sheet window.

Step 8  Select the *Options* menu item and the *Print Preview* option to view and review your Outline Sheet.

Step 9  From the Preview window select the *File* menu item and the *Exit* sub-menu item.

Step 10 When completed with the Outline Sheet select the *Exit* menu item to return to the Sections window.

**To develop a Problem Sheet:**

Step 1  From the Sections window click on the Instructor-Led Section Title.

Step 2  Select the *Sheets* menu item and the *Add Sheet* option.

Step 3  Select *Problem*. 
Step 4  Add the Problem Sheet **Title** and **Introduction** in the designated fields.

Step 5  Select the **Contents** menu item and the **Equipment** sub-menu item.

Step 6  AIM opens the Equipment folder of the Site RRL for selection of the equipment for performance of the Problem Sheet. Since there are 18 folders in the Site RRL that contain equipment, you can select the **Resources** menu item and select the equipment desired from any of the equipment related folders.

Highlight the desired item select the **Options** menu item and the **Select** option. When all the equipment items have been selected select the **Exit** menu item to return to the Problem Sheet window.

Step 7  Select the **Contents** menu item and the **References** sub-menu item.

Step 8  From the Sheet References window select the **Options** menu item and the **Add** option.

Step 9  Select the **Options** menu item and either “**Select Reference for Document**” or “**Select IETM for Document**”.

Step 10  From the Select Site RRL window click on the desired Reference or IETM and click on the **Select** menu item.

**NOTE:** If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser and select the **Options** menu item and the **Select** option.

**NOTE:** The **Type** field will automatically be identified, depending on your selection of Reference or IETM.

Step 11  In the **After Text** field add the required text for the Job. (Example: Chapter 15, paragraphs 15.2.3 through 15.2.8.)

Step 12  After selecting all the references required select the **Exit** menu item.

Step 13  Select the **Contents** menu item and the **Problem** sub-menu item. Add the text of the problem. Identify what has been Given to the student, the Initial and Final conditions for the performance of the Problem Sheet.

Step 14  Select the **File** menu item and the **Save** sub-menu item when finished adding the text.

Step 15  Select the **File** menu item and the **Exit** sub-menu item to return to the Problem Sheet window.

Step 16  Select the **Contents** menu item and the **Answer** sub-menu item.
Step 17 Number and add the answers to questions added in Step 13.

Step 18 Select the **Edit** menu item and the **Save** sub-menu item to save your answers.

Step 19 Select the **Options** menu item and the **Print Preview** option to view and review your Problem Sheet.

Step 20 From the Preview window select the **File** menu item and the **Exit** sub-menu item.

Step 21 When completed with the Problem Sheet select the **Exit** menu item to return to the Sections window.

### 13.1.5.6 Adding Exercises for a Section

Before an Exercise can be used in a Section it must be created, to create an Exercise complete the following steps:

1. Highlight The Section where the Exercise is to be used.
2. Select Resources from the menu bar.
3. Select Exercises from the Resources sub-menu.
4. From the Exercises screen select Options, Create.
5. Fill in the information for the following boxes:
   - **Title:** The title of the Exercise.
   - **Difficulty Type:** This is a Drop-down box where level of difficulty (Basic, Intermediate, or Advanced) is chosen.
   - **Length in Minutes:** Length of the Exercise in minutes.
   - **Training Approach:** The training approach used in the Exercise, such as Group or individual performance training.
   - **Special Instructions:** Any special instructions to the instructor for conducting the Exercise.
6. Select the Contents menu option.
7. Select the Event Activity submenu option.
8. From the Event-Activity Sheet screen select Option, Add Same Level Time/Event
9. Add information for Time/Event Text, RIA Text and RTA Test.
10. Select Edit, Save, and Exit

Once Exercises have been created they can be associated with an element as follows:

1. Highlight the Element where the Exercise is to be used.
2. Select Resources from the menu bar.
3. Select Add Exercise.
4. Highlight the desired Exercise from the Exercises screen.
5. Select Options, Select, Exit.
13.1.6 Lessons Window

The Lessons window contains the following options:

- **Create Lesson**: Allows you to add a new Principle or Procedure Lesson to the list.
- **Add Section to Lesson**: Opens a grid of Sections (that contains their title, version, and status) in the right-hand pane where you can select the Sections that pertain to the Lesson.
- **Copy**: Allows you to duplicate a Lesson in the Lessons window.
- **Create New Version**: Allows you to create a new version of an approved Lesson.
- **Delete**: Allows you to delete a Lesson in the Lessons window.
- **ISD Considerations**: Considerations are entered into the Content Planning Module (CPM) and are brought over to the LO Module on import of a course. They are only editable in the CPM. This item is hidden from the menu for non-imported content.
- **Security Markings**

  From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:
  1. Right click and Go To the appropriate location on the course tree (left pane).
  2. From the menu bar click Options.
  3. From the Options dropdown menu click Security Markings

  This will display the screen show in the figure below.

  ![Entity Security Markings for LP T-000-TEST Rev 0 Chg 0](image)

  The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that
can have security markings and the current marking assigned. The lower portion of the screen is broken into the following three sections:

- **Classification**: The available classifications that can be assigned, the options are:
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier**: This is an additional security modifier to the classification, the options are:
  - (None)
  - COMINT
  - Talent Keyhole
  - COMINT/Talent Keyhole

- **Release Ability**: This is an additional restriction on who the document may be released to, the options are:
  - (None)
  - NOFORN
  - For Official Use Only
  - REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

- **Select**: Enabled after selecting the **Add Section to Lesson** option, it allows you to select a highlighted Section to support a Lesson.
- **Unselect**: Enabled after selecting the **Add Section to Lesson** option, it allows you to unselect the highlighted Section from a Lesson.
- **Find Lesson**: Allows you to enter text to find a Lesson.
- **Check Spelling**: Allows you to check the spelling of any element within the Lesson.
- **Grant Privileges**: Allows you to grant the privileges you have to another AIM User.
To create a Lesson in the Learning Object Module:

Step 1  From the AIM main menu, select the Document menu item, the Learning Object Module sub-menu item and Lesson or click on the Learning Object Module icon and when the Courses window opens select the Contents menu item and the Lessons sub-menu item.

Step 2  From the Lessons window select the Options menu item and the Create Lesson option.

Step 3  AIM will add the New Lesson to the Lesson tree structure in the left-hand pane. Expand the structure of the Lesson by clicking on the + block. This will reveal the Overview, Sections, and Summary portions of the Lesson and expanding the Sections will identify the elements required for each section.

Step 4  With the New Lesson highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Lesson titled General, Job, Skills Data, Info, Sheets if Instructor-Led Sections containing Instruction Sheets have been selected for the Lesson, Resources, and Metadata. Add/identify the following information for each tab and select the Edit menu item and the Save sub-menu item when completed with each tab.

- **General tab** – Enter the Title, Identification Number and Objective in the fields provided. The Identification Number will be assigned for generating an output file for SCORM, NLCOM or AICC and if unknown can remain blank until assigned. Click on the down arrows for Lesson Type, Status, and Classification and select the appropriate information. If the Lesson content is not releasable to foreign nationals check the NOFORN block.

- **Objectives tab** – Lists all the Enabling Objectives of the Sections selected for the Lesson.

- **Job tab** – Enter the Duty and Job Task that the Lesson supports in the fields provided. Click on the down arrows for Category (Skill or Knowledge) and select the appropriate entries.

- **Skills List** – Skills data identifies Task/Knowledge/Skill/Tools/Resources by and ID, Type and Text. If the Skills data is available in the EDE the Skill List data will automatically be entered when importing from EDE.

- **Info** – The Information tab can contain information to identify the author and owner. The date fields allow you to identify the date the Lesson was created, published, and an expiration date can be added when applicable. Keywords can be added to facilitate searching the database for the Lesson.

- **Sheets** – Lists the Instruction Sheets identified in the Sections selected for the
Lesson.

- **Resources** – This is not an area where you can add resources. The collective resources of the elements of the Lesson and the selected Sections will appear in this tab.
- **Metadata** – Each of the folders in the metadata structure contain fields to enter appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected.
Step 5  
Develop the **Overview** section of the Lesson. The **Overview** folders contain Element, Resource, and Metadata tabs. The Element tab contains the Styled Text Editor that you can use to create information and to paste information saved as RTF. The Resource tab works in conjunction with the **Resources** menu item and the **Add Resource**, **Add Graphic** and **Delete Resource** options. The Metadata tab contains folders and fields to enter required data and key words for the Element. Add/identify the information for each item and select the **Edit** menu item and the **Save** sub-menu item when completed with each Element. Add/identify the following information for each of the following Lesson Overview items and select the **Edit** menu item and the **Save** sub-menu item when completed with each item.

Elements may be added, modified or deleted from the Overview unless they are required elements (Introduction and Importance) by highlighting the Overview and selecting Add from the submenu, this will display a list of elements that can be added. To delete an element, highlight the element and select Delete from the Options submenu. To Modify an element, highlight the element and select **Change Element** from the Options submenu. Elements may also be resequenced with some exceptions, for example the Introduction must be the first element. To resequence elements highlight Overview and then select **Resequence** from the Options submenu. It is also possible to add sub-elements by highlighting an element and selecting Add Sub-element from the Options menu.

- **Introduction** – The goal of the **Information** item is to explain the purpose of the Lesson.
- **Importance**- The goal of the **Importance** item is to inform learners why they should be interested in the Lesson by creating interest and relevance.
- **Prerequisite** – The goal of the **Prerequisite** item is to inform learners of knowledge and skills needed to complete the Lesson.
- **Scenario** – The goal of the **Scenario** item is to relate a story to a job function to motivate the learners and capture their attention.

Step 6  
When the Sections that support the Lesson have been developed, click on the Sections heading in the tree structure of the Lesson. The Sections identified in the database will be reflected in a list of Section Titles in the right-hand pane. Highlight the desired Section and select the **Options** menu item and the **Select** option or double-click on the desired Sections. A check mark will appear in the square box to the left of the Sections selected. The Sections can be placed in the order desired for presentation by using the using the click and drag method in the right hand Title column.

The Sections will be reflected in the Lesson tree structure in the left-hand pane and their content can be edited. Select the **Edit** menu item and the **Save** sub-menu item after selecting the desired Sections and sequencing them in the desired order.

Step 7  
Develop the **Summary** section of the Lesson. The **Summary** contain Element, Resource, and Metadata tabs. The Element tab contains the Styled Text Editor
that you can use to create information and to paste information saved as RTF. The Resource tab works in conjunction with the Resources menu item and the Add Resource, Add Graphic and Delete Resource options. The Metadata tab contains folders and fields to enter key words for the Element. Add/identify information for each item and select the Edit menu item and the Save sub-menu item when completed with each element. Add/identify the following information for each item and select the Edit menu item and the Save sub-menu item when completed with each item.

Elements may be added, modified or deleted from the Summary unless they are required elements (Review) by highlighting the Summary and selecting Add from the submenu, this will display a list of elements that can be added. To delete an element, highlight the element and select Delete from the Options submenu. To Modify an element, highlight the element then select Change Element from the Options submenu. Elements may also be resequenced. To resequence elements highlight Overview and then select Resequence from the Options submenu. It is also possible to add sub-elements by highlighting an element and selecting Add Sub-element from the Options menu.

- **Review** – The goal of the Review item is to recap the key points from all Sections in the Lesson.
- **Next Step** – The goal of the Next Step item is to direct the learner to additional steps that would further their knowledge of the subject presented in the Lesson.
- **Resource** – The goal of the Resource item is to provide more information about the knowledge and skills covered in the Lesson.

### 13.1.7 Modules Window

The Modules window contains the following options:

- **Create Module**: Allows you to add a new Module to the list.
- **Add Lesson to Module**: Opens a grid of Lessons (that contains their title, version, and status) in the right-hand pane where you can select the Lessons that pertain to the Module.
- **Copy**: Allows you to duplicate a Module in the Modules window.
- **Create New Version**: Allows you to create a new version of an approved Module.
- **Delete**: Allows you to delete a Module in the Modules window.
- **Security Markings**

From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:

7. Right click and Go To the appropriate location on the course tree (left pane).
8. From the menu bar click Options.
9. From the Options dropdown menu click Security Markings.

This will display the screen show in the figure below.
The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that can have security markings and the current marking assigned. The lower portion of the screen is broken into the following three sections:

- **Classification**: The available classifications that can be assigned, the options are:
  
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier**: This is an additional security modifier to the classification, the options are:
  
  - (None)
  - COMINT
  - Talent Keyhole
  - COMINT/Talent Keyhole

- **Release Ability**: This is an additional restriction on who the document may be released to, the options are:
  
  - (None)
  - NOFORN
  - For Official Use Only
  - REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

- **ISD Considerations**: Considerations are entered into the Content Planning Module (CPM) and are brought over to the LO Module on import of a course. They are only editable in the CPM. This item is hidden from the menu for non-imported content.

- **Find Module**: Allows you to enter text to find a Module.
**Show In Use Information**: If the IN-Use flag is set this option will display which user caused the flag to be set.

**Reset In-Use**: This option is used to reset the IN-Use flag to allow editing.

**Check Spelling** Allows you to check the spelling of any element within the Module.

**Grant Privileges**: Allows you to grant the privileges you have to another AIM User.

**Explain Flag**

**Remove Flag**

**To create a Module in the Learning Object Module:**

**Step 1** From the AIM main menu, select the **Document** menu item, the **Learning Object Module** sub-menu item and **Module** or click on the Learning Object Module icon and when the Courses window opens select the **Contents** menu item and the **Modules** sub-menu item.

**Step 2** From the Modules window select the **Options** menu item and the **Create Module** option.

**Step 3** AIM will add the *New Module* to the Module tree structure in the left-hand pane. Expand the structure of the Module by clicking on the + block. This will reveal the Overview, Sections, and Summary portions of the Module, expanding the Lessons will identify the elements required for each Lesson, and expanding the Sections will identify the elements required for each section.

**Step 4** With the *New Module* highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Module titled Module, Objectives, Metadata, and Resources. Add/identify the following information for each tab and select the **Edit** menu item and the **Save** sub-menu item when completed with each tab.

- **Module tab** – Enter the Title of the Module.
- **Objectives tab** – The Objectives tab will contain the Terminal and Enabling objectives of the Lessons and Sections selected for the Module.
- **Sheets** – The Sheets tab will contain a list of all the Instruction Sheets contained in the Lessons selected for the Module.
- **Resources** – This is not an area where you can add resources. The collective resources of the elements of the Module and the selected Lessons and Sections will appear in this tab.
- **Metadata** – Each of the folders in the metadata structure contain fields to enter appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected.

**Step 5** When the Lessons that support the Module have been developed, click on the Lessons heading in the tree structure of the Module. The Lessons identified in the database will be reflected in a list of Lesson Titles in the right-hand pane.
Highlight the desired Lesson and select the **Options** menu item and the **Select** option or double-click on the desired Lessons. A check mark will appear in the square box to the left of the Lessons selected. The Lessons can be placed in the order desired for presentation by using the using the click and drag method in the right hand Title column.

The Lessons will be reflected in the Module tree structure in the left-hand pane and their content can be edited. Select the **Edit** menu item and the **Save** sub-menu item after selecting the desired Lessons and sequencing them in the desired order.

### 13.1.8 Courses Window

The **Courses window contains the following options:**

- **Create Course**: Allows you to add a new Course to the list.
- **Add Module to Course**: Opens a grid of Modules (that contains their title, version, and status) in the right-hand pane where you can select the Modules that pertain to the Course.
- **Copy**: Allows you to duplicate a Course in the Courses window.
- **Create New Version**: Allows you to create a new version of an approved Course.
- **Delete**: Allows you to delete a Course in the Courses window.

**Security Markings**

From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:

10. Right click and Go To the appropriate location on the course tree (left pane).
11. From the menu bar click Options.
12. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.
The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that can have security markings and the current marking assigned. The lower portion of the screen is broken into the following three sections:

- **Classification**: The available classifications that can be assigned, the options are:
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier**: This is an additional security modifier to the classification, the options are:
  - (None)
  - COMINT
  - Talent Keyhole
  - COMINT/Talent Keyhole
- Release Ability: This is an additional restriction on who the document may be released to, the options are:
  - (None)
  - NOFORN
  - For Official Use Only
  - REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

- **Front Matter:** Contains boilerplate LP and TG Safety, Security, and How to Use information that can be edited for the course.
- **ISD Considerations:** Considerations are entered into the Content Planning Module (CPM) and are brought over to the LO Module on import of a course. They are only editable in the CPM. This item is hidden from the menu for non-imported content.
- **Find Course:** Allows you to enter text to find a Course.
- **Check Spelling:** Allows you to check the spelling of any element within the Course.
- **Grant Privileges:** Allows you to grant the privileges you have to another AIM User for Lessons and Sections.
- **Show In Use Information:** If the IN-Use flag is set this option will display which user caused the flag to be set.
- **Reset In-Use:** This option is used to reset the IN-Use flag to allow editing.
- **Explain Flag**
- **Remove Flag**
To create a Course in the Learning Object Module:

Step 1  From the AIM main menu, select the Document menu item, the Learning Object Module sub-menu item and Course or click on the Learning Object Module icon.

Step 2  From the Courses window select the Options menu item and the Create Course option.

Step 3  AIM will add the New Course to the Module tree structure in the left-hand pane. Expand the structure of the Course by clicking on the + block. This will reveal the Overview, Sections, and Summary portions of the Course, expanding the Modules will identify the elements required for each Module, expanding the Lessons will identify the elements required for each Lesson, and expanding the Sections will identify the elements required for each section.

Step 4  With the New Course highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Course titled Course, Objectives, Metadata, and Resources. Add/identify the following information for each tab and select the Edit menu item and the Save sub-menu item when completed with each tab.

- **Course tab** – Enter the Title of the Course, the Version and the Status.
- **Objectives tab** – The Objectives tab will contain the Terminal and Enabling objectives of the Modules, Lessons and Sections selected for the Course.
- **Sheets** - The Sheets tab will contain a list of all the Instruction Sheets contained in the Modules selected for the Course.
- **Resources** – This is not an area where you can add resources. The collective resources of the elements of the Course, and the selected Modules, Lessons and Sections will appear in this tab.
- **Metadata** – Each of the folders in the metadata structure contain fields to enter appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected.

Step 5  When the Modules that support the Course have been developed, click on the Modules heading in the tree structure of the Course. The Modules identified in the database will be reflected in a list of Module Titles in the right-hand pane. Highlight the desired Module and select the Options menu item and the Select option or double-click on the desired Module. A check mark will appear in the square box to the left of the Modules selected. The Modules can be placed in the order desired for presentation by using the using the click and drag method in the right hand Title column.

The Modules will be reflected in the Course tree structure in the left-hand pane and their content can be edited. Select the Edit menu item and the Save sub-menu item after selecting the desired Modules and sequencing them in the desired order.
APPENDIX A

GLOSSARY

Definitions and Acronyms
A AAC. (Acquisition Advice Code). A field available for data entry in the Resource Requirements List (RRL)

Ability. Enduring attributes of the individual that influence performance and enable the performance of tasks.

ACR. AIM Change Request

Advanced Distributed Learning (ADL). The Advanced Distributed Learning (ADL) Initiative—collaborative effort between government, industry and academia. Its goal is to establish a new distributed learning environment that permits the interoperability of learning tools and course content.

Automated Electronic Classrooms. (AECs)

AG/SAG. (Activity Group/Sub Activity Group). An alphanumeric identifier entered in the RRL. Maximum of 8 characters

Aggregation. Content Aggregation is the process of aggregating resources (SCO /ELOs) into a defined structure (content structure) to build a learning event. An aggregation is a grouping of related ELOs, along with the rules that control the presentation of the grouped material to the learner. A learning event can be constructed recursively; hence a content structure has the shape of a tree, with ELOs/SCOs forming the leaves and aggregations (TLOs) representing the nodes.

AIM. Authoring Instructional Materials

AOB. Average on Board

API. Application Programming Interface

Approve. The act of confirming that an element is final and any further modifications will need to be performed with training material maintenance.

Approving Agency. Any activity that approves training material.

Archive. To make a copy of a curriculum product; export it to a floppy disk, hard drive, or network; and remove it from the AIM I database.
Assessment. The process used to systematically evaluate a learner’s skill or knowledge level (ASTD).

Assessment instruments. Items that are grouped together to form tests, quizzes, exams, or simulations for the purpose of assessment.

Assessment item. Each individual question or task the student is asked to address for assessment purposes.

Asset. A single media element or text element (e.g. an image, audio file, or html file) that can be delivered to a Web client.

Assignment Sheet. An instruction sheet designed to direct study or homework efforts of a trainee.

Authoring Instructional Materials (AIM). An automated tool to assist training managers, curriculum developers, and subject matter experts in the development and maintenance of training materials.

Authoring Instructional Materials I (AIM I). An automated tool to assist training managers, curriculum developers, and subject matter experts in the development and maintenance of training materials that follow MIL-PRF-29612 and NADEDTRA 131B.

Authoring Instructional Materials II (AIM II). An automated tool to assist training managers, curriculum developers, and subject matter experts in the development and maintenance of training materials that follow MIL-PRF-29612 and NADEDTRA 130B.

Average Onboard (AOB). The annual input multiplied by the course length in calendar days (including weekends and holidays) divided by 365.

B BG. Background (PPP table).

Bottleneck. A situation in which only a portion of a class can advance through a period together.


CAGE. (Commercial and Government Entity). Formerly FSCM (Federal Supply Code for Manufacturers)

CBT. Computer Based Training

CCA. Curriculum Control Authority

CCMM. Course Curriculum Model Manager
CDP. (Course Data Processing Code). An alphanumeric code that is provided by NITRAS and entered in the Learning Site Summary. Maximum of 5 characters.

Change. The process of developing a minor modification to an approved course of instruction. A Change cannot increase course length, add additional resources, or modify Course Learning Objectives (CLOs) without Curriculum Control Authority (CCA) authorization.

CIN. (Course Identification Number). An alphanumeric code entered in AIM I windows. Maximum of 10 characters. All letters in alphanumeric codes must be upper case.

CLO. Course Learning Objective

CMI. Computer Managed Instruction

CMS. Course Master Schedule or Course Mission Statement

COG. Cognizant (activity). Field available for data entry in the Resource Requirements List (RRL)

Cognitive Apprenticeship. Model where experts and novices interact while focusing on a realistic, job related task to develop the learner’s essential cognitive skills.

COI. (Curriculum Outline of Instruction). An outline of the topics to be included in the LP

Community of practice. A self-organized, deliberate collaboration of people who share common practices, interests or aims and want to advance their knowledge. When the community proves useful to its members over time, they may formalize their status by adopting a group name and a regular system of interchange.

www.sims.berkeley.edu/courses/is213/s99/Projects/P9/web_site/glossary.htm

Concept maps. A graph that represents knowledge, with nodes representing concepts and arrows representing relations between the concepts.

Content Aggregation. A content aggregation is a map (content structure) that can be used to aggregate learning resources into a cohesive unit of instruction. AIM aggregates all the Topics (SCOs) in a course into the output package (aggregation), which has course level metadata as per SCORM V1.2 and SCORM 2004 requirements.

Content Planning Module (CPM). The CPM supports planning and management of content intended for the ILE. Major functions include: building of Navy Learning Objective Statements (NLOS); planning, managing and executing of ILE content projects; supporting content development workflow and reporting requirements; data exchange and linking with other ILE component systems. In addition the CPM supports Centers in the areas of: event management; messages and announcements. The CPM supports the reuse and repurposing of ILE content by sharing the LOSs entered by Centers and sharing project information.
**Content repository.** Storage facility for digital objects and files made searchable by using metadata.
**Course Curriculum Model Manager (CCMM).** The entity assigned the responsibility for conducting and maintaining a specific course. The CCMM initiates curriculum development and training materials modification; conducts curriculum reviews and analysis of feedback; maintains course audit trail documentation; and develops and approves Changes.

**Course Data Processing Code (CDP).** Alphanumeric code assigned to each course for NITRAS processing. Equates to training location code.

**Course Master Schedule (CMS).** The parts, sections, and topics of the Curriculum Outline of Instruction (COI) placed into a time schedule.

**Course Mission Statement (CMS).** A description of the ultimate purpose of the course including a statement of who is to be trained, what he/she is to be trained to do, the degree of qualification brought about by the training, and where and under what general conditions the graduate will perform the job.

**Course Learning Objectives (CLO).** Statements which describe the overall knowledge and skills to be attained upon completion of the course.

**Course Resource Requirements List (RRL).** A list which identifies the texts, references, equipment, films, graphics, and instructional media materials required to support a curriculum.

**CPATS, (NETC Program Automated Tracking System).** An alphanumeric identifier that is entered in the Learning Site Summary. maximum of 50 characters. Currently suspended.

**CSCI.** Computer Software Configuration Item.

**Curricula Index.** A list of all the formal curricula, by numbers and titles, covered by a particular Training Path Chart (TPC).

**Curriculum Control Authority (CCA).** A Functional Commander designated by NETC to have curriculum control of specific courses/training programs.

**Curriculum Outline Of Instruction (COI).** An outline of the topics to be included in the LP.

**DDA.** Discussion Demonstration Activity

**Developing Agency.** Any activity which produces training materials.

**Diagram Sheet.** An instruction sheet that provides the trainee with a diagram, schematic, illustration, or definitions used by the instructor during the course of instruction.

**Discussion Point. (DP).** A major point to be covered in the topic of a course

**DoD.** Department of Defense.
**DOR.** Drop On Request.

**ECIS.** Electronic Classroom Integration Software.

**Electronic Performance Support Systems. (EPSSs)**

**ELO.** Enabling Learning Object—a collection of one or more Assets with instructional treatment applied to satisfy one and only one Enabling Objective.

**Enabling Objective (EO).** Smaller objective that forms a part of a terminal objective. In our model one ELO addresses each Topic Learning Objective.

**ESS.** Equipment/Subsystem/System.

**Executive Review of Navy Training. (ERNT)**

**Export.** To make a copy of a curriculum product and export it to a floppy disk, hard drive, or network. In contrast to the Archive function, the export function does not remove the original curriculum product from the AIM I database.

**FAL.** Fault Applicability List

**Fault.** A pre-engineered casualty designed to produce a documented set of conditions/indications for training purposes.

**FDS.** Fault Description Sheet

**FID.** Fault Insertion Device

**File Extension.** The Archive/Unarchive and Import/Export utilities use default file extensions for archive (.arc) and export (.exp)

**Flag.** The methodology used to identify to a user where a possible training impact is based on modifications, additions, and/or deletions performed within other elements of the curriculum. In AIM I windows, a flag is a one-character field that contains one of two symbols:
- An encircled `a (('@') is used to indicate a system-generated maintenance flag.
- An `X` is used to indicate a user-generated maintenance flag.

A maintenance flag is generated in the Flag column adjacent to specific material that is linked to source material that was modified from the previously approved version of a Course. Maintenance flags should not be confused with *in-use flags.*

**GFI/M.** Government Furnished Information/Material—materials provided to contracted designers and developers for the creation of ILE content.
**Grant.** The act of giving to another AIM I user the ability to view, edit, lock/unlock, or grant privilege for an AIM I-generated curricula product. The developer of a specific product or any administrator can perform the action.

**GUI.** Graphical User Interface

**High Edit.** The Text Editor available in AIM I’s Trainee Guide module if Word is not installed on the user’s computer.

**HPSM.** Human Performance System Model—cyclical four step process of navy training:
- Define requirements
- Define solutions
- Develop components
- Execute and measure

**ID.** Instructional Designer—one who analyzes instructional problems and designs their solutions

**IDC.** Instruction Delivery Continuum—new framework for the delivery of instructional material for the purposes of Navy training.

**IDP.** Individual Development Plan—A document that includes an assessment of current skills, and a timeline and sources for development to achieve future goals. Outlines the way in which the employee will develop the knowledge, skills, and abilities needed to meet changing organizational needs and environmental demands and/or prepare to achieve future career goals (www.goer.state.ny.us/workforce/glossary.html).

**IETM.** Interactive Electronic Technical Manual

**ILE.** Integrated Learning Environment—The Navy Integrated Learning Environment has been established to provide the technical and administrative infrastructure for the acquisition, development, storage, maintenance, and distribution of learning content.

**IMM.** Instruction Media Material

**Import.** To extract data from a previously exported file and enter that data into the AIM I database.

**IMS.** Worldwide non-profit organization which develops and promotes the adoption of open technical specifications for interoperable learning technology

**Information Sheet.** An instruction sheet which provides information related to subject matter contained in texts or reference books required, but not readily available, to trainees.

**Instructional Strategy.** All materials, methods, activities, and assessments chosen to support a specific learning goal.
**In-Use Flag.** A safety precaution built into AIM I to prevent subsequent users from accessing an AIM I document or topic for any purpose other than viewing. Documents flagged “in use” can only be viewed, and in-use flags can be removed only by an AIM I Administrator via the system’s Admin Utility. In-use flags are not to be confused with system and user maintenance flags.

**ISD - Instructional Systems Development.** A structured approach to developing a plan of instruction. As defined by NAVEDTRA 131B, the ISD process consists of Planning, Stage 1 (PPP and TPS development), Stage 2 (Preliminary TCCD Development), Stage 3 (LP and TG Development), Stage 4 (Pilot), Stage 5 (Distribution). For a more detailed explanation of each of these phases, refer to NAVEDTRA 131B.

**J** **Job Sheet.** An instruction sheet that provides complete information required to perform a job, a task, or other unit of work involving a sequence on manipulative steps.

**JDTA.** Job Duty Task Analysis - Is the standardized process that examines a specific job to identify all the responsibilities and task requirements of a job in an organization. It is a systematic procedure used by Industrial and Organizational Psychologist, Human Resource, or Personnel Managers to describe important aspects of the job regardless of the person in the job.

**L** **Learner-centric.** Learning designs which allow the learner to have control of the learning experience by making choices as to what will be learned, the order of material presentation, and/or the method of delivery, and which ideally support a wide range of learning needs or styles; also, learning designs which adjusts the presentation materials in response to the learner’s knowledge or skill level.

**Learning event.** Any event or activity planned with the goal of learners acquiring new knowledge, gaining or improving skills or abilities, and/or changing behaviors or attitudes. A learning event will include either an enabling or a terminal objective.

**Learning Object.** “Any digital resource that can be used to mediate learning.” (Wiley and Edwards, 2002)

**Learning Management System.** (LMS)

**Lesson Plan (LP).** An approved plan for a course that provides specific definition and direction to the instructor on learning objectives, equipment and instructional media material requirements, and conduct of the course.

**Line Items.** In the context of Personnel Performance Profiles: statements of overt behaviors that a trainee could perform.

**Lock.** The act of rendering a training material incapable of being modified and allowing a user to build other training materials based on it.
LOEE. List of Effective Elements


LP. Lesson Plan

M Mental Models. Representations in the mind of real or imaginary situations. (Craik, 1943).

Metacognition. The process of monitoring and controlling our cognitive processes, or the process of thinking about thinking (Schwarts & Perfect, 2002).

Metadata. Descriptive information about a piece of data that is not usually visible to the user for “purposes of description, administration, legal requirements, technical functionality, use and usage, and preservation (Getty).” Metadata is designed to help locate, organize, access, and use data effectively.

Metatag. Identifies Metadata.

Migration. In the context of PPP-based curriculum development, a two-phase process that encompasses:

- The transfer of AIM 3.X training materials from files within their Unix-based Oracle database to files that are compatible with AIM I's MS Windows-based database
- The importation of those materials into AIM and the completion of all procedures, both manual and automatic, that are necessary to make the materials conform to the formats of AIM I and the guidelines set forth in NAVEDTRA 131B.

MS. Microsoft

NCOM. Navy Content Object Model—a reusable object model having a primary goal to maximize the reuse, repurpose and reference (R3) value of objects.

NEC. Navy Enlisted Classification

NETC. Naval Education and Training Command

NIIN. National Item Identification Number.

NILARS. Navy Integrated Learning Asset Repository System

NITRAS. Navy Integrated Training Resources and Administration System

NMETL. Naval Mission Essential Task List

NMPC. Navy Military Personnel Command.

NOBC. Navy Officer Billet Classification.
NOTAP. Navy Occupational Task Analysis Program.

NTP. Navy Training Plan.

OAC. Profile Item-to-Topic Objective Assignment Chart

OCCSTD. Occupational Standards.

O&MN. Operation and Maintenance, Navy (example of a Navy funding code)

OJT. On the Job Training.

OPN. Other Procurement, Navy (example of a Navy funding code)

PC (Personal Computer). A desktop or laptop microcomputer

Performance-based outcomes. Learner outcomes that are observable with demonstrated objectives or behaviors that are based on standards.

Personnel Performance Profiles (PPP) Tables. A minimum requirement listing of all knowledge and skills required to operate and maintain a system, subsystem, or equipment, or to perform a task or function. There are five types of PPP Tables: Background, System, Subsystem, Equipment, and Task/Function.

Personnel Performance Profiles (PPP) Table Index. A listing of PPP Tables, by number and title, covered by a particular Training Path Chart (TPC).

PFM. Prefaulted Module

Post Assessment. Any activity designed to be taken after a learning event to confirm that a learner has mastered either the enabling objective at the ELO level or the terminal objective at the TLO level.

PPP. Personnel Performance Profile

PQS. Personnel Qualification Standards—a compilation of the minimum knowledge and skills that an individual must demonstrate in order to qualify for watch standing or perform other specific routine duties necessary for the safety, security, or proper operation of a ship, aircraft, or support system.

Problem Sheet. An instruction sheet that provides trainees with the conditions and parameters of a problem and procedural directions for the solution.

Profile Item-to-Topic Objective Assignment Chart (OAC). An administrative tool designed to reflect the coverage of PPP Table items within a curriculum.

PTN. PPP Table Number
R  **RDBMS.** Relational Database Management System.

**Related Instructor Activity (RIA).** Specific direction to the instructor relative to reference documents, instructional media materials, and demonstrations that may be used to prepare to teach a DP.

**Repurpose.** The reuse of an existing learning object in a new context after modifying its instructional treatment, context, or content.

**Reference.** A validated information source in the form of a learning object for generating ideas or simply as a resource in the similar manner that one would use a reference in a traditional development effort.

**Repository.** See Content repository.

**Resource Requirements List (RRL).** See Site Resource Requirements List and Course Resource Requirements List.

**Revision.** A change to CLOs, increase in course length, or training material change that requires additional resources. A revision incorporates previous changes and supersedes preceding editions of the training materials.

**RIA.** Related Instructor Activity

**RiT.** Revolution in Training.

**RRL.** Resource Requirements List.

**R3.** Reuse, Repurpose, and Reference—overarching tri-fold goal for learning objects within the Navy ILE

S  **SCORM. Sharable Content Object Reference Model.** SCORM is a set of specifications published by Advanced Distributed Learning (ADL) for developing, packaging and delivering high-quality education and training materials wherever and whenever they are needed.

**SCORM 2004.** The Sharable Content Object Reference Model (SCORM 2004) defines a Web-based learning "Content Aggregation Model" and "Run-Time Environment" for learning objects. The SCORM is a collection of specifications adapted from multiple sources to provide a comprehensive suite of e-learning capabilities that enable interoperability, accessibility and reusability of Web-based learning content.

**SCORM CAM.** SCORM Content Aggregation Model—describes the assembly, description, and packaging of content as SCORM Assets, SCOs, and higher aggregations. This task is accomplished through the creation of XML documents according to the SCORM meta-data requirements (LOM).
SCORM LOM. SCORM Learning Object Meta-Data (LOM)—inline XML specification for the description of aggregations of content as well as individual media. LOM metadata provides the means for the identification retrieval and subsequent reuse of content.

SCORM RTE. SCORM Run-time Environment—technical specifications in SCORM for the content launch process, standardized communication between content and LMSs and standardized data model elements used for passing information relevant to the learner’s experience with the content.

SCORM SN. SCORM Sequencing and Navigation (SN)—describes how SCORM-conformant content may be sequenced to the learner through a set of learner or system-initiated navigation events.

Sequencing. Describes and prescribes the manner in which the learner receives content

Sharable Content Object (SCO). SCO represents a collection of one or more Assets that include a specific launchable asset that utilizes the SCORM Run-time Environment to communicate with Learning Management Systems (LMSs). A SCO represents the lowest level of granularity of learning resource that can be tracked by an LMS using the SCORM Run-Time Environment. Generally equivalent to a ELO.

Skill. Developed capacities that facilitate learning or the more rapid acquisition of knowledge or that facilitate performance of activities.

Site Resource Requirements List (RRL). A list that identifies the texts, references, equipment, films, graphics, and instructional media materials required to support an entire AIM I site.


SME. Subject Matter Expert — a person who helps to formulate or verifies domain specific instructional content in his or her area of expertise

SMIC. (Special Material Identification Code). Field available for data entry in the Resource Requirements List (RRL).

Split. To divide a Part/Section/Topic/TLO into two more narrowly focused Parts/Sections/Topics/TLOs.

SSO. AIM System Support Office
**System Administrator.** A person responsible for the day-to-day operation and maintenance of the AIM system (hardware and software), establishing user accounts, and setting privilege levels.

**T** TA. Training Agency.

**TAM.** Table Assignment Matrix

**Task.** The most specific level of behavior in a job that describes the performance of a meaningful job function in terms of a specific action applied to a particular object. The behavior must be observable, have a definite beginning and end, and result in a completed work action or a measurable work product (either the performance can be observed or the results of the performance can be seen and measured).

**Task Force Excell.** The Task Force for Excellence through Commitment to Education and Learning (EXCEL)—body in charge of overseeing the implementation of the pilot programs designed enhance and strengthen the Navy's training and education structure.

**TCCD.** Training Course Control Document

**Terminal Objective.** Desired final outcome (e.g., knowledge or performance-based CLO) of the designed instruction/learning experience. Made up of enabling objectives (TLOs).

**T/F.** Task/Function (PPP table)

**TG.** Trainee Guide

**TLA.** Training Level Assignment

**TLO.** Topic Learning Objective developed for curriculum from PPP Line Items and Training Objective Statements (TOS) when a line item is selected at a TOS for a training requirement in a course.

**TLO.** Terminal Learning Object developed for the Web.

**TMDS.** Training Materials Development System

**Topic Learning Objectives (TLO).** The statements which identify the objectives of the topic.

**TOS.** Training Objective Statement

**TPC.** Training Path Chart

**TPS.** Training Path System
**TR.** Trouble Report

**Trainee Guide (TG).** A generic term for the various printed materials developed for trainee use. A publication, comprised of instruction sheets, which provides each trainee with the supplementary material, in addition to technical manuals, judged to be required for the successful completion of a course of study.

**Training Agency.** An office, bureau, command, or headquarters exercising command of and providing support of training materials.

**Training Course Control Document (TCCD).** A collection of products that expresses, in summary form, the content, structure, and essential management information for a course. The TCCD consists of Front Matter, the Curriculum Outline of Instruction, the Resources Requirements List (RRL) and the Course Master Schedule (CMS).

**Training Level Assignment (TLA)** A tabular listing, in PPP Table number sequence, that imposes training levels for the PPP items and identifies the environment where training for a particular PPP item will take place.

**Training Locator Indicator Codes.** Alphanumeric characters, used in TLAs, which define the environment of the training required for PPP line items.

**Training Objective Statements (TOS).** A group of statements which describe the system, subsystem, equipment, or task/function knowledge depths and skill levels to be attained in support of coordinating, directing, or performing operation and maintenance. The objectives define depth and level of training for PPP items.

**Training Path Chart (TPC).** An element of the TPS containing a representation of the order in which TOS system/subsystem/equipment knowledge depths and skill levels are acquired by training. The TPC constitutes the final job model and defines the particular Navy Enlisted Classification (NEC)/Navy Officer Billet Classification (NOBC).

**Training Path System (TPS).** A coordinated system for identifying the training requirements for specific trainees. These trainees must attain the knowledge and skills necessary to coordinate, direct, or perform operation and maintenance of a system, subsystem, equipment, or task/function. The TPS is based on the knowledge and skill items set forth in PPP Tables and upon an orderly categorization of these items.

**Training Project Plan (TPP).** The output of the Plan Phase of the ISD process.

**Learning Site.** The geographical location(s) at which a course or training is conducted.

**TTO - Training Time Out.**

**UI (Unit of issue).** Field available for data entry in the Resource Requirements List. (RRL).
**Unarchive.** A function of AIM I used to import previously archived material into the AIM I database. The Unarchive function differs from the Import function in that it prevents the system from duplicating graphics that already exist in the AIM I database. (Before importing an item to be unarchived, AIM I checks to see whether any graphics the item might contain already reside in the AIM I Graphics Library.)

**Unique Knowledge.** The enduring information including processes, procedures, or intellectual capital that are not transitory or temporary and are required to perform the Skill Group. Identifies the Unique Knowledge that is associated with the tasks that are central to the job.

**Unlink.** The act of disassociating PPP knowledge items from PPP skill items or DPs from TLOs in the Relational Database Management System (RDBMS).

**Unlock.** The act of rendering a training material capable of being modified and thus not allowing a user to build other training materials based on it.

**V** **VI - Visual Information.**

**W** **WC - Wall Charts.**

**Web-based Training (WBT)**


**X** **XML.** Extensible Markup Language—universal format for exchanging structured documents and data on the Web. XML uses HTML-like tags to delimit bits of data, but unlike HTML, leaves interpretation of that data to the applications that read it.
APPENDIX B

ADMINISTRATION AND UTILITIES

1.0 AIM I Administrative and Utility Functions .......................................................B-1

2.0 Utilities Menu Items ............................................................................................B-1

2.1 Change Password Utility ........................................................................B-1

  2.1.1 Enter a New Password ........................................................................B-2

2.2 Site Resource Requirements List (RRL) Utility ..........................................B-2

  2.2.1 Site Resource Requirements List Window Options Menu Item ....B-3

2.3 Graphics Utility ............................................................................................B-12

  2.3.1 Graphics Options Menu Item ................................................................B-12

2.4 Admin Utility ................................................................................................B-18

  2.4.1 Administration Utility Options Menu Item ......................................B-19

2.5 Delete Proposed Training Material (TM) Utility .........................................B-35

2.6 Reporting ........................................................................................................B-36

2.7 RRL/Graphics Location Tool ..................................................................B-40

  2.7.1 Resource/Graphic Selection Window ...................................................B-40

  2.7.2 Resource Selection ...............................................................................B-41

  2.7.3 Graphic Selection .....................................................................................B-42

  2.7.4 Reference Breakdown ............................................................................B-43

  2.7.5 IETM Breakdown ....................................................................................B-44

  2.7.6 Related Courses Selection .................................................................B-44

  2.7.7 Search Results Window .......................................................................B-46

  2.7.8 Print Preview .........................................................................................B-47

2.8 Learning Site Utility ......................................................................................B-49

  2.8.1 Site Options Menu Item .........................................................................B-49

2.9 Agency Utility .................................................................................................B-52

  2.9.1 Agency Options Menu Item ...................................................................B-52

2.10 Archive/Unarchive Utility .............................................................................B-55

  2.10.1 Archive/Unarchive Options Menu Item ..............................................B-55

2.11 Import/Export Utility ....................................................................................B-59

  2.11.1 Rules for Import/Export Process .........................................................B-59

  2.11.2 Import/Export Options Menu Item .....................................................B-60

2.12 User Utility ....................................................................................................B-65

  2.12.1 User Administration Options Menu Item .........................................B-65

2.13 Relink PPP/TPS Utility ................................................................................B-69

2.14 Data Manager Utility ....................................................................................B-70
1.0 AIM I ADMINISTRATIVE AND UTILITY FUNCTIONS

To meet the management and configuration control requirements of training materials managers, AIM I provides administrative and utility functions for:

- Adding new users
- Assigning levels of privilege that enable users to perform specific development or maintenance functions
- Maintaining site support materials and graphics libraries

2.0 UTILITIES MENU ITEMS

The Utilities menu item provides access to all AIM I utilities. The icons provide access to the most frequently used utilities. The Utilities drop-down menu offers the 14 options (sub-menu items), which are listed below.

- Change Password
- Site RRL
- Graphics
- Admin Utility
- Delete Proposed TM
- Reporting
- RRL/Graphics Location Tool
- Learning Site
- Agency
- Archive/Unarchive
- Import/Export
- User
- Relink PPP/TPS
- Data Manager

2.1 Change Password Utility

The Change Password utility allows you to change your AIM I password. Selecting the Change Password sub-menu item generates the Change Password prompt (Figure B-1).

![Figure B-1. Change Password Prompt](image-url)
Every AIM I password must have at least five characters. When a new password is entered into the database, it is encrypted for increased security. Selecting **Cancel** at any time prior to reentry of the password for verification aborts the process, leaving the original password in effect.

### 2.1.1 Enter a New Password

**To enter a new password:**

**Step 1** From the AIM I main menu, select the **Utility** menu item and the **Change Password** sub-menu item. Or, select the Password icon.

**Step 2** Type your old password in the field provided, and select **OK**.

**NOTE:** If you enter an incorrect password, AIM I will prompt: *Sorry, you entered an incorrect password.* Selecting **OK** will return you to the AIM I main menu.

**Step 3** Enter the new password in the field provided, and select **OK**.

**Step 4** Enter the new password again and select **OK**. You will be prompted with the message *Password has been changed. Please remember your new password!*

**NOTE:** If you enter a new password incorrectly the second time, AIM I will prompt: *Mismatch - password unchanged.* Selecting **OK** will allow you to enter the password again.

**Step 5** Select **OK** to return to the AIM I main menu.

### 2.2 Site Resource Requirements List (RRL) Utility

The **Site RRL** sub-menu item allows you to enter unique information about resources needed to support courses developed with AIM I. The data fields are unique to each type of resource. The **Site RRL** option opens the Site RRL window.

The Site RRL window contains the following menu items:

- **Options**
- **Exit**
- **Help**

Each Resource has its own folder. When you click on a resource folder the items contained in the folder will appear in the upper right hand grid. Right clicking on a resource folder will present a pop-up menu with the options to **Add** another item to the folder, **Print Preview** the contents of the folder and **Print** the contents of the folder.
Clicking on the resource item in the upper right hand grid provides summary information for the item highlighted in the lower right hand grid. Right clicking on the resource item in the upper right hand grid will present a pop-up menu with the options to **Modify/View**, **Delete**, **Grant Privileges**, **Replace**, **Display Related Materials**, **Flag Related Materials**, and **Explain Flag**.

Clicking on the column headers for any column allows sorting by that column. Clicking again on the column header reverse-sorts the data. Double clicking the column separator will resize the column to allow all items to show their full text.

The toolbar contains icons for access to most of the options and includes Find and Clear buttons as well as a find box. Entering data in the find box and clicking Find will filter out all resource items of the selected folder to match the search text. Wildcard characters (*) are not required for searching. If a wild card is inserted before the typed entry the software will produce a list of items that end in the entry and if the wildcard is inserted after the entry it will produce a list of items that start with that entry. Placing wildcards on both sides of the entry has the same effect as not using wildcard entries.

When displaying IMIs in the Site RRL, icons are used to indicate different states of an IMI:

- A question mark indicates that the file associated with an IMM is missing from the Media library.
- A pencil indicates that the file associated with an IMM has been modified since it was added to the AIM Media library.
- A flag indicates that the IMM is in conflict with another IMM which occurred during Import.

### 2.2.1 Site Resource Requirements List Window Options Menu Item

The **Site RRL Options** menu contains the following options:

- **Add Resource**: Allows you to add items to the Site RRL.
- **Modify/View Resource**: Allows you to modify or view the contents of the Site RRL.
- **Delete Resource**: Allows you to delete items from the Site RRL.
- **Grant Privileges**: Allows the AIM User who has been assigned this privilege to assign Edit and Grant privilege to other AIM Users for the resource item highlighted. This option gives the AIM Administrator the privilege to assign Edit, Grant, Approve, Clear In Use, and Maintain/Delete RRL privileges to AIM Users from the Site RRL.
- **Replace**: For users with AIM Administrator privilege only. Enabled if an IMM item is in a conflicting state with another IMM item. Allows you to replace an IMM in the database with another IMM item in the list and provides the option of deleting the item from the Site RRL once replaced.
- **Display Related Materials**: Opens a browser that identifies all the training materials the item has been linked to in the database.
- **Flag Related Materials**: Allows you to flag an RRL item in training material that is in development or maintenance to inform users of an impending maintenance action requirement. Flagging an approved course will change the appearance of the course in the Course Select menu to magenta. The flags and explanations for an approved, magenta, course can only be viewed after a change or revision is created for the course.
• **Display Unused Resources**: For *users with AIM Administrator privilege only*. Displays a list of all Resource items, by type, that have not been selected in a Learning Site RRL for a course. The items can be viewed and deleted from the Unused Items window.

• **Search Site RRL**: Allows you to search the entire RRL database (all types of RRL items) for a specific RRL item by title or number.

• **SCORM Meta-Data**: Allows the user to edit the General, Rights, Lifecycle, and Classification Tabs of the Asset for use in developing SCORM compliant Meta-Data files.

• **Explain Flag**: Allows you to view the explanation for the IMM item that is in conflict with another IMM item.

• **Print Preview**: Allows you to preview a list of the resource items that appear in the Site RRL for the desired RRL type.

• **Print**: Allows you to print a list of the items that appear in the Site RRL for the desired RRL type.

### 2.2.1.1 Add Resource

**To add an RRL item:**

**Step 1**
From the AIM I main menu; select the **Utility** menu item and the **Site RRL** sub-menu item. Or, click on the RRL icon.

**Step 2**
Click on the folder for the type of resource required, select the **Options** menu item and the **Add Resource** option or right click and select the **Add** option.

**Step 3**
Fill in the fields required for the resource. When you enter Unit Cost data, keep in mind that AIM will automatically add the dollar sign in the printout.

With the exception of Publications, which require Document Number and Title entries, AIM I requires an entry in the first field of each type and the rest of the fields are optional.

For IMM resources the **Add** option will open the IMM window from which you can select the **Options** menu item that provides the following options:

- **Display Media** full screen for an IMM highlighted,
- **Select File** to add a resource,
- **Rename File** to edit if desired or clear a conflict with another IMI, and
- **Remove File** to remove a conflicting file.

The IMM folder is divided into sub-folders based on the type of file associated with the resource. All IMM will appear when the main IMM folder is selected. If you select a sub-folder AIM filters out the IMM to display only those that fit in the sub-folder.
AIM has built-in support for the IMM file types listed below. This means that files of this type, when selected, will display in the AIM internal viewer (the display on the RRL, DP, RIA screens, as well as the viewer that is displayed when using the Display Media menu item on these screens).

However, a user is able to select any type of file they wish (i.e. HTML, PDF, MOV, DOC, etc.). These files will be treated like any other file in the sense that the IMM will be linked to it. AIM will make a copy in the Media directory, etc.

The only difference in picking a file without built-in support is the IMM display on the DP, RIA, and RRL screens is undefined (for example, picking a PDF or MOV file will show the file's icon, but picking a Word document shows the content of the first page of the Word file). Also, when you use the Display Media menu to display these files, they will open up in their native application. (So displaying a PDF will open up Adobe Acrobat reader).

File types with built-in support in AIM:

**Animations**
- .flc FLC Animation
- .ani Animation
- .swf Shockwave

**Audio**
- .wav WAV Audio
- .mid MIDI Sequence
- .rmi MIDI Sequence
- .au AU Audio

**Graphics**
- .jpg JPEG Image
- .bmp Windows Bitmap Image
- .eps Encapsulated PostScript
- .pcx PCX Image
- .ico Icons
- .cur Cursors
- .cgm Computer Graphics Metafile
- .drw Micrografx Designer
- .dgn DGN
- .plt PLT Graphic
- .wpg WordPerfect Graphic
- .png Portable Network Graphics
- .gif GIF
- .tiff TIFF

**Internet**
- http:// Web Address
- https:// Web Address
2.2.1 Modify/View Resource

To modify an RRL item:

Step 1 From the AIM I main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.

Step 2 Click on the appropriate resource folder.

Step 3 Click on the item you wish to modify/view.

Step 4 From the Site RRL window; select the Options menu item and the Modify/View Resource option.

Step 5 Use the Tab key to move to the desired field and enter the desired modifications.

NOTE: If an item is cited in currently approved baseline material, it cannot be modified.

Step 6 Select the Edit menu item and the Save option to save your entries.

Step 7 Select Exit to return to the Site RRL window.
2.2.1.3 Delete a Resource

To delete a resource item:

Step 1 From the AIM I/II main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.
Step 2 Click on the RRL type required and click on the item you want to delete.
Step 3 From the Site RRL window select the Options menu item.
Step 4 Select the Related Materials option and sequentially select the TPP and Course options to determine whether the item is currently cited in training material. AIM I/II will present a list of TPPs/Courses under development or approved that cite the RRL item.
Step 5 Select the Delete Resource option.
Step 6 At the prompt Delete RRL XXX...? select Yes to delete the item from the database or No to return to the Site RRL window.

NOTE: If the item is cited in a TPP/Course, AIM I/II will mark the item as ‘deleted’, remove it from the Site RRL display, and flag the item in any Course under development. Marked for deletion items cannot be selected in a TPP/Course, but they will continue to appear in TPPs/courses where they have been selected. A TPP/Course cannot be approved if it cites a resource that is marked for deletion.

Step 7 Select Exit to return to the AIM II main menu.

To restore a marked for deletion RRL item:

Step 1 From the AIM I/II main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.
Step 2 From the Site RRL window select the Contents menu item and the Resources Marked for Deletion sub-menu item.
Step 3 Click on the RRL type required and click on the item you want to undelete.
Step 4 Select the Restore Resource option.
Step 5 At the prompt Do you want to make resource XXX... active? select Yes to restore the item to the database or No to return to the Site RRL window.
Step 6 Select Exit to return to the AIM II main menu.

2.2.1.4 Grant Privilege

The Grant Privilege option allows the AIM User who has been assigned this privilege to assign Edit and Grant privilege to other AIM Users for the resource item highlighted. This option gives the AIM Administrator the privilege to assign Edit, Grant, Approve, Clear In Use, and Maintain/Delete RRL privileges to AIM Users from the Site RRL.

To grant privileges to a user for a resource item:

Step 1 From the Site Resource Requirements List window select the folder where the resource is located and highlight the resource item in the list.
Step 2  Select the **Options** menu item and the **Grant Privileges** option. AIM I will open the Grant Privileges for RRL window.

Step 3  Highlight the AIM User to be granted privilege(s).

Step 4  From the list of enable Privilege Attributes check the box(s) next to the privilege desired for the user.

Step 5  Select the **Edit** menu item and the **Save** sub-menu item.

Step 6  Select the additional users and privileges by repeating Steps 3 through 5. When complete; select the **Exit** menu item to return to the Site RRL window.
2.2.1.5 Replace an IMM Item

The Replace option allows the Administrator to replace an IMM if an IMM item is in a conflicting state with another IMM item. Allows you to replace an IMM in the database with another IMM item in the list and provides the option of deleting the item from the Site RRL once replaced.

To Replace an IMM item:

Step 1 Click on the IMM sub-folder for the IMM type and highlight the IMM item you want to replace. The Replace Option will be enabled if a flag icon is present for the IMI, indicating the IMM is in a conflicting state.

NOTE: Replace, Replace With, and Cancel Replacement menu items appear when you right-click on an RRL item as well as under the Options menu item.

Step 2 Select the Options menu item and the Replace option.

Step 3 If the item is cited in an approved course the software will prompt you with the question "RRL is used in an approved Course. Are you sure you want to replace RRL 'XXX'? Click on Yes to replace or No to cancel the option.

Step 4 If the item is cited in an approved training material and you clicked on Yes the software will prompt you with the statement "Select an RRL to replace it." Click on OK and click on the RRL item in the list that will replace it throughout the AIM II database. If the item is no cited in approved material the software will ask you for confirmation.

Step 5 Select the Options menu item and the Replace with option. You can also select Cancel Replacement to terminate the Replace option.

Step 6 If you selected the Replace with option you will be prompted with the question "Replace 'XXX' with 'YYY'?" Click on Yes to replace the item, No to select a different item, or Cancel to terminate the Replace option.

Step 7 If you clicked on Yes you will be prompted with the question "Do you want to delete 'XXX' after replacement?" Select Yes to delete 'XXX' from the Site RRL or No to leave it in the Site RRL.

2.2.1.6 Display Related Materials

Display Related Material allows you to determine what Course Identification Numbers (CINs) TPP, Trainee Preparation, DP/RIAs (Topic Number, DP Number and Text of DP) Instruction Sheets (type of Instruction sheet, number, and title) that cite the selected RRL item. It will also inform you if the item is in the course RRL but hasn’t been selected in the LP/TG.
To view a list of related materials:

Step 1  From the AIM I main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.

Step 2  Click on the resource folder containing the RRL item and highlight the RRL item.

Step 3  Select the Options menu item and the Display Related Materials option.

Step 4  AIM will open a Results window that will contain all the folders that have links to the RRL item. You can Print Preview (Save as PDF) or Print the results.

Step 5  Select Exit to return to the Site Resource Requirements List window.

2.2.1.7 Flag Related Materials for Maintenance Action

The Flag Related Materials option provides the user the capability to flag an RRL item in a TPP or course under development or maintenance for possible maintenance action, (e.g., received a revision to a reference publication used in existing curricula). Flags will be generated in the TPP/Course RRL and in the LP/TG where the item is selected in a RIA/Instruction Sheet.

NOTE: Flagging an approved course will change the appearance of the course in the Course Select menu to magenta. The flags and explanations for an approved, magenta, course can only be viewed after a change or revision is created for the course.

To flag related materials for maintenance action:

Step 1  From the AIM I main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.

Step 2  Click on the resource folder containing the RRL item and highlight the RRL item.

Step 3  Select the Options menu item and the Flag Related Materials option.

Step 4  Enter the maintenance text, in the RRL Maintenance Text window, that you want to accompany the flag for the RRL item selected.

Step 5  Select the Edit menu item and the Save option to save your entry.

Step 6  From the Site Resource Requirements List window; select the Exit menu item to return to the AIM I main menu.
2.2.1.8 Display Unused Resources

The Display Unused Resources option presents a list of all resources in the Site RRL that have not been selected in any training material in the database. The items are listed by the type of resource folder in the Unused Items window. The item field entries in the Site RRL can be viewed for accuracy or the item(s) can be deleted from the Site RRL.

2.2.1.9 Search the Site RRL for a RRL Item

The Search Site RRL option allows you to search the entire Site RRL for an item. No matter which resource folder is selected, the search will be conducted in all types. Identify the item by Title/Number and the software will provide a list of the items found that match the entries and identify the RRL type they are located in for selection.

To search the Site RRL database for an RRL item:

Step 1 From the AIM I main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.

Step 2 From the Site Resource Requirements List window; select the Options menu item and the Search Site RRL option. AIM will open the Search RRL window.

Step 3 Enter the Title/Number of the item desired and click on Find to initiate the search. AIM I will search the database and present a list of the items that match the Title/Number information entered and identify the type of RRL item each is.

Step 4 Double click on the item desired and AIM will open the window for the RRL type of the item and the item will be highlighted.

2.2.1.10 SCORM Metadata

The SCORM Metadata option allows the user to edit the Metadata categories of the IMM Asset for use in developing SCORM compliant Metadata files. Refer to Appendix F for more information on SCORM.

2.2.1.11 Explain Flag

The Explain Flag option is used in conjunction with an IMM item that has one or more icons to the left of its Designator. The Explain Flag option and button displays the reason behind the icon on an IMI. For conflicting IMIs, it also lists the nature of the conflict(s), and the IMIs that it conflicted with.
There are three types of icons that could appear for an IMI:

- A **question mark** indicates that the file associated with an IMM is missing.
- A **pencil** indicates that the file associated with an IMM has been modified since it’s been added to the AIM Media library.
- A **flag** indicates that an IMM conflicted with another IMM during import.

### 2.2.1.12 Print Preview a List of all RRL Items of a Type

**To print preview a list of all RRL items of a type:**

1. **Step 1** From the AIM I main menu, select the **Utility** main menu item and the **Site RRL** sub-menu item. Or, select the RRL icon.

2. **Step 2** Highlight the resource folder required.

3. **Step 3** From the Site RRL window select the **Options** menu item.

4. **Step 4** Select the **Print Preview** option. AIM I will present a screen of the Site RRL as it would appear in printout form. Use the buttons at the bottom of the screen to scroll right and left and the buttons on the right of the screen to scroll up/down.

5. **Step 5** If you want a printout, select the **Print** menu item and, from the Print Setup window, select **OK**.

6. **Step 6** Select **Exit** to return to the Site RRL window.

7. **Step 7** Select the **Exit** menu item to return to the AIM I main menu.

### 2.2.1.13 Print a List of all Resource Items of a Type

1. **Step 1** From the AIM I main menu, select the **Utility** menu item and the **Site RRL** sub-menu item. Or, select the RRL icon.

2. **Step 2** Highlight the resource folder required.

3. **Step 3** From the Site RRL window select the **Options** menu item.

4. **Step 4** Select the **Print** option.

5. **Step 5** From the Print Setup window select **OK** to print.

6. **Step 6** Select the **Exit** menu item to return to the AIM I main menu.
2.2.1.14 Clearing a Conflicting State on an IMI

You can use any of the following actions to clear the conflicting state of an IMM in the Site RRL:

- Delete the IMM that is conflicting with the Imported IMI. (You cannot delete the conflicting IMM itself, because it is used in a Course).
- Modify the IMM that is conflicting with the Imported IMI. (Modifying an IMM includes changing its designator, title, selecting a new file, or renaming the existing file).
- Modify the conflicted IMM itself. AIM will allow the modification of a conflicted IMM even if the RRL is approved, and/or used in an approved course.
- Use the Replace command to replace one IMM with another. Replacing a conflicted IMM with another IMM (normally the conflicting IMI) will clear the conflict. You can replace an IMM with a conflicted IMI, but ONLY if the action would remove the conflict. Conflicted IMIs cannot be cited in any Course other than the one it was Imported with.

2.3 Graphics Utility

Selecting the Graphics utility opens the Graphics window, which lists all the graphics identified in the system with a description and width and height information. The Graphics window offers the following main menu options:

- Options
- Edit
- Exit
- Help

2.3.1 Graphics Option Menu Item

The Options menu item pertains to the selected graphic. It contains the following options:

- Add Graphic
- Modify Graphic
- Delete Graphic
- Replace Graphic
- View Graphic
- Find Graphic
- Display Unused Graphics
- Related Courses
- SCORM Metadata
2.3.1.1 Add Graphic Option

The **Add Graphic** option presents an Open window that allows you to identify the location of a graphic (drive, directory, and filename) you want to add to the Graphics list. Once you have identified the graphic, AIM I will present the Select Graphic window, which allows you to select the graphic file you want to add. If the graphic isn’t a JPG file AIM I will convert it to a JPG file when you add a description to the Graphics Utility and Save it to the database.

AIM I will accept the following types of windows compatible graphics:

- Computer Graphics Metafile, cgm
- Cursors, cur
- DGN, dgn
- GIF, gif
- Compressed GIF, lzw
- Icons, ico
- JPEG Image, jpg
- LZW-compressed GIF and TIFF graphic files
- Micrografx Designer, drw
- PCX Image, pcx
- PLT Graphic, plt
- Portable Network Graphic, png
- TIFF, tiff
- Windows BMP Image, bmp
- WordPerfect Graphic, wpg
- Encapsulated PostScript, .eps

Once you have identified the graphic, AIM I will present the Select Graphic window, which allows you to select the graphic file you want to add. AIM I will read the directory/folder you select and locate all the graphics in that directory/folder that are in the file format you specify, or all files.

To select a graphic, either double-click on its File name or type the name of the graphic in the File Name block. Click on the OK button. The Select graphic window will then open.

All graphics that are selected for the AIM database are converted to JPG files.

**NOTE:** If the selected graphic appears unacceptable for use in the Trainee Guide, try exporting the same graphic from your graphics workstation in Encapsulated Post Script (EPS) format using "EPS No header or Preview" which may sharpen the graphic to an acceptable quality.
The Select Graphic window contains the following menu items:

- **Options**
- **View**
- **Exit**
- **Help**

The **Options** menu item offers the following options:

- **Open**: Allows you to open a different file by returning to the Open window.
- **Select**: Allows you to add the displayed graphic to the AIM I graphics database.
- **Printer Setup**: Accesses the Windows Printer Setup dialog box. For more information on the Windows printer functions, refer to the MS-Windows User’s Guide.
- **Print Option**: Allows you to print the graphic on the connected printer.

**Selection of the Graphics View Menu Item**: The **View** menu item allows you to view the graphic selected on screen. It contains the following options:

- **Actual size**
- **Fit to Frame**
- **Zoom**
  - The **Actual size** option allows you to view the graphic in its actual size. Double clicking on a portion of the graphic will allow you to zoom in on that portion of the graphic.
  - The **Fit to Frame** option allows you to expand the graphic to fill the frame of the window.
  - The **Zoom** option allows you to vary the size of the graphic from 50% to 400% and is enabled when the **Actual size** option has been selected.

Once you have determined that this is the graphic you want, select the **Options** menu item and the **Select** option. This will select the graphic, load it into the Graphics library, and return you to the Graphics window. Enter a description of the Graphic in the text field and select the **Edit** menu item and the **Save** sub-menu item to save the Graphic and its description to the database.

### 2.3.1.2 Modify Graphic Option

The Modify Graphic option permits you to crop, resize, invert, and rotate a graphic that is contained in the Graphic library. The **Edit** menu item contains a **Save As** sub-menu item, which provides you with the ability to modify an existing graphic and save it as a different graphic.

The **Crop** option presents a Resizing window that allows you to place a box around the graphic and remove white space or place a box around a portion of the graphic that is desired and edit the graphic file.

**To Crop a graphic:**

Step 1: From the Graphics window select the **Options** menu item and the **Modify Graphic** option. AIM I will open the Resizing window.
Step 2 Select the **Options** menu item and the **Crop** option. A cross will appear in the window when you select the **Crop** option.

Step 3 Position the cross in the upper left hand corner above the portion of the graphic desired, click and hold the left mouse button, drag the box around the graphic to encompass the portion desired, and release the left mouse button.

Step 4 Select the **Edit** menu item and perform one of the following:

a. Select the **Save** sub-menu item to save the modified graphic to the same file location.

b. Select the **Save As** sub-menu item to save the modified graphic to a different file. Enter a new description for the graphic in the *Description of Graphic* window and click on the **Save** button to add the graphic to the Graphics library.

Step 5 Select the **Exit** menu item to return to the Graphics window.

The **Resize** option allows you to reduce the size of the graphic by 10% each time it is selected. This option will reduce the quality of the graphic image and it is recommended that you print the graphic after each resizing, before you save it to the database, to verify the quality is satisfactory. There is no option to enlarge the graphic once it has been reduced using the **Resize** option.

**To Resize a graphic:**

Step 1 From the Graphics window select the **Options** menu item and the **Modify Graphic** option. AIM I will open the Resizing window.

Step 2 Select the **Options** menu item and the **Resize** option.

Step 3 Each time you select the **Resize** option a message will appear informing you that you are about to decrease the size by 10%. To continue, either click on the **OK** or **Cancel** button.

Step 4 If you clicked on the **OK** button: select the **Edit** menu item and perform one of the following:

a. Select the **Save** sub-menu item to save the modified graphic to the same file location.

b. Select the **Save As** sub-menu item to save the modified graphic to a different file. Enter a new description for the graphic in the *Description of Graphic* window and click on the **Save** button to add the graphic to the Graphics library.

Step 5 Select the **Exit** menu item to return to the Graphics window.
To Invert a graphic:

The Invert option is required if the graphic is a negative and you want to make it a positive in the graphics library.

Step 1  From the Graphics window select the Options menu item and the **Modify Graphic** option. AIM I will open the Resizing window.

Step 2  Select the Options menu item and the Invert option.

Step 3  Select the Edit menu item and perform one of the following:

a. Select the Save sub-menu item to save the modified graphic to the same file location.

b. Select the Save As sub-menu item to save the modified graphic to a different file. Enter a new description for the graphic in the Description of Graphic window and click on the Save button to add the graphic to the Graphics library.

Step 4  Select the Exit menu item to return to the Graphics window.

To Rotate a graphic:

The Rotate option allows you to rotate the graphic 90, 180 or 270 degrees and save the graphic in this position for the AIM I Graphics database.

Step 1  From the Graphics window select the Options menu item and the **Modify Graphic** option. AIM I will open the Resizing window.

Step 2  Select the Options menu item and the Rotate option.

Step 3  Select 90 Degrees, 180 Degrees, or 270 Degrees sub-menu item.

Step 4  Select the Edit menu item and perform one of the following:

a. Select the Save sub-menu item to save the modified graphic to the same file location.

b. Select the Save As sub-menu item to save the modified graphic to a different file. Enter a new description for the graphic in the Description of Graphic window and click on the Save button to add the graphic to the Graphics library.

Step 5  Select the Exit menu item to return to the Graphics window.

2.3.1.3 Delete Graphic Option

The Delete Graphic option allows you to delete the graphic highlighted in the Graphics window. If a graphic is used in an approved course it cannot be deleted.
2.3.1.4 Replace Graphic Option

The Replace Graphic option allows you to replace the graphic highlighted in the Graphics window with another graphic. Wherever this graphic is called out, in Instruction Sheets in the AIM I database, the graphic will be replaced with the new graphic. If a graphic is used in an approved course it cannot be replaced.

The graphic file selected must have an appropriate file name extension.

2.3.1.5 View Graphic Option

The View Graphic option, which you may select after you have highlighted a desired graphic in the Graphics window, presents the Select Graphic window.

2.3.1.6 Find Graphic Option

In a very large database that contains many graphics, it is easier to use the Find option to highlight the desired graphic than to page through the list in the Graphics window.

To find a graphic:

Step 1  Select the Utilities menu item and the Graphics option or click on the Graphics icon. AIM I will present the Graphics window.

Step 2  Select the Options menu item and the Find option. AIM I will present the Find window.

Step 3  Enter the description of the graphic desired in the Find Graphic field. Notice that the field contains a wildcard (*). As you enter the description, the graphics that start with that description up to the * are displayed in the list below.

Step 4  When you have identified the desired graphic, you can select it one of two ways:

a. Click on the Select menu item. AIM I will return you to the Graphics window and the selected graphic will be highlighted.

b. From the list below the Find Graphic field, double click on the desired graphic. AIM I will return you to the Graphic window and the selected graphic will be highlighted.

2.3.1.7 Display Unused Graphics

The Display Unused Graphics option presents a list of all graphics that have not been selected in any training material in the database. The items are listed by the Description in the Unused Items window. The graphic can be viewed for accuracy or the graphic(s) can be deleted from the Graphics Utility.
2.3.1.8 Related Courses Option

The Related Courses option will reveal a list of courses that the graphic is linked to and the instruction sheet(s) that cite the graphic within the course. The list will appear in a Windows Explorer format and can be printed to review the material and analyze which courses will be affected by exercising the Replace option or inform you which courses need to be accessed to delete a graphic. If a graphic is not linked to a course it can be deleted using the delete option from the Graphics Utility.

2.3.1.9 SCORM Meta-Data

The SCORM Meta-Data option allows the user to edit the SCORM categories of the Asset for use in developing SCORM compliant Meta-Data files. Refer to Appendix F for more information on SCORM.

2.4 Admin Utility

The Admin Utility sub-menu item calls the Administration Utility window. Through the Administration Utility window, an AIM Administrator can:

- Grant privileges to a user for a specific PPP, TPS, TPP, Test Module for a specific version of a course, Course, or RRL item.
- Approve a PPP, TPS, TPP, Course, or RRL item(s).
- Approve and Unapprove Cancellation TPPs developed for courses that reside in AIM.
- Reset Migration Status for courses migrated to AIM I from Oracle database using UNIX.
- View In Use Information and Clear in use flags.
- Create, Import, or Delete Extract files for SGML-based, ARCI, PDF-based, PMS, Raster Tech Manuals, and XML-Based IETMs. Refer to Appendix D to develop IETM Extract files.
- Clear Conflict State of IMM in a course that is in conflict with another course.

When the Administration Utility option is selected from the AIM I main menu, the Administration Utility window (Figure B-2) opens.
The Administration Utility window contains the following menu items:

- **Options**
- **Contents**
- **Exit**
- **Help**

### 2.4.1 Administration Utility Options Menu Item

The **Options** menu item offers the options to:

- **Find** a training material item of the type selected from the Contents menu item,
- **Show In Use Items Only** to minimize the search for in use materials,
- **Grant Privilege** for the development/maintenance of PPP, TPS, TPP, Course, and RRL items,
- **Approve** PPP Table, TPS, TPP, Course and selected RRL items,
- **Approve** and **Unapprove** options for Cancellation TPPs developed for courses that reside in AIM,
- **Show In Use Information** option to identify who the item is In Use by and the date and time the training material item was accessed.
- **Reset Migration Status** of a TPS or Course after migration and editing from an Oracle/UNIX platform,
- **Clear In Use** flags for the specified training material, and
- **Clear Conflict State** for an IMM in a course.
First, select one of the following Contents menu sub-items:

- **PPP**
- **TPS**
- **TPP** (The Type field displays the type of the TPP [N(ew), R(esion), M(odification), C(ancellation)]
- **Course**
- **Testing**
- **LP/ECG/TG**
  - **Topic**
  - **TG Sheet**
- **RRL**
- **IETM**
- **Security Markings**
- **User Tracking**

AIM I will then list all the items in the database for the type of training material selected. You can scroll through the list and click on the training material desired or select the Options menu item and the Find option and enter the identifier for the item desired. Once the item is highlighted in the list the following options can be selected:

- **Grant Privilege** for unapproved PPP Table, TPS, TPP, Course or RRL item and privilege to develop test questions for approved PPP Tables.
- **Approve**. The following constraints will be imposed by AIM I before a training material item can be approved:
  - A TPP cannot be approved until the approval date is entered on its Cover Page.
  - A PPP cannot be approved until the approval date is entered on its Cover Page.
  - A TPS cannot be approved until:
    - The approval date has been entered on its Cover Page
    - If a change or revision: The System Flags have been removed from the TPS.
  - A Course cannot be approved until:
    - All its RRL items have been approved
    - A promulgation date has been entered on the TCCD and LP cover pages
    - If a change or revision: The System Flags have been removed from the course.
- **Approve Selected RRL** to approve all the RRL items selected.
- **Unapprove** to unapprove the selected Cancellation TPP.
- **Testing** to select the course and grant privilege for testing materials to an individual to View, Edit, Lock, Grant, Approve/Unapprove, Remove Flag, or Maintain/Delete Tests.
- **Reset Migration Status** to change the status of the material migrated from UNIX AIM from “M” to the status of the material as it appeared in UNIX AIM (See Appendix C for further explanation).
- **Clear In Use** to clear an In-Use flag on an item so that it may be accessed.
- **Clear Conflict State** to clear an IMM conflict between a course Imported and another course(s) in the database.

The LP/TG option is used for clearing an In Use flag for Courses, Topics, and TG Sheets. The Topics, and TG Sheets options do not appear until the LP/TG option is selected.
2.4.1.1 Importing IETM Extract Files

Adding an IETM to the AIM I database is a two-step process. First the IETM structure data must be extracted to an AIM I compatible file (refer to Appendix D). Second, the extracted IETM structure data is then imported into the AIM I database.

**To import IETM extract files to the Site RRL perform the following:**

**Step 1** From the AIM I main menu click on the Admin icon.

**Step 2** Click on the **Contents** menu item and select the **IETM** sub-menu item.

**Step 3** From the IETM window, click on the **File** menu item and the **Import** sub-menu item.

**Step 4** Click on the location of the drive, directory/folder, and file name of the extraction file and click on **OK/Open**.

AIM I will import the extraction files of the IETM into the Site RRL and the fields of the IETM window will be populated with IETM information, including the IETM name and version. The AIM User can now select the IETM for a TPP or TCCD. The IETM must be selected in the Course RRL to be cited in a DP/RIA or Instruction Sheet.

**NOTE:** The fields containing the IETM information can be edited if the location of the viewer should change. Refer to paragraph 2.4.1.2 for mapping the location of the IETM Viewer.

**Step 5** Select the **Options** menu item and the **DDE Information** option. The DDE fields that require verification are Topic Name, Application Location, Configuration Location, and Window Name. Verify the drive designator for your item correctly indicates where your IETM is located for the browser. If incorrect edit as necessary. When completed editing **Exit** and save your entries to the database.

**NOTE:** If you import a course that has IETM links made, and therefore has IETM extraction file(s) attached, you will need to review the DDE Information and make the same editing changes as in Step 5 to launch and display the IETM data.

**To add a later version of an IETM to the Site RRL:**

**Step 1** Select the **Utilities** menu item from the AIM main menu and the **Admin Utility** from the drop-down menu.

**Step 2** From the Administration Utility window select the **Contents** menu item and select the **IETM** sub-menu item. AIM will open the IETM window.
Step 3  From the IETM window, click on the **File** menu item and the **Import** sub-menu item.

Step 4  Click on the location of the drive, directory/folder, and file name of the extraction file and click on **OK/Open**.

AIM I will import the extraction files of the IETM into the Site RRL and the fields of the IETM window will be populated with IETM information, including the IETM name and version.

**NOTE:** The fields containing the IETM information can be edited if the location of the viewer should change. Refer to paragraph 2.4.1.2 for mapping the location of the IETM Viewer.

Step 5  Click on the previous version of the IETM and select the Options menu item and the Link IETM option.

Step 6  AIM will prompt you with the question “Do you have a comparison file to use for linking these IETMs?”

If no comparison file exists answer “No” to the prompt and AIM will link the IETMs based on internal ID’s in the IETM.

The IETM comparison tool was written to address the issue of versioning and unique IDs within multiple versions of an IETM. The comparison file is generated by the developer of the IETM and lists how the IETM should be linked. The file addresses the issue of versioning and unique identification numbers within multiple versions of an IETM.

*Versioning*...The IETMs are currently not guaranteed to have version information at a granular level for the nodes. In other words, there might be an indication that IETM 1 is Version 1 and IETM 2 is Version 2, but not that individual nodes within IETM 2 are changed while other individual nodes have not been modified in Version 2 and are exactly the same as in Version 1. So, this is what the IETM comparison tool attempts to identify. The comparison tool will go through each node in IETM 2 and compare it to what is in IETM 1. If there are any text changes, it will indicate that the node is modified. It will also indicate if a node has been added in IETM 2 or deleted in IETM 2.

*Unique IDs*...One of the premises of the AIM IETM maintenance function is that the IDs for a node will be the same in both IETM Version 1 and Version 2. If this is not the case, then we cannot reference the appropriate IETM nodes in IETM Version 2 when we are attempting to generate an impact report or to update to a later IETM version. The IETM comparison tool has the capability to allow manual entry of ID changes between IETM versions. This is then reported in the IETM comparison file, so that AIM can correctly make the links between IETM Version 2 and IETM Version 1.
When you are using AIM, there is a screen that asks if you have a comparison file. If you say "Yes", AIM will ask the user to find the IETM comparison file. Then, when linking the IETM versions, AIM uses the information in the comparison file to link the IDs between the IETM versions, and store information related to whether nodes have changed between the two versions.

Step 7 Highlight the previous version IETM, select the Options menu item and the Impact Report option. AIM will open the IETM Courses window that will contain a list of all courses that cite the IETM.

Step 8 Impact reports for all the courses can be generated by selecting the Options menu item and the Select All option or an Impact Report can be generated for individual courses by clicking on the desired course and selecting the Options menu item and the Select Option.

Step 9 Select the Options menu item and the Generate Impact Report option. AIM will generate an IETM Impact Report for each course selected. The report can be viewed or printed and will contain a list of:

- Impacted RIAs,
- Impacted TG Sheets, and
- Newly added IETM nodes.

**NOTE:** Refer to the TCCD Module Chapter 6 paragraph 6.2.2, "To add a later version of an IETM to a Learning Site RRL" to complete selection of the later version IETM for the effected course(s).

### 2.4.1.2 Mapping the location of the IETM Viewer

The IETM viewer has to be mapped to the location of the IETM after installing it in the AIM database. The IETM DDE information is updated to identify the path the viewer needs to display the IETM when selected for viewing. DDE information is unique to the type of IETM identified.

**To map a SGML-Based IETM Viewer:**

1. **Step 1** Select the Utilities menu item from the AIM main menu and the Admin Utility from the drop-down menu.

2. **Step 2** From the Administration Utility window select the Contents menu item and select the IETM sub-menu item. AIM will open the IETM window.

3. **Step 3** Highlight the SGML-Based IETM to be mapped.

4. **Step 4** From the IETM window, select the Options menu item and the DDE Information sub-menu item. AIM will open the IETM DDE window.
Figure B-3. IETM DDE Window for SGML-Based

Step 5  View/select the appropriate viewer type in the IETM Viewer Type field.

Step 6  Verify/update the book name and path to the folder in the Topic Name field.

Step 7  Verify/update the path to the TMMIAPP or dtext.exe file for the IETM in the Application Location field.

Step 8  Verify/update the path to the BIN directory in the Configuration Location field.

Step 9  Select the **Edit** menu item and the **Save** sub-menu item.

Step 10 Select the **Exit** menu item to return to the IETM window.

Step 11 Select the **Options** menu item and the **View IETM** option. This will open the browser for the IETM.
Step 12 Open the IETM and highlight a viewable node. Select the Options menu item and the View option for verification that the mapping is correct.

To map an ARCI IETM Viewer:

Step 1 Select the Utilities menu item from the AIM main menu and the Admin Utility from the drop-down menu.

Step 2 From the Administration Utility window select the Contents menu item and select the IETM sub-menu item. AIM will open the IETM window.

Step 3 Highlight the ARCI IETM to be mapped.

Step 4 From the IETM window, select the Options menu item and the DDE Information sub-menu item. AIM will open the IETM DDE window.

Step 5 View/select the appropriate viewer type in the IETM Viewer Type field.

Step 6 Select the Edit menu item and the Save sub-menu item.

Step 7 Select the Exit menu item to return to the IETM window.
Step 8  Select the **Options** menu item and the **View IETM** option. This will open the browser for the IETM.

Step 9  Open the IETM and highlight a viewable node. Select the **Options** menu item and the **View** option for verification that the mapping is correct.

**To map a PDF Documents IETM Viewer:**

Step 1  Select the **Utilities** menu item from the AIM main menu and the **Admin Utility** from the drop-down menu.

Step 2  From the Administration Utility window select the **Contents** menu item and select the **IETM** sub-menu item. AIM will open the IETM window.

Step 3  Highlight the PDF Documents IETM to be mapped.

Step 4  From the IETM window, select the **Options** menu item and the **DDE Information** sub-menu item. AIM will open the IETM DDE window.

![IETM DDE Window for PDF Documents](image)

Figure B-5. IETM DDE Window for PDF Documents

Step 5  Verify/update the location of the PDF file in the *PDF file location* field.

Step 6  Select the **Edit** menu item and the **Save** sub-menu item.
Step 7 Select the **Exit** menu item to return to the IETM window.

Step 8 Select the **Options** menu item and the **View IETM** option. This will open the browser for the IETM.

Step 9 Open the IETM and highlight a viewable node. Select the **Options** menu item and the **View** option for verification that the mapping is correct.

**To map a PMS Documents IETM Viewer:**

Step 1 Select the **Utilities** menu item from the AIM main menu and the **Admin Utility** from the drop-down menu.

Step 2 From the Administration Utility window select the **Contents** menu item and select the **IETM** sub-menu item. AIM will open the IETM window.

Step 3 Highlight the PMS Documents IETM to be mapped.

Step 4 From the IETM window, select the **Options** menu item and the **DDE Information** sub-menu item. AIM will open the IETM DDE window.

![IETM DDE Window for PMS Documents](image)

**Figure B-6. IETM DDE Window for PMS Documents**
Step 5 Verify/update the location of the PMS view (PMSviewer.exe) in the Application Location field.

Step 6 Select the **Edit** menu item and the **Save** sub-menu item.

Step 7 Select the **Exit** menu item to return to the IETM window.

Step 8 Select the **Options** menu item and the **_View IETM** option. This will open the browser for the IETM.

Step 9 Open the IETM and highlight a viewable node. Select the **Options** menu item and the **_View** option for verification that the mapping is correct.

To map a Raster Tech Manuals IETM Viewer:

Step 1 Select the **Utilities** menu item from the AIM main menu and the **Admin Utility** from the drop-down menu.

Step 2 From the Administration Utility window select the **Contents** menu item and select the **IETM** sub-menu item. AIM will open the IETM window.

Step 3 Highlight the Raster Tech Manuals IETM to be mapped.

Step 4 From the IETM window, select the **Options** menu item and the **DDE Information** sub-menu item. AIM will open the IETM DDE window.

![Figure B-7. IETM DDE Window for Raster Technical Manuals](image-url)
Step 5 Verify/select the appropriate viewer type in the IETM Viewer Type field.

Step 6 Verify/update the path to ATIS Interface field.

Step 7 Select the **Edit** menu item and the **Save** sub-menu item.

Step 8 Select the **Exit** menu item to return to the IETM window.

Step 9 Select the **Options** menu item and the **View IETM** option. This will open the browser for the IETM.

Step 10 Open the IETM and highlight a viewable node. Select the **Options** menu item and the **View** option for verification that the mapping is correct.

Generating a No-Change Change

A No-Change Change (NCC) allows a user to update Approved courses to use later versions of IETMs, as long as the update does not affect the content of the Course. The user can then export the information to a file, which can be used by other users to automatically update their copy of the course.

To generate a No-Change Change file:

Step 1 Import the IETM extract file into the database and generate an Impact Report following the steps “To add a later version of an IETM to the Site RRL” above.

Before you can update a course to a later IETM, you first must generate an Impact Report for the IETM and Course. Each node that is listed as having been modified in the later version must be checked by the user to verify that the changes made to this item does not affect the course. If any item used in the Course has been deleted in the later IETM, you will not be able to perform the No-Change Change.

Step 2 Select the **Options** menu item and the **No-Change Change** option. AIM will open the No-Change Change IETM Courses window.

Step 3 Highlight the course that you want to select a later IETM into and select the **Options** menu item and the **Select** option. AIM will open the IETMs window that contains the currently selected IETMs in the course in the top pane and the later version IETMs in the bottom pane.

Step 4 On the bottom pane highlight the desired IETM, select the **Options** menu item, and click on the **Select Later IETM** option.

Step 5 From the No-Change Change IETM Courses window select the **Options** menu item and the **Export No-Change Change Data** option.
The program will check to see that an Impact was generated on the Course for this IETM. If no one ran an Impact Report, an error will occur. Remember, you cannot perform a No-Change Change without generating an Impact Report on the Course.

If an Impact Report has been run, you will be asked to confirm the No-Change Change action. Once confirmed, the program will verify that the RIAs and TG Sheets citing the IETM are unaffected.

AIM will open the No-Change Change Information window. Select the Exit menu item and AIM will create the file.

**To import a No-Change Change (*.ncc) file:**

1. **Step 1** Select the **Utilities** menu item from the AIM main menu and the **Admin Utility** from the drop-down menu.

2. **Step 2** From the Administration Utility window select the **Contents** menu item and the **IETM** option. AIM will open the IETM window.

3. **Step 3** From the IETM window select the **Options** menu item and the **No-Change Change** option. AIM will open the No-Change Change IETM Courses window.

4. **Step 4** Highlight the desired course to import the No-Change Change into. Select the **Options** menu item and the **Import No-Change Change Data** option. AIM will open the No-Change Change Information window for you inspection. Exit the Information window and AIM will ask you for confirmation to Import the No-Change Change. Click on Yes to proceed or No to terminate.

**2.4.1.3 Grant Privilege**

The AIM Administrator can change/grant/revoke privileges for any AIM User for specific training material items in the database.

When the **Grant Privilege** option is selected, AIM I presents a list of all users. Highlighting the desired user will identify the privileges that individual has for the selected training material item. A check in the block indicates the user has that privilege.

**To grant privileges to a user:**

1. **Step 1** From the AIM I main menu, select the **Utilities** menu item and select the **Admin Utilities** sub-menu item. Or, select the Admin icon. AIM I will present the Administration Utility window.

2. **Step 2** Select the **Contents** menu item and select the type of training material for which privilege will be granted. AIM I will present a list of the material of the type selected.
Step 3 Highlight the desired item from the list and select the **Options** menu item.

Step 4 Select the **Grant Privilege** option. AIM I will present the user with the Grant Privilege window for the item selected.

Step 5 Click on the desired user and check the appropriate privilege blocks for the material selected.

Step 6 If more than one user is to be granted privilege, select the **Edit** menu item and the **Save** option to save your entries and repeat Step 5 and 6 or the **Cancel** option to remove your entries. If the **Cancel** option is selected AIM I will prompt the user with "All changes will be lost. Are you sure you want to cancel?". Select **Yes** if you want to cancel and exit to the Administration Utility menu or **No** to return to the Grant Privilege window.

Step 7 If complete, select the **Exit** menu item. At the prompt “**Would you like to save the changes?**” select:
   a. **Yes** to save the changes to the list and exit to the Admin Utility menu
   b. **No** to delete the changes made and exit to the Admin Utility menu
   c. **Cancel** to return to the Grant Privilege window.

### 2.4.1.4 Approve Training Material

In order to approve a TPP, PPP, or TPS, the Issue Dates must be entered on the TPP, PPP or TPS window for the item to be approved. Attempting to approve a TPP, PPP, or TPS without first entering this data into the Issue Date field will result in a message that no entry has been made, and you will be required to:

- Exit the Utility portion of AIM I
- Select the appropriate training material item
- Unlock the item
- Enter the Issue Date in the field provided on the Cover Page
- Lock the item.

In order to approve a TPS or a Course/LP/TG that has undergone maintenance, all system flags (@) that remain in these items must be removed.

**To remove system flags:**

Step 1 From the AIM I main menu, select the TPS or Select Course icon.

Step 2 Highlight the TPS/Course desired, select the **Options** menu item and the **Remove System Flag** option.

Step 3 Select the **Exit** menu item to return to the AIM I main menu.
To approve a PPP, TPS, TPP, or Course:

Step 1 From the AIM I main menu, select the Utilities menu item and select the Admin Utility sub-menu item. Or, select the Admin icon. AIM I will present the Administration Utility window.

Step 2 Select the Contents menu item and select the type of training material that you are going to approve. AIM I will present a list of the material of the type selected.

Step 3 Highlight the desired item from the list and select the Options menu item.

Step 4 Select the Approve option for PPP, TPS, TPP, or Course. AIM I will ask, Approve (item selected)?

NOTE: If approving a TPP or Course and there are RRL items that are not approved AIM I will inform you that there are unapproved RRL items and when acknowledged will present you with a list of the items in the RRL that are not approved. You can select and approve items from this window. You cannot approve a TPP or TCCD until all RRL items cited in their respective RRLs have been approved.

Step 5 To approve the item, select Yes to the prompt to approve the item or No to abort. Repeat Steps 3 through 5 for each item that requires approval.

Step 6 Select Exit to return to the Administration Utility window.

Step 7 Select Exit to return to the AIM I main menu.

To approve one or more RRL items:

Step 1 From the AIM I main menu, select the Utilities menu item and select the Admin Utility sub-menu item. Or, select the Admin icon. AIM I will present the Administration Utility window.

Step 2 Select the Contents menu item and select RRL. AIM I will present a list of all unapproved items in the Site RRL.

Step 3 Select the items that you want to approve from the list by either double clicking on the item or click on the item and select the Options menu item and the Select RRL option.

Step 4 After the item(s) have been selected, select the Options menu item and the Approve Selected RRL option.

Step 5 You will receive the prompt “Are you sure you want to approve all the selected RRLs? This action cannot be undone!” Click on Yes to approve or No to abort the approval.

Step 6 Select Exit to return to the Administration Utility window.
Step 7 Select **Exit** to return to the AIM I main menu.

### 2.4.1.5 **Clear In Use Flag**

The In Use flag prevents more than one person from writing to the same fields in the database at the same time. If you are working on an AIM I training material item and are forced to exit because of an unusual occurrence (e.g., a power failure), the In Use flag remains set for the training material item and prevents you from resuming the task last accessed. However, the **Clear In Use** flag option lets you reset the In Use flag.

**To clear an In Use flag:**

1. **Step 1** From the AIM I main menu, select the **Utilities** menu item and select the **Admin Utility** sub-menu item. Or, select the Admin icon. AIM I will then present the Administration Utility window.

2. **Step 2** Select the **Contents** menu item and select the type of training material from which you wish to remove the In-Use flag.

3. **Step 3** If the database contains a large number of courses you can select the **Options** menu item and the **Show In Use Items** option to narrow your search. When this option is selected only the items in use will appear. Highlight the desired item from the list and select the **Options** menu item.

4. **Step 4** Select the **Options** menu item and the **Show In Use Information** option to verify that you are the only AIM User for which the In Use flag is set. Select **Exit** when verified.

5. **Step 5** Select the **Clear In Use** option (*Figure B-8*). AIM I will ask you to confirm your intention to remove the flag.
Step 6 Select Exit to return to the AIM I main menu.

2.4.1.6 Clear Conflict State

In the Admin Module and the Course Select window the courses that have IMM that are in conflict are displayed in red. When a course is highlighted that is red and the conflicting IMM has been edited or removed the Clear Conflict State option will be enabled to change the Course to a normal foreground color display, remove the conflict and allow the courses to be edited/maintained. Refer to Import/Export Utility (Generate Import IMM Report, paragraph 2.11.2.3) for definitions of conflicting IMM states. IMM items will also be in red in the RRL if in a conflict state.

2.4.1.7 Unapprove a Cancellation TPP:

A Cancellation TPP created from a course contained in the AIM database can be unapproved.

To Unapprove a Cancellation TPP:

Step 1 From the AIM I main menu, select the Utilities menu item and select the Admin Utility sub-menu item. Or, select the Admin icon. AIM I will present the Administration Utility window.

Step 2 Select the Contents menu item and select the TPP sub-menu item.
Step 3  Highlight the Cancellation TPP to be Unapproved. Select the **Options** menu item and the **Unapprove** option.

### 2.4.1.8 User Tracking

This option is only available to AIM Administrators and is intended to be used as a security measure to determine user and event activity. This option should only be used by experienced AIM Administrators. The User Tracking option is used to display user events, due to memory constraints only 10,000 events will be displayed. To display these events follow these steps:

1. From the Main AIM screen select Utilities
2. From the Utilities drop down menu bar select Admin Utilities
3. From the Admin Utilities screen menu bar select Contents
4. From the Contents drop down menu select User Tracking
5. The User Event Display screen is displayed, it is now possible to scroll through the list of events displaying each event's ID, the User Name associated with the event, and the event text. When highlighting an event detailed information will be displayed on the right side of the User Event Display screen.

There are three options available from the User Event Display screen, they are:

- **Filter** - The Filter option allows the administrator to filter the contents of the User Events Display screen. The filtering available is as follows:
  - **User** - Filter by User Name.
  - **Date Range** - Filter by a range of dates.
  - **Types** - Filter by the following Event Types
    - Successful or Unsuccessful Login Attempts
    - Data Viewing/Saving, view events for a specific type of data viewed or saved.
  - **Form** - Search based on a specific database form.
  - **Text Search** - Search based on specific text.

- **Archive** - The Archive option will create a .zip file with a list of the events selected, when the Archive option is selected a dialog box requesting an End Date for the archive will appear, all events older than the End Date will be archived.

- **Output to Excel** - The Output to Excel option will create a .csv file of all events. This output is NOT restricted to the 10,000 events that are displayed, the .csv file will contain all events, or filtered events if filtering is used.

### 2.5 Delete Proposed Training Material (TM) Utility

The **Delete Proposed TM** sub-menu item allows an individual that has Maintain/Delete privilege for the training material item, to delete training materials in the database that have not achieved Approved status and are not cited in other current training material.

In the receipt of proposed changes from facilities that are not the CCMM, it is often necessary to delete the proposed training material.
Unlike the Delete option in the TPS and Select Course windows of AIM I, the **Delete Proposed TM** sub-menu item can be used to delete all associated RRL items, Sites, Agencies, and Graphics, from the AIM I database, unless the items are cited in other training materials.

**NOTE:** AIM I will not execute the Delete Proposed Training Material option if an In-Use Flag is set for the training material you have selected. Review associated materials to ensure no In-Use Flags exist.

When a TPS is selected for deletion, its associated unapproved PPP tables are also deleted (provided they are not cited in any other TPS). When a course is deleted, so are its associated unapproved TPS and PPP tables (provided they are not cited in any other course).

The **Delete Proposed TM** sub-menu item calls the Delete Proposed Training Material utility, from which you can select an **Options** menu item that contains the following:

- **PPP**
- **TPS**
- **Course/LP/TG**
- **Find**
- **Related PPP**
- **Related TPS**
- **Delete**

**PPP**, **TPS**, and **Course/LP/TG** allow you to select the type of training material.

**Find** allows you to find the desired item in the list.

**Related PPP** and **Related TPS** allow you to view the related materials for the item highlighted.

**Delete** allows you to delete the training material highlighted as well as all training material associated with it, including RRL items, sites, agencies, and graphics.
To delete a PPP, TPS, or Course/LP/TG:

Step 1  From the AIM I main menu, select the Utilities menu item and select the Delete Proposed TM sub-menu item. Or, select the Delete icon. AIM I will present the Delete Proposed Training Material window.

Step 2  Select the Options menu item and the type of training material (PPP, TPS, or Course/LP/TG) for deletion.

Step 3  From the list of materials highlight the training material item no longer required. If the list is extensive, select the Options menu item and the Find option. Type in the alphanumeric designator in the Find field and Select the item desired.

Step 4  Select the Options menu item and the Related PPP if the item being deleted is a TPS or course. Select Related TPS if the item being deleted is a PPP or course.

Step 5  After reviewing the related PPP/TPS to ensure that you are not going to delete related materials unintentionally, select the Options menu item and the Delete option. AIM I will ask you for confirmation. Click on Yes to delete the item and its related material from the database. If you do not have the correct privilege AIM I will inform you and terminate the delete process.

CAUTION: If you exit this window without reviewing each of the items in the categories listed, AIM I will delete all the associated items available for deletion automatically from the Agency, Site, RRL, and Graphics portion of the database.

Step 6  AIM I will present you with the Related Support Materials to Delete window. From this window, you can select items for retention/deletion in the database.

Perform the following:
  a. Select the Options menu item and the Agencies sub-menu item.
  b. AIM I will inform you if there are no items in the list available for deletion. Highlight the item required/not required for retention in the database and select the Options menu item and one of the Select/Delete options.
  c. Repeat Steps 6a and 6b for the Agencies, Sites, RRLs, and Graphics sub-menu items.
  d. Select the Exit menu item, and AIM will delete the Training Material, less the related support material selected for retention.

2.6 Reporting

The Reporting utility allows you to generate a number of pre-formatted reports or customize reports with selected information.
Selecting the **Utilities** menu item and the **Reporting** sub-menu item, or clicking on the Reporting icon, opens the AIM Reporting window.

![AIM Reporting Window](image)

**Figure B-9. AIM Reporting: Pre-formatted Reports**

The Reports tab contains a list of reports that can be selected for pre-formatted reports.

**To create a preformatted report:**

1. **Step 1** Select the **Reports** tab and highlight the desired report.

2. **Step 2** Select the **Options** menu item and the **Generate** option. This will open the Print Preview window that will contain the report.

3. **Step 3** Selection of the **Options** menu item will provide the options to **Print** or **Save to PDF** file.

**To create a custom report:**

1. **Step 1** Select the **Custom** tab and highlight the desired item for the report.
Step 2  Pick the fields you want to display on the report by clicking on the desired boxes in the right hand grid.

Step 3  If there is a desired search criteria click on the **Add** button. AIM will open the Search Criteria window.
Step 4 Select the desired field for the software to initiate the search from the Field drop down menu.

Step 5 Select the desired condition from the Condition drop down menu.

Step 6 Enter a value of the item.

Step 7 Select the Options menu item and the Generate option. This will open the Print Preview window that will contain the report.

Step 8 Selection of the Options menu item will provide the options to Print or Save to PDF file.

The Data Output tab of the Reporting module allows you to create files that outputs:
- Text file containing the TLOs for a selected course
- rtf file containing CLOs for a selected course
- Text files for CIITA that contains the Part/Section/Topic numbers for a selected course and associated titles.
- Text files for printing out a list of PPP Tables, TPSs, or Courses in your AIM I database.

![AIM Reporting: Data Output](image)

Figure B-12. AIM Reporting: Data Output
To create a Data Output file:

Step 1   Select the **Data Output** tab and highlight the data desired.

Step 2   Select the **Options** menu item and the **Generate** option. This will open the Select Course window.

Step 3   Highlight and **Select** the desired course. The Select Output File window will open and AIM will assign a name to the file, which can be edited. In the **Save in** field select the directory in which the file will be written and click on the **Save** button.

### 2.7 RRL/Graphics Location Tool

The RRL/Graphics Location Tool allows AIM I users to search for the usage of RRLs and Graphics in their Courses. The program can search all Courses citing a Resource or Graphic or just selected Courses. It can search the entire Course or just individual areas of the Course (e.g., just find all uses of an RRL item in TG Sheets).

#### 2.7.1 Resource/Graphic Selection Window

The main window of the Location Tool is the Selected data window. From this window you select which RRL Items and/or Graphics you want to search for, and find all Courses citing the selected data. There is no limit to the number of items you can select at one time, although keep in mind that the more items selected, the longer the search process will take.

![Figure B-13. RRL/Graphics Location Tool: Selected Data](image-url)
The **File** menu has one item:
- **Open Saved Search**: This option opens a Search Results File saved from the Results screen. This file will be explained later. Once this file is open, you are returned to the results screen.

The **Options** menu has the following items:
- **Add Resources**: Displays a list of all Resource categories and allows you to select/unselect items from any category to be used in the search.
- **Add Graphics**: Displays a list of all Graphics in the AIM I database and allows you to select/unselect those to be used in the search.
- **Breakdown**: For Reference and IETM resources it allows you to narrow the search criteria to specific areas of the Resource.
- **Delete**: Removes the highlighted row from the search list.
- **Delete All**: Removes all entries from the search list.
- **View RRL**: Views the current RRLs data.
- **View Graphic**: Views the current graphic.
- **Related Courses**: This generates a list of all Courses that cite the data displayed on this screen.

### 2.7.2 Resource Selection
When you select the **Add Resources** menu item, you are taken to the Site Resource Requirements List window.

![Figure B-14. RRL/Graphics Location Tool: Resource Selection](image-url)
On the left-hand side is a list of all RRL types. When you highlight a type, all items of that type are displayed on the right-hand side. When you select a resource to search, an ‘X’ is placed in the Sel column of the grid, and a ‘+’ sign is added to the left of the type name to show that items in this category have been selected.

The Options menu has the following items:
- **View RRL**: Views the current RRLs data.
- **Find**: Allows you to search for an RRL within this type. Primary searches the second column, and Secondary searches through the third column. Selecting an item in the find screen highlights it on this window.
- **Select**: Selects the currently highlighted row.
- **Unselect**: Unselects the currently highlighted row.

You can also select/unselect items by double-clicking them with the mouse or by using the spacebar.

Once you’ve finished selecting the items to be searched, click on Exit to return to the main screen. You can return to this screen later to add/delete more Resources.

### 2.7.3 Graphic Selection

When you select the Add Graphics menu item, you are taken to the Graphics selection window. This window lists all Graphics in the Graphics library, and allows you to select/unselect Graphics.

![Figure B-15. RRL/Graphics Location Tool: Graphic Selection](image)
The **Options** menu has the following items:

- **View Graphic**: Views the current Graphic.
- **Find Graphic**: Allows you to search for a Graphic by description. Selecting a Graphic in the find screen highlights it on this screen.
- **Select**: Selects the currently highlighted row.
- **Unselect**: Unselects the currently highlighted row.

You can also select/unselect Graphics by double-clicking them with the mouse or by using the spacebar.

Once you’ve finished selecting the Graphics to be searched, click on **Exit** to return to the main window.

### 2.7.4 Reference Breakdown

When you highlight a Reference from the Selected window and choose **Breakdown** from the **Options** menu item, the RRL Breakdown window is displayed. Entering data in this window reduces the RIA search to just those RIAs that match the entries.

![Figure B-16. RRL Breakdown for a Reference](image)

When searching the RIAs for this RRL, only RIAs that match this data will be listed. Leaving a field blank means that no special searches will be done on that field (do not place an asterisk as a wild-card character into a field to search for all occurrences; it will only look for occurrences of an asterisk). Also, the search only compares the data against the breakdown data of the RIA. If you enter this data as part of the After text, it will not be found. If you leave all the fields blank (as is the default if you do not go to this screen), all citations of the Reference will be found.

In the above example, only RIAs that specify Volume 1, Chapter 3, and paragraph in the Build RIA fields for Volume, Chapter and Citation, will be found.

All fields with some data entered are searched for exact matches, except the “From Item” field. “From Item” searches for all occurrences that begin with the entered text (exact matches included). For example, if you set the “citation” to “paragraph” and “From Item” to “2-1”, then all RIAs with a paragraph citation that begins with “2-1” will be found, including 2-1, 2-1-a, 2-1(a), etc.
2.7.5 IETM Breakdown

When you highlight an IETM from the Selected window and choose Breakdown from the Options menu the IETM Breakdown window is displayed. The IETM Breakdown window displays the IETM tree structure and allows you to select which node(s) to search for.

![Figure B-17. IETM Breakdown](image)

Any number of node(s) can be selected. By selecting a parent node (for example, “IDR (Unit 4009)”) above, all child nodes are automatically searched as well. If no nodes are selected, then all citations to the IETM are found.

2.7.6 Related Courses Selection

Once you’ve selected your Resources and Graphics, choose Related Courses from the Options menu of the Resource/Graphic Selection window. This will display the Related Courses window. This screen displays all Courses that cite the selected Resources/Graphics. You can select/unselect the Courses to search as well as where in the Courses to search. [NOTE: If none of the selected Resources or Graphics is cited in a Course, a dialog box informing you of this will appear, but the Related Courses screen will not appear.]
At the top of the screen you can see four options. These are the areas where the Resources/Graphics can be used and where the Location Tool can search. Un-checking one of these areas will cause that area not to be searched.

The DP/RIA search option is a special option. Not only can you search for all RIAs that cite the selected resources, you can also determine how to display the data. The options are to display by Part, Section, Topic, or DP/RIA (click the down-arrow right of the text to see the options). If you select DP/RIA, then all RIAs that cite the resources will be found. But if you choose “Sections”, for example, then the report will only list the Sections that contain RIAs that cite the resources.

If you opt to search both the DP/RIA (or Part, Section, or Topic) and Faults, then not only are the RIAs and Faults which cite the Resources found, so are all RIAs which cite the Faults which cites the resources (these RIAs are marked on the final output with the text “(cited in Fault)” after the RIA text).

For Graphics, only the TG Sheets are searched. If a Graphic is cited in the Answer portion of the Sheet, then the text “(Answers)” appears after the Sheet information.
The **Options** menu has the following items:

- **Select**: Selects the currently highlighted Course.
- **Select All**: Selects all Courses on the window.
- **Unselect**: Unselects the currently highlighted Course.
- **Unselect All**: Unselects all Courses on the window.
- **Generate Impact Report**: Searches all selected Courses for citations of the selected data.

You can also select/unselect Courses by double-clicking them with the mouse or by using the spacebar. All Courses are selected by default.

### 2.7.7 Search Results Window

Once you’ve selected the Courses and areas to search, choose **Generate Impact Report** from the **Options** menu. This will search all selected Courses for citations of the Resources and Graphics.

![Search Results](image)
The example Search Results window shows how the results data is displayed. Each Resource/Graphic being searched for is listed as a main element. Under each item is a list of all Courses that cite it, if any. Under each Course are the areas that were searched where matches were found, and then a listing of all matches. There are, at most, five areas listed under the Course: TPP, Trainee Prep, Faults, Sheets, and DP/RIAs. “TPP” is displayed when the Resource is cited in the TPP of the Course. No data appears below “TPP”. “Trainee Prep” is displayed when the Resource is cited in the Trainee Preparation section of the Topic Page. Listed under this heading are all Topics in the Course where the Resource is cited. “Faults” is displayed when the resource is cited by a Fault. Listed under this heading are all the Faults that cite the Resource. “Sheets” is displayed when a TG Sheet cites the Resource or Graphic. Listed under this heading are all TG Sheets citing the Resource or Graphic.

The “DP/RIAs” area works a little differently. Depending on the selection on the Related Courses screen, this area will read “Parts”, “Sections”, “Topics”, or “DP/RIAs”. For “Parts”, “Sections”, or “Topics”, listed under the heading will be the Part/Section/Topic numbers that contain RIAs that cite the Resource. For “DP/RIAs”, then the Topic numbers of all Topics that contain RIAs citing the Resource will be listed. Under each topic will be a listing of each RIA citing the Resource.

Only areas where the Resource/Graphic is selected are displayed.

The File menu has the following items:
- **Save Search Results**: Saves the entire set of search data for later display.
- **Print Preview**: Displays the Search results in a printable format.
- **Print**: Prints the search results.

When you save the Search Results data, you are prompted for a file name. Once this has been entered the file is created. By using the **Open Search Results** menu item from the RRLs Selected window **Options** menu item, you can return to this window without having to generate the report again. As this stores all the search data, you can open the file, exit from the results window and change some of the search criteria (what Courses, areas, resources, etc.). You can also send this file to another user and they can open it with their copy of the RRL/Graphics Location Tool.

**NOTE**: You can open any results file, including those not run off your database. This will show the same data as was saved on the other database, allowing you to print it or look at the data. But you should not try to run different searches off of this data, since the information in the file does not match the database information.

### 2.7.8 Print Preview

When you run the **Print Preview** option from the Results window a report will be displayed for each RRL Type selected.
Clicking the magnifying glass button causes the preview to switch between Full Page mode and 100% zoom. Clicking the arrow next to this button gives you the following zoom options:

- **Whole Page**: Zooms the previewed document so it fits entirely into the screen.
- **Page Width**: Changes the Zoom level so that the width of the document fills the screen. You’ll have to scroll up/down, but not left/right.
- **Two Pages**: This displays two pages of the preview at a time.
- **Thumbnail**: Displays thumbnails of all pages (well, all pages that fit in the screen; the number varies).
- **Varying Zoom Levels**: Changes the zoom to a specific percentage from 25% to 150%.

The printed output itself is similar to the Search Results display, but with one exception. If an area is searched and no data is found, the Search Results screen does not show that area. The output does, with the text “None” underneath it. This does not apply to TPP, however, since TPP lists no data under its heading. Therefore, TPP will be printed out only if the Resource is cited in the Course’s TPP.

The **Options** menu has the following items:

- **Print**: Prints the search results.
- **Save to PDF**: Prompts the user for a file name to save the output in PDF format. This does NOT require Adobe’s full Acrobat package.
2.8 Learning Site Utility

*The Learning Site utility is available only to users with AIM Administrator privileges.*

The **Learning Site** sub-menu item opens the Site window. The Site window allows an AIM Administrator to add, modify, or delete Learning Sites (i.e., sites at which training will be conducted.)

**NOTE:** A site can be modified or deleted until the training material it is cited in becomes approved.

The Site Administration window contains the following menu items:

- **Options**
- **Edit**
- **Exit**
- **Help**

### 2.8.1 Site Options Menu Item

Sites are Learning Sites where a curriculum will be taught. The Site may or may not be responsible for the development or approval of the course. The Site list will be used to provide the user a drop-down menu of sites when identifying the Learning Sites in the TPP and the TCCD. If the Site is responsible for the development or approval of the course it's name and address should be entered in the Agency List and AIM I will automatically add it to the Site List.

The **Options** menu item offers options to:

- Add a site and its address to the current list of sites
- Delete a site that you have highlighted. (You will not be able to delete a site that has been selected in a TPP or TCCD).
- Modify the highlighted Site’s name or address.
- Replace a site name and address with another site name and address and if desired delete the replaced site.

#### 2.8.1.1 Add Site

**To add a site:**

**Step 1** From the AIM I main menu, select the **Utility** menu item and the **Learning Site** sub-menu item. Or, select the Site icon.

**Step 2** From the Site window select the **Options** menu item and the **Add Site** option.

**Step 3** AIM I will open a new line. Type the name/acronym of the site in the list.
Step 4 Depress Tab to move to the Address field and click on the field. Enter the address of the site. AIM I will let you enter 50 characters, counting spaces and punctuation.

Step 5 Select the Edit menu item and the Save option to add the site and address to the database. Or, select Cancel to delete your entries.

Step 6 Select the Exit menu item to return to the AIM I main menu.

2.8.1.2 Delete Site

AIM I will allow you to delete a site, provided it is not called out in a Training Project Plan (TPP) or a Training Course Control Document (TCCD).

To delete a site:

Step 1 From the AIM I main menu, select the Utility menu item and the Learning Site sub-menu item. Or, select the Site icon.

Step 2 In the list of sites highlight the site for deletion.

Step 3 From the Site window select the Options menu item and the Delete Site option.

Step 4 AIM I will ask, Delete Site XXX...? Select Yes to delete or No to return to the Site window.

Step 5 Select the Exit menu item to return to the AIM I main menu.

2.8.1.3 Modify Site

AIM I will allow you to modify a site's name or address. This may become necessary if the Site's name or address has been changed or modified.

To modify a site:

Step 1 From the AIM I main menu, select the Utility menu item and the Learning Site sub-menu item. Or, click on the Site icon.

Step 2 In the list of sites click on the site name or address for modification.
Step 3 From the Site window select the **Options** menu item and the **Modify Site** option. Perform one of the following:

a. If the Site is used in an approved course, you will receive the prompt "Site used in approved Course. Are you sure you want to edit Site data?" Click on the **Yes** button. The field will open to permit editing of the name or address.

b. If the Site is not used in approved course, selection of the **Modify Site** option will open the field highlighted for editing. Or, you can double click on the field you desire to modify and it will permit editing.

Step 4 Edit the text as desired.

Step 5 Select the **Edit** menu item and the **Save** sub-menu item or select the **Exit** menu item and save your changes to the database.

### 2.8.1.4 Replace Site

This option is used to replace a site identified in your database with another site identified in your database. It also provides the option to delete the site replaced if desired. For example, it may be necessary to replace a Site with another Site due to a base closure.

**To replace a Site:**

Step 1 From the AIM I main menu, select the **Utility** menu item and the **Learning Site** sub-menu item. Or, click on the Site icon.

Step 2 In the list of sites click on the site name or address for replacement.

Step 3 From the Site window select the **Options** menu item and the **Replace** option.

Step 4 You will be prompted with "Are you sure you want to replace site "XXX"?"

a. Click on **Yes** to proceed.

b. Click on **No** to cancel.

Step 5 If you selected **Yes** you will be prompted with "Select a Site to replace it." Click on **OK** and click on the site desired.

Step 6 Select the **Options** menu item and the **Replace with** option.

Step 7 You will receive the prompt "Replace "XXX"?".

a. Click on **Yes** to replace the site.

b. Click on **No** to select another site.

c. Click on **Cancel** to terminate the **Replace** option.

Step 8 If you selected **Yes** you will be prompted with "Do you want to delete "XXX" after replacement?" Select **Yes** to delete or **No** to retain the replaced site in your database.
2.9 Agency Utility

The Agency utility is available only to users with AIM Administrator privileges.

The Agency sub-menu item opens the Agency window. The Agency window contains a list of the agencies available for selection when you need to identify Developing and Approving agencies during development of training materials. From the Agency window, you can add, delete, modify, or replace agencies. When Agencies are added to the list they are automatically added to the Site List.

The Agency window contains the following menu items:
- Options
- Edit
- Exit
- Help

2.9.1 Agency Options Menu Item

The Options menu item offers options to:
- Add an agency and its address to the current list of sites
- Delete an agency that you have highlighted. (You will not be able to delete an agency that has been selected in a TPP or TCCD).
- Modify the agency name or address.
- Replace an agency name and address with another agency name and address and if desired delete the replaced agency.

2.9.1.1 Add Agency

NOTE: Every agency name must be unique. AIM I will not accept two agencies with the same name or multiple addresses for an agency. For example, there are several FTCs in the Navy. To distinguish among them, you can add locations to names (e.g., FTC, San Diego). When an agency is added to the database, it is also added to the Site List. The Agency Name field is not case sensitive and the name and address field entries can contain multiple lines of text.

To add an agency:

Step 1 From the AIM I main menu, select the Utility menu item and the Agency sub-menu item. Or, click on the Agency icon.

Step 2 From the Agency window select the Options menu item and the Add Agency option.

Step 3 AIM I will open a new line. Type the name/acronym of the site in the list.
Step 4 Depress Tab to move to the Address field and click on the field. Enter the address of the site. AIM I will let you enter 50 characters, counting spaces and punctuation.

Step 5 Select the Edit menu item and the Save option to add the agency to the database. Or, select Cancel to delete your entries.

Step 6 Select the Exit menu item to return to the AIM I main menu.

NOTE: An agency that has been selected in the development or maintenance of a training material item cannot be deleted from the Agency List. The agency must first be deselected from the training material item or, in the case of maintenance, must no longer be cited in any approved baseline training material item. Deleting the agency from the Agency List does not delete it from the Site List.

2.9.1.2 Delete Agency

To delete an agency:

Step 1 From the AIM I main menu, select the Utility menu item and the Agency sub-menu item. Or, click on the Agency icon.

Step 2 In the list of agencies highlight the agency for deletion.

Step 3 From the Agency window select the Options menu item and the Delete Agency option.

Step 4 AIM I will ask, Delete Agency XXX...? Select Yes to delete or No to return to the Agency window.

Step 5 Select the Exit menu item to return to the AIM I main menu.

2.9.1.3 Modify an Agency

An agency title or address can be modified in the database whether it is cited in approved for unapproved training materials.

To modify an agency:

Step 1 From the AIM I main menu, select the Utility menu item and the Agency sub-menu item. Or, click on the Agency icon.

Step 2 Click on the desired agencies title or address.
Step 3 From the Agency window select the **Options** menu item and the **Modify Agency** option. Perform one of the following:

a. If the Agency is used in approved training materials, you will receive the prompt "Agency used in approved training materials. Are you sure you want to edit Agency data?" Click on the **Yes** button. The field will open to permit editing of the name or address.

b. If the Agency is not used in approved course, selection of the **Modify Agency** option will open the field highlighted for editing. Or, you can double click on the field you desire to modify and it will permit editing.

Step 4 Edit the text as desired.

Step 5 Select the **Edit** menu item and the **Save** sub-menu item or select the **Exit** menu item and save you changes to the database.

### 2.9.1.4 Replace Agency

This option is used to replace an agency identified in your database with another agency identified in your database. It also provides the option to delete the agency replaced if desired.

**To replace an Agency:**

Step 1 From the AIM I main menu, select the **Utility** menu item and the **Agency** sub-menu item. Or, click on the Agency icon.

Step 2 In the list of agencies click on the agency name or address for replacement.

Step 3 From the Agency window select the **Options** menu item and the **Replace** option.

Step 4 You will be prompted with "Are you sure you want to replace Agency "XXX"?

a. Click on **Yes** to proceed.

b. Click on **No** to cancel.

Step 5 If you selected **Yes** you will be prompted with "Select an Agency to replace it." Click on **OK** and click on the agency desired.

Step 6 Select the **Options** menu item and the **Replace with** option.

Step 7 You will receive the prompt "Replace "XXX"?"

a. Click on **Yes** to replace the agency.

b. Click on **No** to select another agency.

c. Click on **Cancel** to terminate the **Replace** option.

Step 8 If you selected **Yes** you will be prompted with "Do you want to delete "XXX" after replacement?" Select **Yes** to delete or **No** to retain the replaced agency in your database.
2.10  Archive/Unarchive Utility

The Archive/Unarchive utility is available only to users with AIM Administrator privileges.

The Archive/Unarchive sub-menu item opens the Archive/Unarchive window. The Archive/Unarchive window allows you to archive a PPP, TPS, or Course/LP/TG to a file. When a training material item is archived, it is automatically removed from the AIM I database. If the graphics cited in the course are not used anywhere else, they will also be archived and removed from the database.

2.10.1  Archive/Unarchive Options Menu Item

The Options menu item contains the options to Archive the highlighted training material, Unarchive training material from a file, View Archive Information in a file, Find the desired training material for Archive or generate an Archive IMM Report. When you select an option, AIM I opens an Archive window that lets you identify the drive, directory/folder, and filename in which the Archive information will be placed/from which it will be read. Once you have identified the drive, directory/folder, and file name AIM I performs the selected option.

2.10.1.1  Archive Training Material

Any course can be archived, which deletes it from the database. Approved courses can only be deleted by using the Archive option. Unapproved courses can be deleted by using the Delete option in the Course Select window or by using the Delete Proposed TM Utility. When a Course/LP/TG is archived, the TPS, PPP tables, RRL items, and graphics are also included in the archive file, but the PPP tables, TPS, RRL items, and graphics are not deleted from the database.

To archive training material:

Step 1  From the AIM I main menu, select the Utility menu item and the Archive/Unarchive sub-menu item.

Step 2  From the Archive/Unarchive window select the Options menu item and the type of training material to be archived (PPP, TPS, Course/LP/TG).

Step 3  AIM I will present a list of training materials of the type selected for archiving. Select the Options menu item and the Find option. AIM I will present the Find window.

a. Enter the PTN/TPS#/CIN desired in the Find PPP field. Notice that the field contains a wildcard (*). As you enter the number, the items that start with that number up to the * are displayed in the list below.

b. When you have identified the desired item, you can select it one of two ways:
   - Click on the Select menu item. AIM I will return you to the PPP/TPS/Course window, and the selected the item will be highlighted.
AIM I USER'S MANUAL ADMINISTRATION AND UTILITIES

- From the list below the Find PPP field, double click on the desired item. AIM I will return you to the PPP/TPS/Course window and the selected item will be highlighted.

Step 4 Once the item desired is highlighted, select the **Options** menu item and the **Archive** option.

Step 5 Select the drive, select the directory/folder, and enter the name of the file in the File Name field. Select **OK/Save**.

**NOTE:** The file name extension defaults to ".arc" to identify the file as an archive file. This extension can be edited if desired.

Step 6 AIM I will prompt you with the question "Do you want to view/edit the archive information?" A Yes response will open the Archive/Unarchive information window, which contains information about the contents of the file, who archived it, and the data and time. AIM I is giving you the opportunity to edit the information and add additional comments before it completes the archive file. Once you exit this window, or if you responded No to the prompt, AIM I will prompt you with "Do you want to archive the private notes associated with this course?", if you are archiving a course. If you would like private notes to be a part of the archive file click on Yes, if not click on No. AIM I will then prompt you with "Do you want to archive the IMM files associated with this course?" If you would like to copy the IMM files contained in the course to the archive file click on Yes, if not click on No. AIM will then create an Archive file for the material selected.

Step 7 When the archive file is complete for a course the "IMI Information for Course XXXXX" window will open to display the media included, not included, media that could not be found, and IMM that is cited in the course and not associated with any media file. This report can be printed for your records.

Step 8 Select **Exit** to return to the Archive/Unarchive utility window.

Step 9 Select **Exit** to return to the AIM I main menu.

2.10.1.2 View Archive Information

**To view archive information:**

Step 1 From the AIM I main menu, select the **Utility** menu item and the **Archive/Unarchive** sub-menu item.

Step 2 From the Archive/Unarchive window select the **Options** menu item and the **View Archive Information** option.
Step 3 Identify the drive, directory/folder, and name of the file that contains the Archive information and select **OK/Open**.

AIM I will present you with a list that shows what is in the Archive file, who made the file, and when (date and time) the file was created. If the archive file is a course, the archive information will also contain IMM information for the course. You can select the **Options** menu item and **Print Preview** or **Print** the contents of the Information data from the archive file.

Step 4 Select the **Exit** menu item to return to the Archive/Unarchive window.

Step 5 Select **Exit** to return to the AIM I main menu.

### 2.10.1.3 Unarchive Training Material

**To unarchive training material:**

**Step 1** From the AIM I main menu, select the **Utility** menu item and the **Archive/Unarchive** sub-menu item.

**Step 2** From the Archive/Unarchive window select the **Options** menu item and the **Unarchive** option.

**Step 3** Identify the drive, directory/folder, and name of the file that contains the Archive information and select **OK/Open**.

**Step 4** The software will prompt you "Do you want to automatically Relink the unarchived PPPs/TPSs? It will increase the time of the unarchive process." If you click on **Yes**, the software will look for previous approved versions of the material that is being unarchived and relink the material. If you click on **No** the material being unarchived may require relinking using the Relink PPP/TPS Utility.

**Step 5** If unarchiving material the already exists in the database the software will prompt you with "The unarchiving material already exists in the database and will be compared to the existing material. Continue?" Click on **Yes** and AIM will unarchive the material or **No** to cancel the unarchive operation.

**Step 6** Select the **Exit** menu item to return to AIM I menu. Refer to paragraph 2.13 and perform the Relink PPP/TPS utility if required.
2.10.1.4 Generate Archive IMM Report

When unarchiving a course that contains IMM the software will generate a report to indicate if there are any conflicts between the IMM identified in the course being unarchived and your AIM II database. The Archive IMM Report will produce this same report without unarchiving the course. If there is a conflict between the IMM in the database and the IMM of the archived course, and the course is unarchived, the conflicting courses are no longer editable until the conflict is resolved.

An IMM being unarchived will be considered in conflict with an existing IMM if:

- An existing IMM has the same number/title and cite the same file, but the file has been changed (date/time is different)
- An existing IMM has the same number/title, but cites a different file name.
- An existing IMM has a different number/title, but cites the same file.

If a conflicting IMM is found during unarchive, the following is done:

- The Course is marked as containing a conflict, and the user is prohibited from editing the Course until the conflict is cleared. The Course in conflict is identified in red in both the Admin Module and the Course Select window.
- The conflicting IMIs are marked as conflicting (the existing IMM is NOT marked as conflicting, only the unarchived IMM is marked as such).
- The files of conflicting IMIs are stored in a special sub-directory in the Media directory. This directory is called "Conflicts for Course xxxxxx”.

**NOTE:** You cannot use any conflicted IMIs in any other Courses until the conflict is cleared.

Deleting a Course that contains conflicted IMIs also deletes the conflicted IMIs from the database.

**To generate an Archive IMM Report on an existing archive file:**

1. Step 1 Select Archive/Unarchive from the Utilities drop-down menu.
2. Step 2 Select the **Options** menu item and the **Generate Archive IMM Report** option.
3. Step 3 Identify where the archive file is by selecting the directory and the archive file. Click on the Open button.
4. Step 4 The software will generate an Archive IMM Report and state if there are any conflicts found.

**NOTE:** The software will validate the IMM data in the archive file. If there were no conflicts found the report will contain the statement "No conflicts were found with the existing set of IMIs.”
2.11 Import/Export Utility

The Import/Export utility is available only to users with AIM Administrator privileges.

The Import/Export sub-menu item opens the Import/Export window. The Import/Export window allows you to export a TPP, PPP, TPS, and Course/LP/TG to a file and import:

- A single PPP table
- A TPS and all of its associated PPP tables
- A TPP
- A Course/LP/TG and all of its associated TPSs and all of the TPS's associated PPP tables
- A modified TPS for a TPS that exists in the database and all of its associated (unmodified) PPP tables
- A modified Course/LP/TG file that contains one or more modified Topics and its associated (unmodified) TCCD, TPS, and associated PPP tables, for a Course that exists in the database.

Unlike an archived item, an exported item is not removed from the AIM I database.

2.11.1 Rules for Import/Export Process

In order to import a PPP table that has been exported, the same material cannot be resident on your computer. For example, if your system has PPP A0001, Revision 0, Change 0, AIM I will not permit you to import that table.

An exported TPS contains all related PPP tables from which the TLAs were constructed.
- If the TPS that was exported resides on a system, AIM I will not overwrite the TPS.
- If the PPP tables cited in the TPS are different in any way at the receiving site, AIM I will not allow the receiving site to import the TPS.
- If the TLAs cited in the TPS at the receiving site are different in any way, AIM I will not allow the receiving site to import the TPS unless you select the Import w/Merge TPS option.

A TPP can be exported with a status of incomplete, complete, locked, or approved.
- If the exported “NEW” TPP was incomplete and submitted for review and approval, the approving agency can modify lock/approve the TPP and export it to the originator. AIM I will inform the originator that “TPP with ORIGINAL CIN X-XXX-XXXX already exists in the database, overwrite with importing TPP?” If the originator selects Yes to overwrite the original TPP, the contents of the TPP will be copied to the TPP and the TCCD.
- If the exported “REVISION” TPP was complete/locked and submitted for review and approval, the approving agency can modify and approve the TPP and export it to the originator. AIM I will inform the originator that “TPP with ORIGINAL CIN X-XXX-XXXX already exists in the database, overwrite with importing TPP?” If the originator selects Yes to overwrite the original TPP, the contents of the TPP will be copied to the TPP and the TCCD. The TCCD will be flagged where modifications, deletions, and additions have been made.
• If the exported “NEW” TPP was complete or locked, and submitted for review/approval, the approving agency can modify/approve the TPP and export it to the originator. When imported and overwritten, the information will not be updated in the TCCD.

Proposed modifications can be received for a Course/LP/TG of the same Revision and Change, and either the whole proposed change can be imported or selected topics can be imported. AIM I will permit you to perform all options associated with DPs and RIAs for a proposed modification. If, however, there has been a modification made to the OAC, AIM I will not permit you to receive that proposed modification if the Revision and Change of the Course/LP/TG exists in the database. Thus, two or more facilities can work on the Discussion Demonstration Activities (DDAs) for the same course (new course, change, or revision) at the same time, and their efforts can be consolidated into one package:

• At the Course Curriculum Model Managers (CCMM) site, or
• (For new development) at the Leading Material Preparing Activity (LMPA).

When the **Import** option is exercised for a Course the software will prompt you to import only the originating TPC or the entire TPS associated with the course. If you select the originating TPC the software will import only the originating TPC (and PPPs belonging to that TPC) of the course being imported, not all TPCs (and PPPs) in the TPS being imported.

When Importing a TPS or Course, if there are conflicts between the existing PPP tables and the ones being imported AIM will notify the user of the line items within the PPP table(s) that are in conflict.

There is no feature to allow receipt of proposed changes for integration into a master change package for a PPP table. If a Rev/Chg is being exported to a facility and the receiving facility has already started a Rev/Chg for the same PPP, AIM I will not allow the receiving facility to import the material.

When the **Import/Export** option is selected from the AIM I main menu, the Import/Export window opens. The Import/Export window contains the following main menu items:

- **Options**
- **Exit**
- **Help**

### 2.11.2 Import/Export Options Menu Item

The **Options** menu item offers the options to:

- **Import** training material from a file
- **Import w/Merge TPS** to allow an exported TPS that contains changes to the TLAs or additional TPCs to be imported on the receiving database. The option will not delete applicability codes but will add them and modify As and Rs to Bs.
- **Import Topic** to allow an exported Course/LP/TG that contains modifications to the DPs/RIAs on the receiving database to be imported. The option will allow you to select
the topics that you want to overwrite.

- **Export** the highlighted training material
- **View Export Information** to open the Export Information record, from the export file that will display the contents of the export file and the IMM export report, who generated it and when.
- **Generate Import IMM Report** for an Export file that contains IMI, which produces a report of the IMM and allows the Administrator to view a list of possible conflicting IMIs in the Export file.

When you select an option, AIM I opens an Import/Export window that lets you identify the drive, directory/folder, and file name in which the Import/Export information will be placed/from which it will be read. Once the file has been identified, AIM I performs the selected option.

### 2.11.2.1 Export Training Material

**To export training material:**

**Step 1** From the AIM I main menu, select the **Utility** menu item and the **Import/Export** sub-menu item. Or, select the Import/Export icon.

**Step 2** From the Import/Export window select the **Options** menu item and the type of training material to be exported (**PPP**, **TPS**, **TPP**, **Course/LP/TG**).

**Step 3** AIM I will present a list of training materials of the type selected for export. Highlight the item you want to export and select the **Options** menu item and the **Export** option.

**Step 4** Select the drive, select the directory/folder, and edit the name of the file in the File name field id desired.

**NOTE:** The file name extension defaults to ".exp" to identify the file as an export file. This extension can be edited if desired.

**Step 5** Click on the **Save** button to export the information to a file. AIM I will prompt you with three questions:

- "Do you want to view/edit the export information?" a **Yes** response will open the Export information window, which contains information about the contents of the file, who exported it, and the data and time. AIM I is giving you the opportunity to edit the information and add additional comments before it completes the export file.
- When you exit the Export Information window or if you responded **No** to the prompt AIM I will prompt you with the question "Do you want to export the private notes associated with this course?". Click on **Yes** to include private notes or **No**.
- "Do you want to export the IMM files associated with this Course?" Click on **Yes** to include a copy of the files associated with the IMM in your course or **No** to start exporting your course.
Step 6 When exporting a course, which contains IMM links, a report will be displayed showing all IMIs that were exported. The report will indicate whether the IMM file was included with the export file, was not included, could not be found, or was not linked to a file. Select Exit to return to the Import/Export utility window.

Step 7 Select Exit to return to the AIM I main menu.

2.11.2.2 View Export Information

To view export information:

Step 1 From the AIM I main menu, select the Utility menu item and the Import/Export sub-menu item. Or, select the Import/Export icon.

Step 2 From the Import/Export window select the Options menu item and the View Export Information option.

Step 3 Identify the drive, directory/folder and file name of the file that contains the export information. Click on the Open button. AIM I will present a list that shows what is in the file, who made the file, and when (date and time) the file was created.

Step 4 Select the Exit option to return to the Import/Export window.

Step 5 Select Exit to return to the AIM I main menu.

2.11.2.3 Generate Import IMM Report

When importing a course that contains IMM the software will generate a report to indicate if there are any conflicts between the IMM identified in the course being Imported and the database. The Generate Import IMM Report option will produce this same report without importing the course. If there is a conflict between the IMM selected and the IMM of the imported course, and the course is imported, the conflicting courses are no longer editable until the conflict is resolved.

An IMM being imported will be considered in conflict with an existing IMM if:
- An existing IMM has the same number/title and cite the same file, but the file has been changed (date/time is different)
- An existing IMM has the same number/title, but cites a different file name.
- An existing IMM has a different number/title, but cites the same file.

If a conflicting IMM is found during import, the following is done:
- The Course is marked as containing a conflict, and the user is prohibited from editing the Course until the conflict is cleared. The Course in conflict is identified in red in both the Admin Module and the Course Select window.
- The conflicting IMIs are marked as conflicting (the existing IMM is NOT marked as
conflicting, only the importing IMM is marked as such).
✓ The files of conflicting IMIs are stored in a special sub-directory in the Media directory. This directory is called "Conflicts for Course xxxxxx".

**NOTE:** You cannot use any conflicted IMIs in any other Courses until the conflict is cleared.

Deleting a Course that contains conflicted IMIs also deletes the conflicted IMIs from the database.

**To generate the IMM Import Report:**

**Step 1** Select Import/Export from the Utilities drop-down menu.

**Step 2** Select **Options** and then **Generate Import IMM Report**.

A dialog box with the current directory will be displayed.

**Step 3** Select the desired drive by clicking on the down arrow in the Drives box and dragging the mouse to the desired drive.

**Step 4** Select the desired directory.

**Step 5** Select the desired file.

**Step 6** Click on **Open**.

**NOTE:** The software will validate the IMM data in the export file. If there were no conflicts found the report will contain the statement "No conflicts were found with the existing set of IMIs."

**Step 7** The IMM report can be printed if desired. Select the Exit menu item to return to the Import/Export utility window.

### 2.11.2.4 Import Training Material

**To import training material:**

**Step 1** From the AIM I main menu, select the **Utility** menu item and the **Import/Export** sub-menu item. Or, select the Import/Export icon.

**Step 2** From the Import/Export window select the **Options** menu item and the **Import** or **Import w/Merge TPS** option as desired.

**Step 3** Identify the drive, directory/folder, and name of the file that contains the export information. Select **Open**.
Step 4 The software will prompt you with:
  • "Do you want to automatically Relink the imported PPPs/TPSs? It will increase the time of the import process." If you click on Yes, the software will look for previous approved versions of the material that is being imported and relink the material. If you click on No the material being imported may require relinking using the Relink PPP/TPS Utility.
  • “Do you want to import just the originating TPC of the Course?” This prompt allows the software to only compare the originating TPC with your database if using the Import option or merge just the originating TPC with the TPS if Import w/Merge TPS was selected.
  • If some of the training material in the export file is already present in your database the prompt “The importing material already exists in the database and will be compared to the existing material.” Click on Yes to proceed with the Import or No to terminate.

Step 5 If the course being imported contains IMM the software will validate the IMM and if any conflicts exist provide a report of the conflict information in an IMM Conflict Information report. This report can be printed. Select the Exit menu item to return to the Import/Export utility window.

Step 6 Select Exit to return to the AIM I main menu. Refer to paragraph 2.13 and perform the Relink PPP/TPS utility if required.

To import proposed modifications for topics:

Step 1 From the AIM I main menu, select the Utility menu item and the Import/Export sub-menu item. Or, select the Import/Export icon.

Step 2 From the Import/Export window select the Options menu item and the Import Topic option.

Step 3 Identify the drive, directory/folder, and name of the file that contains the export information. Select OK/Open.

AIM I will present a list of the Topics in the Course.

Step 4 From the list of Topics, highlight the desired topic and select the Options menu item and the Select option.

AIM I will inform you that it is importing the document and let you know when it finishes.

Step 5 Repeat Step 4 for each topic desired.

Step 6 Select Exit to return to the AIM I main menu.
2.12 User Utility

The **User** utility is available only to users with **AIM Administrator** privileges.

The **User** sub-menu item calls the User Administration window. Through the User Administration window, you can add or delete a user, modify a user’s login, change a user’s privilege level from AIM User to AIM Administrator or vice versa, and clear the user’s password if it is forgotten. From the User Information window you can Show Courses for individuals creating PPP-Based curriculum or hide courses for individuals developing a Course/Module/Lesson/Section using the Learning Object Module.

The User Administration window contains the following main menu items:

- **Options**
- **Edit**
- **Exit**
- **Help**

### 2.12.1 User Administration Options Menu Item

The **Options** menu item contains the options to add a user, modify/view user information, delete the highlighted user from the list, and clear a user’s password. The User Information window (Figure B-21) will open when you select the options to **Add User**, **Modify/View User**, or double click on the desired user.

![User Information Window](image)

*Figure B-21. User Information Window*
When the **Delete User** option is selected, AIM I will:
- Prompt you to make sure the action is intentional
- Delete the user upon confirmation.

### 2.12.1.1 Add a User

**To add a user:**

**Step 1**  
From the AIM I main menu, select the **Utilities** menu item and select the **User** sub-menu item. AIM I will present the User Administration window.

**Step 2**  
Select the **Options** menu item and the **Add User** option. AIM I will open the User Information window.

**NOTE:** AIM User is the default privilege level.

**Step 3**  
Type the user’s login name in the User Name field.

**Step 4**  
If AIM Administrator privilege is required for the user you are adding, press **Tab** to highlight Privilege Level field and click on the arrow button. AIM I will present a list of privileges for selection.

**Step 5**  
Click on the desired privilege. The list will disappear, and your selection will appear in the Privilege Level field.

**Step 6**  
If the User will only be using the Learning Object Module uncheck the Show Courses block. The AIM main menu will be limited to only those icons and menu items that are applicable to the Utility.

**Step 7**  
The following fields are optional for the User Information window and can be added now or later using the **Modify/View User** option.
- First Name
- Last Name
- Email Address
- Phone Number
- DSN
- Address

**Step 8**  
Select the **Edit** menu item and the **Save** sub-menu item to save your entries. Select the **Cancel** option to remove your entries.

If you select the **Cancel** option, AIM I will prompt, *All changes will be lost. Are you sure you want to cancel?*  
Select **Yes** if you want to cancel and exit to the User Administration window.  
Select **No** to return to the User Information window.
2.12.1.2 Delete a User

**NOTE:** Do not use this option if a User has forgotten their password. If used for that purpose the software will regard the User as a new entity and the User will not be able to access training materials that the User had privileges for previously. Refer to paragraph 2.8.1.3, Clear User Password.

To delete a user:

Step 1  From the AIM I main menu, select the **Utilities** menu item and select the **User** sub-menu item. AIM I will open the User Administration window.

Step 2  Highlight the name of the user you want to delete.

Step 3  Select the **Options** menu item and the **Delete User** option.

Step 4  AIM I will ask “Delete User XXXX?” select **Yes** to delete the user or **No** to return to the User Administration window.

Step 5  If further editing is required for the list of users, select: The **Edit** menu item and the **Save** option to save your entries.
   a.  The **Cancel** option to remove your entries. If the **Cancel** option is selected, AIM I will prompt, *All changes will be lost. Are you sure you want to cancel?* Select **Yes** if you want to cancel and exit to the AIM I main menu. Select **No** to return to the User Administration window.

Step 6  If no further editing is required for the list of users select the **Exit** menu item. At the prompt “Would you like to save the changes?” select:
   a.  **Yes** to save the changes to the list and exit to the AIM I main menu
   b.  **No** to delete the changes made and exit to the AIM I main menu
   c.  **Cancel** to return to the User Administration window.

2.12.1.3 Privilege Levels

Privilege levels are assigned to Roles and are used to determine accessibility to the information contained in the AIM database.

AIM I Default Roles

The following roles are default roles with specific Privilege Levels: AIM User, AIM Administrator, Curriculum Manager, and Contractor.

- AIM User can view all the training materials and can be assigned privilege to perform specific functions on training material by the AIM Administrator. An AIM User can create training material and has the following default privileges for materials created under their login and password unless modified by an AIM Administrator:
  - **Edit**
  - **Add Notes**
  - **Lock**
AIM Administrators have access to all training materials and Utility functions of AIM I. The AIM Administrator can also assign one or more of the privilege levels shown in the table below to an AIM User for specific training materials via the AIM I Administration utility. Having any one privilege does not allow the AIM User to perform any other privilege. The AIM I User who created a training material item can also maintain that training material once it is approved. If an AIM User is tasked to perform maintenance on a training material that he/she did not create nor have Maintain/Delete privilege, the AIM Administrator has to initiate the change/revision for the training material item and grant the privileges required for the AIM User.

- Curriculum Manager is assigned a Developing Authority (DA). The CM is best described as a Developing Authority Administrator. They have Admin rights on all users and Courses associated to their developing authority. (So, basically, the CM can create users, import/export courses, reset in use, approve, etc, but only on courses within their realm). AIM Administrators can perform administrative functions for all Developing Authorities.

There are also two additional privilege levels; "Lock for Review" and "Unlock for Review". These additional privilege levels allow Curriculum Managers and Administrators to lock-out various Developing Authorities from working on the selected Course. A Curriculum Manager can also use "Lock for Review" to lock out users from his Developing Authority, but not other DAs.

- Contractor, the Contractor Role initially has no privileges assigned to it. The Contractor Role is assigned to Contractors then privileges are assigned based on the needs of the Contractor. Contractor Roles have no privileges until specifically assigned.

2.12.1.4 Clear User Password Option

The Clear User Password Option was created for the AIM Administrator to clear a password for a user who has forgotten their password and cannot gain access to the AIM I database. Once the password is cleared the user can gain access to AIM I without a password and can use the Change Password Utility to enter another password. AIM I will permit the user to access all training materials with the same level of privilege permitted under the previous password.

To clear a user's password:

Step 1 From the AIM I main menu, select the Utilities menu item and select the User sub-menu item. AIM I will open the User Administration window.
Step 2  Highlight the name of the user for which the password will be cleared.
Step 3 Select the **Options** menu item and the **Clear User Password** option.

Step 4 AIM I will ask “Are you sure you want to clear this user's password?” select **Yes** to clear the user's password or **No** to return to the User Administration window.

Step 5 If further editing is required for the list of users, select:
   a. The **Edit** menu item and the **Save** option to save your entries.
   b. The **Cancel** option to remove your entries. If the **Cancel** option is selected, AIM I will prompt “All changes will be lost. Are you sure you want to cancel?” select **Yes** if you want to cancel and exit to the AIM I main menu. Select **No** to return to the User Administration window.

Step 6 If no further editing is required for the list of users select the **Exit** menu item. At the prompt “Would you like to save the changes?” select:
   a. **Yes** to save the changes to the list and exit to the AIM I main menu
   b. **No** to delete the changes made and exit to the AIM I main menu
   c. **Cancel** to return to the User Administration window.

2.12.1.4 Edit a User’s Information

To edit a user's information:

Step 1 From the AIM I main menu, select the **Utilities** menu item and select the **User** sub-menu item. AIM I will present the User Administration window.

Step 2 Highlight the user whom you want to edit.

Step 3 Select the **Options** menu item and the **Modify/View User** option.

Step 4 Edit the desired fields in the User Information window as necessary.

Step 5 When completed with the editing select the **Edit** menu item and the **Save** sub-menu item to save the information to the database.

Step 6 Select the **Exit** menu item to return to the User Administration window.
2.13  Relink PPP/TPS Utility

If you developed a change or revision for an entity and exported it to another site, the receiving site’s database would not have the links between the previously approved entity and the entity received. The Relink PPP/TPS utility will establish the links in the receiving site between the previously approved PPP/TPS and the PPP/TPS received.

Recognition of linking problems:

1. PPP: If your system has the previous version of a PPP imported from another site and it has not been relinked, when attempting to "Select Later TLA" in the TPS the software will prompt you that it hasn't been relinked and will not permit its selection.
2. TPS: If your system has the previous version of a TPS imported from another site and it has not been relinked, when attempting to "Select Later TPC" in the COI Module, the software will prompt you that the TPS has not been relinked and will not permit its selection.

The Relink PPP/TPS utility should be exercised during or after importing an entity, migrating an entity from UNIX, or unarchiving material in the database. Exercise the option on both the PPP and TPS

To Relink PPP/TPS:

Step 1  From the AIM I menu select the Utility menu item and the Relink PPP/TPS utility.

Step 2  From the Relink PPP/TPS window select the Options menu item. The Show Unlinked Only option is a default selection and can be deselected to display all PPP/TPS in the database.

Step 3  Select the PPP or TPS option. AIM I will indicate the PPP or TPS that require relinking with an “X” in the Select column.

Step 4  Click on the PPP or TPS to be relinked, select the Options menu item and the Relink option to relink the entity highlighted. If there is one or more PPP table that requires relinking, you can select the Automatic Linking option to relink all of the PPP tables that have an “X” in the Select column. The Automatic Linking option is disabled for TPS relinking because it could exceed memory space.

Step 5  At the prompt “Are you sure you want to relink this entity?” click on Yes.
Step 6  AIM I will open the Relink window if you are relinking a PPP table that is a Revision of a table contained in your database. The revised table will be on the left and the table it was created from will be on the right. The revised table contains a column titled "Link To". The line items that contain a blank in this column require linking, unless they are line items that did not exist previously. In the case of a Revision the line items that contain links may be in error and require verification. To link the line items perform the following:
   a. Highlight the first line item that requires relinking in the revised table.
   b. Highlight the line item that it should be linked to in the original table.
   c. Select the Options menu item and the Set Link option.
   d. Repeat Steps 6a. through 6c. for each line item that requires relinking. When complete select the Edit menu item and the Save sub-item.

Step 7  AIM I will inform you that it is relinking the PPP/TPS. At the prompt “Link Successful” click on OK. The “X” in the Select column will clear for the PPP/TPS that was relinked.

Step 8  Select the Exit menu item to return to the AIM I menu.

2.14  Data Manager Utility

*For troubleshooting purposes, the Data Manager utility is only available to users with AIM Administrator privilege. Editing in the Data Manager requires an additional password, which can be granted only by the SSO.*

The **Data Manager** sub-menu item calls the Data Manager utility, which displays a list of all the database tables associated with AIM I, along with all the records for each table. The AIM Administrator may be called upon by the SSO to troubleshoot a database problem. Once given the password, the AIM Administrator can edit the contents of the list.

**To edit a list:**

Step 1  From the AIM main menu, select the **Utilities** menu item and select the **Data Manager** sub-menu item. AIM I will present the AIM I Database window.

Step 2  Highlight the required table name and the field that requires editing. Double click on the field that requires editing.

Step 3  AIM I will prompt “Raw data can only be modified by technical support personnel and requires special password. Continue?” select **Yes** to continue or **No** to return to the AIM I Database window.

Step 4  If you select **Yes**, AIM I will open a Support Password window. Enter the password provided by the SSO and select **OK**. Or, you can select **Cancel** to return to the AIM I Database window.
Step 5  If you select OK and the password you entered is valid; edit the field on which you double clicked.

Step 6  If further editing is required, select the Edit menu item and the Save option to save your entries or the Cancel option to remove your entries.

If you select the Cancel option, AIM I will prompt "All changes will be lost. Are you sure you want to cancel?" select Yes if you want to cancel and exit to the AIM I main menu. Select No to return to the AIM I window.

Step 7  If no further AIM I database editing is required select the Exit menu item. At the prompt "Would you like to save the changes?" select:

a. Yes to save the changes to the list and exit to the AIM I main menu
b. No to delete the changes made and exit to the AIM I main menu
c. Cancel to return to the User Administration window.
# APPENDIX C

## TROUBLE REPORT AND AIM CHANGE REQUEST

<table>
<thead>
<tr>
<th>Section</th>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>Trouble Report</td>
<td>C-1</td>
</tr>
<tr>
<td>1.1</td>
<td>Users</td>
<td>C-1</td>
</tr>
<tr>
<td>1.2</td>
<td>Maintenance Action</td>
<td>C-1</td>
</tr>
<tr>
<td>1.3</td>
<td>Trouble Reports</td>
<td>C-1</td>
</tr>
<tr>
<td>1.4</td>
<td>Trouble Report Form</td>
<td>C-1</td>
</tr>
<tr>
<td>1.5</td>
<td>Trouble Report Form Instructions</td>
<td>C-1</td>
</tr>
<tr>
<td>1.6</td>
<td>AIM Change Request</td>
<td>C-2</td>
</tr>
<tr>
<td>1.7</td>
<td>AIM Change Request Form</td>
<td>C-2</td>
</tr>
<tr>
<td>1.8</td>
<td>AIM Change Request Form Instructions</td>
<td>C-2</td>
</tr>
<tr>
<td>1.9</td>
<td>Sending the Database to NAVAIR ORLANDO</td>
<td>C-4</td>
</tr>
</tbody>
</table>
1.0 TROUBLE REPORT

All problems with AIM I are to be reported by the site via the Trouble Report (TR). The TR may be mailed or sent electronically to the SSO. Communication concerning TRs should be directed to the AIM SSO Customer Service Representative by telephone at DSN 960-8620 or commercial (407) 381-8620, fax DSN 960-4519 or commercial (407) 380-4519, or e-mail to orletehelpdesk@navy.mil. The SSO will respond to the TR directly to the point of contact identified on the TR. If the TR cannot be resolved, a change to AIM I may be required. Once a TR has been identified as a potential requirement for a change, the SSO will request the activity to complete an AIM Change Request (ACR).

1.1 Users

User responsibility includes reporting all problems involving AIM I to the SSO.

1.2 Maintenance Action

A request for maintenance of equipment supported by a maintenance contract will go directly to the maintenance contractor. The user will inform the SSO of the problem TR after contracting the appropriate contractor.

1.3 Trouble Reports

TRs provide a forum for reporting problems only, not for requesting changes to AIM I. If a problem is identified as one that requires a change, the SSO will notify the user and request that they submit an ACR. The ACR procedure is outlined in the AIM Life-Cycle Support Configuration Management Plan (ALSCMP).

1.4 Trouble Report Form

AIM SSO Form 93-0002A 11/91 is the AIM Trouble Report Form. A copy of the form appears at the end of this appendix.

1.5 Trouble Report Form Instructions

- **Submitter’s Name, Code & Position**
  
  Provide the name, code, and position of the person submitting the TR.

- **Phone Numbers**
  
  Provide commercial, DSN, fax, and E-mail numbers if available.
• **Submitter’s Activity and Address**
  Provide the activity and address of the person submitting the TR.

• **Narrative of Problem**
  Provide as complete a narrative as possible. Provide as much information as you can about the problem. Use additional pages as required.

• **Hardware Item**
  Provide the name of the hardware item affected.

• **Manufacturer**
  Provide the name of the manufacturer of each hardware item affected.

• **Model**
  Provide the model of each hardware item affected.

• **Software Name**
  Provide the software name affected. Examples: AIM I, AIM II, Novell . . .

• **Version**
  Provide the version of the affected software.

### 1.6 AIM Change Request

An ACR will only be submitted after the SSO has identified that the TR cannot be resolved and notified the user that an ACR should be submitted. Upon receipt of an ACR, the SSO will log it into the database. The SSO will complete Block 3 and return as copy of the form with receipt acknowledgment within 5 working days of receipt. The engineer assigned will then complete the remainder of the form.

### 1.7 AIM Change Request Form

An AIM Change Request Form appears at the end of this appendix.

### 1.8 AIM Change Request Form Instructions

See Table C-1.
<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Requesting activity</td>
<td>Self-explanatory.</td>
</tr>
<tr>
<td>2</td>
<td>Requestor's control no.</td>
<td>The requestor will include a requestor control number to allow tracking of</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the change and correlation with NAVAIR Orlando assigned task number. The</td>
</tr>
<tr>
<td></td>
<td></td>
<td>number will include the requestor’s Unit Identification Code (UIC), the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>device number, the fiscal year, and a request sequence number. Example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>61339-AIM-93-003.</td>
</tr>
<tr>
<td>3</td>
<td>Number assigned by NAVAIR Orlando</td>
<td>Assigned by the NAVAIR Orlando upon receipt of a request.</td>
</tr>
<tr>
<td>4</td>
<td>Requested by</td>
<td>Self-explanatory.</td>
</tr>
<tr>
<td>5</td>
<td>Date</td>
<td>Date form is prepared.</td>
</tr>
<tr>
<td>6</td>
<td>DSN number</td>
<td>Phone number of person named in Block 4. If a commercial number is used,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>strike out “DSN” and include the area code.</td>
</tr>
<tr>
<td>7</td>
<td>Title Change</td>
<td>Title of change should convey to the reader the intent of the change</td>
</tr>
<tr>
<td></td>
<td></td>
<td>being recommended.</td>
</tr>
<tr>
<td>8</td>
<td>Type Change</td>
<td>If the change is intended as a simple hardware, computer, or document</td>
</tr>
<tr>
<td></td>
<td></td>
<td>software change, check the appropriate boxes. If there exists uncertainty,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>check “other” and describe. More than one block may be checked.</td>
</tr>
<tr>
<td>9</td>
<td>Type Hardware System Affected</td>
<td>Include what type of file server is used.</td>
</tr>
<tr>
<td>10</td>
<td>Hardware Sub-System Affected</td>
<td>Self-explanatory.</td>
</tr>
<tr>
<td>11</td>
<td>Software Module Affected</td>
<td>Give software identification for the change being recommended.</td>
</tr>
<tr>
<td>12</td>
<td>Reference</td>
<td>Provide appropriate reference for hardware or software changes; document</td>
</tr>
<tr>
<td></td>
<td></td>
<td>number, page number, and paragraph number for documentation changes.</td>
</tr>
<tr>
<td>13</td>
<td>Need for Change</td>
<td>Describe fully the reason for the change; identify if the change is needed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>for a specific curriculum development requirement, or improvement due to a</td>
</tr>
<tr>
<td></td>
<td></td>
<td>curriculum format change, modification, or other deficiency (use additional</td>
</tr>
<tr>
<td></td>
<td></td>
<td>sheets as necessary).</td>
</tr>
<tr>
<td>14</td>
<td>Recommendations</td>
<td>Recommendations of the requestor, including additional clarifying</td>
</tr>
<tr>
<td></td>
<td></td>
<td>information to aid in expediting the processing of the change request.</td>
</tr>
<tr>
<td></td>
<td>Impact of Non-implementation</td>
<td>Give a statement as to the effects on utilization of AIM I if this change request is disapproved or not implemented.</td>
</tr>
<tr>
<td>---</td>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>16</td>
<td>Are additional Sheets attached?</td>
<td>Indicate if additional attachments, sketches, etc. are attached.</td>
</tr>
<tr>
<td>17</td>
<td>NAVAIR Orlando SSO Contact</td>
<td>Check appropriate answer and/or provide appropriate information.</td>
</tr>
</tbody>
</table>
| 18 | Relative Priority of Change | Indicate priority of change:  
1 = Critical items, no workaround  
2 = Important items, no workaround  
3 = Important items, workaround possible  
4 = Other w/ explanation or referral |

### 1.9 Sending the Database to NAVAIR Orlando

The database is not encrypted and can be compressed (zipped) for transmission through the Internet.

Databases under 4MB can be e-mailed to the SSO's e-mail address (orletehelpdesk@navy.mil). Large databases can be transferred to and from a server at NAVAIR Orlando by using the industry standard File Transfer Protocol (FTP) software. Please call the SSO for instructions.
# TROUBLE REPORT (TR) FORM

## AIM SSO TROUBLE REPORT

<table>
<thead>
<tr>
<th>Submitter’s Name, Code &amp; Position:</th>
<th>Phone Numbers:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>COMM:</td>
<td></td>
</tr>
<tr>
<td>DSN:</td>
<td></td>
</tr>
<tr>
<td>FAX:</td>
<td></td>
</tr>
</tbody>
</table>

Submitter’s Activity and Address:

Narrative of Problem (use additional pages as required):

<table>
<thead>
<tr>
<th>Hardware Item</th>
<th>Manufacturer</th>
<th>Model</th>
<th>Software Name</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

AIM SSO FORM 93-0002a  2/97
<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AUTHORING INSTRUCTIONAL MATERIALS (AIM) CHANGE REQUEST (ACR)</strong></td>
<td></td>
</tr>
<tr>
<td>1. Requesting Activity: (Name/Address)</td>
<td>2. Requestor Control No.:</td>
</tr>
<tr>
<td></td>
<td>3. NAVAIR Orlando Control No.:</td>
</tr>
<tr>
<td>4. Requested By: (Signature, title, and code)</td>
<td>5. Date:</td>
</tr>
<tr>
<td>7. Title of Change: (not to exceed 70 characters)</td>
<td></td>
</tr>
<tr>
<td>8. Type Change: (More than one may be checked)</td>
<td></td>
</tr>
<tr>
<td>___ Hardware ___ Software ___ Documentation ___ Other _____________</td>
<td></td>
</tr>
<tr>
<td>9. Type Hardware System Affected:</td>
<td>10. Hardware Subsystem Affected:</td>
</tr>
<tr>
<td>(i.e., Sun, SCO, HP, PC)</td>
<td>(i.e., Printer, File Server, Other)</td>
</tr>
<tr>
<td>13. Describe the reason for the change: (Use continuation sheet, if needed)</td>
<td></td>
</tr>
<tr>
<td>14. Recommendations: (Provide additional information and/or data to expedite processing of the change request)</td>
<td></td>
</tr>
<tr>
<td>15. Impact of Non-implementation: (Provide statement of effect if this change is not implemented)</td>
<td></td>
</tr>
<tr>
<td>16. Are Additional Sheets Attached? (Circle one) Yes/No</td>
<td></td>
</tr>
<tr>
<td>17. Has SSO Been Contacted? (Circle one) Yes/No</td>
<td></td>
</tr>
<tr>
<td>If Yes, SSO Name Contacted: _____________________________ Date Contacted: ________</td>
<td></td>
</tr>
<tr>
<td>18. Priority of Change: _____ 1 = Critical Item; no work-around.  2 = Important Item; no work-around.</td>
<td></td>
</tr>
<tr>
<td>3 = Important Item; work-around possible. 4 = Other; with explanation or referral</td>
<td></td>
</tr>
<tr>
<td>--------------------------------------------------------------------------</td>
<td></td>
</tr>
</tbody>
</table>

## NAVAIR Orlando USE ONLY

<table>
<thead>
<tr>
<th>ENGINEER ASSIGNED: ___________________</th>
<th>DSN PHONE: _____</th>
<th>DATE: _____</th>
</tr>
</thead>
</table>

Comment:

## SOFTWARE REVIEW TEAM DATE: _____________

<table>
<thead>
<tr>
<th>____ Approval Received</th>
<th>____ Disapproval Received</th>
</tr>
</thead>
</table>

Comment:

## CONFIGURATION REVIEW BOARD DATE: _____________

<table>
<thead>
<tr>
<th>____ Approval Recommended</th>
<th>____ Disapproval Recommended</th>
</tr>
</thead>
</table>

Comment:

## CONFIGURATION CONTROL BOARD DATE: _____________

<table>
<thead>
<tr>
<th>____ Approval Recommended</th>
<th>____ Disapproval Recommended</th>
</tr>
</thead>
</table>

Comment:
(This Page Intentionally Left Blank)
APPENDIX D

DEVELOPING IETM EXTRACTION FILES

Appendix D: Developing IETM Extraction Files

1.0 Introduction .................................................................................................................. D-1

2.0 SGML-based IETM ..................................................................................................... D-1

   2.1 Introduction ...................................................................................................... D-1

   2.2 Installing the SGML-based IETM Extraction Program ................................... D-2

   2.3 Running the SGML-based IETM Extraction Program .................................... D-2

      2.3.1 Description of Registration (Information) File .................................. D-11

      2.3.2 Description of the Library File ........................................................... D-27

      2.3.3 Description of DDE Information File ................................................ D-29

3.0 Other IETMs .............................................................................................................. D-32

   3.1 Introduction .................................................................................................... D-32

   3.2 ARCI IETM ................................................................................................... D-32

      3.2.1 Introduction ........................................................................................ D-32

      3.2.2 Installing the ARCI IETM Extraction Program ................................. D-33

      3.2.3 Running the ARCI IETM Extraction Program .................................. D-33

   3.3 PDF Documents ............................................................................................. D-35

      3.3.1 Introduction ........................................................................................ D-35

      3.3.2 Installing the PDF Extraction Routine ............................................... D-36

      3.3.3 Running the PDF Extraction Routine ................................................ D-36

   3.4 PMS Documents ............................................................................................ D-39

      3.4.1 Introduction ........................................................................................ D-39

      3.4.2 Installing the PMS Documents Extraction Routine ........................... D-39

      3.4.3 Running the PMS Documents Extraction Routine ............................ D-39

   3.5 Raster Technical Manuals .............................................................................. D-42

      3.5.1 Introduction ........................................................................................ D-42

      3.5.2 Installing the Raster Technical Manuals Extraction Routine ............ D-43

      3.5.3 Running the Raster Technical Manuals Extraction Routine .............. D-43

   3.6 XML-Based IETMs  ....................................................................................... D-46

      3.6.1 Introduction ...................................................................................... D-46

      3.6.2 Installing the XML-Based IETM Extraction Routine ...................... D-46

      3.6.3 Running the XML-Based IETM Extraction Routine ....................... D-47

   3.7 S1000D-based IETMs .................................................................................... D-52

      3.7.1 Introduction ...................................................................................... D-52

      3.7.2 Running the S1000D Extraction Routine .............................................. D-53
1.0 INTRODUCTION

The AIM/IETM interface has been developed to accommodate IETMs based on various structures. For example, the IETMs may be based on SGML data, XML data, a relational database or other proprietary structures. In any case, the extraction programs analyze the IETM structural information and write out pertinent nodes information to a text file; the resulting text file is then used to import the structural information into the AIM database. This structural information essentially mimics the table of contents used within the IETM.

The AIM/IETM interface concept has been developed for several types of IETMs:

1. SGML-based structure. Example: UAS-based (ex. SWS), Dynatext-based, AIMSS (relational database IETM with SGML export capability)
2. Database structure. Example: ARCI, PMS
3. Other structures. Example: Raster Technical Manuals, PDF Documents and XML Based documents.
4. XML-based IETM extracts.
5. S1000D IETM extracts.

2.0 SGML-based IETM

2.1 Introduction

The IETMSGML.EXE program extracts hierarchical information from a Standard Graphic Markup Language (SGML)-based IETM (either authored with SGML or able to provide an SGML file rendition of the database) and formats the information for import into the AIM database. The extraction program is written in Visual Basic 5.0 and requires a 32-bit operating system for execution. The program utilizes the Omnimark runtime environment for parsing of the SGML file. The extraction program requires that the following files be available: 1) the SGML IETM file, 2) the DTD and all declared entity files, 3) the DTD/IETM “registration” file, and 4) the library file, which lists all DTDs and entity files referenced by the SGML file.

The extraction program traverses the hierarchical nature of the SGML IETM and writes out each pertinent node’s information to a flat file; the resulting flat file is then used to import the hierarchy information into the AIM database. This hierarchy essentially mimics the table of contents used in the IETM.

The extraction program utilizes functions to parse the SGML file, based on the specified DTD. The extraction process is halted if the SGML file cannot be successfully parsed. (This parsing process uses the library file, which identifies the DTD and all entity files.) If parsing is successful,
a hierarchical tree of all elements found in the SGML file is created. The extraction process then traverses this hierarchical tree and extracts the pertinent information to be imported into AIM. Because of the interactive nature of the IETM, not all elements in the SGML file will be included in the AIM hierarchy. Elements that are included in the IETM solely for the interactive nature of the IETM are ignored by the extraction program and are, therefore, not included in the “flat file”. As each element is analyzed during the extraction process, it is determined if the element has an ID. Typically, an element is included in the AIM hierarchy if the element has an ID and it is not solely involved in the interactive nature of the IETM. If an element has an ID, then the AIM program can automatically position to the node in the IETM, utilizing DDE technology. However, in some cases, the element is only a “container” for other elements in the SGML file and must be traversed and/or included even if there is no ID. An element with no ID is traversed if it is a container with sub-elements that should be included in the AIM hierarchy.

An element with no ID is included in the AIM hierarchy if it is a “placeholder” in the IETM table of contents. However, the corresponding node information in the flat file indicates that there is no ID present and no DDE messaging will be completed for the node.

The program utilizes a “registration file” (ex. *.inf) that describes the IETM and those elements that will be included in the AIM hierarchy. This “registration” file describes the elements that are included in the hierarchy, the elements that should be included even if no ID, the elements that should be traversed, etc. This registration file is critical to the successful extraction of the IETM’s hierarchical content, which will be imported into the AIM database. The DTD and SGML files should be examined carefully when setting up the “registration” file. The “registration” file should be able to be set up for a particular DTD and utilized for any SGML IETMs that make use of that specific DTD. (The “registration” file is discussed in complete detail later in the document.)

**SGML files and DTDs used in the Extraction Program**

The SGML files used in the extraction program must have a DOCTYPE declarations included as the first line of the SGML file. If it is not included in the IETM file, the user will be prompted to enter a DOCTYPE declaration for the file. This will be appended to a temporary file used by the extraction program, which will exist only while the extraction program is being run.

The library file used in the extraction program must be set up prior to attempting to run the extraction program. Complete details on setting up the library file are included later in this document.

**2.2 Installing the SGML-based IETM Extraction Program**

The extraction software is built on the Omnimark runtime product. All necessary files are installed in the AIM directory when the AIM program is installed.
2.3 **Running the SGML-based IETM Extraction Program**

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “SGML” option, and click on the Next button. This screen is shown below.
Figure D-1 IETM Extraction Utility

The “IETM Extraction Utility / Extraction Output” screen will be displayed, which prompts the user to name the resulting output file created by the extraction program.
Figure D-2 Extraction Output

After the user types in a name and hits the Next button, the first screen for the SGML-based Extraction program will appear.
The information required for the extraction is located in several individual files. These files are loaded by clicking on the Browse buttons beside the corresponding text boxes. All files (except the SGML file) necessary for running the extraction program are based on the DTD used in the SGML file and the viewer used to browse the IETM. Representative files can be obtained by contacting the ETE Help Desk. (Please note that these files, particularly the registration file, may need to be tweaked to meet exactly how the IETM SGML file was written based on the DTD.)

Load each of the files indicated on this screen as follows: (Each of these files is explained in more detail later in the document.)

**IETM SGML file:** Browse to find the file. This file is typically located on the CD associated with the IETM. The file typically (but not always) has a “.sgm” extension. For example, the GD SWS file is called “ietm.269”, while an SSBN226 IETM is called “t09oe.sgm”. This file is a required file for extraction.

(Remember that a DOCTYPE declaration must be included in the SGML file. Some IETM developers do not include this declaration at the beginning of the SGML file because of the various authoring/parsing systems being used. If it is not included at the beginning of the file, the program will prompt the user for a DOCTYPE declaration.)
declaration after the extraction process has begun. This DOCTYPE declaration file is typically called doctype.txt)

**DTD associated with IETM SGML file:** Browse to find the file, which has a “.dtd” extension. This file is a *required* file for extraction.

The DTD defines the structure of the elements found within the SGML file.

**Declaration file:** Browse to find the file, which has a “.dec” extension. Some IETM developers will provide declaration files that were used with the IETM and DTDs; otherwise, a default declaration file is used. This file is an *optional* file for extraction.

The declaration file provides information such as the number of potential levels of elements, number of elements able to be declared, etc. If no declaration file is specified, a default declaration file is used.

**DTD Registration file:** Browse to find the file, which has a “.inf” extension. This file is a *required* file for extraction.

The registration files defines the elements that will be used to generate the IETM structure information that will be imported into AIM. The DTD Registration file specifies information about how the SGML file is written according to a DTD; for example, if label attributes are used when displaying node titles.

**Library file:** Browse to find the file, which should have a “.lib” extension. This file is a *required* file for extraction.

The library file informs the extraction functions of the locations of DTDs and entity files that are declared by the DTD.

**DDE information file:** Click the DDE Messaging Info button. The following screen will be displayed. Type the information into the text boxes, or click the “Read From File” button to find the file which contains all DDE information. The file containing the DDE information has a “.dde” extension. This file is a *required* file for extraction.

The DDE file specified information related to what type of viewer is used to display the IETM, where the viewer application is located, and any DDE command information that is necessary to be included in a DDE message to tell a viewer to position to a node. After the file has been read, all text boxes will be filled out with the appropriate information. Click the “OK” button to return to the “Extract SGML-based IETM” screen.

The following screen is an example of information input for an IETM based on display via the UAS 5.0 viewer. The Application Name is always “TMMIAPP” and the Topic Name is always “TECHINFO”. The Application location is the location of the UAS 5.0 executable and may change depending upon the installation of the UAS viewer. The Configuration File is the location of the .dat file that corresponds to the TIDB. The
Configuration Location specifies the directory where the configuration file is located. The DDE PreString will always be “[SHOW(“. The DDE PostString will always be in the format of “)(public name from .dat file)”. The Window Name is the name that is displayed as the window name of the UAS viewer, and at this point will always be “User Access System”.

![IETM DDE](image)

**Figure D- 4 IETM DDE**

The following screen is an example of a browser-based (such as Internet Explorer) IETM. The path where the HTML files are located needs to be identified in “Path of main directory for HTML files.”)
The following screen is an example of a Dynatext-based IETM. The Application Name is always “DTEXT”. The Topic Name is “BOOK(ID of book, title of book). These book values can be copied from the dynatext.ini file. The Application location is the location of the Dynatext executable. The Configuration Location is always the path to the binary (“\bin”) directory located within the installed Dynatext directory. The DDE Prestring is always “ebt-script("ebt-link window=new showtoc=yes target=idmatch(ID,". The DDE Post String is always ‘)”). The Window Name is based on the window name given when Dynatext is launched. In this case, the window name is from version 2.3 of Dynatext.
The following screen is an example of an AIMSS-based IETM. The Application Name is always “AIMSS” and the Topic Name is always “CBT”. The Application Location is the location of the AIMSS executable, and the Configuration Location is the “runtime” directory of the installed AIMSS program. The DDE Prestring is the location of the compiled AIMSS IETM.
The following is an example of a GuideReader-based IETM. The Application Name is always “Guide”. The Topic Name and Configuration Location are the location of the Guide files. The Application location is the location of the GuideReader executable followed by a command option of “-c” followed by the location of the Guide Reader ini file.
After all files have been located, click on the Extract button. The extraction process will then be performed.

Note that a DOCTYPE declaration is required at the beginning of the SGML file. If this declaration is not found, the extraction program will prompt the user for the appropriate DOCTYPE declaration. The user can either type this text into the displayed text box or read the DOCTYPE declaration from a file.

The extraction program will then complete the analysis of the SGML file and the extraction of appropriate structural data of the IETM that should be imported into the AIM database. When this process is complete, a message box will appear informing the user that the IETM has been successfully extracted. A second message box will appear stating that the extraction file has been created with the name that the user selected.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)
2.3.1 Description of Registration (Information) File

The extraction program utilizes an “information file” that describes the IETM and those elements that will be included in the AIM hierarchy. The user should carefully examine the DTD when creating this registration file. The extraction program will base the hierarchy obtained from the IETM on information found in this file.

This information file is important for several reasons:

- The information file defines the elements that will actually be included in the AIM hierarchy. In an interactive IETM, there are several elements that are only important to the interactivity of the IETM, but are not necessarily important to the hierarchy of information. The AIM program essentially mimics the table of contents displayed in the interactive IETM.

- SGML files based on unique DTDs will use different naming conventions for similar types of elements and attributes. For example, node names may have an attribute of “NAME” in one DTD, but have an attribute of “NODE NAME” in another DTD. The definitions of conventions used for the AIM-required IETM information are vital to the successful extraction process.

The following paragraphs describe each section of the registration/information file.

[TAGS] section

The [TAGS] section describes those elements that will be analyzed to be included in the AIM hierarchy. These elements are typically not solely involved in the interactive nature of the IETM.

In this example, elements that are not to be analyzed include ALERT and DIALOG, because these are solely involved in the interactivity of the IETM.

Example for MIL-D-87269 - based IETM:

[TAGS]
DESCINFO
GRAPHIC
PARA
PARA-SEQ
STRING
SYSTEM
TABLE
TASK
TECHINFO

[NODE ATTRIBUTES] Section

This section describes the attributes that are used to define required information about the nodes: name, id, and version. This is information that is required by AIM for tracking nodes, including the tracking over multiple versions. This section also includes some optional information used for defining the names of the nodes that will be displayed in AIM when browsing the structure of the IETM.
Example combining information for several IETMs:

```xml
<node attributes>
    name=NAME
    id=ID
    version=VERSION
    label=LABEL
    no node title=UNTITLED
</node attributes>
```

The “name”, “id”, and “version” descriptions are all required. The “label” and “no node title” descriptions are optional.

### [INCLUDE ELEMENT TAG IN NODE NAME] Section

This section describes the elements where the element tag should be included as part of the element name. For example, an IETMs may have “Figure” elements where the element is displayed such as “Figure 1: Main Equipment Display”. The element name in the SGML file is “1: Main Equipment Display”, while the element tag is “FIGURE”. To make this element title complete, the element tag and element name should be concatenated together.

Example for MIL-D-87269 - based IETM:

```xml
<include element tag in node name>
    this is intentionally left blank because there is nothing that should be defined here
</include element tag in node name>
```

Example for another IETM:

```xml
<include element tag in node name>
    CHAPTER
    FIGURE
    TABLE
</include element tag in node name>
```

### [ID/IDREF LINKING] Section

This section describes the ID/IDREF pairs that are used and the attribute names that describe each of these pairs. When an IDREF attribute is encountered, this indicates to the SGML file that there is a linking to another element with a corresponding ID attribute. The element with the corresponding ID attribute (and its sub-elements) should “replace” the element with the IDREF attribute. This is a convenient way to 1) make the SGML file more readable, and 2) to re-use elements in multiple places of the SGML file without having to duplicate the information.

For example, the MIL-D-87269 DTD has an attribute REF, which is defined as an IDREF type, and an attribute ID, which is defined as an ID type. The element `<SYSTEM REF="OP4612Figures">` is defined. This describes a linking to a corresponding `<SYSTEM ID="OP4612Figures">` defined elsewhere in the SGML file. The element `<SYSTEM ID="OP4612Figures">` and all its contained elements should be inserted into the hierarchy at the point where it was referenced by `<SYSTEM REF="OP4612Figures">`. 
Example for MIL-D-87269 - based IETM:

[ID/IDREF LINKING]
idref=REF;id=ID

[MAP VERSION ATTRIBUTE] Section

This section describes how versions are handled in the IETM. In some cases, the version attribute that is associated with an element is actually mapped to a version element that completely describes the version.

Using the MIL-D-87269 DTD example, elements contain attributes of VERSION="ver0". This “ver0” string is actually mapped to a VERSION element that gives more complete information about the version. The VERSION element whose ID="ver0" shows a REVISION attribute of “1”. This Revision 1 is what is actually contained in the IETM documentation and is what should be displayed by AIM. The “ver0” string is meaningless to the user, but can be used within the AIM code to compare versions.

Example for MIL-D-87269 - based IETM:

[MAP VERSION ATTRIBUTE]
element=VERSION
mapped attribute=ID
display attribute=REVISION

[EXCLUDE ELEMENTS DUE TO SPECIFIED ATTRIBUTES]

This section describes elements that should be excluded because they contain a specific attribute. For example, an element may contain an attribute describing it as a global element, which should not be included except when it is referenced by an ID/IDREF pair.

For example, there could be several cases where a SYSTEM element contains a TYPE attribute with the content of GLOBAL. This means that the SYSTEM element is global and is actually referenced (through an ID/IDREF linking) elsewhere. In some cases, this global SYSTEM element has an ID. Even though it has an ID, it is global and should not be included in the AIM hierarchy other than in places that reference it.

Example for MIL-D-87269 - based IETM:

[EXCLUDE ELEMENTS DUE TO SPECIFIED ATTRIBUTES]
SYSTEM;TYPE=GLOBAL
SYSTEM;ID=MenuReviewAccess
SYSTEM;ID=MenuProcedureAccess
[INCLUDE NO ID] Section

This section describes those elements that should be included in the AIM hierarchy even though they have no ID attribute. These elements are used as IETM viewer “placeholders” in many instances. They essentially describe folders containing graphics, tables, etc. Because the elements have no ID attribute, they will be flagged that there is no specific place to position to in the viewer.

Example for MIL-D-87269 - based IETM:

[INCLUDE NO ID]
TASK
DESCINFO

This information can be entered in two forms:

1) including just an element name (ex. TASK), where all element tags of TASK will be included
2) included an element name and attribute value (ex. TABLE; TABSTYLE=“INLINE”), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be included.

[INCLUDE NO ID BUT REF] Section

This section describes those elements that should be included in the AIM hierarchy even though they have no ID attribute, but they have a reference attribute. These elements are used to reference a “chunk” of the IETM that is placed somewhere else in the SGML file. (See the section describing the ID/IDREF pairs.) This section would be used in cases where it is not appropriate to include all elements of the particular type with no Ids, but to include only those that have a reference attribute.

For example, in one IETM, some SYSTEM elements may contain references to other elements. These SYSTEM elements do not have an ID attribute, only a REF attribute. These elements should be included in the AIM hierarchy. However, not all SYSTEM elements that do not have an ID should be included - just those that have a REF attribute. This is why the SYSTEM element would be included in this section, rather than the [INCLUDE NO ID] section.

Example for MIL-D-87269 - based IETM:

[INCLUDE NO ID BUT REF]
SYSTEM

[TRAVERSE EVEN IF NO ID BUT NO HIERARCHY] Section

This section describes those elements that should be traversed for children; these children may be included in the AIM hierarchy. However, the elements listed here are not included in the hierarchy themselves.
These elements can be thought of as containers within the SGML file. These elements contain sub-elements that can be positioned to within the viewer.

Note that these elements are traversed even if they have no ID attribute.

This information can be entered in two forms:
1) including just an element name (ex. TASK), where all element tags of TASK will be traversed even if no id
2) included an element name and attribute value (ex. TABLE; TABSTYLE="INLINE"), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be traversed

Example for MIL-D-87269 - based IETM:

[TRAVERSE EVEN IF NO ID BUT NO HIERARCHY] PARA-SEQ PARA TECHINFO

[TRAVERSE ONLY EVEN IF ID] Section

This section describes those elements that should be traversed for children but not included in the AIM hierarchy, even if the element does have an ID attribute. These elements could be considered as “placeholders” within the SGML file.

This information can be entered in two forms:
1) including just an element name (ex. TASK), where all element tags of TASK will be traversed even if no id
2) included an element name and attribute value (ex. TABLE; TABSTYLE=”INLINE”), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be traversed

Example for MIL-D-87269 - based IETM:

[TRAVERSE ONLY EVEN IF ID] SYSTEM; ID=MenuDocumentAccess SYSTEM; NAME=

[INCLUDE WITH REPLACEMENT NODE TITLES]

This section describes those elements that are included but their element names are replaced with those listed in the registration file.
Example for an IETM:

[INCLUDE WITH REPLACEMENT NODE TITLES]
BODYREAR=LIST OF TABLES
REAR=LIST OF FOLDOUTS/ADDENDA

In this example, whenever a “BODYREAR” element is encountered, its name will be “LIST OF TABLES” in the IETM structure to be imported into AIM.

[TEXT NODE TYPES], [GRAPHIC NODE TYPES], and [TABLE NODE TYPES] Sections

These sections describe those elements that are described as nodes that are text, graphics, or tables. The node type in the flat file is used by AIM to determine the type of icon to display to the user as an aid to what type of node is selected for viewing or use within a RIA.

Example for MIL-D-87269 - based IETM:

[TEXT NODE TYPES]
SYSTEM
TASK
DESCINFO

[GRAPHIC NODE TYPES]
GRAPHIC

[TABLE NODE TYPES]
TABLE

[IETM NAME ELEMENT] and [IETM VERSION ELEMENT] sections

These sections describe how to find the name and version number for the IETM. This information will be displayed in the AIM IETM Admin screen to show the list of IETMs that are currently stored in the database. This information is also used to create the first node in the IETM structure to be imported into AIM.

If either of these sections is blank, then the user will be prompted by the extraction program to enter the IETM name and version. There are some SGML files that do not have this information embedded within them, so the user must enter the information manually. This process is done immediately upon initiating the extraction process.

Example for MIL-D-87269 - based IETM:

[IETM NAME ELEMENT]
TECHINFO; 1

[IETM VERSION ELEMENT]
SYSTEM; 1
2.3.1.1 Example of Determining the Content of the Registration File using the GD SWS IETM

The sections within the registration file are created by analyzing what is displayed in the specific IETM table of contents within the viewer being used for the IETM and evaluating this with the elements defined in the DTD. The DTD can also be analyzed to determine basic content of the IETM versus elements defined only for the interactivity of the IETM.

In some cases, the process of creating the correct registration file may be iterative. The person extracting the IETM may have to create the registration file, run the extraction, and modify the registration file based on the information that was included or excluded from the resulting extracted text file, and then run the extraction again. This process would continue until the extracted information mimics the table of contents displayed in the specific IETM viewer.\[TAGS\] section - describing acceptable tags that will be included in the AIM hierarchy

By looking at the table of contents of the GD SWS IETM in the GD EDS Viewer and comparing displayed items with the SGML file, you can easily see that the displayed items are SYSTEM, DESCINFO, GRAPHIC, TABLE, and TASK elements. By looking at the DTD, you also easily see that SYSTEM elements are sub-elements of the TECHINFO element. Therefore, these elements should be included as acceptable tags.

The \[TAGS\] section in the registration file would appear as follows:

\[TAGS\]
DESCINFO
GRAPHIC
PARA
PARA-SEQ
STRING
SYSTEM
TABLE
TASK
TECHINF

Example from the SGML file showing TECHINFO, SYSTEM, and DESCINFO elements used: (elements are highlighted in Bold)

```xml
<!DOCTYPE TECHINFO PUBLIC "-//GD//DTD GD SWS TECHINFO//EN">
<TECHINFO NAME="Fire Control System">
.VERSION ID="ver0" REVISION="1" REVDATE="040797" CHANGENO="2" CHGDATE="000000">
</VERSION>
<SYSTEM ID="MenuDocumentAccess" NAME="FCS MK 98 MOD 1 / GS MK 6 MOD 0" VERSION="ver0">
</SYSTEM>
<SYSTEM ID="OP4612" NAME="OP 4612" TYPE="TITLE" VERSION="ver0">
</SYSTEM>
<SYSTEM ID="OP4612v3" NAME="VOLUME 3" TYPE="TITLE" VERSION="ver0">
</SYSTEM>
<DESCINFO ID="OP4612v3c1" NAME="NO CONTENT" VERSION="ver0">
```
Compare these elements with part of the first item of the Table of Contents displayed in the GD SWS EDS Viewer. You’ll notice that the entire IETM is considered to be “FCS MK 98 MOD 1 / GS MK 6 MOD 0”; this is the first main SYSTEM element in the SGML file. Then you’ll see the first element in the TOC - “OP 4612”; this is the next SYSTEM element in the SGML file. Opening the “OP 4612” item in the GD SWS EDS Viewer, you’ll see the next SYSTEM element - “VOLUME 3”. Continuing to open the elements in the GD SWS EDS Viewer, you’ll then see the next SYSTEM element - “CONTENTS” with the child of the DESCINFO element - “NO CONTENT”.

Example from the SGML file showing TASK elements used:

```xml
SYSTEM ID="OP4612v3FII" NAME="FAULT ISOLATION INDEX PROCEDURE" VERSION="ver0">
<TASK NAME="FAULT ISOLATION INDICATION SELECTION" VERSION="ver0">
```

In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Fault Isolation Index Procedure” folder. Opening this folder shows the TASK element = “FAULT ISOLATION INDICATION SELECTION”.

Example from the SGML file showing TABLE elements used:

```xml
<TABLE ITEMID="3-1." TYPE="ColSubHeaders=1" ID="OP4612v3c3t1" NAME="SMP FAILURES">
```

In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Tables” folder. Opening this folder shows the TABLE element = “SMP FAILURES”.

Example from the SGML file showing GRAPHIC elements used:

```xml
<GRAPHIC NAME ="Power Status and Control Panel." ID ="OP4612v3c3f1s0p0" ITEMID="3-1."/>
```

In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Illustrations” folder and then the “3” folder. Opening this folder shows the GRAPHIC element = “Power Status and Control Panel”.

The other acceptable elements are not as obvious to pick out. In some cases, these elements are only containers for sub-elements, where the sub-elements will be included in the AIM hierarchy.

Example from the SGML file showing PARA-SEQ and PARA elements used:

```xml
<DESCINFO TYPE="FOLDER" VERSION="ver0">
<PARA-SEQ>
<PARA VERSION="ver0">
<GRAPHIC NAME="Power Status and Control Panel." ID="OP4612v3c3f1s0p0" ITEMID="3-1."/>
<GRPHPRIM ID="ACN-IC4614-0035B-A2" ITEMID="46140035.tif" CODING="FAX">
<TEXT>
</TEXT>
</GRPHPRIM>
</GRAPHIC>
</PARA>
</PARA-SEQ>
</DESCINFO>
```
In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Illustrations” folder and then the “3” folder. Opening this folder shows the GRAPHIC element = “Power Status and Control Panel”. Notice that in the SGML file, the GRAPHIC element is a sub-element of the PARA element, which is a sub-element of the PARA-SEQ element. However, the PARA and PARA-SEQ elements have no names or IDs and are used as nothing more than containers, which are verified by looking at the DTD.

So, these tags have to be listed as acceptable so that the extraction algorithm will continue to look for the children of these elements; however, they will not be included in the AIM hierarchy. These tags will show up again in the [TRAVERSE BUT NO HIERARCHY]

Section of the registration file, so that the extraction program is told to analyze (traverse) these elements but not include them in the AIM hierarchy.

[NODE ATTRIBUTES] Section

This section describes the names of the attributes that are used in the IETM for defining the required node information for import into AIM. The required information consists of node name, ietm id, and version. In the GD SWS IETM, the node name is defined by the attribute “NAME”, the node ietm id is defined by the attribute “ID”, and the version is defined by the attribute “VERSION”.

The [NODE ATTRIBUTES] section in the registration file would appear as follows:

[NODE ATTRIBUTES]
name=NAME
id=ID
version=VERSION

Example from the SGML file of the node attributes:

<SYSTEM ID="OP4612" NAME="OP 4612" TYPE="TITLE" VERSION="ver0">  
In some cases, the name of the element is the content of a child element rather than the attribute of the element. In this case, the registration file entry would appear as follows:

name=CONTENT(TITLE)

where “TITLE” is the element tag whose content defines the name of the node. The text “CONTENT()” must appear to indicate that the content of an element rather than an attribute of an element will be searched for the element name.

In the GD SWS IETM, this information is sufficient. However, this section also contains optional information used for defining the name of the node that will be displayed in AIM when browsing the IETM structure. The optional information consists of “label” and “no node title”. In some cases, there is a label attribute that is used as part of the element name; therefore, the “label” description would be set to this attribute. In cases where an element is included but does not have a name, the default functionality is to use the sequence number as the name. However, if the “no node title” entry is set to “UNTITLED”, then the element name will be “UNTITLED” concatenated with the element tag name. The registration file entries would appear as follows.
[INCLUDE ELEMENT TAG IN NODE NAME] Section

This section describes the elements where the element tag should be included as part of the element name. For example, an IETMs may have “Figure” elements where the element is displayed such as “Figure 1: Main Equipment Display”. The element name in the SGML file is “1: Main Equipment Display”, while the element tag is “FIGURE”. To make this element title complete, the element tag and element name should be concatenated together.

For the GD SWS IETM, this section would be blank because no such information is necessary:

[INCLUDE ELEMENT TAG IN NODE NAME]

However, in other IETMs, the registration file entry would appear as follows for those elements where the tag name should be included as part of the node name. Note that the tag name will be placed prior to the element name in the complete element title.

[INCLUDE ELEMENT TAG IN NODE NAME]
CHAPTER
FIGURE
TABLE

[ID/IDREF LINKING] Section

This section describes ID/IDREF pairs that are used for linking between elements in the IETM and the attribute names that describe each of these pairs. In the GD SWS IETM, only one ID/IDREF pair is used. The IDREF - type attribute “REF” is used by an element to reference or link to another area of the SGML file. The corresponding ID - type attribute “ID” is used by an element to refer to the “linked” or the referenced element.

The [ID/IDREF LINKING] section in the registration file would appear as follows:

[ID/IDREF LINKING]
idref=REF;id=ID
Example from the SGML file of the ID/IDREF pairs:

```xml
<SYSTEM NAME="ILLUSTRATIONS" REF="OP4619v1Figures" VERSION="ver0">
<SYSTEM NAME="TABLES" REF="OP4619v1Tables" VERSION="ver0">
<SYSTEM NAME="VOLUME 1" ID="OP4619v1Figures" VERSION="ver0">
<DESCINFO TYPE="FOLDER" VERSION="ver0">
<PARA-SEQ>
<PARA VERSION="ver0">
<GRAPHIC NAME="Mk 6 Guidance Assemblies." ID="OP4619v1c1f1s0p0" ITEMID="1-1.">
<GRPHPRIM ID="ACN-4619-11A" ITEMID="46190011.tif" CODING="FAX">
<TEXT>
</TEXT>
</GRPHPRIM>
</GRAPHIC>
<PARA VERSION="ver0">
<GRAPHIC NAME="Interface Relationships." ID="OP4619v1c1f2s0p0" ITEMID="1-2."/>
</PARA>
</PARA-SEQ>
</DESCINFO>
</SYSTEM>
</SYSTEM>
</SYSTEM>
</PARA-SEQ>
</DESCINFO>
</PARA-SEQ>
</PARA-SEQ>
</GRAPHIC>
</PARA VERSION="ver0">
</PARA>
</GRAPHIC>

During the extraction process, the extraction program will insert this sub-hierarchy, starting at the SYSTEM element with ID="OP4619v1Figures", into the AIM hierarchy at the position of the SYSTEM element with REF="OP4619v1Figures".

The portion of the AIM hierarchy would look as follows:

OP 4619
Volume 1
Contents
Illustrations
  1 (corresponding to the DESCINFO element)
    Mk 6 Guidance Assemblies
      Interface Relationships
    2
      Tables

[MAP VERSION ATTRIBUTE] section

In the GD SWS IETM (and defined in the 87269), an element has a VERSION attribute which is an IDREF attribute. So, the VERSION attribute is linked back to a version element. The version element has attributes giving a more complete description of the version, such as revision and change information.

So, when the main IETM version is displayed in the AIM grid, the actual information should be displayed rather than this VERSION attribute. This section describes the element that is referenced when a VERSION attribute is found & the attributes within the element that define the information to be displayed.
The [MAP VERSION ATTRIBUTE] section of the registration file would appear as follows:

[MAP VERSION ATTRIBUTE]
  element=VERSION
  mapped attribute=ID
  display attribute=REVISION

Example from the SGML file of the mapped version information:

```
<VERSION ID="ver0" REVISION="1" REVDATE="040797" CHANGENO="2" CHGDATE="000000">
</VERSION>

<System ID="MenuDocumentAccess" NAME="FCS MK 98 MOD 1 / GS MK 6 MOD 0" VERSION="ver0">
```

When looking for the main IETM version, you can see that the SYSTEM “FCS MK 98 MOD 1 / GS MK 6 MOD 0” has a version attribute of “ver0”. Based on the registration file, the element that is linked is the element “VERSION” with an ID attribute of “ver0” (which in the example is the element immediately proceeding the SYSTEM element). The REVISION attribute then describes the information that will actually be displayed in the AIM grid.

**[EXCLUDE ELEMENTS DUE TO SPECIFIED ATTRIBUTES]**

This section describes elements that should be excluded because they contain a specific attribute. In the GD SWS IETM, there are many SYSTEM elements that have a TYPE attribute of GLOBAL. These elements are typically containers for the referenced element(s) of an ID/IDREF pair. They are essentially defined at the end of the SGML file, for readability of the SGML file and potential “re-use” of the element. Because they’re included when they are referenced, they should not be included when they are simply encountered in the SGML file.

The [EXCLUDE ELEMENTS DUE TO SPECIFIED ATTRIBUTES] section would appear as follows in the registration file:

[EXCLUDE ELEMENTS DUE TO SPECIFIED ATTRIBUTES]
  SYSTEM;TYPE=GLOBAL
  SYSTEM;ID=MenuReviewAccess
  SYSTEM;ID=MenuProcedureAccess

Example from the SGML file of exclusion due to attributes:

```
<System NAME="Table View" TYPE="GLOBAL" VERSION="ver0">
<System NAME="OD 56508" VERSION="ver0">
<System NAME="VOLUME 2" ID="OD56508v2Tables" VERSION="ver0">
```

The SYSTEM “Table View” is found with a TYPE attribute with a value of GLOBAL. This means that the element is defined globally and should not be included in the AIM hierarchy. It contains elements that are referenced from other parts of the IETM.
[INCLUDE NO ID] section

Some elements should be included in the AIM hierarchy even if there is no IETM ID. For example, these elements are typically used as “placeholders” in the some of the IETM’s viewers.

This information can be entered in two forms:

1) including just an element name (ex. TASK), where all element tags of TASK will be included
2) included an element name and attribute value (ex. TABLE; TABSTYLE=”INLINE”), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be included.

The [INCLUDE NO ID] section in the registration file would appear as follows:

```
[INCLUDE NO ID]
TASK
DESCINFO
```

Example from the SGML file of including an element even if no id:

```
<SYSTEM NAME="VOLUME 1" ID="OP4619v1Figures" VERSION="ver0">
<DESCINFO TYPE="FOLDER" VERSION="ver0">
<PARA-SEQ>
<PARA VERSION="ver0">
<GRAPHIC NAME="Mk 6 Guidance Assemblies." ID="OP4619v1c1f1s0p0" ITEMID="1-1.">
<GRPHPRIM ID="ACN-4619-11A" ITEMID="46190011.tif" CODING="FAX">
<TEXT>
</TEXT>
</GRPHPRIM>
</GRAPHIC>
</PARA>
```

The portion of the IETM table of contents looks as follows:

```
OP 4619
Volume 1
Contents
Illustrations
1 (corresponding to the DESCINFO element)
   Mk 6 Guidance Assemblies
   Interface Relationships
2
.
.
Tables
```

So, it is necessary to include the DESCINFO element in order to set up the folder named “1” in the AIM hierarchy, even though the DESCINFO element has no ID (and in this case, no name). The extraction algorithm mimics the display of the IETM in the IETM viewer by simply setting the name of the node to be the sequence number - in this case, it is “1”.
[TRAVERSE EVEN IF NO ID BUT NO HIERARCHY] section

There are some cases where an element is encountered that will not be included in the AIM hierarchy, but the element is critical to the AIM hierarchy because it contains children that should be included in the hierarchy.

This information can be entered in two forms:
1) including just an element name (ex. TASK), where all element tags of TASK will be traversed even if no id
2) included an element name and attribute value (ex. TABLE; TABSTYLE="INLINE"), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be traversed.

An example of this was seen when describing acceptable tags and will be repeated here.

Because the GRAPHIC and TABLE elements must be included in the AIM hierarchy, look at the DTD and determine potential elements that are containers for the GRAPHIC and TABLE elements. You will see that the PARA element is a container for graphic and table elements. You will also see that the PARA-SEQ is a container for the PARA element. Looking at the SGML file confirms this. You’ll also notice that the PARA-SEQ and PARA elements never show up in the GD SWS IETM viewer table of contents. So, this implies that these elements must be included in the registration file section of traversing the element but not including in the hierarchy.

The [TRAVERSE EVEN IF NO ID BUT NO HIERARCHY] section would appear in the registration file as follows:

[TRAVERSE EVEN IF NO ID BUT NO HIERARCHY]
PARA-SEQ
PARA
TECHINFO

Example from the SGML file showing PARA-SEQ and PARA elements which are traversed:

<DESCINFO TYPE="FOLDER" VERSION="ver0">
<PARA-SEQ>
<PARA VERSION="ver0">
<GRAPHIC NAME="Power Status and Control Panel." ID="OP4612v3c3f1s0p0" ITEMID="3-1."/>
<GRPHPRIM ID="ACN-IC4614-0035B-A2" ITEMID="46140035.tif" CODING="FAX">
<Text>
</TEXT>
</GRPHPRIM>
</GRAPHIC>
</PARA>
</PARA-SEQ>
</PARA>
</DESCINFO>

In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Illustrations” folder and then the “3” folder. Opening this folder shows the GRAPHIC element = “Power Status and Control Panel”. Notice that in the SGML file, the GRAPHIC element is a sub-element of the PARA element, which is a sub-element of the PARA-SEQ element. However, the PARA and PARA-SEQ elements have no names or Ids and are used as nothing more than containers, which is verified by looking at the DTD.
So, these tags have to be listed as elements to traverse in order to continue to look for the children of these elements; however, they will not be included in the AIM hierarchy.

**[TRAVERSE ONLY EVEN IF ID] section**

This section describes those elements that should be traversed for children but not included in the AIM hierarchy, even if the element does have an ID attribute. These elements could be considered as “placeholders” within the SGML file.

This information can be entered in two forms:

1) including just an element name (ex. TASK), where all element tags of TASK will be traversed even if no id

2) included an element name and attribute value (ex. TABLE; TABSTYLE="INLINE"), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be traversed.

This section in the registration file would appear as follows:

```
[TRAVERSE ONLY EVEN IF ID]
SYSTEM; ID=MenuDocumentAccess
SYSTEM; NAME=

Example from the SGML file showing SYSTEM elements that are traversed only even though they have an ID attribute:

<TECHINFO NAME="Fire Control System">

<VERSION ID="ver0" REVISION="1" REVDATE="040797" CHANGENO="2" CHGDATE="000000">
</VERSION>

<SYSTEM ID="MenuDocumentAccess" NAME="FCS MK 98 MOD 1 / GS MK 6 MOD 0" VERSION="ver0">

The “TECHINFO” element has already provided the name for the main level of the IETM structure. When the first “SYSTEM” element is encountered, we want to simply traverse it rather than include it in the hierarchy. The element is a main element that contains children that are important to the AIM structure, but this element is not important to be directly included in the hierarchy.

**[INCLUDE WITH REPLACEMENT NODE TITLES]**

This section describes those elements that are included but their element names are replaced with those listed in the registration file.

In the GD SWS IETM, this section would be blank because no such information is necessary, as follows:

*[INCLUDE WITH REPLACEMENT NODE TITLES]*
Example for another IETM:

[INCLUDE WITH REPLACEMENT NODE TITLES]
BODYREAR=LIST OF TABLES
REAR=LIST OF FOLDOUTS/ADDENDA
In this example, whenever a “BODYREAR” element is encountered, its name will be “LIST OF TABLES” in the IETM structure to be imported into AIM.

[TEXT NODE TYPES], [GRAPHIC NODE TYPES], [TABLE NODE TYPES] sections

These sections describe which elements are defined as text items, graphic items, or table items. Simply list the element tag names in each of these sections. This is mainly used for the browser displayed in AIM. If these elements are not completed, AIM simply won’t display an icon identifying the element as text, graphic, or a table. So, these sections are not critical to the extraction process; they will just make the display of the hierarchy in the browser have the additional information of the node type.

[IETM NAME ELEMENT] and [IETM VERSION ELEMENT] sections

These sections describe how to find the name and version number for the IETM. This information will be displayed in the AIM IETM Admin screen to show the list of IETMs that are currently stored in the database. This information is also used to create the first node in the IETM structure to be imported into AIM.

If either of these sections is blank, then the user will be prompted by the extraction program to enter the IETM name and version. There are some SGML files that do not have this information embedded within them, so the user must enter the information manually. This process is done immediately upon initiating the extraction process.

The [IETM NAME ELEMENT] and [IETM VERSION ELEMENT] sections in the registration file would appear as follows:

[IETM NAME ELEMENT]
TECHINFO; 1

[IETM VERSION ELEMENT]
SYSTEM; 1

The format for these sections is as follows:

ELEMENT; nth occurrence to find

The [IETM NAME ELEMENT] section indicates that the 1st occurrence of the TECHINFO element should be found for the name. The [IETM VERSION ELEMENT] section indicates that the 1st occurrence of the SYSTEM element is used for the version of the IETM.
Example from the SGML file showing the first TECHINFO element including the name for the IETM and the first SYSTEM element used to indicate the version of the IETM:

```xml
<TECHINFO NAME="Fire Control System">
    <VERSION ID="ver0" REVISION="1" REVDATE="040797" CHANGENO="2" CHGDATE="000000">
    </VERSION>
    <SYSTEM ID="MenuDocumentAccess" NAME="FCS MK 98 MOD 1 / GS MK 6 MOD 0" VERSION="ver0">
```

### 2.3.2 Description of Library File

A “library” file is used by software to reference the physical location of the DTD and any entity files used in conjunction with the DTD. A library file does not have to reside in the same directory as the DTD; however, for ease of use, the user may wish to keep this library file in the same directory as the SGML file, DTD file, registration file, etc. An example “library file” is shown below. Note that library files are normally created with a “.lib” extension.

```xml
LIBRARY
    
"-//USA-DOD//DTD SUP MIL-M-28001 MATHPACK 911001//EN"
"mathpac.ent"

"-//GD//DTD GD SWS TECHINFO//EN"
"gd269.dtd"

"-//USA-DOD//DTD Content Data Model Generic Layer//EN"
"87269.ent"

"-//EDS//ENTITIES EDS Special Symbols//EN"
"Eds-symb.ent"
```

The first line of each pair shows the “identifier” (name) of the DTD or of the entity file used in the DTD. The second line of each pair shows the physical location of the file. If a full path name is not included then the library file and each file referenced in the library file must reside in the same directory. If the files do not reside in the same directory, then a full path name must be included in the library file.

There are several “mistakes” to check for in the library file if the extraction program does not work successfully:

The path names for the DTD or entity files are not correct. Check your system and make sure that they have been defined correctly.

There are spaces in the file names. For example, the file name “87269.ent” is defined correctly, but the file name “ 87269.ent” is not. (Note the extra space at the beginning of the file name.) The functions used in the extraction program will not be able to successfully find this file.

The PUBLIC identifiers are not specified exactly as they are defined in the DTD or entity files. Check for spelling and addition of extra spaces in the declaration and in the DTD/entity files.
Identifiers are like addresses that allow the SGML processing system to locate resources. (In this case, the library file to locate the resources.) Note that in the above example all identifiers are PUBLIC identifiers. PUBLIC identifiers allow the file to be moved anywhere. They are typically used so that the resource can be moved between machines, etc. and a library file updated to indicate where these files are located. SYSTEM identifiers, on the other hand, contain a path location for a particular machine.

External parameter entities (in this case: mathpac.ent, 87269.ent, and Eds-symb.ent) used in a DTD provide several advantages: 1) they allow a DTD to be modularized, and 2) they allow publicly named material or documents to be used (ex. ISO standard entities).

**GD269.DTD**

The entry in the library is as follows:

"-//GD//DTD GD SWS TECHINFO//EN"
"gd269.dtd"

Explanation:

The DOCTYPE declaration in the SGML file is as follows:

```xml
<!DOCTYPE TECHINFO PUBLIC "-//GD//DTD GD SWS TECHINFO//EN">
```

So, the SGML file will look for a DTD with the identifier of "-//GD//DTD GD SWS TECHINFO//EN". The library file would be used to tell the processing system that the DTD with this identifier is called "gd269.dtd". If a path name were specified, the processing system would expect the file to be located at that path; because no path is specified in this case, the file is expected to be in the same directory as the library file.

**87269.ENT**

The entry in the library is as follows:

PUBLIC "-//USA-DOD//DTD Content Data Model Generic Layer//EN"
"87269.ent"

Explanation:

The DTD declares the entity file contained in the file “87269.ent” in the following statement:

```xml
<!ENTITY % dietmdb-a PUBLIC "-//USA-DOD//DTD Content Data Model Generic Layer//EN" > %dietmdb-a; 
```

Note that here the entity is declared by by external entity declaration (<!ENTITY % dietmdb-a "">) and is also initialized to be used in the document (by the reference %dietmdb-a;).

So, the SGML file will look for an entity with the identifier of "-//USA-DOD//DTD Content Data Model Generic Layer//EN". The library file would be used to tell the processing system that the entity with this identifier is located in the file “87269.ent".
**MATHPAC.ENT**

The entry in the library is as follows:

PUBLIC "-/USA-DOD//DTD SUP MIL-M-28001 MATHPACK 911001//EN"
"mathpac.ent"

Explanation:

The entity "-/USA-DOD//DTD Content Data Model Generic Layer//EN" (located in the file “87269.ent”) declares the entity file contained in the file “mathpac.ent” in the following statement:

<!ENTITY % mathpac PUBLIC "-/USA-DOD//DTD SUP MIL-M-28001 MATHPACK 911001//EN">%mathpac;

Note again that here the entity is declared by external entity declaration (<!ENTITY % mathpac >) and is also initialized to be used in the document (by the reference % mathpac:).

So, the SGML file will look for an entity with the identifier "-/USA-DOD//DTD SUP MIL-M-28001 MATHPACK 911001//EN". The library file would be used to tell the processing system that the entity with this identifier is located in the file “mathpac.ent”.

**EDS-SYMB.ENT**

The entry in the library is as follows:

"-/EDS//ENTITIES EDS Special Symbols//EN"
"Eds-symb.ent"

Explanation:

The DTD declares the entity file contained in the file “eds-symb.ent” in the following statement:

<!ENTITY % eds-symb PUBLIC "-/EDS//ENTITIES EDS Special Symbols//EN"> %eds-symb;

Note again that here the entity is declared by external entity declaration (<!ENTITY % eds-symb >) and is also initialized to be used in the document (by the reference % eds-symb:).

So, the SGML file will look for an entity with the identifier "-/EDS//ENTITIES EDS Special Symbols//EN". The library file would be used to tell the processing system that the entity with this identifier is located in the file “eds-symb.ent”.

### 2.3.3 Description of DDE Information File

The DDE information file contains all information necessary for AIM to have the capability to communicate with the IETM viewer. The DDE information is based on the viewer type; the viewer could be based on a COTS authoring/publishing tool (ex. Inso’s Dynatext product) or could be a custom-built viewer (ex. SWS).
The DDE Information file has the following format:

[DDE Message Information] (Required; used by AIM to verify appropriate DDE file)
TMMIAPP (Required; DDE Application value)
TECHINFO (Required; DDE Topic value)
C:\EDS\UAS\TMMIAPP.EXE (Required; path of the viewer executable)
C:\EDS\IETM-DBS\CONFIG (Required; configuration data path - or exe path if no config.)
[SHOW( (Can be blank; value to be appended to beginning of ID string for DDE command)
)] (Can be blank; value to be appended to end of ID string for DDE command)
1 (DDE command type - current defined values listed below)
Electronic Documentation System (Can be blank or "<none>": window name for IETM viewer)

Notes:

1. The window name is blank or is specified as “<none>” if the main window name for the IETM viewer changes while the IETM viewer is running. If the name is consistent, then it should be specified. Specification of the window name allows AIM to determine if the viewer is already launched and allows AIM to automatically launch the viewer prior to sending a DDE message; otherwise, the user is required to launch the IETM viewer prior to AIM sending a DDE message. For an IETM viewer whose window name is not constant, AIM will attempt to send a DDE message. If an application responds, then the DDE communication is successful; otherwise AIM will inform the user that (s)he must ensure that the viewer is already launched.

2. The current defined DDE command types, based on viewer authoring/publishing types, are:

1 = UAS 3.x or 4x
2 = POKE ARCI
3 = DYNATEXT
4 = GUIDE READER
5 = AIMSS
6 = HTML
7 = UAS 5.x
8 = ATIS viewer
9 = PMS Viewer (proprietary viewer for PMS documents)
10 = Adobe Acrobat/Reader for displaying PDF files
An example for the SWS EDS viewer is as follows:

[DDE Message Information]
TMMIAPP
TECHINFO
C:\EDS\UAS\TMMIAPP.EXE
C:\EDS\IETM-DBS\CONFIG
[SHOW(
)]
1
Electronic Documentation System

3.0 Other IETMs

3.1 Introduction

The AIM program extracts hierarchical information from other types of IETMs that are not based on an SGML file (either authored with SGML or able to provide an SGML file rendition of the database) and formats the information for import into the AIM database. The extraction program is written in Visual Basic 5.0 and requires a 32-bit operating system for execution. The extraction program requires various files to be available based on the particular type of IETM.

3.2 ARCI IETM

The Acoustic Rapid COTS Insertion (ARCI) IETM is built upon a relational database. Therefore, the extraction program examines the appropriate tables within the database to build the structure of the IETM. The extraction program requires the use of ODBC drivers in order to access and work with the relational database. These (32-bit) ODBC drivers are installed when the ARCI IETM is installed from the CD. The extraction can be completed for either IETM display using the proprietary viewer or HTML viewer.

3.2.1 Introduction

The ARCIEXTR.EXE program extracts hierarchical information from an IETM based on a Sybase relational database and formats the information for import into the AIM database. The extraction program is written in Visual Basic 5.0 and requires a 32-bit operating system for execution. In addition, 32-bit “Sybase SQL Anywhere 5.0” ODBC drivers are required for accessing the Sybase database. The extraction program requires that the database be registered with the 32-bit ODBC driver (which automatically is completed when installing the IETM).
3.2.2 Installing the ARCI IETM Extraction Program

A setup program has been created to install the ARCI extraction program and all related necessary files into appropriate directories. Run the setup program provided. The “arciextr.exe” and “arciextr.mdb” files will be installed in the AIM I program directory.

Note that it is assumed that the ARCI IETM is already installed from the ARCI IETM CD. If not, the ARCI IETM should also be installed at this point. This installation process will install the ARCI IETM as well as all (32-bit) ODBC drivers necessary for interfacing with the database, and will register the ARCI database with the ODBC driver.

3.2.3 Running the ARCI IETM Extraction Program

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “ARCI” option, and click on the Next button. The “IETM Extraction Utility / Extraction Output” screen will be displayed, which prompts the user to name the resulting output file created by the extraction program. (These initial screens are discussed and shown in “Running the SGML IETM extraction program.” After the user types in a name and hits the Next button, the first screen for the ARCI Extraction program will appear. This screen is shown below.

This screen initially informs the user that it is expected that the ARCI database has already been registered with ODBC. (If the ARCI IETM was installed from the ARCI CD, this registration will already have been completed. If the ARCI IETM has not been installed, complete this process prior to attempting to run the extraction program.)

The user should click the “Extract” button to initiate the extraction process. A “Select Data Source” screen will appear, prompting the user to choose the appropriate database from which to extract the IETM structural information.
The user should select the “Machine Data Source” tab, highlight the data source name, and then click the OK button.

A screen that prompts for the type of viewer used for this IETM will be displayed. The viewer for the various IETMs may either be the PowerBuilder viewer or an HTML viewer (IETM is viewed via Internet Explorer). Select the appropriate type of viewer. If the viewer is HTML, a location for the HTML files must be selected. This should be the main directory for the HTML files, where the index is located; there may be other subdirectories within this main directory. In addition, the IETM may use some other types of files, so the location of files for AIMSS, AVI, PDF, and PCU files must be specified. (These directories are typically labeled clearly for the individual types of files.)

The extraction program will then complete the analysis of the ARCI database and the extraction of appropriate structural data of the IETM that should be imported into the AIM database. When this process is complete, a message box will appear informing the user that the ARCI IETM has been successfully extracted.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)
3.3 PDF Documents

3.3.1 Introduction

To allow Related Instructor Activities to be linked to individual pieces of a PDF document, a “PDF extraction” routine has been created. The PDF document is rendered through Adobe Acrobat. Typically a PDF contains a Table of Contents that is described by bookmarks. However, communicating with a PDF file from an external program can only be accomplished using named destinations that are established in the PDF files. These named destinations are destination paths that are not sensitive to specific page numbering. In some cases, these named destinations are set up to be the same name as bookmarks. The AIM IETM / PDF extraction routine extracts the named destinations to allow links to be made from the Related Instructor Activities to the corresponding pieces of the PDF document. If only bookmarks are included in the PDF, then a conversion process needs to be made to save a copy of the bookmarks as named destinations. The resulting extraction is a flat list of named destinations, with no hierarchical information such as is seen when using bookmarks.
Note: The PDF document could have been rendered as a result of a process based on all information contained in an SGML file. In this case, the SGML extraction in section 2.0 should be used, with the appropriate Messaging information set to utilizing a “viewer type” of PDF. In this case, the node IDs in the SGML file must be carried forward as named destinations into the PDF file (or bookmarks which can be converted to named destinations via the proprietary product discussed below).

3.3.2 Installing the PDF Extraction Routine

The PDF extraction routine is part of the AIM module “IETM Extraction.exe”. No special installation is required beyond the normal AIM Installation.

3.3.3 Running the PDF Extraction Routine

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “PDF” option, and click on the Next button. The first screen specifically for the PDF Extraction program will appear. This screen requests the user to find the location of the PDF files to be extracted. After locating the file by using the Browse button, click on the Next button.

If the user checked the box indicating that a separate file is used to list all named destinations, then a screen will appear to prompt the user for this file. Browse to find the file, and then click on the Next button.
A screen will appear, prompting the user for the location of the result of the extraction process.
Figure D-13 PDF Extraction Output Location
A screen will now appear indicating that all necessary information has been entered to complete the extraction. Click on the Extract button.

When this process is complete, a message box will appear informing the user that the PDF file has been successfully extracted.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)

### 3.4 PMS Documents

#### 3.4.1 Introduction

To allow Related Instructor Activities to be linked to individual MIPs/MRCs, a “PMS Documents extraction” routine has been created. The PMS database is a Microsoft Access database. The routine extracts all MIPs/MRCs. If the extraction is performed on a “hull specific” CD, then the MIP/MRCs will be tied back to the work center, hull, etc. If the extraction is performed on a “reference” CD, then the extraction of the MIPs/MRCs is simply a list without a hierarchical structure tied to an activity.

#### 3.4.2 Installing the PMS Documents Extraction Routine

The PMS documents extraction routine is part of the AIM module “IETM Extraction.exe”. No special installation is required beyond the normal AIM Installation.

#### 3.4.3 Running the PMS documents Extraction Routine

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “PMS Documents” option, and click on the Next button. The first screen specifically for the PMS Documents Extraction program will appear. This screen requests the user to find the location of the PMS documents database to be extracted (*.pms). After locating the file by using the Browse button, click on the Next button.
A screen will appear, prompting the user for the location of the PMS Viewer. After locating the PMS Viewer by using the Browse button, click on the Next button.
Figure D-15 PMS Viewer Location
A screen will appear, prompting the user for the location of the result of the extraction process.

![IETM Extraction Utility](image)

**Figure D-16 PMS Extraction Output**

A screen will now appear indicating that all necessary information has been entered to complete the extraction. Click on the Extract button. When this process is complete, a message box will appear informing the user that the PMS document file has been successfully extracted. After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)

### 3.5 Raster Technical Manuals

#### 3.5.1 Introduction

To allow Related Instructor Activities to be linked to individual pages in an ATIS Raster Technical Manual, a “Raster Tech Manuals extraction” routine has been created.
3.5.2 Installing the Raster Technical Manuals Extraction Routine

The Raster Technical Manuals extraction routine is part of the AIM module “IETM Extraction.exe”. No special installation is required beyond the normal AIM Installation. However, there are two files that are required as input to this extraction process: 1) a file listing individual documents and references within those documents which is created from the ATIS database using a SQL query; 2) a file listing all documents and their titles that were referenced in the previously mentioned file.

3.5.3 Running the Raster Technical Manuals Extraction Routine

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “Raster Tech Manuals” option, and click on the Next button. The first screen specifically for the Raster Tech Manuals Extraction program will appear. This screen requests the user to find the location of the SQL data file and document title file. After locating the files by using the Browse buttons, click on the Next button.

![IETM Extraction Utility](image)

**Figure D-17 Raster Tech Manual Files**

A screen will appear, prompting the user for the location of the ATIS Interface program, which is used for viewing individual Raster Tech Manuals. After locating the program by using the Browse button, click on the Next button.
A screen will appear, prompting the user for the location of the result of the extraction process. This creates a directory under which all individual Raster Tech Manual document extraction files will be stored.
Figure D-19 Raster Extraction Output

Extraction Output Directory
Where would you like to store the resulting extraction files?

Use the Browse button or enter the directory you want to write the resulting extraction files, and then click Next.

Location: C:\etmsg\Raster TM

[Figure D-19 Raster Extraction Output]
A screen will now appear indicating that all necessary information has been entered to complete the extraction. Click on the Extract button. When this process is complete, a message box will appear informing the user that the Raster Technical Manual file has been successfully extracted.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.) Note that only the individual Raster Tech Manuals that are necessary should be imported into AIM.

3.6 XML-Based IETMs

3.6.1 Introduction

To allow Related Instructor Activities to be linked to XML-authored / HTLM-delivered IETMs, an “XML-based extraction” routine has been created.

3.6.2 Installing the XML-Based IETM Extraction Routine

The XML-based extraction routine is part of the AIM module “IETM Extraction.exe”. No special installation is required beyond the normal AIM Installation. However, there are two files that are required as input to this extraction process: 1) the XML IETM file; 2) the DTD/IETM “registration” file.

This extraction program works in a similar manner as the SGML extraction routine. The extraction program traverses the hierarchical nature of the XML IETM and writes out each pertinent node’s information to a flat file; the resulting flat file is then used to import the hierarchy information into the AIM database. This hierarchy essentially mimics the table of contents used in the IETM.

The extraction program utilizes functions to parse the XML file, based on the specified registration file. The extraction program traverses the hierarchy of the XML file and extracts pertinent elements and information. Because of the interactive nature of the IETM, not all elements in the XML file will be included in the AIM hierarchy. Elements that are included in the IETM solely for the interactive nature of the IETM are ignored by the extraction program (as dictated by the registration file) and are, therefore, not included in the “flat file”.
As each element is analyzed during the extraction process, it is determined if the element has an ID. Typically, an element is included in the AIM hierarchy if the element has an ID and it is not solely involved in the interactive nature of the IETM. If an element has an ID, then the AIM program can automatically position to the node in the IETM, utilizing browser-based technology. However, in some cases, the element is only a “container” for other elements in the SGML file and must be traversed and/or included even if there is no ID. An element with no ID is traversed if it is a container with sub-elements that should be included in the AIM hierarchy.

An element with no ID can be included in the AIM hierarchy if it is a “placeholder” in the IETM table of contents. However, the corresponding node information in the flat file indicates that there is no ID present and no messaging / attempt to launch will be completed for the node.

The program utilizes a “registration file” (ex. *.inf) that describes the IETM and those elements that will be included in the AIM hierarchy. This “registration” file describes the elements that are included in the hierarchy, the elements that should be included even if no ID, the elements that should be traversed, etc. This registration file is critical to the successful extraction of the IETM’s hierarchical content, which will be imported into the AIM database. The XML files (and the schema upon which the XML file is based, if necessary) should be examined carefully when setting up the “registration” file. (Note: With the XML file, case (uppercase/lowercase) is very important when indicating elements that should be included, excluded, etc.) The “registration” file should be able to be set up for a particular schema and utilized for any XML IETMs that make use of that specific schema. (Please see Section 2.3.1 under the SGML extraction description for a complete description of the registration file.)

### 3.6.3 Running the XML-Based IETM Extraction Routine

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “XML-based” option, and click on the Next button. The first screen specifically for the XML-Based IETMs extraction program will appear. This screen requests the user to find the location of the XML file and the registration file. After locating the files by using the Browse buttons, click on the Next button.
A screen will appear, prompting the user to indicate how the IETM is viewed. Typically the XML-Based IETMs are viewed via the browser, but the option to view IETMs developed and delivered in AIMSS 4.x is available. After selecting the option for viewing the IETM, click on the Next button.
A screen will appear asking the user to indicate whether the IETM should be viewed via a browser or via alternative methods (ex. ATIS). (Note: This is currently set up in preparation for viewing through ATIS, but has not been practically used as of yet.) After selecting the option for viewing the IETM via a browser (or alternative), click on the Next button.
A screen will appear, prompting the user for the location of the HTML files that are delivered as the IETM package. After locating the directory by using the Browse buttons, click on the Next button.
Figure D-23 HTML Files Directory

HTML Files Directory
Where is the main directory for the package of HTML files?

Use the Browse button or enter the directory where the HTML files (or subdirectories containing HTML files) are located, and then click Next.

Location: [Input Field]  [Browse]
A screen will appear, prompting the user for the location of the result of the extraction process. This creates a directory under which all individual XML extraction files will be stored.

![HTML Files Directory](image)

Figure D-24 HTML Files Directory (complete)

A screen will now appear indicating that all necessary information has been entered to complete the extraction. Click on the Extract button. When this process is complete, a message box will appear informing the user that the XML file has been successfully extracted.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)

### 3.7 S1000D-Based IETMs

#### 3.7.1 Introduction

To allow Related Instructor Activity to be linked to XML-Based IETMs Using the S1000D Extraction Routine. The extraction program traverses the organization of the data modules defined in the publication module and writes out each data module’s information to a flat file; the resulting flat file is then used to import the hierarchy information into the AIM database. This hierarchy essentially mimics the table of contents used in the IETM.
The extraction program utilizes functions to parse the publication module file. Individual data modules are parsed for title and versioning information.

3.7.2 Running the S1000D Extraction Routine

The following steps will create an IETM extract from the appropriate S1000D file, to be used as a reference in a course it will still need to be imported into the AIM database.

1. From the main AIM menu select Utilities
2. From the Utilities drop down menu select Admin Utility
3. From the Administration Utility menu select Contents, then IETM
4. From the IETM screen select File, then Extract, the IETM Extraction Utility screen will appear.

![IETM Extraction Utility](image)

**Figure D- 25 IETM Selection**

5. Select the S1000D 2.x/3.x XML Package option, then click Next.
6. From the XML Authoring / Extraction Files screen, either type the file location in the text box or click the Browse button to browse to the file location. After the file is selected click Next.

**NOTE:** The file name must be a PM file as seen in the figure below.
7. The NSIV 3.x viewer display information screen is displayed, as seen in the figure below. Input location of the NSIV servlet, if not known use the default. If Country/Language Code checkbox is checked input the appropriate Code, the code for English is _en-US. Click Next.
**NSIV 3.x viewer display information**

Information required for AIN to request to launch a publication and data module in the NSIV viewer.

The servlet URL must be supplied: host and port information designation, as well as the location of the nsiv.jsp.

Servlet URL Info: [http://localhost:7880/NSIV/nsiv.jsp](http://localhost:7880/NSIV/nsiv.jsp)

- Country/Language Codes should be appended to DMC code launch:
  - en-US

---

**Figure D- 27 NSIV Viewer Selection**
8. The Extraction Output screen, like the figure below, is displayed, either type the location of the extraction file or click the browse button to determine the location of the extraction file. Click Next.

![Image of Extraction Output screen]

**Figure D-28 S1000D Extraction Output**

9. The Extraction Data Summary screen is displayed, like the figure below, make note of where the extraction file will be created. Also, notice the extraction file has a ".aim" file extension.
10. Click on Extract to create the S1000D IETM extract file. Remember that to use this IETM it must be imported into the AIM database.
APPENDIX E

AIM I Version 5.1 Functional Changes

Appendix E: Version 5.1 Functional Changes
   1.0  AIM I General ............................................................................................................ E-1
   2.0  Learning Object Module ............................................................................................ E-1
AIM I Version 5.6

- **AIM I/LO Module**
  - Added the ability to add Distribution Statements to the TPP, TCCD, LP and TG.
  - Track Access/Changes to data in AIM I/AIM II/LO Module
  - Add, delete, and modify elements/sub-elements in Lesson Overview/Summary
  - Alphabetize Glossary Elements and Print Comprehensive Glossary with Lesson Plans in Learning Object Module
  - Allow capability to add Text after IETMs selected as a Resource for a Test Item
  - Add ability to create Outline Sheets at Course, Module and Lesson Level in Learning Object Module
  - Display Practice and Assessment Items in Lesson Plan in Learning Object Module
  - Create option to create NCW at the sub-element level in Learning Object Module
  - Option to omit references from Information Sheets
  - Allow TG Sheets as resources for practice or assessment items in Learning Object Module
  - Add Lesson Plan Option to NOT Print Section Front Matter
  - Export Practice Questions to QuestionMark Perception
  - Support for NETC Note 1500 on Metadata Standard
  - ECGs Selectable in LOM
APPENDIX F

SCORM AND NILARS

1.0 Sharable Content Object Reference Model (SCORM) Overview
   1.1 SCORM Content Model Components

2.0 Navy Integrated Learning Asset Repository System (NILARS) Overview
   2.1 Potential Uses of AIM Data in NILARS Repository System

3.0 Developing SCORM Data
   3.1 Creating a SCORM Output
   3.2 SCORM Data Content
   3.3 Detailed Contents of the AIM-to-SCORM Output Package
(This Page Intentionally Left Blank)
1.0 SHARABLE CONTENT OBJECT REFERENCE MODEL (SCORM) OVERVIEW

SCORM is a set of specifications published by Advanced Distributed Learning (ADL) for developing, packaging and delivering high-quality education and training materials wherever and whenever they are needed. SCORM compliant courses leverage course development investments by ensuring that compliant courses are Reusable, Accessible, Interoperable and Durable.

- Reusable: easily modified and used by different developing tools.
- Accessible: can be searched and made available as needed by both learners and content developers.
- Interoperable: operates across a wide variety of hardware, operating systems, and Web browsers.
- Durable: does not require significant modifications with new versions of system software.

In the SCORM the Learning Management System (LMS) has the ability to determine what to deliver and when, and tracks student progress through the learning content through its Application Program Interface (API).

1.1 SCORM Content Model Components

SCORM Content Model Components define how the lower-level sharable, reusable, learning resources are aggregated to compose higher-level units of instruction.

Assets, Sharable Content Objects (SCOs), and Content Aggregations are components that are considered specifications of learning resources.

- Assets: electronic representations of media, text, images, sound, Web pages, assessment objects or other pieces of data that can be delivered to a Web client. The mechanism for binding Assets to Asset Metadata (data about data) is the Content Package. In the current AIM-to-SCORM output, the graphics used in TG sheets are the assets that are the output along with the entire course package. The repository will be able to identify these as separate assets and store them for reuse, independent of the course package (aggregation) or any of the SCOs (Topics) in which they are used.

- Sharable Content Object (SCO): SCO represents a collection of one or more Assets that include a specific launchable asset that utilizes the SCORM Run-time Environment to communicate with Learning Management Systems (LMSs). A SCO represents the lowest level of granularity of learning resource that can be tracked by an LMS using the SCORM Run-Time Environment. The Topic for a course and Lesson/Sections for Learning Objects are the SCO in the current SCORM output from AIM. The Topic includes Instruction Sheets identified in Related Instructor Activities (RIAs).
• Content Aggregation: A content aggregation is a map (content structure) that can be used to aggregate learning resources into a cohesive unit of instruction. AIM aggregates all the Topics (SCOs) in a course into the output package (aggregation), which has course level metadata as per SCORM v1.2 and 2004 requirements.

2.0 NAVY INTEGRATED LEARNING ASSET REPOSITORY SYSTEM (NILARS) OVERVIEW

NILARS is an initiative of the Office of Training Technology to obtain and employ state-of-the-industry content management systems for use by DoD.

• The object is to reduce costs by making individual data assets readily accessible and easily shared within DoD.
• The approach is to use commercially available learning content management software or remove individual data assets from their current packages (lessons, courses, IETMs, etc.), standardize naming of the assets, restore them as individual assets, and make them accessible for reuse.
• The purpose of the NILARS is to provide a learning content object repository used by multiple developers at multiple sites and enable an environment where developers can create, store, reuse, manage, deliver and share learning content.

2.1 Potential Uses of AIM Data in NILARS Repository System

The goal of the Authoring Instructional Materials (AIM)-to-SCORM utility, funded jointly by the ADL CoLab Orlando and NAVAIR Orlando, is to leverage the huge body of existing classroom-based curricula for multiple additional uses in e-Learning and other areas. Refer to Figure 1.
The SCORM-compliant output of AIM (XML-based SCOs packaged at the course topic level) is designed to leverage that existing content as:

1) Input to emerging Electronic Performance Support Systems (EPSSs), such as Interactive Electronic Technical Manuals (IETMs)

2) The “70%” solution as input to Web-based Training (WBT) authoring tools for repurposing as asynchronous, just-in-time training opportunities – to support classroom training, as a parallel path for students unable to attend classroom training, or as a replacement for the traditional course

3) For delivery “as is” via a Learning Management System (LMS), particularly to support structured onboard training as envisioned by the Executive Review of Navy Training (ERNT)
4) As the baseline input to various Electronic Classroom Integration Software (ECIS) applications, such as General Dynamics Elite software used by the submarine community and the Electronic Lesson Plan (ELP) software used by Aegis Training and Readiness Center (ATRC) in their Automated Electronic Classrooms (AECs)

The NILARS Repository should eventually be the lynchpin of all this reuse of AIM-generated curricula data – the primary input from AIM being to NILARS, with automated configuration management, rights management, and user notification occurring via the repository system.

3.0 Developing SCORM Data

3.1 Creating a SCORM Output

The Advanced tab, of the Preferences option from the AIM main menu, gives you the Metadata Spec option to implement NSCORM or SCORM specifications using either 2004 or v1.2 structure for creating SCORM compliant files. SCORM 2004 is automatically selected when the NSCORM Metadata Specification is selected.

To select the desired SCORM output version:

Step 1 Log into AIM I.

Step 2 From the AIM main menu click on the Options menu item and the Preferences option.

Step 3 From the User Preferences window click on the Advanced tab.

Step 4 Select the desired Metadata Specification by clicking on the down arrow in the Metadata Spec field. Select either NSCORM, or SCORM Metadata Specification.

Step 5 If SCORM was selected as the Metadata Spec, select the desired version of SCORM (1.2 or 2004) by clicking on the down arrow in the SCORM Version field. 2004 is automatically selected for NSCORM.

Step 6 Click on the Apply button and then the OK button to close the User Preferences window.

NOTE: SCORM output can be generated for an Approved course using the SCORM Utility.
Step 7  Select the Course menu item and the Select sub-menu item.

Step 8  From the Course Select menu: highlight the Approved course that you want to create the SCORM files for and click on the Select menu item.

Step 9  Click on the Document menu item and the SCORM Data sub-menu item or click on the SCORM icon.

Step 10 The SCORM output can be created for the entire course by opening the course folder in the browser and selecting the File menu item and the Generate SCORM Output sub-menu item. AIM will output the Topic SCOs to a directory titled by CIN, Rev and Change, which will contain a zip file. This zip file can be sent to NILARS to import the aggregation, SCOs, and assets. The key element is the Package Identification File (PIF) that enables the repository, i.e., NILARS, to understand the contents.

Step 11 To view the Topic files (SCOs) created in the SCORM Output, extract the files contained in the zip file to a temporary directory and double click on the desired Topic XML files. The files will open in Windows Internet Explorer.

3.2 SCORM Data Content

The SCORM Data represent the information required for development of Metadata (data about data) files. Metadata files provide a common nomenclature enabling learning resources to be described in a common way. Metadata can be collected in a catalog, as well as directly packaged with the learning resource it describes. Learning resources that are described with Metadata can be systematically searched for and retrieved for use and reuse. Aggregation (course) and SCO (topic) have certain metadata fields that are required. Asset (TG graphic) has only a small subset of those same fields required. The following categories contain mandatory elements (identified with an asterisk by the data entry box) and optional information.

AIM provides default information for the mandatory fields in the categories to develop Metadata files. When developing the course, the categories for the course, topics, and graphics can be edited by the developer from the SCORM Data window, which is accessible by selecting the desired course in the Course Select menu and selecting the Document main menu item and the SCORM Data sub-menu item or by clicking on the SCORM icon. The browser in the left pane allows you to open the desired folder to edit the categories. The course information can also be edited from Lesson Plan window (Cover Page) by selecting the Contents menu item and the SCORM Metadata sub-item. The information for individual Topics (SCOs) can be edited from the Lesson Plan (LP) window (COI) by highlighting the desired Topic, selecting the Contents
menu item and clicking on the **SCORM Metadata** sub-menu item. The information required for metadata depends on the Metadata Specification (NSCORM or SCORM) and the SCORM version (V1.2 or 2004) selected.

The metadata information is required if the metadata category is bolded.

When *NSCORM/2004, SCORM/2004, or SCORM/v1.2 Metadata Specification/Version* is selected for task-based Curriculum development, in accordance with NAVEDTRA 103A methodology, the following metadata categories will appear. Items in blue identify the v1.2 differences.

1.0 General - Provides administrative details on the learning object
   1.1 Identifier - Unique ID
      1.1.1 Catalog - Specify the classification system used to assign a unique ID
      1.1.2 Catalog Entry - Specify the value of the ID in the classification system
   1.2 Title - Give name to object
   1.3 Description - Provide a description of the key characteristics and issues associated with the object from the perspective of the developer for another developer to read
   1.4 Keywords - Provide keywords to aid in searching and browsing of content objects in a repository

2.0 Lifecycle - Provides a history of changes to an object through stages of development especially status of workflow processes
   2.1 Version - Specify the current version of an object. Should be updated as the object is modified over its lifecycle
   2.2 Status - Specify the completion status of an object along its lifecycle. Update this value as the object's status changes during workflow processes

3.0 metaMetadata - Describe the source and nature of the information in the metadata record itself. This information describes the metadata not the learning object. Thus, it is a record of who filled out the metadata for the learning object.
   3.1 Identifier - Identify metadata record with a unique ID. This is not the same as identifying the learning object
      3.1.1 Catalog - Specify the classification system used to assign a unique ID
      3.1.2 Catalog Entry - Specify the value of the ID in the classification system
   3.3 metadataSchema - Enter names of metadata schema used to create metadata for learning object

3.3 metadataSchema - Enter names of metadata schema used to create metadata for learning object

**NOTE: Second metadataSchema not required for v1.2**

4.0 Technical - Specify the technical details and technical requirements for an object
   4.1 Format - Specify the file formats used in the object
   4.2 Location - State the physical location of the objection
5.0 Rights - Specify the cost of use or copyright information for the object
   5.1 Cost - Specify whether or not the object requires payment
   5.2 Copyright and other Restrictions - Specify whether or not the object has any restrictions on use

When **NSCORM Specifications** is selected, the SCORM 2004 version is selected automatically for Learning Object development. The following metadata categories will appear.

**NOTE:** When SCORM Specification is selected with version 2004 or v1.2 the Security Classification portion (10.0) is absent and different items are bolded for required entry. Also, the Location (4.3) is added for v1.2.

1.0 General - Provides administrative details on the learning object
   1.1 Identifier - Unique ID
      1.1.1 Catalog - Specify the classification system used to assign a unique ID
      1.1.2 Catalog Entry - Specify the value of the ID in the classification system
   1.2 Title - Give name to object
   1.3 Language - Specify primary language of object
   1.4 Description - Provide a description of the key characteristics and issues associated with the object from the perspective of the developer for another developer to read
   1.5 Keywords - Provide keywords to aid in searching and browsing of content objects in a repository
   1.7 Structure - Specify the relationship between object components

2.0 Lifecycle - Provides a history of changes to an object through stages of development especially status of workflow processes
   2.1 Version - Specify the current version of an object. Should be updated as the object is modified over its lifecycle
   2.2 Status - Specify the completion status of an object along its lifecycle. Update this value as the object's status changes during workflow processes
   2.3 Contribute - Specify the person or organization that contributed to the object
      2.3.1 Role - Describe the role that the contributor played in the object's development
      2.3.2 Entity - Specify the name of the person or group working on the object
         Role Name - Specify the name of the person or group working on the object
         Role Address
         Role Email
      2.3.3 Date - Specify a date for a contribution
         Date - Specify a date for a contribution
         Date Description - Specify a date for a contribution
3.0 metaMetadata - Describe the source and nature of the information in the metadata record itself. This information describes the metadata not the learning object. Thus, it is a record of who filled out the metadata for the learning object.

3.1 Identifier - Identify metadata record with a unique ID. This is not the same as identifying the learning object

3.1.1 Catalog - Specify the classification system used to assign a unique ID
3.1.2 Catalog Entry - Specify the value of the ID in the classification system

3.2 Contribute - States who developed the metadata for the object. This is not necessarily the same person or group who developed the learning object

3.2.1 Role - States the workflow process role of the person creating the metadata record (not the learning object)
3.2.2 Entity - Name of the person or group creating the metadata record
Role Name - Name of the person or group creating the metadata record
Role Address
Role Email
3.2.3 Date – State the date the metadata record is created or changed
3.2.3.1 Date - Enter value of the date
3.2.3.2 Date Description - Enter text description of issues or activities relating to the date this metadata record is made

3.3 metadataSchema - Enter names of metadata schema used to create metadata for learning object

4.0 Technical - Specify the technical details and technical requirements for an object

4.1 Format - Specify the file formats used in the object

4.2 Duration - Specify the average time it takes to complete an object
Time(HH:MM:SS) - Specify the average time it takes to complete an object
Description - Specify the average time it takes to complete an object

5.0 Educational - Provides information on the educational nature of the object

5.1 Interactivity Type – Specify the learning mode intended when using the object

5.2 Learning Resource Type - Specify the type of learning object from a learning event perspective

5.3 Interactivity Level – Describe the degree of user interactivity while using the object in a learning event
5.5 Intended End Use Role - Describe the type of user intended for object
5.6 Context - Describe the type of environment intended for using the object
5.8 Difficulty - Specifies how hard the learning material is in the object
5.9 Typical Learning Time - Specifies an estimated amount of time for the learner to go through the material in the object
  5.9.1 Duration (Days)
  5.9.1 Duration(HH:MM:SS) – Specifies time value
5.9.2 Typical Learning Time Default - Describe characteristics or issues associated with the time value assigned
5.10 Description - Describe how the learning object should be used in a learning event
5.11 Language - Specify primary language of intended user of object
6.0 Rights - Specify the cost of use or copyright information for the object
  6.1 Cost - Specify whether or not the object requires payment
  6.2 Copyright and other Restrictions - Specify whether or not the object has any restrictions on use
  6.3 Description - Describe issues or provide context details on copyright information for the object
7.0 Relation - Specify relationships among this learning object and other learning objects. These are strong relationships not the ordering of objects for a learning event which is handled by the Sequencing and Navigation data model.
  7.1 Kind - Specify nature of the relationship between this learning object and another object.
  7.2 Resource - Defines the second object
    7.2.1 Identifier - Defines unique ID for the second object.
      7.2.1.1 Catalog - Defines the classification system for the ID of the second object.
      7.2.1.2 Catalog Entry - Defines the value of the ID of the second object.
    7.2.2 Resource Description - Identify metadata record with a unique ID. This is not the same as identifying the learning object
8.0 Annotation - Provides comments on the educational use of the object to enable better understanding among developers of how to best use the object.
  8.1 Entity - States the name of the person(s) creating the annotation
    Role Name - States the name of the person(s) creating the annotation
  8.2 Annotation Date - States the date the annotation was created
    8.2.1 Date - States the date the annotation was created
    8.2.2 Date Description - Enter text description of the date
  8.3 Annotation Description - Enter text description of the annotation
9.0 Classification - Describe object using external classification systems
  9.1 Purpose - Describe the reason for classifying the object with an external classification system
9.2 TaxonPath - Defines the taxonomy nodes used from the external classification systems

9.2.1 Source - Defines the name of the taxonomy used
9.2.2 Taxon - Defines the value of the taxonomy node(s) used. Multiple nodes can be assigned from one taxonomy.

9.2.2.1 Taxon ID - ID value used in the external taxonomy
9.2.2.2 Taxon Entry - Text value of the ID value used in the external taxonomy

9.3 Classification Description - Comments on why external classification systems used or associated issues

9.4 Keywords - Keywords to describe the external classification system or why it is used

10.0 Security Classification – Provide security classification for learning object

10.1 Type - Describe the type of the classification whether for US, non-US, joint, foreign, dissemination, SCI, or others

10.2 Classified By – Provide security classification that meets US and additional requirements

10.2.1 Name - Provide the name of the individual who classifies the content
10.2.2 Agency - Provides the controlling authority for the classification of the content

10.2.3 Date – Provides the date for the original classification of the content
10.2.4 Reason – Provides the reason for classifying content at a given level

10.3 Marking – Provides the actual security marking for the type of classification designated in the Classification Type Element

3.3 Detailed Contents of the AIM-to-SCORM Output Package

The files contained in the AIM-to-SCORM output package are generated to conform to SCORM Version 1.2 and SCORM 2004 include:

1. imsmanifest file…which contains the “structure” or organization of the course. The content of this file includes references and locations of all SCOs, raw media files, metadata files, and supporting files. It also lists dependencies between the files.

2. SCOs…are associated with each Topic of the course or Lesson/Sections in the Learning Object Module and are generated as XML content. A corresponding XSL stylesheet is referenced in each SCO in order to have the XML rendered to HTML by the Internet Explorer 5.0 browser (with MSXML 3.0 installed in “replace” mode). (Ex. 1-1.xml) If Internet Explorer 6.0 or higher is used, MSXML does not have to be installed in replace mode.

3. Graphics files (Raw media files)…are stored in the graphics directory of the package. These are stored in .jpg format.
4. Metadata files for the course, SCOs, and graphics files. (Ex. 1-1_meta.xml; 20000001_meta.xml). These metadata files correspond to the IMS spec.

5. API files…which are necessary for communication with the LMS. These files are referenced in the rendered HTML files.

6. DTD and entity files… specifically related to the SCOs. Because the SCO content is in XML format, there are corresponding DTD and entity files associated with the SCOs. (Topic.dtd, TaskandMaterial.ent, TestInfo.ent, TextContent.ent)

7. XSL stylesheet (Topic.xsl) and Cascading Style Sheet (SCORMTopic.css)… Because the SCOs are generated as XML content, there is an XSL stylesheet referenced with the SCO in order to allow the XML content to be rendered as HTML and displayed in the IE 5.0 browser (as described previously). A Cascading Style Sheet (CSS) is associated with the rendered HTML document.

The AIM I-to-SCORM output does validate against the final SCORM 2004 Conformance Suite software posted at ADLnet.org.