(This Page Intentionally Left Blank)
Preface

This manual (Document Identification No. AIM II SUM 00005) was developed for the AIM System Support Office (SSO) to support the computer software configuration item identified as Task Based Authoring Instructional Materials (AIM II). It was prepared in accordance with DOD-STD-2167A, Data Item Description DI-MCCR-80019A.

The AIM SSO is responsible for all aspects of the AIM Program management and support. It is the initial point of contact for all matters dealing with the AIM Program or specific hardware or software issues.

AIM users can call the AIM Help Desk at the following numbers:

<table>
<thead>
<tr>
<th>Service</th>
<th>Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>SSO Help Desk</td>
<td>(407) 381-8620</td>
</tr>
<tr>
<td>SSO FAX</td>
<td>(407) 380-4519</td>
</tr>
<tr>
<td>SSO Email</td>
<td><a href="mailto:ETEHELPDESK@navy.mil">ETEHELPDESK@navy.mil</a></td>
</tr>
</tbody>
</table>

The AIM SSO operates from 0700-1630 Monday through Friday. An evening answering machine is available when the AIM Help Desk is not manned.

Mail should be addressed to:

NAVAIR Orlando
12350 Research Parkway
Orlando, Florida 32862-3275
ATTN: AIM SSO

The goals and objectives of the SSO are to

- Be the Navy expert on AIM application software.
- Support the use of AIM by all authorized government and commercial users of AIM.
- Operate the SSO
  - Assist the AIM Program Manager in developing, maintaining, and executing the Milestone IV System Decision Paper, including considerations of the impact of new technology
  - Document and maintain the hardware, software, and documentation baseline configurations for AIM
  - Develop, operate, and maintain a Trouble Report/Engineering Change Proposal (TR/ECP) tracking and status system
  - Provide configuration status accounting
  - Establish and operate the AIM Help Desk
  - Respond to trouble calls
- Coordinate problem reports and other input from end users
- Respond to user requests for improvements and/or enhancements to AIM
- Research inputs from users and make recommendations to the AIM Project Manager
- Support the AIM Program Manager in presenting change proposals and other information to the Configuration Review Board
- Incorporate approved changes to AIM application software, hardware, and/or documentation as approved by the Configuration Control Board and tasked by the AIM Program Manager
- Conduct tests and assessments to validate that the changes meet the requirements and ensure that the changes are incorporated with a minimal impact to users
- Prepare and distribute updated AIM application software and documentation
- Assist new user sites by helping to identify hardware/software requirements, providing hardware/software procurement support, and providing system setup/testing assistance
- Provide hardware maintenance and commercial off the shelf software license and maintenance support for all NAVEDTRACOM and other AIM sites, as directed and funded by the resource sponsors
- Provide AIM training, as required and tasked by the AIM Program Manager, using the NETC-approved curriculum
- Serve as technical liaison with other Navy programs and with other services on AIM-related issues at the direction of the Program Manager.
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0 INTRODUCTION TO AIM II</td>
<td>1-1</td>
</tr>
<tr>
<td>1.1 Scope</td>
<td>1-1</td>
</tr>
<tr>
<td>1.1.1 Identification</td>
<td>1-2</td>
</tr>
<tr>
<td>1.1.2 System Overview</td>
<td>1-2</td>
</tr>
<tr>
<td>1.1.3 Document Overview</td>
<td>1-3</td>
</tr>
<tr>
<td>1.1.4 Training Materials Development Process</td>
<td>1-3</td>
</tr>
<tr>
<td>1.2 Reference Documents</td>
<td>1-4</td>
</tr>
<tr>
<td>1.3 Automating the Curriculum Process in AIM</td>
<td>1-5</td>
</tr>
<tr>
<td>1.4 AIM II Privileges</td>
<td>1-7</td>
</tr>
<tr>
<td>1.5 Using the Manual</td>
<td>1-8</td>
</tr>
<tr>
<td>1.6 Summary</td>
<td>1-9</td>
</tr>
<tr>
<td>2.0 GETTING STARTED</td>
<td>2-1</td>
</tr>
<tr>
<td>2.1 Login and Course Selection Procedures</td>
<td>2-1</td>
</tr>
<tr>
<td>2.1.1 Selecting Display Preferences</td>
<td>2-3</td>
</tr>
<tr>
<td>2.1.2 Developing a New TPP</td>
<td>2-4</td>
</tr>
<tr>
<td>2.1.3 Selecting an Existing Course</td>
<td>2-4</td>
</tr>
<tr>
<td>2.1.4 Working With the Course Tree Structure</td>
<td>2-5</td>
</tr>
<tr>
<td>2.1.5 Options menu Item</td>
<td>2-7</td>
</tr>
<tr>
<td>2.1.6 View Menu Item</td>
<td>2-9</td>
</tr>
<tr>
<td>2.1.7 Window Menu Item</td>
<td>2-10</td>
</tr>
<tr>
<td>2.1.8 Pop-up Menu</td>
<td>2-10</td>
</tr>
<tr>
<td>2.1.9 Toolbar</td>
<td>2-10</td>
</tr>
<tr>
<td>2.1.10 General</td>
<td>2-11</td>
</tr>
<tr>
<td>2.1.11 Deleting a Course</td>
<td>2-11</td>
</tr>
<tr>
<td>2.2 AIM II Software Conventions</td>
<td>2-12</td>
</tr>
<tr>
<td>2.2.1 Using the Mouse</td>
<td>2-12</td>
</tr>
<tr>
<td>2.2.2 Using the Menus</td>
<td>2-13</td>
</tr>
<tr>
<td>2.2.3 Using the Keyboard</td>
<td>2-13</td>
</tr>
<tr>
<td>2.2.4 Editors Used in AIM II</td>
<td>2-14</td>
</tr>
<tr>
<td>2.2.4.1 MS Word™</td>
<td>2-14</td>
</tr>
<tr>
<td>2.2.4.2 Styled Text Editor</td>
<td>2-15</td>
</tr>
<tr>
<td>2.2.4.3 AIM II Text Editor</td>
<td>2-15</td>
</tr>
<tr>
<td>2.2.4.4 High Edit</td>
<td>2-17</td>
</tr>
<tr>
<td>2.3 Status Levels for AIM II Products</td>
<td>2-22</td>
</tr>
<tr>
<td>2.4 AIM II Help Menu Item</td>
<td>2-22</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>2.4.1 On-line Help.</td>
<td>2-22</td>
</tr>
<tr>
<td>2.4.1.1 Contents</td>
<td>2-24</td>
</tr>
<tr>
<td>2.4.1.2 Index</td>
<td>2-24</td>
</tr>
<tr>
<td>2.4.1.3 Search</td>
<td>2-25</td>
</tr>
<tr>
<td>2.4.2 User’s Manual</td>
<td>2-26</td>
</tr>
<tr>
<td>2.4.3 Changes in Release 5.0</td>
<td>2-27</td>
</tr>
<tr>
<td>2.4.4 Frequently Asked Questions</td>
<td>2-27</td>
</tr>
<tr>
<td>2.4.5 Documentation</td>
<td>2-27</td>
</tr>
<tr>
<td>2.4.6 Getting Started Demonstrations</td>
<td>2-27</td>
</tr>
<tr>
<td>2.5 General Printing Information</td>
<td>2-28</td>
</tr>
<tr>
<td>2.6 Accessing AIM II Utilities</td>
<td>2-28</td>
</tr>
<tr>
<td>2.7 Developing and Maintaining Courses</td>
<td>2-29</td>
</tr>
<tr>
<td>2.8 Printer Administration</td>
<td>2-31</td>
</tr>
<tr>
<td>2.9 Maximum Values for Text Fields</td>
<td>2-31</td>
</tr>
<tr>
<td>3.0 TRAINING PROJECT PLAN (TPP)</td>
<td>3-1</td>
</tr>
<tr>
<td>3.1 Elements of a TPP</td>
<td>3-1</td>
</tr>
<tr>
<td>3.2 Using the AIM II TPP Module</td>
<td>3-2</td>
</tr>
<tr>
<td>3.2.1 Overview of the AIM II TPP Module</td>
<td>3-2</td>
</tr>
<tr>
<td>3.3 Creating a New, Revision, or Cancellation TPP</td>
<td>3-4</td>
</tr>
<tr>
<td>3.3.1 Development of a New TPP</td>
<td>3-4</td>
</tr>
<tr>
<td>3.3.2 Development of a Revision TPP</td>
<td>3-8</td>
</tr>
<tr>
<td>3.3.3 Development of a Cancellation TPP</td>
<td>3-11</td>
</tr>
<tr>
<td>3.3.4 Developing a Modification TPP</td>
<td>3-13</td>
</tr>
<tr>
<td>3.4 Selecting a TPP</td>
<td>3-13</td>
</tr>
<tr>
<td>3.5 TPP Contents</td>
<td>3-14</td>
</tr>
<tr>
<td>3.5.1 Compensation</td>
<td>3-14</td>
</tr>
<tr>
<td>3.5.2 Course Overview/Comments</td>
<td>3-17</td>
</tr>
<tr>
<td>3.5.3 Development Method</td>
<td>3-18</td>
</tr>
<tr>
<td>3.5.4 Justification</td>
<td>3-19</td>
</tr>
<tr>
<td>3.5.5 Milestones</td>
<td>3-21</td>
</tr>
<tr>
<td>3.5.6 Safety Risks and Hazardous Materials</td>
<td>3-22</td>
</tr>
<tr>
<td>3.5.7 Summary of Differences</td>
<td>3-23</td>
</tr>
<tr>
<td>3.5.8 Selecting Learning Sites</td>
<td>3-24</td>
</tr>
<tr>
<td>3.5.8.1 Unselecting a Learning Site</td>
<td>3-27</td>
</tr>
<tr>
<td>3.5.8.2 Identifying Resources</td>
<td>3-28</td>
</tr>
<tr>
<td>3.5.8.2.1 Identifying Resources for a Learning Site</td>
<td>3-29</td>
</tr>
<tr>
<td>3.5.8.2.2 Manpower</td>
<td>3-31</td>
</tr>
<tr>
<td>3.5.8.2.3 Funding</td>
<td>3-32</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>-------</td>
<td>------</td>
</tr>
<tr>
<td>3.5.8.2.4 Facility</td>
<td>3-33</td>
</tr>
<tr>
<td>3.5.8.2.5 Select RRL Items</td>
<td>3-33</td>
</tr>
<tr>
<td>3.5.8.2.6 Unselect RRL Items</td>
<td>3-35</td>
</tr>
<tr>
<td>3.5.8.2.7 Explain Flag</td>
<td>3-36</td>
</tr>
<tr>
<td>3.5.8.2.8 Remove Flag</td>
<td>3-36</td>
</tr>
<tr>
<td>3.6 TPP Options</td>
<td>3-37</td>
</tr>
<tr>
<td>3.6.1 Lock/Unlock</td>
<td>3-37</td>
</tr>
<tr>
<td>3.6.2 Grant Privilege</td>
<td>3-38</td>
</tr>
<tr>
<td>3.6.3 Print Preview</td>
<td>3-38</td>
</tr>
<tr>
<td>3.6.4 Print</td>
<td>3-39</td>
</tr>
<tr>
<td>3.7 On-Line Help</td>
<td>3-39</td>
</tr>
<tr>
<td>4.0 COURSE TRAINING TASK LIST (CTTL) MODULE</td>
<td>4-1</td>
</tr>
<tr>
<td>4.1 Elements of a CTTL</td>
<td>4-1</td>
</tr>
<tr>
<td>4.2 Using the AIM II CTTL Module</td>
<td>4-1</td>
</tr>
<tr>
<td>4.2.1 Overview of the AIM II CTTL Module</td>
<td>4-2</td>
</tr>
<tr>
<td>4.3 Creating or Selecting a CTTL</td>
<td>4-4</td>
</tr>
<tr>
<td>4.4 CTTL Options</td>
<td>4-4</td>
</tr>
<tr>
<td>4.4.1 Add CTTL</td>
<td>4-5</td>
</tr>
<tr>
<td>4.4.2 Delete CTTL</td>
<td>4-7</td>
</tr>
<tr>
<td>4.4.3 Cut, Copy, and Paste a CTTL</td>
<td>4-8</td>
</tr>
<tr>
<td>4.4.4 Copy and Paste Source</td>
<td>4-8</td>
</tr>
<tr>
<td>4.4.5 Select Source From RRL</td>
<td>4-9</td>
</tr>
<tr>
<td>4.4.6 Import FEA Data</td>
<td>4-10</td>
</tr>
<tr>
<td>4.4.7 Course Mission Statement</td>
<td>4-11</td>
</tr>
<tr>
<td>4.4.8 Reset Modification State</td>
<td>4-12</td>
</tr>
<tr>
<td>4.4.9 Build/Rebuild LO</td>
<td>4-12</td>
</tr>
<tr>
<td>4.4.10 Re-sequence CTTL Items</td>
<td>4-13</td>
</tr>
<tr>
<td>4.4.11 Print Preview</td>
<td>4-13</td>
</tr>
<tr>
<td>4.4.12 Print</td>
<td>4-14</td>
</tr>
<tr>
<td>4.4.13 Explain Flag</td>
<td>4-15</td>
</tr>
<tr>
<td>4.4.14 Remove Flag</td>
<td>4-15</td>
</tr>
<tr>
<td>4.5 CTTL Window Edit Menu Item</td>
<td>4-16</td>
</tr>
<tr>
<td>4.6 On-Line Help</td>
<td>4-17</td>
</tr>
<tr>
<td>5.0 LEARNING OBJECTIVES (LO) MODULE</td>
<td>5-1</td>
</tr>
<tr>
<td>5.1 Using the AIM II LO Module</td>
<td>5-1</td>
</tr>
<tr>
<td>5.1.1 Overview of the AIM II LO Module</td>
<td>5-2</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>-------</td>
<td>------</td>
</tr>
<tr>
<td>5.2 SELECTING LOs</td>
<td>5-3</td>
</tr>
<tr>
<td>5.3 LO Window Options Menu Item</td>
<td>5-3</td>
</tr>
<tr>
<td>5.3.1 Add EO</td>
<td>5-4</td>
</tr>
<tr>
<td>5.3.2 Delete EO</td>
<td>5-5</td>
</tr>
<tr>
<td>5.3.3 Join EO</td>
<td>5-6</td>
</tr>
<tr>
<td>5.3.4 Unjoin EO</td>
<td>5-7</td>
</tr>
<tr>
<td>5.3.5 Re-sequence LOs</td>
<td>5-7</td>
</tr>
<tr>
<td>5.3.6 Return to CTTL</td>
<td>5-8</td>
</tr>
<tr>
<td>5.3.7 Curriculum Outline of Instruction</td>
<td>5-8</td>
</tr>
<tr>
<td>5.3.8 Hide/Show CTTL</td>
<td>5-9</td>
</tr>
<tr>
<td>5.3.9 Remove ‘in accordance with’ from LOs</td>
<td>5-9</td>
</tr>
<tr>
<td>5.3.10 Print Preview</td>
<td>5-10</td>
</tr>
<tr>
<td>5.3.11 Print</td>
<td>5-11</td>
</tr>
<tr>
<td>5.3.12 Explain Flag</td>
<td>5-11</td>
</tr>
<tr>
<td>5.3.13 Remove Flag</td>
<td>5-12</td>
</tr>
<tr>
<td>5.4 LO Window Edit Menu Item</td>
<td>5-12</td>
</tr>
<tr>
<td>5.5 On-Line Help</td>
<td>5-13</td>
</tr>
<tr>
<td>6.0 TESTING MODULE</td>
<td>6-1</td>
</tr>
<tr>
<td>6.1 GETTING STARTED</td>
<td>6-1</td>
</tr>
<tr>
<td>6.1.1 Test Learning Objective Window</td>
<td>6-3</td>
</tr>
<tr>
<td>6.1.1.1 Passing Criteria</td>
<td>6-5</td>
</tr>
<tr>
<td>6.1.1.2 Criticality Index</td>
<td>6-5</td>
</tr>
<tr>
<td>6.1.1.3 Test Question &amp; Answer Option</td>
<td>6-6</td>
</tr>
<tr>
<td>6.1.2 Test Support Materials</td>
<td>6-21</td>
</tr>
<tr>
<td>6.1.2.1 Testing Plan</td>
<td>6-21</td>
</tr>
<tr>
<td>6.1.2.2 Instructions for the Proctor</td>
<td>6-23</td>
</tr>
<tr>
<td>6.1.2.3 Instructions for the Trainee</td>
<td>6-23</td>
</tr>
<tr>
<td>6.1.3 Test Development</td>
<td>6-24</td>
</tr>
<tr>
<td>7.0 CURRICULUM OUTLINE OF INSTRUCTION (COI)</td>
<td>7-1</td>
</tr>
<tr>
<td>7.1 Elements of the COI</td>
<td>7-1</td>
</tr>
<tr>
<td>7.2 Using the AIM II COI Module</td>
<td>7-1</td>
</tr>
<tr>
<td>7.2.1 Overview of the AIM II COI Module</td>
<td>7-2</td>
</tr>
<tr>
<td>7.3 Creating or Selecting a COI</td>
<td>7-3</td>
</tr>
<tr>
<td>7.4 COI OPTIONS</td>
<td>7-4</td>
</tr>
<tr>
<td>7.4.1 Creating Units and Topics</td>
<td>7-4</td>
</tr>
</tbody>
</table>
# AIM II USER'S MANUAL

## TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.4.2 Insert Unit/Topic</td>
<td>7-5</td>
</tr>
<tr>
<td>7.4.3 Join Unit/Topic</td>
<td>7-6</td>
</tr>
<tr>
<td>7.4.4 Split Unit/Topic</td>
<td>7-7</td>
</tr>
<tr>
<td>7.4.5 Delete Unit/Topic</td>
<td>7-9</td>
</tr>
<tr>
<td>7.4.6 Copy Unit/Topic from Other Course</td>
<td>7-10</td>
</tr>
<tr>
<td>7.4.7 Remove LO</td>
<td>7-11</td>
</tr>
<tr>
<td>7.4.8 Insert an EO Into a Topic</td>
<td>7-12</td>
</tr>
<tr>
<td>7.4.9 Course Master Schedule</td>
<td>7-12</td>
</tr>
<tr>
<td>7.4.10 Show Unused LOs</td>
<td>7-13</td>
</tr>
<tr>
<td>7.4.11 Hide/Show LOs</td>
<td>7-13</td>
</tr>
<tr>
<td>7.4.12 Print Preview</td>
<td>7-13</td>
</tr>
<tr>
<td>7.4.13 Print</td>
<td>7-15</td>
</tr>
<tr>
<td>7.4.14 Explain Flag</td>
<td>7-15</td>
</tr>
<tr>
<td>7.4.15 Remove Flag</td>
<td>7-16</td>
</tr>
<tr>
<td>7.5 COI Window Edit Menu Item</td>
<td>7-16</td>
</tr>
<tr>
<td>7.5.1 Cut, Copy and Paste</td>
<td>7-16</td>
</tr>
<tr>
<td>7.6 On-Line Help</td>
<td>7-17</td>
</tr>
<tr>
<td>7.7 Summary</td>
<td>7-17</td>
</tr>
<tr>
<td>8.0 COURSE MASTER SCHEDULE (CMS)</td>
<td>8-1</td>
</tr>
<tr>
<td>8.1 Contents of the Course Master Schedule</td>
<td>8-1</td>
</tr>
<tr>
<td>8.2 Using the AIM II CMS Module</td>
<td>8-2</td>
</tr>
<tr>
<td>8.3 Creating or Selecting a CMS</td>
<td>8-2</td>
</tr>
<tr>
<td>8.4 Completing the CMS</td>
<td>8-3</td>
</tr>
<tr>
<td>8.4.1 Period Type</td>
<td>8-3</td>
</tr>
<tr>
<td>8.4.2 Topic Title</td>
<td>8-4</td>
</tr>
<tr>
<td>8.4.3 Entering Week and Day</td>
<td>8-4</td>
</tr>
<tr>
<td>8.4.4 Editing Student-to-Instructor Ratio</td>
<td>8-5</td>
</tr>
<tr>
<td>8.4.5 Period Length</td>
<td>8-5</td>
</tr>
<tr>
<td>8.4.6 Bottleneck Ratio</td>
<td>8-6</td>
</tr>
<tr>
<td>8.4.7 Justification of Ratios</td>
<td>8-6</td>
</tr>
<tr>
<td>8.5 CMS Options</td>
<td>8-7</td>
</tr>
<tr>
<td>8.5.1 Duplicate CMS Period</td>
<td>8-7</td>
</tr>
<tr>
<td>8.5.2 Delete</td>
<td>8-7</td>
</tr>
<tr>
<td>8.5.3 Toggle Page Break</td>
<td>8-8</td>
</tr>
<tr>
<td>8.5.4 Output to Excel and Output to CeTARS</td>
<td>8-8</td>
</tr>
<tr>
<td>8.5.5 Print Preview</td>
<td>8-9</td>
</tr>
<tr>
<td>8.5.6 Print</td>
<td>8-10</td>
</tr>
<tr>
<td>8.5.7 Explain Flag</td>
<td>8-10</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>-------</td>
<td>------</td>
</tr>
<tr>
<td>8.5.8 Remove Flag</td>
<td>8-11</td>
</tr>
<tr>
<td>8.6 CMS Contents</td>
<td>8-11</td>
</tr>
<tr>
<td>8.6.1 Master Schedule Summary (MSS) Justification</td>
<td>8-12</td>
</tr>
<tr>
<td>8.6.2 CNATT Instructor Computation Worksheet</td>
<td>8-12</td>
</tr>
<tr>
<td>8.7 CMS Events</td>
<td>8-13</td>
</tr>
<tr>
<td>8.7.1 CMS Events Options</td>
<td>8-14</td>
</tr>
<tr>
<td>8.7.2 CMS Events Columns</td>
<td>8-15</td>
</tr>
<tr>
<td>8.8 On-Line Help</td>
<td>8-13</td>
</tr>
<tr>
<td>8.9 Summary</td>
<td>8-13</td>
</tr>
<tr>
<td>9.0 TRAINING COURSE CONTROL DOCUMENT (TCCD)</td>
<td>9-1</td>
</tr>
<tr>
<td>9.1 Elements of a TCCD</td>
<td>9-1</td>
</tr>
<tr>
<td>9.1.1 Elements of TCCD Front Matter</td>
<td>9-1</td>
</tr>
<tr>
<td>9.1.2 Elements of TCCD Annexes</td>
<td>9-2</td>
</tr>
<tr>
<td>9.2 Using the AIM II TCCD Module</td>
<td>9-2</td>
</tr>
<tr>
<td>9.2.1 Overview of the AIM II TCCD Module</td>
<td>9-3</td>
</tr>
<tr>
<td>9.3 Selecting the TCCD</td>
<td>9-4</td>
</tr>
<tr>
<td>9.4 TCCD Contents</td>
<td>9-6</td>
</tr>
<tr>
<td>9.4.1 Foreword</td>
<td>9-6</td>
</tr>
<tr>
<td>9.4.2 Course Overview/Comments</td>
<td>9-7</td>
</tr>
<tr>
<td>9.4.3 Supplying Trainee Data</td>
<td>9-8</td>
</tr>
<tr>
<td>9.4.4 Summary of Differences</td>
<td>9-10</td>
</tr>
<tr>
<td>9.4.5 Selecting a Learning Site</td>
<td>9-11</td>
</tr>
<tr>
<td>9.4.5.1 Identifying Resources for a Learning Site</td>
<td>9-13</td>
</tr>
<tr>
<td>9.5 TCCD Options</td>
<td>9-16</td>
</tr>
<tr>
<td>9.5.1 Lock and Unlock Options</td>
<td>9-17</td>
</tr>
<tr>
<td>9.5.2 Grant Privileges</td>
<td>9-18</td>
</tr>
<tr>
<td>9.5.3 Course Option</td>
<td>9-19</td>
</tr>
<tr>
<td>9.5.4 Print Preview and Print Options</td>
<td>9-19</td>
</tr>
<tr>
<td>9.5.5 Central Site Options</td>
<td>9-19</td>
</tr>
<tr>
<td>9.6 Course Maintenance</td>
<td>9-21</td>
</tr>
<tr>
<td>9.6.1 Creating a Revision for a Course</td>
<td>9-21</td>
</tr>
<tr>
<td>9.6.2 Creating a Change for a Course</td>
<td>9-22</td>
</tr>
<tr>
<td>9.6.3 Add a Later IETM Version</td>
<td>9-22</td>
</tr>
<tr>
<td>9.7 Summary</td>
<td>9-23</td>
</tr>
<tr>
<td>10.0 LESSON PLAN</td>
<td>10-1</td>
</tr>
<tr>
<td>10.1 Introduction</td>
<td>10-1</td>
</tr>
<tr>
<td>10.1.1 Relationship Between the LP and the TCCD</td>
<td>10-3</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>--------</td>
</tr>
<tr>
<td>10.1.2 Relationship Between the LP and TG</td>
<td>10-3</td>
</tr>
<tr>
<td>10.1.3 LP Status Levels and Privileges</td>
<td>10-4</td>
</tr>
<tr>
<td>10.2 Getting Started</td>
<td>10-4</td>
</tr>
<tr>
<td>10.3 Lesson Plan Cover Page</td>
<td>10-5</td>
</tr>
<tr>
<td>10.3.1 Lesson Plan Window Options Menu Item</td>
<td>10-6</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>10.3.1.1 Spell Check</td>
<td>10-6</td>
</tr>
<tr>
<td>10.3.1.2 Grant Privileges</td>
<td>10-6</td>
</tr>
<tr>
<td>10.3.1.3 Print Preview</td>
<td>10-7</td>
</tr>
<tr>
<td>10.3.1.4 Print</td>
<td>10-8</td>
</tr>
<tr>
<td>10.3.2 Lesson Plan Window Contents Menu Item</td>
<td>10-9</td>
</tr>
<tr>
<td>10.3.2.1 Safety/Hazard Awareness Notice Contents Menu Subitem</td>
<td>10-9</td>
</tr>
<tr>
<td>10.3.2.2 SCORM Metadata (Course)</td>
<td>10-9</td>
</tr>
<tr>
<td>10.3.2.3 Units/Topics Window</td>
<td>10-11</td>
</tr>
<tr>
<td>10.3.2.3.1 Entering Trainee Preparation Materials</td>
<td>10-12</td>
</tr>
<tr>
<td>10.3.2.3.2 Entering Instructor Preparation Materials</td>
<td>10-13</td>
</tr>
<tr>
<td>10.3.2.3.3 SCORM Metadata (Topic)</td>
<td>10-15</td>
</tr>
<tr>
<td>10.3.2.3.4 Discussion Point/Related Instructor Activity (DP/RIA) Pages</td>
<td>10-15</td>
</tr>
<tr>
<td>10.3.2.3.4.1 Adding DPs</td>
<td>10-16</td>
</tr>
<tr>
<td>10.3.2.3.4.2 Deleting DPs</td>
<td>10-17</td>
</tr>
<tr>
<td>10.3.2.3.4.3 Adding/Deleting Notes, Cautions, and Warnings</td>
<td>10-18</td>
</tr>
<tr>
<td>10.3.2.3.4.4 Working With RIAs</td>
<td>10-18</td>
</tr>
<tr>
<td>10.3.2.3.4.5 Building an RIA</td>
<td>10-19</td>
</tr>
<tr>
<td>10.3.2.3.4.6 Add/Select/Delete Instruction (TG) Sheets</td>
<td>10-21</td>
</tr>
<tr>
<td>10.3.2.3.4.7 Selecting an IETM</td>
<td>10-24</td>
</tr>
<tr>
<td>10.3.2.3.4.8 Selecting an IMI</td>
<td>10-25</td>
</tr>
<tr>
<td>10.3.2.3.4.9 Adding Another RIA</td>
<td>10-26</td>
</tr>
<tr>
<td>10.3.2.3.4.10 Adding a Same Level RIA</td>
<td>10-27</td>
</tr>
<tr>
<td>10.3.2.3.4.11 Adding a Lower Level RIA</td>
<td>10-27</td>
</tr>
<tr>
<td>10.3.2.3.4.12 Deleting an RIA</td>
<td>10-28</td>
</tr>
<tr>
<td>10.3.2.3.4.13 Copying and Pasting a RIA</td>
<td>10-28</td>
</tr>
<tr>
<td>10.3.2.3.4.14 Resequencing DPs and RIAs</td>
<td>10-28</td>
</tr>
<tr>
<td>10.3.2.3.4.15 EO/DP Links</td>
<td>10-29</td>
</tr>
<tr>
<td>10.3.2.3.4.16 Explain Flag</td>
<td>10-30</td>
</tr>
<tr>
<td>10.3.2.3.4.17 Remove Flag</td>
<td>10-31</td>
</tr>
<tr>
<td>10.3.2.3.5 Print Preview/Print a Unit or Topic</td>
<td>10-31</td>
</tr>
<tr>
<td>10.4 Summary</td>
<td>10-32</td>
</tr>
</tbody>
</table>
# AIM II User's Manual

## Table of Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>11.0</strong> Trainee Guide</td>
<td>11-1</td>
</tr>
<tr>
<td>11.1 Overview</td>
<td>11-1</td>
</tr>
<tr>
<td>11.1.1 Front Matter</td>
<td>11-2</td>
</tr>
<tr>
<td>11.1.2 Instruction Sheet</td>
<td>11-3</td>
</tr>
<tr>
<td>11.1.3 Editors Used In the TG</td>
<td>11-4</td>
</tr>
<tr>
<td>11.1.3.1 MS Word™</td>
<td>11-4</td>
</tr>
<tr>
<td>11.1.3.2 Styled Text Editor</td>
<td>11-6</td>
</tr>
<tr>
<td>11.1.3.3 High Edit</td>
<td>11-6</td>
</tr>
<tr>
<td>11.1.3.4 AIM II Text Editor</td>
<td>11-10</td>
</tr>
<tr>
<td>11.2 TG Status Levels and Privileges</td>
<td>11-11</td>
</tr>
<tr>
<td>11.3 Trainee Guide (TG) Main Window</td>
<td>11-12</td>
</tr>
<tr>
<td>11.3.1 TG Options Menu Item</td>
<td>11-12</td>
</tr>
<tr>
<td>11.3.2 TG Contents Menu Item</td>
<td>11-13</td>
</tr>
<tr>
<td>11.3.2.1 Safety/Hazard Awareness Notice</td>
<td>11-13</td>
</tr>
<tr>
<td>11.3.2.2 Security Awareness Notice</td>
<td>11-14</td>
</tr>
<tr>
<td>11.3.2.3 TG Sheets Contents</td>
<td>11-14</td>
</tr>
<tr>
<td>11.3.2.3.1 TG Assignment Sheet</td>
<td>11-14</td>
</tr>
<tr>
<td>11.3.2.3.2 TG Diagram Sheet</td>
<td>11-16</td>
</tr>
<tr>
<td>11.3.2.3.3 TG Job Sheet</td>
<td>11-18</td>
</tr>
<tr>
<td>11.3.2.3.4 TG Problem Sheet</td>
<td>11-21</td>
</tr>
<tr>
<td>11.3.2.3.5 TG Information Sheet</td>
<td>11-22</td>
</tr>
<tr>
<td>11.3.2.3.6 TG Outline Sheet</td>
<td>11-24</td>
</tr>
<tr>
<td><strong>12.0</strong> Learning Object Module</td>
<td>12-1</td>
</tr>
<tr>
<td>12.0 Learning Object Module</td>
<td>12-1</td>
</tr>
<tr>
<td>12.1 Learning Object Module Menu Items</td>
<td>12-2</td>
</tr>
<tr>
<td>12.1.1 Courses, Modules, Lessons, and Sections Contents Menu Item</td>
<td>12-2</td>
</tr>
<tr>
<td>12.1.2 Sections Window</td>
<td>12-2</td>
</tr>
<tr>
<td>12.1.2.1 Create a New Section</td>
<td>12-7</td>
</tr>
<tr>
<td>12.1.2.2 Create a Section From AIM Data</td>
<td>12-9</td>
</tr>
<tr>
<td>12.1.2.3 Creating an Elements List from AIM Data</td>
<td>12-13</td>
</tr>
<tr>
<td>12.1.2.3 Adding Test Items for a Section</td>
<td>12-13</td>
</tr>
<tr>
<td>12.1.2.4 Adding TG Sheets for an Instructor-Led Section</td>
<td>12-22</td>
</tr>
<tr>
<td>12.1.3 Lessons Window</td>
<td>12-29</td>
</tr>
<tr>
<td>12.1.4 Modules Window</td>
<td>12-33</td>
</tr>
<tr>
<td>12.1.5 Courses Window</td>
<td>12-35</td>
</tr>
</tbody>
</table>

## Appendix A - Glossary

1.0 Glossary | A-1 |
# APPENDIX B - Administration and Utilities

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>AIM II ADMINISTRATIVE AND UTILITY FUNCTIONS</td>
<td>B-1</td>
</tr>
<tr>
<td>Utilities Menu Items</td>
<td>B-1</td>
</tr>
<tr>
<td>Change Password Utility</td>
<td>B-1</td>
</tr>
<tr>
<td>2.1.1 Password Change Procedure</td>
<td>B-2</td>
</tr>
<tr>
<td>Site Resource Requirements List (RRL) Utility</td>
<td>B-3</td>
</tr>
<tr>
<td>2.2.1 Site RRL Window Options Menu Item</td>
<td>B-4</td>
</tr>
<tr>
<td>2.2.1.1 Add a Resource</td>
<td>B-5</td>
</tr>
<tr>
<td>2.2.1.2 Modify/View a Resource</td>
<td>B-7</td>
</tr>
<tr>
<td>2.2.1.3 Delete a Resource</td>
<td>B-8</td>
</tr>
<tr>
<td>2.2.1.4 Grant Privilege</td>
<td>B-8</td>
</tr>
<tr>
<td>2.2.1.5 Replace an RRL Item</td>
<td>B-9</td>
</tr>
<tr>
<td>2.2.1.6 Display Related Materials</td>
<td>B-10</td>
</tr>
<tr>
<td>2.2.1.7 Flag Related Materials for Maintenance Action</td>
<td>B-11</td>
</tr>
<tr>
<td>2.2.1.8 Display Unused Resources</td>
<td>B-11</td>
</tr>
<tr>
<td>2.2.1.9 Search the Site RRL for a RRL Item</td>
<td>B-12</td>
</tr>
<tr>
<td>2.2.1.10 SCORM Metadata</td>
<td>B-12</td>
</tr>
<tr>
<td>2.2.1.11 Explain Flag</td>
<td>B-12</td>
</tr>
<tr>
<td>2.2.1.12 Print Preview a List of All RRL Items of a Type</td>
<td>B-13</td>
</tr>
<tr>
<td>2.2.1.13 Print a List of All RRL Items of a Type</td>
<td>B-13</td>
</tr>
<tr>
<td>2.2.1.14 Transparencies Window Options Menu Item</td>
<td>B-14</td>
</tr>
<tr>
<td>2.2.1.15 Clearing a Conflicting State on an IMI</td>
<td>B-16</td>
</tr>
<tr>
<td>Graphics Utility</td>
<td>B-17</td>
</tr>
<tr>
<td>2.3 Graphics Options Menu Item</td>
<td>B-17</td>
</tr>
<tr>
<td>2.3.1 Add Graphic Option</td>
<td>B-17</td>
</tr>
<tr>
<td>2.3.1.2 Modify Graphic Option</td>
<td>B-19</td>
</tr>
<tr>
<td>2.3.1.3 Delete Graphic Option</td>
<td>B-21</td>
</tr>
<tr>
<td>2.3.1.4 Replace Graphic Option</td>
<td>B-21</td>
</tr>
<tr>
<td>2.3.1.5 View Graphic Option</td>
<td>B-21</td>
</tr>
<tr>
<td>2.3.1.6 Find Graphic Option</td>
<td>B-21</td>
</tr>
<tr>
<td>2.3.1.7 Display Unused Graphics</td>
<td>B-22</td>
</tr>
<tr>
<td>2.3.1.8 Related Courses Option</td>
<td>B-22</td>
</tr>
<tr>
<td>2.3.1.9 SCORM Metadata</td>
<td>B-22</td>
</tr>
<tr>
<td>Administration Utility</td>
<td>B-22</td>
</tr>
<tr>
<td>2.4.1 View RRL</td>
<td>B-23</td>
</tr>
<tr>
<td>2.5.2 Grant Privilege</td>
<td>B-24</td>
</tr>
<tr>
<td>2.4.3 Approving Training Material</td>
<td>B-26</td>
</tr>
<tr>
<td>2.4.4 Clear In Use</td>
<td>B-27</td>
</tr>
<tr>
<td>2.4.5 Clear Conflict State</td>
<td>B-28</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>-------</td>
<td>------</td>
</tr>
<tr>
<td>2.4.6 Importing IETM Extract Files</td>
<td>B-29</td>
</tr>
<tr>
<td>2.4.6.1 Mapping the location of the IETM Viewer</td>
<td>B-30</td>
</tr>
<tr>
<td>2.5 Reporting</td>
<td>B-38</td>
</tr>
<tr>
<td>2.6 RRL/Graphics Location Tool</td>
<td>B-41</td>
</tr>
<tr>
<td>2.6.1 Resource/Graphic Selection Window</td>
<td>B-41</td>
</tr>
<tr>
<td>2.6.2 Resource Selection</td>
<td>B-42</td>
</tr>
<tr>
<td>2.6.3 Graphic Selection</td>
<td>B-44</td>
</tr>
<tr>
<td>2.6.4 Reference Breakdown</td>
<td>B-45</td>
</tr>
<tr>
<td>2.6.5 IETM Breakdown</td>
<td>B-46</td>
</tr>
<tr>
<td>2.6.6 Related Courses Selection</td>
<td>B-47</td>
</tr>
<tr>
<td>2.6.7 Search Results Window</td>
<td>B-48</td>
</tr>
<tr>
<td>2.6.8 Print Preview</td>
<td>B-49</td>
</tr>
<tr>
<td>2.7 Learning Site Utility</td>
<td>B-51</td>
</tr>
<tr>
<td>2.7.1 Site Options Menu Item</td>
<td>B-51</td>
</tr>
<tr>
<td>2.7.1.1 Add Site</td>
<td>B-52</td>
</tr>
<tr>
<td>2.7.1.2 Delete Site</td>
<td>B-52</td>
</tr>
<tr>
<td>2.7.1.3 Modify Site</td>
<td>B-53</td>
</tr>
<tr>
<td>2.7.1.4 Replace Site</td>
<td>B-53</td>
</tr>
<tr>
<td>2.8 Agency Utility</td>
<td>B-54</td>
</tr>
<tr>
<td>2.8.1 Agency Options Menu Item</td>
<td>B-55</td>
</tr>
<tr>
<td>2.8.1.1 Add Agency</td>
<td>B-55</td>
</tr>
<tr>
<td>2.8.1.2 Delete Agency</td>
<td>B-56</td>
</tr>
<tr>
<td>2.8.1.3 Modify an Agency</td>
<td>B-56</td>
</tr>
<tr>
<td>2.8.1.4 Replace Agency</td>
<td>B-57</td>
</tr>
<tr>
<td>2.9 Archive Unarchive Utility</td>
<td>B-58</td>
</tr>
<tr>
<td>2.9.1 Archive Options Menu Item</td>
<td>B-58</td>
</tr>
<tr>
<td>2.9.1.1 Archive Training Material</td>
<td>B-58</td>
</tr>
<tr>
<td>2.9.1.2 Unarchive Training Material</td>
<td>B-59</td>
</tr>
<tr>
<td>2.9.1.3 View Archive Information</td>
<td>B-60</td>
</tr>
<tr>
<td>2.9.1.4 Archive IMI Report</td>
<td>B-60</td>
</tr>
<tr>
<td>2.10 Import/Export Utility</td>
<td>B-62</td>
</tr>
<tr>
<td>2.10.1 Rules for the Import/Export Process</td>
<td>B-63</td>
</tr>
<tr>
<td>2.10.2 Import a Course</td>
<td>B-64</td>
</tr>
<tr>
<td>2.10.3 Export a Course</td>
<td>B-65</td>
</tr>
<tr>
<td>2.10.4 View Export Information</td>
<td>B-66</td>
</tr>
<tr>
<td>2.10.5 Import IMI Report</td>
<td>B-66</td>
</tr>
<tr>
<td>2.10.6 Import CNATT ERL Data</td>
<td>B-68</td>
</tr>
<tr>
<td>2.10.7 Import CNATT Publications</td>
<td>B-69</td>
</tr>
</tbody>
</table>
## AIM II USER'S MANUAL

### TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.11 User Utility</td>
<td>B-69</td>
</tr>
<tr>
<td>2.11.1 User Administration Options Menu Item</td>
<td>B-70</td>
</tr>
<tr>
<td>2.11.1.1 Add a User</td>
<td>B-70</td>
</tr>
<tr>
<td>2.11.1.2 Delete a User</td>
<td>B-71</td>
</tr>
<tr>
<td>2.11.1.3 Clear User Password Option</td>
<td>B-72</td>
</tr>
<tr>
<td>2.11.1.4 Edit a User's Information</td>
<td>B-73</td>
</tr>
<tr>
<td>2.12 Data Manager Utility</td>
<td>B-73</td>
</tr>
</tbody>
</table>

### APPENDIX C - Trouble Report and AIM Change Request

1.0 Trouble Report and AIM Change Request ................................. C-1
1.1 Users .............................................................................. C-1
1.2 Maintenance Action ......................................................... C-1
1.3 Trouble Reports ............................................................... C-1
1.3.1 Trouble Report Form Instructions ................................. C-1
1.4 AIM Change Request ......................................................... C-2
1.4.1 AIM Change Request Form Instructions ........................ C-2
1.5 Sending the Database to NAVAIR Orlando ......................... C-4

### APPENDIX D-DEVELOPING IETM EXTRACTION FILES

1.0 Introduction ........................................................................ D-1
2.0 SGML-based IETM ............................................................. D-1
2.1 Introduction ........................................................................ D-1
2.2 Installing the SGML-based IETM Extraction Program .......... D-2
2.3 Running the SGML-based IETM Extraction Program .......... D-2
2.3.1 Trouble Report Form Instructions ................................ D-10
2.3.1.1 Example of Determining the Contents of the Registration File using the GD SWS IETM .......... D-16
2.3.2 Description of the Library File ..................................... D-26
2.3.3 Description of DDE Information File ............................ D-29
3.0 Other IETMs ....................................................................... D-31
3.1 Introduction ........................................................................ D-31
3.2 ARCI IETM ........................................................................ D-31
3.2.1 Introduction ................................................................... D-31
3.2.2 Installing the ARCI IETM Extraction Program .......... D-31
3.2.3 Running the ARCI IETM Extraction Program .......... D-32
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.3</td>
<td>PDF Documents</td>
</tr>
<tr>
<td></td>
<td>3.3.1 Introduction</td>
</tr>
<tr>
<td></td>
<td>3.3.2 Installing the PDF Extraction Routine</td>
</tr>
<tr>
<td></td>
<td>3.3.3 Running the PDF Extraction Routine</td>
</tr>
<tr>
<td>3.4</td>
<td>PMS Documents</td>
</tr>
<tr>
<td></td>
<td>3.4.1 Introduction</td>
</tr>
<tr>
<td></td>
<td>3.4.2 Installing the PMS Documents Extraction Routine</td>
</tr>
<tr>
<td></td>
<td>3.4.3 Running the PMS Documents Extraction Routine</td>
</tr>
<tr>
<td>3.5</td>
<td>Raster Technical Manuals</td>
</tr>
<tr>
<td></td>
<td>3.5.1 Introduction</td>
</tr>
<tr>
<td></td>
<td>3.5.2 Installing the Raster Technical Manual Extraction Routine</td>
</tr>
<tr>
<td></td>
<td>3.5.3 Running the Raster Technical Manual Extraction Routine</td>
</tr>
<tr>
<td>3.6</td>
<td>XML-Based IETMs</td>
</tr>
<tr>
<td></td>
<td>3.6.1 Introduction</td>
</tr>
<tr>
<td></td>
<td>3.6.2 Installing the XML-Based IETM Extraction Routine</td>
</tr>
<tr>
<td></td>
<td>3.6.3 Running the XML-Based IETM Extraction Routine</td>
</tr>
</tbody>
</table>

APPENDIX E-SCORM AND NILARS

1.0 Sharable Content Object Reference Model (SCORM) Overview ............................................E-1
   1.1 SCORM Content Model Components .................................................................................E-1
2.0 Navy Integrated Learning Asset Repository System (NILARS) Overview ......................E-2
   2.1 Potential Uses of AIM Data in NILARS Repository System ........................................E-2
3.0 Developing SCORM Data ......................................................................................E-4
   3.1 SCORM Data Tabs Content ......................................................................................E-4
   3.2 Creating a SCORM Output for an Approved Course ..............................................E-9
   3.3 Detailed Contents of the AIM-to-SCORM Output Package .................................E-10

APPENDIX F-CNATT TPP AND TCCD DEVELOPMENT

1.0 TRAINING PROJECT PLAN (TPP) .............................................................................F-1
   1.1 ELEMENTS OF A TPP ..................................................................................F-1
   1.2 USING THE AIM II TPP MODULE .....................................................................F-2
      1.2.1 Overview of the AIM II TPP Module ..................................................F-2
   1.3 CREATING A NEW, REVISION, OR CANCELLATION TPP ..............................F-4
      1.3.1 Development of a New TPP .................................................................F-4
      1.3.2 Development of a Revision TPP ...........................................................F-8
      1.3.3 Development of a Cancellation TPP ....................................................F-11
   1.4 SELECTING A TPP ...................................................................................F-13
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.5</td>
<td>TPP CONTENTS</td>
</tr>
<tr>
<td>1.5.1</td>
<td>Compensation</td>
</tr>
<tr>
<td>1.5.2</td>
<td>Course Overview/Comments</td>
</tr>
<tr>
<td>1.5.3</td>
<td>Development Method</td>
</tr>
<tr>
<td>1.5.4</td>
<td>Justification</td>
</tr>
<tr>
<td>1.5.5</td>
<td>Milestones</td>
</tr>
<tr>
<td>1.5.6</td>
<td>Safety Risks and Hazardous Materials</td>
</tr>
<tr>
<td>1.5.7</td>
<td>Summary of Differences</td>
</tr>
<tr>
<td>1.5.8</td>
<td>Selecting Learning Sites</td>
</tr>
<tr>
<td>1.5.8.1</td>
<td>Unselecting a Learning Site</td>
</tr>
<tr>
<td>1.5.8.2</td>
<td>Identifying Resources for Learning Sites</td>
</tr>
<tr>
<td>1.5.8.2.1</td>
<td>Identifying Resources</td>
</tr>
<tr>
<td>1.5.8.2.2</td>
<td>Manpower</td>
</tr>
<tr>
<td>1.5.8.2.3</td>
<td>Funding</td>
</tr>
<tr>
<td>1.5.8.2.4</td>
<td>Facilities</td>
</tr>
<tr>
<td>1.5.8.2.5</td>
<td>Select Site RRL Materials</td>
</tr>
<tr>
<td>1.5.8.2.6</td>
<td>Unselect TPP RRL Items</td>
</tr>
<tr>
<td>1.5.8.2.7</td>
<td>Explain Flag</td>
</tr>
<tr>
<td>1.5.8.2.8</td>
<td>Remove Flag</td>
</tr>
<tr>
<td>1.6</td>
<td>TPP OPTIONS</td>
</tr>
<tr>
<td>1.6.1</td>
<td>Lock/Unlock</td>
</tr>
<tr>
<td>1.6.2</td>
<td>Grant Privilege</td>
</tr>
<tr>
<td>1.6.3</td>
<td>Importing CNATT Course and ERL Data</td>
</tr>
<tr>
<td>1.6.4</td>
<td>Print Preview</td>
</tr>
<tr>
<td>1.6.5</td>
<td>Print</td>
</tr>
<tr>
<td>2.0</td>
<td>TRAINING COURSE CONTROL DOCUMENT (TCCD)</td>
</tr>
<tr>
<td>2.1</td>
<td>ELEMENTS OF A TCCD</td>
</tr>
<tr>
<td>2.1.1</td>
<td>Elements of TCCD Front Matter</td>
</tr>
<tr>
<td>2.1.2</td>
<td>Elements of TCCD Annexes</td>
</tr>
<tr>
<td>2.2</td>
<td>USING THE AIM II TCCD MODULE</td>
</tr>
<tr>
<td>2.2.1</td>
<td>Overview of the AIM II TCCD Module</td>
</tr>
<tr>
<td>2.3</td>
<td>SELECTING A TCCD</td>
</tr>
<tr>
<td>2.4</td>
<td>TCCD CONTENTS</td>
</tr>
<tr>
<td>2.4.1</td>
<td>Foreword</td>
</tr>
<tr>
<td>2.4.2</td>
<td>Course Overview/Comments</td>
</tr>
<tr>
<td>2.4.3</td>
<td>Supplying Trainee Data</td>
</tr>
<tr>
<td>2.4.4</td>
<td>Summary of Differences</td>
</tr>
<tr>
<td>2.4.5</td>
<td>Selecting a Learning Site</td>
</tr>
<tr>
<td>2.4.5.1</td>
<td>Identifying Resources for a Learning Site</td>
</tr>
</tbody>
</table>
## AIM II USER’S MANUAL

### TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.5</td>
<td>TCCD OPTIONS ................................................................. F-56</td>
</tr>
<tr>
<td>2.5.1</td>
<td>Lock and Unlock Options .................................................. F-56</td>
</tr>
<tr>
<td>2.5.2</td>
<td>Grant Privileges ............................................................... F-58</td>
</tr>
<tr>
<td>2.5.3</td>
<td>Importing CNATT ERL Data .................................................... F-58</td>
</tr>
<tr>
<td>2.5.4</td>
<td>Print Preview and Print Options ............................................ F-59</td>
</tr>
<tr>
<td>2.6</td>
<td>COURSE MAINTENANCE ............................................................ F-61</td>
</tr>
</tbody>
</table>

### APPENDIX G NAVSPECWAR TRAINING PROJECT PLAN (TPP) MODULE

| 1.0   | TRAINING PROJECT PLAN (TPP) .................................................. G-1 |
| 1.1   | ELEMENTS OF A TPP ................................................................. G-1 |
| 1.2   | USING THE AIM II TPP MODULE ................................................ G-2 |
| 1.2.1 | Overview of the AIM II TPP Module ......................................... G-2 |
| 1.3   | CREATING A NEW, REVISION, OR CANCELLATION TPP ................. G-4 |
| 1.3.1 | Development of a New TPP .................................................... G-4 |
| 1.3.2 | Development of a Revision TPP ............................................... G-8 |
| 1.3.3 | Development of a Cancellation TPP .......................................... G-11 |
| 1.4   | SELECTING A TPP ........................................................................ G-13 |
| 1.5   | TPP CONTENTS ............................................................................ G-14 |
| 1.5.1 | Compensation ............................................................................ G-14 |
| 1.5.2 | Course Overview/Comments .................................................... G-17 |
| 1.5.3 | Development Method ............................................................... G-18 |
| 1.5.4 | Justification ............................................................................. G-19 |
| 1.5.5 | Milestones ................................................................................ G-21 |
| 1.5.6 | Safety Risks and Hazardous Materials ........................................ G-22 |
| 1.5.7 | Summary of Differences ............................................................ G-23 |
| 1.5.8 | Selecting Learning Sites ........................................................... G-24 |
| 1.5.8.1| Unselecting a Learning Site .................................................... G-27 |
| 1.5.8.2| Identifying Resources for a Learning Site ................................. G-28 |
| 1.5.8.2.1| Identifying Resources ........................................................... G-29 |
| 1.5.8.2.2| Manpower .............................................................................. G-31 |
| 1.5.8.2.3| Funding .................................................................................. G-32 |
| 1.5.8.2.4| Facility .................................................................................... G-33 |
| 1.5.8.2.5| Select RRL Items ..................................................................... G-33 |
| 1.5.8.2.6| Unselect RRL Items ............................................................... G-35 |
| 1.5.8.2.7| Explain Flag ............................................................................ G-36 |
| 1.5.8.2.8| Remove Flag .......................................................................... G-36 |
| 1.6   | TPP OPTIONS ............................................................................. G-37 |
| 1.6.1 | Lock/Unlock ............................................................................ G-37 |
| 1.6.2 | Grant Privilege ........................................................................ G-38 |

Release 5.6  xv
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.6.3 Print Preview</td>
<td>G-38</td>
</tr>
<tr>
<td>1.6.4 Print</td>
<td>G-39</td>
</tr>
<tr>
<td>1.7 ON-LINE HELP</td>
<td>G-39</td>
</tr>
</tbody>
</table>
CHAPTER 1

INTRODUCTION TO AIM II

1.0 INTRODUCTION TO AIM II ......................................................................................... 1-1
1.1 SCOPE ................................................................................................................. 1-1
  1.1.1 Identification ............................................................................................ 1-2
  1.1.2 System Overview ..................................................................................... 1-2
  1.1.3 Document Overview ................................................................................ 1-3
  1.1.4 Training Materials Development Process ................................................ 1-3
1.2 REFERENCED DOCUMENTS .......................................................................... 1-4
1.3 AUTOMATING THE CURRICULUM PROCESS USING AIM II................... 1-5
1.4 AIM II PRIVILEGES ........................................................................................ 1-7
1.5 USING THE MANUAL ..................................................................................... 1-8
1.6 SUMMARY ......................................................................................................... 1-9
1.0 INTRODUCTION TO AIM II

The following material is intended to provide an overview of the AIM II software. Specific guidance for developing each of the products supported by AIM II is contained in subsequent chapters. Much of this information is also available from within AIM II by accessing the on-line help.

1.1 SCOPE

Authoring Instructional Materials (AIM II) software provides two methods for developing training material. The first method provides all the training material elements for developing formal classroom materials in accordance with the Task-Based methodology. The second method provides material elements for developing Integrated Learning Environment (ILE) training materials for Instructor-Led and Self-Paced Web presentation.

AIM II software is a complete computerized system for developing and maintaining task based curriculum products. AIM II is based on the NAVEDTRA 130B and ILE curriculum development standard using a relational database structure. The complete system is designed to operate in the MS-Windows™ graphical user environment on either a stand-alone personal computer or Local Area Network. Curriculum products developed using either configuration can transfer data seamlessly.

The AIM II software has been designed for development of either NETC Resource Requirements List (RRL) items or CNATT Equipment Requirement List (ERL) items. AIM II displays ERL headings for CNATT controlled resources when the statement "ENABLE_ERL=Yes" is present in the Aim.ini file. CNATT Course and ERL Data can be imported into the TPP and TCCD when the ERL is enabled. AIM II systems supporting CNATT curricula should only contain CNATT controlled courses.

AIM II also supports two Metaframe or Central Site instances, one for CNATT and one for CSFE. The CNATT Metaframe usage requires two statements in the AIM.ini file; "ENABLE_ERL=Yes" and "ENABLE_METAFRAME=Yes". The CSFE Metaframe usage requires the following AIM.ini configuration statements; "ENABLE_ERL=No" and ENABLE_METAFRAME=Yes".

AIM II partially automates the development and maintenance of:
- Training Project Plans (TPP)
- Resource Requirements Lists (RRL)
- Course Training Task Lists (CTTL)
• Learning Objectives (LOs)
• Knowledge Tests and Test Plans
• Training Course Control Documents (TCCD)
• Curriculum Outlines of Instruction (COI)
• Course Master Schedules (CMS)
• Lesson Plans (LP)
• Trainee Guides (TG)

AIM II partially automates the development and maintenance of the following training material products when developing ILE Based training materials for the Web from the Learning Object module:
• Course
• Modules
• Lessons
• Sections

The Learning Object module has been designed to allow the authoring of new training material, import training material developed in the Content Planning Module (CPM) from a link to the Enterprise Data Environment (EDE), and re-develop training material that already exists in AIM for the ILE environment.

1.1.1 Identification

This User's Manual was developed to support the Computer Software Configuration Item (CSCI) identified as Task based Authoring Instructional Materials (AIM II). This document, Document Identification Number AIM II SUM #00005, was prepared in accordance with DOD-STD-2167A, Data Item Descriptions DI-MCCR-80019A.

1.1.2 System Overview

The objective of AIM II is to automate the task-based method of curriculum development in accordance with the Naval Education and Training Command Task Based Curriculum Development Manual (NAVEDTRA 130B).

The System/Subsystem Specification (SSS) along with the Functional Description (FD) defines the automation of the task-based method originally proposed. State of the art changes in automation capabilities, as well as revised and streamlined task based curriculum development procedures, make this development of curriculum feasible and highly cost effective for the Navy by reducing the time and effort required to produce instructional materials.
1.1.3 Document Overview

This document provides experienced task based curriculum developers with instructions sufficient to execute the AIM II program. Included are the steps for developing and maintaining task based curricula using this software, the expected output, and the measures to be taken if "error" messages appear. For more detailed guidance on the procedures required to build task-based curricula, refer to NAVEDTRA 130B.

1.1.4 Training Materials Development Process

The procedures for developing task based curriculum training materials are divided into six interrelated stages following the Instructional Systems Development (ISD) methodology; Plan, Analyze, Design, Develop, Implement, and Evaluate. AIM II does not support the Implementation or Evaluation phases of the ISD process. A brief explanation of each stage of the ISD process is included. A more detailed explanation of the ISD process used by AIM II to develop task-based curricula can be found in NAVEDTRA 130B.

The ISD process defined in NAVEDTRA 130B includes the following stages:

- **PLAN PHASE** - The starting point of the ISD process. During this phase the developer identifies resource requirements and the sequence of events in the development process of a new course, a revision, or a cancellation- the output of this phase is the Training Project Plan (TPP).
- **ANALYZE PHASE** - The purpose of this phase is to produce the duties and related job tasks, task sequence, level of performance, and the skills and knowledge items, which must be taught - the output of this phase is the Course Training Task List (CTTL).
- **DESIGN PHASE** - This phase produces the course learning objectives and an instructional sequence - the outputs of this phase are the Learning Objectives (LOs), Curriculum Outline of Instruction (COI), Course Master Schedule (CMS), and Training Course Control Document (TCCD).
- **DEVELOP PHASE** - During this phase the developer produces the instructional materials for the instructor and the trainee - the outputs of this phase that are currently supported by AIM II include the Lesson Plan (LP), Trainee Guide (TG), and transparencies.
- **IMPLEMENT PHASE** - This phase begins when the Curriculum Control Authority (CCA) has approved a course for use and the functional commander authorizes the course to be taught - the output of this phase is the actual conduct of instruction. This phase is not considered a development phase and therefore is not supported by AIM II.
• **EVALUATE PHASE** - Elements of this phase consist of the evaluation and revision of the training materials based on assessment of the training materials and the performance of the graduates in the fleet - the outputs of this phase include internal and external evaluation and feedback. This phase is conducted as an ongoing effort to keep the curriculum up to date. The results of this effort are used as the basis for generating either a change or revision to the existing curriculum.

1.2 REFERENCED DOCUMENTS

The following documents are applicable to this User’s Manual:

- AIM II FD Functional Description for Tasked Based Authoring Instructional Materials (AIM), CnTechtra ltr 1500 Ser N61/9780, 19 November 1993.
- Navy ILE Content Developer’s Handbook Mpt&ECioswit-ILE-HDBK-1B, 01 September 2007
1.3 AUTOMATING THE CURRICULUM PROCESS USING AIM II

The figure above shows the interactions and dependencies among task based curriculum development components. The following paragraphs describe these relationships.
The curriculum development process begins with a determination of training necessity and a Front End Analysis (FEA). The FEA is where duties and tasks required for training are determined from a variety of sources including but not limited to Job Task Inventories (JTIs) and Logistics Support Analysis Record (LSAR) data. The result of the FEA is the beginning of the curriculum development process using AIM II.

A Training Project Plan (TPP) is developed during the FEA. Data added to the TPP Module provides all of the front matter and a majority of the management information necessary for the development, revision or cancellation of a course. In addition to this information, resource requirement information is entered in the TPP.

The Course Training Task List (CTTL) is developed to support a specific course mission. Duties and tasks from the FEA, combined with the course mission statement from the TPP, form the foundation for the Curriculum Outline of Instruction (COI).

The duties and tasks from the CTTL are the basis for the Learning Objectives (LOs). Duties are developed into Terminal Objectives (TOs); tasks are developed into Enabling Objectives (EOs). The developer then sequences the objectives. Adding the appropriate conditions and standards as required further develops the LOs. The developer builds the COI by placing the objectives into an instructional sequence for presentation.

The Training Course Control Document (TCCD) is a life cycle management document for each course that consists of front matter, the COI, and annexes including the Resource Requirements List (RRL) and Course Master Schedule (CMS). The AIM II TCCD module uses the COI as the foundation for the CMS.

The COI is used in the Lesson Plan (LP) as the basis of an outline, with the objectives separated into units and topics. Units are comprised of TOs and related Topics. The Topics contain EOs that support the TOs of the Unit. The developer has the ability to cut, copy, and paste to and from a word processor to create Discussion Points (DPs) to support each of the EOs. Related Instructor Activities (RIAs) are developed for the DPs to guide the instructor to the appropriate RRL item that is required to teach the DP and provides amplifying instructions. The standard DP of "Introduction" is automatically inserted into the document by the AIM II program. As the LP is being developed, supporting training materials can be created and then added to the Course and Site Resource Requirements Lists (RRLs).

The initial structure of the Trainee Guide (TG) is created from the LP. The developer initiates the process by selecting TG Sheets as the RRL Type in the RIA column. The available types of instruction sheets include Information, Diagram, Job, Assignment, Outline, or Problem sheets. These sheets are further developed through the TG Module.
1.4 AIM II PRIVILEGES

1.4.1 Single Site Privileges

AIM II uses two kinds of privileges to provide access to the AIM II database:
- AIM User
- AIM Administrator

An AIM User can view all the training materials, less test item and tests, and can be assigned privilege to perform specific functions on training material by the AIM Administrator. An AIM User can create training material and has the following default privileges for materials created under their login and password unless modified by an AIM Administrator:
- View (Testing Module Only)
- Edit
- Lock
- Grant
- Clear In Use
- Maintain/Delete

A person with AIM Administrator privileges has access to all training materials and Utility functions of AIM II.

<table>
<thead>
<tr>
<th>Level</th>
<th>Allows a User to . . .</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>View Test Items and Tests in the Testing Module.</td>
<td>This privilege only exists for the Testing module. A user without view privilege cannot access the Testing Module.</td>
</tr>
<tr>
<td>Edit</td>
<td>Edit a given training material item.</td>
<td>Edit privilege is a default privilege assigned by the software to an AIM User who creates a training material item. A user with Grant privilege can give another user Edit privilege. Note: Users with Edit privilege are granted Add Notes privilege by default.</td>
</tr>
<tr>
<td>Lock</td>
<td>Lock or unlock a given training material item.</td>
<td>Lock privilege is a default privilege assigned by the software to an AIM User who creates a training material item. A user with Grant privilege can give another user Lock privilege.</td>
</tr>
<tr>
<td>Grant</td>
<td>Grant or change privilege levels of other users for a given training material item.</td>
<td>Grant privilege is a default privilege assigned by the software to an AIM User who creates a training material item. A user who has Grant privilege for a given training material item can grant another user privilege levels.</td>
</tr>
</tbody>
</table>
### Training Material Item Privileges

<table>
<thead>
<tr>
<th>Privilege</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Approve</td>
<td>Approve a given training material item. Approval privilege assigned to an AIM User by an AIM Administrator. For the Testing Module the privilege is called Approve/Unapprove.</td>
</tr>
<tr>
<td>Remove Flag</td>
<td>Remove Maintenance (X) Flags. Remove Flag privilege assigned to an AIM User by an AIM Administrator. Note: Users with Remove flag privilege are granted Edit privilege by default.</td>
</tr>
<tr>
<td>Clear In Use</td>
<td>Clear an In Use Flag for a training material item in the Admin Utility. Clear In Use privilege is a default privilege assigned by the software to an AIM User who creates a training material item.</td>
</tr>
<tr>
<td>Maintain/Delete</td>
<td>Create a Change or a Revision for a training material item and delete the item. Maintain/Delete privilege is a default privilege assigned by the software to an AIM User who creates a training material item.</td>
</tr>
</tbody>
</table>

The AIM Administrator can also assign one or more of the privilege levels shown in Table 1-1 to an AIM User for specific training materials via the AIM II Administration utility. Having any one privilege does not allow the AIM User to perform any other privilege.

The AIM II User who created a training material item can also maintain that training material once it is approved. If you are required to perform maintenance on training material that you did not create nor have Maintain/Delete privilege, the AIM Administrator has to grant the privileges required for the AIM User.

On initial installation, the initial default user accounts that are established are based on site requirements. The initial default AIM Administrator accounts are established by the AIM System Support Office (SSO) or support personnel.

#### 1.4.2 Central Site Privileges

AIM II Central Site uses five kinds of privileges to provide access to the AIM II database:

- AIM User
- Curriculum Manager FTS
- Curriculum Manager HQ
- AIM Viewer
- AIM Administrator
The following table represents the default functions available to the different AIM Central Site privilege levels.

<table>
<thead>
<tr>
<th>Privilege Level</th>
<th>Default Functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>AIM User</td>
<td>View all courses but only input/edit Courses that a Curriculum Manager FTS has assigned to them as C2M2.</td>
</tr>
<tr>
<td>Curriculum Manager FTS</td>
<td>Edit privilege for all courses assigned to their Learning Site as C2M2. Administrative privileges to assign roles locally for their Learning Site and AIM Users only. View only for all curriculum at other Learning Sites. Administrative privileges for course approval, revisions/changes, grant privilege for their Learning Site only.</td>
</tr>
<tr>
<td>Curriculum Manager HQ</td>
<td>Assigned to all Learning Sites. Edit all courses for all Learning Sites. No administrative privileges, edit only.</td>
</tr>
<tr>
<td>AIM Viewer</td>
<td>Assigned to all Learning Sites. View all courses for all Learning Sites. No administrative or editing privileges.</td>
</tr>
<tr>
<td>AIM Administrator</td>
<td>Assigned to all Learning Sites. Administrative privileges for all courses.</td>
</tr>
</tbody>
</table>

**NOTE:**
The table above illustrates privileges for CNATT Metaframe users. There are two exceptions for CSFE Metaframe users; Curriculum Manager FTS (FTS) can Import courses and they can create AIM Viewer accounts.

The Central Site AIM User (CSAU) has the same functionality as the Single Site AIM User (SSAU) mentioned above. A CSAU can create new courses and will have the same privileges as a SSAU.

Curriculum Manager FTS (CM FTS) has privileges similar to a Single Site AIM Administrator (SSAA). The CM FTS has the ability to assign additional privileges to CSAUs, but not to Curriculum Manager HQ (CM HQ).

AIM Administrators can assign additional privileges to CM HQs.
AIM Viewers cannot be granted any additional privileges, they can view courses only.

1.5 USING THE MANUAL

To eliminate redundancy and more closely reflect the format of the AIM II software itself, the AIM II User’s Manual presents development and maintenance procedures within the same modules; for example, development and maintenance of an LP are presented in Chapter 10 of the User’s Manual, which corresponds to the LP module of the AIM II software.
For easy reference, Administration and Utility functions are explained in Appendix B.

For users who are not familiar with basic MS Windows conventions, Chapter 2 introduces techniques for moving around in AIM II. Experienced Windows users may turn directly to Section 2.2 of Chapter 2 for login instructions and orientation to the software standard functions.

The remaining chapters correspond to the modules of the AIM II software:

- Chapter 3: Training Project Plan (TPP) Module
- Chapter 4: Course Training Task List (CTTL) Module
- Chapter 5: Learning Objective (LO) Module
- Chapter 6: Testing Module
- Chapter 7: Curriculum Outline of Instruction (COI) Module
- Chapter 8: Course Master Schedule (CMS) Module
- Chapter 9: Training Course Control Document (TCCD) Module
- Chapter 10: Lesson Plan (LP) Module
- Chapter 11: Trainee Guide (TG) Module
- Chapter 12: The Learning Object Module

Six appendices follow chapter 11:

- Appendix A: Glossary (and a list of acronyms)
- Appendix B: Administration and Utilities
- Appendix D: Developing IETM Extraction Files
- Appendix E: SCORM and NILARS
- Appendix F: CNATT TPP and TCCD Development
- Appendix G: NSW TPP and TCCD Development

### 1.6 SUMMARY

Chapter 1 reviewed the task based curriculum development process and explained how AIM II automates that process. Chapter 1 also described the manual's organization into chapters that correspond directly to the AIM II modules used in the development and maintenance of training material products.
CHAPTER 2
GETTING STARTED

2.0 GETTING STARTED ........................................................................................................... 2-1

2.1 LOGIN AND COURSE SELECT PROCEDURES ................................................................. 2-1
  2.1.1 Selecting Display Preferences ........................................................................ 2-3
  2.1.2 Developing a New TPP .................................................................................. 2-4
  2.1.3 Selecting an Existing Course ......................................................................... 2-4
  2.1.4 Working With the Course Tree Structure ...................................................... 2-5
  2.1.5 Options menu Item ......................................................................................... 2-7
  2.1.6 View Menu Item ............................................................................................ 2-9
  2.1.7 Window Menu Item ..................................................................................... 2-10
  2.1.8 Pop-up Menu ................................................................................................ 2-10
  2.1.9 Toolbar ......................................................................................................... 2-10
  2.1.10 General ......................................................................................................... 2-11
  2.1.11 Deleting a Course ......................................................................................... 2-11

2.2 AIM II SOFTWARE CONVENTIONS .................................................................. 2-12
  2.2.1 Using the Mouse .......................................................................................... 2-12
  2.2.2 Using the Menus .......................................................................................... 2-13
  2.2.3 Using the Keyboard ..................................................................................... 2-13
  2.2.4 Editors Used in AIM II ................................................................................ 2-14
    2.2.4.1 MS Word™ ................................................................................... 2-14
    2.2.4.2 Styled Text Editor .......................................................................... 2-15
    2.2.4.3 AIM II Text Editor ......................................................................... 2-15
    2.2.4.4 High Edit ........................................................................................ 2-17

2.3 STATUS LEVELS FOR AIM II PRODUCTS ........................................................ 2-22

2.4 AIM II HELP MENU ITEM .................................................................................... 2-22
  2.4.1 On-line Help ................................................................................................ 2-22
    2.4.1.1 Contents ......................................................................................... 2-24
    2.4.1.2 Index .............................................................................................. 2-24
    2.4.1.3 Search ............................................................................................. 2-25
  2.4.2 User’s Manual .............................................................................................. 2-26
  2.4.3 Changes in Release 5.0 ................................................................................ 2-27
  2.4.4 Frequently Asked Questions ........................................................................ 2-27
  2.4.5 Documentation ............................................................................................. 2-27
  2.4.6 Getting Started Demonstrations ................................................................... 2-27

2.5 GENERAL PRINTING INFORMATION ...................................................................... 2-28

2.6 ACCESSING AIM II UTILITIES ........................................................................... 2-28

2.7 DEVELOPING AND MAINTAINING COURSES .................................................. 2-29

2.8 PRINTER ADMINISTRATION ................................................................................... 2-31
  2.8.1 Printing Modules Except TG to a File ......................................................... 2-31
  2.8.2 Printing the TG to a File .............................................................................. 2-31
  2.8.3 Printing the TG to a File (non-NMCI) .......................................................... 2-32
2.0 GETTING STARTED

When beginning to use the AIM II software, the AIM Administrator will establish a user account. A user account consists of a user identification of a login name and AIM II privilege as an AIM User or AIM Administrator. Login to the AIM II workstation can be accomplished once a user account is established.

The User Utility provides the AIM Administrator the flexibility to designate individuals who will only be allowed to create training materials in the TLO/ELO module by selecting the Show Courses column and from the drop-down menu selecting No. The user will then only have access to the menu items and icons associated with the TLO/ELO Utility.

To run the software, follow local procedures for login and proceed to the Windows DeskTop Manager window. Check with the AIM Administrator if a preset path for the AIM II program does not exist.

The AIM II program has its own login procedure that checks the user ID and privileges.

When the AIM II program is exited, the AIM II process will terminate. Any work that you have saved is written to the database and is backed up as part of the operating systems and database's general backup and recovery procedures.

**WARNING:** For Windows 95 through NT: The tool bar on the bottom of the window will indicate all windows that are currently open in AIM II. When logging out of AIM II, ensure that all of its associated windows are exited first, by opening each window from the tool bar and selecting the Exit menu item for each window, before exiting from the AIM II main menu. If the associated windows have not been closed and AIM II is exited from the main menu, the user will receive the prompt "The Program XXXX is still open". If Ctrl-Alt-Del is used to end the task, a possibility of database corruption exists, and an In-Use flag will remain for the training material item last accessed.

2.1 LOGIN AND COURSE SELECT PROCEDURES

To log into AIM II:

- **Step 1**  From the Windows DeskTop; double click on the AIM II icon.
Step 2 To enter AIM II, log in with a valid user name and password. If the user name and password are valid, AIM II allows access to the resources for which you have been granted privileges. The AIM II Administrator has the responsibility of entering user names and privilege levels.

If this is your first time logging into AIM II, you will not have a password. With your cursor in the Password field - press <Enter>.

The login procedure can be canceled at any time by clicking on the Cancel button.

NOTE: AIM II uses two different levels of privileges. The options are AIM User and AIM Administrator. A person with AIM User privilege has the privilege to view and develop new materials in AIM. View (Testing Module only), Edit, Lock, Grant, and Clear In Use are default privileges assigned to an AIM User who creates training materials.

The AIM Administrator level of privilege allows access to all training materials and Utility functions of AIM II.

On initial installation, the initial default user accounts will be established based on site requirements.

Items in black are available for immediate user selection. Items that appear dimmed or "grayed out" are not available for selection at this time.

Methods for selecting an item include:

- Clicking the left mouse button while the arrow is anywhere on the appropriate icon.
- Clicking once on them or by holding down the ALT key and pressing the underlined letter can access the items on the top menu bar. Pressing the underlined letter accesses the sub-menu items.
- Scrolling to highlight the item using the keyboard arrow keys then pressing the enter/return key. (For directions on clicking and scrolling, see paragraph 2.2.1.)

Items that appear on the window as dimmed are options that are not currently available (i.e., either they are not applicable to the task currently being implemented or you do not have the privilege to access these options). To move between the various fields within each window, use either the mouse or the keyboard Tab key.
Many windows provide the **Edit** option with a drop-down menu including **Save** and **Cancel** (unless otherwise stated). **Print** evokes the AIM standard print utility, which permits the displayed data to be sent to a printer or a file. **Print Preview** presents the formatted document in the window. An **Options** menu item allows you to **Print** the document or **Save** the document to a PDF file. The **Go to** menu item includes **Previous Page**, **Next Page**, **First Page**, and **Last Page**. The Find field can be used to enter words for search criteria and the Find button will search for each occurrence of the word throughout the document. Page and Actual Page fields can be edited to select specific pages in the document. Windows can be exited from any menu by selecting **Exit**. **Help**, which provides details concerning the AIM II displayed window, operates similarly to the online help feature for Microsoft Windows.

### 2.1.1 Selecting Display Preferences

The first thing to look at is the **Options**-menu item and the **Preferences** sub-menu item. This allows you to change several aspects of how AIM works on a user-by-user basis. The first tab (**Display**) lists options to change the size of the Toolbar buttons and color scheme (large icons and Windows colors are the defaults). There are also options to maximize each form on display and bold the display text on the screen. The second tab (**Courses**) gives the user the option to remember the recently selected Courses (up to 9 can be remembered). These will be listed under the Course menu item in AIM. The checkbox "Open last Course on login" will, if checked, cause AIM to automatically select the last Course you had selected when you login. Note that changes made to these properties should take effect immediately. The option "Return to highlight position which, when selected, will return you to the last item you were on in the interface. For example, you were checking out the data in the TCCD Funding section of a site when you closed the Course window. The next time you open the Course, your highlight will move back to TCCD Funding, rather than having you search your way for it. The third tab, **Advanced**, gives you the option to use NSCORM or SCORM Metadata specifications. Choosing the NSCORM specification automatically selects 2004 version and when the SCORM specification is selected you have a choice of using the 2004 version or v1.2 for creating SCORM compliant files. It also provides the option for the user to use SLC grouping for Sections in the Learning Object Module. The fourth tab, **CPM**, gives the user the ability to add the User Name and Password, issued by the Content Planning Module Administrator, for accessing the CPM when developing Learning Object Module materials.

The AIM Administrator does not have to assign an AIM User password; he/she need only add the user to the list as an AIM User. When the user logs into AIM II, login can be accomplished without a password until the user selects the **Change password** utility and enters a password. At initial entry, the user can depress <Return> when the cursor moves to the password field of the login window and gain access to AIM II until the user has entered a password into the system.
If you forget your password, the AIM Administrator can clear your old password by using the **Clear User Password** option from the **User** Utility. This option will retain your privileges for training materials assigned using the old password.

Two methods are available for selecting options from the main menu - (1) click on the menu bar and again on the item of choice from the drop-down menu, or (2) click on the associated icon.

Selection of the **Course** menu item from the AIM II main window causes the course drop-down menu to appear. The drop-down menu contains two sub-menu items and a list of courses previously selected. To work on a course that exists in the database, click on **Select** and AIM will open the Course Select window from which you can select the desired course. To develop a new course, click on **New** and AIM will open the Training Project Plan (TPP) window where you will start the development process for a new course.

### 2.1.2 Developing a New TPP:

Development or redevelopment of a course that does not exist in AIM II is commenced with the development of a TPP.

1. **Step 1** Select the **Course** menu item and the **New** sub-menu item or click on the New Course icon.
2. **Step 2** A blank TPP window will open where you can identify the development project. Refer to Chapter 3 for the development of the TPP.

### 2.1.3 Selecting an Existing Course:

1. **Step 1** Select the **Course** menu item and the **Select** sub-menu item or click on the Select Course icon.
2. **Step 2** The software will open the Course Select window from which you can highlight the desired course, select the **Options** menu item, and perform various options on the course or select the course highlighted by double clicking on the course or clicking on the **Select** menu item.
3. **Step 3** When a course is selected the Course tree structure is listed in a hierarchy for which the user can navigate as if it was Windows Explorer.
Once selected, and the Course interface is displayed, that Course will be listed as the most recent Course under the Course menu (the list appears in a Last-Selected-Shows-First ordering). Two Course Tree Structure menu items also appear after the course is selected; Options and View. The View menu allows you to toggle on or off the Summary and Notes display grids in the Course window. The Note display shows all notes for the item if any. The Summary display shows a read-only version of the data for the element selected. Note that this may be the actual data or a summarized version of the data.

The Options menu item allows you to edit/view notes for the currently selected element in the tree (left hand side). Selecting GoTo, or clicking on the corresponding icon, will open the window for the item highlighted. Selecting the Preview and Print options, or clicking on the corresponding icons, either preview or print the contents of the folder you have selected.

All forms work independently of each other, which means if you want to display several screens at once and edit the data therein, you can.

As the Course displays are done in a separate window, you can open several Courses at one time. Clicking a button or choosing an item from the Documents menu item causes AIM to act as if you said "GoTo" on the main module item in the tree.

The Windows menu item contains options to move the windows in standard Windows fashion, tile, cascade, and arrange icons.

AIM will only open one instance of a module per Course, or, for utilities, only one instance. Therefore, if you click on TPP for a Course, do some work in it, but leave it open, return to AIM, and click the TPP button again, the existing TPP comes forward. However, different Courses will cause different instances of TPP to run.

2.1.4 Working With the Course Tree Structure

Once you’ve selected a Course, the Course is displayed in a Course window inside the AIM window (see Figure 1 below). Since all Course information is contained within this single window, you can easily select and work with multiple Courses at one time, each with its own Course window.
The Course window has up to four parts. On the left hand side is the Course structure. This is a representation of the main elements of the Course. The right side lists information regarding the element currently highlighted in the Course structure. On the top is a list of all child elements of the highlighted element (for example, all Topics in the current Unit). Below that is a display of data summarizing the current element (for example, highlighting TPP->Milestones in the Course structure displays the Milestone data itself. Below the summary is a display of all Notes attached to the current element. Note that if there’s no data to display in a particular section, it will not be displayed. So, if TPP Milestones has no Notes attached, then the “Notes” section is hidden from view. This allows more room for the other sections to display their data. Of the three sections, only Summary will display on every element (unless the summary display has been turned off.)

Figure 2-1. Course Display
Besides the display of the Course Structure and Summary), there are a few other details to look at. First, you may notice folder icons with little red flags on them. These indicate the element (or one of its child elements) is flagged. The Bold lettering on “TPP” and “Topic 2” indicate these items have notes attached to them. TPP and TCCD folders will show a letter to indicate the current status of that document.

2.1.5 Options Menu Item

The Options menu item contains the following options:

- **GoTo**
- **Edit Notes**
- **Preview Notes**
- **Print Notes**
- **Print Preview**
- **Print**
- **Generate HTML**
- **Preferences**.

With the exception of the Generate HTML option (enabled only for LP/TG), the above menu items work on either the current element of the Course structure, or the highlighted element in the child list, whichever one you last clicked. For example, if you were to choose **GoTo** from the **Options** menu, it would go to the window for the folder that is currently open in the Course Tree Structure.

**GoTo**

The **GoTo** option, allows the user to automatically go to the screen to display/edit the current element. **GoTo** can also be initiated by double-clicking an element in the child element list on the right-hand side of the screen.

**NOTE:** There are currently four elements for which GoTo does not work: The main Course element (top-most item in the Course structure), the LP/TG element, and the Instructor Preparation and Trainee Preparation elements of each Topic. There is no screen that directly correlates to these elements. Currently, double-clicking these nodes acts as if you selected that element in the Course structure.
Edit Notes
The **Edit Notes** option is available to all users who have Edit Privilege for the selected training material, and can be used on any element in the Course structure. This menu displays the Notes screen, which allows the user to view all notes on the specified element, and allows adding of new notes. The user can delete his/her own notes, but not any notes belonging to another user. There are two types of notes, Public and Private. Only the user who entered it sees a Private note. A Public note is displayed to all users.

Preview/Print Notes
These options, when available, either **Preview** or **Print** the Notes for the selected element.

Preview/Print
These options, when available, either **Preview** or **Print** the selected element, as if you performed this task from the module itself. Preview and Print are only available on elements which printing was previously done (main elements, like TPP, CTTL, etc., individual Units/Topics in the LP, and individual Sheets for the TG).

Generate HTML
The software generates HTML file format of an LP/TG that can be used as needed (for example, you can display the HTML file in a web browser). The HTML file format also provides active hyperlinks from the LP Topic Page and RIA entries in the LP citing IMM resources, allowing a viewer of the HTML version of the LP to click on a link to see the corresponding file. This could be used to review an LP and its related media files, without searching for the media cited in a RIA. When you view the HTML file in a web browser, hyperlinks will appear in RIAs for IMMs for which the corresponding file was found. When you click on the link, the associated media file will be displayed.

The HTML output for the TG that has been developed in Word can contain hyperlinks to the IMM selected in the Instruction Sheets. High Edit does not provide this functionality.

Preferences
The **Preferences** option takes you to the User Preferences screen. On this screen, you can change different aspects of AIM to suit your needs. All preferences are User specific and do not affect other users.
**Display**

The **Display** tab allows you to specify whether to use large or small buttons for the AIM toolbar, and whether the colors used on the screens are the old-style AIM colors, or should follow the Windows color scheme of the running computer. The Maximize option, when set, will automatically maximize each form on display. The Bold display text on the screen option will present all text entries in AIM in bold.

**Courses**

The **Courses** tab contains settings for the Recent Courses section of the **Course** menu, whether or not to display the recent Courses and how many Courses to display in the list. There’s also the option to have AIM automatically open the most recent Course in the list when you log into AIM. The “Return to highlight position” tells AIM to save the element that was highlighted when the Course screen was closed, and return to that position when you re-select the Course.

**Advanced**

The **Advanced** tab gives you the Metadata Spec option to implement NSCORM or SCORM Metadata specifications and using either SCORM versions 2004 or v1.2 structure for creating SCORM compliant files. It also provides the option for the user to use the SLC (Submarine Learning Center) grouping of elements *(Learn, Explore, Practice)* for Sections in the Learning Object Module.

**CPM**

The **CPM** tab gives the user the ability to add the User Name and Password, issued by the Content Planning Module Administrator, for accessing the CPM when developing Learning Object Module materials.

### 2.1.6 View Menu Item

The **View** menu item contains the following sub-menu items: **Notes, Summary, Refresh, Expand All**, and **Collapse**.

**Notes, Summary**

These sub-menu items toggle whether the Note and Summary displays in the Course screen should be displayed. These settings are Course specific, so turning off summary in one Course will not turn off their display in other Courses. These settings are also saved in the database, so the next time you select this Course, the settings you had previously will be restored.
Refresh
This sub-menu item allows the user to refresh the Course structure and summary information manually. Usually making changes in AIM will automatically cause the data to refresh, but changes made by other users will not show up without a manual refresh. (Note: A quicker way to refresh just the summary data would be to click the element in the Course Structure).

Expand All
This sub-menu item will expand the highlighted folder. Two possible uses for this would be to aid in the hunt for flagged Topics or items with Notes without having to click the + boxes next to every element.

Collapse
This sub-menu item will collapse the highlighted folder.

2.1.7 Window Menu Item
The Window menu contains the standard set of options with multiple window applications. Note that most of these options will only work (or at least make sense) if you have more than one Course window open. Underneath these options is a list of all open Course windows. Selecting one brings that window forward.

2.1.8 Pop-up Menu
If you right-click on a folder in the Course Tree Structure, a small pop-up menu is displayed, giving options for that folder. These options are the same options located under the Options menu item.

2.1.9 Toolbar
This toolbar has buttons for GoTo, Edit Notes, Preview, Print, View Notes, and View Summary. These options work exactly like their menu counterparts.
2.1.10 General

- You can only open one instance of a module. If Agency is already running, and you attempt to use the Utilities-Agency menu again, AIM will display the currently running module, rather than starting up a new instance of the existing one. For Course modules, this is Course specific (AIM will only open one instance of a TPP per Course).

- For modules, which are broken down into several sub-elements in the Course structure (TPP, TCCD, LP, and TG), the individual elements work independently of one another, allowing you to edit/view different pieces of the same Course at the same time. For example, you can bring up for view/edit the Justification and the Development Method of a TPP at the same time. You can also modify the RRL of two different sites at the same time, or edit the DPs in two separate Topics in the same LP.

- The above independent editing also works if you select the original AIM II main menu icons, as well as through the Course Tree Structure. If you go to TPP through the Document menu, then choose Justification from the Contents menu, you no longer are prevented from returning to the TPP screen while Justification remains open. You can keep Justification open and return to the main TPP screen to go to another part of TPP, or just edit some of the cover info.

2.1.11 Deleting a Course

To delete a course:

Step 1  Select the **Course** menu item and the **Select** sub-menu item or click on the Select Course icon.

Step 2  From the Course Select window select the **Options** menu item and the **Delete** option.

Step 3  The software will ask for confirmation. Click on **Yes** to delete or **No** to cancel the delete option. **There is no 'undelete' option.**
2.2 AIM II SOFTWARE CONVENTIONS

The AIM II software is an MS-Windows™ based application and uses many of its conventions as the window software. The MS-Windows™ software is a graphical software environment. MS-Windows™ uses an interface that combines icons (pictures), drop-down menus, and fill in data windows (which are referred to as "windows" in this user's manual). With windows, more than one application can be run at a time and transfer of information can be accomplished between the different applications. This feature is especially useful when copying large amounts of text from a word processor into the AIM II program. A review of some of the more common features of the window software in AIM II is listed here for reference.

2.2.1 Using the Mouse

Moving the mouse moves the pointer on the window.

- **Pointing** to an object is the first step in using the mouse. Point to an object by moving the mouse so that the tip of the pointer is in contact with the object.
- **Clicking** on an object means to press the left mouse button and release it immediately. Click on an object after pointing to it.
- **Double Clicking** on an object is pressing the left mouse button twice in rapid succession. Double-clicking is usually a shortcut for making a selection. For example, a course can be selected from any of the modules by double clicking on the course title.
- **Dragging** an object is pressing the mouse button and holding it down while moving the mouse.
- **Dropping** is releasing the mouse button once it is in the position on the window at the location required. These procedures in AIM II are called **drag and drop**.
- **Highlighting** is pointing to an object and clicking the mouse once. This will make the selected object stand out from the rest of the window. Highlighting selects the item for performance of other actions such as saving or dragging.
- **Minimizing** is reducing a window to an icon (picture). When reduced to icons, windows-based applications continue to run but their windows do not take up space on the window. To reduce a window to an icon, click on the Minimize button in the upper right corner of the window.
- **Maximizing** is enlarging a window to its maximum size. To enlarge a window to its maximum size, click on the Maximize button in the upper right corner of the window.
- **Scrolling** is pointing to the arrows within a window and clicking on them. This will move the text on the window in the direction of the arrow. This option is available to view portions of the material being worked on if it is too big to be seen in the available window.
• **Scroll bars** are generally located on the right side and at the bottom of a window. Each scroll bar has a scroll arrow at each end and most contains a small square box called a scroll box.

• **Scroll arrows** point in the direction that the text in the window will move if clicked on: right and left or up and down. To move in small steps, click on the arrows.

• **Scroll box** represents the location in the document. To move in large jumps, drag the scroll box.

### 2.2.2 Using the Menus

All of the windows in AIM II have menus, which will execute commands. The row of words across the top of the window is called the menu bar, or just the menu. Each of these words has a "drop-down" menu attached to them. For example, on some windows the word **Options** is on the menu. Clicking on the **Options** menu item will cause another menu to "drop-down" and provide the specific commands that can be executed.

Menu conventions:

- **Dimmed options** indicate that the command is unavailable at the current time. For example, the **Edit** option may not be available until data has been entered into the fields of the window.

- **Underlined letters** indicate which letter should be typed after pressing the ALT key to select an option using the keyboard.

- **Icons** provide another way to choose AIM II modules. Icons are pictures that represent the module or functionality.

### 2.2.3 Using the Keyboard

The keyboard can be used to perform many of the same functions as the mouse. The following conventions are useful keyboard options:

- The **ALT** key plus the underlined letter of the option will execute the main menu command just like clicking on the command with the mouse.

- The **Tab** key moves the cursor right from field to field on the windows.

---

1 These options are repeated in the sections of this User's Manual where they apply. However, they appear more frequently in the first few chapters as reminders. In later chapters, the description is left out.
• **Shift + Tab** moves the cursor left from field to field (not applicable to all AIM II windows).
• **Arrow** keys will move the cursor in the direction to which the arrow points.

**NOTE:** Arrows are generally active within a field. The Tab key moves the cursor from field to field.

### 2.2.4 Editors Used In AIM II

Four Editors are used in the AIM software:
- **MS Word**
- **High Edit**
- **Styled Text Editor**
- **AIM Text Editor**

#### 2.2.4.1 MS Word

MS Word is the default editor for the major text entry portions of the TG, which includes:
- Safety/Hazard Awareness Notice
- Assignment Sheet - Study Questions
- Diagram Sheet - Diagram
- Information Sheet - Information
- Job Sheet - Job Steps
- Outline Sheet - Topic Outline
- Problem Sheet – Problem

In previous versions of AIM II, MS Word was not available and High Edit was used as the editor. AIM II offers the user a choice of which editor to use when maintaining curricula that was previously developed using High Edit. High Edit will still be used for approved materials that were originally developed using High Edit. If MS Word is not available the user will be required to use High Edit for the Instruction Sheets and a basic text editor for the Safety/Hazard Awareness Notice. NMCI users that are working with older courses may need to convert the embedded Word files within each course. To convert the older Word files, .doc file format, to the newer .docx file format a conversion application can be found in the AIM directory. When running the converter (ConvertWordContent1 or 2) the user will be asked whether to convert a single export file or the entire database. The user will then be asked which format to convert to, either Word 2003 or Word 2007+. If the user is using Word 2010 they must check the Trust Center to verify their system has not been blocked from using older files.
2.2.4.2 Styled Text Editor

The Styled Text Editor (Figure 2-2) is used for the LP in the Safety/Hazard Awareness Notice, Discussion Points (DPs), and the After Text portion of Related Instructor Activities (RIAs). It is also used in the TG Instruction Sheets that contain an Introduction field and provides the developer with the ability to change font, pitch, center, and justify the text.

![Figure 2-2. Styled Text Editor for Introduction Fields](image)

2.2.4.3 AIM II Text Editor

The AIM II Text Editor (Figure 2-3) is used in the Training Project Plan (TPP), Training Course Control Document (TCCD), and Trainee Guide (TG) where large amounts of text need to be stored. Although you may type in as much data as you choose, using the MS Windows cut-and-paste option from an existing application or selecting the Import Text File option is a time-saving alternative to re-typing narrative sections in the Text Editor. There are no options in the AIM II Text Editor to change fonts, underline, bold, center text, etc. it is a simple text entry window.
To copy and paste to or from any MS Window-based word processor or any field in AIM:

Step 1  Select the text to be cut or copied by highlighting it in the original document. (Use either the keyboard or mouse.)

Step 2  Press Control + C to copy the selected text to the clipboard.

Step 3  Position the cursor at the location where you want the copied text to be pasted.
Step 4 Press **Control** + **V** to paste the text at the location of the cursor. Because the same information will remain in the buffer, you can paste it repeatedly until new text is copied to the buffer or the computer is powered down.

**To cut text from any MS Window-based word processor or any field in AIM:**

Step 1 Highlight the text you wish to cut.

Step 2 Press **Control** + **X**.

**To edit undo:** Press the **Control** key + **Z**.

Other features of the AIM Text Editor are straightforward. The **Options** menu lets you import a text (.txt) file and print or print preview documents; the **Edit** menu allows you to spell check highlighted text or an entire document; to search forward or backward through text for words or characters that you specify; to replace words or characters that you specify; to spell check the entire document or selected text; and to save or cancel changes you make to text in Text Editor.

The **Exit** and **Help** menus are self-explanatory.

**2.2.4.4 High Edit**

The AIM High Edit (*Figure 2-4*) function, which is available for editing Trainee Guide (TG) Instruction Sheets, offers more formatting features than those available in the AIM Text Editor and can be used when MS Word is not available. The High Edit menu bar offers the following choices: **File**, **Edit**, **Format**, **Options**, **Table**, **Exit**, and **Help**.
The menu bar's **File** drop-down menu provides the options to print or print preview text, and add or delete graphics for an instruction sheet, and import a text file.

The **File** drop-down menu provides the following options:

- **Add Graphic** - Allows you to select a graphic from the Graphic Utility portion of the database. The width and height of the graphic can be adjusted to size the graphic for the instruction sheet when selected in the Graphics library. When this information is saved in the Graphics library the file name of the graphic and it's sizing information is placed on the Instruction Sheet where the cursor was located when the **Add Graphic** option was selected.

- **Delete Graphic** - Placing the cursor on the same line as the graphic, in the instruction sheet and selecting this option will delete the graphic from the Instruction Sheet and unlink the graphic from the Graphics library.
• **Import Text File** - If the required text has already been created in a word processor and saved as a Rich Text Format (.rtf) or Text (.txt) file the entire contents of the file can be imported into the Instruction Sheet at the location of the cursor by selecting this option and selecting the appropriate file.

• **Export to File** - This option allows you to export the contents of the editor window to either a Rich Text Format (.rtf) or Text (.txt) file.

• **Print** - This option allows you to print the entire Instruction Sheet for review. When Word is the default editor of the TG the software will print the correct page number of the TG Sheet. When High Edit is the default editor the software does not calculate the actual position of the Instruction Sheet in the TG and each printout starts with page number 1.

• **Print Preview** - This option allows you to preview and print the **Current Page**, **Range of Pages**, and **Entire Document** for review of the Instruction Sheet. When Word is the default editor of the TG the software will ask if you desire to have the correct page number of the TG Sheet displayed. When High Edit is the default editor, the software does not calculate the actual position of the Instruction Sheet in the TG and each printout reflects the page number contained in the document starting with the page number 1.

The menu bar's **Edit** drop-down menu offers the standard windows **Cut**, **Copy**, and **Paste** options, which can be selected by the following keystroke options:

- **Cut** = Ctrl + X
- **Copy** = Ctrl + C
- **Paste** = Ctrl + V.

The Edit menu offers a number of other options:

- **Undo (Ctrl + Z)**: Allows cancellation of a command, a keystroke, or a series of keystrokes, one at a time, in reverse order, beginning with the command, keystroke, or series of keystrokes entered most recently.
- **Clear (Del)**: Deletes the character to the right of the cursor or any highlighted text.
- **Select All**: Highlights all text within a TG sheet.

**NOTE**: Find and Find and Replace options exercised on an entire AIM Editor window of text will not examine the contents of a Graphic.

- **Find (Ctrl + F)**: Takes the cursor, either forward or backward, to the text (a word or string of words) that is specified in a window the command calls up.
- **Find Next (F3)**: Allows the software to continue a search.
- **Find and Replace (Ctrl + R)**: Allows the software to replace the text (a word or string of words) entered in the "Replace with" field. High Edit allows replacement of the next occurrence of the text, either forward or backward, or all occurrences of the text.
• **Spell Check Entire Document (Shift + F2):** Identifies possibly misspelled words, suggests substitutes, and allows you to replace or ignore possibly misspelled words throughout the text.

• **Spell Check From Cursor Down:** Identifies possibility of a highlighted word being misspelled. Suggests substitutes, and allows you to replace or ignore possibly misspelled word from the position of the cursor to the end of the file.

• **Save (Ctrl + S):** Saves the editing completed for the selected portion of the instruction sheet.

• **Cancel:** Cancels all editing accomplished since last save.

High Edit’s **Format** drop-down menu offers formatting features. Options available from the **Format** drop-down menu include the following character attributes:

• **Normal:** Changes highlighted boldface or italic text to normal.

• **Bold (Ctrl + B):** Makes highlighted text boldface (e.g., **boldface text**).

• **Underline (Ctrl + U):** Draws a line under highlighted text (e.g., *underlined text*).

• **Italic (Ctrl + I):** Makes highlighted text italic (e.g., *italic text*).

• **Strike Thru:** Draws a line through highlighted text (e.g., *delete text*).

• **Superscript:** Makes a highlighted character superscript (e.g., 22 becomes $2^2$).

• **Subscript:** Makes a highlighted character subscript (e.g., H2O becomes H$_2$O).

**Format** menu options also include the following text attributes:

• **Align Left:** Gives highlighted text flush left and ragged right margins. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.

• **Center:** Centers text. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.

• **Align Right:** Gives highlighted text ragged left and flush right margins. If text is not highlighted the command lines up only the text on the line on which the cursor rests.

• **Justify:** Lines up both left and right margins of highlighted text. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.

• **Spacing:** Provides a sub-menu with items "**Single**, "One and a Half" and "**Double". Inserts empty line spaces between each line of highlighted text.

• **Paragraph Spacing:** Provides the option to control the spacing for paragraphs within the document and allows you to select sub-menu items "**Single**, "One and a Half" and "**Double".

• **Color:** Provides the option to change the color of highlighted text from a palette of 16 font colors (including black and white).

• **Font:** Provides the option to alter the appearance of highlighted text for viewing and printing, including size, typeface, color, and font attributes such as bold or italic.
NOTE: Use of Tabs with Center or Justify format can cause portions of text to be un-editable.

From the **Options** drop-down menu, the following options are available:

- **Indent**: Provides for indentation of the text on the line of the cursor and subsequent lines before the next hard return. The document indenture has default of "1". Placing the cursor at the desired location, selecting the Indent option can change the indenture, by entering the value desired for left, right, and first line indentures.
- **Bullets Numbering**: Opens a Bullets and Numbering window from which you can select from either 8 different styles of bullets or numbering for selection to indent the highlighted text in your file.
- **Toggle Page Break**: Inserts or deletes a page break at the location of the cursor.
- **Tab visible**: Inserts an arrow (→) in TG sheet text wherever a tab has been entered.
- **Line Feed Visible**: Inserts a paragraph mark (¶) in TG sheet text wherever a hard return has been entered.
- **Space Visible**: Inserts a centered dot (●) in TG sheet text wherever a space character has been entered.

From the **Table** drop-down menu, the following options are available:

- **Create Table**: Will create a table with the number of rows and columns specified. Will default to a grid table unless you desire to change the properties of the table.
- **Border Style**: Will allow you to change the border of the cells highlighted to No border, Box, or Shadow. This screen will also allow you to create a 3-D effect through use of raised and sunken lines and allow you to change the line characteristics.
- **Cell Dimension**: Will allow you to change the row height to Auto, At Least, and Exactly. Auto will expand the height of the row automatically as text is entered, At Least will establish the height of the row in a cell until the text expands it. Exactly will limit the amount of text a cell can display in a given row. You can also select the indenture from the left for each row, change the width of a column, and change the space between columns. All measurements are in centimeters, which correspond to the ruler bar.
- **Insert Table Row**: Adds a row above the row containing the cursor.
- **Append Table Row**: Adds a row to the bottom of the table.
- **Delete Table Row**: Deletes the row containing the cursor.
- **Insert Table Column**: Adds a column to the left of the column containing the cursor.
- **Append Table Column**: Adds a column to the far right of the table.
- **Delete Table Column**: Deletes the column containing the cursor.
2.3 STATUS LEVELS FOR AIM II PRODUCTS

The status levels for AIM II related products, which will appear on the window, are:

- **Incomplete (I)**: The minimum information required by the software to develop a product has not been supplied or TPP has never been locked.
- **Complete (C)**: The minimum information required by the software to develop a product has been supplied.
- **Locked (L)**: The product is complete but not yet approved. In the case of the TPP, the first time the TPP is locked, that information will be copied to the TCCD, which will be the foundation for follow on products.
- **Approved (A)**: This product is ready to be promulgated. No further actions/modifications will be permitted to this product in the development mode (only the Test module contains an Unapprove option). To modify this product, requires the creation of a Change or Revision (as appropriate).

**WARNING:** Approval is a final act for all training material item except test item and tests. Once a product is approved in AIM II it CANNOT be 'unapproved'. Do not approve a curriculum product until directed from the Curricula Control Authority (CCA).

The Training Project Plan (TPP) must be locked once in order to work in the TCCD module. The Training Course Control Document (TCCD) must be locked in order to work on the LP and TG.

2.4 AIM II HELP Menu Item

AIM II includes complete documentation in an accessible help system that includes searchable on-line help files, .pdf-based documents, and media-enhanced demonstrations of certain AIM functions.

2.4.1 On-line Help

The **On-line Help** item under the **Help** menu provides three different methods for accessing information:

- **Contents** – shows the table of contents for the Help files
- **Index** – shows the information in alphabetical order
- **Search** – allows you search for keywords or phrases
Each of these methods may be accessed by clicking on the appropriate tab in the Help Topics window. (*Figure 2-5*)

**Adding IETM Extract Files to RRL**

To add ARCI or SGML IETM extract files to the Site RRL, perform the following:

1. From the AIM II Main Menu click on the Admin icon.
2. Click on the Options menu item and select the IETM option.
3. From the IETM window, click on the File menu item and the Import sub-menu item.
4. Click on the location of the drive, directory, and file name of the extraction file and click on OK.

AIM will import the extraction files of the IETM into the Site RRL and the fields of the ietm window will be populated with ietm information, including the IETM name and version of the IETM. The AIM User can now select the IETM for a TPP or TTCd. The IETM must be selected in the Course RRL to be cited in a DP/RUA or Instruction Sheet.

**See Also:**

Adding a Later IETM Version

*Figure 2-5. On-line Help, Help Topics Window*

At the top of the Help window the following buttons are available to help you navigate through the Help information.

- **Hide/Show** – Closes and opens the table of contents.
- **Back** - Brings you back to the previous Help Topic menu
- **Print** - Prints the content window
- **Options** – Repeats the above options
2.4.1.1 Contents

The Contents tab of the On-line Help lists all the available information in a table of contents format. Main topics are indicated with a purple book. These main topics may be expanded by double-clicking on them.

The information under each main topic may be accessed by clicking on it.

Hot words are designated by blue, underlined text. These hot words indicate that a word or phrase may be clicked on to view the glossary definition. Related topics are indicated in the “See Also” panel.

2.4.1.2 Index

The Index tab of the On-line Help lists all the available information alphabetically. To access information quicker, you may type in the first few letters of the word or phrase in the field provided. Clicking on the Display button when the text is highlighted will open the related information (Figure 2-6).
Error Messages/Actions

There are two types of errors that can occur while executing the AIM II program: user errors or software runtime errors. If the user attempts to perform an operation for which he/she does not have privileges to perform, the AIM II program will generate a message stating the user does not have the privilege to perform the operation and provide the appropriate instructions to continue program usage. Similarly, if the user attempts to perform any operation that is not technically feasible or in accordance with AIM II task based curriculum development, the AIM II program will provide the user with a message containing the nature of the error and directions regarding operation continuation.

If a software runtime error occurs, the AIM II program will:

1. Generate a message telling the user that a runtime error has occurred.
2. Prompt the user to write down the message and notify his or her System Support Office (SSO).
3. Provide the user with instructions regarding how to proceed.

Depending upon the nature of the error, the program will either stop or the user will be permitted to continue.

See Also:

- Contacting the AIM SSO
- AIM Trouble Report

Figure 2-6. On-line Help Index Tab

2.4.1.3 Search

The Search tab of the On-line Help allows you to search the entire contents of the Help files for a particular word or phrase by typing it in or clicking a topic. When the information is found and highlighted, clicking the Display button will access the information (Figure 2-7).
2.4.2 User’s Manual

The User’s Manual item under the Help menu is a navigable AIM II Release 5.0 User’s Manual in Adobe Acrobat .pdf file format. This User’s Manual has a linked table of contents available for finding information quickly.

The User’s Manual may also be printed from this location.
2.4.3 Changes in Release 5.0

The Changes in Release 5.0 item under the Help menu is a navigable document in Adobe Acrobat .pdf file format that provides quick reference to the major changes in this Version of AIM II.

2.4.4 Frequently Asked Questions

The Frequently Asked Questions item under the Help menu is a navigable document in Adobe Acrobat .pdf file format, which provides answers to Frequently Asked Questions on AIM II.

2.4.5 Documentation

The following documentation are reflected in the Help menu item list to support curricula development. They will display in PDF file format in Adobe Acrobat.

- ISD/SAT Handbook
- Glossary for Training Handbook
- NAVEDTRA 130B
  - Developer’s Guide
  - Sample Products
  - Manager’s Guide

2.4.6 Getting Started Demonstrations

The Getting Started Demonstrations item under the Help menu expands to further topics:

- Creating a New Course or TPP
- Opening an Existing Course
- Course Tree Window Panes
- Working with the Course Tree Structure
- Course Tree Status, Flag, and Note Indications
- Options Menu Functions
- View Menu Function
- Window Menu Functions

When each of these items is clicked, an .avi movie file automatically opens which shows a screen demonstration in AIM II of the corresponding topic. When the demonstration is finished, simply close the window it opened in.
2.5 GENERAL PRINTING INFORMATION

Printing capabilities included in AIM II include the ability to print the entire document, multiple pages, or any single page of each document using the Print Preview option. Additionally, users can preview the document prior to printing.

**Format - Portrait or Landscape**
The AIM II print function will automatically print using the correct printer orientation for each printed product, e.g., TPP is printed in portrait orientation; LP can be printed in either portrait or landscape orientation.

2.6 ACCESSING THE AIM II UTILITIES

To access the Utilities portion of AIM II, select **Utilities** from the AIM II main window. This will result in the display of a drop-down menu that contains all of the AIM II utilities. There are also icons for each utility.

**NOTE:** The AIM Administrator level of privilege is required to perform the functions listed below the first line on the drop-down menu.

Instructions for the operation of each of the utilities are contained in Appendix B.
2.7 DEVELOPING AND MAINTAINING COURSES

From AIM II’s main menu, creating a new course or maintaining an approved course can begin by selecting the Course menu item.

To initiate development of a new course follow the instructions that begin in Chapter 3: The Training Project Plan Module.

A new course is defined as a Rev 0 course that does not exist in the AIM II database. There may be instances that require development of a Revision for a course that does not exist in the AIM II database. This task can be accomplished by selecting a new TPP and entering the revision letter for the course in the Rev field and the type of TPP will change from New to Revision. The software enables the same functionality for Revisions and new development, with the exception of flagging criteria. Since this Revision will be a new course to the AIM II database, flagging criteria does not apply to the new training material being entered.

**NOTE:** The Rev and Chg field entries must be accomplished before the TPP cover page information is initially saved. Once the cover page information is saved to the database these fields cannot be edited.

To initiate development of a Change or Revision of an approved course in AIM II, begin by:

Step 1 Highlighting an approved Course from the list shown in the Course Select window.

Step 2 Select the Options menu item and the Maintain option. Selecting the Maintain option provides the options of either creating a Revision or a Change.

**NOTE:** If you select a Course that has not been approved, you will not be able to perform maintenance on it; the Maintain option is disabled

When **Change** is selected, AIM II will:

- Place a copy of the approved Course in the AIM II database
- Repeat the Course title in the list of Courses that appears in the Course Select window
- Assign the copy of the Course a Change number
- Enter a "C" for Complete in the Status column adjacent to the new Change's title in the Course Select window.
When AIM II creates a Change, the Training Course Control Document (TCCD) is initially unlocked to provide access to the Resource Requirements List, the Course Data, Learning Objectives, Curriculum Outline of Instruction (COI), and the Course Master Schedule for editing.

If the Change was created to edit only the Lesson Plan (LP) and/or the Trainee Guide (TG), the TCCD must first be locked.

For additional instructions, see Chapter 9: The Training Course Control Document (TCCD) Module.

When selecting Revision from the Maintain options, the software will prompt "Copy LP/TG information with Course?"

A Yes response will:
- Place a copy of the approved TPP, TCCD, Course/LP/TG in the AIM II database.
- Repeat the Course title in the list of Courses that appears in the Course Select window.
- Assign the copy of the Course the next sequential Revision letter.
- Enter a "C" for Complete in the Status column adjacent to the new Revision title in the Course Select window.

A No response will:
- Place a copy of the approved TPP, TCCD, and Course (less the user developed Discussion Points and Related instructor Activities) in the AIM II database.
- Repeat the Course title in the list of Courses that appears in the Course Select window.
- Assign the copy of the Course a Revision letter.
- Enter a "C" for Complete in the Status column adjacent to the new Revision title in the Course Select window.

**NOTE:** The TG Instruction Sheets developed for the latest approved version of the course are available for selection when developing the Related Instructor Activities for the new LP.

- Repeat the Course title in the list of Courses that appears in the Course Select window.
- Assign the copy of the Course a Revision letter.
- Enter a "C" for Complete in the Status column adjacent to the new Revision title in the Course Select window.

For information about TPP, see Chapter 3: TPP Module.
2.8 PRINTER ADMINISTRATION

The initial printer is dependent on the printer selected as default in Windows. AIM II can be configured to print out on almost any printer. The initial installation will, most likely, be set up for Hewlett Packard Laser Jet. To install additional printers, update printer drivers, or modify the existing printer configuration by adding the desired printer through the Windows Control Panel.

NOTE: A Default Printer with printer drivers must be established in Windows to perform Print Preview.

2.8.1 Printing Modules except TG to a file

Generating PDF output of a course Lesson Plan can be accomplished by following these steps:

1. Right click on the desired folder in the tree structure.
2. Select Print Preview from the drop-down menu.
3. In the Printer Setup pop-up box select the desired options and click the Ok button.
4. From the Print Preview Menu bar select Options.
5. From the Options menu select Save to PDF.
6. In the Browse box select the location and file name.
7. Exit the Print Preview screen.

2.8.2 Printing the TG to a file

To generate PDF output of the TG a software application capable of producing PDF files must be installed on the computer. For NMCI computers Snagit is the suggested application, a full version of Adobe Acrobat will also work. For non-NMCI computers see the next section. Generating PDF output of a course Trainee Guide can be accomplished by following these steps:

1. Right click on the TG folder in the tree structure.
2. Select Print Preview from the drop-down menu.
3. In the Printer Setup pop-up box select the desired options and click the Ok button.
4. From the Print Preview Menu bar select the Print option.
5. From the Print pop-up box select the application that will generate the PDF file from the Name drop-down menu. If the application is not listed it must be installed. Click the Ok button.
6. Close the Print Preview Screen.
7. When printing is complete open the application to review the PDF file.
2.8.3 Printing the TG to a file (non-NMCI)

For non-NMCI users or users without a PDF generating software application there is a free PDF print drivers available:

doPDF (http://www.dopdf.com) is a free download. Once installed follow the steps above for Printing the TG to a file, select doPDF as the printer.

2.9 MAXIMUM VALUES FOR TEXT FIELDS

The database of AIM II is only limited in size by the amount of hard disk space available for use with the database. However, there are program-coding limitations imposed on the database for long fields (60,000 characters) and certain text fields (960 characters).

30,000 Character limitation for:
- TPP, Justification
- CTTL, Duty/Task text
- LO, TO/EO text
- COI, Unit/Topic text

3,000 Character limitation for:
- Safety/Hazard Awareness Notice
- Course Mission
- Foreword
- Course Overview
- DPs
- Security Awareness Notice

960 Character limitation for:
- RIA text
- Instruction Sheet Introduction field
CHAPTER 3

TRAINING PROJECT PLAN (TPP) MODULE

3.0 TRAINING PROJECT PLAN (TPP) ................................................................. 3-1
3.1 ELEMENTS OF A TPP ............................................................................. 3-1
3.2 USING THE AIM II TPP MODULE ....................................................... 3-2
   3.2.1 Overview of the AIM II TPP Module ............................................ 3-2
3.3 CREATING A NEW, REVISION, CANCELLATION, OR DEACTIVATION TPP ................................................................. 3-4
   3.3.1 Development of a New TPP ....................................................... 3-4
   3.3.2 Development of a Revision TPP ................................................. 3-8
   3.3.3 Development of a Cancellation or Deactivation TPP .................. 3-11
   3.3.4 Developing a Modification TPP ................................................... 3-13
3.4 SELECTING A TPP .................................................................................. 3-14
3.5 TPP CONTENTS ...................................................................................... 3-15
   3.5.1 Distribution Statement ................................................................. 3-15
   3.5.2 Compensation ............................................................................... 3-19
   3.5.3 Prerequisite ................................................................................... 3-22
   3.5.4 Occupational Classification ......................................................... 3-22
   3.5.5 Course Overview/Comments ....................................................... 3-22
   3.5.6 Development Method .................................................................. 3-23
   3.5.7 Justification .................................................................................. 3-24
   3.5.8 Milestones .................................................................................... 3-26
   3.5.9 Safety Risks and Hazardous Materials ......................................... 3-27
   3.5.10 Summary of Differences ............................................................. 3-28
   3.5.11 Selecting Learning Sites ............................................................... 3-29
      3.5.11.1 Unselecting a Learning Site .................................................. 3-33
      3.5.11.2 Identifying Resources for a Learning Site ......................... 3-34
         3.5.11.2.1 Identifying Resources .................................................. 3-34
         3.5.11.2.2 Manpower ................................................................. 3-36
         3.5.11.2.3 Funding ..................................................................... 3-37
         3.5.11.2.4 Facility ....................................................................... 3-38
         3.5.11.2.5 Select RRL Items ....................................................... 3-38
         3.5.11.2.6 Unselect RRL Items ................................................... 3-40
         3.5.11.2.7 Explain Flag ............................................................... 3-41
         3.5.11.2.8 Remove Flag .............................................................. 3-41
   3.6 TPP OPTIONS ........................................................................................ 3-42
   3.6.1 Lock/Unlock .................................................................................. 3-42
   3.6.2 Grant Privilege ............................................................................... 3-43
   3.6.3 Print Preview .................................................................................. 3-43
   3.6.4 Print ................................................................................................ 3-44
   3.6.4 Central Site Options ...................................................................... 3-44
3.7 ON-LINE HELP ...................................................................................... 3-45
3.0 TRAINING PROJECT PLAN (TPP)

A curriculum development project is a complex undertaking, bringing together a wide range of human and material resources to create quality training. The task based curriculum development process, in accordance with NAVEDTRA 130B, consists of six phases, beginning with the Plan Phase. This phase consists of gathering information and building the plan for training material development, revision, or cancellation. The output product of this phase is the Training Project Plan (TPP). When approved, the TPP becomes the authorization to undertake a course revision or cancellation, or a new course development project, and initiate resource requisitions. For development of a TCCD to support a CNATT curriculum refer to Appendix F.

Course development and, often, course revisions require the identification of resources to develop or implement the proposed course. Resources fall into four broad categories: (1) facilities, (2) funding, (3) personnel, and (4) equipment. All four categories require long lead-time planning. An approved TPP is the authority to submit requests for resources.

In the case of a course cancellation, the approved TPP provides justification for the action and identification of resources for reallocation.

3.1 ELEMENTS OF A TPP

Specific elements of data and information shall include the following items where applicable:

- Cover Page
- Table of Contents
- Course Data for each Learning Site
- Prerequisite
- Occupational Classification
- Course Overview/Comments
- Justification/Summary of Differences (for a Revision TPP)
- Safety Risks and Hazardous Materials exposure
- Curriculum Development Method
- Resources Requirements for each Learning Site
- Compensation Manpower and Funding
- Milestones

NOTE: When the TPP is locked, work can begin on the next step in the project, the Analyze Phase.
3.2 USING THE AIM II TPP MODULE

The AIM II TPP Module provides all of the tools to develop New, Revision, and Cancellation TPPs. The program will present a series of windows starting with the AIM II window. These windows have a menu across the top and a tool bar below the menu. The tool bar contains icons that represent different program features.

You can select options from the menu in two ways; by pressing the ALT key and the underlined letter, or by clicking on the option with the left mouse button. With either method, selecting an option from the menu or the button bar brings up windows that allow you to enter the data necessary to complete a TPP.

If you are working on a new TPP, the fields presented in the window will be blank. You must provide the appropriate information by either typing the information in the correct field or selecting from a series of drop-down menus. If you are working on a TPP that is in progress or completed, you can edit existing data and/or provide new data as necessary. Each window is explained in this user's manual with instructions on how to fill in the necessary data.

3.2.1 Overview of the AIM II TPP Module

Each of the following steps is explained in further detail in this guide. These paragraphs are meant as a quick reference for getting around the software.

You can start a new TPP by selecting the Course menu item and the New sub-menu item on the AIM II main menu bar, or clicking on the "New" icon from the tool bar. If you are working on an existing TPP, choose the Course menu item and the Select sub-menu item from the main menu bar or click on the "Select Course" icon. A list of available courses will appear. Select the course to work on from the list by either highlighting the desired course and then clicking on the Select menu item, or by double clicking on the desired course.

From the Course Select window you can select the Options menu item and the Copy option to copy an existing TPP or Course. Copying a TPP or Course will open the Course Information window, where you can enter the CIN, Revision, Change, and Title of the Course that will be developed, revised, or cancelled, provided the CIN does not exist in the AIM II database.

Copying a TPP produces an Incomplete TPP with all the data of the TPP copied, no associated CTTL or TCCD, and allows the user to develop a New (Rev 0 Chg 0), Revision or Cancellation TPP. Copying a Course produces a complete TPP with a copy of all the training materials contained in the Course that was copied. This option allows you to create a New or Cancellation TPP for the CIN entered in the Course Information window.
The Course Select window provides the option to maintain an approved curriculum. Highlighting the desired course and selecting the **Options** menu item and the **Maintain/Revision** option allows you to create a Revision TPP and Course for the highlighted course.

Selecting the **New** sub-menu item opens the TPP window and allows you to create a New, Revision or Cancellation TPP. If you select a course from the Course Select window, AIM II will return you to the main menu and the TPP through TG icons will be enabled for the selected course. A new course will have blank fields in the TPP window, while an existing course will have data in the fields. If you enter a Revision letter in the Rev field of the new TPP the TPP type will change from New to Revision. To develop a Cancellation TPP for a course not contained in the AIM II database click on the menu arrow of the Type field and select Cancellation. After completing or modifying the data in the window, you must select the **Edit** menu item and the **Save** sub-menu item to save the changes. If you do not wish to save your changes, you can select **Cancel**. You must either save or cancel before proceeding further. Once the cover page is saved the Rev and Chg fields cannot be edited.

AIM develops a course tree structure when the TPP cover page is saved to the database. From this browser you can open folders of the various elements of the course. Clicking on a folder and selecting the **Options** menu item and the **GoTo** sub-menu item will open the desired portion of the course. If a folder contains sub-elements, the contents will be displayed on the upper right hand side of the grid. Double clicking on the desired folder in the upper right hand grid will open the desired window. The lower right hand portion of the grid displays Summary data contained in the folder or sub-element item highlighted. A check block is provided for each folder in the course tree. As you complete development of each folder, click on the check block to identify that this item is complete. Private or public notes can be added to the training material items for management of the curriculum by clicking on the desired folder, selecting the **Options** menu item and the **Edit Note** option.

You can also access the different portions of the course selected by clicking on the **Document** menu item and clicking on the desired sub-menu item. This method allows you to access all elements contained within the document. Each document also has an associated icon. For ease of explaining the steps involved in developing the different portions of each training material item this User’s manuals directs you to use the Document sub-menu item or associated icons.

To identify where the proposed course will be taught, you will select the TPP window **Contents** menu item and the **Learning Sites** sub-menu item. You will be provided with a "Learning Site Summary" window. Here you can enter the Course Data Processing (CDP) code, course length in calendar days, class minimum and maximum capacity, class convenings per year, and student throughput per year for each selected site.
NOTE: A CDP code denotes a course and a location for NITRAS processing. This code may not be available at this point in the development process. This entry is optional.

After you have entered the data for the Learning Site Summary window, you can select RRL to access the TPP Resource Requirements List (RRL) for the site highlighted. From here you can select RRL items to be used in the course by the Learning Site. Selecting Resource allows you to select RRL types as well as input manpower, funding, and facility data.

NOTE: The first Learning Site selected will be the Course Curriculum Model Manager (CCMM) and provide the default RRL items available. AIM II will allow you to use the RRL data from the first site selected for subsequent sites. This option will become available when another site is selected.

Returning to the TPP window, you can select Contents to provide the information for compensation, course overview/comments, development method, justification, milestones, safety risks and hazardous materials, summary of differences for a Revision TPP, and Learning Sites.

You can lock your TPP from the Options menu item when all the data required has been added.

NOTE: When the TPP is locked for the first time, shared data will be copied to the TCCD Module.

### 3.3 CREATING A NEW, REVISION, OR CANCELLATION TPP

There are three types of TPPs: New, Revision, and Cancellation. There are different methods to develop each type, depending on whether you desire to use existing data in the database or not.

#### 3.3.1 Development of a New TPP

If you need to develop a new TPP for a course, you will either select the Course menu item and the New sub-menu item, which will open a TPP window with blank fields, or highlight a course which contains a TPP similar to the TPP to be developed in the Course Select window and select the Options menu item and the Copy TPP/Course option.

NOTE: Learning Sites and Agency information must be included in the database prior to the development of the first TPP. This information is provided through the AIM II Utilities menu item and the Learning Site and Agency sub-menu items. For more information refer to Appendix B.
To create a New TPP using the Course menu item and the New sub-menu item:

**Step 1** From the AIM II window, select the **Course** menu item and the **New** sub-menu item, or click on the New Course icon.

You will be presented with the Training Project Plan (TPP) window *(Figure 3-1).*

The cursor will now be in the first field that will be blank. Use the **Tab** key to move from field to field, or position the cursor in the desired field.

**Step 2** Enter the Course Identification Number (CIN). The CIN can be modified for the New course until the TPP has been approved.
NOTE: As a safety precaution, Tabbing between fields does not take you to the Revision or Change fields, you have to click in them explicitly to modify the contents. The ability to modify the Rev and Chg has been provided to permit development of a revision for a course that does not exist in the AIM II database or re-development of a course that exists in a different medium. The Rev and Chg fields cannot be edited after the cover page of the TPP is saved.

Step 3 Select "Prepared By" and "Prepared For" from the drop-down menus. Clicking on the down arrows will scroll the available options. Select the correct item by clicking the left mouse button.

Step 4 Type the complete course title. Do not use abbreviations.

Step 5 Type in the Short Title if applicable. Use of recognized acronyms is permitted.

Step 6 Type in the Training Type if applicable.

Step 7 Type in the Purpose of Course with respect to the following questions:
   a. Who is to be trained?
   b. What job will the person be trained to perform?
   c. What is the degree of qualification, or how well will the person be able to perform the job?
   d. Where will the person utilize the training?
   e. What are the conditions under which the graduate will perform on the job?

You can use the TAB key to advance forward through the fields or use the mouse to position the cursor. To go backwards through the fields, press Shift + Tab.

CAUTION: When the TPP is completed and locked the TPP information is copied to the Training Course Control Document (TCCD). Do not lock the TPP until all data required has been entered.

Step 8 Click on the Edit menu item and the Save sub-menu item.
If you do not want to save the TPP information that you have entered, you can select **Cancel**.

**Step 9** Refer to paragraphs 3.5 and 3.6 to complete the TPP.

**To create a New TPP from an existing TPP:**

**Step 1** From the AIM II window, select the **Course** menu item and the **Select Course** sub-menu item.

**Step 2** From the Course Select window, highlight the Course that will be copied and select the **Options** menu item and the **Copy** option.

**Step 3** To copy the TPP only, select the **TPP** sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN and edit the Title of the new course.
   b. Click on the **Edit** menu item and the **Save** sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the Course Select window.

**Step 4** To copy the entire Course, select the **Course** sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, and Chg of the new course and edit the Title.
   b. Click on the **Edit** menu item and the **Save** sub-menu item.
   c. Click on Yes to confirm you want to copy the Course. AIM II will copy the Course and return you to the Course Select window.

**Step 5** From the Course Select window highlight the new course and click on the **Select** menu item.

**Step 6** From the AIM II menu click on the TPP icon.

**Step 7** Refer to paragraphs 3.5 and 3.6 to complete the TPP.
3.3.2 Development of a Revision TPP

Development of a Revision TPP can be undertaken to develop a revision for a course that exists in the AIM II database or does not exist in the AIM II database. Re-development of a revised course that exists in a different medium will also result in a Revision, whether the developer initially selects the New menu item or utilizes the copy option because entry in the Rev field is required.

To create a Revision TPP for a course contained in the AIM II database using the Course menu item and the Select Course sub-menu item:

Step 1 From the AIM II window; select the Course menu item and the Select Course sub-menu item.

Step 2 From the Course Select window highlight the Course that you want to revise and select the Options menu item and the Maintain/Revision option.

Step 3 At the prompt "Are you sure you want to create a Revision for this Course?" click on the Yes button to proceed or the No button to return to the Course Select window.

Step 4 At the prompt "Copy LP/TG information with Course?" click on the Yes button to copy the entire LP/TG of the current baseline for the revision or click on No to copy the approved course less the user developed Discussion Points (DPs) and Related Instructor Activities (RIAs).

Note: If the LP/TG Information is not copied, the Instruction Sheets, developed for the baseline course, are available for selection for the RIAs when developing the new LP.

Step 5 For the question "Do you want to copy the TCCD data to the modification TPP?" answer Yes to copy TCCD information to the new TPP. Answer No to copy TPP information to the new TPP.

Step 6 After AIM II creates the revision for the course, it will return you to the Course Select window and the revision created will be highlighted. Click on the Select menu item and AIM II will return you to the AIM II menu.

Step 7 Select the Document menu item and the Training Project Plan (TPP) sub-menu item or click the TPP icon to open the TPP window.

Step 8 Refer to paragraphs 3.5 and 3.6 to edit the TPP for the Revision.
To create a Revision TPP for a course not contained in the AIM II database using the Course menu item and the New sub-menu item:

Step 1  From the AIM II window select the Course menu item and the New sub-menu item.

You will be presented with the Training Project Plan (TPP) window and your cursor will be in the first field, which will be blank. Use the Tab key to move from field to field.

Step 2  Type the Course Identification Number (CIN). The CIN can be modified for the course until the TPP has been approved.

**NOTE:** As a safety precaution, Tabbing between fields does not take you to the Revision or Change fields, you have to click in them explicitly to modify the contents. The ability to modify the Rev and Chg has been provided to permit development of a revision for a course that does not exist in the AIM II database or re-development of a course that exists in a different medium. When the cover page of the TPP is saved these fields can no longer be edited.

Step 3  Click on the Rev field and enter the alpha character for the Revision. The TPP type will change from New to Revision when the alpha character is entered into the field.

Step 4  If you are re-developing a revised course that does not exist in the AIM II database and this course has undergone change(s) enter the change number in the Chg field.

Step 5  Select "Prepared By" and "Prepared For" from the drop-down menus. Clicking on the down arrows will scroll the available options. Select the correct item by clicking the left mouse button.

Step 6  Type the complete course title. Do not use abbreviations.

Step 7  Type in the Short Title if applicable. Use of recognized acronyms is permitted.

Step 8  Type in the Training Type if applicable.
Step 9 Type in the Purpose of Course with respect to the following questions:
   a. Who is to be trained?
   b. What job will the person be trained to perform?
   c. What is the degree of qualification, or how well will the person be able to perform the job?
   d. Where will the person utilize the training?
   e. What are the conditions under which the graduate will perform on the job?

   You can use the TAB key to advance forward through the fields or use the mouse to position the cursor. To go backwards through the fields, press Shift + Tab.

   CAUTION: When the TPP is completed and locked the TPP information is copied to the Training Course Control Document (TCCD). Do not lock the TPP until all data required has been entered.

Step 10 Click on the Edit menu item and the Save sub-menu item.

   If you do not want to save the TPP information that you have entered, you can select Cancel.

Step 11 Refer to paragraphs 3.5 and 3.6 to complete the TPP.

To create a Revision TPP for a course not contained in the AIM II database using the Course menu item and the Select Course sub-menu item:

Step 1 From the AIM II window; select the Course menu item and the Select Course sub-menu item.

Step 2 From the Course Select window, highlight the Course that will be copied and select the Options menu item and the Copy option.

Step 3 To copy the TPP only, select the TPP sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, and Chg as appropriate and edit the Title of the new course.
   b. Click on the Edit menu item and the Save sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the course select window.
Step 4  To copy the entire Course, select the Course sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, Chg of the course and edit the Title.
   b. Click on the Edit menu item and the Save sub-menu item.
   c. Click on Yes to confirm you want to copy the Course. AIM II will copy the Course and return you to the course select window.

Step 5  From the Course Select window highlight the new course and click on the Select menu item.

Step 6  From the AIM II menu click on the TPP icon.

   NOTE: The TPP has a Complete Status when Copy/Course is performed and an Incomplete Status when Copy/TPP is performed.

Step 7  Refer to paragraphs 3.5 and 3.6 to complete the TPP.

3.3.3 Development of a Cancellation/Deactivation TPP

The following procedures can be used for either a Cancellation or Deactivation TPP. A Cancellation TPP should be used when a course will no longer be taught anywhere in the Navy, a Deactivation TPP should be used when a course will no longer be taught at selected Learning Sites.

To develop a Cancellation/Deactivation TPP for a course contained in the AIM II database:

Step 1  From the AIM II window; select the Course menu item and the Select Course sub-menu item.

Step 2  From the Course Select window, highlight the Course that the Cancellation TPP will be developed for and select the Options menu item and the Copy option.

Step 3  Select the Training Project Plan sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN and append CAN to the end of the CIN for the development of the Cancellation TPP.
   b. Click on the Edit menu item and the Save sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP
and return you to the course select window.

Step 4 From the Course Select window highlight the Cancellation course and click on the Select menu item.

Step 5 From the AIM II menu click on the TPP icon.

**NOTE:** When the TPP is identified as a Cancellation TPP by the software the Course Select window will contain dashes in the Rev and Chg columns.

Step 6 Refer to paragraphs 3.5 and 3.6 to complete the appropriate portions of the Cancellation TPP.

There are two methods to develop a Cancellation TPP for a course not contained in the AIM II database:

1. The first method is to use paragraph 3.3.1 (Development of a New TPP) using the Course menu item and the New sub-menu item and click on the Training Project Plan (TPP) window Cancellation button.
2. The second method is to use the Course Select window Copy option to copy an existing TPP and edit the fields for the TPP you are developing.

To develop a Cancellation/Deactivation TPP for a course not contained in the AIM II database using the Copy TPP option:

Step 1 From the AIM II window; select the Course menu item and the Select Course sub-menu item.

Step 2 From the Course Select window, highlight the Course that will be copied and select the Options menu item and the Copy option.

Step 3 To copy the TPP, select the TPP sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, and Chg as appropriate and edit the Title of the course for the development of the Cancellation/Deactivation TPP.
   b. Click on the Edit menu item and the Save sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the course select window.

Step 4 From the Course Select window highlight the new course and click on the Select menu item.
Step 5  From the AIM II menu click on the TPP icon.

**NOTE:** When the TPP is identified as a Cancellation TPP by the software the Course Select window will contain dashes in the Rev and Chg columns.

Step 6 Refer to paragraphs 3.5 and 3.6 to complete the appropriate portions of the Cancellation TPP.

3.3.4 Developing a Modification TPP

A Modification TPP can be created for a course to keep a historical record of the course and identify the maintenance actions completed until the next revision is created. A Modification TPP can only be created from an approved TPP and will be identified in the Course Tree Structure and folders of the TPP from which it originated. The Revision and Change fields of a modification TPP will always be Rev 0 Chg 0. The Modification TPP can be approved and unapproved from the Admin Utility. When a Modification TPP is unapproved the latest TCCD data is copied from the TCCD to the TPP.

**To create a Modification TPP:**

Step 1 From the AIM II main menu select the **Course** menu item and the **Select** sub-menu item.

Step 2 From the Course Select window highlight the desired approved course and click on the **Select** menu item. Click on the TPP folder in the Course Tree Structure.

Step 3 From the AIM II main menu select the **Options** menu item and the **Create Modification TPP** option.

Step 4 Confirm that a Modification TPP is to be created by clicking the Yes button.

Step 5 To use TCCD data answer Yes to the question "Do you want to update the TPP with the TCCD data?", answering No will use TPP data.

When Locking a Modification TPP, with an unapproved TCCD the user will be prompted to copy the TPP data to the TCCD, answering yes will copy the data, answering no will not.
3.4 SELECTING A TPP

Once the TPP window fields have been saved to the AIM II database, you can exit the TPP and return to it later for editing or modification.

There are four different ways to access a TPP window after the course has been selected from the Course Select menu:

1. From the AIM II main menu select the Document menu item and the Training Project Plan (TPP) sub-menu item.
2. Click on the TPP icon.
3. From the course tree structure click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TPP element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.
4. From the course tree structure click on the TPP folder, select the Options menu item and the GoTo sub-menu item. Opening the TPP folder can provide Summary or Note data on the right hand portion of the course tree grid if the View menu sub-items (Note or Summary) have been checked. Summary data includes the information contained in the TPP window and Note data contains Personal and/or Private Notes recorded by developers.

If the TPP window cover page is complete and you desire to work on an element within the TPP you can either select the element from the Contents menu item in the TPP window or double-click on the TPP folder in the course tree structure. Double-clicking the TPP folder or clicking on the “+” box next to the TPP will expand the tree information to include the contents of the TPP. Once the tree has been expanded you can click on the element desired and can exercise Options menu sub-items (Edit Note and GoTo) and View menu sub-items (Note and Summary).

If the Status field of the course selected from the Course Select window is Incomplete you can modify all of the data in the window except the Rev, Chg, and Status fields. If the status of the course selected is Locked, you will have to select the TPP window Options menu item and the Unlock option to edit the fields. Once Unlocked, the Status field will change to Complete which signifies the TPP can be edited but the information will not be copied to the TCCD. To save your changes to the TPP window you must select the Edit menu item and the Save sub-menu item. (If you do not save the cover page data after editing, you will not be able to access the Options or Contents menu.)

From this window you can select the Options or Contents menu sub-items.
3.5 TPP CONTENTS

After saving the data in the TPP window fields and selecting a TPP, you can edit or create the TPP Contents.

The elements of the TPP contents are:

- Distribution Statement
- Compensation
- Prerequisite
- Occupational Classification
- Course Overview/Comments
- Development Method
- Justification
- Milestones
- Safety Risks and Hazardous Materials
- Summary of Differences
- Learning Sites

3.5.1 Distribution Statement

The Distribution Statement menu option is to allow the user to input official distribution statements that will be printed on the cover page of the TPP.

![Figure 1: Distribution Statement Screen](image-url)
The first field, *Type*, lists the distribution statements. Selecting a statement displays the text in the field below (this field is NOT editable). Under the *Distribution Statement* field are fields for *Reason*, *Date of Determination*, and *Controlling DoD Office*. Which of these fields display depends on the statement selected; for example, Distribution Statement X does not have a reason.

The *Reason* field is another drop-down that list the pre-defined reasons (see below). If one of the pre-defined reasons does not suffice, *Free Text* can be selected, and the user can enter whatever text they want in the *Reason Text* field (not shown).

The other two fields on the screen are plain text fields and can contain whatever text the user wants to enter (the date field will not be validated as a date, in case the user needs or wants to put in values like *January, 2014* or *2059*).

The following are the default distribution statements with insertion points for the reason, date of determination, and controlling DOD office.

**Distribution Statement A**

Approved for public release; distribution is unlimited.

**Distribution Statement B**

Distribution authorized to U.S. Government Agencies only [reason] [date of determination]. Other requests for this document shall be referred to [controlling DoD office].

**Distribution Statement C**

Distribution authorized to U.S. Government Agencies and their contractors [reason] [date of determination]. Other requests for this document shall be referred to [controlling DoD office].

**Distribution Statement D**

Distribution authorized to the Department of Defense and U.S. DoD contractors only [reason] [date of determination]. Other requests shall be referred to [controlling DoD office].

**Distribution Statement E**

Distribution authorized to DoD Components only [reason] [date of determination]. Other requests shall be referred to [controlling DoD office].
Distribution Statement F

Further dissemination only as directed by [controlling DoD office] [date of determination] or higher DoD authority.

Distribution Statement X

Distribution authorized to U.S. Government Agencies and private individuals or enterprises eligible to obtain export-controlled technical data in accordance with reference (c) [date of determination]. Controlling DoD office is [controlling DoD office].

The following are the default reasons for a distribution statement. Selection of any of these (except Other) will hard-code the reason text into the distribution text. (Table taken from the web site Distribution Statements & Their Corresponding Reasons for Use)

<table>
<thead>
<tr>
<th>&quot;REASON FOR RESTRICTION&quot;</th>
<th>MAY BE USED ON DISTRIBUTION STATEMENT:</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMINISTRATIVE OR OPERATIONAL USE. To protect technical or operational data or information from the automatic dissemination under the International Exchange Program or by other means. This protection covers publications required solely for official use or strictly for administrative operational purposes. This statement may be applied to manuals, pamphlets, technical orders, technical reports, and other publications containing valuable technical or operational data.</td>
<td>B C D E</td>
</tr>
<tr>
<td>CONTRACTOR PERFORMANCE EVALUATION. To protect information in management reviews, records of contractor performance evaluation, or other advisory documents evaluating programs of contractors.</td>
<td>B E</td>
</tr>
<tr>
<td>CRITICAL TECHNOLOGY. To protect information and technical data that advance current technology or describe new technology in an area of significant or potentially significant military application or that relate to a specific military deficiency of a potential adversary. Information of this type may be classified or unclassified. When unclassified, technology is export-controlled and subject to the provisions of DoD Directive 5230.25.</td>
<td>B C D E</td>
</tr>
</tbody>
</table>
**DIRECT MILITARY SUPPORT.** The document contains export-controlled technical data of such military significance that release for purposes other than direct support of DoD-approved activities may jeopardize an important technological or operational military advantage of the United States. Designation of such data is made by competent authority in accordance with DoDD 5230.25.

**FOREIGN GOVERNMENT INFORMATION.** To protect and limit distribution in accordance with the desires of the foreign government that furnished the technical information. Information of this type normally is classified at CONFIDENTIAL level or higher in accordance with DoD 5200.1-R.

**PREMATURE DISSEMINATION.** To protect patentable information on systems or processes in the developmental or concept stage from premature dissemination.

**PROPRIETARY INFORMATION.** To protect information not owned by the U.S. Government and protected by a contractor’s “limited rights” statement, or received with the understanding that it not be routinely transmitted outside the U.S. Government.

**SOFTWARE DOCUMENTATION.** Releasable only in accordance with DoD Instruction 7930.2.

**TEST AND EVALUATION.** To protect results of test and evaluation of commercial products or military hardware when such disclosure may cause unfair advantage or disadvantage to the manufacturer of the product.

**SPECIFIC AUTHORITY.** To protect information not specifically included in the above reasons and discussions, but which requires protection in accordance with valid documented authority such as Executive Orders, classification guidelines, DoD or DoD Component regulatory documents. When filling in the reason, cite “Specific Authority (identification of valid documented authority).”

**ELIGIBLE TO RECEIVE EXPORT-CONTROLLED DATA.** Distribution Statement X shall be used on unclassified documents when distribution statements B, C, D, E, or F do not apply, but the document does contain technical data as explained in DoD Directive 5230.25.

**OTHER:** Free text entry.

If none of these apply, the user will have an option to enter free text.
3.5.2 Compensation

Use this window to provide recommended source of compensation for both manpower and funding. Identify possible course cancellations/reductions, cross utilization of instructors, etc.

To enter TPP Compensation:

Step 1 From the TPP window; select the **Contents** menu item and the **Compensation** sub-menu item. From the drop-down menu you will have two options: **Manpower**, **Funding**, and **Facility**.

To enter the TPP Manpower data:

Step 1 Click on **Manpower** from the TPP Compensation drop-down menu. This will open the TPP Manpower Compensation window.

Step 2 In the **Site Name** field either select the Learning Site from the drop-down list or type in the name of the Learning Site. After each entry press the TAB key to advance to the next field. You can use Shift+Tab to move backwards. The mouse can also be used to select the desired field.

**NOTE:** You will only be allowed to enter each site once. To enter more than one entry in the Number/Type Billets category, position your cursor at the end of the first entry in that field. Hold down the <Ctrl> key and press <Enter>.

Step 3 Enter the Number/Type of Billets e.g., 2/E-6 4245. Use <CTRL> and <ENTER> to add additional Number/Type of Billets entries to the same field.

Step 4 Type in the source of the funding, by positioning the cursor in the Source field and typing in the information.

Step 5 Estimate the manpower shortfall, if any, and enter the shortfall.

**NOTE:** The TAB key will allow you to advance to the next field or line without having to save each entry.

Step 6 Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to
Step 7 Click on the Exit menu item to return to the TPP window.

To enter the TPP Funding Compensation data:

Step 1 From the TPP window select the Contents menu item and the Compensation/Funding sub-menu items. This will open the TPP Funding Compensation window, Figure 3-2.

Step 2 In the Site Name field select the Learning Site from the drop-down list or type in the name of the Learning Site.

Step 3 Enter the Dollar Amount. You can enter whole numbers. The program will automatically format the number to a currency entry including two decimal places.

Step 4 Type in the name of the funding source.
Step 5  Estimate the funding shortfall, if any, and enter the amount. The number entered will be formatted into currency as in Step 3 above.

Step 6  Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries.

Step 7  Select the **Options** menu item and the **Add** option and perform Steps 2 through 7 above for each additional entry required.

Step 8  Click on the **Exit** menu item to return to the TPP window.

To enter the TPP Facility Compensation data:

Step 1  From the TPP window select the **Contents** menu item and the **Compensation/Facility** sub-menu items. This will open the TPP Facility Compensation window.

Step 2  In the **Site Name** field select the Learning Site from the drop-down list or type in the name of the Learning Site.

Step 3  Enter the Dollar Amount. You can enter whole numbers. The program will automatically format the number to a currency entry including two decimal places.

Step 4  Type in the name of the funding source.

Step 5  Estimate the funding shortfall, if any, and enter the amount. The number entered will be formatted into currency as in Step 3 above.

Step 6  Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries.

Step 7  Select the **Options** menu item and the **Add** option and perform Steps 2 through 7 above for each additional entry required.
Step 8  Click on the Exit menu item to return to the TPP window.

To delete a TPP Funding/Facility Compensation entry:

Step 1  From the TPP window select the Contents menu item and the Compensation/Funding or Compensation/Facility sub-menu items. This will open the TPP Funding Compensation window.

Step 2  Use your mouse and highlight the entry that you want to delete.

Step 3  Select the Options menu item and the Delete option. The program will ask you to confirm your choice.

Step 4  Click on Yes.

Step 5  Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries.

Step 6  Click on the Exit menu item to return to the TPP window.

3.5.3 Prerequisite

The prerequisites required of the trainee that are scheduled to attend the course. Prerequisites may be equipment, rate or rating specific, basic skills, or course specific. Prerequisites normally relate to prior training or skills, not ASVAB scores.

3.5.4 Occupational Classification

Applicable rank, rate designator, NEC or NOBC, of the intended input population, and the NEC, NOBC, or MOS earned by course graduates.

3.5.5 Course Overview/Comments

In the course overview/comments of the TPP, list course subjects. Note any changes from any previous project plan. For a new course, this will be a description of the skills and knowledge to be attained. This is not intended to be the equivalent of a curriculum outline or to contain objectives. The overview will help the Training Agency understand what the course will actually contain.
To enter the Course Overview/Comments:

Step 1 From the TPP window; select the Contents menu item and the Course Overview/Comments sub-menu item. AIM II will open the Course Overview/Comments window, which contains the AIM Text Editor menu items.

Step 2 If the Course Overview/Comments exist in an ASCII file, you can select the Options menu item and the Import Text File option to select the file and import the contents of the file into the AIM text editor. If a text file doesn't exist, type in the Course Overview/Comments.

Step 3 Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries.

Step 4 Click on the Exit menu item to return to the TPP window.

3.5.6 Development Method

The Navy uses different systems for developing training programs. The AIM II program is based on the task-based system. This software is programmed to the specifications in NAVEDTRA 130B: Task Based Curriculum Development Manual, and the options presented are tailored to this method.

To select the Course Development Methods:

Step 1 From the TPP window; select the Contents menu item and the Course Development Method sub-menu item. AIM II will open the TPP Development Method window.

Step 2 Use the mouse to double click in the Sel/Unsel column next to the training materials documents that you will use.

An "X" will appear after each document that you select to indicate that it should be included in the TPP. You can use the Tab key to advance through the documents without changing the selection. You can use Shift+Tab to back up.

Step 3 Type in the mode of instruction. This should be a description of how the instruction should best be implemented. Address such issues as the use of lecture, group paced or individualized instruction, laboratory periods, problem solving sessions, and any other instructional methodology, which will be used in the
AIM II will automatically precede the text you enter with: "The primary mode of instruction:..."

Step 4 Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries.

Step 5 Click on the Exit menu item to return to the TPP window.

3.5.7 Justification

There must be a reason (or reasons) to undertake the development of a new course or the revision of an existing course. The justification for initiating the development of a new course or the revision of existing training materials can come from:

- Navy Training Plans (NTPs) (OPNAVINST 1500.8)
- Tasking by higher authority
- Internal course reviews and local command initiatives
- External course reviews
- Surveillance and external feedback
- Training appraisal.

To enter a TPP Justification:

Step 1 Select the Contents menu item and the Justification sub-menu item from the TPP window. AIM II will open the Justification window (refer to Figure 3-3).

After each entry, press the TAB key to advance to the next field.
Step 2 Enter the References.

Step 3 Enter the Reasons for and Anticipated Benefits of the Proposed Project.

Step 4 Enter the impact if not approved.

Step 5 Select the **Edit** menu item and the **Save** sub-menu item to save your entries.

Step 6 Select the **Exit** menu item to return to the TPP window.
3.5.8 Milestones

Milestones are a time-phased narrative commencing with TPP approval. Your milestones should include identification of major developmental products or events relating to the training materials development method selected, and end with implementation. For each event, you will enter a start date and a projected completion date.

The initial list of Milestones is provided for you. You may edit this list by adding, modifying, or deleting the default list. All initial dates supplied will be the computer date the TPP was initiated and any new milestones added would be the computer date of when the milestone was added.

Dates can be added automatically by selecting the calendar icon or manually as day, month, year (dd. mmm, yy) or month/day/year. AIM II will convert entries to day, month, and year.

To enter/add TPP Milestones:

Step 1 From the TPP window; select the Contents menu item and the Milestones submenu item. AIM II will open the TPP Milestones window.

Step 2 The milestones are automatically numbered. Using the mouse, highlight the content field of the first milestone you would like to edit.

Step 3 Edit the description of the milestone.

Step 4 Today's date will be entered as the default start date. You can Tab to the next field or type over/select another start date. To enter a different date using the calendar icon:

NOTE: To delete a Start/Completion dates double-click in the field to get an edit background and either use the Backspace key or highlight the date and delete it with the Delete key.

a. Click on the Date Start field and a calendar icon will appear.
b. Click on the calendar icon and the currently selected calendar will appear.
c. Click on the month down arrow and select the desired month.
d. Click on the year down arrow and select the desired year.
e. Click on the desired day and the date will be entered into the Start Date field.
Step 5 Type in the projected end date in the Date Complete field. To enter a different date using the calendar icon:
  a. Click on the Date Complete field and a calendar icon will appear.
  b. Click on the calendar icon and the currently selected calendar will appear.
  c. Click on the month down arrow and select the desired month.
  d. Click on the year down arrow and select the desired year.
  e. Click on the desired day and the date will be entered into the Date Complete field.

Step 6 You can continue to edit milestones in this manner.

NOTE: Once you have entered milestones and saved them, to add additional milestones you must select Options from the menu and Add from the drop-down menu. The new milestones will be added below the current cursor position.

To delete a milestone:

Step 1 Using the mouse, click anywhere on the milestone that you want to delete.

Step 2 Select the Options menu item and the Delete option. The program will ask you to confirm your choice.

Step 3 Click on Yes. The milestones will automatically be renumbered.

Step 4 You may continue to delete milestones in this manner.

Step 5 Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries.

Step 6 Click on the Exit menu item to return to the TPP window.

3.5.9 Safety Risks and Hazardous Materials

To enter data in the Safety Risks and Hazardous Materials field:

Step 1 From the TPP window; select the Contents menu item and the Safety Risks and Hazardous Materials sub-menu item. AIM II will open the Safety Risks and Hazardous Materials window, which contains the AIM Text Editor, and two check-box options for Safety Risks and two check-box options for Hazardous Materials.
Step 2 Enter in the identified Safety Risks and Hazardous Materials or if there are none, the Editor is unavailable and a statement indicating no Safety Risks or Hazardous Materials will be automatically generated.

**NOTE:** If the information required exists in a text file in a Windows editor, rather than retype all of the information required into the AIM Editor, you can use the Options menu item and the Import Text File option to retrieve the text file for the TPP.

Step 3 Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries.

Step 4 Click on the Exit menu item to return to the TPP window.

### 3.5.10 Summary of Differences

The Summary of Differences sub-menu item is used when you are developing a TPP for a revision to a course. It allows you to summarize the differences between the current baseline of the TCCD, LP, and TG and the planned revision of the course. The Summary of Differences will print with the Justification of the TPP prior to the Impact if not approved portion of the Justification.

**To enter Summary of Differences:**

Step 1 Open the TPP Summary of Differences window by performing one of the following:
   a. With the TPP folder open in the Course Tree Structure; double click on the Summary of Differences folder in the upper right hand panel,
   b. Expand the TPP and open the Summary of Differences folder in the Course Tree Structure and click on the Go button on the toolbar,
   c. After selecting the course, access the TPP window by either selecting the Document menu item and the Training Project Plan (TPP) sub-menu item or click on the TPP icon. Select the Contents menu item and the Summary of Differences sub-menu item.

Step 2 From the Styled Text Editor add the desired text.

Step 3 After entering the text you can choose one of two ways to exit:
First Method:
- Select the **Edit** menu bar item.
- Select **Save** to save your text and/or select **Cancel** to delete your new data entries and return to the AIM I Text Editor window.
- Select the Exit menu bar item. AIM I will return you to the TPP window or the Course Tree Structure.

Second Method:
- Select the **Exit** menu bar item. If the text has been entered/modified, AIM I will prompt, *Edit Text has been modified. Would you like to save new data?*

If there is no new data, selecting this item will return you to the TPP main window or the Course Tree Structure.

### 3.5.11 Selecting Learning Sites

When developing a TPP, you must select all Learning Sites where the proposed course will be taught. You must select and save a Learning Site before you can add items to the resource requirements list.

**NOTE:** The option to print each site’s RRL individually or all sites is provided in the TCCD Module.

To select a Learning Site:

**Step 1**
From the TPP window; select the **Contents** menu item and the **Learning Sites** sub-menu item. AIM II will open the Learning Site Summary window, which contains a list of all the Learning Sites in the database.

**NOTE:** Learning Sites are added to the list through the AIM Utilities. If you do not see the Learning Site that you want to select, it can be added through the AIM Utilities Module. Contact your AIM Administrator to add the desired sites.

**Step 2**
Click on the desired Learning Site.

**Step 3**
Select the **Options** menu item and the **Select** option. An ‘X’ will appear in the Select column for the site selected.

**Step 4**
The cursor will appear in the CDP (Course Data Processing Code) field. Enter the CDP if known. You will be allowed to enter four characters. The software will
check for duplicate entries. A CDP entry is not required.  
**After each entry press the TAB key to advance to the next field.**

**Step 5** Type in the course length in days, which includes weekends. Fields are provided for both the current and planned course lengths and both should be completed. For a new TPP the Current fields should contain zeroes (0).

**Step 6** For Class, Lab, and PA (Practical Application) hours enter the number of hours appropriate for each.

**Step 7** Type in the number of classes per year for each site, both current and planned.

**Step 8** Type in the minimum and maximum class capacity, both current and planned.

**Step 9** Type in the class convenings, both current and planned.

**Step 10** Type in the annual student throughput (up to 5 digits).

**Step 11** Type in the Manpower Totals, both current and planned.

**Step 12** Fill in Site Consideration data with any training unique site information that is not contained elsewhere.

**NOTE:** The average on board is automatically calculated.

You can use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. Once you are satisfied with the Learning Site Summary data, as you have entered it, you must **Save** it.

Entering that information in the Site Considerations field can identify any unique site items.

**Step 13** Select the **Edit** menu item and the **Save** sub-menu item. If this is the first site that has been selected an "X" will appear in the CCMM (Course Curriculum Model Manager) column next to the site that you selected.

If you do not want to save the Learning Site information that was entered, you can select **Cancel**.

AIM II will verify that the student throughput is less than or equal to the Class max. Capacity multiplied by the Class Convenings.
Step 14  Select Exit to return to the TPP window.

NOTE: You must repeat this procedure for each Learning Site that you select. The RRL information from the first site selected can be used as default information for all subsequent sites. Therefore, it is recommended that you complete paragraph 3.5.8.2 “Identifying Resources” for the original site selected before selecting additional sites. You will be asked if you would like to use the CCMM data as the default for each additional site selected.

To select an additional Learning Site:

Step 1  From the TPP window; select the Contents menu item and the Learning Sites sub-menu item. AIM II will open the Learning Site Summary window, which contains a list of all the Learning Sites in the database.

NOTE: Learning Sites are added to the list through the AIM Utilities. If you do not see the Learning Site that you want to select, it can be added through the AIM Utilities Module. Contact your AIM Administrator to add the desired sites.

Step 2  Select the Options menu item and the Show Selected Sites Only if it has a check mark next to it to view all the Learning Sites in the Learning Site Utility. Click on the desired Learning Site.

Step 3  Select the Options menu item and the Select option. The prompt “Would you like to use (CCMM data) as default?” will appear.

Step 4  Select Yes or No as appropriate. If yes was selected you will be asked if you would like to update the database with the default data. If you selected Yes an "X" will appear in the Sel column next to the site that you selected to indicate that it should be included in the TPP, the Course Data and RRL data entered for the CCMM will be reflected in the new site selected.

Step 5  The cursor will appear in the CDP (Course Data Processing Code) field. Enter the CDP if known. You will be allowed to enter four alphanumeric characters. The software will check for duplicate entries. A CDP entry is not required.

After each entry press the TAB key to advance to the next field. If you copied the original site information the Course Data fields and RRL can be edited for the new site.
Step 6 Type in the course length in days, which includes weekends. Fields are provided for both the current and planned course lengths and both should be completed. For a new TPP the Current fields should contain zeroes (0).

Step 7 For Class, Lab, and PA (Practical Application) hours enter the number of hours appropriate for each.

Step 8 Edit/type in the number of classes per year for each site, both current and planned.

Step 9 Edit/type in the minimum and maximum class capacity, both current and planned.

Step 10 Edit/type in the class convenings, both current and planned.

Step 11 Edit/type in the annual student throughput (up to 5 digits).

Step 12 Fill in Site Consideration data with any training unique site information that is not contained elsewhere.

**NOTE:** The average on board is automatically calculated.

You can use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. Once you are satisfied with the Learning Site Summary data, as you have entered it, you must **Save** it.

Entering that information in the Site Considerations field can identify any unique site items.

Step 13 Select the **Edit** menu item and the **Save** sub-menu item.

If you do not want to save the Learning Site information that was entered, you can select **Cancel**.

AIM II will verify the student throughput is less than or equal to the Class max. Capacity multiplied by the Class Convenings.

Step 14 Select **Exit** to return to the TPP window.
3.5.11.1 Unselecting a Learning Site

Step 1 From the TPP window select the Contents menu item and the Learning Sites sub-menu item. AIM II will open the Learning Site Summary window, which contains a list of all the Learning Sites in the database.

Step 2 Click on the Learning Site that you want to deselect. If the Learning Site selected for deletion is the CCMM you will have to select another site as CCMM using the Select as CCMM option first to Unselect it as a site.

Step 3 Select the Options menu item and the Unselect option.

The program will ask you to confirm your choice.

Step 4 Click on Yes.

You will be asked to verify the deletion, Figure 3-4.

![Figure 3-4. Unselecting a Learning Site](image)

Step 5 Click on Yes.
3.5.11.2 Identifying Resources

For each Learning Site that you select, you will provide a best estimate of the known and anticipated resources necessary to implement the training. This part of the TPP is the Resource Requirements List (RRL).

To build a Resource Requirements List:

Step 1 From the TPP window select the Contents menu item and the Learning Sites sub-menu item. The Learning Site Summary window will open which contains a list of Learning Sites in the database.

Step 2 Use your mouse to highlight the Learning Site that you want to work on. The site must have an "X" in the Sel column, which indicates that it has been selected. **NOTE:** If you need to include a new site that is not currently available for selection, you must add it through the AIM Utilities. To select a site, see paragraph 3.5.8.

Step 3 Select the RRL menu item. AIM II will open the TPP RRL window. From here you can select the resources for your Learning Site.

3.5.11.2.1 Identifying Resources for a Learning Site

Although the training resources required to teach a course might be the same from site to site, each Learning Site will at least be different with respect to the resources on hand. For each Learning Site, the AIM II program will contain a master database for the Site RRL. This is an inventory of all of the types of resource requirement items that reside at the site. To convey what resources will be required to teach the course at each site, you would build a separate RRL for each site.

**NOTE:** You must select RRL items in this module or the TCCD module in order for them to be available in the CTTL, Testing, LP and TG Modules. You may print each site's RRL in the TCCD Module.

From the Learning Site Summary window, after you have selected RRL, you can begin to select items for the Learning Site RRL from those available in the Site RRL, Figure 3-5.
To add RRL items to the Learning Site:

Step 1  From the Learning Site Summary window select the RRL menu item.

Step 2  From the TPP RRL window, click on Resources. This will bring up a drop-down menu, which includes all of the types of resources available to include in the TPP.

The first three elements (Manpower, Funding, and Facility) from the Resource drop-down menu require additional input.
3.5.11.2.2 Manpower

For new courses or revisions, you should identify officer, enlisted, civilian, contractor, and support billets required, the number of billets authorized, the number of compensated billets that can be provided, and the difference (if any). For cancellations, identify all billets that will be offered up. Specify differences if there are any. Space is also available to enter Notes.

To enter the Learning Site Manpower data:

Step 1 On the Learning Site Summary window; select the desired site by clicking on that site one time.

Step 2 Select the RRL menu item. AIM II will open the TPP RRL window.

Step 3 Select the Resources menu item. A drop-down menu will appear which contains all the resources of the TPP RRL.

Step 4 Select Manpower on the drop-down menu. AIM II will open the TPP Manpower window. The cursor will default to the Officer Billets Required field.

Step 5 Use your mouse to highlight the field in which you will enter data.

Step 6 For Officer, Enlisted, Civilian, Contractor, and Support personnel, type in the number of billets required, the number of billets authorized, and the number of compensated billets that can be provided. Type in the differences in the delta field.

Step 7 In the bottom pane of the window there is a Note field where you can add comments about the manpower entries.

Step 8 When you have completed entering the data, select the Edit menu item and the Save sub-menu item to update the database with your entries.
Step 9 Select the **Exit** menu item to return to the TPP RRL window.

### 3.5.11.2.3 Funding

For your TPP you should identify the appropriation source (e.g., O&MN or OPN), AG/SAG, and the initial or recurring costs. For development of a Revision to an existing course identify only the additional costs required to implement training.

**To enter the Learning Site Funding data:**

- **Step 1** On the Learning Site Summary window; select the desired site by clicking on that site one time.
- **Step 2** Select the **RRL** menu item, which will open the TPP RRL window.
- **Step 3** Select the **Resources** menu item.
- **Step 4** Select **Funding** on the drop-down menu, which will open the TPP Funding window.

You can use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. You can also use the arrow keys.

- **Step 5** Type in the appropriation (up to 15 characters).
- **Step 6** Type in the AG/SAG (Activity Group/Sub Activity Group) and the expense.

**NOTE:** The appropriation, AG/SAG, and expense are required entries, which you can find in NAVSUP 437 or the MILSTRIP/MILSTRAP Desk Guide.

- **Step 7** Enter the Dollar Amount under the year. You can enter whole numbers. The program will automatically format the number to a currency entry including two decimal places.
- **Step 8** In the bottom pane of the window there is a Note field where you can add comments about the funding entries.
- **Step 9** When you have completed entering the data, select the **Edit** menu item and either
the Save or Cancel sub-menu item to update your entries.

Step 10 Select the Options menu item and the Add option and repeat Steps 5 through 9 to make additional funding entries.

Step 11 Select the Exit menu item to return to the TPP RRL window.

3.5.11.2.4 Facility

Identify requirements for MILCON (Military Construction) or special projects for facilities modification. These requirements are highly situation-specific. See OPNAVINST 11102.1 and NETCINST 11102.2 for detailed facilities documentation requirements.

To enter Learning Site Facility Data:

Step 1 From the Learning Site Summary window; select the RRL menu item. This will open the TPP RRL window.

Step 2 Select the Resources menu item.

Step 3 Select Facility on the drop-down menu. This will open the TPP Facility window for text entry in the AIM II Text editor.

Step 4 Enter the facility information.

Step 5 When you are finished, select the Edit menu item and either the Save or Cancel sub-menu item to update your entry.

Step 6 Click on Exit to return to the TPP RRL window.

3.5.11.2.5 Select RRL Items

The AIM II software lists the types of resources, which can be entered in a Site Resource Requirements List. The following RRL headings can be selected to identify the resources required for the Learning Site:
To add an RRL Item to the Learning Site:

Step 1 From the Learning Site Summary window highlight the desired Learning Site and select the **RRL** menu item. This will open the TPP RRL window.

Step 2 Select the **Resources** menu item.

Step 3 Click on the desired RRL type from the drop-down menu listed. On the lower portion of the window, you will see the items that exist in the Site RRL.

Step 4 Highlight the desired Site RRL item. If the Site RRL Identifier does not provide enough information on the item, select the **Options** menu item and the **View RRL** option. AIM II will retrieve the Site RRL record for your inspection. Select the **Exit** menu item to return to the TPP RRL window.

Step 5 Select the **Options** menu item and the **Select TPP RRL** option or double click on the desired item from those available in the Site RRL Identifier (lower portion of
Step 6 Click in the Qty Req'd field. Enter the quantity required to tech the course. AIM II will check that the quantity required is greater than zero when the entry is saved.

Use the **TAB** key or click with the mouse to advance to the next field.

Step 7 Highlight the field for Qty On Hand and enter the quantity on hand at the Learning Site.

Step 8 When you have completed adding RRL items of this type from the Site RRL to your TPP RRL, select the **Edit** menu item and the **Save** sub-menu item to update your entries. You will be prompted with the question "Would you like to add the RRL item(s) to all Sites?" if there has been more than one site selected in the TPP. Click on **Yes** to add the item to all sites or **No** to add the item to the site selected.

Step 9 Repeat Steps 2 through 8 to enter other RRL types/items for the Learning Site.

Step 10 Select the **Exit** menu item to return to the main TPP RRL window.

### 3.5.11.2.6 Unselect RRL Items

From the TPP RRL Window:

Step 1 Click on the desired TPP RRL item for deletion.

Step 2 Select the **Options** menu item and the **Unselect TPP RRL** option.

Step 3 Confirm the deletion by selecting **Yes** when prompted.

Step 4 After all desired Learning Site RRL deletions have been made and you try to save your editing you will receive a message stating that the TPP RRL has been modified. You must click on **Yes** to save your changes.
3.5.11.2.7 Explain Flag

The TPP RRL window contains a Flag column that will display a flag (X) for a TPP RRL item if the item has a maintenance record entry from the Site RRL. The Options menu item in the Site RRL contains a Flag Related Material option with sub-menu items for selection of TPP or Courses. Maintenance records can inform developers/maintainers of the status of the item, (e.g., superseded, change received, etc.).

To review the maintenance record for a flagged TPP RRL item:

Step 1 Click on the flagged TPP RRL item.

Step 2 Select the Options menu item and the Explain Flag option. AIM II will retrieve the maintenance record.

Step 3 Select the Exit menu item to return to the TPP RRL window.

3.5.11.2.8 Remove Flag

The TPP RRL window contains a Flag column that will display a flag (X) for a TPP RRL item if the item has a maintenance record entry from the Site RRL. The Options menu item in the Site RRL contains a Flag Related Material option with sub-menu items for selection of TPP or Courses. Maintenance records can inform developers/maintainers of the status of the item, (e.g., superseded, change received, etc.). Before a TPP can be approved, all flags must be removed from the TPP RRL. Individuals with Remove Flags privilege, as well as the AIM Administrator, can exercise the Remove Flag option. Removing a flag from an item in the TPP RRL does not remove the maintenance record from the item in the Site RRL.

To remove a flag from a TPP RRL item:

Step 1 Highlight the TPP RRL item that is flagged.

Step 2 Select the Options menu item and the Remove Flag option. If you do not have Remove Flag privilege this option will not be enabled.
3.6 TPP OPTIONS

After selecting a TPP to work on and saving the TPP window required entries, you can access the TPP Options menu item. The elements of the TPP options are:

- Lock
- Unlock
- Grant Privilege
- Print Preview
- Print.

3.6.1 Lock/Unlock

When you have completed the TPP, and you are ready to use the TPP information to develop other training materials, you must "lock" the TPP. "Locking" the TPP, maintains the integrity of the baseline data from which all other related training materials are built.

**The each time the TPP is locked, shared data is copied to the TCCD.** This data will be used as the foundation of the TCCD.

To Lock the TPP:

From the TPP window select the **Options** menu item and the **Lock** option. The TPP is now locked and no changes may be made to it unless you "unlock" the TPP. The first time the TPP is locked the Status field will change from Incomplete to Locked. Subsequently, when the TPP is unlocked the Status field will change from Locked to Complete. This indicates the information contained in the TPP has already been copied to the TCCD and any further editing of the TPP, with the exception of the Cover Page, must also be performed in the TCCD.

To Unlock the TPP:

1. Step 1 From the TPP window; select the **Options** menu item.
2. Step 2 Select the **Unlock** option from the drop down menu. The Status field will change from Locked to Complete.
3.6.2 Grant Privilege

Selection of the Grant Privilege option allows an AIM User who is the developer of the TPP to assign Edit, Lock, and Grant privileges to other AIM Users. The AIM Administrator can grant Edit, Lock, Grant, Approve, Remove Flag, and Clear In Use privileges to AIM Users.

3.6.3 Print Preview

Selection of Print Preview will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- Options - contains the options to Print or Save to PDF. Print opens the Print window, which allows you to print a page, range of pages, the whole document, print to file, and number of copies. Save to PDF saves the document as a PDF file to the desired location.
- Go To - moves to the previous, next, first, last, or desired page.
- Exit - returns to the TPP window.
- Help - provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- Previous - moves to the previous page.
- Next - moves to the next page.
- Find – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- Page _ of Page - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Accesses the page desired by typing in the page number in the first field and depressing Enter.
- Actual Page - displays the actual page number, as shown on the page. Typing the page number in this field and depressing Enter accesses the page number desired.
Double clicking the left mouse zooms in and double clicking the right mouse zooms out. Clicking the arrow to the right of the zoom icon (magnifying glass) presents a sub-menu from which you can select **Whole Page, Page Width, Two Pages, Thumbnail**, and present the page in 25% increments to 100% and also select 150%.

**To print preview the TPP:**

Step 1 From the Training Project Plan (TPP) window select the **Options** menu item and the **Print Preview** option. AIM II will open the Printer Setup window.

Step 2 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3 Click on the **OK** to print preview.

### 3.6.4 Print

Selection of the **Print** option allows the entire document to be printed:

**To print the entire TPP:**

Step 1 Select the **Options** menu item and the **Print** option. AIM II will open the Printer Setup window.

Step 2 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3 Click on the **OK** button. While the software is preparing the TPP for print, you can select Cancel to terminate the print job.

### 3.6.5 Central Site Options

For Central Site implementations there are two additional options, "**Lock for Review**" and "**Unlock for Review**". These two options work as a toggle to allow the Locking/Unlocking of the TPP. When Locked only Curriculum Manager HQs and AIM Administrators can edit the TPP.
3.7  ON-LINE HELP

The help option allows you to go directly to the AIM II On-line Help Window. This help option is a hypertext help tool that allows you to find the information that you desire.
CHAPTER 4

COURSE TRAINING TASK LIST (CTTL) MODULE

4.0 COURSE TRAINING TASK LIST (CTTL) .......................................................... 4-1
4.1 ELEMENTS OF A CTTL ............................................................................... 4-1
4.2 USING THE AIM II CTTL MODULE ........................................................... 4-1
  4.2.1 Overview of the AIM II CTTL Module .................................................. 4-2
4.3 CREATING A CTTL .................................................................................. 4-4
4.4 CTTL OPTIONS ......................................................................................... 4-4
  4.4.1 Add CTTL .......................................................................................... 4-5
  4.4.2 Delete CTTL ....................................................................................... 4-7
  4.4.3 Cut, Copy, and Paste a CTTL .............................................................. 4-8
  4.4.4 Copy and Paste Source ...................................................................... 4-8
  4.4.5 Select Source From RRL ................................................................. 4-9
  4.4.6 Import FEA Data ............................................................................... 4-10
  4.4.7 Course Mission Statement ................................................................. 4-11
  4.4.8 Reset Modification State ................................................................. 4-12
  4.4.9 Build/Rebuild LO ............................................................................. 4-12
  4.4.10 Impacted LOs .................................................................................. 4-13
  4.4.11 Related Materials, Related Materials with Tasks ......................... 4-13
  4.4.12 Re-sequencing CTTL Items .............................................................. 4-13
  4.4.13 Print Preview .................................................................................... 4-13
  4.4.14 Print .................................................................................................. 4-14
  4.4.15 Explain Flag ..................................................................................... 4-15
  4.4.16 Remove Flag .................................................................................... 4-15
4.5 CTTL WINDOW EDIT MENU ITEMS ......................................................... 4-17
4.6 ON-LINE HELP ......................................................................................... 4-18
(This Page Intentionally Left Blank)
4.0 COURSE TRAINING TASK LIST (CTTL)

A Course Training Task List (CTTL) is the output of the Analyze Phase. Once developed, the CTTL is the foundation of the course and will be used to develop the learning objectives and all other course materials.

The CTTL is a list of duties and tasks to be trained in a course. It describes each duty and task that supports the course mission. You develop the CTTL by analyzing the Course Mission Statement and the available technical documentation. The analysis may require input by Subject Matter Experts (SMEs), technical documentation, and job analysis data/courseware. Additional sources of input to the CTTL can be found in NAVEDTRA 130B.

Remember that a job is made up of duties and tasks. A duty is a major part of a job. Tasks are major parts of a duty. Both duties and tasks must be observable.

The CTTL will be used to develop learning objectives and instructional strategies, techniques, and methodologies.

4.1 ELEMENTS OF A CTTL

Although the nature and extent of your curriculum development project will determine the format of the CTTL, the following elements should be included in the CTTL as a minimum:

- Heading Information
- Course Mission Statement
- Number
- Source
- Duty/Task
- Level

4.2 USING THE AIM II CTTL MODULE

The AIM II CTTL Module provides the tools to develop a CTTL. The program will allow you to enter text describing the duties and tasks to be taught in a course of instruction. You will be required to enter/select specific data pertaining to each duty or task to be taught including the Source that identifies the duty or task, the Text of the duty or task, the Type (duty/task), and Level (skill/knowledge). The Flag column is used to identify items that have been modified from the original approved material during creation of a Change or Revision.
You can select options from the menu in two ways. First, you can select an option from the menu bar by pressing the ALT key and typing the underlined letter. Second, you can select an option by highlighting it with a mouse and clicking the left mouse button. With either method, selecting an option from the menu will bring up windows, which will allow you to enter the data necessary to complete a CTTL.

If you are working on a new CTTL, the window presented will contain a number 1 in the No. Column for the first CTTL item (Duty). You must provide the appropriate information by either typing the information in the correct space or selecting from a series of drop-down menus. If you are working on a CTTL that is in progress or completed, you can edit existing data and/or provide new data as necessary. Each window is explained in this User's Manual with instructions on how to fill in the necessary data.

Duties and Tasks can be re-sequenced in the CTTL by using the click and drag method. Duties can only be dropped on duties and tasks can only be dropped on tasks supporting the same duty.

4.2.1 Overview of the AIM II CTTL Module

Each of the following steps is explained in further detail in this manual. These paragraphs are meant as a quick reference for getting around the software.

You can start a new CTTL by selecting the Course menu item and the Select sub-menu item or by clicking on the "Select Course" icon. A list of available courses will appear. Select the course to work on from the list.

NOTE: When the Course menu item is selected, a list of courses previously selected will be displayed as part of the drop-down menu. If the desired course is in the list, click on the course and the software will select it and display the course tree structure and summary information for the last area accessed.

There are four different ways to access a CTTL after the course has been selected:

1. From the AIM II main menu select the Document menu item and the Course Training Task List (CTTL) sub-menu item.
2. Click on the CTTL icon.
3. From the course tree structure click on the CTTL folder, select the Options menu item and the GoTo sub-menu item. The View menu item contains sub-menu items for Note (Public and Private) and Summary data. When these sub-menu items are checked the Note/Summary data will be displayed in the right hand grids of the Course tree structure. Opening the CTTL folder can provide Summary data that identifies the total number of CTTL items in the CTTL, and a table containing all Duties; their Number, Source/s, Text, Level, and number of associated tasks.

4. From the course tree structure, click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the CTTL element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.

From the CTTL window you can select the Options menu item to display the drop-down menu which will give you options to Add CTTL or Delete CTTL, as well as to Copy CTTL, Cut CTTL, and Paste CTTL.

**NOTE:** If you change the CTTL after you have selected the "Build LO" option, you must "Rebuild" the LOs from that point on. This option becomes available on the menu automatically and allows you to rebuild the LOs based on the latest CTTL data. Only new or edited CTTL items and associated LOs will be affected.

You can either copy a source from a CTTL item and paste it to the new item or select Select Source from RRL to go to the CTTL Sources window and select RRL items. Selecting Course Mission Statement allows you to view the Course Mission Statement window. Build LO/Rebuild LO allows the user to construct Learning Objectives from CTTL statements.

The Print Preview and Print options allow you to examine the entire document, which consists of header, CIN, course title, Course Mission Statement, and a list of all CTTL items listed by number which includes the source/s for each item, Duty/Task text, and level (K or S).

The Explain Flag option allows you to view and print maintenance records for CTTL items that are flagged and Remove Flag removes the flag from the CTTL to permit the Change or Revision to be approved.
4.3 CREATING A CTTL

In the process of developing a new course, you will create a new CTTL that contains the duties and tasks unique to the particular course of instruction.

During the development of CTTL statements, you can select the source of the duty or task from information entered in the Training Project Plan (TPP) Resource Requirements List (RRL) that was copied to the TCCD RRL when you locked the TPP. Since the TPP is only a planning document, it will not be necessary to go back and update the TPP if you discover that a source was not initially entered into the TPP. AIM II will allow you to type in the source as well as select it from RRL information entered into the TCCD.

4.4 CTTL OPTIONS

After selecting a Course, you can edit or create the CTTL through the **Options** drop-down menu of the CTTL window. The elements of the CTTL Options are:

- **Add CTTL**
- **Delete CTTL**
- **Copy CTTL**
- **Cut CTTL**
- **Paste CTTL**
- **Copy Source**
- **Paste Source**
- **Select Source from RRL**
- **Import FEA Data**
  - **MindManager**
  - **SPAWAR JTA**
- **Course Mission Statement**
- **Reset Modification State**
- **Build/Rebuild LO**
- **Print Preview**
- **Print**
- **Explain Flag**
- **Remove Flag**
4.4.1 Add CTTL

CTTL information entered here will be used to form Terminal and Enabling Objectives. The AIM II program assumes that you have analyzed the appropriate technical documentation and other sources of job analysis data and that you are ready to create the CTTL.

To enter/add a CTTL statement:

Step 1 The program will automatically provide the sequence number for the first CTTL item. The cursor will default to the block for Source for the first CTTL item, which will be a Duty. Click on the Options menu item and the Select Source from RRL option or double click on the Source field.

Step 2 From the CTTL Sources window select the Options menu item and the Add option.

Step 3 From the Course RRL type window (which defaults to publications and can be changed to any type of resource by selecting the Resources menu item and the type desired) click on the item desired and either; select the Options menu item and the Select as Source option or double click on the item. An "X" will appear in the select column for each item selected.

Step 4 Select the Exit menu item to return to the CTTL Sources window.

Step 5 If you desire to have the sources print in a different sequence than the way they are listed, they can be re-sequenced using the drag and drop method.

Step 6 When the source(s) have been selected and are in the proper sequence; select the Edit menu item and the Save sub-menu item.

Step 7 Select the Exit menu item to return to the CTTL window.

After each entry press the TAB key to advance to the next field. You can use Shift+Tab to move backwards.

Step 8 Type in the text of the Duty. Each statement should support the course mission statement, be short, begin with a performance action verb, end with an object, and be observable. Further requirements for CTTL statements are contained in NAVEDTRA 130B.
Step 9  When you tab to the **Type** field, you will see a down arrow. Use the mouse and click on the down arrow. Select **Duty** or type the first letter of the desired selection ("D").

Step 10 When you Tab to the **Level** field, you will see a down arrow. Use the mouse and click on the down arrow. Select either **Skill** or **Knowledge**, or type the first letter of the desired selection, i.e., "K" or "S".

Step 11 Click on the **Options** menu item and the **Add CTTL** option to add a Task to support the Duty.

**NOTE:** "Tab" or "Return" at the end of a line will allow entry of additional items without selecting the **Options** menu item and the **Add CTTL** option.

Step 12 Type in the name of the source or click on the **Options** menu item and the **Select Source from RRL** option and repeat Steps 2 though 7 above.

Step 13 Type in the text of the Task. Further requirements for CTTL statements are contained in NAVEDTRA 130B.

Step 14 When you tab to the **Type** field, you will see a down arrow. Use the mouse and click on the down arrow. Select **Task** or type the first letter of the desired selection ("T").

Step 15 When you Tab to the **Level** field, you will see a down arrow. Use the mouse and click on the down arrow. Select either **Skill** or **Knowledge**, or type the first letter of the desired selection, i.e., "K" or "S".

Step 16 Repeat Steps 5 through 9 for each additional task required to support the duty. For ease in editing, the options **Cut CTTL**, **Copy CTTL**, **Paste CTTL**, **Copy Source**, and **Paste Source** are provided (refer to paragraphs 4.4.3 and 4.4.4).

Step 17 Click on **Edit** and **Save** or **Cancel** with regard to your entries. If no additional Duties are required proceed to Step 21.

Step 18 To add another Duty, click on the **Options** menu item and the **Add CTTL** option.

**NOTE:** "Tab" or "Return" at the end of a line will allow entry of additional items without selecting the **Options** menu item and the **Add CTTL** option.
Step 19  Click on the **Options** menu item and the **Select Source from RRL** option (refer to paragraph 4.4.5 to select a source from the RRL).

Step 20  Repeat Steps 2 through 17.

Step 21  To return to the AIM II window, click on **Exit**.

**NOTE:** When a new CTTL item is created during Maintenance the item will be flagged and identified as added.

### 4.4.2  Delete CTTL

If a CTTL statement does not support the Course Mission Statement or a duty, it should be deleted from the CTTL. During development, deleting CTTL items will delete corresponding EOs and TOs from the LO and COI Modules. If this results in a Unit or Topic with no more TOs/EOs supporting it, the Unit or Topic is deleted completely. Deleting a CTTL item during maintenance will flag the LOs linked to it to inform you that the LO should be deleted.

**To delete a CTTL statement:**

Step 1  Position the cursor on the desired CTTL statement and select the **Options** menu item and the **Delete** option.

Step 2  The program will ask you to confirm that you want to delete the statement. Click on **No** to cancel and return to the CTTL field or **Yes** to delete the statement.

Step 3  Click on **Edit**.

Step 4  Click on **Save** or **Cancel** to update your changes. To return to the AIM II window, click on **Exit**.

**NOTE:** When a CTTL item is deleted during the creation of a Change or Revision and the LOs are Rebuilt, the LOs in the LO module will be flagged and the Explanation will reveal that the CTTL item that was linked to the LO has been deleted. The maintenance action required would be deleting the LOs no longer supported by a CTTL item.
4.4.3 Copy, Cut, and Paste a CTTL

Many CTTL statements will have information, which is repeated or similar to another CTTL statement. For example, it is very common for many CTTL statements to be derived from the same source. The Cut, Copy and Paste options facilitate entering CTTL statements by allowing you to copy or move statements in your CTTL.

To cut or copy a CTTL statement:

Step 1 Use your mouse to highlight the statement that you want to cut or copy.

Step 2 Select Options from the menu bar.

Step 3 Click on Copy CTTL or Cut CTTL, as required.

**NOTE:** To use a statement over again by modifying the contents, use the Copy function. This will leave the original statement in its current position. To move a statement from one position in the document to another, use the Cut option.

Step 4 Use the mouse to highlight the empty field where you want to copy or move your CTTL statement. Wherever the cursor is, that is where the CTTL item will be pasted.

Step 5 Click on Options.

Step 6 Click on Paste CTTL to put the statement in the selected field. Edit the text.

Step 7 Click on Edit.

Step 8 Click on Save or Cancel to update your changes. To return to the AIM II window, click on Exit.

**NOTE:** When a new CTTL item is created during Maintenance the item will be flagged and identified as added.

4.4.4 Copy and Paste Source

Step 1 Use your mouse to highlight the CTTL item that contains the source information you want to use for the new CTTL item.
Step 2 Select **Options** from the menu bar and click on **Copy Source** option or right click on the mouse and select Copy Source.

**NOTE:** Copying the source will copy all the sources identified in the CTTL Sources window for the CTTL item highlighted as well as the links to the RRL for the course.

Step 3 Use the mouse to highlight the empty field where you want to paste the source/s.

Step 4 Click on the **Options** menu item and click on the **Paste Source** option, or right click on the mouse and select Paste Source, to link the source/s to the desired CTTL item.

Step 5 Click on the **Edit** menu item and the **Save** sub-menu item or **Cancel** to update your changes.

Step 6 Refer to paragraph 4.4.1 to complete your CTTL item.

### 4.4.5 Select Source from RRL

AIM II requires that you select one or more RRL items as the Source for the CTTL item before the CTTL item can be saved to the database. If the TPP has never been locked the resources will come from the TPP.

**To select a source for the CTTL item from the RRL:**

Step 1 Click on the Source field for the CTTL item.

Step 2 Select the CTTL window **Options** menu item and the **Select Source from RRL** option. AIM II will open the CTTL Sources window.

**NOTE:** The CTTL Sources window can also be opened by double clicking the CTTL Source field.

Step 3 Select the CTTL window **Options** menu item and the **Add** option. AIM II will open the Course RRL type window. This is a split window, which displays the contents of the Course RRL (which defaults to Publications), on the top, and the Site RRL on the bottom for the resource type selected.

Step 4 To select an RRL item of a different type, click on the **Resources** menu item and click on the RRL type desired.
Step 5  To select an RRL item from the Course RRL, either double click on the item in the top portion of the window or click once on the item, select the **Options** menu item and the **Select as Source** option. An "X" will appear in the Select column for each item selected.

Step 6  To select an item from the Site RRL for your Course RRL:
   a. Either double click the item desired in the bottom portion of the window or click on the item, select the **Options** menu item and the **Select Course RRL** option.
   b. Enter the Quantity required if greater than one.

   **NOTE:** If the Site RRL item was inadvertently selected, it can be deselected by dragging and dropping it back to the Site RRL or selecting the **Options** menu item and the **Unselect Course RRL** option. If the item is saved to the Course RRL it can be unselected only from the TPP or TCCD.

   c. Select the **Edit** menu item and the **Save** sub-menu item.
   d. Perform Step 5 to select the item as the source for your CTTL item.

   **NOTE:** If the item desired is not contained in either the Course RRL or the Site RRL you can select the **Site RRL** menu item and add the item. After exiting the Site RRL the item will be available for selection in the Course RRL.

Step 7  When all desired sources have been selected select the **Exit** menu item to return to the CTTL Sources window

Step 8  From the CTTL Sources window, the items can be re-sequenced to the order desired by clicking on a source and dragging and dropping it at the desired location. Select the **Edit** menu item and the **Save** sub-menu item.

Step 9  Select the **Exit** menu item to return to the CTTL window. Select the **Edit** menu item and the **Save** sub-menu item to save your source(s) to the database.

### 4.4.6 Import FEA Data

The **Import FEA Data** option gives you the capability to import Front End Analysis data from **MindManager** (Mindjet for visual thinking software) and **SPAWAR JTA** (xls data produced from Job Task Analysis).
To import MindManager export data:

Step 1 Create an export file from MindManager and select the Text Outline option. This will create a Rich Text Format file in Word. Save the file as a Plain Text file for import into the CTTL.

Step 2 Select the CTTL window Options menu item, the Import FEA Data option and select the MindManager submenu item.

Step 3 Identify the file location and select the text file for import.

Step 4 Click on the Edit menu item and the Save sub-menu item to add your FEA data to the CTTL.

To import SPAWAR JTA data:

Step 1 Create an XLS data output from the SPAWAR Job Task Analysis.

Step 2 Select the CTTL window Options menu item, the Import FEA Data option and select the SPAWAR JTA submenu item.

Step 3 Identify the file location and select the text file for import.

Step 4 Click on the Edit menu item and the Save sub-menu item to add your FEA data to the CTTL.

4.4.7 Course Mission Statement

All duties and tasks included in the CTTL must support the Course Mission Statement. You can view the Course Mission Statement at any time from the CTTL Module.

To view the Course Mission Statement:

Step 1 Select the Options menu item and the Course Mission Statement option.

You will see the Course Mission Statement as written in the TCCD.

Step 2 To return to the CTTL window, click on Exit.
4.4.8 Reset Modification State

After CTTL items have been developed the **Build LO** option will be selected to create fields in the LO module for Terminal Objective (TO) development, from the Duty CTTL items, and Enabling Objective (EO) development, from the Task CTTL items. The fields will contain the CTTL behavior text appended with “in accordance with *the source document(s)*”. The statements that AIM creates for the LO fields are not LOs and require editing and addition of applicable Conditions and Standards for the development of TOs and EOs. After the TOs and EOs are developed in the LO module you may find it necessary to return to the CTTL and edit a CTTL item. An asterisk will appear in the Number column of a CTTL item that is edited after the Learning Objective has been built. If you do not want the Learning Objectives linked to the CTTL item to be rebuilt to AIMs original verbage perform the following.

**To reset the modification state of a CTTL item:**

Step 1  Click on the CTTL item edited, that contains an asterisk in the number column and does not require the learning objective to be rebuilt.

Step 2  Select the **Options** menu item and the **Reset Modification State** option.

AIM will clear the asterisk from the Number column for the CTTL item and will not rebuild the LO linked to the item when the **Rebuild LO** option is selected.

Step 3  Select the **Edit** menu item and the **Save** sub-menu item to save the maintenance action.

4.4.9 Build/Rebuild LO

The CTTL statements serve as the basis for learning objectives, which are used in the next AIM II module, Learning Objective (LO). The LOs are in turn used in the Curriculum Outline of Instruction, the next step in the curriculum development process. Once you are satisfied with all of your CTTL statements, select the **Options** menu item and the **Build LO** option.

If you modify the CTTL statements after building the LOs, the option will change to reflect **Rebuild LO**. The AIM program will automatically rebuild the LOs that are linked to CTTL items according to the latest version of the CTTL statements that you save, unless you select the option **Reset Modification State** for edited CTTL items that have an asterisk in the Number column. If two LOs have been joined, the new text from the CTTL will be added to the existing LO text. Only the newly added or modified CTTL statements will be affected by rebuilding LOs.
If a CTTL item is modified and you do not select "Rebuild LOs" you will be prompted to rebuild them when exiting the CTTL Module or accessing the LO module.

4.4.10 Impacted LOs

The Impacted LOs option will display a list of Learning Objectives that will be impacted by the modified CTTL line item when a "Rebuild LO" option is selected.

4.4.11 Related Materials, Related Materials with Tasks

When a Duty or Task is highlighted the Related Materials option is available. Selecting the Related Materials option will display, with an option to print, all of the related materials for the Duty or Task. This includes Learning Objectives, Discussion Points, and Instruction Sheets. If a Duty is highlighted the Related Materials with Tasks is also available. This option will display, with an option for printing, all related materials for the Duty and all associated Tasks.

4.4.12 Re-sequencing CTTL Items

The CTTL items can be sequenced in the order desired by clicking on the item and dragging and dropping it at the location desired. A task can be re-sequenced within any duty but must be dropped on another task. Duties must be dropped on duties for re-sequencing. All associated tasks are moved with the duty.

4.4.13 Print Preview

Selection of Print Preview will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- Options - contains the options to Print or Save to PDF. Print opens the Print window, which will allow you to print a page, range of pages, print to file, and designate the number of copies. Save to PDF saves the document as a PDF file to the desired location.
- Go To - moves to the previous, next, first, last, or desired page.
• **Exit** - returns to the CTTL window.
• **Help** - Provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- **Previous** - moves to the previous page.
- **Next** - moves to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Accesses the page desired by typing in the page number in the first field and depressing **Enter**.
- **Actual Page** - displays the actual page number, as shown on the page. Accesses the page desired by typing in the page number in the field and depressing **Enter**.

The right and left mouse buttons allow you to zoom in and out by double clicking on the page. Double click the left mouse button to zoom in to a single page display and double click the right mouse button to zoom out.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

**To print preview the CTTL:**

Step 1  From the Course Training Task List (CTTL) window select the **Options** menu item and the **Print Preview** option.

Step 2  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3  Click on the **OK** to print preview.

**4.4.12 Print**

Selection of the **Print** option allows the entire document to be printed:

**To print the entire CTTL:**

Step 1  Select the **Options** menu item and the **Print** option.
Step 2 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3 Click on the OK to print.

4.4.14 Explain Flag

The software from the course RRL in either development or maintenance generates flags.

The course is considered to be in Maintenance if it is a non-Rev 0 Change 0 Course and either:
1. A previous version of the Course exists at the current Revision, or
2. The course is in a Change 0 Revision Course, a previous version of this course exists in your database, and the course has an LP.

If these conditions aren't met, the Course isn't considered to be in maintenance, and as such, no flags will be generated for added/deleted/modified items other than RRL items.

The Explain Flag allows you to view and print the maintenance record for the highlighted and flagged CTTL item. The maintenance record states what type of maintenance action was performed to the item (added or modified), the Revision and Change of the item, who performed the maintenance action (by login name), and when the maintenance action was performed.

When in Maintenance the CTTL items added/modified/deleted will flag the associated LOs to inform the user that a maintenance action may be required.

To read the maintenance record for a flagged CTTL item:

Step 1 Click on the flagged item

Step 2 Select the Options menu item and the Explain Flag option. AIM II will open the Maintenance Record window for the item.

Step 3 Click on the Exit menu item to return to the CTTL window.

4.4.15 Remove Flag

The Remove Flag option can only be exercised by a user with Remove Flag privilege or by the AIM Administrator. The flags are used for review purposes and must be removed prior to approval of the course. The Remove Flag option will remove the flag and the maintenance record
for the highlighted CTTL item.

From within each module for training materials AIM II has the **Remove Flag** option that enables the removal of the flag for the highlighted item individually. Flags can also be removed from the entire course by selecting the Course Select window, the **Options** menu item, and the **Remove All Flags** option.

**To remove a flag from a CTTL item:**

1. Click on the flagged item
2. Select the **Options** menu item and the **Remove Flag** option. AIM II will remove the flag and the associated maintenance record.
4.5 CTTL WINDOW EDIT MENU ITEMS

Many tasks will have information, which is repeated or similar to another task. The **Edit** Menu item contains **Cut**, **Copy** and **Paste** sub-menu items that facilitate entering tasks by allowing you to copy or move statements in your task. **Cut** and **Copy** copies the entire text of the field highlighted. If you desire to cut/copy/paste a portion of the text, block the desired words and use Ctrl-X, Ctrl-C, and Ctrl-V respectively.

**To cut or copy an EO:**

1. **Step 1** Use the mouse to highlight the task that you want to cut or copy.

2. **Step 2** Select the **Edit** menu item and the **Cut** or **Copy** sub-menu item from the **Edit** drop-down menu.

   **NOTE:** To use a statement over again by modifying the contents, use the **Copy** function. This will leave the original statement in its current position. To move a statement from one position in the document to another, use the **Cut** option.

3. **Step 3** Use the mouse to highlight the empty field where you want to copy or move your task statement. Select the **Edit** menu item and click on **Paste** sub-menu item to put the statement in the selected field.

   **NOTE:** If the field you are pasting the text into contains text, the text in the buffer will be appended to the previously existing text.

4. **Step 4** Select **Edit**.

5. **Step 5** Click on **Save** or **Cancel** with regard to your changes. To return to the AIM II main window, click on **Exit**.
4.6 ON-LINE HELP

The help option allows you to go directly to the AIM II On-line Help Screen. This help option is a hypertext help tool that should allow you to navigate easily to find the information that you desire.
(This Page Intentionally Left Blank)
(This Page Intentionally Left Blank)
5.0 LEARNING OBJECTIVES (LO) MODULE

By completing a Course Training Task List (CTTL) the content of a new or revised course was established. The CTTL is the foundation for the entire curriculum development effort. During this phase of the curriculum development project, the Design Phase, you will write the Learning Objectives (LOs) for the new/revised course.

The Design Phase is the transition between the job world and the course. All duties and tasks listed on the CTTL will be developed into LOs. LOs tell exactly how the job duties and tasks will be performed in the course. From the CTTL, AIM II creates a Terminal Objective (TO) for each duty and an Enabling Objective (EO) from each of the supporting tasks.

In this module you can modify the AIM II generated TOs and EOs to further clarify the behavior, standard, and condition, add supporting EOs for tasks that may result in multiple objectives, join EOs for tasks that may be combined to produce a single objective, and re-sequence the EOs in the order they will be taught.

After completing the LOs, you will compile these objectives into the Curriculum Outline of Instruction (COI) and arrange the objectives in the order in which they will be taught.

5.1 USING THE AIM II LO MODULE

The AIM II LO Module provides the tools to develop Learning Objectives for the course. The program will present a series of windows. These windows will have a menu bar across the top.

You can select options from the menu in two ways. First, you can select an option from the menu bar by pressing the ALT key and typing the underlined letter. Second, you can select an option by highlighting it with a mouse and clicking the left mouse button. With either method, selecting an option from the menu will bring up windows, which will allow you to enter the data necessary to complete the LOs.

If you are working on a new Course you may have to add additional EOs to support the existing TOs or EOs. You must provide the appropriate information by either typing the information in the correct field or selecting from a series of drop-down menus. If you are working on a course that is in progress or completed, you can edit existing data and/or provide new data as necessary. Each window is explained in this User's Manual with instructions on how to fill in the necessary data.
5.1.1 Overview of the AIM II LO Module

Each of the following steps is explained in further detail in this manual. These paragraphs are meant as a quick reference for getting around the software.

To work on Learning Objectives, choose **Course** and then **Select** from the menu bar, or click on the "Select Course" icon. A list of available courses will appear. Select the course to work on from the list.

Select **Learning Objectives (LO)** at the main window by either clicking on the LO icon or clicking on **Document** and **Learning Objectives (LO)** from the drop-down menu.

You will see a list of the AIM-generated LOs. For each Duty listed in the CTTL, a terminal objective (TO) was created. Under each TO is a list of Enabling Objectives (EOs) that were developed by AIM from the tasks that support the Duty. All objectives may be modified to incorporate the desired behavior, standard, and condition. The Level column indicates whether the CTTL item, that the LO was generated from, is a **Skill** or a **Knowledge** item.

You can select **Options** to display the drop-down menu which will give you options to **Add EO**, **Delete TO/EO**, **Join EO**, **Unjoin EO**, **Return to the CTTL**, access the **Curriculum Outline of Instruction**, and **Hide/Show CTTL**. This menu also provides options to **Print Preview** and **Print** learning objectives.

The **Explain Flag** and **Remove Flag** options are used during maintenance. When a CTTL item is added, modified, or deleted, during the creation of a Change/Revision, it will flag the LOs that were developed from the CTTL item. Also, when an LO is added, modified, or deleted, flags will be generated in the LO module to indicate the item(s) have undergone maintenance. A maintenance record will exist for each flagged item that indicates what maintenance action was performed to generate the flag, who performed the maintenance action, and when it was performed. The Maintenance Record for each flagged item can be printed for your records. All flags must be removed from the CTTL before the course Rev/Chg can be approved. An individual with Remove Flags Privilege for the course, or the AIM Administrator, can exercise the **Remove Flag** option.

You can select **Edit** to **Cut**, **Copy** and **Paste** when editing the EOs. **Cut** and **Copy** act on the entire contents of the text field. If it is desired to Cut or Copy selected (highlighted) text and not the entire field, use CTRL-X for Cut, CTRL-C for Copy and CTRL-V for Paste.

Re-sequencing can be accomplished by the click and drag method. TOs can be dragged and dropped on other TOs and EOs can be dropped on other EOs supporting the same TO.
5.2 SELECTING LOs

In the process of developing a new course, AIM II will build LOs from the duties and tasks in the CTTL and you will add the appropriate conditions and standards. To add additional TOs, you must first add the duty and supporting task(s) to the CTTL and rebuild the LOs. The software will join the CTTL item text with the words “in accordance with” and append all sources from the CTTL source field. If multiple sources are noted for the EO it may be necessary to add additional EOs or create subitems for existing EOs.

There are four different ways to access the LO module after the course has been selected:

1. From the AIM II main menu select the Document menu item and the Learning Objective (LO) sub-menu item.
2. Click on the LO icon.
3. From the course tree structure click on the LO folder, select the Options menu item and the GoTo sub-menu item. The View menu item contains sub-menu items for Note (Public and Private) and Summary data. When these sub-menu items are checked the Note/Summary data will be displayed in the right hand grids of the Course tree structure. Opening the LO folder can provide Summary data that identifies the total number of LO items in the course, and a table containing all Terminal Objectives; their Sequence number, LO Text, Level, and number of supporting EOs.
4. From the course tree structure, click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the LO element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.

5.3 LO WINDOW OPTIONS MENU ITEM

After selecting a Course, you can edit or create the LOs through the Options menu. The LO Options are:

- Add EO
- Delete TO/EO
- Join EO
- Unjoin EO
- Return to CTTL
- Curriculum Outline of Instruction
- Hide/Show CTTL
- Remove ‘in accordance with’ from LOs
5.3.1 Add EO

The Enabling Objectives (EOs) are built upon CTTL task statements that you composed in the CTTL module. When you select the LO Module, you will see two windows on your screen. The upper window contains the CTTL duty and task statements. The lower window contains the AIM II-generated LOs.

There is a one-for-one correspondence between the CTTL duty statements and the terminal objectives. You can only edit the duty and task statements shown in the CTTL portion of the Learning Objectives (LO) window by using the Return to CTTL option.

You may add EOs to support any given TO or EO, but care must be exercised. If you have identified a task that should be in the CTTL to support the duty, return to the CTTL, add the task, and rebuild the LOs to generate the supporting EO.

There are two methods that can be used to add an EO. The first method that can be used is a drag and drop method. The second method utilizes the Option menu item.

To add an EO using the drag and drop method:

Step 1 Click on the CTTL item that will be used to create the EO and keep the left mouse button depressed.

Step 2 Drag and drop it on the EO that precedes the location desired for the new EO.

Step 3 Edit the text of the new EO as desired.

Step 4 Select the Edit menu item and the Save sub-menu item.

To add an EO using the Options menu item:

Step 1 On the top portion of the window; highlight the CTTL task that you would like to use as a basis for adding an EO. You will see two grids in the window: the upper grid contains the CTTL statements and the lower grid contains the LOs. Each CTTL task statement has been presented as an enabling objective with the source(s) of the CTTL statement integrated into the learning objective.
Step 2  The new EO will be added to the list of LOs following the LO that is highlighted. Highlight the desired LO on the bottom portion of the window.

Step 3  You can click on the CTTL item and drag and drop it on the highlighted LO or select the Options menu item and the Add EO option.

Step 4  The program will automatically provide the sequence number and the cursor will be in the lower window. Click on the text field of the EO and edit as desired.

Step 5  To enter sub-items for the EO; depress the Ctrl-Enter keys at the completion of the stem of the EO to open a new line to enter the first subitem. Enter the desired text and repeat this procedure for each additional subitem required.

Step 6  You can continue to add EOs in this manner. For ease in editing, you can use the Edit menu subitems Cut, Copy, and Paste. Repeat this process until you have completed all the EOs that you plan to add during this session.

Step 7  Select the Edit menu item and the Save sub-menu to save the new EO to the database. Selecting the Cancel sub-menu item will allow you to cancel your entries and restore the LOs to their previous condition.

Step 8  Select Exit to return to the AIM II window.

5.3.2  Delete TO/EO

A TO can only be deleted if it no longer supports (linked to) a Duty in the CTTL.

You may delete any EO that you have added. The original enabling objective, derived from the supporting CTTL statement, may not be deleted. During development, deleting an EO will remove the EO from the Topic in the COI and corresponding LP/TG data. If the EO is the last EO in the Topic, the Topic will be deleted.

To delete a TO/EO:

Step 1  Click on the TO/EO that you want to delete.

Step 2  Select the Options menu item and the Delete TO/EO option.

Step 3  The program will ask you to confirm that you want to delete the objective. Click on No to cancel and return to the TO/EO field or Yes to delete the objective.
Step 4  Select the **Edit** menu item and the **Save** sub-menu to save the deletion of the EO to the database. Selecting the **Cancel** sub-menu item cancels entries and restores the TO/EO to it's previous condition.

Step 5  Select the **Exit** menu item to return to the AIM II window.

### 5.3.3 Join EO

This option allows two EOs to be joined to create a single EO. You can only join EOs that belong to the same TO.

**To Join EOs perform the following:**

**Step 1**  Highlight the primary EO (the EO that is at the location where the resultant EO will be created).

**Step 2**  Select the **Options** menu item and the **Join EO** option. The "Select secondary EOs to join with" screen will appear.

**Step 3**  Click on the EOs to be joined into the primary EO. Select the **Options** menu and the **Join** option. AIM will notify you that you are about to join EOs and if you want to continue, Click "Yes" to continue or "No" to cancel the Join.

**Step 4**  Once the EOs are joined it may be necessary to edit the resultant text of the EO. Double click on the LO Text field for the resultant EO and edit as necessary.

**Step 5**  Select the **Edit** menu item.

**Step 6**  Select the **Save** or **Cancel** sub-menu item with regard to your changes.

**Step 7**  To return to the AIM II Main Menu, select the **Exit** menu item. If you did not save your modifications to the database, the software will prompt you with "LO has been modified. Would you like to save new data?" Click on "Yes" to save the new data, "No" to exit without saving the product of the join operation and any editing that might have been accomplished, or "Cancel" to terminate the Exit operation.
5.3.4 Unjoin EO

An Unjoin can only be performed on an EO that is a product of a join operation and represents more than one CTTL item. It will restore the original EOs developed from the CTTL items. If a join had been accomplished on two or more EOs that represent the same CTTL item the Unjoin option cannot be performed (refer to paragraph 5.3.1, Add EO).

To Unjoin an EO:

Step 1 Highlight the EO you want to Unjoin.

Step 2 Select the **Options** menu item and the **Unjoin EO** option. AIM II will prompt you with "You are about to Unjoin this EO. Do you want to continue?" Click on "Yes" to Unjoin the EOs, "No" to select another EO for the Unjoin, or "Cancel" to terminate the Unjoin operation. Once Unjoined, the CTTL column for the EOs will indicate the numbers of all linked CTTL items.

Step 3 Once the EOs are unjoined it may be necessary to edit the resultant text of the EOs. Double click on the LO Text field for each of the resultant EOs and edit as necessary.

Step 4 Select the **Edit** menu item.

Step 5 Select the **Save** or **Cancel** sub-menu item with regard to your changes.

Step 6 To return to the AIM II Main Menu, select the **Exit** menu item. If you did not save your modifications to the database, the software will prompt you with "LO has been modified. Would you like to save new data?" Click on "Yes" to save the new data, "No" to exit without saving the product of the join operation and any editing that might have been accomplished, or "Cancel" to terminate the Exit operation.

5.3.5 Re-sequence LOs

LOs can be re-sequenced using the drag and drop method. EOs can only be re-sequenced under the TO they support and a TO can only be dropped on another TO. When re-sequenced the LO will automatically be re-numbered and the CTTL column will reflect the CTTL item that the LO is linked to.
To re-sequence an LO:

  Step 1  Click on the LO to be re-sequenced and keep the left mouse button depressed.

  Step 2  Drag the LO to the position desired and release the left mouse button.

5.3.6  Return to CTTL

Selecting the Return to CTTL option allows you to add to or modify existing CTTL items. It does not allow you to delete CTTL items. Refer to Chapter 4 to exercise the CTTL options that are enabled.

To return to the CTTL:

  Step 1  Select the Options menu item and the Return to CTTL option. AIM II will open the Course Training Task List (CTTL) window.

  Step 2  To add or modify existing CTTL items refer to Chapter 4.

  Step 3  When CTTL modifications are completed and LOs have been rebuilt, select the Exit menu item. AIM II will close the CTTL and open the Learning Objectives (LO) window.

5.3.7  Curriculum Outline of Instruction

This option allows you to view the COI Module of the AIM II Software for the course that you are editing or creating without exiting from the LO Module. The functionality of the COI module is explained in the next chapter of the User's Manual, COI Module.

To view the COI:

  Step 1  Click on Curriculum Outline of Instruction from the Options drop-down menu.

  Step 2  Click on Exit to return to the Learning Objectives (LO) window.
5.3.8 Hide/Show CTTL

The **Hide/Show CTTL** option is a toggle that allows you to hide the CTTL when working on the LOs and show the CTTL when needed to add additional EOs.

**To hide the CTTL:**

Select the **Options** menu item and the **Hide CTTL** option.

**To display the CTTL above the LOs:**

Select the **Options** menu item and the **Show CTTL** option.

5.3.9 Remove ‘in accordance with’ from LOs

The **Remove ‘in accordance with’ from LOs** option allows the user to delete the phrase that is appended to all CTTL behavior statements that reflects the source document that is referenced to develop the LOs with the appropriate conditions and standards. This option will only remove the phrase ‘in accordance with (including the source document)’ from those EOs where the phrase has not been edited.

**To remove the ‘in accordance with …’ phrase from all TOs/EOs:**

1. **Step 1** Click on **Remove ‘in accordance with’ from LOs** from the **Options** drop-down menu.
2. **Step 2** AIM will generate the prompt: “Are you sure you want to remove the ‘in accordance with…’ phrase from all TOs/EOs that use it?” Click on **Yes** to delete the phrase from all unedited TOs/EOs.
3. **Step 3** AIM will inform you how many TOs/EOs were updated. Click on **OK** to proceed.
4. **Step 4** Select the Edit menu item and the Save sub-menu item to save the editing to the database.
5.3.10 Print Preview

Selection of Print Preview will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- **Options** - contains the options to Print or Save to PDF. Print opens the Print window, which allows you to print a page, range of pages, print to file, print the entire document, and enter the number of copies. Save to PDF saves the document as a PDF file to the desired location.
- **Go To** - moves to the previous, next, first, last, or desired page.
- **Exit** - returns to the Learning Objectives (LO) window.
- **Help** - provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- **Previous** - moves to the previous page.
- **Next** - moves to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Accesses the page desired by typing in the page number in the first field and depressing Enter.
- **Actual Page** - displays the actual page number, as shown on the page. Accesses the page desired by typing in the page number in the field and depressing Enter.

The right and left mouse buttons allow you to zoom in and out by double clicking on the page and allows you to view multiple pages. Double click the left mouse button to zoom in to a single page display and double click the right mouse button to zoom out.

Below the main menu, on the left side, there are arrows and icons to turn pages, view and print your document.
To print preview the LOs:

Step 1  From the Learning Objective (LO) window; select the Options menu item and the Print Preview option.

Step 2  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3  Click on the OK to print preview.

5.3.11  Print

Selection of the Print option allows the entire document to be printed:

To print the entire LO:

Step 1  Select the Options menu item and the Print option.

Step 2  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3  Click on the OK to print.

5.3.12  Explain Flag

The course is considered to be in Maintenance if it is a non-Rev 0 Change 0 Course and either:

1.  A previous version of the Course exists at the current Revision, or
2.  The course is in a Change 0 Revision Course, a previous version of this course exists in your database, and the course has an LP.

If these conditions aren't met, the Course isn't considered to be in maintenance, and as such, no flags will be generated for added/deleted/modified items other than RRL items.

The Explain Flag has two sub-menu selections to allow you to view and print the maintenance record for the highlighted and flagged CTTL item or the flagged LO. The maintenance record states what type of maintenance action was performed to the item (added, modified, and deleted), the Revision and Change of the item, who performed the maintenance action (by login name), and when the maintenance action was performed. When in Maintenance the CTTL items
added/modified/deleted will flag the associated LOs to inform the user and the user can determine what maintenance action are required.

To read the maintenance record for a flagged CTTL item or LO:

Step 1  Click on the flagged item

Step 2  Select the Options menu item and the Explain Flag option.

Step 3  Select either the CTTL or LO sub-menu item as desired. AIM II will open the Maintenance Record window for the item.

Step 4  Click on the Exit menu item to return to the Learning Objectives (LO) window.

5.3.13 Remove Flag

The Remove Flag option can only be exercised by a user with Remove Flag privilege or by the AIM Administrator. The flags are used for review purposes and must be removed prior to approval of the course. The Remove Flag option will remove the flag and the maintenance record for the highlighted LO (to remove the flags from the CTTL items refer to Chapter 4).

From within each module for training materials AIM II has the Remove Flag option that enables the removal of the flag for the highlighted item individually. Flags can also be removed for the entire course by selection of the Remove All Flags option from the Course Select window Options menu item.

To remove a flag from an LO:

Step 1  Click on the flagged item

Step 2  Select the Options menu item and the Remove Flag option. AIM II will remove the flag and the associated maintenance record.

5.4 LO WINDOW EDIT MENU ITEM

Many EOs will have information, which is repeated or similar to another EO. For example, it is very common for many EOs to be derived from the same source. The Edit Menu item contains Cut, Copy and Paste sub-menu items that facilitate entering EOs by allowing you to copy or move statements in your EO.
To cut or copy an EO:

Step 1 Use your mouse to highlight the EO that you want to cut or copy.

Step 2 Select the **Edit** menu item and the **Cut** or **Copy** sub-menu item from the **Edit** drop-down menu.

**NOTE:** To use a statement over again by modifying the contents, use the **Copy** function. This will leave the original statement in its current position. To move a statement from one position in the document to another, use the **Cut** option.

Step 3 Use your mouse to highlight the empty field where you want to copy or move your EO statement. Select the **Edit** menu item and click on **Paste** sub-menu item to put the statement in the selected field.

Step 4 Select **Edit**.

Step 5 Click on **Save** or **Cancel** with regard to your changes. To return to the AIM II main window, click on **Exit**.

### 5.5 ON-LINE HELP

The help option allows you to go directly to the AIM II On-line Help Screen. This help option is a hypertext help tool that should allow you to navigate easily to find the information that you desire.
CHAPTER 6

TESTING MODULE

6.0 TESTING MODULE ........................................................................................................... 6-1
6.1 GETTING STARTED .......................................................................................................... 6-1
   6.1.1 Test/Learning Objectives Window ........................................................................ 6-3
       6.1.1.1 Passing Criteria ................................................................ 6-5
       6.1.1.2 Criticality Index ............................................................... 6-5
       6.1.1.3 Test Question & Answer Option ...................................... 6-6
       6.1.2 Test Support Materials ..................................................................... 6-21
           6.1.2.1 Testing Plan ................................................................... 6-21
           6.1.2.2 Instructions for the Proctor ............................................ 6-23
           6.1.2.3 Instructions for the Trainee ............................................ 6-23
       6.1.3 Test Development ............................................................................ 6-24
6.0 TESTING MODULE

Developing a test using AIM II is a multi-part process beginning with developing the written test items or a Testing Plan. All test items developed will be linked to the objective that they support, the associated reference, and any graphics, if required, and saved to the database with these links intact. After the test items have been built and approved for use, they can be selected into a specific test.

The test items are inherently linked to each specific learning objective in direct support of the Instructional Systems Development (ISD) process. For this reason, learning objectives must be developed prior to the user being able to develop test items.

**NOTE:** Due to the copy-and-paste functionality of the MS-Windows clipboard, test items or test item candidates could be developed in any Windows based word processor at any time and then copied into the AIM II Testing Module as desired. This copy function will be limited to one field at a time.

Completion of the AIM II Testing Module is not required to make the course status complete or prevent the TCCD from being locked.

This version of AIM II does not support performance testing.

6.1 GETTING STARTED

Test developers can access the AIM II Testing Module from within a specific course for which they have privilege in AIM II and develop test materials for that course. An AIM Administrator can grant an individual up to seven privileges for the Testing Module associated with a course through the AIM II Administration Menu.

- View
- Edit
- Lock
- Grant
- Approve/Unapprove
- Remove Flag
- Maintain/Delete Tests

The AIM User that develops a course has the default privileges of View, Edit, Lock, Grant, and Maintain/Delete Test Items and can use the Grant Privilege option to grant other users privilege to View, Edit, Lock, and Grant. The user that has been granted Approve/Unapprove privilege by the AIM II Administrator can approve/unapprove test items and tests.
The Test module is accessed from the AIM II menu, after selecting the applicable course, by selecting the **Document** menu item and the **Testing** sub-menu item, by clicking on the Test icon or opening the Testing folder in the Course Tree Structure, right click of the mouse and selecting GoTo.

When the Test module is selected the Tests window opens for the course selected *(Figure 6-1)*.

![Figure 6-1. Tests Window](image)

After test questions have been created and approved for the EOs you can **Add** tests for your course.

The Tests window contains **Options, Contents, Edit, Exit** and **Help** Menu items.

The **Options** menu item contains the following options:

- **Modify/View** – edit or view the highlighted test in the list
- **Add** – add a new test to the list
- **Delete** – delete the highlighted test from the list
- **Copy** - copy the highlighted test to create a new test
- **Create New Version** – create a new version of the test highlighted
- **View/Resequence Test Items** – view and re-sequence the test item identified on the highlighted test
• **Grant Privilege** – change privilege(s) for individuals to control access to Tests, Test Items, Testing Plan and Instructions for the Proctor and Trainee.
• **Print Preview** – viewing printing, and developing PDF files for the highlighted test.
• **Print** – printing the highlighted test.
• **Explain Flag** – view the explanation for the Maintenance (X) flag or System generated (@) flag which can appear in the Flag column of the Tests window.
• **Remove Flag** – remove the Maintenance/System flag.

The **Contents** menu item contains a sub-menu with the following items:
• **Test Items** – opens the Test/Learning Objectives window for development of test questions, identifying the Criticality Index and assigning a Passing Criteria for EOs.
• **Testing Plan** – opens the Test Plan window from which you can also create a Test Plan Matrix to identify all Tests that will be developed to support the course.
• **Instructions for the Proctor** – opens a boilerplate set of instructions for the Proctor that can be edited.
• **Instructions for the Trainee** - opens a boilerplate set of instructions for the Trainee that can be edited.

### 6.1.1 Test/Learning Objectives Window

Selecting the Tests window **Contents** menu item and the **Test Items** sub-menu item opens the Test/Learning Objectives window that displays a menu bar that contains **Options, Edit, Exit**, and **Help** menu items (Figure 6-2).
The left hand grid can either display the Units and Topics of the Course (Show Unit/Topics) or the Terminal Objectives (Show TOs) of the course depending on which Options menu item is selected. The right hand grid will display the EO numbers associated with the Terminal Objective or Topic file. The number of test items written for an EO is displayed in the Number of Test Items field. The text of the EO, Passing Criteria, Criticality of the EO as well as a flag column are displayed in the remainder of the grid.

The Test/Learning Objectives window Options menu item provides the following options:

a. **Test Items** – Opens the Test Items for EO window that allows you to view the test items written for the EO highlighted and Add (Fill-in-the-blank, Multiple Choice, True/False, and Two Column Matching test questions), Modify, Copy, or Delete the Test Items.

b. **Criticality Index** - Allows you to select the Criticality Index WorkSheet window for the highlighted LO.

c. **View LO** - Allows you to view the entire text of the highlighted EO.
d. **Show Unit/Topics** – When this option is checked the left hand grid of the Test/Learning Objectives window will display the CIN and the Units and Topics within the CIN. When the Topic folder is opened the EOs contained in the Topic will be displayed in the right hand grid.

e. **Show TOs** - When this option is checked the left hand grid of the Test/Learning Objectives window will display the CIN and the Terminal Objectives within the CIN. When a Terminal Objective folder is opened the supporting EOs will be displayed in the right hand grid.

f. **Print Preview** – Allows you to print preview all the test items written that support the highlighted EO.

g. **Print** – allows you to print all the test items written that support the highlighted EO.

h. **Explain Flag** - Allows you to view the Maintenance Record for the EO flagged. The Maintenance flag "X" can indicate that the EO was added, deleted, or modified. The System flag (@) can indicate that the EO/resource/graphic linked to the Test Item was modified and is an alert that the Test Item may require a maintenance action.

i. **Remove Flag** - Allows an individual with Remove Flag privilege or the AIM Administrator to remove the flag and maintenance record from the item prior to approving associated test items.

### 6.1.1.1 Passing Criteria

**Passing Criteria** - The default value for this field is 100%. The field is intended as a reminder to the test developer as to the minimum passing level of responses to questions based on this EO. All safety items should be tested at 100%. The test developer can modify the default value by clicking in the Passing Criteria field, delete the existing data and replace it with the new/updated information.

### 6.1.1.2 Criticality Index

**Criticality Index** - The Criticality Index is a combination of three factors: (1) Criticality, (2) Difficulty, and (3) Course Relation. Each Criticality Index entry will include one number (0-3) from each of the three factors. The higher the number the more critical this learning objective is to the overall objectives of the course. During test development the Enabling Objectives will be displayed in order of Criticality Index from the highest to the lowest.

To enter the Criticality Index double click in the Criticality Index box or select Criticality Index from the **Options** drop-down menu. The Criticality Index WorkSheet window will open for the highlighted EO (*Figure 6-3*).
Select the appropriate value for Criticality, Difficulty, and Course Relation, 0-3. The sum total of the three values will be saved as the Criticality Index for the Enabling Objective.

**NOTE:** All safety related items should automatically be rated as a 9.

### 6.1.1.3 Test Items Option

Selecting the **Test Items** option opens the Test Items for EO window, which contains a list of the current test items for the selected EO (*Figure 6-4*).
The Test Items for EO window contains:

- EO Text field which contains the text of the EO selected
- Type column which identifies the type of questions that have been created for the EO:
  - Fill-in-the-Blank
  - Multiple Choice
  - True False
  - Two Column Matching
  - Performance
- Sequence column that identifies the number of test questions written for each type of question.
- Item Text column which displays the text of the stem of the question.
- Status column - which can contain:
  - I - Incomplete - Not all required information, noted by an asterisk (*) in the field, is included.
  - C - Complete - All required information has been included. Can be Locked.
  - L - Locked.
  - A - Approved – If you have Approve/Unapprove privilege the test item can be approved for use in a test or Unapproved to remove it from a test, which also unapproves the test it was selected in.
Flag Column - A maintenance flag (X) in this column will inform you if any test item, has been modified. A system generated flag (@) will inform you if any material linked to the EO has been modified and no maintenance action has been completed on the test item.

The Test Item for EO window contains the following menu items:

- **Options** menu item contains the following options:
  - **Add** option to develop Fill-in-the blank, Multiple Choice, True/False, Two Column Matching, and Performance type questions.
  - **Modify/View Test Item** option to modify the highlighted test item or view a locked or approved test item.
  - **Copy** option to copy the highlighted question to make another.
  - **Delete Test Item** option to delete the highlighted test item if it is unlocked or incomplete.
  - **Print Preview** option to view the test question written for the EO as it would appear when printed. When the Print Preview option is selected the Printer Setup window will open, which permits you to add 'Page X of Y' for page accountability, Setup Header/Footer for a classified test, and select the Graphic location.
  - **Print** option to print the test item to the default printer. When the Print option is selected the Printer Setup window will open, which permits you to add 'Page X of Y' for page accountability, Setup Header/Footer for a classified test, and select the Graphic location.
  - **Explain Flag** option to retrieve the maintenance explanation for a flagged test item.
  - **Remove Flag** option to allow an individual with Remove Flag privilege to remove a flag from a test item prior to approval of the item.
- **Exit** menu item to return to the Test/Learning Objectives window.
- **Help** menu item to retrieve the Test Module On-Line Help menu.

To develop Fill-in-the-blank questions:

**Step 1** From the Test window; select the **Contents** menu item and the **Test Items** sub-menu item.

**Step 2** From the Test/Learning Objectives window select the **Options** menu item and check either the **Show Unit/Topics** or **Show TOs** option.

**Step 3** Open the Units Topic folder or Terminal Objective desired and in the left grid and click on the EO that you want to develop a Fill-in-the-blank test question for in the right grid.
Step 4  Select the **Options** menu item and the **Test Items** option.

Step 5  From the Test Items for EO window; select the **Add** option.

Step 6  Select the **Fill-in-the blank** sub-menu item. The Test Item for EO window will open (*Figure 6-5)*.

![Figure 6-5. (Fill-in-the blank) Test Item for EO Window](image)

Step 7  Click on the K Level field down arrow and from the drop-down menu select the appropriate level of learning for the question.

- K1 - Recognize (recommended selection for T/F Test Items)
- K2 - Recall
- K3 - Comprehend
- K4 - Analyze
- K5 - Evaluate
Step 8  Click on the Q&A tab. Click on the Stem field and enter the text of the question. Use the underline feature to enter the blank line.

Step 9  Click on the Answer field and enter the text of the answer.

Step 10  Click on the Resource tab. Select the **Options** menu item and the **Select Resource** option.

AIM II will open the Select Site RRL window that contains the Publications that are contained in the Site RRL.

Step 11  Click on the publication that contains the test question information and select the **Select** menu item. AIM II will enter the publication identifier in the Resources tab of the Fill-in-the-blank Test Item for EO window. You may also double click on the desired publication to select it.

Step 12  Enter the publication breakdown information (e.g., Volume, Part, Chapter, etc.) in the publication breakdown fields.

Step 13  If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the **Options** menu item and the **Select Graphic** option. AIM II will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the **Options** menu item and the **Select** option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform with the 6.5 width and 8.5 height maximum values.
   c. Select the **Edit** menu item and the **Save** sub-menu item. AIM II will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 14  The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.
Step 15 A down-arrow will appear in the Status field when the required information has been added to the fields and tabs (fields identified with an asterisk are required) and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 16 Select the **Edit** menu item and the **Save** sub-menu item to save the Fill-in-the-blank question to the database.

Step 17 Select the **Exit** menu item to return to the Test Items for EO window.

Step 18 Repeat Steps 3 through 15 for each additional Fill-in-the-blank question required for the EO selected.

From the Test Items for EO window you can select the **Options** menu item and the **Modify/View** option to edit the test item or select the **Delete** option to delete it until its status is Locked or Approved.

**To develop Multiple Choice questions:**

Step 1 From the Test window; select the **Contents** menu item and the **Test Items** sub-menu item.

Step 2 From the Test/Learning Objectives window select the **Options** menu item and check either the **Show Unit/Topics** or **Show TOs** option.

Step 3 Open the Units Topic folder or Terminal Objective desired and in the left grid and click on the EO that you want to develop a **Multiple Choice** test question for in the right grid.
Step 4  Select the **Options** menu item and the **Test Items** option.

Step 5  From the Test Items for EO window; select the **Add** option and the **Multiple Choice** sub-menu item. The Multiple Choice Test Item for EO will open (Figure 6-6.)

![Figure 6-6. (Multiple Choice) Test Item for EO Window](image)

Step 6  Click on the Q&A tab. In the Stem field add the text of the question.

Step 7  In the Answer/Distractor fields enter the text of the distractors and answer. At least four entries must be made to save the question to the database.

Step 8  Click on the Answer text and select the **Options** menu item and the **Set Answer** option or double click on the Correct Answer column adjacent to the answer. An “X” will appear in the Correct Answer column adjacent to the answer.
Step 9  Click on the Resource tab, select the **Options** menu item and the **Select Resource** option.

AIM II will open the Select Site RRL window (*Figure 6-7*) that contains the Publications that are contained in the course RRL. A publication must be selected as the basis for each test item.

![Select Site RRL Window (showing Options)](image)

*Figure 6-7. Select Site RRL Window (showing Options)*

Step 10  Click on the publication that contains the test question information and select the **Select** menu item. AIM II will enter the publication identifier in the RRL field of the Test Item for EO window. You can also double click on the desired publication to select it.

Step 11  Enter the publication breakdown information (e.g., Volume, Part, Chapter, etc.) in the publication breakdown fields.
Step 12 Click on the K Level field down arrow and from the pop-up menu select the appropriate level of learning for the question.
K1 - Recognize (Only applicable for T/F type Test Items)
K2 - Recall
K3 - Comprehend
K4 - Analyze
K5 - Evaluate

Step 13 If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM II will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform with the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM II will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 14 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 15 A down-arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 16 Select the Edit menu item and the Save sub-menu item to save the multiple-choice question to the database.

Step 17 Select the Exit menu item to return to the Test Items for EO window.

Step 18 Repeat Steps 3 through 14 for each additional multiple-choice question required for the EO selected.
From the Test Items for EO window you can select the **Options** menu item and the **Modify/View Item** option to edit the test item or select the **Delete Test Item** option to delete it until its status changes to **Locked** or **Approved**.

**To develop True/False questions:**

- **Step 1**  From the Test window; select the **Contents** menu item and the **Test Items** sub-menu item.

- **Step 2**  From the Test/Learning Objectives window select the **Options** menu item and check either the **Show Unit/Topics** or **Show TOs** option.

- **Step 3**  Open the Units Topic folder or Terminal Objective desired and in the left grid and click on the EO that you want to develop a Fill-in-the-blank test question for in the right grid.

- **Step 4**  Select the **Options** menu item and the **Test Items** option.

- **Step 5**  From the Test Items for EO window; select the **Add** option.

- **Step 6**  Select the **True/False** sub-menu item. AIM II will open the Test Item for EO window (*Figure 6-8*).
Step 7  Click on the K Level field down arrow and from the pop-up menu select the appropriate level of learning for the question.
K1 - Recognize (recommended selection for T/F Test Items)
K2 - Recall
K3 - Comprehend
K4 - Analyze
K5 – Evaluate

Step 8  Click on the Q&A tab and enter the text of the statement in the Stem field.

Step 9  Identify the correct answer by clicking on the box next to either TRUE or FALSE. An "X" will appear in the box to indicate the correct answer.

Step 10 Click on the Resource tab. Select the Options menu item and the Select Resource option. AIM II will open the Select Site RRL window that contains the Publications that are contained in the Site RRL (Figure 6-9)
Step 11 Click on the publication that contains the test question information and select the **Select** menu item. AIM II will enter the publication identifier in the Resource tab of the Test Item for EO window.

Step 12 Enter the publication breakdown information (e.g., Volume, Part, Chapter, etc.) in the publication breakdown fields.

Step 13 If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the **Options** menu item and the **Select Graphic** option. AIM II will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the **Options** menu item and the **Select** option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform with the 6.5 width and 8.5 height maximum values.
   c. Select the **Edit** menu item and the **Save** sub-menu item. AIM II will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.
Step 14 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 15 A down-arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 16 Select the Edit menu item and the Save sub-menu item to save the True/False question to the database.

Step 17 Select the Exit menu item to return to the Test Items for EO window.

Step 18 Repeat Steps 3 through 15 for each additional True/False question required for the EO selected.

From the Test Items for EO window you can select the Options menu item and the Modify/View option to edit the test item or select the Delete option to delete it until its status is Locked or Approved.

To develop Two Column Matching test questions:

Two column matching test items are actually four to eight individual test items in one question. To develop a two-column matching test item you will enter data in two parallel columns that correspond to each other. The left column (stimulus) will contain four to eight entries. The right column (responses) will contain six to ten entries. The right column MUST have two more entries than the left column. These two additional entries are provided to prevent the trainees from being able to guess at the last few matching items after having ruled the ones that they know.

Step 1 From the Test window; select the Contents menu item and the Test Items sub-menu item.

Step 2 From the Test/Learning Objectives window select the Options menu item and check either the Show Unit/Topics or Show TOs option.
Step 3  Open the Units Topic folder or Terminal Objective desired and in the left grid and click on the EO that you want to develop a Fill-in-the-blank test question for in the right grid.

Step 4  Select the Options menu item and the Test Items option.

Step 5  From the Test Items for EO window; select the Add option.

Step 6  Select the Two Column Matching sub-menu item. The Test Item for EO window will open (Figure 6-10).

Step 7  Click on the K Level field down arrow and from the pop-up menu select the appropriate level of learning for the question.

K1 - Recognize (recommended selection for T/F Test Items)
K2 - Recall
K3 – Comprehend
K4 - Analyze
K5 – Evaluate

Step 8 Click on the Q&A tab. Click on the Stem field and enter the text of the directions for the Column Matching Test Item.

Step 9 Select the **Options** menu item and the **Add Left Entry option**, or click in the desired location to add an entry.

Step 10 Enter the text for the first item of the left column.

Step 11 Repeat Steps 9 and 10 for each item to be added to the left column. AIM II will permit up to 8 entries. After four entries in either column you will need to manually add entries using the Options drop-down menu.

Step 12 Select the **Options** menu item and the **Add Right Entry** option, or click in the desired location to add an entry.

Step 13 Enter the text for the first item in the right column.

Step 14 Repeat Steps 12 and 13 for each item to be added to the right column. AIM II will permit up to 10 entries for the right column. The right column must have two more entries than the left column.

**NOTE:** Entries made in the Right and Left columns can be re-sequenced by clicking on the text and using “drag and drop” to place the item where desired.

Step 15 Click on the Answer column for the first item in the left column and select the letter of the matching item in the right column. You can use an answer once, more than once or not at all.

Step 16 Repeat Step 13 for each item in the left column.

Step 17 Click on the Resource tab. Select the **Options** menu item and the **Select Resource** option. AIM II will open the Select Site RRL window that contains the Publications that are contained in the Site RRL.

Step 18 Click on the publication that contains the test question information and select the **Select** menu item. AIM II will enter the publication identifier in the Resource tab of the Two Column Matching Test Item for EO window.
Step 19 Enter the publication breakdown information (e.g., Volume, Part, Chapter, etc.) in the publication breakdown fields.

Step 20 If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM II will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform with the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM II will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 21 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 22 A down arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 23 Select the Edit menu item and the Save sub-menu item to save the Two Column Matching question to the database.

Step 24 Select the Exit menu item to return to the Test Items for EO window.

Step 25 Repeat Steps 3 through 22 for each additional Two Column Matching question required for the EO selected.

From the Test Items for EO window you can select the Options menu item and the Modify/View option to edit the test item or select the Delete option to delete it until its status is Locked or Approved.
To develop Performance questions:

Step 1  From the Test window; select the **Contents** menu item and the **Test Items** sub-menu item.

Step 2  From the Test/Learning Objectives window select the **Options** menu item and check either the **Show Unit/Topics** or **Show TOs** option.

Step 3  Open the Units Topic folder or Terminal Objective desired and in the left grid and click on the EO that you want to develop a Fill-in-the-blank test question for in the right grid.

Step 4  Select the **Options** menu item and the **Test Items** option.

Step 5  From the Test Items for EO window; select the **Add** option.

Step 6  Select the **Performance** sub-menu item. AIM II will open the Test Item for EO window (*Figure 6-11*).

![Figure 6-11. Performance Test Item for EO Window](image)
Step 7  Click on the K Level field down arrow and from the pop-up menu select the appropriate level of learning for the question.
K1 - Recognize (recommended selection for T/F Test Items)
K2 - Recall
K3 – Comprehend
K4 - Analyze
K5 – Evaluate

Step 8  Click on the Title field and enter the text of the title of the Performance Item.

Step 9  Click on the white space in the lower half of the screen and enter the performance step required.

Step 10  Click on the Resources tab.

Step 11  Select the Options menu item and the Add Resource option. AIM II will open the Select Site RRL window that contains the Publications that are contained in the Site RRL.

Step 12  Click on the publication that contains the test question information and select the Select menu item. AIM II will enter the publication identifier in the Resource tab of the Performance Test Item for EO window.

Step 13  Enter the publication breakdown information (e.g., Volume, Part, Chapter, etc.) in the publication breakdown fields.

Step 14  If there is an associated graphic to be used in conjunction with the test item perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Add Graphic option. AIM II will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform with the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM II will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.
Step 15  The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 16  A down arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 17  Select the Edit menu item and the Save sub-menu item to save the Performance test item to the database.

Step 18  Select the Exit menu item to return to the Test Items for EO window.

Step 19  Repeat Steps 6 through 14 for each additional Performance Test Item required for the EO selected.

From the Test Items for EO window you can select the Options menu item and the Modify/View option to edit the test item or select the Delete option to delete it until its status is Locked or Approved.

6.1.2  Test Support Materials

The test support materials can be developed from the Tests window by selecting the Contents menu item and the sub-menu items; Testing Plan, Instructions for the Proctor and Instructions for the Trainee. The Testing Plan lists all of the evaluation instruments that will be used to determine satisfactory completion of desired learning outcomes and details remediation and retest criteria allowed. Completion of these materials is optional. These materials are not required to complete or lock any materials in AIM II. They also are not required to complete the development of tests using the AIM II Testing Module.

6.1.2.1  Testing Plan

To create a Testing Plan:

Step 1  From the Tests window; select the Contents menu item and the Testing Plan
Step 2  If you are revising a previously approved testing plan enter the appropriate alpha/numeric character in the Version field.

Step 3  Click on the arrow for the Status field and click on the appropriate status. Options include:

1. Incomplete - This status is the default status. When all required fields (fields containing an asterisk) have been filled out the status automatically changes to Complete.
2. Complete – All required fields contain an entry. This status can be changed to Locked or Approved by the Testing Plan developer.
3. Locked - This signifies that the Testing Plan is ready for review by the Testing Administrator. The Testing Plan cannot be edited until the status is changed back to Complete.
4. Approved - This version of this Testing Plan has been Approved. When the Status of the Testing Plan has been changed to Approved, the login name of the Testing Administrator will automatically be inserted into the Approval field. To modify an Approved Testing Plan, the status must be changed back to Complete by the Approval authority.

Step 4  The Date field is editable. It automatically reflects the date when the Testing Plan window was first accessed. When the Status changes, click on the date field and enter the date that corresponds to the change in Status.
Step 5  
Click on the Purpose field and enter the purpose of the Testing Plan.

**NOTE:** The Course Overview field reflects the Course Overview developed in the TPP and is not editable.

Step 6  
Click on the Minimum Passing Grade field and enter the alpha/numeric passing grade (e.g., SAT, 70, etc.). You may also enter individual grade requirements if more than one standard applies across the course.

Step 7  
Click on the Justification and/or Comments field and enter the rationale for establishing a Minimum Passing Grade that deviates from the Naval Education and Training Command (NETC) standard.

Step 8  
Click on the Test Procedures and/or Constraints field and enter text describing any situation that prevents testing of the objectives and explain what actions have been taken to eliminate the constraints. Examples could include local modifications to the CCMM Approved Testing Plan due to substituting Training Unique Equipment (TUE) for Technical Training Equipment (TTE).

Step 9  
Enter the Developer and Reviewer authority names as the Testing Plan completes the associated phase.

Step 10  
Select the **Contents** menu item and the **Test Plan Matrix** sub-menu item. AIM II will open the Test Plan Matrix window.

Step 11  
Select the **Options** menu item and the **Add** option.

Step 12  
For the Test Type field, click on the arrow and select from the drop-down menu.

Step 13  
Enter the minimum grade.

Step 14  
Enter the percent that the test applies toward the student's total grade. This adds to the Total Weight, which can be viewed from the Testing Plan cover page. When all test percentages are added they must equal 100% for the Test Matrix to be complete.

Step 15  
If there are retest criteria click on the Retest field and the arrow and select Yes from the drop-down menu. The Retest field defaults to a No entry.

Step 16  
Click on the Retest Criteria, if applicable, and describe the review, remediation, and retesting procedures.
Step 17 Select the **Edit** menu item and the **Save** sub-menu item.

Step 18 Select the **Exit** menu item to return to the Testing Plan Window.

Step 19 Select the **Exit** menu item to return to the Tests window.

### 6.1.2.2 Instructions for the Proctor

**To create instructions for the proctor:**

**Step 1** From the Tests window; select the **Contents** menu item and the **Instructions for the Proctor** sub-menu item.

**Step 2** If there are no instructions saved to the database, AIM II will inform you and ask if you want to create them. Click on "Yes" to continue. AIM II will open the Test Instructions for the Proctor window, which is an AIM II text editor window containing boilerplate information that can be edited as necessary.

**Step 3** To import a text file; select the **Options** menu item and the **Import Text File** option. This will open the Import Text File window and you can specify the path and location of the file. Click on OK and the text file will be imported into the AIM II text editor.

**Step 4** Enter the required text in accordance with your specifications.

**NOTES:**

1. Sample text files for Instructions for the Proctor and Trainee have been included in the default AIM II directory. They can be selected by selecting the Import Text File option from the Options drop-down menu.
2. Only ASCII Text files can be imported. Word processed or (.wri) files must be converted to ASCII prior to being imported using the Import Text File Option.

**Step 5** Select the **Edit** menu item and the **Save** sub-menu item.

**Step 6** Select the **Exit** menu item to return to the Tests window.
6.1.2.3 Instructions for the Trainee

To create test instructions for the trainee:

Step 1 From the Tests window; select the Contents menu item and the Instructions for the Trainee sub-menu item.

Step 2 If there are no instructions saved to the database, AIM II will inform you and ask if you want to create them. Click on "Yes" to continue. AIM II will open the Test Instructions for the Trainee window, which is an AIM II text editor window containing boilerplate information and can be edited as necessary.

Step 3 To import a text file; select the Options menu item and the Import Text File option. This will open the Import Text File window and you can specify the path and location of the file. Click on OK and the text file will be imported into the AIM II text editor.

Step 4 Enter the required text in accordance with your specifications.

Step 5 Select the Edit menu item and the Save sub-menu item.

Step 6 Select the Exit menu item to return to the Tests window.

6.1.3 Test Development

AIM II gives you the option of manually selecting the test items or letting AIM II randomly generate a test. You will also have the option of developing another test based on the original. This is referred to as Create a New Version.

Create a New Version develops an alternate test for the original one selected by selecting test items from those available in the database that correspond to the same Enabling Objective as the original and are in the same Enabling Objective order as the original. That is to say that if the first test has five test items for EO 1.1 as one through five, the alternate test will also have five test items for EO 1.1 as test items one through five. AIM II will not duplicate the original test items as long as a sufficient amount of alternate corresponding test items are available in the database.

Selecting the Add or Modify/View option from the Tests window opens the Test Information window in which you will enter the title of the test, select the type of test (open or closed book, or combination of the two), enter the number of test items the test will include, and enter the time
the test will take to complete. From this window you have the option to have AIM II automatically create a test based on the selected EOs or manually generate a test based on the test items you select for each desired EO. The Automatic/Manual Select windows contain the options to select/unselect an individual EO/Item and unselect all EOs/Items. Both windows contain Flag columns to indicate when an EO or test item has been maintained and the options to review the maintenance records for the flagged items. Since all flags must be removed from a course before it is approved, the Remove Flag option is also included.

To generate a test automatically:

Step 1 From the Tests window; select the Options menu item and the Add option. AIM II will open the Test Information window (Figure 6-11).

Step 2 Enter the Title of the Test.

Step 3 Click on the Type field arrow and select "Open", "Closed", or "Combination" from the drop-down menu to indicate the type of test.

Step 4 In the Duration field enter the number of minutes the students will have to complete the test.

Step 5 In the Required Number of Items in Test field enter the number of questions to be selected for the test.

NOTE: The Date field is filled in automatically by the software and indicates the date of development. The date can be edited until the test is approved.
Step 6 If there are any amplifying notes required for the test enter the text in the Note field.

Step 7 Select the Options menu item and the Select Test Items Automatically option. AIM II will open the Automatic Select window which is a split window containing the EOs on the top and the approved test questions for the highlighted EO on the bottom portion of the window.

Step 8 For each EO that is to be tested:
   a. In the left grid open the desired Unit/Topic, by clicking on the ‘+’ block, and open the appropriate Topic folder or open the desired TO.
   b. Click on the desired EO in the top portion of the window.
   c. Select the Options menu item and the Select option. An "X" will appear in the EO "#" column to indicate the EO is selected.

Step 9 Select the Options menu item and the Generate option. AIM II will randomly select the test items for the EO selected and the number of test questions will be reflected in the ‘# Sel’ column next to the EO and in the Required Number of Items in Test field on the Test Information window.

**NOTE:** Two Column Matching test items count as a minimum of 4 individual test items. The actual number is based on the number of required matching entries (entries in the left column).

Step 10 Select the Edit menu item and the Save sub-menu item to save the test items to the database.

Step 11 Repeat Steps 8 through 10 for each EO to be tested.

Step 12 When the selected Test Items field equals the quantity of the Required Items field the note under the EO text field will change from red to black and state “# out of a required # test items selected”. Select the Edit menu item and the Save sub-menu item. Select the Exit menu item to return to the Test Information window.

Step 13 If no further editing of the test is required; select the Status field down arrow and click on the Lock/Approve status. The status down arrow will not be visible until the correct number of test questions have been selected and there are no residual items.

Step 14 Select the Edit menu item and the Save sub-menu item to save the Test Information to the database.
Step 15 Select the Exit menu item to return to the Tests window.

Step 16 Repeat Steps 1 through 15 for each additional automatically generated test required.

To generate a test manually:

Step 1 From the Tests window; select the Options menu item and the Add option. AIM II will open the Test Information window.

Step 2 Enter the Title of the Test.

Step 3 Click on the Type field arrow and select "Open", "Closed", or "Combination" from the drop-down menu to indicate whether the test is an open book or closed book test, or a combination of the two.

Step 4 In the Required Number of Items in Test field enter the number of questions that will be selected for the test.

Step 5 In the Duration field enter the number of minutes the students will have to complete the test.

NOTE: The Date field is filled in automatically by the software and indicates the date of development. The date can be edited until the test is approved.

Step 6 If there are any amplifying notes required for the test enter the text in the Note field.

Step 7 Select the Options menu item and the Select Test Items Manually option. AIM II will open the Manual Selection window which contains either the Unit/Topics of the course or TOs in the course on the left grid and a right grid with a split window containing the EOs on the top and the approved test questions for the highlighted EO on the bottom portion of the window.
Step 8  For each EO that is to be tested:
       a. In the left grid open the desired Unit/Topic, by clicking on the ‘+’ block, and
          open the appropriate Topic folder or open the desired TO.
       b. Click on the desired EO in the top portion of the window.
       c. Select the **Options** menu item and the **Select** option. An "X" will appear in the
          EO "#" column to indicate the EO is selected.

Step 9  When the selected Test Items field equals the quantity of the Required Items field
the note under the EO text field will change from red to black and state “# out of a
required # test items selected”. Select the **Edit** menu item and the **Save** sub-menu
item.

Step 10 Select the **Exit** menu item to return to the Test Information window.

Step 11 If no further editing of the test is required; select the **Status** field down arrow and
click on the Lock/Approved status. The status down arrow will not be visible until
the correct number of test questions have been selected and there are no residual
items.

Step 12 Select the **Edit** menu item and the **Save** sub-menu item to save the test
information to the database.

Step 13 Select the **Exit** menu item to return to the Tests window.

Step 14 Repeat Steps 1 through 13 for each additional manual generated test required.

**To generate an alternate test from an existing test**

This process allows you to generate an alternate series test from a baseline-approved test. The
alternate test will have the following attributes compared to the original:

1. Same number of test items
2. Same amount of time (duration)
3. Same Learning Objectives in the same order
4. Different test items, from the original, when available.

**To generate the alternate test:**

Step 1 In the Tests window, highlight the test that you desire to make an alternate
version. The original test must have been Approved.
Step 2 Select **Options**, then **Create New Version**.

Step 3 The alternate version test can be created automatically or manually and when the required number of test items have been selected the test will have a status of Complete and numbered as the next version (vX).

**To re-sequence test items on a test:**

This action can only be performed on tests that are not locked or approved.

Step 1 From the Tests or Test Information window; select the **Options** menu item and the **View/Resequence Test Items** option.

Step 2 Click on the test items and drag them to the desired locations. The test item numbers will be automatically updated.

Step 3 Select the **Edit** menu item and the **Save** sub-menu item.

Step 4 Select the Exit menu item to return to the Tests window.

**To print preview/print a test:**

A Test can be print previewed/printed from the Tests window or from the Test Information window. The Print Preview and Print options have the same functionality from either window. When printing an unapproved test the word “**DRAFT**” is printed in all four corners.

Step 1 From the Tests window, highlight the Test you desire to print preview/print and select the **Options** menu item. Select the **Print Preview/Print** option.

Step 2 From the Printer Setup window (**Figure 6-12**), select from the following:
Figure 6-13. Printer Setup Window

- **Print ‘Page X of Y’**: used to number the pages of the test. Required for a classified test.
- **Setup Header/Footer**: used to enter one line of text in the header and up to three lines of text in the footer. Required to enter classification of the test in header and footer for a classified test.
- **Graphics on the Current Page**: used when you want to display/print the graphic associated with a test item on the same page as the question.
- **Graphics on the Next Page**: used when you want to display the graphic associated with a test item on the next page after the question.
- **Graphics at the End**: used when you want to display the graphic associated with the test items on the test at the end of the test.
- **Print Answers**: Will display/print the answer key.

**Step 3**
Click on the OK button after selections have been made on the Printer Setup window.

**Step 4**
The Print Preview window allows you to view the entire test and/or report and has the Options menu item which allows you to select either **Print** or **Save as PDF**. If you select the option to save the test/answers to a PDF file the software will require you to select the directory in which the file will be placed and name the file.

**Step 5**
If the Print option has been selected, select the window's default printer. If multiple copies are desired click on the Properties button and enter the quantity required and click on OK. Click on OK to print.
CHAPTER 7

CURRICULUM OUTLINE OF INSTRUCTION (COI) MODULE

7.0 CURRICULUM OUTLINE OF INSTRUCTION (COI) ................................................. 7-1

7.1 ELEMENTS OF THE COI .................................................................................. 7-1

7.2 USING THE AIM II COI MODULE ................................................................. 7-1
  7.2.1 Overview of the AIM II COI Module ...................................................... 7-2

7.3 CREATING OR SELECTING A COI ............................................................... 7-3

7.4 COI OPTIONS ..................................................................................................... 7-4
  7.4.1 Creating Units and Topics ....................................................................... 7-4
  7.4.2 Insert Unit/Topic ...................................................................................... 7-5
  7.4.3 Join Unit/Topic ........................................................................................ 7-6
  7.4.4 Split Unit/Topic ....................................................................................... 7-7
  7.4.5 Delete Unit/Topic .................................................................................... 7-9
  7.4.6 Copy Unit/Topic from Other Course ..................................................... 7-10
  7.4.7 Remove LO ............................................................................................ 7-11
  7.4.8 Insert an EO Into a Topic ....................................................................... 7-12
  7.4.9 Course Master Schedule ........................................................................ 7-12
  7.4.10 Show Unused LOs ............................................................................... 7-13
  7.4.11 Hide/Show LOs .................................................................................... 7-13
  7.4.12 Print Preview .......................................................................................... 7-13
  7.4.13 Print ........................................................................................................ 7-15
  7.4.14 Explain Flag ........................................................................................... 7-15
  7.4.15 Remove Flag .......................................................................................... 7-16

7.5 COI WINDOW EDIT MENU ITEMS .............................................................. 7-16
  7.5.1 Cut, Copy and Paste ............................................................................... 7-16

7.6 ON-LINE HELP ................................................................................................. 7-17

7.7 SUMMARY ....................................................................................................... 7-17
(This Page Intentionally Left Blank)
7.0 CURRICULUM OUTLINE OF INSTRUCTION (COI)

By completing the Learning Objectives (LOs) in the previous module, you completed the first portion of the Design Phase of curriculum development. In this module you will sequence the learning objectives into Units and Topics, thus creating the Curriculum Outline of Instruction (COI) for the new/revised course.

The Design Phase is the transition between the job world and the course. Using the AIM II software, the first part of the Design Phase is broken out into two modules: Learning Objectives and Curriculum Outline of Instruction. All duties and tasks listed on the CTTL were developed into LOs.

In this module you will arrange the objectives in the order in which they will be taught. This arrangement will help produce the most effective learning in the shortest time possible.

7.1 ELEMENTS OF THE COI

Using the AIM II Software, you created two types of LOs: terminal and enabling. When you selected the option to build LOs in the CTTL module, for every Duty statement listed on the CTTL, a terminal objective was created. For every Task statement listed on the CTTL, an enabling objective was created. In the Learning Objectives (LO) module you modified, added, and joined the LOs to complete the LOs for your course.

In the COI you divide the materials into Units by selecting Terminal Objectives (TOs) and select the EOs that will be covered in each Topic. You will also resequence the Units/Topics/EOs in the order in which they will be presented to the trainee.

7.2 USING THE AIM II COI MODULE

The AIM II COI Module provides you with all of the tools necessary to complete the Curriculum Outline of Instruction for a new, changed, or revised course. The program will present a series of windows. These windows have a menu across the top and a tool bar below the menu. The tool bar contains icons, which represent different program features.
You can select options from the menu in two ways. First, you can select an option from the menu bar by pressing the ALT key and typing the underlined letter. Second, you can select an option by highlighting it with a mouse and clicking the left mouse button. With either method, selecting an option from the menu will bring up windows, which will allow you to enter the data necessary to complete the COI.

If you are working on a new Course, some of the windows presented may be blank. You must provide the appropriate information by either typing the information in the correct field or selecting from a series of drop-down menus. If you are working on a course that is in progress or completed, you can edit existing data and/or provide new data as necessary. Each window is explained in this User's Manual with instructions on how to fill in the necessary data.

### 7.2.1 Overview of the AIM II COI Module

Each of the following steps is explained in further detail in this manual. These paragraphs are meant as a quick reference for getting around the software.

To work on developing the Curriculum Outline of Instruction, choose **Course, Select** from the menu bar or click on the "Select Course" icon. A list of available courses will appear. Select the course to work on from the list.

Select **Curriculum Outline of Instruction (COI)** at the main window by either clicking on the COI icon or clicking on **Document** and **Curriculum Outline of Instruction (COI)** from the drop-down menu.

You will see the list of LOs that you created in the LO Module. For each Duty listed in the CTTL, a terminal objective was created. For each Task listed under a duty, an enabling objective was created.

This module uses the drag and drop method to select learning objectives from the top half of the window (LOs) to create Units and Topics in the COI on the bottom half of the window.

**To create a Unit and Topic using drag and drop editing:**

1. **Step 1** The first Unit number is provided by the software. For subsequent Units and Topics, click in the Unit No. column. The Unit number will be inserted in this position.
Step 2    Select the TO (#.0 LOs) to be addressed in the Unit from the top half of the window by clicking on it, hold down the left mouse button, and drag the TO to the Unit number created in Step 1 and release the left mouse button to drop the TO and all its supporting EOs into the first Topic of the Unit.

NOTE: The text of the TO and the text of the first supporting EO are inserted for the Unit and Topic titles and are intended to be modified to make Unit and Topic titles, as appropriate. You will not be allowed to enter text in the COI below the Unit or Topic Title. Editing of the actual TOs and EOs can only be accomplished from the Learning Objectives (LO) Module.

Step 3    Click on the new Unit/Topic Title field to highlight the TO, double click on the field, and edit the TO verbiage to create a Unit title.

Step 4    Click on the Unit/Topic Title field to highlight the EO text, double click on the field, and edit the EO verbiage to create a Topic title that is descriptive of the EOs contained within the Topic.

Step 5    Select the Edit menu item and the Save sub-menu item to save your COI information.

After creating at least one Unit, you can select Options to display the drop-down menu. From here, you can Insert, Join, Split, and Delete Unit/Topic, Copy Unit/Topic from Other Course, Remove LO, view the Course Master Schedule, Show Unused LOs, Hide/Show LOs, Print Preview and Print the COI, Explain Flag and Remove Flag.

7.3 CREATING OR SELECTING A COI

In the process of developing a new course, COIs are created from the LOs. Because of this direct relationship, the process for creating a COI for a new course and selecting an existing COI is the same.

There are four different ways to access the COI after the course has been selected:

1. From the AIM II main menu select the Document menu item and the Curriculum Outline of Instruction (COI) sub-menu item.
2. Click on the COI icon.
3. From the course tree structure, click on the COI folder, select the **Options** menu item and the **GoTo** sub-menu item. The **View** menu item contains sub-menu items for **Note** (Public and Private) and **Summary** data. When checked the sub-menu items the Note/Summary data will be displayed in the right hand grids of the Course tree structure. Opening the COI folder will provide Summary data that identifies the total number of COI items, and a table containing all Units, their Number, the Unit Title, and number of Topics.

4. From the course tree structure, click on the CIN folder. The folders contained in the course will be reflected in the upper right hand grid. Double-clicking on a folder in the upper right hand grid will open the folder and it can be viewed/edited.

### 7.4 COI OPTIONS

After selecting a Course, you can edit or create the COI through the **Options** menu. The COI Options are:

- **Insert Unit/Topic**
- **Join Unit/Topic**
- **Split Unit/Topic**
- **Delete Unit/Topic**
- **Copy Unit/Topic from Other Course**
- **Remove LO**
- **Course Master Schedule**
- **Show Unused LOs**
- **Hide/Show LOs**
- **Print Preview**
- **Print**
- **Explain Flag**
- **Remove Flag**

**NOTE:** In addition to editing the COI through the use of the menu options, you can resequence the Units and Topics through drag and drop editing. This procedure is explained in paragraph 7.2.1.

#### 7.4.1 Creating Units and Topics

Use the terminal objectives that you created in the LO Module to form the Units of the course. Use the enabling objectives to form the Topics. Refer to paragraph 7.2.1 to guide your decisions in forming Units and Topics.
**AIM II USER'S MANUAL COI MODULE**

**To create a Unit/Topic:**

**Step 1** In the COI (lower half of the window), click in the field corresponding to the Unit or Topic you would like to add. (AIM II will automatically provide the next sequential number.) A Unit number "1" is automatically added by AIM II for a Course with no Unit/Topic.

**Step 2** Use the mouse to highlight the TO/EO (upper half of the window) that you would like to use as a basis for creating a Unit/Topic. Drag the objective from the upper window to the first blank row of the bottom window.

**NOTE:** Use TOs to form Units. There must be at least one TO per Unit.

**Step 3** The program will automatically number the Unit (all you have to do is click the mouse at the desired location of the new Unit). The text of the TO will appear as the Unit Title. When you drag a TO from the top window to the bottom, all associated EOs will be dragged down as well. The first EO supporting the TO will be used to develop the Topic title. Clicking on the text field will allow you to modify the Unit or Topic title.

**Step 4** Type in/edit the title of the Unit/Topics. Unit Title should be limited to 80 characters (including spaces).

**Step 5** Continue to add Units/Topics in this manner.

**Step 6** Click on **Edit**.

**Step 7** Click on **Save** or **Cancel** with regard to your entries. To return to the AIM II main window, click on **Exit**.

**7.4.2 Insert Unit/Topic**

Once you have created at least one Unit and Topic, you may use the **Insert Unit/Topic** option to sequence the Units and Topics within the COI. You may also use drag and drop editing to sequence the Units and Topics.

**Step 1** Position the cursor on the Unit or Topic number that you would like to insert the new Unit or Topic **AFTER**.

**Step 2** Select the **Options** menu item and the **Insert Unit/Topic** option.
Step 3 Drag and drop the desired Terminal/Enabling Objectives from the top half of the window as described previously.

Step 4 Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries. To return to the AIM II main window, click on Exit.

To re-sequence Units, Topics, or EOs using drag and drop editing:

Units can be resequenced into any order. Topics can only be re-sequenced within the assigned Unit and EOs can be re-sequenced within the assigned Topic. You cannot re-sequence a Topic or an EO of a Unit to another Unit.

Step 1 Click on the Unit/Topic/EO that will be re-sequenced and hold the left mouse button down.

Step 2 Drag the Unit, Topic, or EO to the location where you want to place it. Release the mouse button to drop the Unit, Topic, or EO in place.

Step 3 The program will automatically renumber the Units and Topics and keep track of the LO Sequence Number.

Step 4 Continue to re-sequence Units, Topics, and EOs in this manner.

Step 5 Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries. To return to the AIM II main window, click on Exit.

7.4.3 Join Unit/Topic

Once you have created at least two Units or Topics, you may use the Join Unit/Topic option to join two Units or Topics together. The joining of Units and Topics should be planned out carefully. If you join incorrectly, you can use the Split Unit/Topic option to restore the Unit/Topic to its original state.

CAUTION: When splitting a Topic, DPs and their associated RIAs that are not linked to an EO will be duplicated in each Topic.
To join a Unit or Topic:

You will see two windows on your screen. The upper window contains the Learning Objectives. The lower window contains fields for Unit Number, Topic Number, LO Sequence Number, and Unit/Topic Title. You will use the Units and Topics in the lower window to join Units/Topics.

Step 1 Use your mouse to highlight the primary Unit or Topic (the Unit/Topic location where the resultant Unit/Topic will appear after the join).

Step 2 Select the **Options** menu item and the **Join Unit/Topic** option.

Step 3 At the prompt "Click on Unit/Topic to join with." click on the OK button.

Step 4 Highlight the Unit/Topic that you would like to join with the highlighted Unit/Topic. You must join Topics with Topics and Units with Units.

Step 5 At the prompt "Are you sure you want to join the Units/Topics?" Click on the **Yes** button to join, the **No** button to select a different Unit/Topic, or the **Cancel** button to cancel the join operation.

Step 6 The program will automatically number or renumber the Units and Topics. Use the text from both Units/Topics and edit the resultant Unit/Topic Title field. Double clicking on the text field will allow you to modify the title.

Step 7 You can continue to join Units and Topics in this manner.

Step 8 Select the **Edit** menu item and the **Save** sub-menu item to update your COI.

Step 9 To return to the AIM II main window, select the **Exit** menu item.

**NOTE:** No update is performed if **Cancel** is selected.

### 7.4.4 Split Unit/Topic

When creating a Unit, by clicking on a TO from the LO portion of the window and dragging/dropping into the COI, AIM II associates all the supporting EOs with the TO and places them in a single Topic. It may be desirable to split the Unit/Topic to enhance teachability.
To split a Unit:

Step 1  Click on the Unit to be split.

Step 2  Select the **Options** menu item and the **Split Unit/Topic** option. The software will prompt you with "Please select the TOPICs to remain with the original UNIT. All others will be removed to the new UNIT."

Step 3  Click on the **OK** button. AIM II will open the Split Unit window.

Step 4  Click on each of the Topics to remain with the original Unit and select the **Options** menu item and the **Select** option or double click on the desired Topics.

Step 5  Select the **Exit** menu item. AIM II will prompt you with "Selections for splitting have been made. Would you like to split entity?"

Step 6  Click on **Yes** to split the Unit, **No** to return to the Split Unit window and Select/Deselect Topics for the Unit, or **Cancel** to terminate the Split Unit option and return to the COI. The Unit that contains the Topics not selected will become the next sequential Unit after the new Unit.

Step 7  Edit the resulting Unit titles is necessary to reflect contents and select the **Edit** menu item and the **Save** sub-menu item.

Step 8  To return to the AIM II main window, click on **Exit**.

To split a Topic:

**CAUTION**: When splitting a Topic, DPs and their associated RIAs that are not linked to an EO will be duplicated in each Topic.

Step 1  Click on the Topic to be split.

Step 2  Select the **Options** menu item and the **Split Unit/Topic** option. The software will prompt you to select the EOs that will remain with the original Topic. All others will be moved to the new Topic.

Step 3  Click on the **OK** button. AIM II will open the Split Topic window.

Step 4  Click on each of the EOs to remain with the original Topic, select the **Options** menu item and the **Select** option, or double click on the desired EOs.
Step 5 Select the **Exit** menu item. AIM II will prompt you with "Selections for splitting have been made. Would you like to split entity?"

Step 6 Click on **Yes** to split the Topic, **No** to return to the Split Topic window and Select/Deselect EOs for the Topic, or **Cancel** to terminate the Split Topic option and return to the COI. The Topic that contains the EOs not selected will follow the new Topic.

Step 7 Edit the resulting Topic titles is necessary to reflect content and select the **Edit** menu item and the **Save** sub-menu item.

Step 8 To return to the AIM II main window, click on **Exit**.

### 7.4.5 Delete Unit/Topic

Deleting a Unit or Topic from the COI will delete all associated materials in the LP and TG.

**To delete a Unit/Topic:**

**Step 1** Click on the Unit/Topic that you want to delete.

**Step 2** Select the **Options** menu item and the **Delete Unit/Topic** option. The program will ask you to confirm that you want to delete the Unit/Topic.

**Step 3** Click on **Yes** to delete the Unit/Topic. If you change your mind, you can click on **No** to cancel and return to the LO/COI window.

**Step 4** If a Topic was deleted from a Unit, edit the Unit title if necessary.

**Step 5** Select the **Edit** menu item and the **Save** sub-menu item.

**Step 6** To return to the AIM II main window, click on **Exit**.
7.4.6 **Copy Unit/Topic From Other Course**

Copying a Unit/Topic from another course is a planned event and this decision should have been made when developing the CTTL. The **Copy Unit/Topic from Other Course** option is not enabled until at least one Unit has been developed in the COI. AIM II will ask you where you want the Unit/Topic inserted in the COI and will insert the entities where specified. When a Unit/Topic is copied from another course the duties and all the supporting tasks will be added to the CTTL. AIM II will copy the TOs/EOs for the newly added CTTL items and add them to the LOs.

If the Unit/Topic, that you are copying, comes from a course that has an LP with Unit/Topic page information, DPs, RIAs, RRL items, and TG Sheets, and you want to use the LP elements in your course, you must lock your TCCD and generate an LP for your course before copying the Unit/Topic.

If you copy a Unit/Topic and you have not created an LP, the Unit/Topic will be added to the COI, supporting duties/tasks will be added to your CTTL, and the LOs will be added to your learning objectives. But, when you lock your TCCD for the first time and create your LP, it will not contain the DP/RIAs of the copied course.

**To copy a Unit/Topic from another Course:**

- **Step 1** Select the COI **Options** menu item and the **Copy Unit/Topic from Other Course** option. AIM II will open the Course Select window.

- **Step 2** Click on the course that contains the Unit/Topic you want to copy and click on the **Select** menu item. AIM II will open the COI window, which contains a split window with the COI of the course that the material will be copied from on the top and the COI of the course the material will be copied to on the bottom.

- **Step 3** Click on the Unit/Topic to be copied on the top portion of the window and click on the position where you want the topic inserted after in the COI of the course being developed.

- **Step 4** Select the **Edit** menu item and the **Copy** sub-menu item. AIM II will open the Copy Unit/Topic window.

- **Step 5** Enter the Unit/Topic number you want to copy in the field provided.

- **Step 6** Enter the Unit/Topic number, where the copied Unit/Topic will be inserted after, in the field provided (subsequent Unit/Topic numbers will be resequenced).
Step 7  Click on the **OK** button to copy or the **Cancel** button to return to the COI window.

Step 8  If you selected **OK**, select the COI **Edit** menu item and the **Save** sub-menu item. AIM II will copy the material and insert the copied Unit/Topic at the Unit/topic number entered in Step 6 and resequence subsequent Units/Topics. AIM II will record the Unit/Topic number in the Originating Unit/Topic (Orig U/T) field adjacent to the Title of the Unit/Topic copied.

Step 9  If the Unit/Topic was copied to a location that is not desired select the **Edit** menu item and the **Cancel** sub-menu item. AIM II will restore the COI of the course to its previous state.

Step 10  Repeat Steps 3 through 8 for each Unit/Topic that you want to copy.

Step 11  When complete; select the **Exit** menu item. AIM II will prompt you with "Unit/Topics have been selected for copying. Save?"

Step 12  Click on **Yes** to save the copied Unit/Topic to the database and return to the Course Select window, **No** to exit the copy option and return to the Course Select window without saving the copied Unit/Topic, or Cancel to return to the COI window.

Step 13  From the Course Select window select the **Exit** menu item to return to the COI of your course.

You may have to edit the CTTL to remove unwanted CTTL items that were copied and are not present in the Unit/Topic copied.

### 7.4.7 Remove LO

A TO can only be removed from a Unit if there are no directly supporting EOs in any of its Topics. You may remove any EO from a Topic. During development, all associated material will be removed when the LO is removed. During maintenance all associated material will be flagged for deletion.

**To remove an LO:**

- **Step 1** Use the mouse and click on the LO that you want to remove.
Step 2  Select the **Options** menu item and the **Remove LO** option. The program will ask you for confirmation.

Step 3  Click on **Yes** to remove the LO. If you change your mind, you can click on **No** to cancel and return to the LO/COI window.

Step 4  Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your changes. To return to the AIM II main window, click on **Exit**.

### 7.4.8 Insert an EO into a Topic

To add an EO to a Topic use the drag and drop method. Dragging an EO down from the LO into a Topic of the COI will place the new EO right after the EO that it is dropped on.

### 7.4.9 Course Master Schedule

This option allows you to view the Course Master Schedule (CMS) for the course that you are editing or creating without exiting from the COI Module. The functionality of the CMS Module is explained in the next chapter of the User's Manual, CMS Module.

**To view the CMS:**

Step 1  Select the **Options** menu item and the **Course Master Schedule** option.

**NOTE:** When you view the CMS, you will receive a message that says "Course is being edited, can only view. Continue?" To view the CMS, click on Yes and continue.¹

Step 2  Click on **Exit** to return to the COI Module.

---

¹ This message means that only one version of the TCCD can be edited at one time. Since your input into the COI can alter the TCCD, the program prevents any other user (including you) from editing any other part of the document simultaneously.
7.4.10 Show Unused LOs

All LOs developed in the LO module must be selected when developing the COI. If all LOs are not selected, then the course cannot be approved. The **Show Unused LOs** option allows you to view a list of the LOs that have not been included in your COI. The list can be printed to facilitate development of the COI.

**To show unused LOs:**

- **Step 1** Select the **Options** menu item and the **Show Unused LOs** option.
- **Step 2** Select the **Options** menu item and the **Print** option.
- **Step 3** Select the **Exit** menu item to return to the COI.

7.4.11 Hide/Show LOs

The **Hide/Show** LOs option allows you to hide the LOs to work on the COI and show the LOs when developing Units and Topics for the COI.

**To hide or show the LOs:**

Select the **Options** menu item and the **Hide/Show** LOs option.

7.4.12 Print Preview

Selection of **Print Preview** will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting **OK** will present the default printer selected. Selecting **OK** from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:
- **Options** - contains the options to **Print** or **Save to PDF**. **Print** opens the Print window, which allows you to print a page, range of pages, entire document, print to file, and number of copies. **Save to PDF** saves the document as a PDF file to the desired location.
- **Go To** - moves to the previous, next, first, last, or desired page.
- **Exit** - returns to the Curriculum Outline of Instruction (COI) window.
- **Help** - provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:
- **Previous** - moves to the previous page.
- **Next** - moves to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Accesses the page desired by typing in the page number in the first field and depressing **Enter**.
- **Actual Page** - displays the actual page number, as shown on the page. Accesses the page desired by typing in the page number in the field and depressing **Enter**.

The right and left mouse buttons allow you to zoom in and out by double clicking on the page and allows you to view multiple pages. Double click the left mouse button to zoom in to a single page display and double click the right mouse button to zoom out.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

**To print preview the COI:**

**Step 1** From the Curriculum Outline of Instruction (COI) window; select the **Options** menu item and the **Print Preview** option.

**Step 2** From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

**Step 3** Click on the **OK** to print preview.
7.4.13 Print

Selection of the Print option allows the entire document to be printed:

To print the entire COI:

- Step 1 Select the Options menu item and the Print option.
- Step 2 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.
- Step 3 Click on the OK to print.

7.4.14 Explain Flag

The course is considered to be in Maintenance if it is a non-Rev 0 Change 0 Course and either:
1. A previous version of the Course exists at the current Revision, or
2. The course is in a Change 0 Revision Course, a previous version of this course exists in your database, and the course has an LP.

If these conditions are NOT met, the Course isn't considered to be in maintenance, and as such, no flags will be generated for added/deleted/modified items other than RRL items.

The Explain Flag has two sub-menu selections to allow you to view and print the maintenance record for the highlighted and flagged LO item or the flagged Unit/Topic/EO. The maintenance record states what type of maintenance action was performed to the item (added, modified, or deleted), the Revision and Change of the item, who performed the maintenance action (by login name), and when the maintenance action was performed. If the flag originated in the LO module the explanation will aid the user in determining the required maintenance action.

To read the maintenance record for a flagged LO item or Unit/Topic:

- Step 1 Click on the flagged item
- Step 2 Select the Options menu item and the Explain Flag option.
Step 3 Select either the LO or Unit/Topic/EO sub-menu item as desired. AIM II will open the Maintenance Record window for the item.

Step 4 Click on the Exit menu item to return to the COI window.

### 7.4.15 Remove Flag

The **Remove Flag** option can only be exercised by a user with Remove Flag privilege or by the AIM Administrator. The flags are used for review purposes and must be removed prior to approval of the course. The Remove Flag option will remove the flag and the maintenance record for the highlighted Unit/Topic/EO (to remove the flags from the LO items refer to Chapter 5).

From within each module for training materials AIM II has the **Remove Flag** option that enables the removal of the flag for the highlighted item individually. Flags can also be removed for the entire course by selection of the **Remove Flag** option from the Course Select window **Options** menu item.

**To remove a flag from a Unit/Topic/EO:**

1. Step 1 Click on the flagged item
2. Step 2 Select the **Options** menu item and the **Remove Flag** option. AIM II will remove the flag and the associated maintenance record.

### 7.5 COI WINDOW EDIT MENU ITEMS

#### 7.5.1 Cut, Copy, and Paste

**To cut or copy:**

1. Step 1 Click on the text field to be cut or copied.
2. Step 2 Select the **COI Edit** menu item and **Cut** or **Copy** sub-menu item.
NOTE: To duplicate the contents, use the **Copy** function. This will leave the original text in its current position. To move contents from one position in the document to another, use the **Cut** option.

Step 3 Use the mouse to highlight the field where you want to paste the copied text. Click on **Paste** to put the contents in the selected field.

Step 4 Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries. To return to the AIM II main window, click on **Exit**.

In addition to the above-mentioned cut, copy, and paste options the following option is also available.

**To cut, copy, and paste to or from any windows based word processor to or from any field in AIM II is as follows:**

- **Step 1** Select the text to be cut or copied by highlighting it in the original document.
- **Step 2** `<Ctrl + C>` will copy this information to the clipboard.
- **Step 3** Position your cursor on the location that you want the copied information to be pasted.
- **Step 4** `<Ctrl + V>` will paste this information at the location of the cursor. This same information will remain in the buffer and can be pasted repeatedly until new information is copied to the buffer, or the computer is powered down.

### 7.6 ON-LINE HELP

The help option allows you to go directly to the AIM II On-line Help Window. This help option is a hypertext help tool that should allow you to navigate easily to find the information that you desire.

### 7.7 SUMMARY

By completing this module, you have numbered and sequenced the LOs into Units and Topics. The AIM II software relies on this input to build a portion of the TCCD and the CMS.
(This Page Intentionally Left Blank)
8.8 ON-LINE HELP .......................................................... 8-16
8.9 SUMMARY ................................................................. 8-16
8.0 COURSE MASTER SCHEDULE (CMS)

By completing the Curriculum Outline of Instruction (COI) in the previous module, you have enough data to prepare the Course Master Schedule. In this module you will place the lesson topics of the COI into a time schedule, thus creating the Master Schedule Summary Sheet (MSSS) and Course Master Schedule (CMS) for the new/revised course.

The CMS is a management tool that provides the planned period-by-period subject matter for a course, time allocated to each subject, time specified for theory and laboratory instruction, detailed sequence of the instructional program, and the maximum student-to-instructor ratio for each period. The MSSS and CMS are an annex of the Training Course Control Document (TCCD), an output of the next module. The CMS is also printed as part of the Trainee Guide (TG). The CMS is part of the Design Phase of curriculum development.

NOTE:
If the Use Events checkbox was checked in the TCCD the please refer to Section 8.7 CMS Events below.

8.1 CONTENTS OF THE COURSE MASTER SCHEDULE

The CMS places lesson topics of the COI into a time schedule.

The normally scheduled technical training workweek for students shall be 40 hours of approved technical training topics. Time allocated to non-technical training requirements, such as General Military Training (GMT), will be in addition to this requirement.

Approved non-technical training subjects scheduled outside the 40-hour technical training work week will be included in the Course Master Schedule if technical training instructors are required to do the training. Physical training and medical or dental time directly related to or required for the technical course completion, or required as a prerequisite for follow-on technical training, may be included in Course Master Schedules only if technical training instructors not in a duty or watch status are required to participate in those evolutions.

The time that you designate for topics should reflect the time required presenting the Lesson Topic. The time should NOT include testing. The total course length will be the sum of the lesson topic periods, testing periods, and authorized administrative periods. The CMS in AIM II keeps a running total of the instructional hours, less break time. Since partial periods of 15, 30, 50 and 90 instructional minutes can be indicated; an instructional week is noted by 33.33
accumulated instructional hours. The remaining number of hours to equal a 40-hour workweek is considered break time (10 minutes per hour of instruction).

When AIM II is loaded to support the Center for Naval Aviation Technical Training (CNATT) curriculum development and under the Contents menu item contains the Instructor Computation Worksheet.
8.2 USING THE AIM II CMS MODULE

The AIM II CMS Module provides all of the tools to complete the Course Master Schedule for a new or revised course.

Options include:
- **Duplicate CMS Period** adds additional periods for the highlighted Class, Lab, or Special period.
- **Delete** deletes the highlighted period unless it is the last period supporting a Topic in the COI.
- **Toggle Page Break** inserts or removes a page break. When this option is selected, the period highlighted will start the next page and an asterisk in the No. Column will identify the top of the page or remove the page break previously inserted.
- **Print Preview** previews the MSSS and CMS before sending it to the printer and to print the current page, range of pages, or the entire MSSS and CMS or Save as a PDF file.
- **Print** allows you to print the entire MSSS and CMS.
- **Explain Flag** allows you to view and print the maintenance record for the flagged period when creating a Change or Revision to the Course.
- **Remove Flag** allows the user with Remove Flag privilege, or the AIM Administrator, to remove the flag and maintenance record from the database at the completion of review and approval for the Course Change or Revision. All flags must be removed for the AIM Administrator to approve the Course.

Contents include:
- **Justification** opens the Styled Text Editor window where justification for Student Instructor Ratios and Bottleneck Ratios can be entered for the MSSS.
- **Instructor Computation Worksheet** menu item is present when developing CNATT curriculum. Selecting this menu sub-item displays the Instructor Comp Worksheet in Excel.

Selecting **Edit** on the CMS menu bar allows you to Save or Cancel your entries.

8.3 CREATING OR SELECTING A CMS

In the process of developing a new course, a CMS is created from the new COI. Because of this direct relationship, the process for creating a CMS for a new course and selecting an existing CMS is the same.
There are four different ways to access a CMS after the course has been selected:

1. From the AIM II main menu select the **Document** menu item and the **Course Master Schedule (CMS)** sub-menu item.
2. Click on the CMS icon.
3. From the course tree structure click on the CMS folder, select the **Options** menu item and the **GoTo** sub-menu item. The **View** menu item contains sub-menu items for **Note** (Public and Private) and **Summary** data. When these sub-menu items are checked the Note/Summary data will be displayed in the right hand grids of the Course tree structure. Opening the CMS folder can provide Summary data that identifies the total number of periods and weeks and the total instructional time for the course.
4. From the course tree structure, click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the CMS element in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.

### 8.4 COMPLETING THE CMS

The CMS defaults to the following information provided by other modules of the AIM II software. The number refers to the Unit/Topic number. The type defaults to Class. The fields for week and day are blank. The field for Ratio reflects the maximum class size that you provided in the TCCD Module. The field for Period Length (P.L.) defaults to 50 minutes and can be changed to 15, 30, 50 or 90. The field for Bottleneck is blank.

You may edit the CMS data by: changing the type of period, modifying a title for a special or duplicated period, specifying the week and day that the topic will be taught, modifying the student-to-instructor ratio, selecting one of three period lengths, and indicating the bottleneck information. You can add a period into the CMS, or delete a period that you added from the CMS.

#### 8.4.1 Period Type

Examples of period types are classroom, laboratory, practical application, field, shop, written test, and performance test. Any period type, which is not classroom, laboratory, or practical application (PA), should be indicated as "Special." A special period may also consist of a formal graduation ceremony providing it does not exceed one period.

Individual medical and dental time, overseas interviews, ceremonies, administrative time, and command time not directly related to technical training shall NOT be included in the Master Schedule.
To edit the period type:

Step 1 Click on the field for Type. An arrow will appear in the right portion of the field.

Step 2 Use your mouse to highlight the arrow. This will present a drop-down menu with the options: Class, Lab, PA, and Special. Click on the type of environment that is appropriate for presentation of the Lesson Topic, or type the first letter of the type desired (C, L, S or P).

Step 3 If the Type selected was Special, add the Title of the period in the Topic Title field.

Step 4 Continue to change the period types in this manner.

8.4.2 Topic Title

The AIM II software provides the topic titles in the CMS based on the titles in the COI. Only Special and duplicate period titles should be edited.

8.4.3 Entering Week and Day

The fields for week and day are blank. You enter the week and the day that the topic will be taught. The normal scheduled training day consists of 8 hours of approved technical training topics exclusive of meal hours (which is 6.66 hours of instructional time if there is a ten minute break for each hour of instruction). The normal training period is 60 minutes, whether or not a break time is included. Ideally, a period should consist of 50 minutes of technical instruction and a 10-minute break; however, local training situations may preclude strict adherence to this ideal for some courses. Guidance on entering variations to the normal workday and week can be found in the latest CNETINST on preparing the CMS.

To enter the week and day:

Step 1 Click on the field for Week or Day. This will highlight the field.

Step 2 Type in the week and day.

Step 3 Select Edit.

Step 4 Select Save to update your entries or Cancel to delete the changes to your entries. To return to the AIM II main menu, click Exit.
8.4.4 Editing Student-to-Instructor Ratio

The student-to-instructor ratio is indicated and expressed as a ratio in the "Ratio." field. The ratio of students per instructor for each instructional situation must be set based on space and equipment constraints, which yields the highest possible ratio without serious detriment to quality of training. A student-to-instructor ratio of 25:1 is the planning standard for formal theory (classroom, lecture, written tests, etc.) work. This standard is not inflexible since space configurations or other factors may sometimes dictate variation. If these constraints do not allow a ratio of 25:1, the ratio listed should be the maximum possible.

NOTE: Do not adjust a ratio simply because the actual student input is less than the planned. Base Laboratory (shop, line, performance testing, field instruction, etc.) ratios on a review of each topic to determine the highest ratio of students-to-instructors in consideration of equipment, safety, and teaching effectiveness for the particular instructional situation.

To edit the student-to-instructor ratio:

Step 1 Click on the Ratio field. Type in the student-to-instructor ratio. (Number of students to Number of instructors, e.g., 20:10 would indicate that there are two students per instructor with a class size of 20).

Step 2 Select Save to update your entries or Cancel to delete the changes to your entries. To return to the AIM II main menu, click Exit.

8.4.5 Period Length

A period is defined as 50 minutes of instruction and 10 minutes of break time. AIM II defaults to 50-minute periods. AIM II has a drop-down menu, which includes 15, 30, 50, and 90 so you can identify partial periods. Total period length for the course is tabulated automatically by AIM II and is reflected in the Total Period Length field. The Total Period Length is a summation of all the period times excluding break time, e.g., a 40 hour course would have a Total Period length of 33 hrs and 33 minutes.

To change the period length:

Step 1 Click on the Period Length (P.L.) field. A down arrow will appear in the field.

Step 2 Click on the down arrow and from the menu click on the desired selection.
8.4.6 Bottleneck Ratio

When equipment or space limits exist, situations can occur where only a portion of the class can advance through a period together. The usual procedure to overcome such bottlenecks is to split the class; one group receives the required curriculum period and the remainder of the class is in a standby waiting to rotate through the bottleneck.

To indicate the bottleneck for a particular Lab, PA, or Special period, the bottleneck ratio would be the number of students who can progress through the bottleneck together with the instructor. A class with a maximum class size of 25 students going through a lab period, which can accommodate 5 students at a time with one instructor, would show a student-to-instructor ratio of 25:1 for the course and a bottleneck ratio of (5/1) for the lab periods.

To edit the bottleneck ratio:

Step 1 Using the mouse, highlight the Bottleneck field. Type in the student-to-instructor ratio, which can be used for the bottleneck in parenthesis with a slash vice a colon. [(Number of students - / - Number of instructors), e.g., (6/1)]. Note the use of the slash "/" vice colon ":" which is used for the Student/Instructor ratio for the course. This field can contain up to 15 characters for non-CNATT courses. For a CNATT course the field can contain 7 characters, e.g., (XX/YY).

Step 2 Click on Edit and select Save from the drop-down menu.

NOTE: For unique bottleneck situations, refer to latest CNETINST governing CMS development.

8.4.7 Justification of Ratios

The Justification of Ratios field is provided for the developer to add justification when it is necessary for the Student/Instructor ratio for a period or the Bottleneck Ration for a Lab, Special or PA period. This field will expand to accommodate the required text entry.

To add text to justify a Student/Instructor ratio for a period:

Step 1 Click on the Justification of Ratios field for the period and type the text required.

Step 2 Click on Edit and select Save from the drop-down menu.
8.5 CMS OPTIONS

To facilitate constructing the CMS, the AIM II Software allows you to duplicate and delete CMS periods. Ensure that the Type of period, Week, Day, Student/Instructor Ratio, and Bottleneck fields are completed before duplicating CMS periods.

8.5.1 Duplicate CMS Period

The Duplicate CMS Period option allows you to add additional periods for the highlighted period to reflect exactly how long it will take to teach the subject matter. The titles of duplicate periods and Special periods can be edited as necessary.

To duplicate a CMS period:

Step 1 Click on the existing CMS period that you would like to duplicate.

Step 2 Click on Options menu item and the Duplicate CMS Period option.

Step 3 In the Duplicate CMS Period window provided enter the number of times the period should be duplicated in the field provided and click on the OK button.

Step 4 Edit duplicate period titles as desired.

Step 5 Click on Edit.

Step 6 Select Save to update your entries or Cancel to delete the changes to your entries. To return to the AIM II main menu, click Exit.

8.5.2 Delete

The Delete option allows you delete any duplicated period or Special period unless it is the last period supporting a Topic in the COI.

To delete a CMS period:

Step 1 Click on the existing CMS period that you would like to delete.

Step 2 Click on Options menu item and the Delete option. You will be asked to confirm each deletion. The entry will be deleted.
NOTE: You may not delete the only entry for a topic in the CMS.

Step 3 Continue to delete CMS periods in this manner.

Step 4 Select **Edit**.

Step 5 Select **Save** to update your entries or **Cancel** your entries. To return to the AIM II main menu, select **Exit**.

### 8.5.3 Toggle Page Break

The AIM II Software will automatically insert page breaks when the Print or Print Preview options are selected. The developer can create page breaks at different locations by using the **Toggle Page Break** option. When this option is selected, the period highlighted will start the next page and an asterisk in the No. Column will identify the top of the page.

**To insert page breaks into the CMS:**

- **Step 1** Click on the existing CMS period that you would like to appear as the first period of the next page.
- **Step 2** Click on **Options** menu item and the **Toggle Page Break** option. An asterisk will appear in the No. Column to indicate that this period will start on a new page.
- **Step 3** Continue to enter page breaks where desired.
- **Step 4** Select **Edit**.
- **Step 5** Select **Save** to update your entries or **Cancel** your entries. To return to the AIM II main menu, select **Exit**.

### 8.5.4 Output to Excel and Output to CeTARS

Selection of the **Output to Excel** option causes the software to prepare a Microsoft Excel Comma Separated Values file of the CMS which can be stored wherever desired.

Selection of the **Output to CeTARS** option causes the software to prepare a Text Document file of the CMS and a WinZip file containing the file which can be stored in the desired directory.
8.5.5 Print Preview

Selection of Print Preview will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- Previous - moves to the previous page.
- Next - moves to the next page.
- Find – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- Page _ of Page - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Accesses the page desired when the page number is typed in the first field and Enter is depressed.
- Actual Page - displays the actual page number, as shown on the page. Accesses the page desired when the page number is typed in the field and Enter is depressed.

The right and left mouse buttons allow you to zoom in and out by double clicking on the page. Double click the left mouse button to zoom in to a page and double click the right mouse button to zoom out.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

To print preview the CMS:

Step 1 From the Course Master Schedule (CMS) window; select the Options menu item and the Print Preview option.

Step 2 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.
Step 3  Click on the **OK** to print preview. The first page of the CMS is displayed, the *Master Schedule Summary Sheet (MSSS)*, in the Print Preview window. Use the Print Preview options as desired and when complete select the **Exit** menu item to return to the Course Master Schedule (CMS) window.

8.5.6 **Print**

When printing from the CMS module, the *Master Schedule Summary Sheet (MSSS)* will be the first part of the CMS output. It will not print with the CMS in any other document. The MSSS data will come from the data within the CMS and TCCD. The Date, Activity, Course Short Title, and CIN will be taken from the TCCD main screen. The Location data will list the sites selected in the TCCD. The summary data will automatically summarize the current CMS data. And the justification section will be taken from the *Justification* area, under the *Contents* menu item, of the CMS.

**To print the entire CMS:**

Step 1  Select the **Options** menu item and the **Print** option.

Step 2  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3  While the software is preparing the MSSS and CMS for print, you can select Cancel to terminate the print job. AIM will only print to the default printer selected in the Control Panel of your PC. Click on the **OK** button.

8.5.7 **Explain Flag**

The course is considered to be in Maintenance if it is a *non*-Rev 0 Change 0 Course and either:

1. A previous version of the Course exists at the current Revision, or
2. The course is in a Change 0 Revision Course, a previous version of this course exists in your database, and the course has an LP.

If these conditions are **NOT** met, the Course isn't considered to be in maintenance, and as such, no flags will be generated for added/deleted/modified items other than RRL items.
The Explain Flag allows you to view and print the maintenance record for the highlighted and flagged Period. The maintenance record states what type of maintenance action was performed to the item (added, modified, or deleted), the Revision and Change of the item, who performed the maintenance action (by login name), and when the maintenance action was performed. From the explanation the user can determine what maintenance actions are required in the CMS.

To read the maintenance record for a flagged Period:

Step 1 Click on the flagged item

Step 2 Select the Options menu item and the Explain Flag option. AIM II will open the Maintenance Record window for the item.

Step 3 Click on the Exit menu item to return to CMS window.

8.5.8 Remove Flag

The Remove Flag option can only be exercised by a user with Remove Flag privilege or by the AIM Administrator. The flags are used for review purposes and must be removed prior to approval of the course. The Remove Flag option will remove the flag and the maintenance record for the highlighted Period.

From within each module for training materials AIM II has the Remove Flag option that enables the removal of the flag for the highlighted item individually. Flags can also be removed for the entire course by selection of the Remove Flag option from the Course Select window Options menu item.

To remove a flag from a Period:

Step 1 Click on the flagged item

Step 2 Select the Options menu item and the Remove Flag option. AIM II will remove the flag and the associated maintenance record.

8.6 CMS CONTENTS

The CMS Contents menu item contains a Justification sub-menu item and, if developing a CNATT curriculum, an Instructor Computation Worksheet sub-menu item.
8.6.1 Master Schedule Summary Sheet (MSSS) Justification

Selecting the **Justification** sub-menu item opens a Styled Text Editor window. This Styled Text Editor field can be used to justify Lab, Special, and Practical Application (PA) period ratios for the entire course when the ratios are less than planned class size. The Justification appears when printing or previewing the CMS, on the first page, which is called the Master Schedule Summary (MSS). The MSS can only be printed from the CMS Module.

Example:  "The (3/1) ratio is used for aircraft periods because of the aircraft space restrictions that allow only three trainees at a time to perform APU turn up, with one instructor and one safety observer present. The (3/2) bottleneck is created because only one aircraft is available for training. The remaining three trainees are in a standby status waiting their turn to rotate through the bottleneck."

To add/edit Justification for the ratios of the course:

1. Click on the CMS **Contents** menu item and select the **Justification** sub-menu item.
2. Using the Styled Text Editor add/edit the text as necessary.
3. When complete select the **Edit** menu item and the **Save** sub-menu item.
4. Select the Exit menu item to return to the Course Master Schedule (CMS) window.

8.6.2 CNATT Instructor Computation Worksheet

The worksheet is available for CNATT curriculum development. When the sub-menu item is selected the software loads in a fresh copy of the template file into Microsoft Excel. This can be edited and saved wherever desired. It is NOT stored in the AIM database and each time the sub-menu item is selected the software loads a new, blank template. The sub-menu item is always available regardless of the status of the course.

To create an Instructor Computation Worksheet

1. Click on the CMS **Contents** menu item and select the **Instructor Computation Worksheet** sub-menu item. The software will open the Worksheet in Microsoft Excel.
2. Edit as required and save the worksheet to the desired location.
3. Exit the worksheet to return to the CMS.
8.7 CMS Events

The CMS Events Module allows the user to manage the CMS using training events instead of Topics and Periods. In the CMS Events Module a Period length is 60 minutes, this is not adjustable. The Total Periods column is a calculated entry based on the Num Periods, Students, Instructors, Bottleneck Students, and Bottleneck Instructors.

There is no restriction on the order in which events can be placed. The Events will be displayed in the order specified by the user, not necessarily in the order of the Topics within the COI. Events may also be resequenced, a warning will be given if an Event is out of sequence.

When creating a new Event, the user has the option of associating it to a Topic, the Topic association can be changed at any point. Theory and Lab Events must be associated with Topics.

Each Learning Site can have its own CMS, if a CMS has not been specifically created for a Learning Site, the default CMS will be used, the CMS for the CCMM is the default CMS.

Events can only be added and/or deleted within the CCMM CMS.

8.7.1 CMS Events Options

8.7.1.1 Add

To Add Events to the CMS complete the following steps:

Step 1 From the Options menu select Add.

Step 2 From the Units/Topics screen select the Topic that the Event will be associated with by either highlighting the Topic and selecting Select from the menu bar or double-clicking on the desired Topic, if there is no Topic associated with the Event select Exit.

Step 3 If a topic was selected then the Topic #, Event Title, Students, and Instructors columns will be filled in. If no Topic was selected the a blank line will be generated.

8.7.1.2 Add Missing Topics

To add missing Topics to the CMS select the Add Missing Topics option from the Options menu. All Topics not already included in the CMS will be added.
8.7.1.3 Delete

The Delete option is used to delete highlighted Topics. Highlight the desired Topic and select the Delete option from the Options menu.

8.7.1.4 Print Preview/Print

The Print Preview and Print options work as they do elsewhere in AIM, select Print Preview to preview the CMS in printed format. Select Print to begin printing of the CMS.

8.7.1.5 Explain Flag/Remove Flag

The Explain Flag and Remove Flag options work as they do elsewhere in AIM, select Explain Flag to see a brief explanation of the flag. Select Remove Flag to remove the flag.

8.7.2 CMS Events Columns

There are 11 columns on the CMS Events screen. Following is a brief description of each column.

- **Topic #:** The Topic # column designates the associated Topic number with the Event. Not all Events require Topic numbers.
- **Event Title:** The description or title of the Event, if associated with a Topic the default will be the Topic title.
- **Event Type:** There are 26 different Event Types to choose from, this column is a drop-down list with the different types listed.
- **Num Periods:** This is the number of periods require for the Event.
- **Students:** Standard number of students for the Event.
- **Instructors:** Standard number of instructors for the Event.
- **Bottleneck Students:** Number of students because of Bottleneck for the Event.
- **Bottleneck Instructors:** Number of instructors because of Bottleneck for the Event.
- **Total Periods:** Calculated based on Number of Students and Number of Instructors or Bottleneck Students and Bottleneck Instructors if present.
- **Justification:** Justification of a Bottleneck Event.
- **Flag:** Maintenance Flag indication column.
8.8 ON-LINE HELP

The help option allows you to go directly to the AIM II On-line Help Screen. This help option is a hypertext help tool that should allow you to navigate easily to find the information that you desire.

8.9 SUMMARY

An accurate CMS will show the correct student-to-instructor ratio and include any bottleneck ratios. It will show the curriculum hours accomplished and yield the correct number of instructor contact hours. The information put into the CMS here will automatically be carried over to the TCCD, LP and TG.
CHAPTER 9

TRAINING COURSE CONTROL DOCUMENT (TCCD) MODULE

9.0 TRAINING COURSE CONTROL DOCUMENT (TCCD) ............................................. 9-1
9.1 ELEMENTS OF A TCCD .................................................................................. 9-1
  9.1.1 Elements of TCCD Front Matter ............................................................ 9-1
  9.1.2 Elements of TCCD Annexes ..................................................................... 9-2
9.2 USING THE AIM II TCCD MODULE ............................................................. 9-2
  9.2.1 Overview of the AIM II TCCD Module .................................................. 9-3
9.3 SELECTING A TCCD .................................................................................. 9-4
9.4 TCCD CONTENTS ..................................................................................... 9-6
  9.4.1 Foreword ................................................................................................. 9-6
  9.4.2 Course Overview/Comments ................................................................ 9-7
  9.4.3 Supplying Trainee Data ........................................................................... 9-8
  9.4.4 Summary of Differences ........................................................................ 9-10
  9.4.5 Selecting a Learning Site ....................................................................... 9-11
    9.4.5.1 Identifying Resources for a Learning Site ...................................... 9-13
9.5 TCCD OPTIONS ............................................................................................. 9-16
  9.5.1 Lock and Unlock Options ...................................................................... 9-17
  9.5.2 Grant Privileges ..................................................................................... 9-19
  9.5.3 Course Option ........................................................................................ 9-19
    9.5.3.1 Use Events .................................................................................... 9-19
    9.5.3.2 CMS prints in next Documents .................................................... 9-19
    9.5.3.3 Course Approval ............................................................................ 9-19
  9.5.4 Print Preview and Print Options ............................................................ 9-20
  9.5.5 Central Site Options .............................................................................. 9-23
9.6 COURSE MAINTENANCE ................................................................................ 9-23
  9.6.1 Creating a Revision for a Course .......................................................... 9-23
  9.6.2 Creating a Change for a Course ........................................................... 9-24
9.6.3 Add a Later IETM Version ................................................................. 9-24
9.7 SUMMARY .......................................................................................... 9-25

(This Page Intentionally Left Blank)
The Training Course Control Document (TCCD) is a collection of products that express, in summary form, the content, structure, and essential management information for a course. You have already supplied most of the information for the TCCD while working through the AIM II Modules TPP, CTTL, LO, COI, and CMS. The TCCD is a consolidation of much of the information on a course into a single document. For CNATT curriculum refer to Appendix F to develop the TCCD.

9.1 ELEMENTS OF A TCCD

The TCCD consists of the following items:

- Front Matter
- Curriculum Outline of Instruction
- Annexes

9.1.1 Elements of TCCD Front Matter

The front matter of the TCCD contains:

- **Cover Page.** This information is copied from the TPP module.
- **Letter of Promulgation.** This is issued after successful course pilot. The AIM II Module reserves a place marker for the Letter of Promulgation.
- **Summary of Differences.** Copied from the TPP module for a Revision TPP or developed in the TCCD when creating a Change for a curriculum to identify the differences between the baseline curriculum and the Revision or Change.
- **Table of Contents.**
- **Foreword.** The foreword is not required but serves as a place to explain to reviewers any unique aspect of the course, which may not be apparent from the basic data.
- **Course Data.** Course data is copied from the TPP module and may be updated.
- **Trainee Data.** This data consists of personnel physical requirements, security clearances, obligated service, and NOBC/NEC earned.
- **Outline of Instruction.** Lists the Unit and Topic titles, hours and tenths of hours for class, lab, special and practical application periods.
- **Curriculum Outline of Instruction.** From the COI module
### 9.1.2 Elements of TCCD Annexes

- **Resource Requirements List (RRL).** The RRL is a composite listing of all the materials needed to conduct training. The RRL in the TCCD may be updated from the original RRL composed in the TPP module.

RRL database includes the following Resources:

<table>
<thead>
<tr>
<th>Category</th>
<th>Resources</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manpower</td>
<td>Maintenance Trainer</td>
</tr>
<tr>
<td>Funding</td>
<td>Miscellaneous Materials</td>
</tr>
<tr>
<td>Facility</td>
<td>Ordnance</td>
</tr>
<tr>
<td>Calibration</td>
<td>PC Simulation</td>
</tr>
<tr>
<td>Computers</td>
<td>Photographs</td>
</tr>
<tr>
<td>Consumables</td>
<td>Prefaulted</td>
</tr>
<tr>
<td>Equipment</td>
<td>Publications</td>
</tr>
<tr>
<td>Equipment Refurbshed</td>
<td>Slides</td>
</tr>
<tr>
<td>Films</td>
<td>Software</td>
</tr>
<tr>
<td>Hand Tools</td>
<td>Support Equipment</td>
</tr>
<tr>
<td>IETM</td>
<td>Test Equipment</td>
</tr>
<tr>
<td>IMI</td>
<td>Training Devices</td>
</tr>
<tr>
<td></td>
<td>Training Equipment</td>
</tr>
<tr>
<td></td>
<td>Training Material</td>
</tr>
<tr>
<td></td>
<td>Transparencies</td>
</tr>
<tr>
<td></td>
<td>VI Equipment</td>
</tr>
<tr>
<td></td>
<td>Video (Celluloid)</td>
</tr>
<tr>
<td></td>
<td>Wall Charts</td>
</tr>
</tbody>
</table>

- **Master Schedule Summary Sheet and Course Master Schedule.** See CMS Module.

### 9.2 USING THE AIM II TCCD MODULE

The AIM II TCCD Module provides the tools to produce a TCCD. The program will present a series of windows. These windows will have a menu across the top.

You select an option by highlighting the option with a mouse and clicking the left mouse button. Selecting an option from the menu will bring up windows, which will allow you to enter the data.
necessary to complete a TCD.
If you are working on a new TCCD, some of the fields presented may be blank. You must provide the appropriate information by either typing the information in the space or selecting from a series of drop-down menus. If you are working on a TCCD, which is in progress or completed, you can edit existing data and/or provide new data as necessary. Each window is explained in this User's Manual with instructions on how to fill in the necessary data.

On all forms where data is entered into grids/tables, Tab/Return moves the cursor from one row to the next, allowing you to enter data in all fields before saving the information to the database.

9.2.1 Overview of the AIM II TCCD Module

Each of the following steps is explained in further detail in this manual. These paragraphs are meant as a quick reference for getting around the software.

You can start a new TCCD by selecting the Course menu item and the Select sub-menu item from the AIM II main menu bar or by clicking on the "Select Course" icon. The Course Select window will open which contains a list of available courses. Click on the desired course and click on the Select menu item. The Course Select window will close and the AIM II window will contain the CIN of the course selected in the title bar.

Select the Document menu item and the Training Course Control Document (TCCD) sub-menu item or click on the TCCD icon. The TCCD window has data in the fields that you supplied in the TPP module. After completing or modifying the data in the window, you must select the Edit menu item and then the Save sub-menu item to save the changes. If you do not wish to save your changes, you can select Cancel. You must either save or cancel before proceeding further. From this TCCD main window you can select the Options or Contents menu item to continue developing the TCCD.

To identify where the proposed course will be taught, you will select the Contents menu item and the Learning Sites sub-menu item. You will be provided with a "Learning Site" window. Click on the desired site, select the Options menu item and the Modify option to edit the Course Data copied from the TPP: the Course Data Processing (CDP) code, course length, class minimum and maximum capacity, class convening, student throughput for each site, site considerations, and RRL data.

After entering the data for the Course Data window, select the RRL menu item to access the Learning Site RRL for the selected Learning Site. From here you can select RRL Resources menu item and the RRL type/items to be used in the course. Selecting Resources also allows you to update manpower, funding, and facility data.
The TCCD window **Options** menu item also includes **Lock**, **Unlock**, **Grant Privileges**, **Print Preview** and **Print** options. The **Contents** menu item includes the **Foreword** and **Course Overview/Comments**, **Trainee Data**, **Summary of Differences** and **Learning Sites** sub-menu items. **Course Overview/Comments**, **Summary of Differences** (for revisions) and **Learning Sites** data will be the same data entered in the TPP module and are editable.

When you have finished providing data for the TCCD, you must select the **Edit** menu item and the **Save** sub-menu item to save your data to the database. You can also **Cancel** your input from the **Edit** menu item. You can lock your TCCD from the **Options** menu.

### 9.3 SELECTING A TCCD

There are four different ways to access a TCCD window after the course has been selected from the Course Select menu:

1. From the AIM II main menu select the **Document** menu item and the **Training Course Control Document (TCCD)** sub-menu item.
2. Click on the TCCD icon.
3. From the course tree structure click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TCCD element in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.
4. From the course tree structure click on the TCCD folder, select the **Options** menu item and the **GoTo** sub-menu item. Opening the TCCD folder can provide Summary or Note data on the right hand portion of the course tree grid if the **View** menu sub-items (**Note** or **Summary**) have been checked. Summary data includes all the information contained in the TCCD window. Note data contains Personal and/or Private Notes recorded by developers.

If the TCCD window cover page is complete and you desire to work on an element within the TCCD you can either select the element from the **Contents** menu item in the TCCD window or double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the element desired and can exercise **Options** menu sub-items (**Edit Note** and **GoTo**) and **View** menu sub-items (**Note** and **Summary**).
The main window of the TCCD that you selected will be presented, as shown in Figure 9-1. You can click on and edit all of the fields in the window except Change, Rev, Status, and CNATT ERL fields. To save the changes, select the Edit menu item and the Save sub-menu item.

Figure 9-1. TCCD Window
To edit the TCCD from the TCCD Main Window:

Step 1 Enter the new/updated information. The Instructor/Support Manning, Trainee Data, and Foreword will be blank the first time that you enter the TCCD.

**NOTE:** Data on the Cover Page of the TCCD that is shared with the TPP will be updated in the TPP when edited as long as the TPP is not approved.

Step 2 Click on **Edit**.

Step 3 Select **Save**.

If you do not want to save the TCCD information that you have entered, you can select **Cancel**.

### 9.4 TCCD CONTENTS

After selecting a TCCD, you can edit the TCCD **Contents**. The elements of the TCCD contents are:
- **Foreword**
- **Course Overview/Comments**
- **Trainee data**
- **Summary of Differences**
- **Learning Sites**

#### 9.4.1 Foreword

The foreword is not required but is a place to explain to reviewers any unique aspect of the course, which may not be apparent from the basic data.

There are three different ways to access the TCCD Course Foreword window after selecting the Course from the Course Select window:

1. Select the **Document** menu item and the **Training Course Control Document (TCCD)** sub-menu item or click on the TCCD icon to open the TCCD window. From the TCCD window select the **Contents** menu item and the **Foreword** sub-menu item.
2. From the course tree structure, double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the Foreword folder and can exercise Options menu sub-items (Edit Note and GoTo) and View menu sub-items (Note and Summary).

3. From the course tree structure click on the TCCD folder. This will identify the elements of the TCCD in the upper right hand grid. Either double-click on the Foreword folder in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.

To enter the TCCD Foreword:

Step 1 The TCCD Course Foreword window allows you to select the Options menu item and the Import Text File option or type/edit the Foreword directly.

Step 2 Edit the foreword as necessary

Step 3 Click on Edit.

Step 4 Select Save to update your entries or Cancel to delete the changes to your entries. To return to the TCCD main window or the course tree, click on Exit.

9.4.2 Course Overview/Comments

In the TPP you supplied this information. For a new course it was a description of the skills and knowledge to be attained. The overview will help the Training Agency see what the course will actually contain.

There are three different ways to access the TCCD Course Overview/Comments window after selecting the Course from the Course Select window:

1. Select the Document menu item and the Training Course Control Document (TCCD) sub-menu item or click on the TCCD icon to open the TCCD window. From the TCCD window select the Contents menu item and the Course Overview/Comments sub-menu item.

2. From the course tree structure, double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the Course Overview/Comments folder and can exercise Options menu sub-items (Edit Note and GoTo) and View menu sub-items (Note and Summary).
3. From the course tree structure click on the TCCD folder. This will identify the elements of the TCCD in the upper right hand grid. Either double-click on the Course Overview/Comments folder in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.

**To enter the TCCD Course Overview/Comments:**

**Step 1** The TCCD Course Overview/Comments window allows you to select the **Options** menu item and the **Import Text File** option or type/edit the Course Overview/Comments directly.

**Step 2** Edit the Course Overview/Comments as necessary

**Step 3** Click on **Edit**.

**Step 4** Select **Save** to update your entries or **Cancel** to delete the changes to your entries. To return to the TCCD main window or the course tree, click on **Exit**.

**9.4.3 Supplying Trainee Data**

The Trainee Data consists of personnel physical requirements, security clearances, obligated service, and NOBC/NEC/MOS earned, *Figure 9-2.*
To enter trainee data:

Step 1   Perform one of the following to identify the trainee data required for the course:
  a. From the TCCD window, select the Contents menu item and the Trainee Data sub-menu item. The Trainee Data window will open.
  b. From the course structure tree click on the TCC folder and expand the tree by clicking on the ‘+’ block. Click on the Trainee Data folder and select the Options menu item and the GoTo option or double-click on the Trainee Data folder on the upper right hand grid.

Use the TAB key to advance forward through the fields. To go backwards through the fields, press Shift + Tab. You can also use the arrow keys.

Step 2   Enter the Personnel Physical requirements.

Step 3   Enter the Security Clearances.

Step 4   Enter the Obligated Service.
Step 5 Enter the NOBC/NEC.

Step 6 When you have completed entering the data, select the Edit menu item and the Save sub-menu item to update your entries or Cancel to delete the changes to your entries.

Step 7 To return to the TCCD main or the course tree, click on Exit.

9.4.4 Summary of Differences

The Summary of Differences sub-menu item is used when you are developing a TCCD for a revision or a change to a course. It allows you to summarize the differences between the current baseline of the TCCD, LP, and TG and the planned revision or change of the course.

To enter Summary of Differences:

Step 1 Open the TCCD Summary of Differences window by performing one of the following:
   a. With the TCCD folder open in the Course Tree Structure; double click on the Summary of Differences folder in the upper right hand panel,
   b. Expand the TCCD and open the Summary of Differences folder in the Course Tree Structure and click on the Go button on the toolbar,
   c. After selecting the course, access the TCCD window by either selecting the Document menu item and the Training Course Control Document (TCCD) sub-menu item or click on the TCCD icon. Select the Contents menu item and the Summary of Differences sub-menu item.

Step 2 From the Styled Text Editor add/edit the desired text.

Step 3 After entering/modifying the text you can choose one of two ways to exit:
   First Method:
   - Select the Edit menu bar item.
   - Select Save to save your text and/or select Cancel to delete your new data entries and return to the Styled Text Editor window.
   - Select the Exit menu bar item. AIM II will return you to the TCCD window or the Course Tree Structure.
Second Method:
- Select the **Exit** menu bar item. If the text has been entered/modified, AIM II will prompt, *Edit Text has been modified. Would you like to save new data?*

If there is no new data, selecting this item will return you to the TCCD main window or the Course Tree Structure.

### 9.4.5 Selecting a Learning Site

When completing the TCCD, select all Learning Sites where the course will be taught. After selecting a Learning Site and saving it to the database, you can update information that you supplied by selecting the **Modify/View** option if necessary.

There are three different ways to access the Learning Site window, *Figure 9-3*, of the TCCD after the TCCD window has been selected:

1. Select the **Document** menu item and the **Training Course Control Document (TCCD)** sub-menu item or click on the TCCD icon to open the TCCD window. From the TCCD window select the **Contents** menu item and the **Learning Sites** sub-menu item.
2. Double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the Learning Sites folder and can exercise **Options** menu sub-items (**Edit Note** and **GoTo**) and **View** menu sub-items (**Note** and **Summary**).
3. From the course tree structure click on the TCCD folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TCCD element in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.

---

**NOTE:** Learning Sites are added to the list through the AIM Utilities program. If you do not see the Learning Site that you want, it can be added through Site Administration in the Utilities module.
Figure 9-3. Learning Site Window

NOTE: If only the selected Learning Site(s) appear in the Learning Sites window select the Options menu item and click on the Show Selected Sites Only option to remove the check mark. All sites available from the Learning Site Utility will appear for selection.

Step 1 Select the Options menu item and the Show Selected Sites Only if it has a check mark next to it to view all the Learning Sites in the Learning Site Utility. Click on the desired Learning Site.

Step 2 Select the Options menu item and the Select option. The software will ask if you want to use the CCMM data as default.

Step 3 Select Yes or No as appropriate. If yes was selected you will be asked if you would like to update the database with the default data. If you selected Yes an "X" will appear in the Sel column next to the site that you selected to indicate that it should be included in the TPP and the Course Data and RRL data entered for the CCMM will be reflected in the new site selected.
Step 4 Using the mouse, click on the CDP field. Type the Course Data Processing code. **After each entry press the TAB key to advance to the next field.**

Step 5 Modify the course length in days, which includes weekends.

Step 6 Modify the minimum and maximum class capacity. When changing the Max Class Capacity you will be asked if you want to update all CMS periods with the new Instructor/Student ratio for the course.

Step 7 Modify the number of Class Convenings Required per year for the selected site.

Step 8 Modify the annual student throughput, as necessary.

**NOTE:** The average on board is automatically calculated.

Use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. Once you are satisfied with the Learning Site summary data, as you have entered it, you must **Save** it.

Step 9 Modify Site Consideration field as necessary.

Step 10 Instructional Days is not a required field; therefore the **TAB** key skips this field. To modify click on the field and edit as necessary.

Step 11 Select the **Edit** menu item and the **Save** sub-menu item.

If you do not want to save the Learning Site information that you have entered, you can select **Cancel**.

Step 12 To return to the Learning Site window, click on **Exit**.

**NOTE:** If you need to change the site identified as CCMM click on the desired site and select the **Options** menu item and the **Select CCMM** option. AIM will ask for confirmation before changing who is designated as CCMM.

### 9.4.5.1 Identifying Resources for a Learning Site

For each Learning Site selected, provide a best estimate of the known and anticipated resources necessary to implement the training in the TPP Resource Requirements List (RRL). In the TCCD, you have an opportunity to complete the data. If this is a new development, you may use this opportunity to update the resources needed to conduct the course.
To modify the Resources for a Learning Site:

**Step 1**
Select the Learning Site desired (Refer to paragraph 9.4.3). The site must have an "X" in the Sel column, which indicates that it has been selected.

**Step 2**
Perform one of the following to select the resources of a Learning Site:

a. From the Learning Site window select the **Options** menu item and the **Modify** option. This will open the Course Data window. The Course data can be edited if required. An additional field, not present in the TPP, for Instructional Days is included to note how many days the course requires less weekends and holidays. If the Course data has been edited select the **Edit** menu item and the **Save** sub-menu item. When changing the Max Class Capacity you will be asked if you want to update all CMS periods with the new Instructor/Student ratio for the course.

b. Select the **RRL** menu item. This will open the Learning Site RRL window. Select **Resources** from the menu. This will provide a drop down menu of all the RRL types available as well as Manpower, Funding, and Facility data.

c. From the course tree structure expand the TCCD and Learning Sites folders and click on the desired sites. The upper right hand portion of the grid will contain the Resource folders.

**NOTE:** The procedure for selecting RRL items in the TCCD is identical to the procedure used in the TPP. For a detailed description of this procedure, refer to the TPP chapter of this manual.

**NOTE:** From the Learning Site RRL window, after you have selected **Resources**, you can begin to select additional items for the RRL. The Manpower, Funding and Facilities data were copied from the TPP and do not require additional input. They are not part of the TCCD.

**Step 3**
Perform one of the following to identify the resources required for the Learning Site:

a. From the Learning Site RRL window **Resources** menu click on any discrete resource type from the drop down menu listed below Facility.

b. From the course structure tree click on the TCC folder and expand the tree by clicking on the ‘+’ block. Click on the Learning Sites folder and expand the tree by clicking on the ‘+’ block. Click on the folder for the desired Learning Site and expand the tree by clicking on the ‘+’ block. Open the RRL folder and select the **Options** menu item and the **GoTo** option or double-click on the RRL folder on the upper right hand grid.

The items contained in the Site RRL are reflected in the bottom grid.
Step 4  Use your mouse to highlight the item in the Site RRL.

Step 5  Select the **Options** menu item and the **Select Course RRL** option to select the item for your Course, or double click on the Site RRL Identifier and the item will move to the Course RRL.

Step 6  Repeat Step 4 for each additional resource items required of the type selected.

Step 7  Enter the quantity required for each item selected from the Site RRL.

Step 8  You must save your entries before you can select another type of resource. Select the **Edit** menu item and the **Save** sub-menu item.

Step 9  To add more items from a different type of resource, repeat Steps 1 through 6. To return to the Course Data window or course tree, click on **Exit**.

Step 10 To return to the Learning Site window from the Course Data window, click on **Exit**.

**To add additional Learning Sites:**

**NOTE:** If only the selected Learning Site(s) appear in the Learning Sites window select the **Options** menu item and click on the **Show Selected Sites Only** option to remove the check mark. All sites available from the Learning Site Utility will appear for selection.

Step 1  From the Learning Sites window, highlight the desired Learning Site, select the **Options** menu item, and select the **Select Site** option. AIM will ask if you want to use the CCMM data as default. Perform one of the following:

- Click on **Yes** to copy the CCMM Course Data, RRL Manpower and Funding data to the data fields of the site highlighted.
- Click on **No** to enter Course Data and Resources in the blank fields provided.
- Click on **Cancel** to terminate the **Select Site** option.

Step 2  If you selected **Yes** AIM will ask if you want to update the database with the default data now. If you want to create a separate RRL for each site with the same information as the CCMM click on **Yes**, if not click on **No**.

Step 3  After answering the prompts, enter the CDP for the selected site and modify the Course Data and Resources as necessary.
To change the CCMM to another selected site:

Step 1  Select the **Contents** menu item on the TCCD main window, and click on the **Learning Sites** sub-menu item. A list of Learning Sites will appear.

**NOTE:** Learning Sites are added to the list through the AIM I Utilities module. If you do not see the Learning Site that you want to select, your AIM Administrator can add them.

Step 2  Highlight/click on the site desired for CCMM.

Step 3  Select the **Options** menu item and the **Select CCMM** option.

Step 4  AIM will prompt; *This Site is selected as the new CCMM. CCMM data from old CCMM Site will replace this Site's data. Continue?*

Step 5  Click on **Yes** to select the highlighted site as the new CCMM. Click on **No** to terminate the option.

Step 6  If you selected a new CCMM, enter the CDP for the selected site and modify the course and RRL data fields as necessary. Refer to the previously outlined steps for modifying Learning Site information.

To unselect a Learning Site, highlight the Learning Site no longer required, and select the **Options** menu item and the **Unselect** option. AIM will unselect the Learning Site, the course data, and all related RRL data.

When you have completed the Learning Site modifications, select the Learning Sites window **Exit** menu item, save your entries, and return to the TCCD window.

### 9.5 TCCD OPTIONS

After selecting a TCCD, you can access the TCCD **Options**. The elements of the TCCD options are:

- **Lock**
- **Unlock**
- **Grant Privileges**
- **Course Options**
- **Print Preview**
- **Print**
9.5.1 Lock and Unlock Options

When the TCCD is locked for the first time, the developer can proceed to the Lesson Plan (LP). When the LP cover page is initially saved AIM II will create a lesson plan based on the structure established in the Curriculum Outline of Instruction (COI). The developer can unlock and edit the TCCD as long as no one is logged into the LP or Trainee Guide (TG).

Prior to the LP being developed, the COI option of Copy Unit/Topic from another course will only allow management materials from the CTTL through the COI to be copied. Once the software has developed the LP, the Copy Unit/Topic from another course option will allow all materials from the CTTL through the TG to be copied from another course.

The developer can resequence Units and Topics in the COI after the LP has been created, and these changes will be carried forward to the LP. However, resequencing of the EOs within a Topic will not resequence the Discussion Points in the LP.

There are four different ways to access a TCCD window after the course has been selected from the Course Select menu:

1. From the AIM II main menu select the Document menu item and the Training Course Control Document (TCCD) sub-menu item.
2. Click on the TCCD icon.
3. From the course tree structure, click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TCCD element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.
4. From the course tree structure click on the TCCD folder, select the Options menu item and the GoTo sub-menu item. Opening the TCCD folder can provide Summary or Note data on the right hand portion of the course tree grid if the View menu sub-items (Note or Summary) have been checked. Summary data includes; CIN, Rev, Change, Title, AIM II Status, and Date obtained from the information contained in the TPP window. Note data contains Personal and/or Private Notes recorded by developers.

To Lock the TCCD:

Step 1  Select the TCCD window.

Step 2  Select the Options menu item and the Lock option. The Status field will change from Complete to Locked.
Step 3  Select the Exit menu item to return to the AIM II main menu and course tree structure.

To Unlock the TCCD:

Step 1  Select the TCCD window.

Step 2  Select the Options menu item and the Unlock option. The Status field will change from Locked to Complete.

Step 3  Select the Exit menu item to return to the AIM II main menu and course tree structure.

9.5.2  Grant Privileges

The Grant Privileges option can be used by the developing AIM User to assign Edit, Lock and Grant privilege levels to other AIM Users. It can also be used by an AIM Administrator to assign the same privilege levels plus Approve, Remove Flag, Clear In Use, and Maintain/Delete Course to AIM Users.

9.5.3  Course Options

The Course Options option displays the dialog box below and is used to select the following CMS options:

9.5.3.1  Use Events

The Use Events option is to use Events vice Topics in the CMS, for a complete explanation of this feature refer to the CMS section of this manual.

9.5.3.2  CMS prints in next Documents

Check boxes are provided to select whether to print the CMS in the TCCD and the TG.

9.5.3.3  Course Approval

A check box is provided to select ignoring the CMS once the course has been Approved.
9.5.4 Print Preview and Print Options

After selecting a Course, you can print or preview the TCCD using the TCCD window Option menu item. Printing and previewing the entire TCCD can also be accomplished by opening the TCCD folder in the course tree structure, selecting the Options menu item and the Preview/Print options.

The TCCD window Print Options are:

- **Print Preview** - View TCCD of All Sites or View TCCD of Selected Site
- **Print** - Print TCCD of All Sites or Print TCCD of Selected Site

Print Preview of a TCCD

Selection of Print Preview/Print and either of the sub-menu items will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
• Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting **OK** will present the default printer selected. Selecting **OK** from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- **Options** - contains the options to **Print** or **Save to PDF**. **Print** opens the Print window, which allows you to print a page, range of pages, the whole document, print to file, and number of copies. **Save to PDF** saves the document as a PDF file to the desired location.
- **Go To** - moves to the previous, next, first, last, or desired page.
- **Exit** - returns to the TCCD window.
- **Help** - provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- **Previous** - moves to the previous page.
- **Next** - moves to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Access the page desired by typing in the page number in the first field and depressing **Enter**.
- **Actual Page** - displays the actual page number, as shown on the page. Access the page desired by typing in the page number in the field and depressing **Enter**.

The right and left mouse buttons allow you to zoom in and out by double clicking on the page and allows you to view multiple pages. Double click the left mouse button to zoom in to a single page display and double click the right mouse button to zoom out.

Bellow the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

**To print preview all sites:**

Step 1 Select the **Options** menu item and the **Print Preview** option.

Step 2 Select the **View TCCD of All Sites** sub-menu item.

Step 3 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the **OK** button and AIM will prepare the TCCD for print preview and display the first page of the TCCD in the window.
Step 3  Exercise the Print Preview options noted above and when completed select the Exit menu item to return to the TCCD window.

**To print preview selected sites:**

Step 1  Select the Options menu item and the Print Preview option.

Step 2  Select the View TCCD of Selected Site sub-menu item.

Step 3  Double click on the desired Learning Site for print preview.

Step 4  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the OK button and AIM will prepare the TCCD for print preview and display the first page of the TCCD in the window.

Step 5  Exercise the Print Preview option noted above, as desired and when complete select the Exit menu item to return to the TCCD window.

**To print all sites:**

Step 1  Select the Options menu item and the Print option.

Step 2  Select the Print TCCD of All Sites sub-menu item.

Step 3  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the OK button AIM will open the Print window where you can select the printer desired.

Step 4  After the printer selection has been made click on the OK button. AIM will prepare the TCCD for printing and send the printout to the printer.

**To print selected sites:**

Step 1  Select the Options menu item and the Print option.

Step 2  Select the Print TCCD of Selected Site sub-menu item.
Step 3 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the **OK** button AIM will open the Print window where you can select the printer desired.

Step 4 Highlight the desired site and click on the **Select** menu item for print. AIM will open the Print window where you can select the printer desired.

Step 5 After the printer selection has been made click on the **OK** button. AIM will prepare the TCCD for printing and send the printout to the printer.

### 9.5.4 Central Site Options

For Central Site implementations there are two additional options, "Lock for Review" and "Unlock for Review". These two options work as a toggle to allow the Locking/Unlocking of the TCCD. When Locked only Curriculum Manager HQs and AIM Administrators can edit the TCCD.

### 9.6 COURSE MAINTENANCE

After the AIM Administrator has approved the Course (TPP through TG), a Revision or a Change can be created for the Course. When required, you can initiate a Change or Revision by performing the following.

#### 9.6.1 Creating a Revision for a Course

**To create a revision:**

When a Revision is created for a course in the AIM II database, the Course must be Approved before it can be maintained.

Step 1 From the AIM II window; select the **Course** menu item and the **Select Course** sub-menu item.

Step 2 From the Course Select window highlight the Course that you want to revise and select the **Options** menu item and the **Maintain/Revision** option.

Step 3 At the prompt "Are you sure you want to create a Revision for this Course?" click on the "**Yes**" button to proceed or the "**No**" button to return to the Course Select
Step 4 At the prompt "Copy LP/TG information with Course?" click on the "Yes" button to copy the entire LP/TG of the current baseline for the revision or click on "No" to copy the approved course less the user developed Discussion Points (DPs) and Related Instructor Activities (RIAs).

**NOTE:** If the LP/TG information is not copied, the Instruction Sheets, developed for the baseline course, are available for selection for the RIAs when developing the new LP.

Step 5 After AIM II creates the revision for the course, it will return you to the Course Select window and the revision created will be highlighted. Click on the **Select** menu item and AIM II will return you to the AIM II menu.

### 9.6.2 Creating a Change for a Course

**To create a change:**

When a Change is created the course must be approved before it can be maintained.

Step 1 Select the AIM II **Course** menu item and the **Select** sub-menu item.

Step 2 From the Course Select window highlight the approved course that requires maintenance and select the **Options** menu item and the **Maintain** option.

Step 3 Select the **Change** sub-menu item. AIM II will create a change for the course by copying the approved course. When completed the next sequential change to the course will be identified in the Course Select menu. Highlight the Change, click on the **Select** menu item, and AIM II will return you to the AIM II menu.

### 9.6.3 Add a Later IETM Version

A later version of IETM for the course can be added during the development of a course or during Maintenance.

**To add a later version of an IETM to a Learning Site RRL in the TCCD:**

Step 1 Select the **Course** menu item and the **Select** sub-menu item.

Step 2 Highlight the desired course and click on the **Select** menu item.
Step 3 From the AIM main menu select the Document men item and the Training Course Control Document (TCCD) sub-menu item.

Step 4 From the TCCD cover page select the Options menu item and the Unlock option.

Step 5 Select the Contents menu item and the Learning Sites sub-menu item.

Step 6 From the Learning Site window, click on the desired site and select the Options menu item and the Modify/View option.

Step 7 From the Course Data window select the RRL menu item.

Step 8 From the Learning Site RRL window click on the Resources menu item and the IETM sub-menu item.

Step 9 Click on the new IETM identifier in the Site RRL (bottom pane) and select the Options menu item and the Select Later IETM option.

Step 10 When prompted with "During the Select Later IETM process all RIA/TG Sheets will be updated to reflect the use of the new IETM. These changes will be saved now and you will not be able to undo this action. Continue?" click on the Yes button. AIM will flag the updated RIAs and TG Sheets with System Flags to indicate the reference has been updated to a later version IETM and the IETM has been modified or deleted.

Step 11 Exit to the TCCD cover page select the Options menu item and the Lock option. Select the Exit menu item to return to the AIM main menu.

9.7 SUMMARY

The TCCD is a life cycle document that consists primarily of other documents created to support a course of instruction. AIM II pulls together these documents, enabling you to utilize previously supplied data and only requiring you to provide Foreword and Course Overview information.

The TCCD Module is the basis of the Lesson Plan and Trainee Guide. Remember that the TCCD must be locked prior to working on the LP or TG, and that all RRL items, that you will be able to select from, must first be selected in the TCCD Module.
# CHAPTER 10

**LESSON PLAN (LP) MODULE**

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.0</td>
<td>LESSON PLAN</td>
<td>10-1</td>
</tr>
<tr>
<td>10.1</td>
<td>INTRODUCTION</td>
<td>10-1</td>
</tr>
<tr>
<td>10.1.1</td>
<td>Relationship Between the LP and the TCCD</td>
<td>10-3</td>
</tr>
<tr>
<td>10.1.2</td>
<td>Relationship Between the LP and TG</td>
<td>10-3</td>
</tr>
<tr>
<td>10.1.3</td>
<td>LP Status Levels and Privileges</td>
<td>10-4</td>
</tr>
<tr>
<td>10.2</td>
<td>GETTING STARTED</td>
<td>10-4</td>
</tr>
<tr>
<td>10.3</td>
<td>LESSON PLAN COVER PAGE</td>
<td>10-5</td>
</tr>
<tr>
<td>10.3.1</td>
<td>Lesson Plan Window Options Menu Item</td>
<td>10-6</td>
</tr>
<tr>
<td>10.3.1.1</td>
<td>Spell Check</td>
<td>10-6</td>
</tr>
<tr>
<td>10.3.1.2</td>
<td>Grant Privileges</td>
<td>10-6</td>
</tr>
<tr>
<td>10.3.1.3</td>
<td>Specify Volume Breaks</td>
<td>10-7</td>
</tr>
<tr>
<td>10.3.1.4</td>
<td>Print Preview</td>
<td>10-7</td>
</tr>
<tr>
<td>10.3.1.5</td>
<td>Print</td>
<td>10-8</td>
</tr>
<tr>
<td>10.3.2</td>
<td>Lesson Plan Window Contents Menu Item</td>
<td>10-9</td>
</tr>
<tr>
<td>10.3.2.1</td>
<td>Safety/Hazard Awareness Notice Contents Menu Sub-item</td>
<td>10-9</td>
</tr>
<tr>
<td>10.3.2.2</td>
<td>Topic Time</td>
<td>10-9</td>
</tr>
<tr>
<td>10.3.2.3</td>
<td>SCORM Metadata (Course)</td>
<td>10-9</td>
</tr>
<tr>
<td>10.3.2.4</td>
<td>Units/Topics Window</td>
<td>10-11</td>
</tr>
<tr>
<td>10.3.2.4.1</td>
<td>Entering Trainee Preparation Materials</td>
<td>10-12</td>
</tr>
<tr>
<td>10.3.2.4.2</td>
<td>Entering Instructor Preparation Materials</td>
<td>10-13</td>
</tr>
<tr>
<td>10.3.2.4.3</td>
<td>SCORM Metadata (Topic)</td>
<td>10-15</td>
</tr>
<tr>
<td>10.3.2.4.4</td>
<td>Discussion Point/Related Instructor Activity (DP/RIA) Pages</td>
<td>10-15</td>
</tr>
<tr>
<td>10.3.2.4.5</td>
<td>Print Preview/Print a Unit or Topic</td>
<td>10-31</td>
</tr>
<tr>
<td>10.4</td>
<td>SUMMARY</td>
<td>10-32</td>
</tr>
</tbody>
</table>
10.0 LESSON PLAN

The AIM II Lesson Plan (LP) module will assist you in building an actual LP that will be used in the classroom. As you create an LP, you will be defining an intricate network of relationships among all of the elements of the associated training materials.

10.1 INTRODUCTION

In creating an LP, you will be establishing relationships between:

- Resource Requirements List (RRL) items, Related Instructor Activities (RIAs), and Unit Pages
- Discussion Points (DPs) and Enabling Objectives (EOs)
- Instruction Sheets and the RRL

Because AIM II stores the relationships that you establish, the need for elaborate paper trails is greatly reduced. AIM II also reduces the need for extensive word processing or retyping of existing material since it generates the formatting and some of the basic texts.

The heart of the LP lies in the Discussion Demonstration Activity (DDA) pages, which contain the Discussion Points (DPs) and Related Instructor Activities (RIAs). The LP is designed to provide specific definition and direction to the instructor on EOs, equipment, and instructional media requirements and on the conduct of training. Proper development of the LP is extremely important since the LP will serve as the instructor’s primary teaching aid. Teaching techniques, methods, exercises, and applications that will enhance the learning process should all be included in the LP.

The LP module of AIM II contains the tools to create and sequence the DPs and to form the foundation for Trainee Guide (TG) sheets.

Elements of the LP include the following:

- Front Matter
- Cover Page (optional)
- Title Page
- Change Record
- Table of Contents
- Security Awareness Notice
- Safety/Hazard Awareness Notice
- Terminal Objectives
- Units and Lesson Topics
• Topic pages
  o EOs
  o Trainee Preparation Material
  o Instructor Preparation Material
  o Topic Time
• DDA pages
  o DPs
  o RIAs
• Trainee Guide Answer Sheets

The capabilities of the LP module enable you to create the following:
• Safety/Hazard Awareness Notice
• Topic Trainee Preparation Material requirements
  o Support Materials (identification of Instruction sheets and trainee assignment directions for the instructor)
  o Reference Publications (identification of RRL documentation and trainee assignment directions for the instructor)
• Topic Instructor Preparation Material annotation
  o Reference Publications cited in the Topic, and
  o Training Materials Required
• DPs to outline the EOs
  o Notes, Cautions, and Warnings
  o RIAs to support the DPs
    ➢ Identification of RRL items and directions for the instructor

AIM II will automatically insert a DP for each EO and add Introduction, Summary and Review, Assignment, and Application DPs for each Topic.

The Lesson Plan:
• Provides specific definition and direction to the instructor on training objectives, equipment and support material requirements, and course conduct
• Programs the use of all other training materials
• Contains LOs that reflect the skills and knowledge to be attained upon successful completion of each Topic.
• Provides an outline of instructional materials to be taught in a logical and efficient manner
• Provides specific equipment and support material requirements, and guidance for conducting the course

The Change Record keeps an account of the person who physically entered a change package into a curriculum. Since the purpose of the Change Record is to record the entry of changes into binders that hold the curriculum, AIM II will automatically generate a blank form for that use.
The Table of Contents is automatically generated by AIM II. The Table of Contents lists the titles and page numbers of the Front Matter, Units/Topics, and Trainee Guide Answer Sheets in the LP.

Since changes made to the curriculum in the LP module do not involve the structure of the course, the table of contents will change only if you unlock the Training Course Control Document (TCCD) and change the structure in the Curriculum Outline of Instruction (COI) module. In such cases, AIM II will generate a new Table of Contents based on the new structure.

Multiple users can edit the LP/TG concurrently. A user can edit only one Topic/Instruction Sheet at a time.

10.1.1 Relationship Between the LP and the TCCD

The TCCD module contains the structural features of a curriculum in the COI, such as the design and structure of the Units, Topics, and EOs.

The LP module contains the tools to create and sequence the DPs for each Unit/Topic within the curriculum in the order desired for presentation. Links are established between the DPs in the LP module and the EOs in the TCCD module to provide the capability for AIM II to flag (X) items that have undergone maintenance actions once the course is approved. Also, the paper-based LP can be printed for use from the LP module.

As with any system that has a hierarchy of materials, it is recommended that you complete as much of your course as possible before beginning the LP. Changes to the structure of a course have drastic impacts on the LP.

Where needed, the ability to add Notes, Cautions, and Warnings is in AIM II and documented in this User's Manual. However, the best way to avoid a mishap is to conscientiously apply sound curriculum development techniques when constructing training materials. Build the foundations solidly before proceeding to the next step.

10.1.2 Relationship Between the LP and the TG

Just as an LP must first be outlined in the COI module, the TG instruction sheets must first be defined in the LP.

When an instruction sheet is selected in a RIA, a TG is created. As you create RIAs, you will select TG sheets as materials for use. You will define the type of TG sheet and its place in the presentation of the Unit/Topic material. This action will generate a TG sheet sequentially numbered in the TG. Development of the TG sheets is accomplished from the TG Module.
10.1.3 LP Status Levels and Privileges

Status levels and privileges are assigned to the Course and LP/TG in order to provide a level of administrative security. Privileges minimize unauthorized use of the system. Status levels limit the types of actions that can be performed on an LP. Examples of privileges include Edit, Lock/Unlock, Grant, Remove Flag, and Clear In Use. As a developer/maintainer, you must have at least Edit privilege to work in the LP.

Because of the intrinsic relationship between the TCCD and the LP/TG, the privilege you have for a Course will be the privilege of the LP/TG. The AIM Administrator can grant you privilege to access and work on the LP/TG from the Admin Utility.

If the course development is complete (the TCCD is locked), your LP will have all the necessary training elements in the correct order; but there can be instances when you will need to unlock the TCCD and add or delete Units/EOs and RRL items.

10.2 GETTING STARTED

There are three different ways to access a Lesson Plan window after the course has been selected from the Course Select menu:

1. From the AIM II main menu select the Document menu item and the Lesson Plan (LP) sub-menu item.
2. Click on the LP icon.
3. From the course tree structure double-click on the LP/TG or click on the “+” to expand the tree, click on the LP folder, and select the Options menu item and the GoTo sub-menu item. Opening the LP folder can provide Summary or Note data on the right hand portion of the course tree grid if the View menu sub-items (Note or Summary) have been checked. Summary data includes; CIN, Rev, Change, Title, and Status from the LP window. Note data contains Personal and/or Private Notes recorded by developers.

If the Lesson Plan window is complete and you desire to work on an element within the LP you can either:

1. Select the element from the Contents menu item in the Lesson Plan window (Safety/Hazard Awareness Notice, SCORM Metadata or Units), or
2. Double-click on the LP/TG folder in the course tree structure. Double-clicking the LP/TG folder or clicking on the “+” box next to the LP/TG will expand the tree information to include LP, TG, and Unit folders. Once the tree has been expanded you can click on the element desired and can exercise Options menu sub-items (Edit Note and GoTo) and View menu sub-items (Note and Summary).
Opening the LP/TG folder in the course tree structure will also display the elements of the LP and TG in the upper right hand grid. Double clicking on the folders in the upper right hand grid will open the following windows:

- LP - Lesson Plan window
- TG - Trainee Guide (TG) window
- Unit # – Units/Topics window

The LP, TG, and Unit folders can be expanded to reveal their contents as well. The LP, TG, and Unit folders can be expanded to work on specific portions as follows:

- LP folder – Safety/Hazard Awareness Notice
- TG folder – Safety/Hazard Awareness Notice and Security Awareness Notice
- Unit folder – will open a list of Topic folders. When the Topic folder is expanded, addition folders will be identified for:
  - Trainee Preparation – which can be expanded to include Trainee Support Materials, Reference Publications, IETMs, IMI, and Instructor Preparation.
  - DPs
  - Instruction Sheets

**NOTE:** In order to work on the LP, the associated TCCD must be locked.

### 10.3 LESSON PLAN COVER PAGE

The Lesson Plan window contains text entry fields for modification of the Preparation Date and Security Awareness Notice. The fields for the CIN/Rev/Chg and Title are derived from the TCCD and cannot be modified in the LP module. The Revision Date field will contain Promulgation Date for a Revision to the course and is not editable until a Revision is created for a course.

**NOTE:** You must update and save the Cover Page information before you can access the contents of the LP.

The Prep. Date field is editable and should contain the publication date of the LP/TG. When a Revision is created the contents of the Prep. Date field (original publication date) will be in parenthesis below the Rev. Date on the printed cover page of the LP.

You can also edit the contents of the Security Awareness Notice at this time. You can come back to the Security Awareness Notice for further editing at any time prior to approval.
10.3.1 Lesson Plan Window Options Menu Item

The Options menu item allows you to spell check the entire LP and grant privileges to other users to work in the LP. It also allows you to select the type of print or print preview functionality and the material you want to print or print preview.

10.3.1.1 Spell Check

Selecting the Spell Check option will check the entire LP for misspelled words. Unfortunately, it does not recognize acronyms and lists them as misspelled. Using the find and replace feature under the Notepad window Edit menu item only changes the spelling of the word in the resultant Write file and does not change the spelling in the LP. The resultant file can be saved or printed for later use in correcting the spelling of words in the LP. The Spell Check routine divides the LP into the following components and informs you if there are any spelling errors in the component.

- Cover Page
- Change Record
- Table of Contents
- Security Awareness Notice
- Safety/Hazard Awareness Notice
- Learning Objectives
- Trainee Preparation Materials for each Topic
- Instructor Preparation for each Topic
- DPs/RIAs for each Topic

To spell check the LP:

Step 1 From the Lesson Plan window select the Options menu item and the Spell Check option. AIM II will commence spell checking the LP and you can click on the Cancel button to terminate the Spell Check program.

Step 2 When the Spell Check program is complete the file will be displayed. The File menu item will allow you to save the file, print, or exit to the Lesson Plan window.

10.3.1.2 Grant Privilege

The Grant Privilege option allows the AIM User who has been assigned this privilege to assign Edit and Grant privilege to other AIM Users for the LP. This option gives the AIM Administrator the privilege to assign Edit, Grant, Remove Flag, and Clear In Use privileges to AIM Users from the LP.
To grant privileges to a user for the LP:

Step 1 From the Lesson Plan window select the Options menu item and the Grant Privileges option. AIM II will open the Grant Privileges for LP window.

Step 2 Highlight the AIM User to be granted privilege(s).

Step 3 From the list of enable Privilege Attributes check the box(s) next to the privilege desired for the user.

Step 4 Select the Edit menu item and the Save sub-menu item.

Step 5 Select the additional users and privileges by repeating Steps 2 through 4. When complete; select the Exit menu item to return to the Lesson Plan window.

10.3.1.3 Security Markings
From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:

1. Right click and Go To the appropriate location on the course tree (left pane).
2. From the menu bar click Options.
3. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.
The top portion of the Security Markings screen indicates the CIN and Title of the course. The
center of the screen lists different sections of the Lesson Plan (LP) that can have security
markings and the current marking assigned. The lower portion of the screen is broken into the
following three sections:

- **Classification**: The available classifications that can be assigned, the options are:
  
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier**: This is an additional security modifier to the classification, the options are:
  
  - (None)
  - COMINT
  - Talent Keyhole
• COMINT/Talent Keyhole

- Release Ability: This is an additional restriction on who the document may be released to, the options are:
  - (None)
  - NOFORN
  - For Official Use Only
  - REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

10.3.1.4 Additional Optional Pages
To select additional Optional pages to be included in the Lesson Plan follow the steps below:
1. From the main AIM screen, right click and Go To on the LP folder in the course tree.
2. From the menu bar select Options.
3. From the Options dropdown menu select LP Options
4. Click on the check box next to the desired pages
5. Click the OK button

The Print Options dialog box is show in the figure below.
10.3.1.5 Specify Volume Breaks

The Specify Volume Breaks option allows the user to create separate volumes based on Topic, to specify a volume break:

Step 1 From the Lesson Plan window select the Options menu and the Specify Volume Breaks option.

Step 2 Select the topic where the volume break should occur (first topic of the new volume) by either double-clicking on the topic or highlighting the topic and selecting it from the Options menu.

Step 3 Once all desired volume breaks have been selected, select the Options menu item and the Generate sub-menu item.

10.3.1.6 Print Preview

Selection of Print Preview will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the LP for page accountability when printing classified curriculum,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the LP, and
- Select the desired orientation of Portrait or Landscape of which Landscape is a default.

Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the LP for Print Preview. When prepared it displays the first page of the LP and allows you to select the following menu items:

- Options - contains the options to Print or Save to PDF. Print opens the Print window, which allows you to print a page, range of pages, the whole document, print to file, and number of copies. Save to PDF saves the document as a PDF file to the desired location.
- Go To - moves to the previous, next, first, last, or desired page.
- Exit - returns to the Lesson Plan window.
- Help - provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- Previous - moves to the previous page.
- Next - moves to the next page.
- Find – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- Page _ of Page - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Accesses the page desired by typing in the
page number in the first field and depressing Enter.

- **Actual Page** - displays the actual page number, as shown on the page. Typing the page number in this field and depressing Enter accesses the page number desired.

Double clicking the left mouse zooms in and double clicking the right mouse zooms out. Clicking the arrow to the right of the zoom icon (magnifying glass) presents a sub-menu from which you can select Whole Page, Page Width, Two Pages, Thumbnail, and present the page in 25% increments to 100% and also select 150%.

Print Preview of an LP displays hyperlinks to IMM selected in the course under Trainee Preparation Materials, Instructor Preparation Materials, and RIAs. The IMM can be viewed by clicking on the hyperlink. The LP HTML file produced, using the AIM main menu Options menu item and the Generate HTML option, also contain the IMM hyperlinks.

Below the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

**To print preview the LP:**

**Step 1** From the Lesson Plan window; select the Options menu item and the Print Preview option.

**Step 2** From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified curriculum.

**Step 3** Click on the OK to print preview the LP.

**10.3.1.7 Print**

Selection of the Print option allows you to print the entire document.

**To print the entire LP:**

**Step 1** Select the Options menu item and the Print option.

**Step 2** From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified curriculum.

**Step 3** Click on the OK button to view the default printer and click on OK to print.
10.3.2 Lesson Plan Window Contents Menu Item

Selecting the Contents menu item will allow you to:

- Display the drop-down menu
- Modify the Safety/Hazard Awareness Notice
- Modify Topic Time in the CMS
- Modify the SCORM Metadata tabs for the course
- Access the Units

10.3.2.1 Safety/Hazard Awareness Notice Contents Menu Sub-item

The Safety/Hazard Awareness Notice is used to identify measures necessary to ensure the safety of the class [i.e., Training Time Out (TTO) and Drop On Request (DOR)]. When the LP is first built by the software a default Safety/Hazard Awareness text is added which contains text on TTO. If DOR text is required the developer must add it. AIM II provides a text editor window for text entry. See Chapter 2, Section 2.4, for directions on using the AIM II Text Editor.

To enter Safety/Hazard Awareness Notice information:

Step 1 From the Lesson Plan window select the Contents menu item and the Safety/Hazard Awareness Notice sub-menu item. Or, from the course tree structure expand the LP/TG folder, open the LP folder, and in the upper right hand grid double click on the Safety/Hazard Awareness element. AIM II will open the Safety/Hazard Awareness window, which contains the AIM II Text Editor.

Step 2 Boilerplate information is furnished by the software and can be edited as desired. If the desired text already exists in another file, delete the boilerplate and select the Options menu item and the Import Text File option and select the desired file.

Step 3 When finished, select the Exit menu item and save the entry to the database.

10.3.2.2 Topic Time

The Topic Time option is used to edit information about the Topic that will appear in the CMS. To edit this information select Topic Time from the Contents menu on the Units/Topics screen. Once the Events screen appears editing information is done the same way as the Events screen in the CMS Module. Refer to the CMS section of this manual for more information.

10.3.2.3 SCORM Metadata (Course)

Sharable Content Object Reference Model (SCORM) is a set of specifications published by
Advanced Distributed Learning (ADL) for developing, packaging and delivering high-quality education and training materials wherever and whenever they are needed. SCORM compliant courses leverage course development investments by ensuring that compliant courses are Reusable, Accessible, Interoperable and Durable.

The SCORM Data information represent the information required for development of metadata (data about data) files. Metadata files provide a common nomenclature enabling learning resources to be described in a common way. Metadata can be collected in a catalog, as well as directly packaged with the learning resource it describes. Learning resources that are described with meta-data can be systematically searched for and retrieved for use and reuse. Aggregation (course) and SCO (topic) have certain metadata fields that are required. Asset (TG graphic) has only a small subset of those same fields required.

Assets, Sharable Content Objects (SCOs), and Content Aggregations are components that are considered specifications of learning resources.

- Assets: electronic representations of media, text, images, sound, Web pages, assessment objects or other pieces of data that can be delivered to a Web client. The mechanism for binding Assets to Asset Metadata (data about data) is the Content Package. In the current AIM-to-SCORM output, the graphics used in TG sheets, Transparencies, and Test Items are the assets that are the output along with the entire course package. The repository will be able to identify these as separate assets and store them for reuse, independent of the course package (aggregation) or any of the SCOs (Topics) in which they are used.

- Sharable Content Object (SCO): SCO represents a collection of one or more Assets that include a specific launchable asset that utilizes the SCORM Run-time Environment to communicate with Learning Management Systems (LMSs). A SCO represents the lowest level of granularity of learning resource that can be tracked by an LMS using the SCORM Run-Time Environment. The topic is the SCO in the current SCORM output from AIM.

- Content Aggregation: A content aggregation is a map (content structure) that can be used to aggregate learning resources into a cohesive unit of instruction. AIM aggregates all the Topics (SCOs) in a course into the output package (aggregation), which has course level metadata.

AIM provides default information for the mandatory information for SCORM or ILE Metadata specifications using SCORM version 1.2 or 2004.

The specification and version can be selected from the AIM main menu by selecting the Options menu item and the Preferences option. The Advanced tab contains the Metadata Specification and version selection.

The course Tabs can be edited from Lesson Plan window (Cover Page) by selecting the Contents menu item and the SCORM Metadata sub-item. The bolded items are required for the Metadata Specification and version selected.
The Tabs for individual Topic Sharable Content Objects (SCOs) can be edited from the Units/Topics window by highlighting the desired Topic, selecting the Contents menu item and clicking on the **SCORM Metadata** sub-menu item. Test item data is stored with the topic it’s associated with and graphics used in test items appear in the list of graphics in the course.

Functionality for editing the Tabs for the course, topics, and graphics and generating a SCORM Output is also provided to the developer by selecting the desired course in the Course Select menu and selecting the **Document** main menu item and the **SCORM Data** sub-menu item or by clicking on the SCORM icon. The browser in the left pane allows you to open the Course, Topic, or Graphic folder to edit the associated Tabs. The SCORM-compliant output of AIM is an XML-based SCOs packaged at the course topic level that can be viewed using Internet Explorer. Refer to Appendix E to generate SCORM Output.

**To edit the Metadata for the course:**

1. **Step 1** From the Lesson Plan window select the **Contents** menu item and the **SCORM Metadata** sub-menu item. AIM will open the SCORM Metadata window.

2. **Step 2** Click on the Category that requires entry. An Explanation field is provided to describe the content requirements. Edit as necessary. Bolded categories require data entry and all other categories are optional.

3. **Step 3** When editing has been completed select the **Edit** menu item and **Save**.

4. **Step 4** Select the **Exit** menu item to return to the Lesson Plan window.
10.3.2.4 Units/Topics Window

Selecting **Units** from the Lesson Plan window **Contents** menu item opens the Units/Topics window. Or, expanding the LP/TG folder in the course tree structure displays all the Units contained in the course. Open the Unit folder and select the **Options** menu item and the **GoTo** option to open the Unit/Topics window. From this window you can print or print preview the highlighted Unit or individual Topic. Clicking on a Topic will enable the **Contents** menu item of the Units/Topics window.

**Step 1** Highlight the desired Unit/Topic and select the **Options** menu item. AIM II will present the **Print Preview** and **Print** sub-menu items.

**Step 2** Highlight the desired Topic and select the **Contents** menu item. AIM II will present the following sub-menu items:

- Trainee Preparation Materials
- Instructor Preparation Materials
- SCORM Metadata (for Topic)
- DP/RIA
10.3.2.4.1 Entering Trainee Preparation Materials

Trainee Preparation Materials is a heading on the Unit/Topic Page printout; it is divided into four categories:

- **Trainee Support Materials**, which are TG sheets
- **Reference Publications**, which are reference documents listed in the course RRL
- **IETMs**, which are Imported extract files of an Interactive Electronic Technical Manual
- **IMIs**, which are Interactive Multimedia Instructions

When the trainee is required to prepare for the Topic prior to its commencement, an entry is required in at least one of these areas. AIM II records the entry on the Unit/Topic Page under the heading of Trainee Preparation Materials.

**To enter Support Materials for Trainee Preparation:**

**Step 1** Highlight the desired Unit/Topic in the Units/Topics window and select the **Contents** menu item and the **Trainee Preparation Materials/Trainee Support Material** sub-menu items. Or, in the course tree structure, expand the desired Unit, Topic, and Trainee Preparation folder. Open the Trainee Support Materials folder and select the **Options** menu item and the **GoTo** option.

**Step 2** AIM II will open the Trainee Preparation Materials (Trainee Support Materials) window and present a list of Instruction Sheets that have been identified in the RIAs of the highlighted Topic. To select an Instruction Sheet from the existing list, select the **Options** menu item and the **Select** option. An "X" will appear in the select column.

a. Enter the Before Text desired by selecting the arrow and one of the selections from the pop-up menu.

b. Enter the instructions that the instructor will impart to the trainee in the After Text field.

c. Select **Edit** and the **Save** sub-menu item to save the TG sheet.

**Step 3** To unselect an Instruction Sheet from the existing list, click on the Instruction sheet and select the **Options** menu item and the **Unselect** option.

**Step 4** Repeat Steps 2 for each additional Support Material entry required.

**Step 5** Select the **Exit** menu item to return to the Units/topics window or course tree structure.
To enter Reference Publications, IETM, or IMM for Trainee Preparation Materials:

**Step 1** Highlight the desired Unit/Topic in the Units/Topics window and select the **Contents** menu item and the **Trainee Preparation Materials/Reference Publication, IETM,** or IMM sub-menu items. Or, in the course tree structure, expand the desired Unit, Topic, and Trainee Preparation folder. Open Reference Publications, IETMs, or IMM folder, and select the **Options** menu item and the **GoTo** option.

**Step 2** AIM II will open the Trainee Preparation Material (Reference Publications), (IETM) or (IMM) window, which contains a list of publications, IETM, or IMM from the Course RRL. Highlight the desired publication, IETM, or IMM and double-click on the Select field to select it. An X will appear in the select column.

**Step 3** Click on the Before Text column and the down arrow. From the list provided, click on the appropriate Before Text.

**Step 4** Double click on the After Text column and type in the volume, chapter, paragraph, and page numbers, as required, and any other assignment directions the instructor must give the trainee.

**Step 5** Select the **Edit** menu item and the **Save** sub-menu item to save the Unit Page entry.

**Step 6** Repeat Steps Two through Five for each additional Reference Publication, IETM, or IMM entry required.

**Step 7** Select the **Exit** menu item to return to the Units/Topics window or course tree structure.

10.3.2.4.2 Entering Instructor Preparation Materials

Instructor Preparation is a heading on the Unit/Topic Page printout; it is divided into three categories: Review Assigned Trainee Material, **Reference Publications,** and **Training Materials Required.** RRL items required are automatically entered into these categories when you select them for the RIAs. However, if there are specific instructions required for the instructor for any of these items, use of the Instructor Preparation menu item will allow you to add Before and After text to include amplifying information for the instructor.
To enter Reference Publications Before and After text:

Step 1  Highlight the desired Unit/Topic in the Units/Topics window and select the Contents menu item and the Instructor Preparation Materials/Reference Publications sub-menu items. Or, in the course tree structure, expand the desired Unit, Topic, and Instructor Preparation folder. Open the Reference Publications folder and select the Options menu item and the GoTo option.

Step 2  AIM II will open the Instructor Preparation Material (Reference Publications) window and present a list of publications that have been identified in the RIAs of the highlighted Topic. Click on the publication for which amplifying text is to be added.

- Enter the Before Text desired by selecting the arrow and one of the selections from the pop-up menu.
- Enter the instructions for the instructor in the After Text field.
- Select Edit and the Save sub-menu item to save the instructions for the Topic Page.

Step 3  Repeat Steps 2 for each additional publication entry required.

Step 4  Select the Exit menu item to return to the Units/Topics window or course tree structure.

To enter Training Materials Required Before and After text:

Step 1  Highlight the desired Unit/Topic in the Units/Topics window and select the Contents menu item and the Instructor Preparation Materials/Training Materials Required sub-menu items. Or, in the course tree structure, expand the desired Unit, Topic, and Instructor Preparation folder. Open Training Materials Required folder and select the Options menu item and the GoTo option.

Step 2  AIM II will open the Instructor Preparation Material (Training Materials Required) window, which contains a list of Instruction Sheets that have been selected in the RIAs within the Topic. Highlight the desired Instruction Sheet for which amplifying text is to be added.

Step 3  Click on the Before Text column and the down arrow. From the list provided, click on the appropriate Before Text.

Step 4  Double click on the After Text column and type in the required text for the instructor.
Step 5 Select the **Edit** menu item and the **Save** sub-menu item to save the Unit/Topic Page entry.

Step 6 Repeat Steps Two through Five for each additional Instruction Sheet requiring amplifying text for the instructor.

Step 7 Select the **Exit** menu item to return to the Units/Topics window or course tree structure.

### 10.3.2.4.3 SCORM Metadata (Topic)

*Refer to paragraph 10.3.2.2 for an explanation of SCORM and Metadata information.*

The information for individual Topic Sharable Content Objects (SCOs) can be edited from the Lesson Plan (LP) window by highlighting the desired Topic, selecting the **Contents** menu item and clicking on the **SCORM Metadata** sub-menu item. Test item data is stored with the topic it’s associated with and graphics used in test items appear in the list of graphics in the course.

**To edit the Metadata information for the Topic:**

1. From the Units/Topics window, highlight the Topic desired, select the **Contents** menu item, and the **SCORM Metadata** sub-menu item. AIM will open the SCORM Metadata window.
2. Click on the Category that requires entry. An Explanation field is provided to describe the content requirements. Edit as necessary. Bolded categories require data entry and all other categories are optional.
3. When editing has been completed select the **Edit** menu item and **Save**.
4. Select the **Exit** menu item to return to the Units/Topics window.

### 10.3.2.4.4 Discussion Point/Related Instructor Activity (DP/RIA) Pages

Selecting **DP/RIA** from the **Contents** menu item in the Units/Topics window opens the DP/RIA window for the Unit/Topic highlighted. Or, in the course tree structure, expand the desired Unit, Topic. Open the DPs folder and select the **Options** menu item and the **GoTo** option.

The Flag column in the DP/RIA window or a red flag on the DPs folder in the course tree structure can indicate that one or more of the following maintenance actions have been performed when a change or revision is created for the course:
The EO to which the DP is linked was modified/deleted, and maintenance action may be required.
- The EO to which the DP is linked was joined to another EO.
- The DP has been modified or added.
- The DP's associated RIA has been added, modified, or deleted.
- An RRL item related to a RIA has been modified or deleted.

The Explain Flag option for the DP/RIA window will indicate the origin of the flag and explain what was done to generate it. The Remove Flag option is an AIM Administrator task. All Maintenance flags must be removed from the TCCD, LP, or TG before the change or revision for the curriculum can be approved.

10.3.2.4.4.1 Adding DPs

The default DPs include:
- An Introduction DP
- A DP for each EO
- Summary and Review
- Assignment
- Application

To add DPs:

Step 1 Position your cursor at the point at which you want to add a DP.

Step 2 Select **Options**, then **Add Same Level DP (Ctrl + A)** or **Add Lower Level DP (Ctrl + L)**, as desired.

For example:
- a. If you highlight DP 1 and add at the same level, you will add a new DP 2.
- b. If you highlight DP 1.a and add at the same level, you will add a new DP 1.b.
- c. If you highlight DP 1.a(1) and add at the same level, you will add a new DP 1.a(2).

For example:
- a. If you highlight DP 1 and add at the lower level, you will add a new DP 1.a.
- b. If you highlight DP 1.a and add at the lower level, you will add a new DP 1.a(1).
- c. If you highlight DP 1.a(1) and add at the lower level, you will add a new DP 1.a(1)(a).
To edit the contents of a DP:

Step 1 Click on the DP to be edited.

Step 2 Type in the text of the DP in the field provided on the bottom portion of the window.

**NOTE:** The text editing field on the bottom portion of the window provides the use of the Font and pitch menu bar items as well as the Cut, Copy, Paste, Bold, Italics, Underline, Strikeout, Superscript and Subscript buttons.

**WARNING:** Insure the font selected is a standard font that resides on all PCs that will be used to print and view the LP. If the course is imported into a system that does not contain the selected font, Windows ™ will interpret the font to a font that may not match.

10.3.2.4.4.2 Deleting DPs

Each EO must be supported by at least one DP. The last DP linked to an EO cannot be deleted.

To delete a DP:

Step 1 Click on the DP to be deleted.

Step 2 Select the **Options** menu item and the **Delete DP (Ctrl + D)** option.

Step 3 The software will prompt "Are you sure you want to delete this DP?" click on **Yes** to delete or **No** to terminate the **Delete DP** option. If the DP has no sub-DPs attached, the DP and its associated RIA will be deleted.

Step 4 If there are DPs at a level lower than the DP being deleted, the software will prompt you "Do you wish to move the sub-DPs to another DP?" you can perform one of the following options:

a. If you click on **Yes** the software will prompt you with "Select the DP you want to attach the sub-DPs to." Click on **OK** and AIM II will open the Pick New DP window. Highlight the desired DP to be appended and click on the **Select** menu item. You will be prompted with "Are you sure you want to move the sub-DPs to DP X?" Clicking on **Yes** will append the highlighted DP with the sub-DPs and their associated RIAs. Clicking on **No** will enable you to select another DP.

b. If you click on **No** the sub-DPs along with their associated RIAs will be deleted.
c. If you click on **Cancel**, the **Delete DP** option will be canceled and return you to the DP/RIA window.

### 10.3.2.4.4.3 Adding/Deleting Notes, Cautions, and Warnings

AIM II provides the flexibility to add Notes, Cautions, and Warnings before and after all DPs. The Note, Caution, or Warning is linked to the DP, therefore, if the DP is deleted, the Note, Caution, or Warning associated with the DP is also deleted.

**Step 1**  
Click on the DP to which you would like to add a Note, Caution, or Warning.

**Step 2**  
Select **Options**; then select **Add Note**, **Caution**, or **Warning**. The sub-menu will give you the choice of placing the Note before or after the highlighted DP.

**Step 3**  
Type in the text of the Note, Caution, or Warning in the editing field at the bottom of the page.

**NOTE:** You cannot add a RIA to a Note, Caution, or Warning

**NOTE:** The text editing field on the bottom portion of the window provides the use of the Font and pitch menu bar items as well as the Cut, Copy, Paste, Bold, Italics, Underline, Strikeout, Superscript and Subscript buttons.

**WARNING:** Insure the font selected is a standard font that resides on all PCs that will be used to print and view the LP. If the course is imported into a system that does not contain the selected font, Windows™ will interpret the font to a font that may not match.

### 10.3.2.4.4 Copy and Paste DP/RIAs

It is possible to Copy and Paste Discussion Points (DPs) and their related Related Instructor Activities (RIAs) from one topic to another or even from one course to another. Regardless of where the DP/RIAs get pasted the process is the same, as described below:

**Step 1**  
Highlight the desired DP to Copy.

**Step 2**  
Move to the desired location to Paste the DP (open a second course if necessary).

**Step 3**  
Click on the desired location within the new topic's DP/RIA screen, highlighting the DP that the Copied DP will be inserted behind.

**Step 4**  
Select either Same Level or Lower Level from the Paste DP/RIA sub-menu to
paste the selected DP/RIA as the same level or as a subordinate level DP/RIA.

There are several considerations when copying DP/RIAs:

When Pasting within the same course, if copying a main level DP, there will be a prompt asking if the EO should be copied to the topic. Answering "Yes" will copy the EO to the new topic, answering "No" will not. This prompt will not appear if the user does not have Edit privileges for the COI.

When Pasting a DP/RIA that contains Outline Sheets a new Outline Sheet will be created, but it will be blank, this will prompt the user if they want to use Main DPs in the Outline.

When copying DP/RIAs that have Instruction Sheets attached within the same course the user is prompted with "Would you like to copy the Instruction Sheets to this Topic?" Answering "Yes" will create a copy of the Instruction Sheets associated with the DP/RIA, answering "No" will link the DP/RIA to the original Instruction Sheet. If Instructional Sheets are linked to multiple DP/RIAs editing the content in one will affect the others.

If you copy DP/RIAs from one course to another, the EO linked to the original DP/RIA is NOT copied to the other course.

10.3.2.4.4.5 Working With RIAs

From the DP/RIA window Options menu item, the following options are available:

- **Build RIA or (Ctrl + B):** Allows you to create an RIA in a blank RIA field or modify an existing RIA.
- **Add Another RIA or (Ctrl + R):** Allows you to open a new RIA field for the same DP/RIA under the RIA field highlighted and enter a new RIA statement.
- **Add Same Level RIA:** Allows you to highlight a numbered RIA and add another RIA at the same level as the RIA highlighted. (For example, if you select this option when RIA 2-a is highlighted AIM II will generate a field for RIA 2-b.)
- **Add Lower Level RIA:** Allows you to enter the RIA at a lower level for the RIA highlighted. (For example, if you select this option when the RIA for DP 2-b is highlighted and there is no DP 2-b-1, AIM II will generate a RIA 2-b-1 to enter RIA data only.)
- **Delete RIA:** Allows you to delete a RIA entry.
- **Copy RIA:** Allows you to copy the contents of a highlighted RIA into a buffer.
- **Paste RIA:** Allows you to paste the contents of the buffer into the blank highlighted RIA field.
The build and add options open the Build RIA window. The **Options** menu item of the Build RIA window provides the following options:

- **Copy RRL from previous saved RIA**: Will copy the information from the previously saved RIA in this Topic if it was linked to an RRL item. This option is primarily designed to copy Publications used to develop an RIA and will copy the Before Text, RRL Type, RRL Item, and Volume/Part breakdown. The software will blank out the Sub Part Type and subsequent fields for the new RIA.

- **View IETM Structure**: Allows the developer to examine the structure of an IETM selected in an RIA. It opens the IETM Browser and highlights the selected IETM.

- **Launch/View IETM**: Allows the developer to view the contents of the IETM selected from the location where the IETM is stored.

- **View RRL**: Allows the developer to view the Site RRL fields of the RRL item selected for the RIA.

- **Display Media**: Allows the developer to view the IMM selected using the full screen. This option also exists on the DP/RIA window to view the IMM full screen without having to go to the Build RIA window.

### 10.3.2.4.4.6 Building a RIA

The Build RIA option has two purposes: to create a RIA in a blank RIA field and to modify an existing RIA.

**To build an RIA:**

1. **Step 1** Click on the RIA to be created/modified.

2. **Step 2** Select the **Options** menu item and the **Build RIA (Ctrl + B)** option, or double click on the RIA field. AIM II will present the Build RIA window.

   **NOTE:** If the RRL item desired for this RIA is the same item that was selected to build the previously saved RIA you can select the Build RIA window **Options** menu sub-item **Copy RRL from previously saved RIA** option.

3. **Step 3** Position the cursor in the RRL Type field and click on the down arrow to select from the RRL Types available.
Step 4

If only a text entry is desired for the RIA entry, for instructor direction, and the RIA does not require an RRL item selection start your text entry in the After Text field.

**NOTE:** The text editing field on the bottom portion of the window provides the use of the Font and pitch menu bar items as well as the Cut, Copy, Paste, Bold, Italics, Underline, Strikeout, Superscript and Subscript buttons.

**WARNING:** Insure the font selected is a standard font that resides on all PCs that will be used to print and view the LP. If the course is imported into a system that does not contain the selected font, Windows™ will interpret the font to a font that may not match.

Step 5

If the RIA entry requires an RRL item, scroll through the list and click on the type of RRL item desired. For all items except TG sheets, AIM II will present the Course RRL window, which contains a split window with the Course RRL items on the top and the Site RRL items on the bottom. Perform one of the following steps:

**Step 5a:** If the information presented on the window does not give you enough information about the item to select it, select the **Options** menu item and the **View RRL** option to open the Site RRL window for the item highlighted. All the information entered into the Site RRL for the item highlighted will be displayed. Select the Exit menu item to return to the Course RRL.

**Step 5b:** If the item desired is contained in the Course RRL List, highlight the item and select the **Options** menu item and the **Select RRL for RIA** option.

**NOTE:** If this is a NAMTRA course and an approved NAMTRA ERL has been imported, only items of the following RRL types can be added to the course: Equipment, Films, Photographs, Publications, Slides, Transparencies, Videos, and Wall Carts.

**Step 5c:** If the item desired is contained in the Site RRL List, highlight the item and select the **Options** menu item and the **Select Course RRL** option. Or, click and drag the item from the Site RRL and drop it in the Course RRL. Enter the quantity information in the Quantity Required field and select the **Edit** menu item and the **Save** sub-menu item. Perform the preceding step (Step 5b) to select the item for the RIA.
Step 5d: If the item desired does not appear in either the Course RRL or Site RRL, select the Site RRL menu item. AIM II will open the Site RRL window. Perform the following:

1. From the list of RRL types, highlight the type of RRL item required. Select the Options menu item and the Add RRL option. AIM II will open the RRL Type window.
2. Enter the required information in the fields provided and select the Exit menu item and save the information to the Site RRL.
3. From the Site RRL window select the Exit menu item to return to the Course RRL window. Perform Steps 5b and 5c for the new Site RRL item.

Step 6 Enter the publications breakdown data in the fields provided for Publications resource (Volume #, etc.).

Step 7 Click on the Before Text field arrow and select an appropriate Before Text entry that corresponds to the type of RRL item selected or, if the text desired is not in the drop-down list, enter text in the field provided. Before Text informs the instructor what is to be done with the RRL item selected and will precede the title of the RRL item selected.

Step 8 Click on the After Text field (text that will follow the title of the RRL item selected) and enter the desired amplifying information.

NOTE: The text editing field on the bottom portion of the window provides the use of the Font and pitch menu bar items as well as the Cut, Copy, Paste, Bold, Italics, Underline, Strikeout, Superscript and Subscript buttons.

WARNING: Insure the font selected is a standard font that resides on all PCs that will be used to print and view the LP. If the course is imported into a system that does not contain the selected font, Windows™ will interpret the font to a font that may not match.

Step 9 Select the Exit menu item and save the information to the RIA

10.3.2.4.7 Add/Select/Delete Instruction (TG) Sheets

To add/select Instruction sheets:

Step 1 From the RIA Text column; double click. You will be placed in the LP - Build RIA window. The RRL Type field will be highlighted.
Step 2  
Click anywhere in the RRL Type field to display a list of RRL types.

Step 3  
Select TG Sheets as the RRL type. AIM II will present you with the TG Sheets window, which will:
- Be blank if no TG sheets have been created
- Contain a list of all Instruction Sheets in the TG

To select an existing TG sheet:

Click on the TG Sheet desired for the RIA and select the **Options** menu item and the **Select** option.

To identify a new TG sheet:

Step 1  
Select the **Options** menu item and the **Create** option. AIM II will display a menu of the different types of TG sheets available.

**CAUTION:** Do not create an Assignment Sheet for an Assignment DP/RIA if it is to be used as Trainee Preparation Material for a subsequent Topic. The Assignment Sheet must be created from the Topic that contains the EOs it will support. It can be noted in a Topic that it does not support by using the Before and After text fields of the RIA.

Step 2  
Click on the desired TG sheet. AIM II will add an Instruction sheet to the list of the types selected and place the cursor in the Sheet Title field.

Step 3  
Enter the Sheet Title and select the **Edit** menu item and the **Save** sub-menu item.
Assignment and Outline Sheet titles are added by the software, have the same title as the Topic, and can be modified. During maintenance, when developing Changes and Revisions, the Title of a TG Sheet can only be modified in the TG.

Step 4  
To select the TG sheet for the RIA, click on the TG sheet and select the **Options** menu item and the **Select** option.

Enter Before Text and After Text, as required and select the **Edit** menu item and the **Save** sub-menu item to save your RIA entry.

**NOTE:** The text editing field on the bottom portion of the window provides the use of the Font and pitch menu bar items as well as the Cut, Copy, Paste, Bold, Italics, Underline, Strikeout, Superscript and Subscript buttons.
To delete an existing Instruction Sheet:

In order to delete an existing Instruction Sheet in the course RRL, all RIAs that cite the instruction sheet have to be deleted.

Step 1 Click on the RIA that contains the Instruction Sheet to be deleted.

Step 2 Select the **Options** menu item and the **Delete RIA** option.

Step 3 Confirm deletion by clicking on the **Yes** button when prompted "Are you sure you want to delete this RIA?"

Step 4 Select the **Exit** menu item and save the new data.

Step 5 From the Units/Topics window; select the **Contents** menu item and the **DP/RIA** sub-menu item.

Step 6 Click on a RIA field that contains no RIA text.

Step 7 Select the **Options** menu item and the **Build RIA** option.

Step 8 Click on the RRL Type field and select TG Sheets.

Step 9 From the TG Sheets window, click on the TG Sheet for deletion.

Step 10 Select the **Options** menu item and the **Delete** option.

Step 11 Confirm your deletion by clicking on the **Yes** button.

Step 12 Select the **Exit** menu item to return to the Build RIA window.

Step 13 Select the **Exit** menu item to return to the Units/Topics window.
10.3.2.4.4.8 Selecting an IETM

Once an IETM Extraction file has been imported to the Site RRL by the AIM Administrator, using the Admin Utility, you can add that IETM to the Course RRL. AIM contains browsers for SWS and ARCI IETMs from which you can expand the menu of the IETM and select the item desired for the RIA.

To select an IETM:

1. From the DP/RRIA window; double click on the RIA Text field for the appropriate DP. You will be placed in the LP - Build RIA window.
2. Click anywhere in the RRL Type field to display a list of RRL types.
3. Select IETM as the RRL type. AIM II will open the Course RRL type window, which contains a list of IETMs selected for the course and will also allow you to select an IETM from the Site RRL for the course and enter the appropriate quantity information.

**NOTE:** An IETM RRL item can only be added to the Site RRL from the Admin Utility. To Add/Modify/Delete an IETM RRL item in the Site RRL contact the AIM Administrator.

4. Click on the desired IETM from the Course RRL and select the Options menu item and the Select RRL for RIA option.

AIM will connect the IETM to the database and the IETM Browser window will open. Clicking on the "+" blocks next to the titles in the IETM Browser will expand the menu and clicking on the "-" blocks next to the titles will reduce the menu.

5. Select the Options menu item and the Find option. AIM will open the Find window. Enter the name of the item desired or scroll through the list and click on the item. Click on the Select and Exit menu items to return to the browser. The item selected will be highlighted.

**NOTE:** If the item selected has an icon between the "-" box and the title, it can be selected for the RIA. If an icon is not present, this represents a menu title and not an accessible IETM.

6. Select the Options menu item and the Select option. AIM will return you to the Build RIA window and the IETM selected will be identified in the RRL field.
Step 7 Enter Before Text and After Text, as required, and select the Edit menu item and the Save sub-menu item to save your RIA entry.

10.3.2.4.9 Selecting an IMI

Interactive Multimedia Instructions (IMI) resources have been divided into six different folders within the Site RRL:
- Animation
- Audio
- Graphic
- Internet
- Power Point
- Video

The Build RIA window displays the IMM selected so that you can view/hear your selection. A viewer will open to play a video. The slides will be presented for a Power Point presentation and you can also select the slide/s applicable to the RIA. When the IMM is selected for an RIA AIM creates hot-links to the IMM for the RIA and Topic Page. The hot-links are used for development of HTML and SCORM files for the LP.

**NOTE**: When selecting a Power Point Slide presentation as an IMM for a RIA the software contains fields for the user to add the starting and ending slide number(s). The starting and ending slide numbers are appended to the IMM title in the RIA to inform the instructor which slides are required to teach the DP. After the field entries have been saved to the database AIM does not restrict you to the slides selected.

**To select a Power Point Presentation for an RIA:**

Step 1 In the DP/RIA window click on the RIA field where the Power Point Presentation slide will be identified, select the Options menu item and the Build RIA option or double-click on the RIA field, to open the Build RIA window.

Step 2 Click on the arrow for the RRL Type to open the course resource selection menu and click on the IMM resource.

Step 3 From the Course RRL click on the desired Power Point Presentation. Select the Options menu item and select the Select RRL for RIA option. AIM will open the Power Point Presentation and display it in the Build RIA window. The display will also show you how many slides are contained in the presentation.
Step 4 Select the Slide Range by entering the number of the first slide to be presented in the From field and the last slide to be presented in the Through field. If only one slide is required enter this slide number in the From field and leave the Through field blank.

**NOTE:** When additional RIAs are built using the same Power Point Presentation AIM will automatically present the next sequential slide in the presentation for selection. However, you can select any slide(s) to build the RIA.

Step 5 Click on the arrow for the Before Text entry and select the appropriate direction for the instructor or type the direction in the field provided.

Step 6 If there are additional instructions for the instructor to direct the discussion of the slides selected enter the direction in the After Text field.

Step 7 Select the **Edit** menu item and the **Save** submenu item to save you RIA. AIM will return you to the DP/RIA window and the first slide selected in the From field of the Build RIA window will be displayed in the lower right when the RIA is highlighted.

**NOTE:** The IMM will only be displayed in the DP/RIA window if the Show IMM Preview option has been selected in the DP/RIA window. When you Print Preview the Topic containing the IMM it will be displayed on the Topic Page under Instructor Preparation/Training Materials Required and in the RIAs as a blue hot link. This is also how it will appear in a Generated HTML file output for the Web, less headers and footers.

**10.3.2.4.10 Adding Another RIA**

A RIA entry must exist for the DP before you can add another RIA sentence for a DP. The Add Another RIA option is not available when the RIA field highlighted is blank.

**To add another RIA:**

Step 1 Click on the RIA field that you want the new RIA to follow.

Step 2 Select **Options**, then select the **Add Another RIA (Ctrl + R)** option. AIM II will open a new field to build a RIA statement.

Step 3 Perform the steps listed in Section 10.3.2.3.4.5, Steps 3 through 9, to build a RIA.
10.3.2.4.11 Adding a Same Level RIA

The Add Same Level RIA option can only be used if the RIA highlighted has a lower level indenture than the DP it supports. AIM II will generate a RIA at the same subitem level of the RIA that is highlighted. (For example, if RIA 2-c is highlighted, AIM II will generate a field for RIA 2-d.)

Text cannot be entered in the DP field for this RIA. If DP text is desired, you must use the Add Lower Level DP option before building the associated RIA.

To add a same level RIA:

Step 1 Click on the RIA field that you want the new RIA to follow.

Step 2 Select Options; then select the Add Same Level RIA option. AIM II will open a new field in which to build an RIA statement.

Step 3 Perform the steps listed in Section 10.3.2.3.4.5, Steps 3 through 9, to build a RIA.

10.3.2.4.12 Adding a Lower Level RIA

The Add Lower Level RIA option can be used only if the DP of the RIA highlighted does not have a sub-item at the same level as the RIA that you want to create. AIM II will generate an RIA at the level below the RIA that is highlighted. (For example, if RIA 2-c is highlighted, AIM II will generate a field for RIA 2-c-1.) Text cannot be entered in the DP field for this RIA. If DP text is desired, you must use the Add Lower Level DP option before building the associated RIA.

To add a lower level RIA:

Step 1 Click on the RIA field that you want the new RIA to follow.

Step 2 Select Options; then select the Add Lower Level RIA option. AIM II will open a new field to build a RIA statement.

Step 3 Perform the steps listed in Section 10.3.2.3.4.5, Steps 3 through 9, to build a RIA.
10.3.2.4.13 Deleting an RIA

The Delete option can be used to delete:

- A single RIA that has no sub-items
- An RIA, including all its sub-items

Deletion of a RIA does not delete the RRL item or the TG sheet that was called out in the RIA. They can be selected for other RIAs.

To delete an RIA:

Step 1 Click on the RIA that you want to delete and select the **Options** menu item.

Step 2 Select the **Delete RIA** option. AIM II will delete the RIA and any associated sub-items.

10.3.2.4.14 Copying and Pasting an RIA

The Copy and Paste options can save time in building RIAs if you have returned to an RRL item that has been referenced previously in a RIA.

To copy and paste an RIA:

Step 1 Click on the RIA that you want to copy and select the **Options** menu item.

Step 2 Select the **Copy RIA** option. AIM II will place the RIA in a buffer.

Step 3 Highlight the blank RIA field in which you want the contents of the buffer to be placed and select the **Options** menu item and the **Paste RIA** option. AIM II will place the contents of the buffer in the RIA and will maintain the links established with the RRL item selected.

10.3.2.4.15 Re-sequencing DPs and RIAs

When DPs are re-sequenced, their associated Notes/Cautions/Warnings and RIAs are re-sequenced with them. The only criterion is that the DP to be re-sequenced must be of the same indenture as the DP that it will be dropped on. For example, DP 3 can be re-sequenced to DP 5, and AIM II will renumber DP 4 to DP 3, DP 5 to DP 4, and DP 3 to DP 5. DP 3 cannot be re-sequenced to DP 5-a because 5-a is at a different level of indenture. Notes/Cautions/Warnings can be re-sequenced only within the DPs from which they were developed.
RIAs supporting a DP can be re-sequenced at the same level of indenture. RIAs cannot be re-sequenced from one DP to another.

**To re-sequence a DP/RIA:**

- **Step 1** Position the mouse arrow on the text of the DP/RIA you want to move and click on the text, holding the left mouse button down.

- **Step 2** Move the mouse, and a hand will appear in place of the arrow. Drag the text to the location desired and release the left mouse button. AIM II will re-sequence the DP/RIA to its new location and renumber subsequent DPs/RIAs.

### 10.3.2.4.4.16 EO/DP Links

When the LP is initially created the Introduction, Summary and Review, Assignment, and Application DPs are created for each Topic and a DP space (containing the text of the EO) is created to support every EO. The Introduction, Summary and Review, Assignment, and Application DPs are not linked to an EO; therefore, any sub-DPs added to them will not be linked to an EO.

Linking makes surveillance of items for maintenance easier when you are developing Changes to training materials. Each DP that was initially created from an EO by the software is automatically linked to the originating EO and any sub-DPs added to these original DPs would be linked to the same EO. When adding major DPs (DP 2, 3, etc.) the software will link the DP to the EO of the highlighted DP when the Add option is selected. The EO/DP Links Options menu item displays the EO that the DP is linked to and permits the user to changes the links.

If an EO is modified during the development of a Change or Revision, the DP that it is linked to will be flagged to alert you that:

- A maintenance action has been performed.
- The DP may require a maintenance action as a result.

If an EO is added or moved from one Topic to another in the COI, the DP is added to the end of the Topic and then you can re-sequence the DP where desired using the drag and drop method. During maintenance, if an EO is deleted, its associated DPs and RIAs will be deleted. If an EO is modified, its associated DP will be flagged for modification. If an EO is added to the Topic, its associated DP will be flagged to inform you that you need to outline the EO with supporting DPs.

**To view/link a DP to the EO it supports:**

- **Step 1** From the DP/RIA window; highlight the DP.
Step 2 Select the **Options** menu item and the **EO/DP Links** option. AIM II will open a double pane window that reflects the Topic Number and Title, the major DPs in the left pane and the EOs in the right pane.

Step 3 With a major DP highlighted in the right pane, An "X" will be in the Set column for the EO that the DP is linked to.

Step 4 If a major DP is incorrectly linked to an EO, double click on the Set column in the right pane for the EO it supports. Select the **Edit** menu item and the **Save** sub-menu item.

Step 5 Select the **Exit** menu item and AIM II will return you to the DP/RIA window.

**10.3.2.4.4.17 Explain Flag**

The software from the course RRL in either development or maintenance generates flags.

The course is considered to be in Maintenance if it is a non-Rev 0 Change 0 Course and either:
1. A previous version of the Course exists at the current Revision, or
2. The course is in a Change 0 Revision Course, a previous version of this course exists in your database, and the course has an LP.

If these conditions aren't met, the Course isn't considered to be in maintenance, and as such, no flags will be generated for added/deleted/modified items other than RRL items.

The **Explain Flag** option of the DP/RIA window provides Maintenance Explanations for the highlighted DP/RIA that is flagged. The Maintenance Explanation can be printed for the AIM Administrator Change Record entries that have to be made when approving a change. During the creation of a Change or Revision a DP can be flagged if its associated EO is added/modified/deleted, or if the DP has been added or re-sequenced. A RIA can be flagged if it has been added or re-sequenced. The flags will help the user determine the maintenance action required for flags generated from maintenance actions performed on EOs and DPs.

**To view the Maintenance Explanation for a flagged DP/RIA:**

Step 1 From the DP/RIA window; highlight the flagged DP/RIA.

Step 2 Select the **Options** menu item and the **Explain Flag** option.

Step 3 Select the **DP** or **RIA** sub-menu item. AIM II will open the Maintenance Explanations window for the DP or RIA.
Step 4  Select the **Exit** menu item and AIM II will return you to the DP/RIA window.

### 10.3.2.4.18  Remove Flag

The Remove Flag option is available for the individual that has been granted the Remove Flag privilege by the AIM Administrator for the purpose of reviewing a Change or Revision to the LP. Removal of the flag condones the maintenance action by the reviewer. All maintenance flags must be removed before the Change or Revision can be approved.

**To remove a flag from a DP/RIA:**

**Step 1**  From the DP/RIA window; highlight the flagged DP/RIA.

**Step 2**  Select the **Options** menu item and the **Explain Flag** option.

**Step 3**  Select the **DP** or **RIA** sub-menu item. AIM II will open the Maintenance Explanations window for the DP or RIA. Review the maintenance explanations.

**Step 4**  If you concur with the maintenance actions and desire to remove the flag, record the maintenance action. When approving the course the record of maintenance will be added to the Change Record of the LP.

**Step 5**  Select the **Exit** menu item and AIM II will return you to the DP/RIA window.

**Step 6**  From the DP/RIA window select the **Options** menu item and the **Remove Flag** option.

**Step 7**  Select the **DP** or **RIA** sub-menu item previously selected in Step 3. AIM II will remove the flag for the DP or RIA.

### 10.3.2.4.5  Print Preview/Print a Unit or Topic

**To print preview or print the entire Unit/Topic:**

**Step 1**  From the Units/Topics window; highlight the desired Unit or Topic. Select the **Options** menu item and the **Print Preview** or **Print** option. Or, from the course tree structure, click on the desired Unit or Topic folder and select the **Options** menu item and the **Preview** or **Print** option.

**Step 2**  Select the desired Printer Setup parameters and click on OK.
10.4 SUMMARY

Chapter 10 provided instructions on inserting, editing, deleting, re-sequencing, and linking DPs, and adding Notes, Cautions, and Warnings to the DP outline. It also explained how to define a location in the TG each time you select the TG as the RRL type.
CHAPTER 11

TRAINEE GUIDE (TG) MODULE

11.0 TRAINEE GUIDE ........................................................................................................ 11-1

11.1 OVERVIEW ............................................................................................................. 11-1
  11.1.1 Front Matter ........................................................................................................ 11-2
  11.1.2 Instruction Sheet ............................................................................................... 11-3
  11.1.3 Editors Used In the TG ...................................................................................... 11-4
    11.1.3.1 MS Word™ .................................................................................................. 11-4
    11.1.3.2 Styled Text Editor ...................................................................................... 11-6
    11.1.3.3 High Edit .................................................................................................... 11-6
    11.1.3.4 AIM II Text Editor ..................................................................................... 11-10

11.2 TG STATUS LEVELS AND PRIVILEGES ............................................................. 11-11

11.3 TRAINEE GUIDE (TG) MAIN WINDOW ............................................................. 11-12
  11.3.1 TG Options Menu Item ....................................................................................... 11-12
  11.3.2 TG Contents Menu Item .................................................................................... 11-13
    11.3.2.1 Safety/Hazard Awareness Notice ............................................................... 11-13
    11.3.2.2 Security Awareness Notice ........................................................................ 11-14
    11.3.2.3 TG Sheets Contents ..................................................................................... 11-14
      11.3.2.3.1 TG Assignment Sheet ........................................................................ 11-14
      11.3.2.3.2 TG Diagram Sheet ............................................................................... 11-16
      11.3.2.3.3 TG Job Sheet ....................................................................................... 11-18
      11.3.2.3.4 TG Problem Sheet ............................................................................... 11-21
      11.3.2.3.5 TG Information Sheet .......................................................................... 11-22
      11.3.2.3.6 TG Outline Sheet ................................................................................. 11-24
11.0 TRAINEE GUIDE

The Trainee Guide (TG) is a compilation of Instruction Sheets that are designed to be used by the trainee to increase the effectiveness of the instruction. The trainee guide is not built until the first instruction sheet is created in the LP and selected in a Related Instructor Activity (RIA).

You cannot work on an instruction sheet in the TG module without first creating and selecting the instruction sheet in the RIA.

Multiple users can edit the LP/TG concurrently. Only one user can edit a Topic's data in either module at any one time.

11.1 OVERVIEW

There are three different ways to access a Trainee Guide (TG) window after the course has been selected from the Course Select menu:

1. From the AIM II main menu select the Document menu item and the Trainee Guide (TG) sub-menu item.
2. Click on the TG icon.
3. From the course tree structure double-click on the LP/TG or click on the “+” to expand the tree, click on the TG folder, and select the Options menu item and the GoTo sub-menu item. Opening the TG folder can provide Summary or Note data on the right hand portion of the course tree grid if the View menu sub-items (Note or Summary) have been checked. Summary data includes; CIN, Rev, Change, Title, and Status from the LP window. Note data contains Personal and/or Private Notes recorded by developers.

There are two ways of selecting an individual Instruction Sheet, one way is to select it starting from the Trainee Guide (TG) window and the other is to use the course tree structure.

To select an instruction sheet from the Trainee Guide (TG) window:

Step 1 From the Trainee Guide (TG) window highlight the Topic that contains the Instruction Sheet that you want to edit.

Step 2 Click on the Contents menu of the Trainee Guide (TG) window and select the TG Sheets sub-menu item. AIM II will open the TG Sheet window, which contains a list of instruction sheets in the highlighted Unit/Topic.
Step 3 Click on the TG sheet that requires editing and select the **Options** menu item and the **Select TG Sheet** option.

**To select an instruction sheet from the course tree structure:**

Step 1 Expand the LP/TG, Unit, and Topic folders.

Step 2 Open the desired Instruction Sheet folder and select the **Options** menu item and the **GoTo** option.

A TG is arranged in two basic divisions: the Front Matter and the instruction sheets. Any references that are used in the instruction sheet are included in the Resource Requirements List (RRL). The six types of instruction sheets are listed in *Table 11-1*.

### Table 11-1. Instruction Sheets, Divisions, and Associated Elements

<table>
<thead>
<tr>
<th>Front Matter</th>
<th>Instruction Sheet</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title Page</td>
<td>Assignment Sheet</td>
</tr>
<tr>
<td>Change Record</td>
<td>Job Sheet</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>Information Sheet</td>
</tr>
<tr>
<td>Security Awareness Notice</td>
<td>Problem Sheet</td>
</tr>
<tr>
<td>Safety/Hazard Awareness Notice</td>
<td>Outline Sheet</td>
</tr>
<tr>
<td>Terminal Objectives*</td>
<td>Diagram Sheet</td>
</tr>
<tr>
<td>Course Master Schedule*</td>
<td></td>
</tr>
</tbody>
</table>

* **NavedTRA 130B optional items**

#### 11.1.1 Front Matter

The Front Matter of a TG provides general information about a particular TG. AIM II generates the following Front Matter elements automatically:

- **Title Page**: Identifies the title of the course, the Course Identification Number (CIN), the Revision and Change Number, the agency it was prepared for, the agency it was prepared by, and the Promulgation Date. Any special graphics need to be created outside AIM II.
- **Change Record Page**: Records the entry of changes into the TG. It also identifies, by initials, who entered each change and when.
- **Table of Contents**: Lists the titles and the page numbers of all instruction sheets arranged by Unit and Topic number. If, at any time, you go back to the LP and add or delete instruction sheets, you will need to reprint your TG Table of Contents.
• **Security Awareness Notice:** Is initially identical to the Security Awareness Notice in the LP. Once edited it will be unique to the TG.

• **Safety/Hazard Awareness Notice:** Is initially identical to the Safety/Hazard Awareness Notice in the LP, once edited it is unique to the TG and editing will only effect the TG.

• **Terminal Objectives:** Are identical to the Terminal Objectives in the COI module.

• **Course Master Schedule:** Is identical to the Course Master Schedule in the CMS module.

### 11.1.2 Instruction Sheets

The TG module provides automated assistance for you in producing the six types of instruction sheets for your TG:

- Assignment Sheets
- Job Sheets
- Information Sheets
- Problem Sheets
- Outline Sheets
- Diagram Sheets

Assignment Sheets are used to assign necessary assignments and identify the Enabling Objectives (EOs) that the assignments are prepared to cover. An Assignment Sheet usually includes study questions for the trainee to answer.

Job Sheets are step-by-step procedures that the trainee must follow in the performance of operation or maintenance tasks and include a listing of the equipment and references necessary to perform the Job Sheet.

Information Sheets provide additional, amplifying, or background information essential to the trainee’s thorough understanding of a Topic and include a list of the references from which the information was obtained.

Problem Sheets are developed to assist the trainee in developing problem-solving skills. Because Problem Sheets may be developed in any format, all the options available for the other instruction sheets are available during development of Problem Sheets.

Outline Sheets are provided to assist the trainee in taking notes to support the current topic. Diagram Sheets are graphic representations provided for the trainee to use for notes. The interface with the AIM II Graphics utility (in the AIM II Utilities module) is where an actual graphic is entered. The TG module then allows the user to select a graphic from the graphics library in the database for the Diagram Sheet.
Answer Sheets are part of the LP; they are created when you work on the Answers portion of an Assignment, Job, or Problem Sheet in the TG. You can include graphics in your answers and import text files (in ASCII format). Answer Sheets are printed as part of the Back Matter of the LP. The text for the answers to the questions created in the Assignment, Job, or Problem Sheet is recorded on the Answer Sheet portion of the LP back matter.

11.1.3 Editors Used In The TG

There are four text editors that can be used in the TG: MS Word™, High Edit, AIM II Text Editor, and the Styled Text Editor.

If MS Word™ is present on your computer and selected as the default editor, Word will be used in the development of the Safety/Hazard Awareness Notice and where the main body of text is located on each Instruction Sheet. The Styled Text Editor will be used for the Introduction fields of the Instruction Sheets.

High Edit is the default editor if Word is not present on your computer or if selected as the default for new or previously developed materials. Approved materials that were developed in High Edit will remain in High Edit. If a Change or Revision is created for an approved course that was developed in High Edit, the developer has the ability to change the default editor to Word, but once a document is saved in Word the developer cannot change the default editor back to High Edit. The TG Options also allows the developer to save the documents in Word 97 format. When developing the TG with High Edit as default, the Safety/Hazard Awareness Notice uses the AIM II Text Editor, Introduction fields for the Instruction Sheets use the Styled Text Editor and the main body of text for each Instruction Sheet is completed in High Edit.

**WARNING: When using the editors in AIM, there is no timed backup. Save your materials frequently.**

Since Word is the most commonly used application software, the directions for developing the TG are focused on how to use High Edit.

11.1.3.1 MS Word™

MS Word™ is the default editor for the major text entry portions of the TG, which includes:

- Safety/Hazard Awareness Notice
- Assignment Sheet - Study Questions
- Diagram Sheet - Diagram
- Information Sheet - Information
- Job Sheet - Job Steps and Safety
- Outline Sheet - Topic Outline
• Problem Sheet – Problem and Directions

**Icons and menu sub-items added to Word**

There are two icons and two menu sub-items that have been added to the *Insert* menu item for AIM application. The first is the AIM Graphic *Insert* sub-menu item, which uses the AIM login icon. The second is the AIM IMM *Insert* sub-menu item, which uses a video camera icon. These menu items and icons have been provided to insure that the developer links the graphic or IMM from the AIM Graphics library and the Course RRL to the curriculum for later development of Export, Archive, HTML, and SCORM files.

**AIM is affected by the security settings in Word:**

AIM has included two macros for Word to allow the software to bring up the Graphics Selection program and create a hot link to IMM in the database. The macros are only required to add graphics from the AIM graphics library to the instruction sheet or IMM from the course RRL. They are not required for viewing or printing the TG. Microsoft has security built in to Word to prevent unwanted macros from running.

Word has a process known as digital signing to identify who created macros. This signs a macro with a certificate coming from some trusted source (the Graphics Selection macro comes from Verisign). If the macro is altered in any way, the certificate becomes invalid, which prevents tampering. When a document or template, that contains said signed macro, is opened by Word they can tell who created the macro and display that information to the user.

Early versions of Word 97 will just say: “This file contains macros, do you want to accept them?” This is an all or nothing proposition. It doesn’t tell you who wrote the macro, or whether it has been signed. In order for the user to avoid seeing this message every time AIM opens a Word document (and it will show up many times during one print cycle) the user will have to turn off “macro virus protection”. To turn this off, click the “Tools-> Options menu, go to the General tab, and uncheck the “macro virus protection” option.

Updated versions of 97, and all later versions of Word, have a more robust protection scheme. Word offers three levels of protection: Low, Medium, and High. [You can check your current settings through the Tools->Macros->Security menu. The first tab is your security level. The second tab shows your trusted sources.

Low protection is actually No protection. Files with macros are opened without warning. Medium protection will inform users of unsigned macros and suggest they don’t accept them. Signed macros will be displayed and the user has the option to accept macros from the source. If selected, any new documents opened with a macro from that source are accepted and enabled without prompting.
High protection will disable unsigned macros without notification. Signed macros offer the same accept/deny prompt as in medium above, except the user MUST accept all macros from that source before they can enable the macros. High security will disable AIM macros.

For Word 2000 (and some 97) users, it is recommended that you use the “Medium” security level. No Macro will be disabled without warning.

For Word 97 users, you must turn off macro virus warnings.

To enable the Graphics and IMM macros manually:
- Go to the AIM directory on your computer (default location is C:\Program Files\AIM II).
- Inside the AIM directory, open the directory Data Files
- Double-click to open the file named setup.doc.
- You should be asked to enable macros. Click the "Always trust..." check box and click Enable.
- The Insert Graphic/IMI icons and sub-menu items should now appear in Word.

11.1.3.2 Styled Text Editor

The Styled Text Editor is used for the instruction sheet Introduction fields, Answers for questions on Assignment Sheets, Job Sheets, and Problem Sheets and Directions for a Problem Sheet. It provides the developer with the ability to change font, pitch, center, and justify the text. Right click on the mouse and a pop-up menu appears with Cut/Copy/Paste options.

11.1.3.3 High Edit

AIM’s High Edit function is available for editing Trainee Guide (TG) Instruction Sheets if Word is not available or if the materials had previously been developed in High Edit. The High Edit menu bar offers six choices: **File, Edit, Format, Options, Table, Exit,** and **Help.**

The menu bar's **File** drop-down menu provides the options to print or print preview text, and add or delete graphics for an instruction sheet, and import a text or rich text formatted file.

The **File** drop-down menu provides the following options:
- **Add Graphic** - Allows you to select a graphic from the Graphic Utility portion of the database. The width and height of the graphic can be adjusted to size the graphic for the instruction sheet when selected in the Graphics library. When this information is saved in the Graphics library the file name of the graphic and its sizing information is placed on the Instruction Sheet where the cursor was located when the **Add Graphic** option was selected.
• **Delete Graphic** - Placing the cursor on the same line, as the graphic in the instruction sheet and selecting this option will delete the graphic from the Instruction Sheet and unlink the graphic from the Graphics library.

• **Import Text File** - If the required text has already been created in a word processor and saved as a Rich Text Format (.rtf) or Text (.txt) file the entire contents of the file can be imported into the Instruction Sheet at the location of the cursor by selecting this option and selecting the appropriate file.

• **Export to File** - This option allows you to export the contents of the editor window to either a Rich Text Format (.rtf) or Text (.txt) file.

• **Print** - This option allows you to print the entire Instruction Sheet for review. When Word is the default editor of the TG the software will print the correct page number of the TG Sheet. When High Edit is the default editor the software does not calculate the actual position of the Instruction Sheet in the TG and each printout starts with page number 1.

• **Print Preview** - This option allows you to preview and print the **Current Page, Range of Pages**, and **Entire Document** for review of the Instruction Sheet. When Word is the default editor of the TG the software will ask if you desire to have the correct page number of the TG Sheet displayed. When High Edit is the default editor, the software does not calculate the actual position of the Instruction Sheet in the TG and each printout reflects the page number contained in the document starting with the page number 1.

The menu bar's **Edit** drop-down menu offers the standard windows **Cut, Copy, and Paste** options, which can be selected by the following keystroke options:

- Cut = Ctrl + X
- Copy = Ctrl + C
- Paste = Ctrl + V.

The **Edit** menu offers a number of other options:

• **Undo (Ctrl + Z)**: Allows cancellation of a command, a keystroke, or a series of keystrokes, one at a time, in reverse order, beginning with the command, keystroke, or series of keystrokes entered most recently.

• **Clear (Del)**: Deletes the character to the right of the cursor or any highlighted text.

• **Select All**: Highlights all text within a TG sheet.

**NOTE**: Find and Find and Replace options exercised on an entire AIM Editor window of text will not examine the contents of a Graphic.

• **Find (Ctrl + F)**: Takes the cursor, either forward or backward, to the text (a word or string of words) that is specified in a window the command calls up.

• **Find Next (F3)**: Allows the software to continue a search.

• **Find and Replace (Ctrl + R)**: Allows the software to replace the text (a word or string of words) entered in the "Replace with" field. High Edit allows replacement of the next occurrence of the text, either forward or backward, or all occurrences of the text.
• **Spell Check Entire Document (Shift + F2):** Identifies possibly misspelled words, suggests substitutes, and allows you to replace or ignore possibly misspelled words throughout the text.

• **Spell Check From Cursor Down:** Identifies possibility of a highlighted word being misspelled. Suggests substitutes, and allows you to replace or ignore possibly misspelled words from the position of the cursor to the end of the file.

• **Save (Ctrl + S):** Saves the editing completed for the instruction sheet.

• **Cancel:** Cancels all editing accomplished since last save.

High Edits **Format** drop-down menu offers formatting features. Options available from the **Format** drop-down menu include the following character attributes:

- **Normal:** Changes highlighted boldface or italic text to normal.
- **Bold (Ctrl + B):** Makes highlighted text boldface (e.g., **boldface text**).
- **Underline (Ctrl + U):** Draws a line under highlighted text (e.g., _underlined text_).
- **Italic (Ctrl + I):** Makes highlighted text italic (e.g., *italic* text).
- **Strike Thru:** Draws a line through highlighted text (e.g., *delete text*).
- **Superscript:** Makes a highlighted character superscript (e.g., 22 becomes $2^2$).
- **Subscript:** Makes a highlighted character subscript (e.g., H2O becomes H$_2$O).

**Format** menu options also include the following text attributes:

- **Align Left:** Gives highlighted text flush left and ragged right margins. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Center:** Centers text. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Align Right:** Gives highlighted text ragged left and flush right margins. If text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Justify:** Lines up both left and right margins of highlighted text. If the text is not highlighted the command lines up only the text on the line on which the cursor rests.
- **Spacing:** Provides a sub-menu with items "Single", "One and a Half" and "Double". Inserts empty line spaces between each line of highlighted text.
- **Paragraph Spacing:** Provides the option to control the spacing for paragraphs within the document and allows you to select sub-menu items "Single", "One and a Half" and "Double".
- **Color:** Provides the option to change the color of highlighted text from a palette of 16 font colors (including black and white).
- **Font:** Provides the option to alter the appearance of highlighted text for viewing and printing, including size, typeface, color, and font attributes such as bold or italic.

**NOTE:** Use of Tabs with Center or Justify format can cause portions of text to be in editable.
From the **Options** drop-down menu, the following options are available:

- **Indent**: Provides for indentation of the text on the line of the cursor and subsequent lines before the next hard return. The document indenture has default of "1". Placing the cursor at the desired location, selecting the Indent option can change the indenture, by entering the value desired for left, right, and first line indentures.

- **Bullets Numbering**: Opens a Bullets and Numbering window from which you can select from either 8 different styles of bullets or numbering for selection to indent the highlighted text in your file.

- **Toggle Page Break**: Inserts or deletes a page break at the location of the cursor.

- **Tab visible**: Inserts an arrow (→) in TG sheet text wherever a tab has been entered.

- **Line Feed Visible**: Inserts a paragraph mark (¶) in TG sheet text where a hard return has been entered.

- **Space Visible**: Inserts a centered dot (●) in TG sheet text wherever a space character has been entered.

The following procedure will allow you to format a *Hanging Indent* (as it is called in Microsoft Word97). For example purposes, formatting of a job step from a Job Sheet will be described. *(NOTE: There are several different ways to format a hanging indent. The following procedure is only one of the methods.)*

**To create a Hanging Indent in High Edit:**

1. **Step 1** Position the cursor where you want to create the paragraph with a *Hanging Indent*.

2. **Step 2** Select **Indent** from the **Options** drop-down menu.

3. **Step 3** Type "3" in the Left box and "1.5" (minus 1.5) in the First Line box, then click OK. *(Note: Ensure that the entry in the Right box is 0 (zero).)*

4. **Step 4** Type "Step 1." And press the Tab key, and then type the text of the step. The text will now wrap to the start of the text following "Step 1."

From the **Table** drop-down menu, the following options are available:

- **Create Table**: Will create a table with the number of rows and columns specified. Will default to a grid table unless you desire to change the properties of the table. *To create a table refer to paragraph 11.3.2.3.6 (TG Diagram Sheet).*

- **Border Style**: Will allow you to change the border of the cells highlighted to No border, Box, Grid or Shadow. This screen will also allow you to create a 3-D effect through use of raised and sunken lines and allow you to change the line styles.
• **Cell Dimension**: Will allow you to change the row height to Auto, At Least, and Exactly. Auto will expand the height of the row automatically as text is entered, At Least will establish the height of the row in a cell until the text expands it. Exactly will limit the amount of text a cell can display in a given row. You can also select the indenture from the left for each row, change the width of a column, and change the space between columns. All measurements on the ruler bar are in centimeters.

• **Insert Table Row**: Adds a row above the row containing the cursor.

• **Append Table Row**: Adds a row to the bottom of the table.

• **Delete Table Row**: Deletes the row containing the cursor.

• **Insert Table Column**: Adds a column to the left of the column containing the cursor.

• **Append Table Column**: Adds a column to the far right of the table.

• **Delete Table Column**: Deletes the column containing the cursor.

To save an edited TG sheet, select **Edit** and **Save** on the AIM Editor window menu bar. Alternatively, enter Control + S. If you have edited text and attempt to exit via the Exit option on the menu bar, AIM II will prompt, *Text has been modified. Would you like to save?*

Holding down the Alt key and repeatedly depressing the Tab key will show you how many windows you have open. You can switch to a different window and copy text or characters required for your document then again open the TG window and paste the text or characters at the position desired.

### 11.1.3.4 AIM II Text Editor

The AIM II Text Editor is only used for the Safety/Hazard Awareness Notice is High Edit is the default editor of the TG. Although you may type in as much data as you choose, using the MS Windows cut-and-paste option from an existing application or selecting the Import Text File option is a time-saving alternative to re-typing narrative sections in the Text Editor. There are no options in the AIM II Text Editor to change fonts, underline, bold, center text, etc. it is a simple text entry window.

**To copy and paste to or from any MS Window-based word processor or any field in AIM:**

1. **Step 1** Select the text to be cut or copied by highlighting it in the original document. (Use either the keyboard or mouse.)
2. **Step 2** Press **Control + C** to copy the selected text to the clipboard.
3. **Step 3** Position the cursor at the location where you want the copied text to be pasted.
Step 4  Press **Control + V** to paste the text at the location of the cursor. Because the same information will remain in the buffer, you can paste it repeatedly until new text is copied to the buffer or the computer is powered down.

**To cut text from any MS Window-based word processor or any field in AIM:**

Step 1  Highlight the text you wish to cut.

Step 2  Press **Control + X**.

**To edit undo:** Press the **Control** key + **Z**.

Other features of the AIM Text Editor are straightforward. The **Options** menu lets you import a text (.txt) file and print or print preview documents; the **Edit** menu allows you to spell check highlighted text or an entire document; to search forward or backward through text for words or characters that you specify; to replace words or characters that you specify; to spell check the entire document or selected text; and to save or cancel changes you make to text in Text Editor.

### 11.2  TG STATUS LEVELS AND PRIVILEGES

Status levels and privileges are assigned to the LP/TG to provide a level of administrative security. Privileges minimize unauthorized use of the system by specific users. Status levels limit the type of actions that can be performed on a LP/TG. AIM II assigns the same level of permission to the TG as to the LP.

Privileges are granted for the LP and TG simultaneously and the software does not differentiate. The privilege levels that can be granted to an AIM User by an AIM Administrator are Edit, Grant, Remove Flag, and Clear In Use. The privileges an AIM User with Grant privilege can assign another AIM User are Edit and Grant. Privilege can be granted for the LP/TG independently of the Course. If you have Edit privilege, you may edit a TG. If you have Remove Flag privilege you can remove the maintenance flags in the TG, which is required prior to approval of the Course. If you have Grant privilege, you may grant and revoke privileges. If you have Clear In Use privilege you can access the Utility module and Clear an In Use flag for the LP Topic or Instruction Sheet. For additional information about privileges, see Chapter 1, Section 1.4.
11.3  TRAINEE GUIDE (TG) MAIN WINDOW

The Trainee Guide (TG) window contains four menu items; Options, Contents, Exit, and Help. The Options and Contents menu items contain sub-menu items for working on the TG.

11.3.1  TG Options Menu Item

The TG Options menu item contains the following options:

- **Find TG Sheet**: Opens the Find TG Sheet window that contains a list of all TG Sheets sited in RIAs in the LP by sheet type, number, and title. The TG sheets are listed by the Unit, Topic, and sequence number. The Find field contains a wild card and allows you to find the TG Sheet by entering the title. The Select menu item opens the Unit/Topic that contains the TG Sheet.

- **Delete Unused TG Sheets**: Opens the Unused TG Sheets window which lists all the TG Sheets in the Course RRL that have not been selected for a Related Instructor Activity (RIA) in the LP. Highlighting the Instruction Sheet not required and selecting the Delete option from the Options menu item will delete the Instruction Sheet from the Course RRL.

- **Spell Check**: Will perform a spell check of the entire TG and will write the results to a Notepad file that can be printed for reference when editing the TG. Each element and the status of the spell check will be identified in the file.

- **Security Markings**: From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:

  1. Right click and Go To the appropriate location on the course tree (left pane).
  2. From the menu bar click Options.
  3. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.
The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that can have security markings and the current marking assigned. The lower portion of the screen is broken into the following three sections:

- **Classification**: The available classifications that can be assigned, the options are:
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier**: This is an additional security modifier to the classification, the options are:
  - (None)
  - COMINT
  - Talent Keyhole
COMINT/Talent Keyhole

Release Ability: This is an additional restriction on who the document may be released to, the options are:

- (None)
- NOFORN
- For Official Use Only
- REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified. The user can select additional pages to be printed in the TG for the following: Letter of Promulgation Placeholder, Purpose of Course, How To Use the Lesson Plan, and Course Master Schedule.

- **TG Options**: The default for printing is 10 point and if printing to a file AIM will generate one file for the TG. By using the Print Options you can change the font for the TG to 12 point, for all areas not utilizing Word or High Edit, and the output can print elements of the TG as separate files. The Cover Page, Table of Contents, Change Record, Security Awareness Notice, etc., are elements of the TG and can be printed as separate files. The default editor is Microsoft Word unless the document was previously created in High Edit. If the user desires High Edit it can be selected as the editor of choice by checking the block adjacent to the statement *Don’t use Microsoft Word as the default editor*. If using High edit you can elect not to expand the Headers/Footers area and you will not be queried to enter Page X of Y or Header/Footer information when Printing or Print Previewing. If using Word/Word 97 for the TG you will be presented with a Printer Setup window when Print Previewing or Printing.

- **Print/Print Preview - Entire TG**: Both Print and Print Preview depend upon the TG Options selected and the default editor selected. Print Preview in a Word TG will display the IMM in the Word documents of each Instruction Sheet and by double clicking on the IMM designator will display the IMM (as long as the magnifier icon is disabled). The High Edit portion of the TG does not have the functionality to include IMI.
The High Edit TG Print Preview window displays the total number of pages, current page from the cover, actual page number, and allows you to find an Instruction Sheet by typing the Unit, Topic, and sequence number of the sheet. The Print menu item for High Edit contains the option to print the Current Page, Range of Pages, and Entire Document Selection of the Go To menu item allows you to select the previous, next, first, last, or desired page. Clicking on the page with the left mouse button allows you to zoom in on the page. Clicking on the page with the right mouse button allows you to zoom out. Selecting Exit will exit the TG Print Preview window and return you to the Trainee Guide (TG) window. When the option Print/Preview the Entire TG is selected, the Dialog box in the figure below is shown. If the TG is to be Printed or Previewed as a single volume the user must click on the check box next to "Ignore Volumes".

It should also be noted that if a Lesson Plan volume does not contain any TG sheets, no corresponding Trainee Guide volume will be printed.

- **Print/Print Preview - Unit/Topic TG Sheets**: Both Print and Print Preview depend upon the TG Options selected and the default editor selected.

### 11.3.2 TG Contents Menu Item

Highlight a topic to develop; then select the Contents menu item, which displays a sub-menu. From the sub-menu, you can select **Safety/Hazard Awareness Notice**, **Security Awareness Notice**, or **TG Sheets**.

### 11.3.2.1 Safety/Hazard Awareness Notice

The Safety/Hazard Awareness Notice initially is the same as contained in the LP. If desired, it can be edited and when saved will be unique to the TG.

**To edit the Safety/Hazard Awareness Notice:**
Step 1  From the Trainee Guide (TG) window, click on the **Contents** menu item and the **Safety/Hazard Awareness Notice** sub-menu item. AIM will open the TG Safety Awareness Notice window in Word™ if it is the default editor.

Step 2  If High Edit is the default editor and the text required is contained in an existing text (.txt) file, delete the existing text, select the **Options** menu item, and select the **Import Text File**. Locate the file and select it for import. The file contents will be imported into the TG Safety Awareness Notice window.

Step 3  Edit the imported or existing text as necessary and select the **Edit** menu item and the **Save** sub-menu item.

Step 4  Select the **Exit** menu item to return to the Trainee Guide (TG) window.
11.3.2.2 Security Awareness Notice

The **Security Awareness Notice** sub-menu item is provided for the trainee and is generated from the LP. If it requires editing you must do so from the LP.

11.3.2.3 TG Sheets

Selecting **TG Sheets** from the Trainee Guide (TG) window **Contents** menu item opens the TG Sheet window, which contains a list of all the TG Sheets in the Topic highlighted.

**To select a TG sheet:**

1. Highlight the desired TG Sheet.
2. Select the **Options** menu item and the **Select TG Sheet** option. Or, double click on the highlighted instruction sheet. AIM II will open a window for that type of instruction sheet from which you can enter the data for the sheet selected.

11.3.2.3.1 TG Assignment Sheet

Double clicking on an Assignment Sheet from the TG Sheets window will display the TG Assignment Sheet window for the Assignment Sheet selected.

The title is the same as the Topic title and can be edited.

**NOTE:** You must fill in the Introduction field before you enter any other data or save any changes to existing data.

**To enter information in the TG Assignment Sheet window:**

1. Position the cursor in the Introduction field.
2. Type in the desired information.
3. Select **Edit**; then select **Save**.

Selecting the **Contents** menu item produces a drop-down menu that contains **EO Links, Study Assignment, Study Questions, and Answers**. The **Study Questions** will open the High Edit window and the **Answers** sub-menu items will present the AIM Text Editor for development of those portions of the Assignment Sheet. When you are done, save your entries then select **Exit** to return to the Assignment Sheet window.
To select the EOs that the Assignment Sheet will support:

Step 1  Select the **Contents** menu item and the **EO Links** sub-menu item. AIM II will retrieve a list of the EOs in the Topic.

Step 2  Consecutively highlight each EO that the Assignment Sheet will cover and select the **Options** menu item and the **Select** option until all EOs desired have been selected. An X in the select column will indicate that the EO is selected.

Step 3  Select the **Exit** menu item and save your changes to the database. AIM II will return you to the TG Assignment Sheet window.

To create Study Assignments:

Step 1  Select the **Contents** menu item and the **Study Assignment** sub-menu item. AIM will present the Study Assignment window for your Assignment Sheet.

Step 2  Click on the Type column arrow and select the type of document (Reference, TG Sheet, or IETM) you want to direct the trainee to use for the assignment. AIM will automatically open the Course RRL for the Type of material selected.

Step 3  Highlight the desired item and either select the **Options** menu item and the **Select** option or double-click the item.

If the item selected was an IETM perform the following:

**NOTE:** AIM will connect the IETM to the database and the IETM Browser window will open. Clicking on the "+" blocks next to the titles in the IETM Browser will expand the menu and clicking on the "-" blocks next to the titles will reduce the menu.

a.  Select the **Options** menu item and the **Find** option. AIM will open the Find window. Enter the name of the item desired. The "*" wildcard can be used if the entire document number is not known. Scroll through the list and click on the item. Click on the **Select** and **Exit** menu items to return to the browser. The item selected will be highlighted.
NOTE: If the item selected has an icon between the "-" box and the title, it can be selected for the document. If an icon is not present, this represents a menu title and not an accessible IETM.

b. Select the Options menu item and the Select option. AIM will return you to the Study Assignment window and the IETM selected will be identified in the Document field.

Step 4 What do you want the trainee to do with the Reference, TG Sheet, or IETM? Click on the Before Text column and the arrow button. Click on a Before Text verb from the list provided (Read, Review, Scan, Study, or Complete) or type in the desired Before Text.

Step 5 If you need to change the document selected select the Options menu item, click on the Select RRL/TG/IETM for Document option that corresponds to the selection made in Step 3 or double click on the Document field. AIM will retrieve the References, TG Sheets, or IETMs from the Course RRL. Highlight the desired item and either select the Options menu item and the Select option or double-click the item.

Step 6 Double click on the After Text field and enter directions on exactly what to Read, Review, Scan, Study, or Complete in the document selected.

Step 7 Add additional assignments as required by selecting the Options menu item and the Add option and repeating Steps 2 through 7. When you are done, select the Exit menu item and save your entries to the database and exit to the TG Assignment Sheet window.

Step 8 Select the Exit menu item from the TG Assignment Sheet window and return to the TG Sheet window.

11.3.2.3.2 TG Diagram Sheet

Double clicking on a Diagram Sheet from the TG Sheets window displays the TG Diagram Sheet window for the Diagram Sheet selected.

Selecting the Contents menu item and the Diagram sub-menu item from the TG Diagram Sheet window opens the AIM Editor window. The File menu item allows you to select the Add Graphic option, which presents a list of the graphics contained in the Graphics library in the AIM II database.
**NOTE:** This procedure is identical for entering graphics into any text field, regardless of the type of sheet. The graphic is placed in the document in the upper left hand corner of the file. Positioning can be accomplished using the Font options and returns.

To add a graphic into a text field from Graphics library:

1. **Step 1** Highlight the desired graphic and select the **Options** menu item and the **Select** option.

   **NOTE:** The list of graphics presented will be all that are currently in the AIM II Graphics database. To add additional graphics to the database, refer to Appendix B, Utilities.

2. **Step 2** Enter the print width and height as desired (maximum: 6.5 x 8.5).

3. **Step 3** Select **Edit**, then select **Save**.

   **NOTE:** AIM II records the location and sizing data and places this information on a line in the Text Editor window. Use Print Preview to examine the positioning and sizing of the graphic for the Diagram Sheet.

4. **Step 4** Select the **File** menu item and the **Print Preview** option to view the Graphic and the relative positioning of the graphic selected. The software will prompt you with "Adjusting Graphic Location. Page Breaks before Graphics may be inserted or deleted."

5. **Step 5** Click on the **Yes** button and AIM will insert the page breaks where required or click on **No** and AIM will indicate where you should add page breaks with dashed lines.

6. **Step 6** To center the graphic in the horizontal, place your cursor on the graphic line, select the **Font** menu item and click on the **Center** submenu item. Use the Enter key to vertically position the graphic. When complete, select the **Edit** menu item and the **Save** sub-menu item to save your data to the buffer.

7. **Step 7** Select the **Exit** menu item to return to the TG Diagram Sheet window.

8. **Step 8** Select the **Exit** menu item from the TG Diagram Sheet window and save the new data to the database. The software will return you to the TG Sheets window or the course tree structure.
To modify an existing graphic from the AIM Editor:

Step 1  Position the cursor on the line of the graphic and select the **File** menu item and the **Modify Graphic** option.

The Graphic Resize window will open which displays the Graphic Width and Height entered when the graphic was selected from the Graphics library.

Step 2  To resize the graphic select the **Options** menu item and the following options will appear:

- **Increase 5%** - increases the width and height of the graphic 5%
- **Decrease 5%** - decreases the width and height of the graphic 5%
- **Original** - enabled only when the Graphic Resize window is open and will return the graphic's width and height to the values that were present when the window was initially opened.

Step 3  Select the appropriate option and select **OK** when complete. The window will close and the graphic resize information will appear on the graphic line.

11.3.2.3.3 TG Job Sheet

Double clicking on a Job Sheet from the TG Sheets window displays the TG Job Sheet window for the Job Sheet selected.

The Job Sheet window contains **Options**, **Contents**, **Edit**, **Exit**, and **Help** menu items and contains fields for the entry or modification of the Sheet Title and Introduction.

To **enter information** in the TG Job Sheet window:

Step 1  Position the cursor in the Sheet Title or Introduction field.

Step 2  Type in the desired information.

Step 3  Select **Edit** and **Save**.

The **Contents** menu item contains the sub-menu items for **Equipment**, **References** and **IETM** selection from the RRL and for the development of **Self Test Questions**, **Job Steps**, **Answers**, and **Safety Precautions**.
To identify the equipment required for the performance of the Job Sheet:

Step 1 Select the Contents menu item and the Equipment sub-menu item. The software will open the TG Job Sheet Equipment Selection window. This window defaults to the Job Sheet Equipment Selection window. Click on the Resources menu item to select a different RRL type.

Step 2 Highlight the desired equipment and select the Options menu item and the Select option or double-click on the item. The View RRL option is an aid to select the correct equipment and allow you to view all the information contained in the Site RRL for the item highlighted.

Step 3 Select the Exit menu item and save the selection to the database. The software will return you to the TG Job Sheet window.

To identify the references or IETM required for the performance of the Job Sheet:

Step 1 Select the Contents menu item and the Reference or IETM sub-menu item. The software will open the Reference or IETM for Job Sheet window.

NOTE: The Reference window is used for Assignment, Information, and Problem Sheets. The After Text field can be used to identify the exact portion of the document (Volume, Part, Chapter, etc.) if desired.

Step 2 Select the Options menu item and the Select RRL for Document or Select IETM for Document option as applicable.

Step 3 Highlight the document required for the performance of the Job Sheet and either select the Options menu item and the Select option or double-click the item in the grid.

Step 4 If the Select IETM for Document option was selected perform the following:

NOTE: AIM will connect the IETM to the database and the IETM Browser window will open. Clicking on the "+" blocks next to the titles in the IETM Browser will expand the menu and clicking on the "+" blocks next to the titles will reduce the menu.

a. Select the Options menu item and the Find option. AIM will open the Find window. Enter the name of the item desired. The "*" wildcard can be used if the entire document number is not known. Scroll through the list and click on the item. Click on the Select and Exit menu items to return to the browser. The item selected will be highlighted.
NOTE: If the item selected has an icon between the "-" box and the title, it can be selected for the document. If an icon is not present, this represents a menu title and not an accessible IETM.

b. Select the **Options** menu item and the **Select** option. AIM will return you to the Information Sheet window and the IETM selected will be identified in the References portion of the Job Sheet when printed.

Step 5 If more than one reference/IETM is required; select the **Options** menu item and the **Add** option. Repeat Steps 2 through 4 as applicable.

Step 6 When all documents have been identified, select the **Exit** menu item and save the selection(s) to the database. The software will return you to the TG Job Sheet window.

**To enter Job Steps for the performance of the Job Sheet:**

Step 1 From the TG Job Sheet window; select the **Contents** menu item and the **Job Steps** sub-menu item. AIM II will open the High Edit window, where you can add the Job Steps required. When complete, select the **Edit** menu item and the **Save** sub-menu item to save your data to the buffer.

Step 2 Select the **Exit** menu item to return to the TG Job Sheet window.

Step 3 From the TG Job Sheet window, select the **Exit** menu item, save your entries to the database, and return to the TG Sheets window.

**To enter self test questions to the Job Sheet:**

Self-test questions will be under their own heading on the Job Sheet, separate from the Job Steps. Answers to the questions will be identified using the **Answers** option. The answers will be recorded in the LP as part of the back matter called Answer Sheets. It is important to assign the questions and answers the same identifier in both the question and the answer.

Step 1 From the TG Job Sheet window; select the **Contents** menu item and the **Self Test Questions** sub-menu item.

Step 2 From the Self-Test Questions of Job Sheet window number and add/edit the questions required. If the questions have been developed in another text editor and saved as a text file they can be imported using the **Import Text File** option.

Step 3 Select the **Edit** menu item and the **Save** sub-menu item.
Step 4 Select the Exit menu item to return to the TG Job Sheet window.

To enter answers to the self test questions:

Step 1 From the TG Job Sheet window; select the Contents menu item and the Answers sub-menu item.

Step 2 From the TG Answer text of Job Sheet window number and add/edit the answers required. If the answers have been developed in another text editor and saved as a text file they can be imported using the Import Text File option.

Step 3 Select the Edit menu item and the Save sub-menu item.

Step 4 Select the Exit menu item to return to the TG Job Sheet window.

To enter a Safety Precautions statement:

Step 1 From the TG Job Sheet window; select the Contents menu item and the Safety Precautions sub-menu item. AIM II will open the High Edit window, where you can add the awareness statement. When complete, select the Edit menu item and the Save sub-menu item.

Step 2 Select the Exit menu item to return to the TG Job Sheet window.

Step 3 From the TG Job Sheet window select the Exit menu item to return to the TG Sheets window.

11.3.2.3.4 TG Problem Sheet

Double clicking on a Problem Sheet from the TG Sheets window displays the TG Problem Sheet window for the Problem Sheet selected.

The Problem Sheets window contains Options, Contents, Edit, Exit, and Help menu items.

The Problem Sheet window Sheet Title is a text entry field and the Introduction field is a Styled Text entry fields. The title was initially created in the LP but can be modified in the Problem Sheet window.

To enter information in the TG Problem Sheet window:

Step 1 Position the cursor in the Introduction field and enter the text that describes the purpose of the Problem Sheet for the trainee.
Step 2 Select the **Edit** menu item and the **Save** sub-menu item to save the text to the database.

Step 3 Select the **Contents** menu item and the **Problem** sub-menu item. AIM II will open the High Edit window, where you can add the headings and text for Problem, Given, Initial Conditions, Required Responses, and Final Conditions. When complete, select the **Edit** menu item and the **Save** sub-menu item to save your data to the database.

Step 4 Select the **Exit** menu item to return to the TG Problem Sheet window.

Step 5 Select the **Contents** menu item and the **Answers for Problem Text** sub-menu item. AIM II will open the AIM Editor window, where you can enter the answers for any questions you asked the trainee in the Required Responses portion of the Problem. Make sure the number of the answer corresponds to the number of the question. When you are done, select the **Edit** menu item and the **Save** sub-menu item to save your answers to the database.

Step 6 Select **Exit** and AIM II will return to the TG Problem Sheet window.

Step 7 Select the **Contents** menu item and the **Directions** sub-menu item. AIM II will open the AIM Editor window, where you can enter the directions for the trainee to execute the problem. When you are done, select the **Edit** menu item and the **Save** sub-menu item to save your answers to the database.

Step 8 Select **Exit** and AIM II will return to the TG Problem Sheet window.

Step 9 Select the **Exit** menu item to return to the TG Sheets window.

**NOTE:** Enter the number of the question when entering the answer. The answer page(s) will print out as the last page(s) of the LP.

### 11.3.2.3.5 TG Information Sheet

Information Sheets provide additional, amplifying, or background information essential for the trainee but not contained, or easily found, in technical manuals or other official documentation.

**To enter text in the TG Information Sheet window:**

Step 1 Double click on the Information Sheet from the TG Sheets window. The software will display the TG Information Sheet window for the Information Sheet selected.
NOTE: The cursor defaults to the Introduction field of the window. You must enter text in the Introduction field before you can select the Information menu item.

Step 2 Enter the Introduction text to explain the purpose of the instruction sheet to the trainee. Select the Edit menu item and the Save sub-menu item.

Step 3 Select the Options menu item.

Step 4 Select the Select Reference for Document or Select IETM for Document menu item.

Step 5 Highlight the Document or IETM that provided the information for the Information Sheet and select the Options menu item and the Select Reference or IETM for Document option.

Step 6 If you selected an IETM in Step 5, perform the following:

NOTE: AIM will connect the IETM to the database and the IETM Browser window will open. Clicking on the "+" blocks next to the titles in the IETM Browser will expand the menu and clicking on the "-" blocks next to the titles will reduce the menu.

a. Select the Options menu item and the Find option. AIM will open the Find window. Enter the name of the item desired. The "*" wildcard can be used if the entire document number is not known. Scroll through the list and click on the item. Click on the Select and Exit menu items to return to the browser. The item selected will be highlighted.

NOTE: If the item selected has an icon between the "-" box and the title, it can be selected for the document. If an icon is not present, this represents a menu title and not an accessible IETM.

b. Select the Options menu item and the Select option. AIM will return you to the Information Sheet window and the IETM selected will be identified in the References portion of the Information Sheet when printed.

Step 7 If more than one document is required to compile the information for the Information Sheet, select the Options menu item and the Add Reference option and repeat Steps 3 through 6 as applicable.

Step 8 When all documents have been identified, select the Edit menu item and the Save sub-menu item.
Step 9 Select the **Contents** menu item and the **Information** menu sub-item. AIM II will open the AIM Editor window. Enter the information that you will present to the trainee. When you are done, select the **Edit** menu item and the **Save** sub-menu item to save the information to the database.

Step 10 Select the **Exit** menu item to return to the Information Sheet window.

Step 11 Select the **Exit** menu item to return to the TG Sheets window.

### 11.3.2.3.6 TG Outline Sheet

The title is the same as the Lesson Topic in the LP and can be edited. The Outline Sheet lists all the EOs of the Topic and presents an outline of the major points to be covered in the Topic. More sub-headings may be included than on the DDA page in the Lesson Topic. Usually, space will not be provided for note taking.

**To enter an Introduction in the TG Outline Sheet window:**

Step 1 Position the cursor in the Introduction field.

Step 2 Type in the desired information.

Step 3 Select **Edit**; then select **Save**.

**To enter the Topic Outline for the Topic:**

Step 1 Select the **Contents** menu item and the **Topic Outline** sub-menu item. AIM II will retrieve an AIM Editor window for text entry of your outline.

If there is no sheet text you will be prompted with "Do you want to load Main DP Information?" to have the DPs for the current Topic inserted into the sheet text. If the answer is "Yes", the main level DPs will be inserted as the default text. You can modify the text as desired. If the first DP is an Introduction DP you will also be prompted, "Do you want to remove the Introduction DP?" If the answer is Yes the Introduction DP will not be added to the Outline Sheet.

Step 2 Enter the text required to outline the main points that will be covered in the Topic for each EO. When you are done, select the **Edit** menu item and the **Save** sub-menu item to save the Topic Outline to the buffer.
Step 3  Select the **Exit** menu item to return to the TG Outline Sheet window.

Step 4  Select the **Exit** menu item when you are done with the Outline Sheet and save all your entries to the database. AIM II will return you to the TG Sheets window.
CHAPTER 12

THE LEARNING OBJECT MODULE

12.0 Learning Object Module ........................................................................................................ 12-1
12.1 Learning Object Module Menu Items ..................................................................................... 12-2
  12.1.1 File Options ...................................................................................................................... 12-2
  12.1.2 Resource Options ............................................................................................................. 12-3
  12.1.3 Sheet Options .................................................................................................................... 12-4
  12.1.4 Courses, Modules, Lessons, and Sections Contents Menu Item .................................. 12-4
  12.1.5 Sections Window ............................................................................................................... 12-4
    12.1.5.1 Create a New Section .................................................................................................. 12-8
    12.1.5.2 Create a Section From AIM Data .............................................................................. 12-10
    12.1.5.3 Creating an Elements List from AIM Data ............................................................. 12-13
    12.1.5.4 Adding Test Items for a Section ................................................................................. 12-14
    12.1.5.5 Adding TG Sheets for an Instructor-Led Section ..................................................... 12-22
  12.1.6 Lessons Window .............................................................................................................. 12-29
  12.1.7 Modules Window ............................................................................................................... 12-32
  12.1.8 Courses Window .............................................................................................................. 12-33
12.0 LEARNING OBJECT MODULE

AIM addresses two methodologies for assembling Web-based training material. The default method uses Course/Module/Lessons supported by Sections that contain elements. The second method, in support of ILE and the Submarine Learning Center (SLC), of creating Course/Module/Lessons and Sections in which the Sections contain three folders (Learn, Explore, and Practice) which house the elements.

The SLC method can be used by selecting the AIM main menu Options menu item and the Preferences option. Under the Advanced tab of the User Preferences window you can check the block to use the SLC grouping for a Section. The Section window in the Learning Object Module includes three subcategories for a Section (Learn, Explore, and Practice). The required and optional elements for a Concept, Fact, Principle, Procedure, and Process Section are the same as the default method.

The Course contains at least one Module, Lessons and Sections. A Module contains at least one Lesson and Sections. The Course, Module and Lesson are packaged with overview and summary information. The Lessons also contain instructional content (Sections).

The Course and Module structure are provided to allow the creation of Instructor-Led training in accordance with the ILE architecture.

A Lesson is a Terminal Learning Object that supports a single Terminal Objective Statement.

A Section is an Enabling Learning Object (ELO) that supports a single Enabling Objective Statement (EOS). Normally the Sections are created first, then the Lesson would be developed and the supporting Sections would be selected for the Lesson in the order that they will be presented. When a Module is created, the Lesson(s) that support the Module are selected and Module(s) selected for a Course. AIM presents you with four windows, Courses, Modules, Lessons and Sections, which can be selected from the Contents menu item of the Learning Object Module or from the AIM main menu Document menu item and the Learning Object Module sub-menu item. From the Courses, Modules and Lessons windows you can develop the Overview and Summary elements, and select the Modules that support the Course, the Lessons that the support the Modules, and the Sections that will support the Lesson. From the Sections window you can develop any of the five types of Sections: Concept, Fact, Principle, Procedure, and Process.

Sections, Lessons, Modules and a Course can be developed from scratch in the Learning Object Module. A Curriculum Outline of Instruction for a course, developed in the Content Planning Module (CPM) and exported to the Enterprise Data Environment (EDE), can be imported into the Learning Object module from the EDE. A Section can be created from a Topic Learning Objective in the COI or DPs linked to the Topic Learning Objective using the Options menu item and the Create Section from AIM Data option.

Only courses, modules, lessons, and section that were imported from CPM can be versioned in AIM LO Module, after the content has been approved in CPM. The status of a course, module,
lesson, section is maintained in both CPM and AIM LO Module simultaneously.
12.1 Learning Object Module Menu Items

The Courses, Modules, Lessons and Sections windows have the following menu items:

- **File**: Allows you to Import or generate Output files.
- **Options**: Contains options applicable to Courses, Modules, Lessons, or Sections.
- **Resources**: Allows you to manage Resources.
- **Contents**: Allows you to select the windows for development of a Course, Module, Lesson, or Section and launch the Content Planning Module (CPM).
- **Edit**: Allows you to save your editing to the database or cancel the editing accomplished since the last time you saved.
- **Exit**: Allows you to exit to the AIM main menu.
- **Help**: Allows you to retrieve the Learning Object Module HTML On-Line Help.

12.1.1 File Options

The following options are available under the File drop-down menu.

- **Import Learning Object**: Allows you to Import a SCORM Output file, created in AIM I or AIM II, into the database.
- **Import from EDE**: Imports a Course from Enterprise Data Environment (EDE) that was originally designed and exported from CPM.
- **Update from EDE**: Updates the Section with the latest EDE information.
- **CBT**
  - **Update Display Pages**: Update the Display Pages associated with recently updated CBT content.
  - **Store Runtime Packages**: Stores the Runtime Package associated with CBT content.
  - **Store Source File Package**: Stores the Source Files associated with CBT content.
  - **Retrieve Runtime Package**: Retrieves previously stored Runtime Packages.
  - **Retrieve Source File Package**: Retrieves previously stored Source File Packages.
  - **Delete Runtime Package**: Deletes a previously stored Runtime Package.
  - **Delete Source File Package**: Deletes a previously stored Source File Package.
- **Generate Output Package**
  - **SCORM**: This output uses the Metadata Specification and SCORM version selected from the AIM main menu **Options>Preferences** in the Advanced tab. It Allows you to create an AIM export file that can be:
    - Imported into another AIM I or AIM II database
    - Unzipped and used as a standalone preview of the Course/Module/Lesson/Section.
    - Imported into self paced authoring tools for the development of interactive ILT or Self-Paced Sections.
    - Imported into Enterprise Data Environment (EDE).
Tested with the ADL test suite to verify it is a valid SCORM package
- **Elite**: Allows you to create a Section or Lesson output that can be imported into the electronic classrooms that employs Elite software. This output uses SCORM Version 1.2, regardless of the version selected under AIM main menu **Options>Preferences** in the Advanced tab.

- **Export RRL to EDE**: Allows the user to Export RRL data to the EDE, this RRL data can then be Imported into the Content Planning Module (CPM).

- **Preview**
  - **Course Level Preview**:  
    At the course level the preview options are:
    - LP (or LP Change Package if available)
    - TG (or TG Change Package if available)
    - TPP from EDE
    - TCCD from EDE
  
  - **Module Level Preview**:  
    At the Module level the preview options are:
    - LP
    - TG

  - **Lesson and Section Level Preview**:
    - **Web**: For Self-Paced Sections
    - **Developer**
    - **Student**
    - **Storyboard**
    - **LP**: This option will output a Course in the classic AIM/LP format when a Course is highlighted.
    - **Sheets**: For Instructor-Led Sections that contain Instruction Sheets.

**NOTE:**
At the Course level, when LP is selected from the Preview menu the following dialog box appears:
The top section allows the user to select page control printing and Header/Footer editing.

The **Course Matter Items** allows the user to select additional; course materials to be Printed/Previewed, is includes Front Matter, Content, and Reference Materials.

There is a check box to exclude Self-Paced sections, if unchecked Self-Paced sections will be included in the Print/Preview.

The **Main DP Printing Options** allows the Discussion Points to either be Printed/Previewed one per page or Continuously.
**DP Spacing** allows the user to specify the number of blank lines between discussion points. There is also a checkbox that, when checked, will override any specified spacing that may have been used during development.

The Glossary may be printed per Lesson or for the entire course. The Glossary will either print at the end of each Lesson, after the Summary or at the end of the Course, after the OAC. When the Glossary is printed it will be alphabetized.

**NOTE:**

At the Module, Lesson, and Section levels, when LP is selected from the Preview menu the following dialog box appears:

![Printer Setup Dialog Box]

The top section allows the user to select page control printing and Header/Footer editing.

There is a check box to exclude Self-Paced sections, if unchecked Self-Paced sections will be included in the Print/Preview.

The **Main DP Printing Options** allows the Discussion Points to either be Printed/Previewed one per page or Continuously.

The Section Printing Options includes check boxes for not including Self-Paced Sections as these are not Instructor-led Sections, Excluding Section Front Matter as it may be redundant to the Lesson Front Matter, and Excluding Information Sheet References.
NOTE:
If Exclude Section Front Matter is selected no Section Front Matter will be displayed, including Information Sheet References.

- **DP Spacing** allows the user to specify the number of blank lines between discussion points. There is also a checkbox that, when checked, will override any specified spacing that may have been used during development.

**Generate Test Questions Package**: Allows you to create a Questionmark QML file/package from the test items developed for the Section that can be imported into the Questionmark software. Practice and Assessment Items may be printed for review by selecting either "Practice Item to PDF" or "Assessment Item to PDF" from the Generate Test Items submenu. When selecting either practice items or assessment items the user will then have various printing options depicted in the figure below.

Regardless of which print option is selected the output will have a header of "For Review Only - Not a Test", as actual tests should be generated using a QML package.

- **Submit Content**: Sets the status of the selected course, module, lesson, or section to Submitted. Submitting a course, If the course was imported from CPM via the EDE the status will also be set to Submitted in CPM; any changes to the COI in CPM will reset the status to New in CPM and Complete in AIM LO Module.
  - **Accept Content**: Sets the status of submitted content to Accepted. If the course was imported from CPM via the EDE, the status will also be set to Accepted in CPM. **Note**: Accepted content can only be approved or rejected in CPM. Approved content cannot be changed in AIM LO Module and a new version must
be created in CPM, the course exported from CPM and updated from EDE in AIM LO Module. When content is rejected in CPM, a message is displayed stating that. The reason for a rejection can be viewed in CPM under the History for the content.

- **Reject Content**: Sets the status of submitted content back to Complete. If the course was imported from CPM via the EDE, the status will reset to New in CPM.

### 12.1.2 Resource Options

The following options are available from the Resources drop-down menu, these options will vary depending on which level is highlighted (Course, Module, Lesson, Section, or Element):

- **Add Resource**: Allows you to add a resource from the Site RRL Utility to the Resources Tab of the Element you have open.
- **Add Graphic**: Allows you to add a graphic from the Graphics Utility to the Resources Tab of the Element you have open.
- **Add Sheet**: Allows the user to add Instructional Sheets as a Resource.
- **Add Fault**: This option brings up the Function Faulted box where users can Create Faults to an Element.
- **Add Free Text**: Allows the user to add free text to be used in a RIA.
- **Delete Resource**: Allows you to delete a resource from the Resources Tab of the Element you have open.
- **Copy Resource**: Allows the user to copy a resource that is already used by an Element.
- **Paste Resource**: Used to Paste a previously Copied Resource in an Element.
- **Replace Resource**: Used to replace one Resource with a different Resource.
- **Select Later IETM**: Used to select a later version of an existing IETM.
- **No-Change Change**: Used to update to a later version of an IETM, the later version must first be imported into the AIM database.
- **View IETM Structure**: Allows you to open the browser with the structure of the IETM.
- **Launch/View IETM**: Allows you to view the IETM identified in the Resources.
- **View RRL**: Allows you to see what information is entered about a resource when highlighting a resource or graphic cited by a Section’s Element.
- **Display Media**: Allows you to display an IMM full screen.
- **Modify/View Fault**: Used to edit existing Faults.

### 12.1.3 Sheets Options

Instructional Sheets are added at the Section level and are only available for Instructor-Led Sections. Outline sheets may be added at the Course, Module and Lesson level, all other Sheets can only be added at the Section level. Lesson sheets may only be assigned to the Lesson’s RIAs under Overview/Summary. Section sheets may only be cited within the RIAs or Assessment/Practice items of the section.
The options from the Sheet drop-down menu are:

- **Add Sheet**: Allows you to add Instruction Sheets to an Instructor-Led Section when the Section Title is highlighted.
  - Assignment
  - Diagram
  - Information
  - Job
  - Outline
  - Problem
- **Modify/View Sheet**: Allows you to modify and view the highlighted TG Sheet in the Sheets tab of the Section.
- **Delete Sheet**: Allows you to delete the highlighted TG Sheet in the Sheets tab of the Section.
- **Copy Sheet**: Copies the highlighted sheet for pasting into a different Section.
- **Paste Sheet**: Pastes a previously Copied Sheet into the desired Section.

### 12.1.4 Courses, Modules, Lessons and Sections Contents Menu Item

When the Learning Object Module is selected from the **Document** menu item, choose the type of material you are developing: Course, Module, Lesson, or Section. Clicking on the Learning Object Module icon will open the Courses window by default. The **Contents** menu item provides selection of Courses, Modules, Lessons, Sections or Launch CPM (Content Panning Module).

### 12.1.5 Sections Window

A Section is a self-contained chunk of information built to accomplish a single enabling objective statement. Sections are the instructional content selected for the Lesson. They are combined to form the **Lesson**. A Section is referred to as a “topic” within the **Lesson**. The Section content (elements) varies depending on the type of Section selected.

There are five types of Sections:

- **Concept** – A class of items that shares common key features and is known by a common name.
- **Fact** – Unique, one-of-a-kind types of information.
- **Procedure** – A sequential set of steps to be followed by one individual to accomplish a task or make decisions. Actions within the procedure must be done the same way each time within a given situation.
- **Process** – A series of actions, changes, or functions that achieve an end result. It often is used when you need to illustrate a flow of events that describes how something works.
- **Principle** – A procedural job task that requires judgment or when guidelines must be applied to a situation.
Each type of Section has different elements. The Table 12-1 illustrates the Section types and the elements that are required and optional. Each element is presented on one screen for E-Learning content.

<table>
<thead>
<tr>
<th>ELEMENTS</th>
<th>SECTION TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Concept</td>
</tr>
<tr>
<td>Section Review</td>
<td>O</td>
</tr>
<tr>
<td>Introduction</td>
<td>R</td>
</tr>
<tr>
<td>Definition</td>
<td>R</td>
</tr>
<tr>
<td>Fact-Image, List, or Table</td>
<td>O</td>
</tr>
<tr>
<td>Example</td>
<td>R</td>
</tr>
<tr>
<td>Non-Example</td>
<td>O</td>
</tr>
<tr>
<td>Analogy</td>
<td>O</td>
</tr>
<tr>
<td>Principle Statement</td>
<td>O</td>
</tr>
<tr>
<td>Guidelines</td>
<td>R</td>
</tr>
<tr>
<td>Decision, Procedure or Combined Table</td>
<td>R</td>
</tr>
<tr>
<td>Demonstration</td>
<td>O</td>
</tr>
<tr>
<td>Practice Questions</td>
<td>R</td>
</tr>
<tr>
<td>Process</td>
<td>R</td>
</tr>
<tr>
<td>Section Review</td>
<td>O</td>
</tr>
<tr>
<td>Assessment</td>
<td>R</td>
</tr>
<tr>
<td>Interaction</td>
<td>O</td>
</tr>
<tr>
<td>Glossary</td>
<td>O</td>
</tr>
<tr>
<td>Safety Information</td>
<td>O</td>
</tr>
<tr>
<td>Security Information</td>
<td>O</td>
</tr>
</tbody>
</table>

NOTE: R=Element is required and O=Element is optional.

Table 12-1. Required and Optional Elements for a Section

When developing each type of Section the Elements that are required will be identified in **bold**. The optional elements can be deleted if not desired by highlighting the element on the Sections window, selecting the **Options** menu item and the **Delete** option.

Additional Elements can be added to a Section by selecting the **Options** menu item, the **Add Element** option. The Elements presented and available for selection are dependent on the type of Section being developed.
The Sections window options are as follows:

- **Create Section**: Allows you to add a Section, of one of the types selected below, to the Section list. If there is doubt about the type a Decision Wizard is provided. Answering the questions in Decision Wizard will produce a suggested type by percentage.
  - **Concept**
  - **Fact**
  - **Principle**
  - **Procedure**
  - **Process**
  - **Decision Wizard**

- **Copy Elements**: With a Section highlighted all elements of the Section are copied.

- **Paste Elements**: Allows the user to paste previously copied elements into a Section. After selecting **Paste Elements** the user will see a pop-up box like the one below. Users can select the type of elements that will be pasted into the current Section.

- **Copy/Paste Element**: To copy and paste single elements, highlight the element, select **Copy Element** from the **Option** drop down menu, move the cursor to the location to paste the element, select **Paste Element** from the **Option** menu drop down.

- **Create Section from AIM Data**: Allows you to select the desired course, the COI and TLO, or DP in AIM I to initiate the development of a Section.

- **Create an Elements List from AIM Data**: Allows you to select DP/RIAs from an existing AIM course.

- **Create Student Sheet From AIM Data**: Allows you to create an entire Instruction Sheet from an Instruction Sheet that exists in a course in the AIM database when the Section Title is highlighted.

- **Add Element**: Allows you to add additional elements that are dependent on the type of Section being developed. Elements are automatically numbered when they are created.
• **Add Note/Caution/Warning Element:** These can be placed after any existing Section Element or sub-element.
  - Note
  - Caution
  - Warning

• **Re-sequence Elements:** Allows you to re-sequence the elements of the Section to put them in the order desired for presentation to the student.

• **Storyboard:** Allows the developer to detail concepts and add materials for the Storyboarding of Self-Paced Sections. The following tabs accept input in Rich Text Format (RTF) with the exception of the Comments tab that is used to add Notes and ISD Comments. ISD Comments are added in CPM and imported from the EDE into the LO Module. ISD Comments are not editable in the LO Module
  - Display
  - Narration
  - Animation
  - Storyboard Notes
  - Table Text
  - Interaction
  - Comments

• **Copy:** Allows you to duplicate a Section in the respective window.

• **Create New Version:** Allows you to create a new version of an approved Section.

• **Delete:** Allows you to delete a Section in the respective window.

• **Add Test Item:** Allows you to add a test item for Practice or Assessment Elements.
  - Fill-in the-blank
  - Multiple Choice
  - True/False
  - Two-Column Matching
  - Performance

• **Modify/View Test Item:** Allows you to modify or view a test item for a Practice or Assessment Element.

• **Delete Test Item:** Allows you to delete a test item for a Practice or Assessment Element.

• **Trainee Preparation Materials:** This option is used to identify any preparation materials the student may need to review before the Section.

• **Security Markings:**
  
  From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:
  
  1. Right click and Go To the appropriate location on the course tree (left pane).
  2. From the menu bar click Options.
  3. From the Options dropdown menu click Security Markings

  This will display the screen show in the figure below.
The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that can have security markings and the current marking assigned. The lower portion of the screen is broken into the following three sections:

- **Classification**: The available classifications that can be assigned, the options are:
  
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier**: This is an additional security modifier to the classification, the options are:
  
  - (None)
  - COMINT
  - Talent Keyhole
  - COMINT/Talent Keyhole
• Release Ability: This is an additional restriction on who the document may be released to, the options are:
  o (None)
  o NOFORN
  o For Official Use Only
  o REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

• **ISD Considerations:** Considerations are entered into the Content Planning Module (CPM) and are brought over to the LO Module on import of a course. They are only editable in the CPM. This item will be hidden from the menu for non-imported content.

• **Find Section:** Allows you to enter text to find a Section.

• **Check Spelling:** Allows you to check the spelling of a Section or an Element.

• **Show:** Allows you to select a specific type of Sections and list them. Default is **All.**
  o **All**
  o **Concept**
  o **Fact**
  o **Principle**
  o **Procedure**
  o **Process**

• **Grant Privileges:** Allows you to grant the privileges you have to another AIM User.

• **Show In Use Information:** If the In Use flag is set this option will display information regard which use caused the flag to be set.

• **Reset In-Use:** This option is used to rest the In Use flag, allowing the user to edit the data.

• **Explain Flag**

• **Remove Flag**

Select the SCORM Metadata specification and the version of SCORM that will be used to develop the material in the Learning Object Module.

Step 1 From the AIM main menu, select the **Options** menu item and the **Preferences** option.

Step 2 Click on the **Advanced** tab.

Step 3 In the Metadata Specification field, click on the down-arrow, and select one of the following:
  • NSCORM
• SCORM

Step 4 In the SCORM version field, click on the down-arrow, and select one of the following:
• V1.2,
• 2004, or
• 2004 3rd ed.

NOTE
SCORM 2004 is selected by default if NSCORM was selected in Step 3.

12.1.5.1 Create a New Section

To create a new Section in the Learning Object Module:

Step 1 From the AIM main menu, select the Document menu item, the Learning Object Module sub-menu item and Section or click on the Learning Object Module icon and when the Courses window opens select the Contents menu item and the Sections sub-menu item.

Step 2 From the Sections window, select the Options menu item and the Create Section option for a Section that will be developed from data not present in the AIM database.

Step 3 Select one of the types of Section (Concept, Fact, Principle, Procedure, or Process).

NOTE
Select the Decision Wizard option if the type has not been determined. The Wizard will provide the type based on the answers you provide to the questions.

Step 4 AIM will add the New (Type) Section to the tree structure in the left-hand pane. Expand the structure of the Section by clicking on the + block. This will reveal the required elements (in Bold) and optional elements of the Section.

Step 5 With the New (Type) Section highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Section titled General, Job, Skills Data, Info, Sheets for an Instructor-Led Section, Resources, and Metadata. Add/identify the following information for each tab and select the Edit menu item and the Save sub-menu item when completed with each tab.

• General – Enter the Title, Identification Number and Objective in the fields provided. The Identification Number will be assigned for generating an output file for SCORM, NLCOM or AICC and if unknown can remain blank until assigned. Click on the down arrows for Section Type, Status, and Classification and select the appropriate information. Identify the Instruction Type by selecting Self-Paced or Instructor-Led. If the Section content is not releasable to foreign nationals, check the NOFORN block. Enter the
Class/Lab/PA Time in minutes for an Instructor-Led Section or IMM Time in
minutes for a Self-Paced Section.

- **Job** – Enter the Duty and Job Task that the Section supports in the fields
  provided. Click on the down arrows for Category (Knowledge or Skill) and
  select the appropriate entry. If the Section is created using the **Create Section
  from AIM Data** option the CIN, Learning Objective, and DP Number fields
  will have content from the material copied.

- **Skills List** – Skills data identifies Task/Knowledge/Skill/Tools/Resources by
  and ID, Type and Text. If the Skills data is available in the EDE the Skill List
data will automatically be entered when importing from EDE.

- **Info** – The Information tab can contain information about who the author and
  owner is, the date the Section was created, published, and an expiration date.
  Keywords can be added to facilitate searching the database for the Section.
  Click on the down arrows for Cognitive level (Remember or Apply) and select
  the appropriate entry.

- **Sheets** – Instruction Sheets can be added to support a Section. The TG Sheets
  are identified by Sequence, Type and Title in this tab. A TG Sheet is added by
  highlighting the Section title, selecting the **Sheets** menu item and the **Add
  Sheet** option.

- **Resources** – Resources that support the entire Section will be identified in this
  tab. Resources cannot be added directly into this tab. Resources can be added
to Element folders from the Site RRL by selecting the **Resources** menu item
  and the **Add Resource** option when developing the Element folders of the
  Section.

- **Metadata** – Each of the folders in the metadata structure contain fields to
  enter appropriate information for SCORM specification and version selected.
  Bolded folders indicate that data entry is required. Right-clicking on headings
  will identify the information that can be added for the SCORM version
  selected.

**Step 6** Develop each Element of the Section. Each Element contains an **Element** tab, a
**RIA** tab is present if Section is identified as Instructor-Led, and **Metadata** tabs.
The Element tab contains the Styled Text Editor that you can use to create
information and to paste information saved as RTF. The **Search AIM Data**
option can be used to access data for the Elements and RIA tab. The RIA tab
works in conjunction with the **Resources** menu item and the **Add Resource, Add
Graphic, Add Sheet, Add Fault, Add Free Text** and **Delete Resource** options.
The Metadata tab contains folders and fields to enter key words for the Element.
Add/identify the information for each element and select the **Edit** menu item and
the **Save** sub-menu item when completed with each element. Refer to Table 1
above to determine the required and optional elements for the type of Section
being developed.

### 12.1.5.2 Create a Section from AIM Data

The **Create Section from AIM Data** option allows you to select the desired course, COI or DP,
Part, Section, and Topic desired to build any of the types of Sections. If the type of Section is not readily identifiable, the **Decision Wizard** option can be used to determine the type of Section.

If test questions have already been developed (for the PPP line item the TLO and DP are linked to) in the database they can be selected for the Practice or Assessment Elements in the Section by using the **Search AIM Data** option in the Learning Object Module after the TLO or DP has been selected and the Section created.

**Step 1** From the AIM main menu, select the **Document** menu item, the **Learning Object Module** sub-menu item and **Section** or click on the Learning Object Module icon and when the Courses window opens select the **Contents** menu item and the **Sections** sub-menu item.

**Step 2** From the Sections window select the **Options** menu item and the **Create Section from AIM Data** option.

**Step 3** From the Select Course window click on the desired course containing the Topic Learning Objective (TLO) or Discussion Point (DP) that the Section will be converted from and then click on the **Select** menu item.

**Step 4** From the Create Section from CIN window you can select either the DP or COI. You can create a Section from a TLO in the COI, if the COI is selected, or from a DP in the LP if DP is selected. For the purpose of this explanation click on the down arrow and select DP.

**Step 5** From the Course Structure in the left-hand pane open the desired Part and Section, to reveal the topics in the Section.
Step 6  Click on the desired Topic to reveal the DPs for the Topic in the right-hand pane.

Step 7  Click on the desired DP and click on the Create menu item. A sub-menu will appear and you can select the type of Section to be created from the DP. If it is unclear which type the DP should become, the Decision Wizard should be selected. When you have answered all questions in the Decision Wizard AIM will bold the type of Section based on your answers and provide a percentage for each type. Click on the appropriate type.

Step 8  AIM will return you to the Sections window where you can develop your Section after selecting the appropriate type of Section.

Step 9  The Section converted from the DP is added to the tree structure in the left-hand pane. Expand the structure of the Section by clicking on the + block. This will reveal the required (in Bold) and optional Elements of the Section. If using the SLC method, the Learn, Explore, and Practice folders will contain the Elements that are required and optional.

Step 10  With the Section highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Section titled General, Job, Skills Data, Info, Sheets for Instructor-Led Section, Resources, and Metadata. Add/identify the following information for each tab and select the Edit menu item and the Save sub-menu item when completed with each tab.

- **General** – Enter the Title, Identification Number and Objective in the fields provided. The Identification Number will be assigned for generating an output file for SCORM, NLCom or AICC and if unknown can remain blank until assigned. Click on the down arrows for Section Type, Status, and Classification and select the appropriate information. Identify the Instruction Type by selecting Self-Paced or Instructor-Led. If the Section content is not releasable to foreign nationals, check the NOFORN block. Enter the Class/Lab/PA Time in minutes for an Instructor-Led Section or IMM Time in minutes for a Self-Paced Section.

- **Job** – Enter the Duty and Job Task that the Section supports in the fields provided. Click on the down arrows for Category (Knowledge or Skill), and select the appropriate entry. If the Section is created using the Create Section from AIM Data option, the CIN, Learning Objective, and DP Number fields will have content from the material copied.

- **Skills List** – Skills data identifies Task/Knowledge/Skill/Tools/Resources by and ID, Type and Text. If the Skills data is available in the EDE the Skill List data will automatically be entered when importing from EDE.

- **Info** – The Information tab can contain information about who the author and owner is, the date the Section was created, published, and an expiration date. Keywords can be added to facilitate searching the database for the Section. Click on the down arrows for Cognitive level (Remember or Apply) and select the appropriate entry.
• **Sheets** – Instruction Sheets can be added to support a Section. The TG Sheets are identified by Sequence, Type and Title in this tab. A TG Sheets is added by highlighting the Section title, selecting the **Sheets** menu item and the **Add Sheet** option.

• **Resources** – Resources that have been selected for the Elements of the Section will appear in the Resources tab. Resources cannot be added directly to this tab.

• **Metadata** – Each of the folders in the metadata structure contain fields to enter appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected.

**Step 12** Develop each Element of the Section. Each Element contains Element, Instructor Activity for Instructor-Led Sections, Resource, and Metadata tabs.

• The Element tab contains the Styled Text Editor that you can use to create information and to paste information saved as RTF. The **Search AIM Data** options can be used to access DP and RIA information linked to the objective used to create the Section or from other courses and topics. DP and RIA information can be copied into the Element tab and resources selected in the RIA will be added to the Resources tab.

• The Instructor Activity tab will be present for Instructor-Led Sections. Enter the instructions for the instructor detailing how to teach the element.

• The Storyboard option will be present for Self-Paced Sections. Enter storyboard development concepts to be used in any self-paced content authoring tool that is XML aware and has the ability to translate AIM XML outputs.

• The Resource tab works in conjunction with the **Resources** menu item and the **Add Resource**, **Add Graphic**, and **Delete Resource** options. These options allow you to add items from the Site RRL and Graphics Utility.

• The Metadata tab contains folders in the metadata structure with fields to enter key words for the Section and appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected. Add/identify the bolded information for each item and select the **Edit** menu item and the **Save** sub-menu item when completed with each Element.

Refer to Table B-1 above to determine the required and optional elements for the type of Section being developed.
12.1.5.3 Creating an Element List from AIM Data

The Creating Element List from AIM Data option is used to copy DP/RIA information from an existing AIM course. To copy DP/RIAs follow the steps below:

Step 1 From the Learning Object Module main menu select the Section icon, fourth icon from the left.

Step 2 Select Option, Create Section, Fact.

Step 3 In the Instruction Type select Instructor-Led from the drop-down menu.

Step 4 Highlight the Section titled New Fact Section.

Step 5 Click the '+' sign next the New Fact Section to expand the section and show the elements contained in the section.

Step 6 Select Options, Create Element List from AIM Data.

Step 7 From the Select Course box, select the desired course to copy DP/RIA information from.

Step 8 Click the '+' sign next to the desired Unit to expand the unit and show the Topics list.

Step 9 Highlight the desired topic.

Step 10 Click in the Sel column of the desired DP.

Step 11 Select Options.

Step 12 Select either Select, to select the main DP only, or Select With Children to select main DP and Sub-DPs.

Step 13 In the Element Type column of the main DP select the desired type (Fact-Image, Fact-List, Fact-Table, Section Review, Practice, or Interaction). Element types for Sub-DPs cannot be selected.

Step 14 Select Edit, Save. The main DP will now be listed as the Element Type selected (DP text will be in the text box of the Element tab), Sub-DPs can be viewed by clicking the '+' sign next to the new element.
12.1.5.4 Adding Test Items for a Section

If test questions have already been developed for the PPP table line item linked to the TLO/DP in the database they can be selected for the Assessment item in the Section by using the **Search AIM Data** option in the Lesson/Section Utility after the TLO/DP has been selected and the Section created. The Test Items for the Section can then be edited as necessary.

**To add new Test Items for a Section:**

**Step 1** From the AIM main menu, select the **Document** menu item, the **Learning Object Module** sub-menu item and **Section** or click on the Learning Object Module icon and when the Courses window opens select the **Contents** menu item and the **Sections** sub-menu item.

**Step 2** In the left-hand pane, click on the desired Section, and open it (click on the “+” block) to reveal the content items. Click on the Practice or Assessment element. If using the SLC method, the Practice folder will contain the Practice and Assessment elements of the Section.

**To develop Fill-in-the-blank questions:**

**Step 1** From the Sections window select the **Options** menu item and the **Add Test Item** option. Select **Fill-in-the-blank** from the sub-menu.

**Step 2** Click on the Resource tab. Select the **Resources** menu item and the **Select Resource** option.

**Step 3** Click on the Resource that contains the test question information, and select the **Select** menu item. Resource options are IETM, IMM, Sheet, or Publication.

**Step 4** Enter the required resource information as determined by the resource selected.

**Step 5** Click on the TOS down arrow, and select the appropriate TOS for the question.

**Step 6** Click on the K Level field down arrow, and from the drop-down menu select the appropriate level of learning for the question.

**Step 7** Click on the Q&A tab. Click on the Stem field, and enter the text of the question. Use the underline feature to enter the blank line.
Step 8  Click on the Answer field, and enter the text of the answer.

Step 9  The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 10 If there is an associated graphic to be used in conjunction with the test item, perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic, and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 11  Select the Edit menu item and the Save sub-menu item to save the Fill-in-the-blank question to the database.

Step 12 A down-arrow will appear in the Status field when the required information has been added to the fields and tabs, and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 13  Select the Exit menu item to return to the Sections window.

To develop Multiple Choice questions:

Step 1  From the Sections window, select the Options menu item and the Add Test Item option. Select Multiple Choice from the sub-menu.

Step 2  Click on the Resource tab. Select the Resources menu item and the Select Resource option.

Step 3  Click on the Resource that contains the test question information, and select the Select menu item. Resource options are IETM, IMM, Sheet, or Publication.

Step 4  Enter the required resource information as determined by the resource selected.
Step 5  Click on the TOS down arrow, and select the appropriate TOS for the question.

Step 6  Click on the K Level field down arrow, and from the pop-up menu select the appropriate level of learning for the question.
K1 - Recognize (recommended selection for T/F Test Items)
K2 - Recall
K3 - Comprehend
K4 - Analyze
K5 - Evaluate

Step 7  Click on the Q&A tab. In the Stem field, add the text of the question.

Step 8  In the Answer/Distractor fields, enter the text of the distractors and answer. At least four entries must be made to save the question to the database.

Step 9  Click on the Answer text, select the Options menu item and the Set Answer option, or double-click on the column adjacent to the answer. An “X” will appear in the Correct Answer column adjacent to the answer.

Step 10 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 11 If there is an associated graphic to be used in conjunction with the test item perform the following:
  a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
  b. Click on the desired graphic and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.
  c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.
Step 12 Select the Edit menu item and the Save sub-menu item to save the multiple-choice question to the database.

Step 13 A down arrow will appear in the Status field when the required information has been added to the fields and tabs, and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 14 Select the Exit menu item to return to the Sections window.

To develop True/False questions:

Step 1 From the Sections window select the Options menu item and the Add Test Item option. Select True/False from the sub-menu.

Step 2 Click on the Resource tab. Select the Resources menu item and the Select Resource option.

Step 3 Click on the Resource that contains the test question information, and select the Select menu item. Resource options are IETM, IMM, Sheet, or Publication.

Step 4 Enter the required resource information as determined by the resource selected.

Step 5 Click on the TOS down arrow and select the appropriate TOS for the question.

Step 6 Click on the K Level field down arrow, and from the pop-up menu, select the appropriate level of learning for the question.
   K1 - Recognize (recommended selection for T/F Test Items)
   K2 – Recall
   K3 - Comprehend
   K4 – Analyze
   K5 - Evaluate

Step 7 Click on the Stem field and enter the text of the question.

Step 8 Identify the correct answer by clicking on the box next to either TRUE or FALSE. An "X" will appear in the box to indicate the correct answer.
Step 9 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item, and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 10 If there is an associated graphic to be used in conjunction with the test item, perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic, select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 11 Select the Edit menu item and the Save sub-menu item to save the True/False question to the database.

Step 12 A down arrow will appear in the Status field when the required information has been added to the fields and tabs, and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 13 Select the Exit menu item to return to the Sections window.

To develop Two-Column Matching test questions:

Two column matching test items are actually four to eight individual test items in one question. To develop a two-column matching test item you will enter data in two parallel columns that correspond to each other. The left column (stimulus) will contain four to eight entries. The right column (responses) will contain six to ten entries. The right column MUST have two more entries than the left column. These two additional entries are provided to prevent the trainees from being able to guess at the last few matching items after having ruled out the ones that they know. The entries in the columns can be re-sequenced using the click-and-drag method.

Step 1 From the Sections window select the Options menu item and the Add Test Item option. Select Two-Column Matching from the sub-menu.
Step 2  Click on the Resource tab. Select the Resources menu item and the Select Resource option.

Step 3  Click on the Resource that contains the test question information, and select the Select menu item. Resource options are IETM, IMM, Sheet or Publication.

Step 4  Enter the required resource information as determined by the resource selected.

Step 5  Click on the TOS down arrow, and select the appropriate TOS for the question.

Step 6  Click on the K Level field down arrow, and from the pop-up menu, select the appropriate level of learning for the question.

Step 7  Click on the Q&A tab. Click on the Stem field and enter the text of the directions for the Column Matching Test Item.

Step 8  Select the Options menu item, and the Add Left Entry option, or click in the desired location to add an entry.

Step 9  Enter the text for the first item of the left column.

Step 10  Repeat Steps 8 and 9 for each item to be added to the left column. AIM I will permit up to eight entries. After four entries in either column, you will need to manually add entries using the Options drop-down menu.

Step 11  Select the Options menu item and the Add Right Entry option, or click in the desired location to add an entry.

Step 12  Enter the text for the first item in the right-hand column.

Step 13  Repeat Steps 11 and 12 for each item to be added to the right-hand column. AIM I will permit up to 10 entries for the right-hand column. The right-hand column must have two more entries than the left-hand column.

Step 14  Click on the Answer column for the first item in the left-hand column and select the letter of the matching item in the right column. You can use an answer once, more than once, or not at all.

Step 15  Repeat Step 14 for each item in the left column.
Step 16 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item, and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 17 If there is an associated graphic to be used in conjunction with the test item, perform the following:
   a. Click on the Graphic tab. Select the Options menu item and the Select Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic, and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 18 Select the Edit menu item and the Save sub-menu item to save the Two Column Matching question to the database.

Step 19 A down-arrow will appear in the Status field when the required information has been added to the fields and tabs and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.

Step 20 Select the Exit menu item to return to the Sections window.

To develop Performance questions:

Step 1 From the Sections window select the Options menu item and the Add Test Item option. Select Performance from the sub-menu.

Step 2 Click on the K Level field down arrow, and from the drop-down menu select the appropriate level of learning for the question.

Step 3 Click on the Performance tab and enter the title of the Performance scenario in the Title field.

Step 4 Click in the text field below the Title and add the text for the Performance scenario.
AIM I will open the Select Site RRL window that contains the Publications that are contained in the Site RRL.

Step 5 Click on the Resources tab. Click on the Options menu item and the Select Resource option.

AIM I will open the Select Site RRL window that contains the Publications that are contained in the Site RRL.

Step 6 Click on the publication that supports the Performance scenario and select the Select menu item. AIM I will enter the publication identifier in the Resources tab of the Performance Test Item for Line Item window. You may also double-click on the desired publication to select it.

Step 7 Enter the publication breakdown information (e.g., Volume, Part, Chapter) in the publication breakdown fields.

Step 8 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who Administratively approved the test item and the Date the test item was first created. The default developer is the login name of the individual that first created the test item and can be edited. The default date can be edited before the test item is locked for approval.

Step 9 If there is an associated graphic to be used in conjunction with the test item, perform the following:
   a. Select the Options menu item and the Add Graphic option. AIM I will open the Graphics window that contains a list of all the graphics contained in the Graphics library.
   b. Click on the desired graphic, and select the Options menu item and the Select option. Selection of a graphic enables the sizing portion of the window for the graphic selected. The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 height maximum values.
   c. Select the Edit menu item and the Save sub-menu item. AIM I will return you to the Graphic tab and the field for Graphic description will contain the graphic description from the graphics library for the graphic selected. The graphic description field can be edited and will print out below the graphic.

Step 10 Select the Edit menu item and the Save sub-menu item to save the Performance question to the database.

Step 11 A down-arrow will appear in the Status field when the required information has been added to the fields and tabs, and the Status will change to Complete. The Status can then be changed from Complete to Locked or Approved by clicking on the down arrow and selecting the appropriate Status and saving the information to the database.
Step 12 Select the Exit menu item to return to the Sections window.

12.1.5.5 Adding TG Sheets for an Instructor-Led Section

When developing a Section you can create Instruction Sheets (TG Sheets) for the students. There are six types of Instruction Sheets:

- Assignment
- Diagram
- Information
- Job
- Outline
- Problem

To develop an Assignment Sheet:

Step 1 From the Sections window click on the Instructor-Led Section Title.

Step 2 Select the Sheets menu item and the Add Sheet option.

Step 3 Select Assignment.

Step 4 Add the Assignment Sheet Title and Introduction in the designated fields. The Section Title will be the default title of the Assignment Sheet and it can be edited.

Step 5 Select the Contents menu item and the Study Assignments sub-menu item.

Step 6 From the Sheet References window select the Options menu item and the Add option.

Step 7 Select the Options menu item and either “Select Reference for Document” or “Select IETM for Document”.

Step 8 From the Select Site RRL window click on the desired Reference or IETM and click on the Select menu item.

**NOTE**: If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser and select the Options menu item and the Select option.

**NOTE**: The Type field will automatically be identified, depending on your selection of Reference or IETM.

Step 9 Click on the Before Text field and click on the down arrow. Select the desired verb.

Step 10 In the After Text field add the required text for the Assignment. (Example: Chapter 15, paragraphs 15.2.3 through 15.2.8.)
Step 11 Repeat Steps 6 through 9 for each additional assignment.

Step 12 After adding the last assignment select the **Exit** menu item.

Step 13 Select the **Contents** menu item and the **Study Questions** sub-menu item. Number and add the desired study questions to the Word document.

Step 14 Select the **File** menu item and the **Save** sub-menu item when finished adding study questions.

Step 15 Select the **File** menu item and the **Exit** sub-menu item to return to the Assignment Sheet window.

Step 16 Select the **Contents** menu item and the **Answer** sub-menu item.

Step 17 Number and add the answers to the questions added in Step 12.

Step 18 Select the **Edit** menu item and the **Save** sub-menu item to save your answers.

Step 19 Select the **Options** menu item and the **Print Preview** option to view and review your Assignment Sheet.

Step 20 From the Preview window select the **File** menu item and the **Exit** sub-menu item.

Step 21 When completed with the Assignment Sheet select the **Exit** menu item to return to the Sections window.

**To develop a Diagram Sheet:**

Step 1 From the Sections window click on the Instructor-Led Section Title.

Step 2 Select the **Sheets** menu item and the **Add Sheet** option.

Step 3 Select **Diagram**.

Step 4 Add the Diagram Sheet **Title** in the designated field.

Step 5 Select the **Contents** menu item and the **Diagram** sub-menu item.

Step 6 Select the **Insert** menu item and the **AIM Graphic, or AIM IMM** sub-menu item.

Step 7 If **AIM Graphic** was selected, click on the desired graphic from the Select Graphic window. Select the **Options** menu item and the **Select** option. This will place the graphic in the position of your cursor in your Word document.
If AIM IMM was selected, click on the desired IMM from the IMM Selection window. Select the **Options** menu item and the **Select** option. This will place a hot link to the IMM in the position of your cursor in your Word document.

**Step 8** Select the **File** menu item and the **Save** sub-menu item when finished adding graphics/IMI.

**Step 9** Select the **Options** menu item and the **Print Preview** option to view and review your Diagram Sheet.

**Step 10** From the Preview window select the **File** menu item and the **Exit** sub-menu item.

**Step 11** When completed with the Diagram Sheet select the **Exit** menu item to return to the Sections window.

**To develop an Information Sheet:**

**Step 1** From the Sections window click on the Instructor-Led Section Title.

**Step 2** Select the **Sheets** menu item and the **Add Sheet** option.

**Step 3** Select **Information**.

**Step 4** Add the Information Sheet **Title** and **Introduction** in the designated fields.

**Step 5** Select the **Contents** menu item and the **References** sub-menu item.

**Step 6** From the Sheet References window select the **Options** menu item and either “**Select Reference for Document**” or “**Select IETM for Document**”.

**Step 8** From the Select Site RRL window click on the desired Reference or IETM and click on the **Select** menu item.

**NOTE:** If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser and select the **Options** menu item and the **Select** option.

**NOTE:** The **Type** field will automatically be identified, depending on your selection of Reference or IETM.

**Step 9** In the **After Text** field add the required text for the Information. (Example: Chapter 15, paragraphs 15.2.3 through 15.2.8.)

**Step 10** Repeat Steps 6 through 9 for each additional document.

**Step 11** After adding the last document select the **Exit** menu item.
Step 12 Select the Contents menu item and the Information sub-menu item. Add the required text to the Word document.

Step 13 Select the File menu item and the Save sub-menu item when finished adding information.

Step 14 Select the File menu item and the Exit sub-menu item to return to the Information Sheet window.

Step 15 Select the Options menu item and the Print Preview option to view and review your Information Sheet.

Step 16 From the Preview window select the File menu item and the Exit sub-menu item.

Step 17 When completed with the Information Sheet select the Exit menu item to return to the Sections window.

To develop a Job Sheet:

Step 1 From the Sections window click on the Instructor-Led Section Title.

Step 2 Select the Sheets menu item and the Add Sheet option.

Step 3 Select Job.

Step 4 Add the Job Sheet Title and Introduction in the designated fields.

Step 5 Select the Contents menu item and the Equipment sub-menu item.

Step 6 AIM opens the Equipment folder of the Site RRL for selection of the equipment for performance of the Job Sheet. Since there are 18 folders in the Site RRL that contain equipment, you can select the Resources menu item and select the equipment desired from any of the equipment related folders.

Highlight the desired item and select the Options menu item and the Select option. When all the equipment items have been selected select the Exit menu item to return to the Job Sheet window.

Step 7 Select the Contents menu item and the References sub-menu item.

Step 8 From the Sheet References window select the Options menu item and the Add option.

Step 9 Select the Options menu item and either “Select Reference for Document” or “Select IETM for Document”.
Step 10  From the Select Site RRL window click on the desired Reference or IETM and click on the Select menu item.

**NOTE:** If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser and select the Options menu item and the Select option.

**NOTE:** The Type field will automatically be identified, depending on your selection of Reference or IETM.

Step 11  In the After Text field add the required text for the Job. (Example: Chapter 15, paragraphs 15.2.3 through 15.2.8.)

Step 12  After selecting all the references required select the Exit menu item.

Step 13  Select the Contents menu item and the Self Test Questions sub-menu item. Number and add the desired study questions to the Word document.

Step 14  Select the File menu item and the Save sub-menu item when finished adding self test questions.

Step 15  Select the File menu item and the Exit sub-menu item to return to the Job Sheet window.

Step 16  Select the Contents menu item and the Safety Precautions sub-menu item. Add the required safety precautions for performance of the Job Sheet to the Word document.

Step 17  Select the File menu item and the Save sub-menu item when finished adding safety precautions.

Step 18  Select the File menu item and the Exit sub-menu item to return to the Job Sheet window.

Step 19  Select the Contents menu item and the Job Steps sub-menu item. Number and add the desired job steps to the Word document.

Step 20  Select the File menu item and the Save sub-menu item when finished adding job steps.

Step 21  Select the File menu item and the Exit sub-menu item to return to the Job Sheet window.

Step 22  Select the Contents menu item and the Answer sub-menu item.

Step 23  Number and add the answers to the self test questions added in Step 13.
Step 24  Select the **Edit** menu item and the **Save** sub-menu item to save your answers.

Step 25  Select the **Options** menu item and the **Print Preview** option to view and review your Job Sheet.

Step 26  From the Preview window select the **File** menu item and the **Exit** sub-menu item.

Step 27  When completed with the Job Sheet select the **Exit** menu item to return to the Sections window.

**To develop an Outline Sheet:**

Step 1  From the Sections window click on the Instructor-Led Section Title.

Step 2  Select the **Sheets** menu item and the **Add Sheet** option.

Step 3  Select **Outline**.

Step 4  Add the Outline Sheet **Title** and **Introduction** in the designated fields. The Section Title will be the default title of the Outline Sheet and it can be edited.

Step 5  Select the **Contents** menu item and the **Section Outline** sub-menu item. Add the required text to the Word document.

Step 6  Select the **File** menu item and the **Save** sub-menu item when finished adding the outline.

Step 7  Select the **File** menu item and the **Exit** sub-menu item to return to the Outline Sheet window.

Step 8  Select the **Options** menu item and the **Print Preview** option to view and review your Outline Sheet.

Step 9  From the Preview window select the **File** menu item and the **Exit** sub-menu item.

Step 10  When completed with the Outline Sheet select the **Exit** menu item to return to the Sections window.

**To develop a Problem Sheet:**

Step 1  From the Sections window click on the Instructor-Led Section Title.

Step 2  Select the **Sheets** menu item and the **Add Sheet** option.

Step 3  Select **Problem**.
Step 4 Add the Problem Sheet **Title** and **Introduction** in the designated fields.

Step 5 Select the **Contents** menu item and the **Equipment** sub-menu item.

Step 6 AIM opens the Equipment folder of the Site RRL for selection of the equipment for performance of the Problem Sheet. Since there are 18 folders in the Site RRL that contain equipment, you can select the **Resources** menu item and select the equipment desired from any of the equipment related folders.

Highlight the desired item select the **Options** menu item and the **Select** option. When all the equipment items have been selected select the **Exit** menu item to return to the Problem Sheet window.

Step 7 Select the **Contents** menu item and the **References** sub-menu item.

Step 8 From the Sheet References window select the **Options** menu item and the **Add** option.

Step 9 Select the **Options** menu item and either “**Select Reference for Document**” or “**Select IETM for Document**”.

Step 10 From the Select Site RRL window click on the desired Reference or IETM and click on the **Select** menu item.

**NOTE:** If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser and select the **Options** menu item and the **Select** option.

**NOTE:** The **Type** field will automatically be identified, depending on your selection of Reference or IETM.

Step 11 In the **After Text** field add the required text for the Job. (Example: Chapter 15, paragraphs 15.2.3 through 15.2.8.)

Step 12 After selecting all the references required select the **Exit** menu item.

Step 13 Select the **Contents** menu item and the **Problem** sub-menu item. Add the text of the problem. Identify what has been Given to the student, the Initial and Final conditions for the performance of the Problem Sheet.

Step 14 Select the **File** menu item and the **Save** sub-menu item when finished adding the text.

Step 15 Select the **File** menu item and the **Exit** sub-menu item to return to the Problem Sheet window.

Step 16 Select the **Contents** menu item and the **Answer** sub-menu item.
Step 17  Number and add the answers to questions added in Step 13.

Step 18  Select the Edit menu item and the Save sub-menu item to save your answers.

Step 19  Select the Options menu item and the Print Preview option to view and review your Problem Sheet.

Step 20  From the Preview window select the File menu item and the Exit sub-menu item.

Step 21  When completed with the Problem Sheet select the Exit menu item to return to the Sections window.

12.1.5.6  Add Exercise Controller Guide (ECG)

When Section title is highlighted allows the user to create an Exercise. When an Element is highlighted allows the user to select a previously created Exercise. The Exercises created for a course will collectively create an Exercise Controller Guide which will have Front Matter similar to a Lesson Plan and Trainee Guide.

Before an Exercise can be used in a Section it must be created, to create an Exercise complete the following steps:
  Step 1.  Highlight The Section where the Exercise is to be used.
  Step 2.  Select Resources from the menu bar.
  Step 3.  Select Exercises from the Resources sub-menu.
  Step 4.  From the Exercises screen select Options, Create.
  Step 5.  Fill in the information for the following boxes:

- **Title:** The title of the Exercise.
- **Difficulty Type:** This is a Drop-down box where level of difficulty (Basic, Intermediate, or Advanced) is chosen.
- **Length in Minutes:** Length of the Exercise in minutes.
- **Training Approach:** The training approach used in the Exercise, such as Group or individual performance training.
- **Special Instructions:** Any special instructions to the instructor for conducting the Exercise.

  Step 6.  Select the Contents menu option.
  Step 7.  Select the Event Activity submenu option.
  Step 8.  From the Event-Activity Sheet screen select Option, Add Same Level Time/Event
  Step 9.  Add information for Time/Event Text, RIA Text and RTA Test.
  Step 10. Select Edit, Save, and Exit

Once Exercises have been created they can be associated with an element as follows:
  Step 1.  Highlight the Element where the Exercise is to be used.
  Step 2.  Select Resources from the menu bar.
  Step 3.  Select Add Exercise.
Step 4. Highlight the desired Exercise from the Exercises screen.
Step 5. Select Options, Select, Exit.

12.1.6 Lessons Window

The Lessons window contains the following options:

- **Create Lesson**: Allows you to add a new Principle or Procedure Lesson to the list.
- **Add Section to Lesson**: Opens a grid of Sections (that contains their title, version, and status) in the right-hand pane where you can select the Sections that pertain to the Lesson.
- **Copy**: Allows you to duplicate a Lesson in the Lessons window.
- **Create New Version**: Allows you to create a new version of an approved Lesson.
- **Delete**: Allows you to delete a Lesson in the Lessons window.

**Security Markings:**
From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:

1. Right click and Go To the appropriate location on the course tree (left pane).
2. From the menu bar click Options.
3. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.

![Entity Security Markings for LP T-000-TEST Rev 0 Chg 0](image)

The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that can have security markings and the current marking assigned. The lower portion of
the screen is broken into the following three sections:

- **Classification**: The available classifications that can be assigned, the options are:
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier**: This is an additional security modifier to the classification, the options are:
  - (None)
  - COMINT
  - Talent Keyhole
  - COMINT/Talent Keyhole

- **Release Ability**: This is an additional restriction on who the document may be released to, the options are:
  - (None)
  - NOFORN
  - For Official Use Only
  - REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

- **ISD Considerations**: Considerations are entered into the Content Planning Module (CPM) and are brought over to the LO Module on import of a course. They are only editable in the CPM. This item is hidden from the menu for non-imported content.

- **Select**: Enabled after selecting the **Add Section to Lesson** option, it allows you to select a highlighted Section to support a Lesson.

- **Unselect**: Enabled after selecting the **Add Section to Lesson** option, it allows you to unselect the highlighted Section from a Lesson.

- **Find Lesson**: Allows you to enter text to find a Lesson.
• **Check Spelling** Allows you to check the spelling of any element within the Lesson.
• **Grant Privileges**: Allows you to grant the privileges you have to another AIM User.
• **Show In Use Information**: If the IN-Use flag is set this option will display which user caused the flag to be set.
• **Reset In-Use**: This option is used to reset the IN-Use flag to allow editing.
• **Explain Flag**
• **Remove Flag**

**To create a Lesson in the Learning Object Module:**

**Step 1** From the AIM main menu, select the **Document** menu item, the **Learning Object Module** sub-menu item and **Lesson** or click on the Learning Object Module icon and when the Courses window opens select the **Contents** menu item and the **Lessons** sub-menu item.

**Step 2** From the Lessons window select the **Options** menu item and the **Create Lesson** option.

**Step 3** AIM will add the **New Lesson** to the Lesson tree structure in the left-hand pane. Expand the structure of the Lesson by clicking on the + block. This will reveal the Overview, Sections, and Summary portions of the Lesson and expanding the Sections will identify the elements required for each section.

**Step 4** With the **New Lesson** highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Lesson titled **General**, **Job**, **Skills Data**, **Info**, **Sheets** (if Instructor-Led Sections containing Instruction Sheets have been selected for the Lesson, Resources, and Metadata). Add/identify the following information for each tab and select the **Edit** menu item and the **Save** sub-menu item when completed with each tab.

- **General tab** – Enter the Title, Identification Number and Objective in the fields provided. The Identification Number will be assigned for generating an output file for SCORM, NLCOM or AICC and if unknown can remain blank until assigned. Click on the down arrows for Lesson Type, Status, and Classification and select the appropriate information. If the Lesson content is not releasable to foreign nationals check the NOFORN block.
- **Objectives tab** – Lists all the Enabling Objectives of the Sections selected for the Lesson.
- **Job tab** – Enter the Duty and Job Task that the Lesson supports in the fields provided. Click on the down arrows for Category (Skill or Knowledge) and select the appropriate entries.
- **Skills List** – Skills data identifies Task/Knowledge/Skill/Tools/Resources by and ID, Type and Text. If the Skills data is available in the EDE the Skill List data will automatically be entered when importing from EDE.
- **Info** – The Information tab can contain information to identify the author and owner. The date fields allow you to identify the date the Lesson was created, published, and an expiration date can be added when applicable. Keywords
can be added to facilitate searching the database for the Lesson.

- **Sheets** – Lists the Instruction Sheets identified in the Sections selected for the Lesson.

- **Resources** – This is not an area where you can add resources. The collective resources of the elements of the Lesson and the selected Sections will appear in this tab.

- **Metadata** – Each of the folders in the metadata structure contain fields to enter appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected.
Step 5  Develop the Overview section of the Lesson. The Overview folders contain Element, Resource, and Metadata tabs. The Element tab contains the Styled Text Editor that you can use to create information and to paste information saved as RTF. The Resource tab works in conjunction with the Resources menu item and the Add Resource, Add Graphic and Delete Resource options. The Metadata tab contains folders and fields to enter required data and key words for the Element. Add/identify the information for each item and select the Edit menu item and the Save sub-menu item when completed with each Element. Add/identify the following information for each of the following Lesson Overview items and select the Edit menu item and the Save sub-menu item when completed with each item. Elements may be added, modified or deleted from the Overview unless they are required elements (Introduction and Importance) by highlighting the Overview and selecting Add from the submenu, this will display a list of elements that can be added. To delete an element, highlight the element and select Delete from the Options submenu. To Modify an element, highlight the element then select Change Element from the Options submenu. Elements may also be resequenced with some exceptions, for example the Introduction must be the first element. To resequence elements highlight Overview and then select Resequence from the Options submenu. It is also possible to add sub-elements by highlighting an element and selecting Add Sub-element from the Options menu.

- **Introduction** – The goal of the Information item is to explain the purpose of the Lesson.
- **Importance** - The goal of the Importance item is to inform learners why they should be interested in the Lesson by creating interest and relevance.
- **Prerequisite** – The goal of the Prerequisite item is to inform learners of knowledge and skills needed to complete the Lesson.
- **Scenario** – The goal of the Scenario item is to relate a story to a job function to motivate the learners and capture their attention.

Step 6  When the Sections that support the Lesson have been developed, click on the Sections heading in the tree structure of the Lesson. The Sections identified in the database will be reflected in a list of Section Titles in the right-hand pane. Highlight the desired Section and select the Options menu item and the Select option or double-click on the desired Sections. A check mark will appear in the square box to the left of the Sections selected. The Sections can be placed in the order desired for presentation by using the using the click and drag method in the right hand Title column.

The Sections will be reflected in the Lesson tree structure in the left-hand pane and their content can be edited. Select the Edit menu item and the Save sub-menu item after selecting the desired Sections and sequencing them in the desired order.

Step 7  Develop the Summary section of the Lesson. The Summary contain Element, Resource, and Metadata tabs. The Element tab contains the Styled Text Editor that you can use to create information and to paste information saved as RTF. The
Resource tab works in conjunction with the Resources menu item and the Add Resource, Add Graphic and Delete Resource options. The Metadata tab contains folders and fields to enter key words for the Element. Add/identify information for each item and select the Edit menu item and the Save sub-menu item when completed with each element. Add/identify the following information for each item and select the Edit menu item and the Save sub-menu item when completed with each item. Elements may be added, modified or deleted from the Summary unless they are required elements (Review) by highlighting the Summary and selecting Add from the submenu, this will display a list of elements that can be added. To delete an element, highlight the element and select Delete from the Options submenu. To Modify an element, highlight the element then select Change Element from the Options submenu. Elements may also be resequenced. To resequence elements highlight Overview and then select Resequence from the Options submenu. It is also possible to add sub-elements by highlighting an element and selecting Add Sub-element from the Options menu.

- Review – The goal of the Review item is to recap the key points from all Sections in the Lesson.
• **Next Step** – The goal of the *Next Step* item is to direct the learner to additional steps that would further their knowledge of the subject presented in the Lesson.
• **Resource** – The goal of the *Resource* item is to provide more information about the knowledge and skills covered in the Lesson.

### 12.1.7 Modules Window

The Modules window contains the following options:

- **Create Module**: Allows you to add a new Module to the list.
- **Add Lesson to Module**: Opens a grid of Lessons (that contains their title, version, and status) in the right-hand pane where you can select the Lessons that pertain to the Module.
- **Copy**: Allows you to duplicate a Module in the Modules window.
- **Create New Version**: Allows you to create a new version of an approved Module.
- **Delete**: Allows you to delete a Module in the Modules window.
- **Security Markings**
  
  From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:
  1. Right click and Go To the appropriate location on the course tree (left pane).
  2. From the menu bar click Options.
  3. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.

![Entity Security Markings](image)

**Caption:** Entity Security Markings for LP T-000-TEST Rev 0 Chg 0

- **Options**
- **Actions**
- **Help**

**Columns:**
- **Entity Node**
- **Security Marking**

**Rows:**
- **List of Effective Elements**
- **Effective Elements**
- **Effective Node**
- **Effective Node**
- **Effective Node**
- **Effective Node**
- **Effective Node**
- **Effective Node**
- **Effective Node**
- **Effective Node**

**Security Markings:**
- **Confidential**
- **Class**
- **Distribution**
- **Access**
- **Release Ability**

**Cells:**
- **T-000-TEST Rev 0 Chg 0**
- **Pre-Release Testing Training Project Plan**
- **(None)**
- **(None)**

**Release 5.1**
The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that can have security markings and the current marking assigned. The lower portion of the screen is broken into the following three sections:

- **Classification:** The available classifications that can be assigned, the options are:
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier:** This is an additional security modifier to the classification, the options are:
  - (None)
  - COMINT
  - Talent Keyhole
  - COMINT/Talent Keyhole

- **Release Ability:** This is an additional restriction on who the document may be released to, the options are:
  - (None)
  - NOFORN
  - For Official Use Only
  - REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

- **ISD Considerations:** Considerations are entered into the Content Planning Module (CPM) and are brought over to the LO Module on import of a course. They are only editable in the CPM. This item is hidden from the menu for non-imported content.

- **Find Module:** Allows you to enter text to find a Module.
• **Show In Use Information:** If the IN-Use flag is set this option will display which user caused the flag to be set.

• **Reset In-Use:** This option is used to reset the IN-Use flag to allow editing.

• **Check Spelling** Allows you to check the spelling of any element within the Module.

• **Grant Privileges:** Allows you to grant the privileges you have to another AIM User.

• **Explain Flag**

• **Remove Flag**

---

**To create a Module in the Learning Object Module:**

**Step 1** From the AIM main menu, select the **Document** menu item, the **Learning Object Module** sub-menu item and **Module** or click on the Learning Object Module icon and when the Courses window opens select the **Contents** menu item and the **Modules** sub-menu item.

**Step 2** From the Modules window select the **Options** menu item and the **Create Module** option.

**Step 3** AIM will add the **New Module** to the Module tree structure in the left-hand pane. Expand the structure of the Module by clicking on the + block. This will reveal the Overview, Sections, and Summary portions of the Module, expanding the Lessons will identify the elements required for each Lesson, and expanding the Sections will identify the elements required for each section.

**Step 4** With the **New Module** highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Module titled Module, Objectives, Metadata, and Resources. Add/identify the following information for each tab and select the **Edit** menu item and the **Save** sub-menu item when completed with each tab.

  • **Module tab** – Enter the Title of the Module.
  
  • **Objectives tab** – The Objectives tab will contain the Terminal and Enabling objectives of the Lessons and Sections selected for the Module.
  
  • **Sheets** – The Sheets tab will contain a list of all the Instruction Sheets contained in the Lessons selected for the Module.

  • **Resources** – This is not an area where you can add resources. The collective resources of the elements of the Module and the selected Lessons and Sections will appear in this tab.

  • **Metadata** – Each of the folders in the metadata structure contain fields to enter appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected.

**Step 5** When the Lessons that support the Module have been developed, click on the Lessons heading in the tree structure of the Module. The Lessons identified in the database will be reflected in a list of Lesson Titles in the right-hand pane.
Highlight the desired Lesson and select the **Options** menu item and the **Select** option or double-click on the desired Lessons. A check mark will appear in the square box to the left of the Lessons selected. The Lessons can be placed in the order desired for presentation by using the using the click and drag method in the right hand Title column.

The Lessons will be reflected in the Module tree structure in the left-hand pane and their content can be edited. Select the **Edit** menu item and the **Save** sub-menu item after selecting the desired Lessons and sequencing them in the desired order.

### 12.1.8 Courses Window

The **Courses window contains the following options:**
- **Create Course**: Allows you to add a new Course to the list.
- **Add Module to Course**: Opens a grid of Modules (that contains their title, version, and status) in the right-hand pane where you can select the Modules that pertain to the Course.
- **Copy**: Allows you to duplicate a Course in the Courses window.
- **Create New Version**: Allows you to create a new version of an approved Course.
- **Delete**: Allows you to delete a Course in the Courses window.
- **Security Markings**
  From the main AIM screen, with a course selected and the tree structure expanded, perform the following steps to access the Security Markings screen:
  1. Right click and Go To the appropriate location on the course tree (left pane).
  2. From the menu bar click Options.
  3. From the Options dropdown menu click Security Markings.

This will display the screen show in the figure below.
The top portion of the Security Markings screen indicates the CIN and Title of the course. The center of the screen lists different sections of the Lesson Plan (LP) that can have security markings and the current marking assigned. The lower portion of the screen is broken into the following three sections:

- **Classification**: The available classifications that can be assigned, the options are:
  - Unclassified
  - Confidential
  - Secret
  - Top Secret
  - Unclassified/NOFORN

- **Modifier**: This is an additional security modifier to the classification, the options are:
  - (None)
  - COMINT
  - Talent Keyhole
  - COMINT/Talent Keyhole
- **Release Ability:** This is an additional restriction on who the document may be released to, the options are:
  - (None)
  - NOFORN
  - For Official Use Only
  - REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the dropdown menu to save the security markings. There is also a Rest option that will reset the security markings of the highlighted Entity to Unclassified.

- **Front Matter:** Contains boilerplate LP and TG Safety, Security, and How to Use information that can be edited for the course.
- **ISD Considerations:** Considerations are entered into the Content Planning Module (CPM) and are brought over to the LO Module on import of a course. They are only editable in the CPM. This item is hidden from the menu for non-imported content.
- **Find Course:** Allows you to enter text to find a Course.
- **Check Spelling:** Allows you to check the spelling of any element within the Course.
- **Grant Privileges:** Allows you to grant the privileges you have to another AIM User for Lessons and Sections.
- **Show In Use Information:** If the IN-Use flag is set this option will display which user caused the flag to be set.
- **Reset In-Use:** This option is used to reset the IN-Use flag to allow editing.
- **Explain Flag**
- **Remove Flag**
To create a Course in the Learning Object Module:

Step 1  From the AIM main menu, select the Document menu item, the Learning Object Module sub-menu item and Course or click on the Learning Object Module icon.

Step 2  From the Courses window select the Options menu item and the Create Course option.

Step 3  AIM will add the New Course to the Module tree structure in the left-hand pane. Expand the structure of the Course by clicking on the + block. This will reveal the Overview, Sections, and Summary portions of the Course, expanding the Modules will identify the elements required for each Module, expanding the Lessons will identify the elements required for each Lesson, and expanding the Sections will identify the elements required for each section.

Step 4  With the New Course highlighted in the tree structure, observe that there are tabs in the right-hand pane associated with the Course titled Course, Objectives, Metadata, and Resources. Add/identify the following information for each tab and select the Edit menu item and the Save sub-menu item when completed with each tab.

- **Course tab** – Enter the Title of the Course, the Version and the Status.
- **Objectives tab** – The Objectives tab will contain the Terminal and Enabling objectives of the Modules, Lessons and Sections selected for the Course.
- **Sheets** - The Sheets tab will contain a list of all the Instruction Sheets contained in the Modules selected for the Course.
- **Resources** – This is not an area where you can add resources. The collective resources of the elements of the Course, and the selected Modules, Lessons and Sections will appear in this tab.
- **Metadata** – Each of the folders in the metadata structure contain fields to enter appropriate information for SCORM specification and version selected. Bolded folders indicate where data entry is required. Right-clicking on headings will identify the information that can be added for the SCORM version selected.

Step 5  When the Modules that support the Course have been developed, click on the Modules heading in the tree structure of the Course. The Modules identified in the database will be reflected in a list of Module Titles in the right-hand pane. Highlight the desired Module and select the Options menu item and the Select option or double-click on the desired Module. A check mark will appear in the square box to the left of the Modules selected. The Modules can be placed in the order desired for presentation by using the using the click and drag method in the right hand Title column.

The Modules will be reflected in the Course tree structure in the left-hand pane and their content can be edited. Select the Edit menu item and the Save sub-menu item after selecting the desired Modules and sequencing them in the desired order.
A  AAC - Acquisition Advice Code. Field available for data entry in the Resource Requirements List (RRL) for an equipment.

Ability - Enduring attributes of the individual that influence performance and enable the performance of tasks.

Advanced Distributed Learning (ADL) - The Advanced Distributed Learning (ADL) Initiative—collaborative effort between government, industry and academia. Its goal is to establish a new distributed learning environment that permits the interoperability of learning tools and course content.

AEC - Automated Electronic Classroom.

AG/SAG - (Activity Group/Sub Activity Group). An alphanumeric identifier entered in the RRL. Maximum of 8 characters

Aggregation - Content Aggregation is the process of aggregating resources (SCO /ELOs) into a defined structure (content structure) to build a learning event. An aggregation is a grouping of related ELOs, along with the rules that control the presentation of the grouped material to the learner. A learning event can be constructed recursively; hence a content structure has the shape of a tree, with ELOs/SCOs forming the leaves and aggregations (TLOs) representing the nodes.

AIM Administrator - A person designated to be responsible for the review and approval of curriculum products developed and/or maintained using AIM II. Additional responsibilities include adding user accounts, deleting and replacing RRL items, and setting privilege levels.

AOB - Average Onboard - The annual student input multiplied by the course length in calendar days (including weekends and holidays) divided by 365.

API - Application Program Interface.

Approve - The act of confirming that an element is final and any further modifications will need to be performed within Curriculum Maintenance.
Approving Agency - Any activity that approves training materials.

Archive - To make a copy of a curriculum product; export it to a floppy disk, hard drive, or network; and remove it from the AIM I database.

Assessment - The process used to systematically evaluate a learner’s skill or knowledge level (ASTD).

Assessment instruments - Items that are grouped together to form tests, quizzes, exams, or simulations for the purpose of assessment.

Assessment item - Each individual question or task the student is asked to address for assessment purposes.

Asset - A single media element or text element (e.g. an image, audio file, or html file) that can be delivered to a Web client.

Assignment Sheet - An instruction sheet designed to direct the study or homework efforts of a trainee.

ATIC - Aegis Training and Readiness Center

Authoring Instructional Materials (AIM) - An automated tool to assist training managers, curriculum developers, and subject matter experts in the development and maintenance of training materials.

Authoring Instructional Materials I (AIM I) - An automated tool to assist training managers, curriculum developers, and subject matter experts in the development and maintenance of training materials that follow MIL-PRF-29612 and NAVEDTRA 131A.

Authoring Instructional Materials II (AIM II) - An automated tool to assist training managers, curriculum developers, and subject matter experts in the development and maintenance of training materials that follow MIL-PRF-29612 and NAVEDTRA 130B.

Average Onboard (AOB) - The annual input multiplied by the course length in calendar days (including weekends and holidays) divided by 365.

B Behavior - Any activity that is both observable and measurable.

**CANTRAC** - Catalog of Navy Training Courses.

**CBT** - Computer Based Training

**CCA** - Curriculum Control Authority.

**CCMM** - The entity assigned the responsibility for conducting and maintaining a specific course. The CCMM initiates curriculum development and training materials modification; conducts curriculum reviews and analysis of feedback; maintains course audit trail documentation; and develops and approves Changes.

**CDP** - Course Data Processing. An alphanumeric code assigned to each course for NITRAS processing. A CDP identifies a specific course at a specific Learning Site.

**Change** - Pages issued to add, amend, correct, substitute, delete, or otherwise modify data by replacing, deleting, or adding pages. (See also: Interim Change and Revision)

**CIN** - Course Identification Number.

**CM** - Corrective Maintenance.

**CMI** - Computer Managed Instruction

**CMS** - Course Master Schedule. The units and topics of the Curriculum Outline of Instruction (COI) placed into a time schedule.

**CNATT** - Center for Naval Aviation Technical Training.

**CNO** - Chief of Naval Operations.

**COG** - Cognizant (activity). Field available for data entry in the Resource Requirements List (RRL) for an equipment.

**Cognitive Apprenticeship** - Model where experts and novices interact while focusing on a realistic, job related task to develop the learner’s essential cognitive skills.

**COI** - (Curriculum Outline of Instruction). An outline of the topics to be included in the LP

**Community of practice** - A self-organized, deliberate collaboration of people who share common practices, interests or aims and want to advance their knowledge. When the community proves useful to its members over time, they may formalize their status by adopting a group name and a regular system of interchange. [www.sims.berkeley.edu/courses/is213/s99/Projects/P9/web_site/glossary.htm](http://www.sims.berkeley.edu/courses/is213/s99/Projects/P9/web_site/glossary.htm)

**Concept maps** - A graph that represents knowledge, with nodes representing concepts and arrows representing relations between the concepts.
**Condition** - The portion of the learning objective or task statement that describes the situation/environment in which the learners write/express/perform the specified behavior. Conditions include any pertinent influence upon task performance, including any or all of the following: location of performance, environment, equipment, manuals, or supervision required.

**Content Aggregation** - A content aggregation is a map (content structure) that can be used to aggregate learning resources into a cohesive unit of instruction. AIM aggregates all the Topics (SCOs) in a course into the output package (aggregation), which has course level metadata as per SCORM 1.2 requirements.

**Content repository** - Storage facility for digital objects and files made searchable by using metadata.

**Course Mission Statement** - A description of the ultimate purpose of the course including a statement of who is to be trained, what he/she is to be trained to do, the degree of qualification brought about by the training, and where and under what general conditions the graduate will perform the job.

**Course Resource Requirements List (RRL)** - A list which identifies the texts, references, equipment, films, graphics, and instructional media materials required to support a curriculum.

**CSCI** - Computer Software Configuration Item.

**CTTL** - Course Training Task List. A list of duties and tasks to be trained in the course.

**Curriculum Control Authority (CCA)** - A Functional Commander designated by NETC to have curriculum control of specific courses/training programs.

**DDA** - Discussion Demonstration Activity.

**Developing Agency** - Any activity that produces training materials.

**Diagram Sheet** - An instruction sheet that provides the trainee with a diagram, schematic, illustration, or definitions used by the instructor during the course of instruction.

**Discussion Point (DP)** - A major point to be covered in the topic of a course.

**DoD** - Department of Defense.

**DOR** - Drop On Request.

**ECIS** - Electronic Classroom Integration Software.
ELO – Enabling Learning Object—a collection of one or more Assets with instructional treatment applied to satisfy one and only one Enabling Objective.

ELP - Electronic Lesson Plan.

EOs - Enabling Objectives. The statements that identify the objectives of the unit/topic.

EPSS - Input to emerging Electronic Performance Support System.

ERNT - Executive Review of Navy Training.

Export - To make a copy of a curriculum product and export it to a floppy disk, hard drive, or network. In contract to the Archive function, the export function does not remove the original curriculum product from the AIM I database.

FAL - Fault Applicability List

Fault - A pre-engineered casualty designed to produce a documented set of conditions/indications for training purposes.

FDS - Fault Description Sheet

FEA - Front End Analysis. The process conducted at the initiation of a training development effort to identify discrete duties and tasks.

FID - Fault Insertion Device

File Extension - The Archive/Unarchive and Import/Export utilities use default file extensions for archive (.arc) and export (.exp)

Flag - The maintenance methodology used to identify to a user where a possible training impact is based on modifications, additions, and/or deletions performed within other elements of the curriculum.

GFI/M - Government Furnished Information/Material—materials provided to contracted designers and developers for the creation of ILE content

Grant - Provide users with certain levels of privilege to develop, modify, or administer training materials.

GUI - Graphical User Interface

High Edit - The Text Editor available in AIM II's Trainee Guide module if Word is not installed on the user’s computer.
HPSM - Human Performance System Model—cyclical four step process of navy training:
  • Define requirements
  • Define solutions
  • Develop components
  • Execute and measure

ID - Instructional Designer—one who analyzes instructional problems and designs their solutions

IDC - Instruction Delivery Continuum—new framework for the delivery of instructional material for the purposes of Navy training.

IDP - Individual Development Plan—A document that includes an assessment of current skills, and a timeline and sources for development to achieve future goals. Outlines the way in which the employee will develop the knowledge, skills, and abilities needed to meet changing organizational needs and environmental demands and/or prepare to achieve future career goals (www.goer.state.ny.us/workforce/glossary.html).

IETM - Interactive Electronic Technical Manual

ILE - Integrated Learning Environment—The Navy Integrated Learning Environment has been established to provide the technical and administrative infrastructure for the acquisition, development, storage, maintenance, and distribution of learning content.

IMM - Instruction Media Materials

Import - To extract data from a previously exported file and enter that data into the AIM I database.

IMS - Worldwide non-profit organization which develops and promotes the adoption of open technical specifications for interoperable learning technology

Information Sheet - An instruction sheet that provides information related to subject matter contained in texts or reference books required by, but not readily available to, trainees.

ISD - Instructional Systems Development. A structured approach to developing a plan of instruction. As defined by NAVEDTRA 130B, the ISD process consists of six phases: Planning, Analysis, Design, Development, Implementation, and Evaluation. For a more detailed explanation of each of these phases, refer to NAVEDTRA 130B Series.

Job - The duties and tasks performed by one individual that constitute his/her job. The job is the basic unit used in carrying out the personnel actions of selection, training, classification, and assignment.
**Job Sheet** - An instruction sheet that provides the complete information required to perform a job, a task, or other unit of work involving a sequence of manipulative steps.

**JTA** - Job Task Analysis - Is the standardized process that examines a specific job to identify all the responsibilities and task requirements of a job in an organization. It is a systematic procedure used by Industrial and Organizational Psychologist, Human Resource, or Personnel Managers to describe important aspects of the job regardless of the person in the job.

**Learner-centric** - Learning designs which allow the learner to have control of the learning experience by making choices as to what will be learned, the order of material presentation, and/or the method of delivery, and which ideally support a wide range of learning needs or styles; also, learning designs which adjusts the presentation materials in response to the learner’s knowledge or skill level.

**Learning event** - Any event or activity planned with the goal of learners acquiring new knowledge, gaining or improving skills or abilities, and/or changing behaviors or attitudes. A learning event will include either an enabling or a terminal objective.

**Learning Object** - “Any digital resource that can be used to mediate learning.” (Wiley and Edwards, 2002)

**Learning Management System** - (LMS)

**LO** - Learning Objective. A statement of desired behavior upon completion of a designated instructional unit. A properly formatted objective contains a behavior, condition, and standard.

**Lock** - The act of rendering a training material incapable of being modified and thus allows a user to build other training materials based on it.

**LOEE** - List of Effective Elements


**LP** - Lesson Plan. An approved plan for a course that provides specific definition and direction to the instructor on learning objectives, equipment, and instructional media material requirements, and conduct of the course.

**LSAR** - Logistics Support Analysis Record.

**Mental Models** - Representations in the mind of real or imaginary situations.(Craik, 1943).
**Metacognition** - The process of monitoring and controlling our cognitive processes, or the process of thinking about thinking (Schwarts & Perfect, 2002)

**Metadata** - Descriptive information about a piece of data that is not usually visible to the user for “purposes of description, administration, legal requirements, technical functionality, use and usage, and preservation (Getty).” Metadata is designed to help locate, organize, access, and use data effectively.

**Metatag** - Identifies Metadata.

**MS** - Microsoft

**MSS** - Master Schedule Summary.

**NCOM** - Navy Content Object Model—a reusable object model having a primary goal to maximize the reuse, repurpose and reference (R3) value of objects.

**NEC** - Navy Enlisted Classification.

**NETC** - Education Training Professional Development and Technology Center.

**NIIN** - National Item Identification Number.

**NILARS** - Navy Integrated Learning Asset Repository System.

**NITRAS** - Navy Integrated Training Resources Administration System. An automated training information system designated to be responsive to the demands of the Chief of Naval Education and Training. Provides direct support for the Chief of Naval Personnel and the Navy Recruiting Command.

**NMETL** - Naval Mission Essential Task List

**NMPC** - Navy Military Personnel Command.

**NOBC** - Navy Officer Billet Classification.

**NOTAP** - Navy Occupational Task Analysis Program.

**NTP** - Navy Training Plan.

**OCCSTD** - Occupational Standards.

**O&MN** - Operation and Maintenance, Navy (example of a Navy funding code).
OJT - On-The-Job Training.

OPN - Other Procurement, Navy (example of a Navy funding code).

PC - (Personal Computer). A desktop or laptop microcomputer

Performance-based outcomes - Learner outcomes that are observable with demonstrated objectives or behaviors that are based on standards.

PFM - Prefaulted Module

PM - Preventive Maintenance.

POA&M - Plan of Action and Milestone.

Post Assessment - Any activity designed to be taken after a learning event to confirm that a learner has mastered either the enabling objective at the ELO level or the terminal learning objective at the TLO level.

PPP - Personnel Performance Profile.

PQS - Personnel Qualification Standard.

Problem Sheet - An instruction sheet that provides trainees with the conditions and parameters of a problem and procedural directions for the solution.

RDBMS - Relational Database Management System.

Revision - A change to Terminal Objectives (TOs), an increase in course length, or a training material change that requires additional resources. A revision incorporates previous changes and supersedes earlier editions of the training materials.

Repurpose - The reuse of an existing learning object in a new context after modifying its instructional treatment, context, or content.

Reference - A validated information source in the form of a learning object for generating ideas or simply as a resource in the similar manner that one would use a reference in a traditional development effort.

Repository - See Content repository.

RIA - Related Instructor Activity. Specific direction to the instructor relative to reference documents, instructional media materials, and demonstrations that may be used to prepare to teach a DP.
**RiT** - Revolution in Training.

**RRL** - Resource Requirements List.

**R3** - Reuse, Repurpose, and Reference—overarching tri-fold goal for learning objects within the Navy ILE

**SAG** - Subactivity Group for funding.

**SCO** - Sharable Content Object.

**SCORM - Sharable Content Object Reference Model.** SCORM is a set of specifications published by Advanced Distributed Learning (ADL) for developing, packaging and delivering high-quality education and training materials wherever and whenever they are needed.

**SCORM 2004** - The Sharable Content Object Reference Model (SCORM 2004 ) defines a Web-based learning "Content Aggregation Model" and "Run-Time Environment" for learning objects. The SCORM is a collection of specifications adapted from multiple sources to provide a comprehensive suite of e-learning capabilities that enable interoperability, accessibility and reusability of Web-based learning content.

**SCORM CAM** - SCORM Content Aggregation Model—describes the assembly, description, and packaging of content as SCORM Assets, SCOs, and higher aggregations. This task is accomplished through the creation of XML documents according to the SCORM meta-data requirements (LOM).

**SCORM LOM** - SCORM Learning Object Meta-Data (LOM)—inline XML specification for the description of aggregations of content as well as individual media. LOM metadata provides the means for the identification retrieval and subsequent reuse of content.

**SCORM RTE** - SCORM Run-time Environment—technical specifications in SCORM for the content launch process, standardized communication between content and LMSs and standardized data model elements used for passing information relevant to the learner’s experience with the content.

**SCORM SN** - SCORM Sequencing and Navigation (SN)—describes how SCORM-conformant content may be sequenced to the learner through a set of learner or system-initiated navigation events.

**Sequencing** - Describes and prescribes the manner in which the learner receives content.
Sharable Content Object (SCO) - SCO represents a collection of one or more Assets that include a specific launchable asset that utilizes the SCORM Run-time Environment to communicate with Learning Management Systems (LMSs). A SCO represents the lowest level of granularity of learning resource that can be tracked by an LMS using the SCORM Run-Time Environment. Generally equivalent to a ELO.

Skill - Developed capacities that facilitate learning or the more rapid acquisition of knowledge or that facilitate performance of activities.

Skill Object - A re-usable detailed description of what people do in accomplishing work. A SkillObject contains logically grouped knowledge, skills, abilities, tools and tasks (2-10) that are required to successfully perform a job.

Site RRL - A list which identifies the texts, references, equipment, films, graphics, and instructional media materials required to support an entire AIM II site.

SME - Subject Matter Expert.

SMIC - Special Material Identification Code. Field available for data entry in the Resource Requirements List (RRL) for equipment.

SM&R - Source Maintainability and Recoverability, field available for data entry in the Resource Requirements List (RRL) for equipment.

SSO - System Support Office for AIM software.

Standard - A statement describing how well a task or learning objective must be performed.

System Administrator - A person responsible for the day-to-day operation and maintenance of the AIM II system (hardware and software).

TA - Training Agency.

Task - A single unit of specific work behavior with a clear beginning and ending. A task is performed for its own sake; that is, it is not dependent upon other tasks.

Task Force Excell - The Task Force for Excellence through Commitment to Education and Learning (EXCEL)—body in charge of overseeing the implementation of the pilot programs designed enhance and strengthen the Navy's training and education structure.

TCCD - Training Course Control Document. A collection of products that expresses, in summary form, the content, structure, and essential management information for a course. The TCCD consists of Front Matter, the Curriculum Outline of Instruction, the Resources Requirements List (RRL), and the Course Master Schedule (CMS).
TG - Trainee Guide. A generic term for the various printed materials developed for trainee use. A publication, comprising instruction sheets, which provides each trainee with the technical manuals and supplementary material required for the successful completion of a course of study.

TLO - Terminal Learning Object.

TOs - Terminal Objectives. Statements that describe the overall knowledge and skills to be attained upon completion of the course.

TMDS - Training Materials Development System

TPP - Training Project Plan. The output of the Plan phase of the ISD process.

TR - Trouble Report

Training Agency - An office, bureau, command, or headquarters exercising command of and providing support of training materials.

Learning Site - The geographical location(s) at which a course or training is conducted.

TTO - Training Time Out.

UI - Unit of Issue. Field available for data entry of the supply code in the Resource Requirements List (RRL) for equipment.

Unarchive - A function of AIM II used to import previously archived material into the AIM II database. The Unarchive function differs from the Import function in that it prevents the system from duplicating graphics that already exist in the AIM II database. (Before importing an item to be unarchived, AIM II checks to see whether any graphics the item might contain already reside in the AIM II Graphics Library.)

Unique Knowledge - The enduring information including processes, procedures, or intellectual capital that are not transitory or temporary and are required to perform the SkillObject™. SkillsNET is mainly interested in the Unique Knowledge that is associated with the tasks that are central to the STARs job.

Unlock - Render a training material capable of being modified and thus not allow a user to build other training materials based on it.

VI - Visual Information.

WBT - Web-based Training.

WC - Wall Charts.

XML - Extensible Markup Language—universal format for exchanging structured documents and data on the Web. XML uses HTML-like tags to delimit bits of data, but unlike HTML, leaves interpretation of that data to the applications that read it.
## APPENDIX B

### ADMINISTRATION AND UTILITIES

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>AIM II ADMINISTRATIVE AND UTILITY FUNCTIONS</td>
<td>B-1</td>
</tr>
<tr>
<td>2.0</td>
<td>UTILITIES MENU ITEMS</td>
<td>B-1</td>
</tr>
<tr>
<td>2.1</td>
<td>CHANGE PASSWORD UTILITY</td>
<td>B-1</td>
</tr>
<tr>
<td>2.1.1</td>
<td>Password Change Procedure</td>
<td>B-2</td>
</tr>
<tr>
<td>2.2</td>
<td>SITE RESOURCE REQUIREMENTS LIST (RRL) UTILITY</td>
<td>B-3</td>
</tr>
<tr>
<td>2.2.1</td>
<td>Site RRL Window Options Menu Item</td>
<td>B-4</td>
</tr>
<tr>
<td>2.3</td>
<td>GRAPHICS UTILITY</td>
<td>B-17</td>
</tr>
<tr>
<td>2.3.1</td>
<td>Graphics Options Menu Item</td>
<td>B-17</td>
</tr>
<tr>
<td>2.4</td>
<td>ADMINISTRATION UTILITY</td>
<td>B-22</td>
</tr>
<tr>
<td>2.4.1</td>
<td>View RRL</td>
<td>B-23</td>
</tr>
<tr>
<td>2.4.2</td>
<td>Grant Privilege</td>
<td>B-24</td>
</tr>
<tr>
<td>2.4.3</td>
<td>Approve Training Material</td>
<td>B-26</td>
</tr>
<tr>
<td>2.4.4</td>
<td>Clear In Use</td>
<td>B-27</td>
</tr>
<tr>
<td>2.4.5</td>
<td>Clear Conflict State</td>
<td>B-28</td>
</tr>
<tr>
<td>2.4.6</td>
<td>Importing IETM Extract Files</td>
<td>B-29</td>
</tr>
<tr>
<td>2.5</td>
<td>REPORTING</td>
<td>B-38</td>
</tr>
<tr>
<td>2.6</td>
<td>ASSOCIATED CURRICULUM DOCUMENTS</td>
<td>B-41</td>
</tr>
<tr>
<td>2.6.1</td>
<td>Associated Curriculum Documents Window</td>
<td>B-41</td>
</tr>
<tr>
<td>2.6.1.1</td>
<td>Add Document</td>
<td>B-41</td>
</tr>
<tr>
<td>2.6.1.2</td>
<td>Modify/View Document</td>
<td>B-42</td>
</tr>
<tr>
<td>2.6.1.3</td>
<td>Delete Document</td>
<td>B-42</td>
</tr>
<tr>
<td>2.6.1.4</td>
<td>Display Related Materials</td>
<td>B-42</td>
</tr>
<tr>
<td>2.6.1.5</td>
<td>Flag Related Materials</td>
<td>B-42</td>
</tr>
<tr>
<td>2.6.1.6</td>
<td>Document Types</td>
<td>B-43</td>
</tr>
<tr>
<td>2.6.1.6.1</td>
<td>Adding Document Types</td>
<td>B-43</td>
</tr>
<tr>
<td>2.6.1.6.2</td>
<td>Deleting Document Types</td>
<td>B-43</td>
</tr>
<tr>
<td>2.6.1.6.3</td>
<td>Modifying Document Types</td>
<td>B-43</td>
</tr>
<tr>
<td>2.7</td>
<td>RRL/GRAPHICS LOCATION TOOL</td>
<td>B-44</td>
</tr>
<tr>
<td>2.7.1</td>
<td>Resource/Graphic Selection Window</td>
<td>B-44</td>
</tr>
<tr>
<td>2.7.2</td>
<td>Resource Selection</td>
<td>B-45</td>
</tr>
<tr>
<td>2.7.3</td>
<td>Graphic Selection</td>
<td>B-47</td>
</tr>
<tr>
<td>2.7.4</td>
<td>Reference Breakdown</td>
<td>B-48</td>
</tr>
<tr>
<td>2.7.5</td>
<td>IETM Breakdown</td>
<td>B-49</td>
</tr>
<tr>
<td>2.7.6</td>
<td>Related Courses Selection</td>
<td>B-50</td>
</tr>
<tr>
<td>2.7.7</td>
<td>Search Results Window</td>
<td>B-51</td>
</tr>
<tr>
<td>2.7.8</td>
<td>Print Preview</td>
<td>B-53</td>
</tr>
<tr>
<td>2.8</td>
<td>LEARNING SITE UTILITY</td>
<td>B-55</td>
</tr>
<tr>
<td>2.8.1</td>
<td>Site Options Menu Item</td>
<td>B-55</td>
</tr>
<tr>
<td>2.9</td>
<td>AGENCY UTILITY</td>
<td>B-59</td>
</tr>
<tr>
<td>2.9.1</td>
<td>Agency Options Menu Item</td>
<td>B-59</td>
</tr>
<tr>
<td>2.10</td>
<td>ARCHIVE/UNARCHIVE UTILITY</td>
<td>B-63</td>
</tr>
<tr>
<td>2.10.1</td>
<td>Archive Options Menu Item</td>
<td>B-63</td>
</tr>
</tbody>
</table>
(This Page Intentionally Left Blank)
1.0 AIM II ADMINISTRATIVE AND UTILITY FUNCTIONS

To meet the management and configuration control requirements of training materials managers, AIM II provides administrative and utility functions for:

- Adding new users
- Assigning levels of privilege that enable users to perform specific development or maintenance functions
- Maintaining site support materials and graphics libraries

2.0 UTILITIES MENU ITEMS

The Utilities option on the AIM II main menu bar gives you access to the AIM II utilities. The Utilities drop-down menu offers the 12 options (sub-menu items), which are listed below.

- Change Password
- Site RRL
- Graphics
- Admin Utility
- Reporting
- RRL/Graphics Location Tool
- Learning Site
- Agency
- Archive/Unarchive
- Import/Export
- User
- Data Manager

NOTE: The Change Password, Site RRL, Graphics, Admin Utility, Reporting, and RRL/Graphics Location Tool utilities are available to all users; the remaining utilities are available only to users with AIM Administrator privileges.

2.1 CHANGE PASSWORD UTILITY

Passwords provide security against data loss. The AIM II Password Utility provides an easy, menu-driven method for changing your password.
To exercise the Change Password Utility, select **Change Password** from the **Utilities** drop-down menu on the AIM II Main screen. You may also click on the Password icon.

The AIM Administrator does not have to assign an AIM User password; he/she need only add the user to the list as an AIM User. When the user logs into AIM II, login can be accomplished without a password until the user selects the change password utility and enters a password. At initial entry, the user can depress <Return> when the cursor moves to the password field of the login window and gain access to AIM II until the user has entered a password into the system.

If you forget your password, the AIM Administrator can clear your old password by using the **Clear User Password** option from the User Utility. This option will retain your privileges for training materials assigned using the old password.

**2.1.1 Password Change Procedures**

Step 1 From the AIM II Main Menu click on the Password icon, or select Password from the **Utilities** drop-down menu.

Step 2 You will be prompted to enter the old password.

Step 3 You will be prompted to enter the new password. Spaces can be used in a password.

Step 4 Re-enter the new password for verification.

**NOTE:** The two entries must match perfectly, or the process is aborted. Clicking on Cancel before you enter the password the second time will cancel the operation and leave the original password in effect.

The password must have at least five characters. When you enter the password into the database, it is encrypted for increased security. Clicking on the Cancel button at any time before you reenter the new password for verification will abort the process, leaving the original password in effect.
2.2 SITE RESOURCE REQUIREMENTS LIST (RRL) UTILITY

The Site RRL Utility provides a means to enter the required information necessary to support all designated training development needs from a logistics viewpoint. The data fields are unique to each type of resource. You do not need to fill in each field for each RRL item, but the more thorough that you are at the time of initial data entry, the easier this information will be to update.

If the CNATT ERL is enabled in the Aim.ini file, the resources will have ERL identifiers. CNATT ERL Data is course specific. If CNATT Data exists and is required for a course, the AIM Administrator can import the CNATT ERL Data and Publications using the Import/Export utility. If CNATT Data does not exist you can create the RRL as stipulated below for non-equipment items.

To exercise the Site RRL Utility, from the Utilities drop-down menu shown on the AIM II Main screen, select Site RRL. You may also click on the RRL icon.

There are several different Site RRL windows and the one displayed depends on the Resources folder that has been opened.

1. If the Resource type is equipment the three columns in the upper pane of the window will contain the Nomenclature, Part Number, and Status of each piece of equipment that is contained in the open Resources folder.
2. If the Resource type is Publications, the three columns in the upper pane of the window will contain the Document Title, Document Number, and Status of each publication in the database.
3. If the Resource type is Films or Videos, the three columns in the upper pane of the window will contain the Designator, Title, and Status of each item, of the type highlighted, in the database.
4. If the Resource type is IMM (Animation, Audio, Graphic, Power Point, Video, or Simulation) the three columns in the upper pane of the window will contain the Designator, Title, and Status of each item that is contained in the open Resources folder.
5. If the Resource type is Photographs or Wall Charts the three columns in the upper pane of the window will contain the Number, Title, and Status of each item that is contained in the open Resources folder.
6. If the Resource type is Software the three columns in the upper pane of the window will contain the Title, Number, and Status of each item that is contained in the open Resources folder.
7. If the Resource type is Transparencies or Slides the three columns in the upper pane of the window will contain the Title, Figure Number, and Status of each item that is contained in the open Resources folder.

NOTE: If the RRL type is IETM a message stating "IETM RRL can only be viewed here. Go to the IETM Administration Screen in the Admin Module to Add/Modify/Delete this data." will appear. Refer to
Icons depict the different states of IMMs in the Site RRL. The Explain Flag option or menu button displays the reason behind the icon and, for conflicting IMMs, it also lists the nature of the conflict(s), and the IMMs it conflicted with:

- A question mark indicates that the file associated with an IMM is missing.
- A pencil indicates that the file associated with an IMM has been modified since it has been added to the AIM Media library.
- A flag indicates that an IMM conflicted with another IMM during import.

### 2.2.1 Site RRL Window Options Menu Item

The Site RRL **Options** menu contains the following options:

- **Add Resource**: Allows you to add items to the Site RRL or access the IMM window.
- **Modify/View Resource**: Allows you to modify or view the contents of the Site RRL.
- **Delete Resource**: Allows you to delete items from the Site RRL.
- **Grant Privileges**: Allows the AIM User who has been assigned this privilege to assign Edit and Grant privilege to other AIM Users for the resource item highlighted. This option gives the AIM Administrator the privilege to assign Edit, Grant, Approve, Clear In Use, and Maintain/Delete RRL privileges to AIM Users from the Site RRL.
- **Replace**: For *users with AIM Administrator privilege only*. Allows you to replace an item in the database with another item in the list and will provide the option of deleting the item from the Site RRL once replaced.
- **Display Related Materials**: Opens a browser that identifies all the training materials the item has been linked to in the database.
- **Flag Related Materials**: Allows you to flag an RRL item in training material that is in development or maintenance to inform users of an impending maintenance action requirement.
- **Display Unused Resources**: Allows you to view a list of items in the Site RRL which have not been linked to any training material.
- **Search Site RRL**: Allows you to search the entire RRL database (all types of RRL items) for a specific RRL item by title or number and provides wildcard (*) functionality.
- **SCORM Metadata**: Allows the user to edit the General, Rights, Lifecycle, and Classification Tabs of the resource for use in developing SCORM compliant Metadata files.
- **Print Preview**: Allows you to preview a list of the resource items that appear in the Site RRL for the desired RRL type.
• **Print:** Allows you to print a list of the items that appear in the Site RRL for the desired RRL type.

The window also has icons that represent the options and a field to execute a search on a Resource folder to **Find** an item. Selecting the Find field will clear the field and allows you to search for RRL items within the resource folder that is selected. A wildcard (*) is not necessary and the field is not case sensitive. When the desired information has been typed in the field, clicking on the **Find** button or depressing Enter on the keyboard will find the items with the characters typed in the field. Clicking on the **Clear** button clears the list of items from the list items that were a result of the Find and restores the list of all Resource items contained in the folder selected.

### 2.2.1.1 Add Resource

**To add an RRL item:**

1. **Step 1** From the AIM II main menu; select the **Utility** menu item and the **Site RRL** sub-menu item. Or, click on the RRL icon.

2. **Step 2** Click on the folder for the type of resource required, select the **Options** menu item and the **Add Resource** option or right click and select the **Add** option.

3. **Step 3** Fill in the fields required for the resource.
   For equipment type resources, when entering Unit Cost data, keep in mind that AIM will automatically add the dollar sign in the printout.
   
   With the exception of Publications, which require Document Number and Title entries, AIM II requires an entry in the first field of each type and the rest of the fields are optional.

   For IMM resources the **Add** option will open the IMM window from which you can select the **Options** menu item that provides the following options:
   - **Display Media** full screen for an IMM highlighted,
   - **Select File** to add a resource,
   - **Rename File** to edit if desired or clear a conflict with another IMM, and
   - **Remove File** to remove a conflicting file.
AIM has built-in support for the IMM file types listed below. This means that files of this type, when selected, will display in the AIM internal viewer (the display on the RRL, DP, RIA screens, as well as the viewer that is displayed when using the Display Media menu item on these screens).

However, a user is able to select any type of file they wish (i.e. HTML, PDF, MOV, DOC, etc, etc, etc). These files will be treated like any other file in the sense that the IMM will be linked to it. AIM will make a copy in the Media directory, etc. The only difference in picking a file without built-in support is the IMM display on the DP, RIA, and RRL screens is undefined (for example, picking a PDF or MOV file will show the file's icon, but picking a Word document shows the content of the first page of the Word file). Also, when you use the Display Media menu to display these files, they will open up in their native application. (So displaying a PDF will open up Adobe Acrobat reader).

File types with built-in support in AIM:

**Animations**
- .flc  FLC Animation
- .ani  Animation
- .swf  Shockwave

**Audio**
- .wav  WAV Audio
- .mid  MIDI Sequence
- .rmi  MIDI Sequence
- .au   AU Audio

**Graphics**
- .jpg  JPEG Image
- .bmp  Windows Bitmap Image
- .eps  Encapsulated PostScript
- .pcx  PCX Image
- .ico  Icons
- .cur  Cursors
- .cgm  Computer Graphics Metafile
- .drw  Micrografx Designer
- .dgn  DGN
- .plt  PLT Graphic
- .wpg  WordPerfect Graphic
- .png  Portable Network Graphics
- .gif  GIF
- .tiff  TIFF
Internet
  http:// Web Address
  https:// Web Address

PowerPoint
  .ppt   Microsoft PowerPoint
  .pot   Presentation Template
  .pps   PowerPoint Show

Video
  .avi   AVI Video
  .mpg   MPG Video
  .mpeg  MPEG Movies

Simulation
  .vsf   Virtual File System

Step 4 Select the Edit menu item and the Save sub-menu item to save your entries.

Step 5 Repeat Steps 3 and 4 for each additional resource of this type required.

Step 6 Repeat Steps 2 through 5 for each additional RRL type required.

Step 7 Select Exit to return to the AIM main menu.

2.2.1.2 Modify/View Resource

To modify an RRL item:

Step 1 From the AIM II main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.

Step 2 Click on the appropriate resource folder.

Step 3 Click on the item you wish to modify/view.

Step 4 From the Site RRL window select the Options menu item and the Modify/View Resource option.

Step 5 Use the Tab key to move to the desired field and enter the desired modifications.
NOTE: If an item is cited in currently approved baseline material, it cannot be modified.

Step 6 Select the **Edit** menu item and the **Save** option to save your entries.
Step 7 Select Exit to return to the Site RRL window.

2.2.1.3 Delete a Resource

To delete an RRL item:

Step 1 From the AIM I/II main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.
Step 2 Click on the RRL type required and click on the item you want to delete.
Step 3 From the Site RRL window select the Options menu item.
Step 4 Select the Related Materials option and sequentially select the TPP and Course options to determine whether the item is currently cited in training material. AIM I/II will present a list of TPPs/Courses under development or approved that cite the RRL item.
Step 5 Select the Delete Resource option.
Step 6 At the prompt Delete RRL XXX...? select Yes to delete the item from the database or No to return to the Site RRL window.

NOTE: If the item is cited in a TPP/Course, AIM I/II will mark the item as 'deleted', remove it from the Site RRL display, and flag the item in any Course under development. Marked for deletion items cannot be selected in a TPP/Course, but they will continue to appear in TPPs/courses where they have been selected. A TPP/Course cannot be approved if it cites a resource that is marked for deletion.

Step 7 Select Exit to return to the AIM II main menu.

To restore a marked for deletion RRL item:

Step 1 From the AIM I/II main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.
Step 2 From the Site RRL window select the Contents menu item and the Resources Marked for Deletion sub-menu item.
Step 3 Click on the RRL type required and click on the item you want to undelete.
Step 4 Select the Restore Resource option.
Step 5 At the prompt Do you want to make resource XXX... active? select Yes to restore the item to the database or No to return to the Site RRL window.
Step 6 Select Exit to return to the AIM II main menu.

2.2.1.4 Grant Privilege

The Grant Privilege option allows the AIM User who has been assigned this privilege to assign
Edit and Grant privilege to other AIM Users for the resource item highlighted. This option gives the AIM Administrator the privilege to assign Edit, Grant, Approve, Clear In Use, and Maintain/Delete RRL privileges to AIM Users from the Site RRL.
To grant privileges to a user for a resource item:

Step 1 From the Site Resource Requirements List window select the folder where the resource is located and highlight the resource item in the list.

Step 2 Select the Options menu item and the Grant Privileges option. AIM II will open the Grant Privileges for RRL window.

Step 3 Highlight the AIM User to be granted privilege(s).

Step 4 From the list of enable Privilege Attributes check the box(s) next to the privilege desired for the user.

Step 5 Select the Edit menu item and the Save sub-menu item.

Step 6 Select the additional users and privileges by repeating Steps 3 through 5. When complete; select the Exit menu item to return to the Lesson Plan window.

2.2.1.5 Replace an RRL Item

The Replace option allows the Administrator to replace a duplicated item in the database with another item of the same type listed in the Site RRL. This is a global replacement for the database and can even be accomplished in approved training materials.

To Replace an RRL item:

Step 1 Click on the folder for the resource type and highlight the RRL item you want to replace.

---

NOTE: Replace, Replace With, and Cancel Replacement menu items appear when you right-click on an RRL item as well as under the Options menu item.

---

Step 2 Select the Options menu item and the Replace option.

Step 3 If the item is cited in an approved course the software will prompt you with the question "RRL is used in an approved Course. Are you sure you want to replace RRL 'XXX'? Click on Yes to replace or No to cancel the option.
Step 4 If the item is cited in an approved training material and you clicked on **Yes** the software will prompt you with the statement "Select an RRL to replace it." Click on **OK** and click on the RRL item in the list that will replace it throughout the AIM II database. If the item is not cited in approved material the software will ask you for confirmation.

Step 5 Select the **Options** menu item and the **Replace with** option. You can also select **Cancel Replacement** to terminate the **Replace** option.

Step 6 If you selected the **Replace with** option you will be prompted with the question "Replace 'XXX' with 'YYY'?" Click on **Yes** to replace the item, **No** to select a different item, or **Cancel** to terminate the **Replace** option.

Step 7 If you clicked on **Yes** you will be prompted with the question "Do you want to delete 'XXX' after replacement?" Select **Yes** to delete 'XXX' from the Site RRL or **No** to leave it in the Site RRL.

### 2.2.1.6 Display Related Materials

**Display Related Material** allows you to determine what Course Identification Numbers (CINs) TPP, Trainee Preparation, DP/RIAs (Topic Number, DP Number and Text of DP) Instruction Sheets (type of Instruction sheet, number, and title) that cite the selected RRL item. It will also inform you if the item is in the course RRL but hasn’t been selected in the LP/TG.

**To view a list of related materials:**

Step 1 From the AIM II main menu; select the **Utility** menu item and the **Site RRL** sub-menu item. Or, click on the RRL icon.

Step 2 Click on the resource folder containing the RRL item and highlight the RRL item.

Step 3 Select the **Options** menu item and the **Display Related Materials** option.

Step 4 AIM will open a Results window that will contain all the folders that have links to the RRL item. You can Print Preview (Save as PDF) or Print the results.

Step 5 Select **Exit** to return to the Site Resource Requirements List window.
2.2.1.7  Flag Related Materials for Maintenance Action

The **Flag Related Materials** option provides the user the capability to flag an RRL item in a TPP or course under development or maintenance for possible maintenance action, (e.g., received a revision to a reference publication used in existing curricula). Flags will be generated in the TPP/Course RRL and in the LP/TG where the item is selected in a RIA/Instruction Sheet.

**NOTE:** This option will not flag approved training materials, nor will a flag appear in materials if a change or revision of the approved training material has been generated after the Flag Related Materials option is executed.

To flag related materials for maintenance action:

1. From the AIM II main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.
2. Click on the resource folder containing the RRL item and highlight the RRL item.
3. Select the Options menu item and the Flag Related Materials option.
4. Enter the maintenance text, in the RRL Maintenance Text window, that you want to accompany the flag for the RRL item selected.
5. Select the Edit menu item and the Save option to save your entry.
6. From the Site Resource Requirements List window select the Exit menu item to return to the AIM II main menu.

2.2.1.8  Display Unused Resources

The **Display Unused Resources** option allows you to search the entire Site RRL for items that are not linked to any training material items in the database. The **Options** menu item allows you to View, Select, Unselect an item, Delete the item highlighted, Delete Selected items, or Delete All items in the list.
2.2.1.9 Search the Site RRL for an RRL Item

The **Search for RRL** option allows you to search the entire Site RRL for an item. No matter which resource folder is selected, the search will be conducted in all types. Identify the item by Title/Number and the software will provide a list of the items found that match the entries and identify the RRL type they are located in for selection.

**To search the Site RRL database for an RRL item:**

1. From the AIM II main menu; select the **Utility** menu item and the **Site RRL** sub-menu item. Or, click on the RRL icon.
2. From the Site Resource Requirements List window select the **Options** menu item and the **Search Site RRL** option. AIM will open the Search RRL window.
3. Enter the Title/Number of the item desired and click on **Find** to initiate the search. AIM II will search the database and present a list of the items that match the Title/Number information entered and identify the type of RRL item each is.
4. Double click on the item desired and AIM will open the window for the RRL type of the item and the item will be highlighted.

2.2.1.10 SCORM Metadata

The **SCORM Metadata** allows you to add/edit metadata information for any resource in the RRL for later SCORM export of course information. Selecting this option when a resource item is highlighted in the Site RRL will allow you to add/edit Metadata category information in the SCORM Metadata window.

2.2.1.11 Explain Flag

Icons depict the different states of IMMs in the Site RRL. The **Explain Flag** option or menu button displays the reason behind the icon and, for conflicting IMMs, it also lists the nature of the conflict(s), and the IMMs it conflicted with:

- A question mark indicates that the file associated with an IMM is missing.
- A pencil indicates that the file associated with an IMM has been modified since it has been added to the AIM Media library.
- A flag indicates that an IMM conflicted with another IMM during import.
2.2.1.12 Print Preview a List of all RRL Items of a Type

To print preview a list of all RRL items of a type:

Step 1 From the AIM II main menu; select the Utility main menu item and the Site RRL sub-menu item. Or, click on the RRL icon.

Step 2 Click on the resource folder containing the RRL items desired.

Step 3 From the Site Resource Requirements List window select the Options menu item and the Print Preview option.

Step 4 AIM II will present a screen of the Site RRL, as it would appear in printout form. Use the buttons at the bottom of the screen to scroll right and left and the buttons on the right of the screen to scroll up and down.

Step 5 If you want a printout, select the Print menu item and, from the Print Setup window, select OK.

Step 6 Select Exit to return to the Site Resource Requirements List window.

Step 7 Select the Exit menu item to return to the AIM II main menu.

2.2.1.13 Print a List of all RRL Items of a Type

Step 1 From the AIM II main menu; select the Utility menu item and the Site RRL sub-menu item. Or, click on the RRL icon.

Step 2 Click on the resource folder containing the RRL items desired.

Step 3 From the Site Resource Requirements List window select the Options menu item and the Print option.

Step 4 From the Print Setup window select OK to print.

Step 5 Select the Exit menu item to return to the AIM II main menu.
2.2.1.14 Transparencies Window Options Menu Item

Selecting **Options** menu item will display the drop-down menu shown in *Figure B-1*. From here you may add graphics into the RRL Transparencies list.

![Figure B-1. Transparencies Window Options Menu Item](image)

Selecting **Add Graphic** from **Options** drop-down menu on the RRL Transparencies Screen will display the Graphics window shown in *Figure B-2*. 

![Figure B-2. Transparencies Window Add Graphic Menu Item](image)
Click on the graphic desired and select the **Options** menu item and the **Select** option. The positioning and size information is reflected on the bottom of the window when the graphic is selected. The default graphic size is the size of the graphic when it was brought into the AIM II database and is reflected in the print width and print height fields. The width and height can be modified when the graphic is selected. The same graphic can be used over and over and be resized each time it is used. This reduces the quantity of graphics in the database.

The default position for printing the graphic on the page is Center, however, Specify printing position can be selected and you can enter the number of inches from the left and from the top of the page where the graphic will print. Once the graphic sizing and positioning information is saved to the RRL it cannot be modified. If the size and positioning information are incorrect, delete the transparency and add a new one.

---

**Figure B-2. Graphics Selection Menu**

<table>
<thead>
<tr>
<th>Description</th>
<th>Width</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>#1-10-1</td>
<td>6.06</td>
<td>3.81</td>
</tr>
<tr>
<td>#1-10-10</td>
<td>5.75</td>
<td>3.93</td>
</tr>
<tr>
<td>#1-10-2</td>
<td>6.16</td>
<td>2.72</td>
</tr>
<tr>
<td>#1-10-3</td>
<td>5.95</td>
<td>2.49</td>
</tr>
<tr>
<td>#1-10-4</td>
<td>5.96</td>
<td>2.73</td>
</tr>
<tr>
<td>#1-10-5</td>
<td>6.00</td>
<td>4.06</td>
</tr>
<tr>
<td>#1-10-6</td>
<td>5.93</td>
<td>3.87</td>
</tr>
<tr>
<td>#1-10-7</td>
<td>5.78</td>
<td>3.88</td>
</tr>
<tr>
<td>#1-10-8</td>
<td>5.81</td>
<td>3.97</td>
</tr>
<tr>
<td>#1-10-9</td>
<td>5.76</td>
<td>3.94</td>
</tr>
<tr>
<td>#1-6-1</td>
<td>3.75</td>
<td>1.74</td>
</tr>
<tr>
<td>#1-6-2</td>
<td>3.58</td>
<td>2.02</td>
</tr>
<tr>
<td>#1-6-3</td>
<td>6.37</td>
<td>4.34</td>
</tr>
<tr>
<td>#1-9-10</td>
<td>3.57</td>
<td>2.80</td>
</tr>
<tr>
<td>#1-9-2</td>
<td>3.56</td>
<td>2.74</td>
</tr>
<tr>
<td>#1-9-4</td>
<td>3.50</td>
<td>3.77</td>
</tr>
</tbody>
</table>

- Center graphics at default position
- Specify printing position

Print width: 6.16
Print height: 2.72
From left
From top
Selecting **Options** menu item from the Graphics window will display the drop-down menu shown in *Figure B-3*. The user may **Select** the graphic for the transparency, **View** a graphics, and **Find** a graphic.

![Figure B-3. Graphics Window Options Menu Item When Creating a Transparency](image)

### 2.2.1.15 Clearing a Conflicting State on an IMM

You can use any of the following actions to clear the conflicting state of an IMM in the Site RRL:

- **Delete** the IMM that is conflicting with the Imported IMM. (You cannot delete the conflicting IMM itself, because it is used in a Course).
- **Modify** the IMM that is conflicting with the Imported IMM. (Modifying an IMM includes changing its designator, title, selecting a new file, or renaming the existing file).
- **Modify** the conflicted IMM itself. AIM will allow the modification of a conflicted IMM even if the RRL is approved, and/or used in an approved course.
- **Use** the Replace command to replace one IMM with another. Replacing a conflicted IMM with another IMM (normally the conflicting IMM) will clear the conflict. You can replace an IMM with a conflicted IMM, but ONLY if the action would remove the conflict.
Conflicted IMMs cannot be cited in any Course other than the one it was Imported with.
2.3 GRAPHICS UTILITY

Selecting the Graphics utility opens the Graphics window, which lists all the graphics identified in the system with a description and width and height information. The Graphics window offers the following main menu options:

- Options
- Edit
- Exit
- Help

2.3.1 Graphics Options Menu Item

The Options menu item pertains to the selected graphic. It contains the following options:

- Add Graphic
- Modify Graphic
- Delete Graphic
- Replace Graphic
- View Graphic
- Find Graphic
- Display Unused Graphics
- Related Courses
- SCORM Metadata

2.3.1.1 Add Graphic Option

The Add Graphic option presents an Open window that allows you to identify the location of a graphic (drive, directory, and filename) you want to add to the Graphics list. Once you have identified the graphic, AIM II will present the Select Graphic window, which allows you to select the graphic file you want to add. If the graphic isn’t a JPG file AIM II will convert it to a JPG file when you add a description to the Graphics Utility and Save it to the database.

AIM II will accept the following types of windows compatible graphics:

- Computer Graphics Metafile, cgm
- Cursors, cur
- DGN, dgn
- Encapsulated PostScript, eps
- GIF, gif
- Icons, ico
To select a graphic, either double click on its File name or type the name of the graphic in the File Name block. Click on the OK button. The Select graphic window will then open.

The Select Graphic window contains the following menu items:

- **Options**
- **View**
- **Exit**
- **Help**

The **Options** menu item offers the following options:

- **Open**: Allows you to open a different file.
- **Select**: Allows you to add the displayed graphic to the AIM II graphics database.
- **Print**: Allows you to print the graphic on the connected printer.

**Selection of the Graphics View Menu Item.** The **View** menu item allows you to view the graphic selected on screen. It contains the following options:

- The **Actual size** option allows you to view the graphic in its actual size. Double clicking on a portion of the graphic will allow you to zoom in on that portion of the graphic.
- The **Fit to Frame** option allows you to expand the graphic to fill the frame of the window.
- The **Zoom** option allows you to vary the size of the graphic from 50% to 100%.

Once you have determined that this is the graphic you want, select the **Options** menu item and the **Select** option. This will select the graphic, load it into the Graphics library, and return you to the Graphics window. Enter a description of the Graphic in the text field and select the **Edit** menu item and the **Save** sub-menu item to save the Graphic and its description to the database.
If the graphic selected is an Encapsulated PostScript (EPS) file the software will perform an auto-conversion and will present you with the Resizing window. From this window the Options menu item will present the following options:

- **Crop**
- **Resize**
- **Invert**
- **Rotate**
- **Zoom**

### 2.3.1.2 Modify Graphic Option

The Modify Graphic option permits you to crop, resize, invert, and rotate a graphic that is contained in the Graphic library.

The **Crop** option presents a Resizing window that allows you to place a box around the portion of the graphic that you want to retain and remove the portion outside the crop box. You must save the cropped graphic to the database before it can be cropped again.

**To crop a graphic:**

1. From the Graphics window; select the **Options** menu item and the **Modify Graphic** option. AIM II will open the Resizing window.
2. Select the **Options** menu item and the **Crop** option. A cross will appear in the window when you select the **Crop** option.
3. Position the cross in the upper left hand corner above the portion of the graphic desired, click and hold the left mouse button, drag the box around the graphic to encompass the portion desired, and release the left mouse button.
4. Select the **Edit** menu item and the **Save** sub-menu item. Save the cropped graphic to the database.
5. Select the **Exit** menu item to return to the Graphics window.

The **Resize** option allows you to reduce the size of the graphic by 10% each time it is selected. This option will reduce the quality of the graphic image and it is recommended that you print the graphic after each resizing, before you save it to the database, to verify the quality is satisfactory. There is no option to enlarge the graphic once it has been reduced using the **Resize** option.
To Resize a graphic:

Step 1  From the Graphics window select the **Options** menu item and the **Modify Graphic** option. AIM II will open the Resizing window.

Step 2  Select the **Options** menu item and the **Resize** option.

Step 3  Select the **Edit** menu item and the **Save** sub-menu item to save the graphic to the database.

Step 4  Select the **Exit** menu item to return to the Graphics window.

The **Invert** option allows the user to invert a graphic that is too difficult to see because of the background used when the graphic was developed. Inverting the graphic changes the background from either black to white or white to black.

To Invert a graphic:

Step 1  From the Graphics window select the **Options** menu item and the **Modify Graphic** option. AIM II will open the Resizing window.

Step 2  Select the **Options** menu item and the **Invert** option.

Step 3  Select the **Edit** menu item and the **Save** sub-menu item to save the graphic to the database.

Step 4  Select the **Exit** menu item to return to the Graphics window.

The **Rotate** option allows you to rotate the graphic 90, 180 or 270 degrees and save the graphic in this position for the AIM II Graphics database.

To Rotate a graphic:

Step 1  From the Graphics window select the **Options** menu item and the **Modify Graphic** option. AIM II will open the Resizing window.

Step 2  Select the **Options** menu item and the **Rotate** option.

Step 3  Select **90 Degrees**, **180 Degrees**, or **270 Degrees** sub-menu item.

Step 4  Select the **Edit** menu item and the **Save** sub-menu item.
Step 5 Select the Exit menu item.

2.3.1.3 Delete Graphic Option

The Delete Graphic option allows you to delete the graphic highlighted in the Graphics window. If a graphic is used in an approved course it cannot be deleted.

2.3.1.4 Replace Graphic Option

The Replace Graphic option allows you to replace the graphic highlighted in the Graphics window with another graphic. Wherever this graphic is called out, in Instruction Sheets in the AIM II database, the graphic will be replaced with the new graphic. If a graphic is used in an approved course it cannot be replaced.

2.3.1.5 View Graphic Option

The View Graphic option, which you may select after you have highlighted a desired graphic in the Graphics window, presents the Select Graphic window.

2.3.1.6 Find Graphic Option

In a very large database that contains many graphics, it is easier to use the Find option to highlight the desired graphic than to page through the list in the Graphics window.

To find a graphic:

Step 1 Select the Utilities menu item and the Graphics option or click on the Graphics icon. AIM II will present the Graphics window.

Step 2 Select the Options menu item and the Find option. AIM II will present the Find window.

Step 3 Enter the description of the graphic desired in the Find Graphic field. Notice that the field contains a wildcard (*). As you enter the description, the graphics that start with that description up to the * are displayed in the list below.
Step 4 When you have identified the desired graphic, you can select it one of two ways:
   a. Click on the **Select** menu item. AIM II will return you to the Graphics window and the selected graphic will be highlighted.
   b. From the list below the Find Graphic field, double click on the desired graphic. AIM II will return you to the Graphic window, and the selected graphic will be highlighted.

### 2.3.1.7 Display Unused Graphics

The **Display Unused Graphics** option presents a list of all graphics that have not been selected in any training material in the database. The items are listed by the Description in the Unused Items window. The graphic can be viewed for accuracy or the graphic(s) can be deleted from the Graphics Utility.

### 2.3.1.8 Related Courses Option

The **Related Courses** option will display the courses that cite the graphic and where in each course the graphic is used. The display can be printed. If a graphic is not linked to a course it can be deleted using the delete option from the Graphics Utility.

### 2.3.1.9 SCORM Metadata

The **SCORM Metadata** option allows the user to edit the General, Rights, Lifecycle, and Classification Tabs of the Asset for use in developing SCORM compliant Metadata files. Refer to Appendix E for more information on SCORM.

### 2.4 ADMINISTRATION UTILITY

The AIM II Administration Utility consists of a package of utilities that allows the AIM Administrator and AIM User with the assigned privilege level to:

- **View RRL**: View the Site RRL field entries for a Complete RRL item.
- **Show In Use Items Only**: View only the In Use Content menu items.
- **Grant Privilege**: Grant specific privilege levels to specific individuals for specific curriculum products.
- **Approve**: Approve TPPs, Courses, or RRL items.
Show In Use Information: Identify by login name and time of who is using a Content menu item.
• Clear In Use: Clear an In Use flag.
• Clear Conflict State: Clear a conflicting state of an IMM in a course that is in conflict with another course
• Create and import IETM extract files.

NOTE: Approval is a final act. Do not approve a training material item (TPP or Course) until authorized by the CCA.

To exercise the Administration Utility, from the Utilities drop-down menu on the Utilities screen, select the Admin Utility.

Selecting Contents displays the drop-down menu containing the training material types in the database (TPP, Course, Testing, LP/TG, RRL, IETM, and User Tracking). When the type of material desired has been selected the options available for the training material type will be enabled or, when IETM is selected, the IETM window will open to permit the Administrator to create Extract files and Import IETM Extract files into the Site RRL.

2.4.1 View RRL

The View RRL option is enabled after selection of the RRL. It allows you to view and edit, if you have Edit privilege for the RRL item, the field entries for an RRL item (with a status of Complete) in the Site RRL.

To view an RRL item:

Step 1 From the AIM II Main Menu select the Utilities menu item and select the Admin Utilities sub-menu item or click on the Admin icon. AIM II will present the user with the Administration Utility window.

Step 2 Select the Contents menu item and select the RRL type of training material. AIM II will present a list of the Site RRL items with a complete status in the Site RRL and they will be listed by RRL Type.

Step 3 Highlight the desired item from the list and select the Options menu item.

Step 4 Select the View RRL option. AIM II will present you with the fields of the RRL item. If you have edit privilege you will be able to edit the fields.
Step 5  Select the **Exit** menu item to return to the Administration Utility window.

### 2.4.2 Grant Privilege

When an AIM Administrator or an individual with Grant privilege, selects **TPP, Course, Testing, LP/TG, or RRL** from the **Contents** menu item, AIM II will present a list of all the items of the type selected. Highlighting the desired training material item from the list and selecting the **Options** menu item and the **Grant Privilege** option will present the user with the Grant Privilege window. The user with Grant privilege will highlight an AIM User from the list of login names and select the desired privileges for the training material item.

"Privilege" provides a level of administrative security for the training materials. The privilege level granted to a user will determine not only what training materials the user has access to, but what functions the user may perform upon a given training material.

- **a.** The Initiator of a training material type has the following privileges for training materials created:
  - TPP – Edit, Lock, Grant, and Clear In Use
  - Course – Edit, Lock, Grant, Clear In Use, and Maintain/Delete Course
  - Testing – View, Edit, Lock, Grant, Maintain/Delete Tests
  - LP/TG – Edit, Grant, and Clear In Use
  - RRL – Edit, Grant, Clear In Use, and Maintain/Delete RRL.

- **b.** The AIM II Administrator has unlimited access to all training material in the AIM II database. The AIM II Administrator can change (assign or revoke) privilege levels for all AIM Users. Only the Administrator can assign or revoke Approve, Remove Flag, and View (Test Module only) privileges.

- **c.** The privilege levels are:
  1. **View.** Allows a user to view test items and tests for a course in the Testing module.
  2. **Edit.** Edit will allow the user to edit the training material item for which that user has privilege and add Notes to the folder in the Course Tree structure.
  3. **Lock.** Lock will allow the user to Lock, and Unlock the training materials for which the user has Lock privilege.
  4. **Grant.** Allows a user to grant privileges to another user for the training material item.
  5. **Approve/Unapprove.** Allows an AIM User to approve and unapprove test items and tests in the Testing Module.
  6. **Approve.** Allows an AIM User to approve the training material item (TPP, Course, or Site RRL item).
(7) **Remove Flag.** Remove Flag privilege will allow the user to remove maintenance flags, which is required prior to approval of the item (TPP, Course, Test/Test Item, LP/TG).

(8) **Clear In Use.** Allows an AIM User to clear an In Use flag for a training material item [TPP, Course, LP/TG (Topic or TG Sheet)].

(9) **Maintain/Delete.** Allows an AIM User to maintain and delete the training material item (Course, Test Items and Tests, or Site RRL items).

**To Grant Privilege to another user:**

Step 1  From the AIM II Main Menu select the **Utilities** menu item and select the **Admin Utilities** option or click on the Admin icon. AIM II will present the user with the Administration Utility window.

Step 2  Select the **Contents** menu item and select the type of training material that privilege will be granted for. AIM II will present a list of the material of the type selected.

Step 3  Highlight the desired item from the list and select the **Options** menu item.

Step 4  Select the **Grant Privilege** option. AIM II will present the user with the Grant Privilege window for the item selected.

Step 5  Click on the desired user and check the appropriate privilege blocks for the material selected.

Step 6  If more than one user is to be granted privilege, select the **Edit** menu item and the **Save** option to save your entries and repeat Step 5 and 6 or the **Cancel** option to remove your entries. If the **Cancel** option is selected AIM II will prompt the user with "All changes will be lost. Are you sure you want to cancel?" Select **Yes** if you want to cancel and exit to the Administration Utility menu or **No** to return to the Grant Privilege window.

Step 7  When complete select the **Exit** menu item to return to the Admin Utility window for the training material type selected. Select **Exit** again to return to the AIM main menu.
2.4.3 Approving Training Material

Approval of a TPP or a Course is a final act. Insure that the cover page of the material being approved contains the correct dates before approving the material. The TPP has a Date field to record the date that the Curriculum Control Authority (CCA) approved the TPP. The TCCD has a Date field to record the promulgation date from the Letter of Promulgation issued by the CCA. The Lesson Plan has two date fields, one called the Preparation Date and the other the Revision Date. The Preparation Date field can either contain the date from the Letter of Promulgation or the date of an approved Change Notice. The Revision Date field will either be blank (for Rev 0) or contain the Letter of Promulgation date for a later Revision.

Prior to approving a Change or Revision, all flags must be removed by a person assigned Remove Flag privilege. The Explain Flag options contained in the modules of AIM II allow the reviewer to view and print the Maintenance Record for the flagged item. The Remove Flag options allow the reviewer to remove the flags individually during the review process. To assist the AIM Administrator in filling out the Change Record, it is recommended that the individual with Remove Flag privilege obtain a printout (or print to file) of the Maintenance Record for each flagged item before selecting the Remove Flag option. Removal of all flags indicates the maintenance actions are complete and have been reviewed for accuracy. Each training material module of AIM II contains the Explain and Remove Flag options. The Course Select window contains the option *Locate Flags* which identifies the items flagged in the entire Course. Selecting the Remove All Flags option, from the Course Select window for the highlighted course, removes all flags from the entire course. Once flags are removed the Maintenance Records for these items can no longer be accessed.

To approve a training material item:

Step 1 From the AIM II main menu, select the Utilities menu item and select the Admin Utilities sub-menu item or click on the Admin icon. AIM II will present the user with the Administration Utility window.

Step 2 Select the Contents menu item and select the type of training material that you are going to approve. AIM II will present a list of the material of the type selected.

Step 3 Highlight the desired item from the list and select the Options menu item.

Step 4 Select the Approve option. The Admin utility will prompt the user with "Approve (item selected)?"

Step 5 To approve the item, select Yes at the prompt.
NOTE: The TPP and all RRL items cited in the training material must be approved and all flags must be removed prior to approving the course.

Step 6  If a message appears stating that the course contains flagged material and cannot be approved and the reviewers have submitted the Maintenance Record printouts (or created Maintenance Record files) for all flagged items to be entered in the Change Record, perform the following:
   a. Click on the OK button and select the Exit menu item to exit the Admin utility and return to the AIM II menu.
   b. Select the Course menu item and the Select sub-menu item.
   c. Highlight the CIN to be approved.
   d. Select the Options menu item and the Locate Flags option. The Locate Flags window will tell you the modules that contain maintenance flags. Verify the Maintenance Record printouts correspond to these modules.
   e. Select the Exit menu item from the Locate Flags window.
   f. From the Course Select window, select the Options menu item and the Remove All Flags option.
   g. Select the Exit menu item and return to Step 1.

Step 7  If approving a Change, the Description of Change window will open. This window contains two fields, one for Description of LP Change, and one for Description of TG Change. Each of these fields allows up to 240 characters. Assemble the maintenance records from the reviewer(s) who cleared the Maintenance flags in the LP/ TG and enter the maintenance information for the Change Record in the appropriate fields.

Step 8  Select Edit and Save to save the Change Record information and approve your Change.

Step 9  Select Exit to return to the AIM II Main Menu.

2.4.4 Clear In Use

If the user is working in a module of AIM II and is forced to exit because of an unusual occurrence (e.g., a power failure or disk failure), the In Use flag will remain set and prevent the user from resuming the task last accessed. The AIM II Clear In Use Utility provides the capability to reset the In Use flag.
The purpose of the In Use flag is to prevent more than one person from trying to write to the same fields in the database at the same time. This could cause loss of information in that portion of the database.

In the event that an In Use flag is set by accident, an individual with Clear In Use privilege must clear this flag before work can continue on the affected training material item.

**To clear an In Use flag:**

1. From the AIM II main menu, select the **Utilities** menu item and select the **Admin Utility** sub-menu item. Or, select the Admin icon. AIM II will then present the Administration Utility window.

2. Select the **Contents** menu item and select the type of training material from which you wish to remove the In-Use flag.

3. If the database contains a large number of courses you can select the **Options** menu item and the **Show In Use Items** option to narrow your search. When this option is selected only the items in use will appear. Highlight the desired item from the list and select the **Options** menu item.

4. Select the **Options** menu item and the **Show In Use Information** option to verify that you are the only AIM User for which the In Use flag is set. Select **Exit** when verified.

5. Select the **Clear In Use** option. AIM II will ask you to confirm your intention to remove the flag.

6. Select **Exit** to return to the AIM II main menu.

### 2.4.5 Clear Conflict State

In the Admin Module and the Course Select window the courses that have IMM that are in conflict are displayed in red. When a course is highlighted that is red and the conflicting IMM has been edited or removed the **Clear Conflict State** option will be enabled to change the Course to a normal foreground color display, remove the conflict and allow the courses to be edited/maintained. Refer to Import/Export Utility (Generate Import IMM Report, paragraph 2.11.5) for definitions of conflicting IMM states. IMM items will also be in red in the RRL if in a conflict state.
2.4.6 Importing IETM Extract Files

Adding an IETM to the AIM II database is a two-step process. First the IETM structure data must be extracted to an AIM II compatible file (refer to Appendix D). Second the extracted IETM structure data is then imported into the AIM II database.

**To import IETM extract files to the Site RRL perform the following:**

- **Step 1** From the AIM II main menu click on the Admin icon.
- **Step 2** Click on the **Contents** menu item and select the **IETM** option.
- **Step 3** From the IETM window, click on the **File** menu item and the **Import** sub-menu item.
- **Step 4** Click on the location of the drive, directory, and file name of the extraction file and click on **OK**.

AIM will import the extraction files of the IETM into the Site RRL and the fields of the IETM window will be populated with IETM information, including the IETM name and version of the IETM. The AIM User can now select the IETM for a TPP or TCCD. The IETM must be selected in the Course RRL to be cited in a DP/RIA or Instruction Sheet.

**WARNING:** The fields containing the IETM information can be edited if the location of the viewer should change. Do not change the information in these fields unless required. Improper entries could disable the viewer/browser.

**To add a later version of an IETM to the Site RRL:**

- **Step 1** From the AIM II main menu click on the Admin icon.
- **Step 2** Click on the **Options** menu item and select the **IETM** option.
- **Step 3** From the IETM window, click on the **File** menu item and the **Import** sub-menu item.
- **Step 4** Click on the location of the drive, directory, and file name of the extraction file and click on **OK**.
AIM will import the extraction files of the IETM into the Site RRL and the fields of the IETM window will be populated with IETM information, including the IETM name and version of the IETM.

**WARNING:** The fields containing the IETM information can be edited if the location of the viewer should change. Do not change the information in these fields unless required. Improper entries could disable the viewer/browser.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 5</td>
<td>Click on the previous version of the IETM and select the <strong>Options</strong> menu item and the <strong>Link IETM</strong> option. AIM will link the new version with the previous version IETM.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Highlight the previous version IETM, select the <strong>Options</strong> menu item and the <strong>Impact Report</strong> option. AIM will open the IETM Courses window that will contain a list of all courses that cite the IETM.</td>
</tr>
<tr>
<td>Step 7</td>
<td>Impact reports for all the courses can be generated by selecting the <strong>Options</strong> menu item and the <strong>Select All</strong> option or an Impact Report can be generated for individual courses by clicking on the desired course and selecting the <strong>Options</strong> menu item and the <strong>Select</strong> Option.</td>
</tr>
<tr>
<td>Step 8</td>
<td>Select the <strong>Options</strong> menu item and the <strong>Generate Impact Report</strong> option. AIM will generate an IETM Impact Report for each course selected. The report can be viewed or printed and will contain a list of:   * Impacted RIAs,   * Impacted TG Sheets, and   * Newly added IETM nodes.</td>
</tr>
</tbody>
</table>

**NOTE:** Refer to the TCCD Module Chapter 9 paragraph 9.4.5.1, "To add a later version of an IETM to a Learning Site RRL" to complete selection of the later version IETM for the effected course(s).

2.4.6.1. Mapping the location of the IETM Viewer

The IETM viewer has to be mapped to the location of the IETM after installing it in the AIM database. The IETM DDE information is updated to identify the path the viewer needs to display the IETM when selected for viewing. DDE information is unique to the type of IETM identified.
To map a SGML-Based IETM Viewer:

Step 1 Select the **Utilities** menu item from the AIM main menu and the **Admin Utility** from the drop-down menu.

Step 2 From the Administration Utility window select the **Contents** menu item and select the **IETM** sub-menu item. AIM will open the IETM window.

Step 3 Highlight the SGML-Based IETM to be mapped.

Step 4 From the IETM window, select the **Options** menu item and the **DDE Information** sub-menu item. AIM will open the IETM DDE window.

Figure B-4. IETM DDE Window for SGML-Based
Step 5 View/select the appropriate viewer type in the IETM Viewer Type field.

Step 6 Verify/update the book name and path to the folder in the Topic Name field.

Step 7 Verify/update the path to the TMMIAPP or dtext.exe file for the IETM in the Application Location field.

Step 8 Verify/update the path to the BIN directory in the Configuration Location field.

Step 9 Select the Edit menu item and the Save sub-menu item.

Step 10 Select the Exit menu item to return to the IETM window.

Step 11 Select the Options menu item and the View IETM option. This will open the browser for the IETM.

Step 12 Open the IETM and highlight a viewable node. Select the Options menu item and the View option for verification that the mapping is correct.

To map an ARCI IETM Viewer:

Step 1 Select the Utilities menu item from the AIM main menu and the Admin Utility from the drop-down menu.

Step 2 From the Administration Utility window select the Contents menu item and select the IETM sub-menu item. AIM will open the IETM window.

Step 3 Highlight the ARCI IETM to be mapped.

Step 4 From the IETM window, select the Options menu item and the DDE Information sub-menu item. AIM will open the IETM DDE window.
Step 5 View/select the appropriate viewer type in the IETM Viewer Type field.

Step 6 Select the **Edit** menu item and the **Save** sub-menu item.

Step 7 Select the **Exit** menu item to return to the IETM window.

Step 8 Select the **Options** menu item and the **View IETM** option. This will open the browser for the IETM.

Step 9 Open the IETM and highlight a viewable node. Select the **Options** menu item and the **View** option for verification that the mapping is correct.
To map a PDF Documents IETM Viewer:

Step 1 Select the Utilities menu item from the AIM main menu and the Admin Utility from the drop-down menu.

Step 2 From the Administration Utility window select the Contents menu item and select the IETM sub-menu item. AIM will open the IETM window.

Step 3 Highlight the PDF Documents IETM to be mapped.

Step 4 From the IETM window, select the Options menu item and the DDE Information sub-menu item. AIM will open the IETM DDE window.

Step 5 Verify/update the location of the PDF file in the PDF file location field.
Step 6 Select the **Edit** menu item and the **Save** sub-menu item.

Step 7 Select the **Exit** menu item to return to the IETM window.

Step 8 Select the **Options** menu item and the **View IETM** option. This will open the browser for the IETM.

Step 9 Open the IETM and highlight a viewable node. Select the **Options** menu item and the **View** option for verification that the mapping is correct.

**To map a PMS Documents IETM Viewer:**

Step 1 Select the **Utilities** menu item from the AIM main menu and the **Admin Utility** from the drop-down menu.

Step 2 From the Administration Utility window select the **Contents** menu item and select the **IETM** sub-menu item. AIM will open the IETM window.

Step 3 Highlight the PMS Documents IETM to be mapped.

Step 4 From the IETM window, select the **Options** menu item and the **DDE Information** sub-menu item. AIM will open the IETM DDE window.
Step 5  Verify/update the location of the PMS view (PMSviewer.exe) in the Application Location field.

Step 6  Select the Edit menu item and the Save sub-menu item.

Step 7  Select the Exit menu item to return to the IETM window.

Step 8  Select the Options menu item and the View IETM option. This will open the browser for the IETM.

Step 9  Open the IETM and highlight a viewable node. Select the Options menu item and the View option for verification that the mapping is correct.
To map a Raster Tech Manuals IETM Viewer:

Step 1 Select the **Utilities** menu item from the AIM main menu and the **Admin Utility** from the drop-down menu.

Step 2 From the Administration Utility window select the **Contents** menu item and select the **IETM** sub-menu item. AIM will open the IETM window.

Step 3 Highlight the Raster Tech Manuals IETM to be mapped.

Step 4 From the IETM window, select the **Options** menu item and the **DDE Information** sub-menu item. AIM will open the IETM DDE window.

![IETM DDE Window](image.png)

**Figure B-8.** IETM DDE Window for Raster Technical Manuals
Step 5 Verify/select the appropriate viewer type in the IETM Viewer Type field.

Step 6 Verify/update the path to ATIS Interface field.

Step 7 Select the **Edit** menu item and the **Save** sub-menu item.

Step 8 Select the **Exit** menu item to return to the IETM window.

Step 9 Select the **Options** menu item and the **View IETM** option. This will open the browser for the IETM.

Step 10 Open the IETM and highlight a viewable node. Select the **Options** menu item and the **View** option for verification that the mapping is correct.

### 2.4.7 User Tracking

This option is only available to AIM Administrators and is intended to be used as a security measure to determine user and event activity. This option should only be used by experienced AIM Administrators. The User Tracking option is used to display user events, due to memory constraints only 10,000 events will be displayed. To display these events follow these steps:

Step 1. From the Main AIM screen select Utilities
Step 2. From the Utilities drop down menu bar select Admin Utilities
Step 3. From the Admin Utilities screen menu bar select Contents
Step 4. From the Contents drop down menu select User Tracking
Step 5. The User Event Display screen is displayed, it is now possible to scroll through the list of events displaying each event's ID, the User Name associated with the event, and the event text. When highlighting an event detailed information will be displayed on the right side of the User Event Display screen.

There are three options available from the User Event Display screen, they are:

- **Filter** - The Filter option allows the administrator to filter the contents of the User Events Display screen. The filtering available is as follows:
  - **User** - Filter by User Name.
  - **Date Range** - Filter by a range of dates.
  - **Types** - Filter by the following Event Types
    - Successful or Unsuccessful Login Attempts
- Data Viewing/Saving, view events for a specific type of data viewed or saved.
  - **Form** - Search based on a specific database form.
  - **Text Search** - Search based on specific text.
- **Archive** - The Archive option will create a .zip file with a list of the events selected, when the Archive option is selected a dialog box requesting an End Date for the archive will appear, all events older than the End Date will be archived.
- **Output to Excel** - The Output to Excel option will create a .csv file of all events. This output is NOT restricted to the 10,000 events that are displayed, the .csv file will contain all events, or filtered events if filtering is used.

### 2.5 REPORTING

The Reporting utility allows you to generate a number of pre-formatted Reports with selected information and Data Output files.

Selecting the **Utilities** menu item and the **Reporting** sub-menu item, or clicking on the Reporting icon, opens the AIM Reporting window (*Figure B-9*).
To create a report:

Step 1 Select the Reports tab and highlight the desired report.

Step 2 Select the Options menu item and the Generate option. This will open the Print Preview window that will contain the report.

Step 3 Selection of the Options menu item will provide the options to Print or Save to PDF file.
To create a Data Output file:

Step 1  Select the **Data Output** tab and highlight the data desired.

Step 2  Select the **Options** menu item and the **Generate** option. This will open the Select Course window.

Step 3  Highlight and **Select** the desired course. The Select Output File window will open and AIM will assign a name to the file, which can be edited. In the **Save in** field select the directory in which the file will be written and click on the **Save** button.
2.6 ASSOCIATED CURRICULUM DOCUMENTS (ACD)

The Associate Curriculum Documents Tool allows AIM II users to add documents for use as reference or inclusion in a course that are not published documents, this includes but is not limited to the following: Exercise Control Guides (ECGs), Evolution Brief Sheets, Operational Risk Management (ORM) sheets, Administrator Guides, and other related documents.

2.6.1 Associated Curriculum Documents Window

The main window of the Associated Curriculum Documents (ACD) Tool is the Documents Main window. This window has the following menu options:

- **Options**
- **Exit**
- **Help**

The Documents Main window is split into two panes, the right pane is a summary window and the left pane is a tree structure window. In the tree structure window there is a main folder titled Types with subfolders under it for each type of ACD that has been developed.

The **Options** menu has the following options:

- **Add Document**: Used to add an ACD for the highlighted type.
- **Modify/View Document**: Used to edit an existing ACD.
- **Delete Document**: Used to delete an ACD.
- **Grant Privilege**: Used to grant privileges to other users.
- **Display Related Materials**: Used to show where the ACD is used in the curriculum.
- **Flag Related Materials**: Used to add maintenance text to the ACD.
- **Document Types**: Used to add additional ACDs.

2.6.1.1 Add Document

To add a document to the ACD documents list follow these steps:

- **Step 1** Ensure the document type is highlighted in the tree structure pane of the Document Main window.
- **Step 2** Select **Add Document** from the **Options** menu.
- **Step 3** From the Document Info window fill in the information for the text boxes in the window (Number, Title, Type, Classification, and NOFORN) Notice the Type text box is prefilled with the ACD type highlighted from the Document Main window.
- **Step 4** Select **Edit**, then Save.
- **Step 5** Select **Contents**, then **Resources**.
- **Step 6** From the Document Resources window select **Add**. This will take you to the
Step 7 Select the desired resource by double-clicking on it.
Step 8 Select Edit and Save. This will return you to the Document Resource window.
Step 9 Add Before and After text if desired the select Exit.
Step 10 From the Documentation Info window select Contents, then Content. This will bring up Word editor to input contents of the ACD.
Step 11 Input the desired content of the ACD, then Exit Word, Clicking Yes to save the contents.
Step 12 From the Document Info window select Edit, Save, and Exit.
Step 13 The newly created ACD can now be seen in the summary pane of the Document Main window.

2.6.1.2 Modify/View Document

To modify or view an ACD follow the steps below:

Step 1 From the Document Main window highlight the ACD to be modified or viewed.
Step 2 Select Options, Modify/View Document.
Step 3 Make changes as needed.
Step 4 Select Edit, Save, and Exit.

2.6.1.3 Delete Document

To delete an ACD follow the steps below:

Step 1 From the Document Main window highlight the ACD to be deleted.
Step 2 Select Options, Delete Document.
Step 3 Select Yes to confirm the deletion of the selected document.

2.6.1.4 Display Related Materials

To view and print where an ACD is used follow the steps below:

Step 1 With an ACD highlighted select Options, Display Related Materials from the Document Main window.
Step 2 The Results window show where the ACD is used, to print preview or print this information select File, and either Print Preview or Print from the Results window.

2.6.1.5 Flag Related Materials

To flag material for review during course maintenance follow the steps below:
Step 1 With the desired ACD highlighted select **Options, Flag Related Materials** from the Document Main window.
Step 2 Enter appropriate Document Maintenance Text in the text box.
Step 3 Select **Edit, Save, and Exit**.

2.6.1.6 Document Types

Document types can be added, modified or deleted by following the step below:

2.6.1.6.1 Adding Document Types

Step 1 From the Document Main window select **Options, Document Types**.
Step 2 From the Document Types window select **Options, Add ACD Type**.
Step 3 Enter the ACD type on the highlighted line and press Enter.
Step 4 Select **Edit, Save, and Exit** to save the new Document type.

2.6.1.6.2 Deleting Document Types

Step 1 From the Document Main window select **Options, Document Types**.
Step 2 With the appropriate Document Type highlighted select **Options, Delete ACD Type**.
Step 3 Click **Yes** in the pop-up box to confirm deletion of the selected Document Type.

2.6.1.6.3 Modifying Document Types

Step 1 From the Document Main window select **Options, Document Types**.
Step 2 With the appropriate Document Type highlighted select **Options, Modify ACD Type**.
Step 3 Modify the Type as desired.
Step 4 Press Enter.
Step 5 Select **Edit, Save, and Exit**.
2.7  RRL/GRAPHICS LOCATION TOOL

The RRL/Graphics Location Tool allows AIM II users to search for the usage of RRLs and Graphics in their Courses. The program can search all Courses citing a Resource or Graphic or just selected Courses. It can search the entire Course or just individual areas of the Course (e.g., just find all uses of an RRL item in TG Sheets). Test items and transparencies citing a graphic will also be located.

2.7.1 Resource/Graphic Selection Window

The main window of the Location Tool is the Selected data window. From this window you select which RRL Items and/or Graphics you want to search for, and find all Courses citing the selected data. There is no limit to the number of items you can select at one time, although keep in mind that the more items selected, the longer the search process will take.

![Figure B-11. RRL/Graphics Location Tool: Selected Data](image)

The **File** menu has one item:

- **Open Saved Search**: This option opens a Search Results File saved from the Results screen. This file will be explained later. Once this file is open, you are returned to the results screen.
The **Options** menu has the following items:

- **Add Resources**: Displays a list of all Resource categories and allows you to select/unselect items from any category to be used in the search.
- **Add Graphics**: Displays a list of all Graphics in the AIM I database and allows you to select/unselect those to be used in the search.
- **Breakdown**: For Reference and IETM resources it allows you to narrow the search criteria to specific areas of the Resource.
- **Delete**: Removes the highlighted row from the search list.
- **Delete All**: Removes all entries from the search list.
- **View RRL**: Views the current RRLs data.
- **View Graphic**: Views the current graphic.
- **Related Courses**: This generates a list of all Courses that cite the data displayed on this screen.

### 2.7.2 Resource Selection

When you select the Add Resources menu item, you are taken to the Site Resource Requirements List window.
On the left-hand side is a list of all RRL types. When you highlight a type, all items of that type are displayed on the right-hand side. When you select a resource to search, an ‘X’ is placed in the Sel column of the grid, and a ‘+’ sign is added to the left of the type name to show that items in this category have been selected.

The Options menu has the following items:

- **View RRL**: Views the current RRLs data.
- **Find**: Allows you to search for an RRL within this type. The software will search **Primary** and **Secondary Identifier** fields for the characters typed in the Find RRL field. A wildcard is not required.
- **Select**: Selects the currently highlighted row.
- **Unselect**: Unselects the currently highlighted row.
You can also select/unselect items by double-clicking them with the mouse or by using the spacebar.

Once you’ve finished selecting the items to be searched, click on **Exit** to return to the main screen. You can return to this screen later to add/delete more Resources.

### 2.7.3 Graphic Selection

When you select the **Add Graphics** menu item, you are taken to the Graphics selection window. This window lists all Graphics in the Graphics library, and allows you to select/unselect Graphics.

![Figure B-13. RRL/Graphics Location Tool: Graphic Selection](image)

The **Options** menu has the following items:

- **View Graphic**: Views the current Graphic.
- **Find Graphic**: Allows you to search for a Graphic by description. Selecting a Graphic in the find screen highlights it on this screen.
- **Select**: Selects the currently highlighted row.
- **Unselect**: Unselects the currently highlighted row.

You can also select/unselect Graphics by double-clicking them with the mouse or by using the spacebar.
Once you’ve finished selecting the Graphics to be searched, click on Exit to return to the main window.

2.7.4 Reference Breakdown

When you highlight a Reference from the Selected window and choose Breakdown from the Options menu item, the RRL Breakdown window is displayed. Entering data in this window reduces the RIA search to just those RIAAs that match the entries.

![Figure B-14. RRL Breakdown for a Reference](image)

When searching the RIAs for this RRL, only RIAs that match this data will be listed. Leaving a field blank means that no special searches will be done on that field (do not place an asterisk as a wild-card character into a field to search for all occurrences; it will only look for occurrences of an asterisk). Also, the search only compares the data against the breakdown data of the RIA. If you enter this data as part of the After text, it will not be found. If you leave all the fields blank (as is the default if you do not go to this screen), all citations of the Reference will be found.

In the above example, only RIAs that specify Volume 1, Chapter 3, and paragraph in the Build RIA fields for Volume, Chapter and Citation, will be found.

All fields with some data entered are searched for exact matches, except the “From Item” field. “From Item” searches for all occurrences that begin with the entered text (exact matches included). For example, if you set the “citation” to “paragraph” and “From Item” to “2-1”, then all RIAs with a paragraph citation that begins with “2-1” will be found, including 2-1, 2-1-a, 2-1(a), etc.
2.7.5 IETM Breakdown

When you highlight an IETM from the Selected window and choose Breakdown from the Options menu the IETM Breakdown window is displayed. The IETM Breakdown window displays the IETM tree structure and allows you to select which node(s) to search for.

Any number of node(s) can be selected. By selecting a parent node [for example, “IDR (Unit 4009)” above], all child nodes are automatically searched as well. If no nodes are selected, then all citations to the IETM are found.

Figure B-15. IETM Breakdown
2.7.6 Related Courses Selection

Once you’ve selected your Resources and Graphics, choose Related Courses from the Options menu of the Resource/Graphic Selection window. This will display the Related Courses window. This screen displays all Courses that cite the selected Resources/Graphics. You can select/unselect the Courses to search as well as where in the Courses to search. [NOTE: If none of the selected Resources or Graphics are cited in a Course, a dialog box informing you of this will appear, but the Related Courses screen will not appear.]

![Related Courses Window](image)

**Figure B-16. Related Courses**

At the top of the screen you can see the options. These are the areas where the Resources/Graphics can be used and where the Location Tool can search. Unchecking one of these areas will cause that area not to be searched.

The DP/RIA search option is a special option. Not only can you search for all RIAs that cite the selected resources, you can also determine how to display the data. The options are to display by Unit, Topic, or DP/RIA (click the down-arrow right of the text to see the options). If you select DP/RIA, then all RIAs that cite the resources will be found. But if you choose “Unit”, for example, then the report will only list the Units that contain RIAs that cite the resources.
The **Options** menu has the following items:

- **Select**: Selects the currently highlighted Course.
- **Select All**: Selects all Courses on the window.
- **Unselect**: Unselects the currently highlighted Course.
- **Unselect All**: Unselects all Courses on the window.
- **Generate Impact Report**: Searches all selected Courses for citations of the selected data.

You can also select/unselect Courses by double-clicking them with the mouse or by using the spacebar. All Courses are selected by default.

### 2.7.7 Search Results Window

Once you’ve selected the Courses and areas to search, choose **Generate Impact Report** from the **Options** menu. This will search all selected Courses and TLO/ELO for citations of the Resources and Graphics.

![Figure B-17. Search Results](image-url)
The example Search Results window shows how the results data is displayed. Each Resource/Graphic being searched for is listed as a main element. Under each item is a list of all Courses that cite it, if any. Under each Course are the areas that were searched where matches were found, and then a listing of all matches. There are, at most, four areas listed under the Course: TPP, Trainee Prep, Sheets, and DP/RIAs. “TPP” is displayed when the Resource is cited in the TPP of the Course. No data appears below “TPP”. “Trainee Prep” is displayed when the Resource is cited in the Trainee Preparation section of the Topic Page. Listed under this heading are all Topics in the Course where the Resource is cited. “Sheets” is displayed when a TG Sheet cites the Resource or Graphic. Listed under this heading are all TG Sheets citing the Resource or Graphic.

The “DP/RIAs” area works a little differently. Depending on the selection on the Related Courses screen, this area will read “Units”, “Topics”, or “DP/RIAs”. For “Units” or “Topics”, listed under the heading will be the Unit/Topic numbers that contain RIAs that cite the Resource. For “DP/RIAs”, then the Topic numbers of all Topics that contain RIAs citing the Resource will be listed. Under each topic will be a listing of each RIA citing the Resource.

Only areas where the Resource/Graphic is selected are displayed.

The File menu has the following items:

- **Save Search Results**: Saves the entire set of search data for later display.
- **Print Preview**: Displays the Search results in a printable format.
- **Print**: Prints the search results.

When you save the Search Results data, you are prompted for a file name. Once this has been entered the file is created. By using the Open Search Results menu item from the RRLs Selected window Options menu item, you can return to this window without having to generate the report again. As this stores all the search data, you can open the file, exit from the results window and change some of the search criteria (what Courses, areas, resources, etc.). You can also send this file to another user and they can open it with their copy of the RRL/Graphics Location Tool.

**NOTE**: You can open any results file, including those not run off your database. This will show the same data as was saved on the other database, allowing you to print it or look at the data. But you should not try to run different searches off of this data, since the information in the file does not match the database information.
2.7.8 Print Preview

When you run the Print Preview option from the Results window a report will be displayed for each RRL Type selected.

![Print Preview Window](image)

Figure B-18. Print Preview Results

Clicking the magnifying glass button causes the preview to switch between Full Page mode and 100% zoom. Clicking the arrow next to this button gives you the following zoom options:

- **Whole Page**: Zooms the previewed document so it fits entirely into the screen.
- **Page Width**: Changes the Zoom level so that the width of the document fills the screen. You’ll have to scroll up/down, but not left/right.
- **Two Pages**: This displays two pages of the preview at a time.
- **Thumbnail**: Displays thumbnails of all pages (well, all pages that fit in the screen; the number varies).
- **Varying Zoom Levels**: Changes the zoom to a specific percentage from 25% to 150%.
The printed output itself is similar to the Search Results display, but with one exception. If an area is searched and no data is found, the Search Results screen does not show that area. The output does, with the text “None” underneath it. This does not apply to TPP, however, since TPP lists no data under its heading. Therefore, TPP will be printed out only if the Resource is cited in the Course’s TPP.

The **Options** menu has the following items:

- **Print**... Prints the search results.
- **Save to PDF**... Prompts the user for a file name to save the output in PDF format. This does NOT require Adobe’s full Acrobat package.

The Print dialog now handles printing of the current page, range of pages, and the entire document.
2.8 Learning Site Utility

The Learning Site utility is available only to users with AIM Administrator privileges.

The Learning Site sub-menu item opens the Site window. The Site window allows an AIM Administrator to add, modify, delete and replace Learning Sites (i.e., sites at which training will be conducted.)

NOTE: A site can be modified or deleted until the training material it is cited in becomes approved.

The Site window contains the following menu items:
- Options
- Edit
- Exit
- Help

2.8.1 Site Options Menu Item

Sites are Learning Sites where a curriculum will be taught. The Site may or may not be responsible for the development or approval of the course. The Site list will be used to provide the user a drop-down menu of sites when identifying the Learning Sites in the TPP and the TCCD. If the Site is responsible for the development or approval of the course its name and address should be entered in the Agency List and AIM II will automatically add it to the Site List.

The Options menu item offers four options:
1. To add a site and its address to the current list of sites
2. To delete a site that you have highlighted. (You will not be able to delete a site that has been selected in a TPP or TCCD).
3. To modify a highlighted site's name or address.
4. To replace a site name and address with another site name and address and if desired delete the replaced site.

2.8.1.1 Add Site

To add a site:

Step 1 From the AIM II main menu; select the Utility menu item and the Learning Site sub-menu item. Or, click on the Site icon.
Step 2  
From the Site window select the **Options** menu item and the **Add Site** option.

Step 3  
AIM II will open a new line. Type the name/acronym of the site in the list.

Step 4  
Depress **Tab** to move to the Address field and click on the field. Enter the address of the site. AIM II will let you enter 50 characters, counting spaces and punctuation.

Step 5  
Select the **Edit** menu item and the **Save** option to add the site and address to the database. Or, select **Cancel** to delete your entries.

Step 6  
Select the **Exit** menu item to return to the AIM II main menu.

### 2.8.1.2 Delete Site

AIM II will allow you to delete a site, provided it is not called out in a Training Project Plan (TPP) or a Training Course Control Document (TCCD).

To delete a site:

Step 1  
From the AIM II main menu select the **Utility** menu item and the **Learning Site** sub-menu item. Or, click on the Site icon.

Step 2  
In the list of sites; highlight the site for deletion.
Step 3 From the Site window select the Options menu item and the Delete Site option.

Step 4 AIM II will ask, Delete Site XXX...? Select Yes to delete or No to return to the Site window.

Step 5 Select the Exit menu item to return to the AIM II main menu.

2.8.1.3 Modify Site

AIM II will allow you to modify a site's name or address. This may become necessary if the Site's name or address has been changed or modified.

To modify a site:

Step 1 From the AIM II main menu select the Utility menu item and the Learning Site sub-menu item. Or, click on the Site icon.

Step 2 In the list of sites; click on the site name or address for modification.

Step 3 From the Site window select the Options menu item and the Modify Site option. Perform one of the following:
   a. If the Site is used in an approved course, you will receive the prompt "Site used in approved Course. Are you sure you want to edit Site data?" Click on the Yes button. The field will open to permit editing of the name or address.
   b. If the Site is not used in approved course, selection of the Modify Site option will open the field highlighted for editing. Or, you can double click on the field you desire to modify and it will permit editing.

Step 4 Edit the text as desired.

Step 5 Select the Edit menu item and the Save sub-menu item or select the Exit menu item and save you changes to the database.

2.8.1.4 Replace Site

This option is used to replace a site identified in your database with another site identified in your database. It also provides the option to delete the site replaced if desired. For example, it may be necessary to replace a Site with another Site due to a base closure.
To replace a Site:

Step 1  From the AIM II main menu; select the **Utility** menu item and the **Learning Site** sub-menu item. Or, click on the Site icon.

Step 2  In the list of sites; click on the site name or address for replacement.

Step 3  From the Site window select the **Options** menu item and the **Replace** option.

Step 4  You will be prompted with "Are you sure you want to replace site "XXX"?"
   a. Click on **Yes** to proceed.
   b. Click on **No** to cancel.

Step 5  If you selected **Yes** you will be prompted with "Select a Site to replace it." Click on **OK** and click on the site desired.

Step 6  Select the **Options** menu item and the **Replace with** option.

Step 7  You will receive the prompt "Replace "XXX"?"
   a. Click on **Yes** to replace the site.
   b. Click on **No** to select another site.
   c. Click on **Cancel** to terminate the **Replace** option.

Step 8  If you selected **Yes** you will be prompted with "Do you want to delete "XXX" after replacement?" Select **Yes** to delete or **No** to retain the replaced site in your database.
2.9  AGENCY UTILITY

The Agency utility is available only to users with AIM Administrator privileges.

The Agency sub-menu item opens the Agency window. The Agency window contains a list of the agencies available for selection when you need to identify Developing and Approving agencies during development of training materials. From the Agency window, you can add, modify, or delete agencies. When Agencies are added to the list they are automatically added to the Site List.

The Agency window contains the following menu items:

- Options
- Edit
- Exit
- Help

2.9.1  Agency Options Menu Item

The Options menu item offers four options:
1. Add agencies to the window’s list of agencies
2. Delete an agency that has been highlighted
3. Modify an agencies name or address
4. Replace an agency with another agency in the database.

2.9.1.1  Add Agency

**NOTE:** Every agency name must be unique. AIM II will not accept two agencies with the same name or multiple addresses for an agency. For example, there are several FTCs in the Navy. To distinguish among them, you can add locations to names (e.g., FTC, San Diego). When an agency is added to the database, it is also added to the Site List. The Agency Name field is not case sensitive and the name and address field entries can contain multiple lines of text.

To add an agency:

Step 1  From the AIM II main menu select the Utility menu item and the Agency sub-menu item. Or, click on the Agency icon.

Step 2  From the Agency window select the Options menu item and the Add Agency option.
Step 3  AIM II will open a new line. Type the name/acronym of the site in the list.

Step 4  Depress Tab to move to the Address field and click on the field. Enter the address of the site. AIM II will let you enter 50 characters, counting spaces and punctuation.

Step 5  Select the Edit menu item and the Save option to add the agency to the database. Or, select Cancel to delete your entries.

Step 6  Select the Exit menu item to return to the AIM II main menu.

**NOTE:** An agency that has been selected in the development or maintenance of a training material item cannot be deleted from the Agency List.

The agency must first be deselected from the training material item or, in the case of maintenance, must no longer be cited in any approved baseline training.

**2.9.1.2  Delete Agency**

**To delete an agency:**

Step 1  From the AIM II main menu; select the Utility menu item and the Agency submenu item. Or, click on the Agency icon.

Step 2  In the list of agencies; highlight the agency for deletion.

Step 3  From the Agency window select the Options menu item and the Delete Agency option.

Step 4  AIM II will ask, Delete Agency XXX...? Select Yes to delete or No to return to the Agency window.

Step 5  Select the Exit menu item to return to the AIM II main menu.

**2.9.1.3  Modify an Agency**

An agency title or address can be modified in the database whether it is cited in approved for unapproved training materials.

**To modify an agency:**
Step 1 From the AIM II main menu; select the **Utility** menu item and the **Agency** sub-menu item. Or, click on the Agency icon.

Step 2 Click on the desired agencies title or address.

Step 3 From the Agency window; select the **Options** menu item and the **Modify Agency** option. Perform one of the following:
   a. If the Agency is used in approved training materials, you will receive the prompt "Agency used in approved training materials. Are you sure you want to edit Agency data?" Click on the **Yes** button. The field will open to permit editing of the name or address.
   b. If the Agency is not used in approved course, selection of the **Modify Agency** option will open the field highlighted for editing. Or, you can double click on the field you desire to modify and it will permit editing.

Step 4 Edit the text as desired.

Step 5 Select the **Edit** menu item and the **Save** sub-menu item or select the **Exit** menu item and save you changes to the database.

### 2.9.1.4 Replace Agency

This option is used to replace an agency identified in your database with another agency identified in your database. It also provides the option to delete the agency replaced if desired.

**To replace an Agency:**

Step 1 From the AIM II main menu; select the **Utility** menu item and the **Agency** sub-menu item. Or, click on the Agency icon.

Step 2 In the list of agencies; click on the agency name or address for replacement.

Step 3 From the Agency window; select the **Options** menu item and the **Replace** option.

Step 4 You will be prompted with "Are you sure you want to replace Agency "XXX"?
   a. Click on **Yes** to proceed.
   b. Click on **No** to cancel.

Step 5 If you selected **Yes** you will be prompted with "Select an Agency to replace it."
Click on OK and click on the agency desired.

Step 6  Select the **Options** menu item and the **Replace with** option.

Step 7  You will receive the prompt "Replace "XXX?".
   a. Click on **Yes** to replace the agency.
   b. Click on **No** to select another agency.
   c. Click on **Cancel** to terminate the **Replace** option.

Step 8  If you selected **Yes** you will be prompted with "Do you want to delete "XXX" after replacement?" Select **Yes** to delete or **No** to retain the replaced agency in your database.
2.10 ARCHIVE/UNARCHIVE UTILITY

The Archive/Unarchive utility is available only to users with AIM Administrator privileges. The Archive/Unarchive sub-menu item opens the Archive/Unarchive window. The Archive/Unarchive window allows you to archive a Course/LP/TG to a file. When a training material item is archived, it is automatically removed from the AIM II database.

2.10.1 Archive Options Menu Item

The Options menu item contains the options to Archive the highlighted training material, Unarchive training material from a file, View Archive Information in a file, or generate an Archive IMM Report. When you select an option, AIM II opens an Archive\Unarchive window that lets you identify the drive, directory, and filename in which the Archive information will be placed/from, which it will be read. Once you have identified the drive, directory, and file name AIM II performs the selected option.

2.10.1.1 Archive Training Material

When a Course/LP/TG is archived the RRL items and graphics are also included in the archive file. The RRL items are not deleted from the database when archiving. The software will ask if the graphics should be deleted.

To archive training material:

Step 1 From the AIM II main menu select the Utility menu item and the Archive/Unarchive sub-menu item.

Step 2 AIM II will present a list of courses contained in the database. Highlight the course you want to archive and select the Options menu item and Archive option.

Step 3 Select the drive, select the directory, and enter the name of the file in the File Name field.
NOTE: The file name extension defaults to ".arc" to identify the file as an archive file. This extension can be edited if desired.

Step 4 Select **OK/Save** to archive the information to a file. AIM II will present the question "Do you want to view/edit the Archive Information?". Clicking on the **No** button will produce the next prompt and will not allow you to edit the Archive Information data. Clicking on the **Yes** button opens the Archive Information window, which contains information about the contents of the file, who archived it (by login name), and the date and time. AIM II is giving you the opportunity to edit the information and add additional comments before it completes the archive file. It is recommended that you edit this information to include your full title and actual name, name of the site, and reason why the Archive file is being created. Once you save the editing corrections and exit this window the software will produce the next prompt.

Step 5 You will be prompted with the question “Do you want to archive private notes associated with this course? Click on the **Yes** or **No** button as desired.

Step 6 You will be prompted with the question “Do you want to archive the IMM files associated with this course?” Click on the **Yes** or **No** button as desired. AIM II will complete the creation of the archive file base on your responses.

NOTE: When archiving a course, which contains IMM links, a report will be displayed showing all IMMs that were archived. The report will indicate whether the IMM file was included with the export file, was not included, could not be found, or was not linked to a file.

Step 7 Select **Exit** to return to the AIM II main menu.

### 2.10.1.2 Unarchive Training Material

**To Unarchive training material:**

Step 1 From the AIM II main menu; select the **Utility** menu item and the **Archive/Unarchive** sub-menu item.

Step 2 From the Archive\Unarchive window select the **Options** menu item and the **Unarchive** option.
Step 3 Identify the drive, directory, and name of the file that contains the Archive information and select **OK/Open**. AIM II will inform you that it is unarchiving the document.

Step 4 Select the **Exit** menu item to return to the AIM main menu.

### 2.10.1.3 View Archive Information

The View Archive Information record displays the contents of the archive file and the IMM in the Course, who generated it and when. The course information includes CIN, Rev, and Change. The IMM information for the course contains IMM included in the archive file, media not included in the archive file, media that could not be found and not included in the archive file, and IMM cited in the course but not associated with any media file.

**To view archive information:**

Step 1 From the AIM II main menu; select the **Utility** menu item and the **Archive/Unarchive** sub-menu item.

Step 2 From the Archive\Unarchive window select the **Options** menu item and the **View Archive Information** option.

Step 3 Identify the drive, directory, and name of the file that contains the Archive information and select **OK/Open**.

AIM II will present you with a list that shows what is in the Archive file, who made the file, and when (date and time) the file was created.

Step 4 Select the **Exit** menu item to return to the Archive/Unarchive window.

Step 5 Select **Exit** to return to the AIM II main menu.

### 2.10.1.4 Archive IMM Report

When unarchiving a course that contains IMM the software will generate a report to indicate if there are any conflicts between the IMM identified in the course being unarchived and your AIM II database. The Archive IMM Report will produce this same report without unarchiving the course. If there is a conflict between the IMM in the database and the IMM of the archived course, and the course is unarchived, the conflicting courses are no longer editable until the
conflict is resolved.
An IMM being unarchived will be considered in conflict with an existing IMM if:

- An existing IMM has the same number/title and cite the same file, but the file has been changed (date/time is different)
- An existing IMM has the same number/title, but cites a different file name.
- An existing IMM has a different number/title, but cites the same file.
- If a conflicting IMM is found during unarchive, the following is done:
  - The Course is marked as containing a conflict, and the user is prohibited from editing the Course until the conflict is cleared. The Course in conflict is identified in red in both the Admin Module and the Course Select window.
  - The conflicting IMMs are marked as conflicting (the existing IMM is NOT marked as conflicting, only the unarchived IMM is marked as such).
  - The files of conflicting IMMs are stored in a special sub-directory in the Media directory. This directory is called "Conflicts for Course xxxxxx".

**NOTE:** You cannot use any conflicted IMMs in any other Courses until the conflict is cleared.

Deleting a Course that contains conflicted IMMs also deletes the conflicted IMMs from the database.

**To view the Archive IMM Report:**

Step 1  Select Archive/Unarchive from the Utilities drop-down menu.

Step 2  Select Options and Generate IMM Report.

A dialog box with the current directory will be displayed.

Step 3  Select the desired drive by clicking on the down arrow in the Drives box and dragging the mouse to the desired drive.

Step 4  Select the desired directory.

Step 5  Select the desired archive file.

Step 6  Click on OK/Open.

**NOTE:** The software will validate the IMM data in the archive file. If there were no conflicts found the report will contain the statement “No conflicts were found with the existing set of IMMs.”
2.11 IMPORT/EXPORT UTILITY

The AIM II Import/Export utility provides the capability to transfer training documents created and stored in the AIM II program from one AIM II location to another. The Import/Export utility also forwards all supporting documents, including graphics, to the intended destination AIM II Agency.

To exercise the Import/Export Utility, from the Utilities drop-down menu on the Utilities screen, the AIM Administrator selects Import/Export, or the Import/Export icon. The AIM Administrator highlights a course to export, then selects Options to display the drop-down menu shown in Figure B-14. The AIM Administrator then selects:

- **Import** to import a course.
- **Export** to start the export process.
- **View Export Information** to open the Export Information record, from the export file that will display the contents of the export file and the IMM export report, who generated it and when.
- **Generate Import IMM Report** for an Export file that contains IMM, which produces a report of the IMM and allows the Administrator to view a list of possible conflicting IMMs in the Export file.
- **Import CNATT ERL Data** will only appear if the database has been configured to support CNATT courses. CNATT Data consists of Course and ERL data supplied by CNATT.
- **Import CNATT Publications** will only appear if the database has been configured to support CNATT courses. This option shall be used to Import CNATT publication data from the CNATT Publication database to the Site RRL.
**2.11.1 Rules for the Import/Export of a Course**

The following rules must be followed for proper operation of the Import/Export utility:

- If the Course exported is the same Rev and Chg materials that exist at the receiving Agencies, the Import process will terminate. For example, if CIN 001, Revision A, Change 1, exists at both the sending and destination Agencies, the transfer of this document is prohibited.
- Flags and Maintenance records will be exported along with the training materials so that the reviewing/approving authority can examine the changes and take actions accordingly.

**NOTE:** If you exercise the import/export function without having any courses in your database, you will receive a message stating "No Courses to Export". Click on OK to return to the Import/Export menu items.
2.11.2 Import a Course

To Import a Course:

Step 1 Select Import/Export from the Utilities drop-down menu.

Step 2 Select **Options**, then **Import**.

A dialog box with the current directory will be displayed (as shown in *Figure B-15*).

![Import/Export v3.2 dialog box](image)

**Figure B-20. Import File Location**

Step 3 Select the desired drive by clicking on the down arrow in the Drives box and dragging the mouse to the desired drive.

**NOTE:** The current directory is displayed under Directories: (upper, middle of the screen), and the contents of the directory are displayed in the left column.

Clicking in the "List Files of Type" can change the types of files displayed field and dragging the mouse to the desired file type.

Step 4 Select the desired directory.
Step 5  Select the desired file.

Step 6  Click on OK/Open.

### 2.11.3 Export a Course

**To Export a course:**

1. From the AIM II Main menu; select Import/Export from the Utilities drop-down menu.
2. Highlight the desired course for Export.
3. Select **Options**, then **Export**.
4. Select the desired drive.
5. AIM will provide a default file name based on CIN, Rev, and Change of the Course.

**NOTE:** The file name extension defaults to ".exp" to identify the file as an export file. The file name and extension can be edited if desired.

6. Click on **OK/Save**.

7. AIM II will present the question "Do you want to view/edit the Export Information?". Clicking on the **No** button will present the next question and will not allow you to edit the Export Information data. Clicking on the **Yes** button opens the Export Information window, which contains information about the contents of the file, who exported it (by login name), and the date and time. AIM II is giving you the opportunity to edit the information and add additional comments before it completes the archive file. It is recommended that you edit this information to include your full title and actual name, name of the site, and reason why the Export file is being created. Once you exit this window, AIM II will generate the Export file, and this information cannot be modified. Select **Exit** and save the new data (if modified). AIM II will prompt you with the next question.

8. You will be prompted with the question “Do you want to export private notes associated with this course? Click on the **Yes** or **No** button as desired.
Step 9 You will be prompted with the question “Do you want to export the IMM files associated with this course?” Click on the Yes or No button as desired. AIM II will complete the creation of the export file base on your responses.

NOTE: When exporting a course, which contains IMM links, a report will be displayed showing all IMMs that were exported. The report will indicate whether the IMM file was included with the export file, was not included, could not be found, or was not linked to a file.

2.11.4 View Export Information

The View Export Information record displays the contents of the export file and the IMM in the Course, who generated it and when. The course information includes CIN, Rev, and Change. The IMM information for the course contains IMM included in the export file, media not included in the export file, media that could not be found and not included in the export file, and IMM cited in the course but not associated with any media file.

To view the export information for an export file:

Step 1 Select Import/Export from the Utilities drop-down menu.

Step 2 Select Options, then View Export Information.

A dialog box with the current directory will be displayed.

Step 3 Select the desired drive by clicking on the down arrow in the Drives box and dragging the mouse to the desired drive.

Step 4 Select the desired directory.

Step 5 Select the desired file.

Step 6 Click on OK/Open.

2.11.5 Generate Import IMM Report

When importing a course that contains IMM the software will generate a report to indicate if there are any conflicts between the IMM identified in the course being Imported and the database. The Generate Import IMM Report option will produce this same report without importing the course. If there is a conflict between the IMM selected and the IMM of the imported course, and the course is imported, the conflicting courses are no longer editable until
the conflict is resolved.
An IMM being imported will be considered in conflict with an existing IMM if:

✓ An existing IMM has the same number/title and cite the same file, but the file has been changed (date/time is different)
✓ An existing IMM has the same number/title, but cites a different file name.
✓ An existing IMM has a different number/title, but cites the same file.

If a conflicting IMM is found during import, the following is done:

✓ The Course is marked as containing a conflict, and the user is prohibited from editing the Course until the conflict is cleared. The Course in conflict is identified in red in both the Admin Module and the Course Select window.
✓ The conflicting IMMs are marked as conflicting (the existing IMM is NOT marked as conflicting, only the importing IMM is marked as such).
✓ The files of conflicting IMMs are stored in a special sub-directory in the Media directory. This directory is called "Conflicts for Course xxxxxx".

**NOTE:** You cannot use any conflicted IMMs in any other Courses until the conflict is cleared.

Deleting a Course that contains conflicted IMMs also deletes the conflicted IMMs from the database.

**To view the IMM Import Report:**

Step 1 Select Import/Export from the Utilities drop-down menu.

Step 2 Select **Options**, then **Generate Import IMM Report**.

A dialog box with the current directory will be displayed.

Step 3 Select the desired drive by clicking on the down arrow in the Drives box and dragging the mouse to the desired drive.

Step 4 Select the desired directory.

Step 5 Select the desired file.

Step 6 Click on **OK/Open**.

**NOTE:** The software will validate the IMM data in the export file. If there were no conflicts found the report will contain the statement "No conflicts were found with the existing set of IMMs."
2.11.6 Import CNATT ERL Data

To import CNATT ERL data, a TPP for the course must already exist. This option can also be accomplished from either the TPP Options menu item or the TCCD Options menu item.

The differences between importing Course and ERL data into a TPP/TCCD and from the Import/Export Utility are:

In Import/Export
- You can import the Course and ERL data into any Course, as long as it is not approved.
- You do not have to select the Course you want to import the data into because the import function will determine that information from the text file.
- If the TPP for the Course the data belongs to is INCOMPLETE, then the data will be imported into the TPP. Otherwise it will be imported into the TCCD.

In TPP/TCCD
- You can only import the data if you have privilege on the TPP/TCCD you are editing.
- When importing the data, it verifies it is for your current Course. You won’t accidentally import the data for another Course.
- You can import data into the TPP, even if you’ve already locked it. You cannot do this from the Import/Export Utility because it will default the data to the TCCD.

To Import CNATT ERL Data:

Step 1 From the AIM II Main menu; select Import/Export from the Utilities drop-down menu.

Step 2 Select Options, then Import CNATT ERL Data.

Step 3 From the Select file to Import window, identify the drive, directory, and CNATT ERL text file to import and click on the Open button.

NOTE: The current directory is displayed under Directories: (upper, middle of the window), and the contents of the directory are displayed in the left column.

The types of files displayed can be changed by clicking in the "List Files of Type" field and dragging the mouse to the desired file type.

NOTE: If the CIN of the TPP and the CIN of the CNATT Export File do not match you will prompted of the difference and asked whether to update the Title. If the answer is Yes it will update the CIN Rev and Title fields as applicable.
Step 4  At the prompt “ERL for TPP X-YYY-YYYY will be updated. Do you want to continue?” click on the **Yes** button.

Step 5  At the prompt “CNATT data merged with AIM Site RRL successfully. XXX records imported.” click on the **OK** button.

### 2.11.7 Import CNATT Publications

**To Import CNATT Publications to the Site RRL:**

**Step 1**  From the AIM II Main menu; select Import/Export from the Utilities drop-down menu.

**Step 2**  Select **Options**, then **Import CNATT Publications**.

From the Select file to Import window, identify the drive, directory, and CNATT Publication text file to import and click on the Open button.

**NOTE:** The current directory is displayed under Directories: (upper, middle of the window), and the contents of the directory are displayed in the left column.

The types of files displayed can be changed by clicking in the "List Files of Type" field and dragging the mouse to the desired file type.

**Step 3**  At the prompt “CNATT data merged with AIM Site RRL successfully. XXX records imported.” click on the **OK** button.
2.12 USER UTILITY

The User utility is available only to users with AIM Administrator privileges.

The User sub-menu item calls the User Administration window. Through the User Administration window, you can add or delete a user from AIM II, modify a user’s login, or change a user’s privilege level from AIM User to AIM Administrator or vice versa.

If a User is only going to be creating and editing material using the Learning Object Module, the AIM Administrator can uncheck the Show Courses block for the User. This will change the AIM main menu and only the applicable menu items and icons for the Learning Object Module will appear.

The User Administration window contains the following main menu items:

- Options
- Edit
- Exit
- Help

2.12.1 User Administration Options Menu Item

The Options menu item contains the options to add a user, modify/view user information, delete the highlighted user from the list, and clear a user's password.

2.12.1.1 Add a User

Spaces are permitted in the user login name. The default password for a new user is Enter (hard return).

To add a user:

To add a user:

Step 1 From the AIM II main menu, select the Utilities menu item and select the User sub-menu item. AIM II will present the User Administration window.

Step 2 Select the Options menu item and the Add User option. AIM II will open the User Information window.
NOTE: AIM User is the default privilege level.

Step 3 Type the user’s login name in the User Name field.

Step 4 If AIM Administrator privilege is required for the user you are adding, press Tab to highlight Privilege Level field and click on the arrow button. AIM II will present a list of privileges for selection.

Step 5 Click on the desired privilege. The list will disappear, and your selection will appear in the Privilege Level field.

Step 6 If the User will only be using the Learning Object Module uncheck the Show Courses block. The AIM main menu will be limited to only those icons and menu items that are applicable to the Utility.

Step 7 The following fields are optional for the User Information window and can be added now or later using the Modify/View User option.
  • First Name
  • Last Name
  • Email Address
  • Phone Number
  • DSN
  • Address

Step 8 Select the Edit menu item and the Save sub-menu item to save your entries. Select the Cancel option to remove your entries.

   If you select the Cancel option, AIM II will prompt, All changes will be lost. Are you sure you want to cancel?
   Select Yes if you want to cancel and exit to the User Administration window.
   Select No to return to the User Information window.

2.12.1.2 Delete a User

NOTE: Do not use this option if a User has forgotten his/her password. If used for that purpose the software will regard the User as a new entity and the User will not be able to access training materials that the User had privileges for previously. Refer to paragraph 2.8.1.3, Clear User Password.
To delete a user:

Step 1 From the AIM II main menu, select the **Utilities** menu item and select the **User** sub-menu item. AIM II will open the User Administration window.

Step 2 Highlight the name of the user you want to delete. Select the **Options** menu item and the **Delete User** option.

Step 3 AIM II will ask, *Delete User XXXX?* Select **Yes** to delete the user or **No** to return to the User Administration window.

Step 4 If further editing is required for the list of users, select:
- The **Edit** menu item and the **Save** option to save your entries.
- The **Cancel** option to remove your entries. If the **Cancel** option is selected, AIM II will prompt, *All changes will be lost. Are you sure you want to cancel?* Select **Yes** if you want to cancel and exit to the AIM II main menu. Select **No** to return to the User Administration window.

Step 5 If no further editing is required, for the list of users select the **Exit** menu item. At the prompt, *Would you like to save the changes?*, select:
- **Yes** to save the changes to the list and exit to the AIM II main menu
- **No** to delete the changes made and exit to the AIM II main menu
- **Cancel** to return to the User Administration window.

### 2.12.1.3 AIM II Default Roles

The following roles are default roles with specific Privilege Levels: AIM User, AIM Administrator, AIM Viewer, Contractor, Curriculum Manager FTS, Curriculum Manager HQ.

- AIM User can view all the training materials, less test item and tests, and can be assigned privileges to perform specific functions on training material by the AIM Administrator. An AIM User can create training material and has the following default privileges for materials created under their login and password unless modified by an AIM Administrator:
  - View (Testing Module Only)
  - Edit
  - Lock
  - Grant
  - Clear In Use
  - Maintain/Delete
• A person with AIM Administrator privileges has access to all training materials and Utility functions of AIM II. The AIM Administrator can also assign one or more of the privilege levels shown in the table below to an AIM User for specific training materials via the AIM II Administration utility. Having any one privilege does not allow the AIM User to perform any other privilege.

• A person with AIM Viewer can view all courses for all Developing Authorities. They do not have administrative or editing privileges.

• Contractor, the Contractor Role initially has no privileges assigned to it. The Contractor Role is assigned to Contractors then privileges are assigned based on the needs of the Contractor. Contractor Roles have no privileges until specifically assigned.

• Curriculum Manager FTS has the following privileges: Edit privilege for all courses assigned to their Agency as CCMM. Administrative privileges to assign roles locally for their Learning Sites and AIM Users only. View only for all curriculum at other Learning Sites. Administrative privileges for course approval, revisions/changes, grant privilege for their Learning Site only.

• Curriculum Manager HQ has the following privileges: Assigned to all Learning Sites. Edit all courses for all Learning Sites. No administrative privileges, edit only.

If the default Roles do not meet the user requirements new roles can be created from the Privilege Level option by following these steps:

1. Select Utilities from the Main menu.
2. Select User from the Utilities drop-down menu.
3. Select Options from the User Administration screen.
4. Select Privilege Levels from the Options drop down menu.
5. Select Options from the Privilege Levels screen.
6. Select Add Role from the Options drop-down menu.
7. Enter a Role Title and select desired Privilege Levels.
8. Click Edit and Save.

NOTE
Only Privileges equal to those of the current user can be assigned to a new role.
All Privilege Levels and their associated functions are listed in the following table.
# Privilege Levels

<table>
<thead>
<tr>
<th>Privilege</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Allowed to view a course</td>
</tr>
<tr>
<td>View Testing Data</td>
<td>Allowed to view Tests and Test Items</td>
</tr>
<tr>
<td></td>
<td>Should apply only to PPP (AIM I) and the Course</td>
</tr>
<tr>
<td>Create</td>
<td>Allowed to Create new courses</td>
</tr>
<tr>
<td>Edit</td>
<td>Allowed to Edit contents of the TPP/TCCD/LP</td>
</tr>
<tr>
<td>Lock/Unlock</td>
<td>Allowed to Lock or Unlock TPP, TCCD</td>
</tr>
<tr>
<td>CMS Editor</td>
<td>Allowed to Edit the Course Master Schedule</td>
</tr>
<tr>
<td>Approve</td>
<td>Allowed to Approve course elements; TPP, TCCD, RRLs</td>
</tr>
<tr>
<td>Maintain</td>
<td>Allowed to create Revisions and Changes</td>
</tr>
<tr>
<td>Review/Edit</td>
<td>Is allowed to Edit a Course that is Locked for Review.</td>
</tr>
<tr>
<td>Delete</td>
<td>Allowed to Delete unapproved PPP/TPS/Courses</td>
</tr>
<tr>
<td>Import</td>
<td>Allowed to Import PPP/TPS/Course into the database</td>
</tr>
<tr>
<td>Export</td>
<td>Allowed to Export PPPs/TPSs/Courses from the database</td>
</tr>
<tr>
<td>Grant Privilege</td>
<td>Allowed to Grant Privileges to another user (can only grant privileges they themselves have)</td>
</tr>
<tr>
<td>Clear In Use</td>
<td>Clear In Use flag</td>
</tr>
<tr>
<td>Remove Flag</td>
<td>Allowed to Clear maintenance flags (requires Edit privilege on the item)</td>
</tr>
<tr>
<td>Manager</td>
<td>Manager is a level which grants the user a sub-set of the above privileges (Edit, Lock, Approve, Grant, Remove Flag, Reset In use, Maintain, CMS, Delete). Can set up Developing Authorities and unlock for review, replace RRLs, delete Approved Courses (at least in AIM II) etc.</td>
</tr>
<tr>
<td>Edit Users</td>
<td>Allowed to Edit other User information</td>
</tr>
<tr>
<td>Edit Agencies</td>
<td>Allowed to Edit Agency information</td>
</tr>
<tr>
<td>Edit Learning Sites</td>
<td>Allowed to Edit Learning Site information</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>View All Course</td>
<td>Allowed to see all courses in database. If you do not have this privilege, you can only see those Courses that belong to your developing authority/agency, or, if you do not have overall View privilege (e.g. a contractor), only those courses you have privilege on.</td>
</tr>
<tr>
<td>Applies to all Agencies</td>
<td>Determines whether this role gives the user the privilege over ALL agencies, or just selected agencies. If this is turned on, when creating a user it will say “All Authorities” where the agency drop-down would be. If this is off, then you’d have to pick one or more agencies the user applies to.</td>
</tr>
<tr>
<td>Allow Multiple Agency Selection</td>
<td>Only available if the previous setting is turned OFF. Determines whether a user with this role can be assigned to just one center, or to multiple centers.</td>
</tr>
</tbody>
</table>

### 2.12.1.4 Clear User Password Option

The Clear User Password Option was created for the AIM Administrator to clear a password for a user who has forgotten his/her password and cannot gain access to the AIM II database. Once the password is cleared the user can gain access to AIM II without a password and can use the Change Password Utility to enter another password. AIM II will permit the user to access all training materials with the same level of privilege permitted under the previous password.

**To clear a user's password:**

1. **Step 1**  From the AIM II main menu, select the **Utilities** menu item and select the **User** sub-menu item. AIM II will open the User Administration window.

2. **Step 2**  Highlight the name of the user for which the password will be cleared.

3. **Step 3**  Select the **Options** menu item and the **Clear User Password** option.

4. **Step 4**  AIM II will ask, *Are you sure you want to clear this user's password?* Select **Yes** to clear the user's password or **No** to return to the User Administration window.

5. **Step 5**  If further editing is required for the list of users, select:
• The **Edit** menu item and the **Save** option to save your entries.
• The **Cancel** option to remove your entries. If the **Cancel** option is selected, AIM II will prompt, *All changes will be lost. Are you sure you want to cancel?* Select **Yes** if you want to cancel and exit to the AIM II main menu. Select **No** to return to the User Administration window.

Step 6 If no further editing is required, for the list of users select the **Exit** menu item. At the prompt, *Would you like to save the changes?*, select:
  - **Yes** to save the changes to the list and exit to the AIM II main menu
  - **No** to delete the changes made and exit to the AIM II main menu
  - **Cancel** to return to the User Administration window.

### 2.12.1.5 Edit a User’s Information

**To edit a user's information:**

Step 1 From the AIM II main menu, select the **Utilities** menu item and select the **User** sub-menu item. AIM II will present the User Administration window.

Step 2 Highlight the user whom you want to edit.

Step 3 Select the **Options** menu item and the **Modify/View User** option.

Step 4 Edit the desired fields in the User Information window as necessary.

Step 5 When completed with the editing select the **Edit** menu item and the **Save** sub-menu item to save the information to the database.

Step 6 Select the **Exit** menu item to return to the User Administration window.
2.13 DATA MANAGER UTILITY

The Data Manager provides a means of viewing and editing the contents of the AIM II relational database. Anyone with AIM Administrator level of privilege can view the contents of each field of the database. Editing the contents of the database requires an additional password. This password is available only from the System Support Office (SSO).

Selecting the **Utilities** menu item and the **Data Manager** utility results in the display of Figure B-21.
Select the **Edit** menu item and the screen below appears (**Figure B-22**). An additional password is required to edit the database. For additional assistance, contact the AIM SSO.

If you click on **Yes**, you will be prompted for the password. An example of this window appears in **Figure B-23**.
NOTE: Ensure the cursor is positioned on the field that you desire to enter.

![Figure B-23. Edit Data Manager Support Password](image)

NOTE: Modifying the database table data can be very dangerous and the password will only be given out if the AIM SSO determines it is necessary.

When the password is provided by the AIM SSO you will type it into the **Support Passcode** field, as displayed above, then click on **OK** or press <Enter>.

Enter the desired text in the “New Data” field. Click on the **Exit** menu item, save your changes, and leave the Data Manager.
APPENDIX C

TROUBLE REPORT AND AIM CHANGE REQUEST

1.0  TROUBLE REPORT AND AIM CHANGE REQUEST ................................................C-1
1.1  USERS.................................................................................................................C-1
1.2  MAINTENANCE ACTION ................................................................................C-1
1.3  TROUBLE REPORTS........................................................................................C-1
  1.3.1  Trouble Report Form Instructions ............................................................C-1
1.4  AIM CHANGE REQUEST ...............................................................................C-2
  1.4.1  AIM Change Request Form Instructions ....................................................C-2
1.5  SENDING THE DATABASE TO NAWCTSD .....................................................C-4

TROUBLE REPORT (TR) FORM......................................................................................C-5
AIM CHANGE REQUEST (ACR) FORM............................................................................C-6
(This Page Intentionally Left Blank)
1.0 TROUBLE REPORT AND AIM CHANGE REQUEST

All problems with AIM II are to be reported on a Trouble Report (TR). The TR may be mailed or sent electronically to the SSO. Communication concerning TRs should be directed to the AIM SSO Customer Service Representative by telephone at DSN 960-8620 or commercial (407) 381-8620, fax DSN 960-4519 or commercial (407) 380-4519, or e-mail to orletehelpdesk@navy.mil. The SSO will respond directly to the point of contact identified on the TR. If the TR cannot be resolved, a change to AIM II may be required. Once a TR has been identified as a potential requirement for a change, the SSO will request the activity to complete an AIM Change Request (ACR).

1.1 USERS

User responsibility includes reporting all problems involving AIM II to the SSO.

1.2 MAINTENANCE ACTION

A request for maintenance of equipment supported by a maintenance contract will go directly to the maintenance contractor. The user will inform the SSO of the TR after contracting the appropriate contractor.

1.3 TROUBLE REPORTS

TRs provide a forum for reporting problems not for requesting changes to AIM II. If a problem is identified as one that requires a change, the SSO will notify the user and request that they submit an ACR. The ACR procedure is outlined in the AIM Life-Cycle Support Configuration Management Plan (ALCSMP). AIM SSO Form 93-0002A 11/91 is the AIM Trouble Report Form. A copy of the form appears at the end of this appendix.

1.3.1 Trouble Report Form Instructions

- **Submitter’s Name, Code & Position**
  
  Provide the name, code, and position of the person submitting the TR.

- **Phone Numbers**
  
  Provide commercial, DSN, fax, and E-mail numbers if available.

- **Submitter’s Activity and Address**
  
  Provide the activity and address of the person submitting the TR.
• **Narrative of Problem**  
  Provide as complete a narrative as possible. Provide as much information as you can about the problem. Use additional pages as required.

• **Hardware Item**  
  Provide the name of the hardware item affected.

• **Manufacturer**  
  Provide the name of the manufacturer of each hardware item affected.

• **Model**  
  Provide the model of each hardware item affected.

• **Software Name**  
  Provide the software name affected. Examples: AIM I, AIM II, Novell . . .

• **Version**  
  Provide the version of the affected software.

### 1.4 AIM CHANGE REQUEST

An ACR will only be submitted after the SSO has identified that the TR cannot be resolved and notified the user that an ACR should be submitted. Upon receipt of an ACR, the SSO will log it into the database. The SSO will complete Block 3 and return as copy of the form with receipt acknowledgment within 5 working days of receipt. The engineer assigned will then complete the remainder of the form. An AIM Change Request Form appears at the end of this appendix.

### 1.4.1 AIM Change Request Form Instructions

See Table C-1.
<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Requesting activity</td>
<td>Self-explanatory.</td>
</tr>
<tr>
<td>2</td>
<td>Requestor's control no.</td>
<td>The requestor will include a requestor control number to allow tracking of the change and correlation with NAVAIR Orlando assigned task number. The number will include the requestor's Unit Identification Code (UIC), the device number, the fiscal year, and a request sequence number. Example: 61339-AIM-93-003.</td>
</tr>
<tr>
<td>3</td>
<td>Number assigned by NAVAIR Orlando</td>
<td>Assigned by NAVAIR Orlando upon receipt of a request.</td>
</tr>
<tr>
<td>4</td>
<td>Requested by</td>
<td>Self-explanatory.</td>
</tr>
<tr>
<td>5</td>
<td>Date</td>
<td>Date form is prepared.</td>
</tr>
<tr>
<td>6</td>
<td>DSN number</td>
<td>Phone number of person named in Block 4. If a commercial number is used, strike out DSN and include the area code.</td>
</tr>
<tr>
<td>7</td>
<td>Title Change</td>
<td>Title of change should convey to the reader the intent of the change being recommended.</td>
</tr>
<tr>
<td>8</td>
<td>Type Change</td>
<td>If the change is intended as a simple hardware, computer or document software change, check the appropriate boxes. If there uncertainty exists, check Others; and describe. More than one block may be checked.</td>
</tr>
<tr>
<td>9</td>
<td>Type Hardware System Affected</td>
<td>Include what type of file server is used.</td>
</tr>
<tr>
<td>10</td>
<td>Hardware Sub-System Affected</td>
<td>Self-explanatory.</td>
</tr>
<tr>
<td>11</td>
<td>Software Module Affected</td>
<td>Give software identification for the change being recommended.</td>
</tr>
<tr>
<td>12</td>
<td>Reference</td>
<td>Provide appropriate reference for hardware or software changes; document number, page number, and paragraph number for documentation changes.</td>
</tr>
<tr>
<td>13</td>
<td>Need for Change</td>
<td>Describe fully the reason for the change; identify if the change is needed for a specific curriculum development requirement, or improvement due to a curriculum format change, modification, or other deficiency (use additional sheets as necessary).</td>
</tr>
<tr>
<td>14</td>
<td>Recommendations</td>
<td>Recommendations of the requestor, including additional clarifying information to aid in expediting the processing of the change request.</td>
</tr>
</tbody>
</table>
15  Impact of Non-implementation
    Give a statement as to the effects on utilization of AIMII if this change request is disapproved or not implemented.

16  Are additional Sheets attached?
    Indicate if additional attachments, sketches, etc. are attached.

17  NAVAIR Orlando SSO Contact
    Checks appropriate answer and/or provide appropriate information.

18  Relative Priority of Change
    Indicate priority of change:
    1  =  Critical items, no workaround
    2  =  Important items, no workaround
    3  =  Important items, workaround possible
    4  =  Other w/ explanation or referral

1.5  SENDING THE DATABASE TO NAVAIR Orlando

The database is encrypted and can be compressed (zipped) for transmission through the Internet. Databases under 4MB can be e-mailed to the SSO’s e-mail address (orletehelpdesk@navy.mil). Large databases can be transferred to and from a server at NAVAIR Orlando by using the industry standard File Transfer Protocol (FTP) software. Please call the SSO for instructions.
## TROUBLE REPORT (TR) FORM

### AIM SSO TROUBLE REPORT

<table>
<thead>
<tr>
<th>Submitter’s Name, Code &amp; Position:</th>
<th>Phone Numbers:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>COMM:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>DSN:</td>
<td></td>
</tr>
<tr>
<td>FAX:</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Submitter’s Activity and Address:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Narrative of Problem (use additional pages as required):</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Hardware Item</th>
<th>Manufacturer</th>
<th>Model</th>
<th>Software Name</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

AIM SSO FORM 93-0002a  2/97
### AUTHORIZING INSTRUCTIONAL MATERIALS (AIM) CHANGE REQUEST (ACR)

<table>
<thead>
<tr>
<th>1. Requesting Activity: (Name/Address)</th>
<th>2. Requestor Control No.:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>3. NAVAIR Orlando Control No.:</td>
</tr>
<tr>
<td>4. Requested By: (Signature, title, and code)</td>
<td>5. Date:</td>
</tr>
<tr>
<td></td>
<td>6. DSN Phone:</td>
</tr>
</tbody>
</table>

7. Title of Change: (not to exceed 70 characters)

8. Type Change: (More than one may be checked)
   - [ ] Hardware
   - [ ] Software
   - [ ] Documentation
   - [ ] Other

9. Type Hardware System Affected:
10. Hardware Subsystem Affected:
    (e.g., Printer, File Server, Other)

11. Software Module Affected:
12. References: (Document, Page, Para No.)

13. Describe the reason for the change: (Use continuation sheet, if needed)

14. Recommendations: (Provide additional information and/or data to expedite processing of the change request)

15. Impact of Non-implementation: (Provide statement of effect if this change is not implemented)

16. Are Additional Sheets Attached? (Circle one) Yes/No

17. Has SSO Been Contacted? (Circle one) Yes/No
   If Yes, SSO Name Contacted ___________________________ Date Contacted:___________

18. Priority of Change: _____
   - 1 = Critical Item; no work-around.
   - 2 = Important Item; no work-around.
   - 3 = Important Item; work-around possible.
   - 4 = Other; with explanation or referral.
**NAVAIR Orlando USE ONLY**

<table>
<thead>
<tr>
<th>ENGINEER ASSIGNED: ___________________</th>
<th>DSN PHONE: _______</th>
<th>DATE: ____</th>
</tr>
</thead>
</table>

Comment:

**SOFTWARE REVIEW TEAM DATE: _____________**

<table>
<thead>
<tr>
<th>____ Approval Received</th>
<th>____ Disapproval Received</th>
</tr>
</thead>
</table>

Comment:

**CONFIGURATION REVIEW BOARD DATE: _____________**

<table>
<thead>
<tr>
<th>____ Approval Recommended</th>
<th>____ Disapproval Recommended</th>
</tr>
</thead>
</table>

Comment:

**CONFIGURATION CONTROL BOARD DATE: _____________**

<table>
<thead>
<tr>
<th>____ Approval Recommended</th>
<th>____ Disapproval Recommended</th>
</tr>
</thead>
</table>

Comment:
# APPENDIX D

## DEVELOPING IETM EXTRACTION FILES

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>Introduction</td>
<td>D-1</td>
</tr>
<tr>
<td>2.0</td>
<td>SGML-based IETM</td>
<td>D-1</td>
</tr>
<tr>
<td>2.1</td>
<td>Introduction</td>
<td>D-1</td>
</tr>
<tr>
<td>2.2</td>
<td>Installing the SGML-based IETM Extraction Program</td>
<td>D-2</td>
</tr>
<tr>
<td>2.3</td>
<td>Running the SGML-based IETM Extraction Program</td>
<td>D-2</td>
</tr>
<tr>
<td>2.3.1</td>
<td>Trouble Report Form Instructions</td>
<td>D-10</td>
</tr>
<tr>
<td>2.3.1.1</td>
<td>Example of Determining the Contents of the Registration File using the GD SWS IETM</td>
<td>D-16</td>
</tr>
<tr>
<td>2.3.2</td>
<td>Description of the Library File</td>
<td>D-26</td>
</tr>
<tr>
<td>2.3.3</td>
<td>Description of DDE Information File</td>
<td>D-29</td>
</tr>
<tr>
<td>3.0</td>
<td>Other IETMs</td>
<td>D-31</td>
</tr>
<tr>
<td>3.1</td>
<td>Introduction</td>
<td>D-31</td>
</tr>
<tr>
<td>3.2</td>
<td>ARCI IETM</td>
<td>D-31</td>
</tr>
<tr>
<td>3.2.1</td>
<td>Introduction</td>
<td>D-31</td>
</tr>
<tr>
<td>3.2.2</td>
<td>Installing the ARCI IETM Extraction Program</td>
<td>D-31</td>
</tr>
<tr>
<td>3.2.3</td>
<td>Running the ARCI IETM Extraction Program</td>
<td>D-32</td>
</tr>
<tr>
<td>3.3</td>
<td>PDF Documents</td>
<td>D-34</td>
</tr>
<tr>
<td>3.3.1</td>
<td>Introduction</td>
<td>D-34</td>
</tr>
<tr>
<td>3.3.2</td>
<td>Installing the PDF Extraction Routine</td>
<td>D-35</td>
</tr>
<tr>
<td>3.3.3</td>
<td>Running the PDF Extraction Routine</td>
<td>D-35</td>
</tr>
<tr>
<td>3.4</td>
<td>PMS Documents</td>
<td>D-37</td>
</tr>
<tr>
<td>3.4.1</td>
<td>Introduction</td>
<td>D-37</td>
</tr>
<tr>
<td>3.4.2</td>
<td>Installing the PMS Documents Extraction Routine</td>
<td>D-37</td>
</tr>
<tr>
<td>3.4.3</td>
<td>Running the PMS Documents Extraction Routine</td>
<td>D-37</td>
</tr>
<tr>
<td>3.5</td>
<td>Raster Technical Manuals</td>
<td>D-39</td>
</tr>
<tr>
<td>3.5.1</td>
<td>Introduction</td>
<td>D-39</td>
</tr>
<tr>
<td>3.5.2</td>
<td>Installing the Raster Technical Manual Extraction Routine</td>
<td>D-40</td>
</tr>
<tr>
<td>3.5.3</td>
<td>Running the Raster Technical Manual Extraction Routine</td>
<td>D-40</td>
</tr>
<tr>
<td>3.6</td>
<td>XML-Based IETMs</td>
<td>D-42</td>
</tr>
<tr>
<td>3.6.1</td>
<td>Introduction</td>
<td>D-42</td>
</tr>
<tr>
<td>3.6.2</td>
<td>Installing the XML-Based IETM Extraction Routine</td>
<td>D-42</td>
</tr>
<tr>
<td>3.6.3</td>
<td>Running the XML-Based IETM Extraction Routine</td>
<td>D-43</td>
</tr>
</tbody>
</table>
1.0 INTRODUCTION

The AIM/IETM interface has been developed to accommodate IETMs based on various structures. For example, the IETMs may be based on SGML data, a relational database or other proprietary structures. In any case, the extraction programs analyze the IETM structural information and write out pertinent nodes information to a text file; the resulting text file is then used to import the structural information into the AIM database. This structural information essentially mimics the table of contents used within the IETM.

The AIM/IETM interface concept has been developed for several types of IETMs:

1. SGML-based structure. Example: UAS-based (ex. SWS), Dynatext-based, AIMSS (relational database IETM with SGML export capability)
2. Database structure. Example: ARCI, PMS
3. Other structures. Example: Raster Technical Manuals, PDF

2.0 SGML-based IETM

2.1 Introduction

The IETMSGML.EXE program extracts hierarchical information from a Standard Graphic Markup Language (SGML)-based IETM (either authored with SGML or able to provide an SGML file rendition of the database) and formats the information for import into the AIM database. The extraction program is written in Visual Basic 5.0 and requires a 32-bit operating system for execution. The program utilizes the Omnimag runtime environment for parsing of the SGML file. The extraction program requires that the following files be available: 1) the SGML IETM file, 2) the DTD and all declared entity files, 3) the DTD/IETM “registration” file, and 4) the library file, which lists all DTDs and entity files referenced by the SGML file.

The extraction program traverses the hierarchical nature of the SGML IETM and writes out each pertinent node’s information to a flat file; the resulting flat file is then used to import the hierarchy information into the AIM database. This hierarchy essentially mimics the table of contents used in the IETM.

The extraction program utilizes functions to parse the SGML file, based on the specified DTD. The extraction process is halted if the SGML file cannot be successfully parsed. (This parsing process uses the library file, which identifies the DTD and all entity files.) If parsing is successful, a hierarchical tree of all elements found in the SGML file is created. The extraction process then traverses this hierarchical tree and extracts the pertinent information to be imported into AIM. Because of the interactive nature of the IETM, not all elements in the SGML file will be included in the AIM hierarchy. Elements that are included in the IETM solely for the interactive nature of the IETM are ignored by the extraction program and are, therefore, not included in the “flat file”.

Release 5.6
As each element is analyzed during the extraction process, it is determined if the element has an ID. Typically, an element is included in the AIM hierarchy if the element has an ID and it is not solely involved in the interactive nature of the IETM. If an element has an ID, then the AIM program can automatically position to the node in the IETM, utilizing DDE technology. However, in some cases, the element is only a “container” for other elements in the SGML file and must be traversed and/or included even if there is no ID. An element with no ID is traversed if it is a container with sub-elements that should be included in the AIM hierarchy.

An element with no ID is included in the AIM hierarchy if it is a “placeholder” in the IETM table of contents. However, the corresponding node information in the flat file indicates that there is no ID present and no DDE messaging will be completed for the node.

The program utilizes a “registration file” (ex. *.inf) that describes the IETM and those elements that will be included in the AIM hierarchy. This “registration” file describes the elements that are included in the hierarchy, the elements that should be included even if no ID, the elements that should be traversed, etc. This registration file is critical to the successful extraction of the IETM’s hierarchical content, which will be imported into the AIM database. The DTD and SGML files should be examined carefully when setting up the “registration” file. The “registration” file should be able to be set up for a particular DTD and utilized for any SGML IETMs that make use of that specific DTD. (The “registration” file is discussed in complete detail later in the document.)

**SGML files and DTDs used in the Extraction Program**

The SGML files used in the extraction program must have a DOCTYPE declarations included as the first line of the SGML file. If it is not included in the IETM file, the user will be prompted to enter a DOCTYPE declaration for the file. This will be appended to a temporary file used by the extraction program, which will exist only while the extraction program is being run.

The library file used in the extraction program must be set up prior to attempting to run the extraction program. Complete details on setting up the library file are included later in this document.

### 2.2 Installing the SGML-based IETM Extraction Program

The extraction software is built on the Omnimark runtime product. All necessary files are installed in the AIM directory when the AIM program is installed.

### 2.3 Running the SGML-based IETM Extraction Program

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “SGML” option, and click on the Next button. This screen is shown below.
The “IETM Extraction Utility / Extraction Output” screen will be displayed, which prompts the user to name the resulting output file created by the extraction program.

After the user types in a name and hits the Next button, the first screen for the SGML-based Extraction program will appear.
The information required for the extraction is located in several individual files. These files are loaded by clicking on the Browse buttons beside the corresponding text boxes. All files (except the SGML file) necessary for running the extraction program are based on the DTD used in the SGML file and the viewer used to browse the IETM. Representative files can be obtained by contacting the ETE Help Desk. (Please note that these files, particularly the registration file, may need to be tweaked to meet exactly how the IETM SGML file was written based on the DTD.)

Load each of the files indicated on this screen as follows: (Each of these files is explained in more detail later in the document.)

**IETM SGML file**: Browse to find the file. This file is typically located on the CD associated with the IETM. The file typically (but not always) has a “.sgm” extension. For example, the GD SWS file is called “ietm.269”, while an SSBN226 IETM is called “t09oe.sgm”. This file is a required file for extraction.
(Remember that a DOCTYPE declaration must be included in the SGML file. Some IETM developers do not include this declaration at the beginning of the SGML file because of the various authoring/parsing systems being used. If it is not included at the beginning of the file, the program will prompt the user for a DOCTYPE declaration after the extraction process has begun. This DOCTYPE declaration file is typically called doctype.txt)

**DTD associated with IETM SGML file**: Browse to find the file, which has a “.dtd” extension. This file is a required file for extraction.

The DTD defines the structure of the elements found within the SGML file.

**Declaration file**: Browse to find the file, which has a “.dec” extension. Some IETM developers will provide declaration files that were used with the IETM and DTDs; otherwise, a default declaration file is used. This file is an optional file for extraction.

The declaration file provides information such as the number of potential levels of elements, number of elements able to be declared, etc. If no declaration file is specified, a default declaration file is used.

**DTD Registration file**: Browse to find the file, which has a “.inf” extension. This file is a required file for extraction.

The registration file defines the elements that will be used to generate the IETM structure information that will be imported into AIM. The DTD Registration file specifies information about how the SGML file is written according to a DTD; for example, if label attributes are used when displaying node titles.

**Library file**: Browse to find the file, which should have a “.lib” extension. This file is a required file for extraction.

The library file informs the extraction functions of the locations of DTDs and entity files that are declared by the DTD.

**DDE information file**: Click the DDE Messaging Info button. The following screen will be displayed. Type the information into the text boxes, or click the “Read From File” button to find the file which contains all DDE information. The file containing the DDE information has a “.dde” extension. This file is a required file for extraction.

The DDE file specified information related to what type of viewer is used to display the IETM, where the viewer application is located, and any DDE command information that is necessary to be included in a DDE message to tell a viewer to position to a node. After the file has been read, all text boxes will be filled out with the appropriate information. Click the “OK” button to return to the “Extract SGML-based IETM” screen.
The following screen is an example of information input for an IETM based on display via the UAS 5.0 viewer. The Application Name is always “TMMIAPP” and the Topic Name is always “TECHINFO”. The Application location is the location of the UAS 5.0 executable and may change depending upon the installation of the UAS viewer. The Configuration File is the location of the .dat file that corresponds to the TIDB. The Configuration Location specifies the directory where the configuration file is located. The DDE PreString will always be “[SHOW(“. The DDE PostString will always be in the format of “)(public name from .dat)”. The Window Name is the name that is displayed as the window name of the UAS viewer, and at this point will always be “User Access System”.

The following screen is an example of a browser-based (such as Internet Explorer) IETM. The path where the HTML files are located needs to be identified in “Path of main directory for HTML files.”
The following screen is an example of a Dynatext-based IETM. The Application Name is always “DTEXT”. The Topic Name is “BOOK(ID of book, title of book). These book values can be copied from the dynatext.ini file. The Application location is the location of the Dynatext executable. The Configuration Location is always the path to the binary (“\bin”) directory located within the installed Dynatext directory. The DDE Prestring is always “ebt-script("ebt-link window=new showtoc=yes target=idmatch(ID,”). The DDE Post String is always ‘)’”. The Window Name is based on the window name given when Dynatext is launched. In this case, the window name is from version 2.3 of Dynatext.
The following screen is an example of an AIMSS-based IETM. The Application Name is always “AIMSS” and the Topic Name is always “CBT”. The Application Location is the location of the AIMSS executable, and the Configuration Location is the “runtime” directory of the installed AIMSS program. The DDE Prestring is the location of the compiled AIMSS IETM.
The following is an example of a GuideReader-based IETM. The Application Name is always “Guide”. The Topic Name and Configuration Location are the location of the Guide files. The Application location is the location of the GuideReader executable followed by a command option of “-c” followed by the location of the Guide Reader ini file.
After all files have been located, click on the Extract button. The extraction process will then be performed.

Note that a DOCTYPE declaration is required at the beginning of the SGML file. If this declaration is not found, the extraction program will prompt the user for the appropriate DOCTYPE declaration. The user can either type this text into the displayed text box or read the DOCTYPE declaration from a file.

The extraction program will then complete the analysis of the SGML file and the extraction of appropriate structural data of the IETM that should be imported into the AIM database. When this process is complete, a message box will appear informing the user that the IETM has been successfully extracted. A second message box will appear stating that the extraction file has been created with the name that the user selected.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)

### 2.3.1 Description of Registration (Information) File

The extraction program utilizes an “information file” that describes the IETM and those elements that will be included in the AIM hierarchy. The user should carefully examine the DTD when creating this
registration file. The extraction program will base the hierarchy obtained from the IETM on information found in this file.

This information file is important for several reasons:

The information file defines the elements that will actually be included in the AIM hierarchy. In an interactive IETM, there are several elements that are only important to the interactivity of the IETM, but are not necessarily important to the hierarchy of information. The AIM program essentially mimics the table of contents displayed in the interactive IETM.

SGML files based on unique DTDs will use different naming conventions for similar types of elements and attributes. For example, node names may have an attribute of “NAME” in one DTD, but have an attribute of “NODE NAME” in another DTD. The definitions of conventions used for the AIM-required IETM information are vital to the successful extraction process.

The following paragraphs describe each section of the registration/information file.

**[TAGS] section**

The [TAGS] section describes those elements that will be analyzed to be included in the AIM hierarchy. These elements are typically not solely involved in the interactive nature of the IETM.

In this example, elements that are not to be analyzed include ALERT and DIALOG, because these are solely involved in the interactivity of the IETM.

Example for MIL-D-87269 - based IETM:

```
[TAGS]
DESCINFO
GRAPHIC
PARA
PARA-SEQ
STRING
SYSTEM
TABLE
TASK
TECHINFO
```

**[NODE ATTRIBUTES] Section**

This section describes the attributes that are used to define required information about the nodes: name, id, and version. This is information that is required by AIM for tracking nodes, including the tracking over multiple versions. This section also includes some optional information used for defining the names of the nodes that will be displayed in AIM when browsing the structure of the IETM.

Example combining information for several IETMs:

```
[NODE ATTRIBUTES]
name=NAME
id=ID
```
The “name”, “id”, and “version” descriptions are all required. The “label” and “no node title” descriptions are optional.

[INCLUDE ELEMENT TAG IN NODE NAME] Section

This section describes the elements where the element tag should be included as part of the element name. For example, an IETMs may have “Figure” elements where the element is displayed such as “Figure 1: Main Equipment Display”. The element name in the SGML file is “1: Main Equipment Display”, while the element tag is “FIGURE”. To make this element title complete, the element tag and element name should be concatenated together.

Example for MIL-D-87269 - based IETM:

[INCLUDE ELEMENT TAG IN NODE NAME]

this is intentionally left blank because there is nothing that should be defined here

Example for another IETM:

[INCLUDE ELEMENT TAG IN NODE NAME]

CHAPTER
FIGURE
TABLE

[ID/IDREF LINKING] Section

This section describes the ID/IDREF pairs that are used and the attribute names that describe each of these pairs. When an IDREF attribute is encountered, this indicates to the SGML file that there is a linking to another element with a corresponding ID attribute. The element with the corresponding ID attribute (and its sub-elements) should “replace” the element with the IDREF attribute. This is a convenient way to 1) make the SGML file more readable, and 2) to re-use elements in multiple places of the SGML file without having to duplicate the information.

For example, the MIL-D-87269 DTD has an attribute REF, which is defined as an IDREF type, and an attribute ID, which is defined as an ID type. The element <SYSTEM REF="OP4612Figures"> is defined. This describes a linking to a corresponding <SYSTEM ID="OP4612Figures"> defined elsewhere in the SGML file. The element <SYSTEM ID="OP4612Figures"> and all its contained elements should be inserted into the hierarchy at the point where it was referenced by <SYSTEM REF="OP4612Figures">. Example for MIL-D-87269 - based IETM:

[ID/IDREF LINKING]
idref=REF;id=ID
[MAP VERSION ATTRIBUTE] Section

This section describes how versions are handled in the IETM. In some cases, the version attribute that is associated with an element is actually mapped to a version element that completely describes the version.

Using the MIL-D-87269 DTD example, elements contain attributes of VERSION="ver0". This “ver0” string is actually mapped to a VERSION element that gives more complete information about the version. The VERSION element whose ID="ver0" shows a REVISION attribute of “1”. This Revision 1 is what is actually contained in the IETM documentation and is what should be displayed by AIM. The “ver0” string is meaningless to the user, but can be used within the AIM code to compare versions.

Example for MIL-D-87269 - based IETM:

[MAP VERSION ATTRIBUTE]  
element=VERSION  
mapped attribute=ID  
display attribute=REVISION

[EXCLUDE ELEMENTS DUE TO SPECIFIED ATTRIBUTES]

This section describes elements that should be excluded because they contain a specific attribute. For example, an element may contain an attribute describing it as a global element, which should not be included except when it is referenced by an ID/IDREF pair.

For example, there could be several cases where a SYSTEM element contains a TYPE attribute with the content of GLOBAL. This means that the SYSTEM element is global and is actually referenced (through an ID/IDREF linking) elsewhere. In some cases, this global SYSTEM element has an ID. Even though it has an ID, it is global and should not be included in the AIM hierarchy other than in places that reference it.

Example for MIL-D-87269 - based IETM:

[EXCLUDE ELEMENTS DUE TO SPECIFIED ATTRIBUTES]  
SYSTEM;TYPE=GLOBAL  
SYSTEM;ID=MenuReviewAccess  
SYSTEM;ID=MenuProcedureAccess

[INCLUDE NO ID] Section

This section describes those elements that should be included in the AIM hierarchy even though they have no ID attribute. These elements are used as IETM viewer “placeholders” in many instances. They essentially describe folders containing graphics, tables, etc. Because the elements have no ID attribute, they will be flagged that there is no specific place to position to in the viewer.
Example for MIL-D-87269 - based IETM:

[INCLUDE NO ID]
TASK
DESCINFO

This information can be entered in two forms:

1) including just an element name (ex. TASK), where all element tags of TASK will be included
2) included an element name and attribute value (ex. TABLE; TABSTYLE="INLINE"), where the element
tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE”
will be included.

[INCLUDE NO ID BUT REF] Section

This section describes those elements that should be included in the AIM hierarchy even though they have
no ID attribute, but they have a reference attribute. These elements are used to reference a “chunk” of the
IETM that is placed somewhere else in the SGML file. (See the section describing the ID/IDREF pairs.)
This section would be used in cases where it is not appropriate to include all elements of the particular type
with no Ids, but to include only those that have a reference attribute.

For example, in one IETM, some SYSTEM elements may contain references to other elements. These
SYSTEM elements do not have an ID attribute, only a REF attribute. These elements should be included in
the AIM hierarchy. However, not all SYSTEM elements that do not have an ID should be included - just
those that have a REF attribute. This is why the SYSTEM element would be included in this section, rather
than the [INCLUDE NO ID] section.

Example for MIL-D-87269 - based IETM:

[INCLUDE NO ID BUT REF]
SYSTEM

[TRAVERSE EVEN IF NO ID BUT NO HIERARCHY] Section

This section describes those elements that should be traversed for children; these children may be included
in the AIM hierarchy. However, the elements listed here are not included in the hierarchy themselves.

These elements can be thought of as containers within the SGML file. These elements contain sub-elements
that can be positioned to within the viewer.

Note that these elements are traversed even if they have no ID attribute.
This information can be entered in two forms:
1) including just an element name (ex. TASK), where all element tags of TASK will be traversed even if no id
2) included an element name and attribute value (ex. TABLE; TABSTYLE="INLINE"), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be traversed

Example for MIL-D-87269 - based IETM:

[TRAVERSE EVEN IF NO ID BUT NO HIERARCHY]
PARA-SEQ
PARA
TECHINFO

[TRAVERSE ONLY EVEN IF ID] Section

This section describes those elements that should be traversed for children but not included in the AIM hierarchy, even if the element does have an ID attribute. These elements could be considered as “placeholders” within the SGML file.

This information can be entered in two forms:
1) including just an element name (ex. TASK), where all element tags of TASK will be traversed even if no id
2) included an element name and attribute value (ex. TABLE; TABSTYLE="INLINE"), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be traversed

Example for MIL-D-87269 - based IETM:

[TRAVERSE ONLY EVEN IF ID]
SYSTEM; ID=MenuDocumentAccess
SYSTEM; NAME=

[INCLUDE WITH REPLACEMENT NODE TITLES]

This section describes those elements that are included but their element names are replaced with those listed in the registration file.

Example for an IETM:

[INCLUDE WITH REPLACEMENT NODE TITLES]
BODYREAR=LIST OF TABLES
REAR=LIST OF FOLDOUTS/ADDENDA

In this example, whenever a “BODYREAR” element is encountered, its name will be “LIST OF TABLES” in the IETM structure to be imported into AIM.
[TEXT NODE TYPES], [GRAPHIC NODE TYPES], and [TABLE NODE TYPES] Sections

These sections describe those elements that are described as nodes that are text, graphics, or tables. The node type in the flat file is used by AIM to determine the type of icon to display to the user as an aid to what type of node is selected for viewing or use within a RIA.

Example for MIL-D-87269 - based IETM:

[TEXT NODE TYPES]
SYSTEM
TASK
DESCINFO

[GRAPHIC NODE TYPES]
GRAPHIC

[TABLE NODE TYPES]
TABLE

[IETM NAME ELEMENT] and [IETM VERSION ELEMENT] Sections

These sections describe how to find the name and version number for the IETM. This information will be displayed in the AIM IETM Admin screen to show the list of IETMs that are currently stored in the database. This information is also used to create the first node in the IETM structure to be imported into AIM.

If either of these sections is blank, then the user will be prompted by the extraction program to enter the IETM name and version. There are some SGML files that do not have this information embedded within them, so the user must enter the information manually. This process is done immediately upon initiating the extraction process.

Example for MIL-D-87269 - based IETM:

[IETM NAME ELEMENT]
TECHINFO; 1

[IETM VERSION ELEMENT]
SYSTEM; 1

2.3.1.1 Example of Determining the Content of the Registration File using the GD SWS IETM

The sections within the registration file are created by analyzing what is displayed in the specific IETM table of contents within the viewer being used for the IETM and evaluating this with the elements defined in the DTD. The DTD can also be analyzed to determine basic content of the IETM versus elements defined only for the interactivity of the IETM.
In some cases, the process of creating the correct registration file may be iterative. The person extracting the IETM may have to create the registration file, run the extraction, and modify the registration file based on the information that was included or excluded from the resulting extracted text file, and then run the extraction again. This process would continue until the extracted information mimics the table of contents displayed in the specific IETM viewer. **[TAGS] section** - describing acceptable tags that will be included in the AIM hierarchy

By looking at the table of contents of the GD SWS IETM in the GD EDS Viewer and comparing displayed items with the SGML file, you can easily see that the displayed items are SYSTEM, DESCINFO, GRAPHIC, TABLE, and TASK elements. By looking at the DTD, you also easily see that SYSTEM elements are sub-elements of the TECHINFO element. Therefore, these elements should be included as acceptable tags.

The [TAGS] section in the registration file would appear as follows:

```
[TAGS]
DESCINFO
GRAPHIC
PARA
PARA-SEQ
STRING
SYSTEM
TABLE
TASK
TECHINF
```

Example from the SGML file showing TECHINFO, SYSTEM, and DESCINFO elements used:
(elements are highlighted in Bold)

```
<!DOCTYPE TECHINFO PUBLIC ":/GD/DTD GD SWS TECHINFO//EN">
<TECHINFO NAME="Fire Control System">
  <VERSION ID="ver0" REVISION="1" REVDATE="040797" CHANGENO="2" CHGDATE="000000">
  </VERSION>
  <SYSTEM ID="MenuDocumentAccess" NAME="FCS MK 98 MOD 1 / GS MK 6 MOD 0" VERSION="ver0">
    <SYSTEM ID="OP4612" NAME="OP 4612" TYPE="TITLE" VERSION="ver0">
      <SYSTEM ID="OP4612v3" NAME="VOLUME 3" TYPE="TITLE" VERSION="ver0">
        <SYSTEM ID="OP4612v3CONTENTS" NAME="CONTENTS" VERSION="ver0">
          <DESCINFO ID="OP4612v3c1" NAME="NO CONTENT" VERSION="ver0">
          </DESCINFO>
        </SYSTEM>
      </SYSTEM>
    </SYSTEM>
  </SYSTEM>
</TECHINFO>
```

Compare these elements with part of the first item of the Table of Contents displayed in the GD SWS EDS Viewer. You'll notice that the entire IETM is considered to be “FCS MK 98 MOD 1 / GS MK 6 MOD 0”; this is the first main SYSTEM element in the SGML file. Then you’ll see the first element in the TOC - “OP 4612”; this is the next SYSTEM element in the SGML file. Opening the “OP 4612” item in the GD SWS EDS Viewer, you’ll see the next SYSTEM element - “VOLUME 3”. Continuing to open the elements in the GD SWS EDS Viewer, you’ll then see the next SYSTEM element - “CONTENTS” with the child of the DESCINFO element - “NO CONTENT”.

Example from the SGML file showing TASK elements used:

```
<SYSTEM ID="OP4612v3FI" NAME="FAULT ISOLATION INDEX PROCEDURE" VERSION="ver0">
  <TASK NAME="FAULT ISOLATION INDICATION SELECTION" VERSION="ver0">
  </TASK>
```

Example from the SGML file showing TASK elements used:

```
<SYSTEM ID="OP4612v3FI" NAME="FAULT ISOLATION INDEX PROCEDURE" VERSION="ver0">
  <TASK NAME="FAULT ISOLATION INDICATION SELECTION" VERSION="ver0">
  </TASK>
```
In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Fault Isolation Index Procedure” folder. Opening this folder shows the TASK element = “FAULT ISOLATION INDICATION SELECTION”.

Example from the SGML file showing TABLE elements used:

```
<TABLE ITEMID="3-1." TYPE="ColSubHeaders=1" ID="OP4612v3c3t1" NAME="SMP FAILURES">

In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Tables” folder. Opening this folder shows the TABLE element = “SMP FAILURES”.

Example from the SGML file showing GRAPHIC elements used:

```
<GRAPHIC NAME="Power Status and Control Panel." ID="OP4612v3c3f1s0p0" ITEMID="3-1.">

In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Illustrations” folder and then the “3” folder. Opening this folder shows the GRAPHIC element = “Power Status and Control Panel”.

The other acceptable elements are not as obvious to pick out. In some cases, these elements are only containers for sub-elements, where the sub-elements will be included in the AIM hierarchy.

Example from the SGML file showing PARA-SEQ and PARA elements used:

```
<DESCINFO TYPE="FOLDER" VERSION="ver0">
<PARA-SEQ>
<PARA VERSION="ver0">
<GRAPHIC NAME="Power Status and Control Panel." ID="OP4612v3c3f1s0p0" ITEMID="3-1.">
<GRPHPRIM ID="ACN-IC4614-0035B-A2" ITEMID="46140035.tif" CODING="FAX">
<TEXT>
</TEXT>
</GRPHPRIM>
</GRAPHIC>
</PARA>
</PARA-SEQ>
</DESCINFO>

In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Illustrations” folder and then the “3” folder. Opening this folder shows the GRAPHIC element = “Power Status and Control Panel”. Notice that in the SGML file, the GRAPHIC element is a sub-element of the PARA element, which is a sub-element of the PARA-SEQ element. However, the PARA and PARA-SEQ elements have no names or IDs and are used as nothing more than containers, which are verified by looking at the DTD.

So, these tags have to be listed as acceptable so that the extraction algorithm will continue to look for the children of these elements; however, they will not be included in the AIM hierarchy. These tags will show up again in the [TRAVERSE BUT NO HIERARCHY]
Section of the registration file, so that the extraction program is told to analyze (traverse) these elements but not include them in the AIM hierarchy.

[NODE ATTRIBUTES] Section

This section describes the names of the attributes that are used in the IETM for defining the required node information for import into AIM. The required information consists of node name, ietm id, and version. In the GD SWS IETM, the node name is defined by the attribute “NAME”, the node ietm id is defined by the attribute “ID”, and the version is defined by the attribute “VERSION”.

The [NODE ATTRIBUTES] section in the registration file would appear as follows:

```
[NODE ATTRIBUTES]
name=NAME
id=ID
version=VERSION
```

Example from the SGML file of the node attributes:

```
<SYSTEM ID="OP4612" NAME="OP 4612" TYPE="TITLE" VERSION="ver0">...
```

In some cases, the name of the element is the content of a child element rather than the attribute of the element. In this case, the registration file entry would appear as follows:

```
name=CONTENT(TITLE)
```

where “TITLE” is the element tag whose content defines the name of the node. The text “CONTENT()” must appear to indicate that the content of an element rather than an attribute of an element will be searched for the element name.

In the GD SWS IETM, this information is sufficient. However, this section also contains optional information used for defining the name of the node that will be displayed in AIM when browsing the IETM structure. The optional information consists of “label” and “no node title”. In some cases, there is a label attribute that is used as part of the element name; therefore, the “label” description would be set to this attribute. In cases where an element is included but does not have a name, the default functionality is to use the sequence number as the name. However, if the “no node title” entry is set to “UNTITLED”, then the element name will be “UNTITLED” concatenated with the element tag name. The registration file entries would appear as follows.

```
label=LABEL
no node title=UNTITLED
```

[INCLUDE ELEMENT TAG IN NODE NAME] Section

This section describes the elements where the element tag should be included as part of the element name. For example, an IETMs may have “Figure” elements where the element is displayed such as “Figure 1: Main Equipment Display”. The element name in the SGML file is “1: Main Equipment Display”, while the element tag is “FIGURE”. To make this element title complete, the element tag and element name should be concatenated together.
For the GD SWS IETM, this section would be blank because no such information is necessary:

[ID/IDREF LINKING] Section

This section describes ID/IDREF pairs that are used for linking between elements in the IETM and the attribute names that describe each of these pairs. In the GD SWS IETM, only one ID/IDREF pair is used. The IDREF - type attribute "REF" is used by an element to reference or link to another area of the SGML file. The corresponding ID - type attribute "ID" is used by an element to refer to the "linked" or the referenced element.

The [ID/IDREF LINKING] section in the registration file would appear as follows:

[ID/IDREF LINKING]
idref=REF;id=ID

Example from the SGML file of the ID/IDREF pairs:

During the extraction process, the extraction program will insert this sub-hierarchy, starting at the SYSTEM element with ID="OP4619v1Figures", into the AIM hierarchy at the position of the SYSTEM element with REF="OP4619v1Figures".
The portion of the AIM hierarchy would look as follows:

OP 4619
  Volume 1
  Contents
  Illustrations
  1 (corresponding to the DESCINFO element)
    Mk 6 Guidance Assemblies
    Interface Relationships
  2
  .
  .
  Tables
  .
  .

[MAP VERSION ATTRIBUTE] section

In the GD SWS IETM (and defined in the 87269), an element has a VERSION attribute which is an IDREF attribute. So, the VERSION attribute is linked back to a version element. The version element has attributes giving a more complete description of the version, such as revision and change information.

So, when the main IETM version is displayed in the AIM grid, the actual information should be displayed rather than this VERSION attribute. This section describes the element that is referenced when a VERSION attribute is found & the attributes within the element that define the information to be displayed.

The [MAP VERSION ATTRIBUTE] section of the registration file would appear as follows:

[MAP VERSION ATTRIBUTE]
element=VERSION
mapped attribute=ID
display attribute=REVISION

Example from the SGML file of the mapped version information:

  
  <VERSION ID="ver0" REVISION="1" REVDATE="040797" CHANGENO="2" CHGDATE="000000">
  </VERSION>
  <SYSTEM ID="MenuDocumentAccess" NAME="FCS MK 98 MOD 1 / GS MK 6 MOD 0" VERSION="ver0">

When looking for the main IETM version, you can see that the SYSTEM “FCS MK 98 MOD 1 / GS MK 6 MOD 0" has a version attribute of “ver0”. Based on the registration file, the element that is linked is the element “VERSION” with an ID attribute of “ver0” (which in the example is the element immediately proceeding the SYSTEM element). The REVISION attribute then describes the information that will actually be displayed in the AIM grid.
This section describes elements that should be excluded because they contain a specific attribute. In the GD SWS IETM, there are many SYSTEM elements that have a TYPE attribute of GLOBAL. These elements are typically containers for the referenced element(s) of an ID/IDREF pair. They are essentially defined at the end of the SGML file, for readability of the SGML file and potential “re-use” of the element. Because they’re included when they are referenced, they should not be included when they are simply encountered in the SGML file.

The [EXCLUDE ELEMENTS DUE TO SPECIFIED ATTRIBUTES] section would appear as follows in the registration file:

```
[EXCLUDE ELEMENTS DUE TO SPECIFIED ATTRIBUTES]
SYSTEM;TYPE=GLOBAL
SYSTEM;ID=MenuReviewAccess
SYSTEM;ID=MenuProcedureAccess
```

Example from the SGML file of exclusion due to attributes:

```
.<SYSTEM NAME="Table View" TYPE="GLOBAL" VERSION="ver0">
.<SYSTEM NAME="OD 56508" VERSION="ver0">
.<SYSTEM NAME="VOLUME 2" ID="OD56508v2Tables" VERSION="ver0">
.
.
The SYSTEM “Table View” is found with a TYPE attribute with a value of GLOBAL. This means that the element is defined globally and should not be included in the AIM hierarchy. It contains elements that are referenced from other parts of the IETM.
```

### [INCLUDE NO ID] section

Some elements should be included in the AIM hierarchy even if there is no IETM ID. For example, these elements are typically used as “placeholders” in the some of the IETM’s viewers.

This information can be entered in two forms:

1) including just an element name (ex. TASK), where all element tags of TASK will be included
2) included an element name and attribute value (ex. TABLE; TABSTYLE="INLINE"), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be included.

The [INCLUDE NO ID] section in the registration file would appear as follows:

```
[INCLUDE NO ID]
TASK
DESCINFO
```
Example from the SGML file of including an element even if no id:

```xml
<SYSTEM NAME="VOLUME 1" ID="OP4619v1Figures" VERSION="ver0">
<DESCINFO TYPE="FOLDER" VERSION="ver0">
<PARA-SEQ>
<PARA VERSION="ver0">
<GRAPHIC NAME="Mk 6 Guidance Assemblies." ID="OP4619v1c1f1s0p0" ITEMID="1-1.">
<GRPHPRIM ID="ACN-4619-11A" ITEMID="46190011.tif" CODING="FAX">
<TEXT>
</TEXT>
</GRPHPRIM>
</GRAPHIC>
</PARA>
</PARA-SEQ>
</DESCINFO>
</SYSTEM>
```

The portion of the IETM table of contents looks as follows:

OP 4619

Volume 1

Contents

Illustrations

1 (corresponding to the DESCINFO element)

Mk 6 Guidance Assemblies

Interface Relationships

2

.

.

Tables

So, it is necessary to include the DESCINFO element in order to set up the folder named “1” in the AIM hierarchy, even though the DESCINFO element has no ID (and in this case, no name). The extraction algorithm mimics the display of the IETM in the IETM viewer by simply setting the name of the node to be the sequence number - in this case, it is “1”.

**[TRAVERSE EVEN IF NO ID BUT NO HIERARCHY] section**

There are some cases where an element is encountered that will not be included in the AIM hierarchy, but the element is critical to the AIM hierarchy because it contains children that should be included in the hierarchy.

This information can be entered in two forms:

1) including just an element name (ex. TASK), where all element tags of TASK will be traversed even if no id

2) included an element name and attribute value (ex. TABLE; TABSTYLE="INLINE"), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be traversed.

An example of this was seen when describing acceptable tags and will be repeated here.
Because the GRAPHIC and TABLE elements must be included in the AIM hierarchy, look at the DTD and determine potential elements that are containers for the GRAPHIC and TABLE elements. You will see that the PARA element is a container for graphic and table elements. You will also see that the PARA-SEQ is a container for the PARA element. Looking at the SGML file confirms this. You’ll also notice that the PARA-SEQ and PARA elements never show up in the GD SWS IETM viewer table of contents. So, this implies that these elements must be included in the registration file section of traversing the element but not including in the hierarchy.

The [TRAVERSE EVEN IF NO ID BUT NO HIERARCHY] section would appear in the registration file as follows:

[TRAVERSE EVEN IF NO ID BUT NO HIERARCHY]
PARA-SEQ
PARA
TECHINFO

Example from the SGML file showing PARA-SEQ and PARA elements which are traversed:

```xml
<DESCINFO TYPE="FOLDER" VERSION="ver0">
  <PARA-SEQ>
    <PARA VERSION="ver0">
      <GRAPHIC NAME="Power Status and Control Panel." ID="OP4612v3c3f1s0p0" ITEMID="3-1.">
        <GRPHPRIM ID="ACN-IC4614-0035B-A2" ITEMID="46140035.tif" CODING="FAX">
          <TEXT/>
        </GRPHPRIM>
      </GRAPHIC>
    </PARA>
  </PARA-SEQ>
</DESCINFO>
```

In the GD SWS EDS Viewer Table of Contents, open the folder “OP 4612” to see the “Illustrations” folder and then the “3” folder. Opening this folder shows the GRAPHIC element = “Power Status and Control Panel”. Notice that in the SGML file, the GRAPHIC element is a sub-element of the PARA element, which is a sub-element of the PARA-SEQ element. However, the PARA and PARA-SEQ elements have no names or IDs and are used as nothing more than containers, which is verified by looking at the DTD.

So, these tags have to be listed as elements to traverse in order to continue to look for the children of these elements; however, they will not be included in the AIM hierarchy.

[TRAVERSE ONLY EVEN IF ID] section

This section describes those elements that should be traversed for children but not included in the AIM hierarchy, even if the element does have an ID attribute. These elements could be considered as “placeholders” within the SGML file.

This information can be entered in two forms:
1) including just an element name (ex. TASK), where all element tags of TASK will be traversed even if no id
2) included an element name and attribute value (ex. TABLE; TABSTYLE="INLINE"), where the element tags of “TABLE” with the attribute of “TABSTYLE” and TABSTYLE’s attribute value of “INLINE” will be traversed.
This section in the registration file would appear as follows:

[TRAVERSE ONLY EVEN IF ID]
SYSTEM; ID=MenuDocumentAccess
SYSTEM; NAME=

Example from the SGML file showing SYSTEM elements that are traversed only even though they have an ID attribute:

<TECHINFO NAME="Fire Control System">

<VERSION ID="ver0" REVISION="1" REVDATE="040797" CHANGENO="2" CHGDATE="000000">
</VERSION>
<SYSTEM ID="MenuDocumentAccess" NAME="FCS MK 98 MOD 1 / GS MK 6 MOD 0" VERSION="ver0">

The “TECHINFO” element has already provided the name for the main level of the IETM structure. When the first “SYSTEM” element is encountered, we want to simply traverse it rather than include it in the hierarchy. The element is a main element that contains children that are important to the AIM structure, but this element is not important to be directly included in the hierarchy.

[INCLUDE WITH REPLACEMENT NODE TITLES]

This section describes those elements that are included but their element names are replaced with those listed in the registration file.

In the GD SWS IETM, this section would be blank because no such information is necessary, as follows:

[INCLUDE WITH REPLACEMENT NODE TITLES]

Example for another IETM:

[INCLUDE WITH REPLACEMENT NODE TITLES]
BODYREAR=LIST OF TABLES
REAR=LIST OF FOLDOUTS/ADDENDA

In this example, whenever a “BODYREAR” element is encountered, its name will be “LIST OF TABLES” in the IETM structure to be imported into AIM.

[TEXT NODE TYPES], [GRAPHIC NODE TYPES], [TABLE NODE TYPES] sections

These sections describe which elements are defined as text items, graphic items, or table items. Simply list the element tag names in each of these sections. This is mainly used for the browser displayed in AIM. If these elements are not completed, AIM simply won’t display an icon identifying the element as text, graphic, or a table. So, these sections are not critical to the extraction process; they will just make the display of the hierarchy in the browser have the additional information of the node type.
[IETM NAME ELEMENT] and [IETM VERSION ELEMENT] sections

These sections describe how to find the name and version number for the IETM. This information will be displayed in the AIM IETM Admin screen to show the list of IETMs that are currently stored in the database. This information is also used to create the first node in the IETM structure to be imported into AIM.

If either of these sections is blank, then the user will be prompted by the extraction program to enter the IETM name and version. There are some SGML files that do not have this information embedded within them, so the user must enter the information manually. This process is done immediately upon initiating the extraction process.

The [IETM NAME ELEMENT] and [IETM VERSION ELEMENT] sections in the registration file would appear as follows:

[IETM NAME ELEMENT]
TECHINFO; 1

[IETM VERSION ELEMENT]
SYSTEM; 1

The format for these sections is as follows:

ELEMENT; nth occurrence to find

The [IETM NAME ELEMENT] section indicates that the 1st occurrence of the TECHINFO element should be found for the name. The [IETM VERSION ELEMENT] section indicates that the 1st occurrence of the SYSTEM element is used for the version of the IETM.

Example from the SGML file showing the first TECHINFO element including the name for the IETM and the first SYSTEM element used to indicate the version of the IETM:

```xml
<TECHINFO NAME="Fire Control System">
...
VERSIOID="ver0" REVISION="1" REVDATE="040797" CHANGENO="2" CHGDATE="000000">
</VERSIOID>
<SYSTEM ID="MenuDocumentAccess" NAME="FCS MK 98 MOD 1 / GS MK 6 MOD 0" VERSION="ver0">
```

2.3.2 Description of Library File

A “library” file is used by software to reference the physical location of the DTD and any entity files used in conjunction with the DTD. A library file does not have to reside in the same directory as the DTD; however, for ease of use, the user may wish to keep this library file in the same directory as the SGML file, DTD file, registration file, etc. An example “library file” is shown below. Note that library files are normally created with a “.lib” extension.
LIBRARY

"-//USA-DOD//DTD MIL-M-28001 MATHPACK 911001//EN"
"mathpac.ent"

"-//GD//DTD GD SWS TECHINFO//EN"
"gd269.dtd"

"-//USA-DOD//DTD Content Data Model Generic Layer//EN"
"87269.ent"

"-//EDS//ENTITIES EDS Special Symbols//EN"
"Eds-symb.ent"

The first line of each pair shows the “identifier” (name) of the DTD or of the entity file used in the DTD. The second line of each pair shows the physical location of the file. If a full path name is not included then the library file and each file referenced in the library file must reside in the same directory. If the files do not reside in the same directory, then a full path name must be included in the library file.

There are several “mistakes” to check for in the library file if the extraction program does not work successfully:

The path names for the DTD or entity files are not correct. Check your system and make sure that they have been defined correctly.

There are spaces in the file names. For example, the file name “87269.ent” is defined correctly, but the file name “ 87269.ent” is not. (Note the extra space at the beginning of the file name.) The functions used in the extraction program will not be able to successfully find this file.

The PUBLIC identifiers are not specified exactly as they are defined in the DTD or entity files. Check for spelling and addition of extra spaces in the declaration and in the DTD/entity files.

Identifiers are like addresses that allow the SGML processing system to locate resources. (In this case, the library file to locate the resources.) Note that in the above example all identifiers are PUBLIC identifiers. PUBLIC identifiers allow the file to be moved anywhere. They are typically used so that the resource can be moved between machines, etc. and a library file updated to indicate where these files are located. SYSTEM identifiers, on the other hand, contain a path location for a particular machine.

External parameter entities (in this case: mathpac.ent, 87269.ent, and Eds-symb.ent) used in a DTD provide several advantages: 1) they allow a DTD to be modularized, and 2) they allow publicly named material or documents to be used (ex. ISO standard entities).

GD269 DTD

The entry in the library is as follows:

"-//GD//DTD GD SWS TECHINFO//EN"
"gd269.dtd"

Explanation:
The DOCTYPE declaration in the SGML file is as follows:

```xml
<!DOCTYPE TECHINFO PUBLIC "-//GD//DTD GD SWS TECHINFO//EN">```

So, the SGML file will look for a DTD with the identifier of “-//GD//DTD GD SWS TECHINFO//EN”. The library file would be used to tell the processing system that the DTD with this identifier is called “gd269.dtd”. If a path name were specified, the processing system would expect the file to be located at that path; because no path is specified in this case, the file is expected to be in the same directory as the library file.

**87269.ENT**

The entry in the library is as follows:

PUBLIC "-//USA-DOD//DTD Content Data Model Generic Layer//EN"
"87269.ent"

Explanation:

The DTD declares the entity file contained in the file “87269.ent” in the following statement:

```xml
<!ENTITY % dietmdb-a PUBLIC "-//USA-DOD//DTD Content Data Model Generic Layer//EN" %dietmdb-a;>
```

Note that here the entity is declared by by external entity declaration (`<!ENTITY % dietmdb-a ".">`) and is also initialized to be used in the document (by the reference `%dietmdb-a;`).

So, the SGML file will look for an entity with the identifier of "-//USA-DOD//DTD Content Data Model Generic Layer//EN". The library file would be used to tell the processing system that the entity with this identifier is located in the file “87269.ent”.

**MATHPAC.ENT**

The entry in the library is as follows:

PUBLIC "-//USA-DOD//DTD SUP MIL-M-28001 MATHPACK 911001//EN"
"mathpac.ent"

Explanation:

The entity "-//USA-DOD//DTD Content Data Model Generic Layer//EN" (located in the file “87269.ent”) declares the entity file contained in the file “mathpac.ent” in the following statement:

```xml
<!ENTITY % mathpac PUBLIC "-//USA-DOD//DTD SUP MIL-M-28001 MATHPACK 911001//EN" %mathpac;>
```

Note again that here the entity is declared by external entity declaration (`<!ENTITY % mathpac ".">`) and is also initialized to be used in the document (by the reference `%mathpac;`).

So, the SGML file will look for an entity with the identifier "-//USA-DOD//DTD SUP MIL-M-28001 MATHPACK 911001//EN". The library file would be used to tell the processing system that the entity with this identifier is located in the file “mathpac.ent”.

D-28
**EDS-SYMB.ENT**

The entry in the library is as follows:

```
"//-EDS//ENTITIES EDS Special Symbols//EN"
"Eds-symb.ent"
```

Explanation:

The DTD declares the entity file contained in the file “eds-symb.ent” in the following statement:

```xml
<!ENTITY % eds-symb PUBLIC "//-EDS//ENTITIES EDS Special Symbols//EN" > %eds-symb; 
```

Note again that here the entity is declared by external entity declaration (<!ENTITY % eds-symb >) and is also initialized to be used in the document (by the reference % eds-symb;).

So, the SGML file will look for a entity with the identifier "//-EDS//ENTITIES EDS Special Symbols//EN". The library file would be used to tell the processing system that the entity with this identifier is located in the file “eds-symb.ent”.

### 2.3.3 Description of DDE Information File

The DDE information file contains all information necessary for AIM to have the capability to communicate with the IETM viewer. The DDE information is based on the viewer type; the viewer could be based on a COTS authoring/publishing tool (ex. Inso’s Dynatext product) or could be a custom-built viewer (ex. SWS).

The DDE Information file has the following format:

```
[DDE Message Information] (Required; used by AIM to verify appropriate DDE file)
TMMIAPP (Required; DDE Application value)
TECHINFO (Required; DDE Topic value)
C:\EDS\UAS\TMMIAPP.EXE (Required; path of the viewer executable)
C:\EDS\IETM-DBS\CONFIG (Required; configuration data path - or exe path if no config.)
[SHOW( ] (Can be blank; value to be appended to beginning of ID string for DDE command)
)] (Can be blank; value to be appended to end of ID string for DDE command)
1 (DDE command type - current defined values listed below)
Electronic Documentation System (Can be blank or "<none>"); window name for IETM viewer)
```
Notes:

1. The window name is blank or is specified as "<none>" if the main window name for the IETM viewer changes while the IETM viewer is running. If the name is consistent, then it should be specified. Specification of the window name allows AIM to determine if the viewer is already launched and allows AIM to automatically launch the viewer prior to sending a DDE message; otherwise, the user is required to launch the IETM viewer prior to AIM sending a DDE message. For an IETM viewer whose window name is not constant, AIM will attempt to send a DDE message. If an application responds, then the DDE communication is successful; otherwise AIM will inform the user that (s)he must ensure that the viewer is already launched.

2. The current defined DDE command types, based on viewer authoring/publishing types, are:

1 = UAS 3.x or 4x 
2 = POKE ARCI 
3 = DYNATEXT 
4 = GUIDE READER 
5 = AIMSS 
6 = HTML 
7 = UAS 5.x 
8 = ATIS viewer 
9 = PMS Viewer (proprietary viewer for PMS documents) 
10 = Adobe Acrobat/Reader for displaying PDF files

An example for the SWS EDS viewer is as follows:

[DDE Message Information]
TMMIAPP
TECHINFO
C:\EDS\UAS\TMMIAPP.EXE
C:\EDS\IETM-DBS\CONFIG
[SHOW( 
)]
1
Electronic Documentation System
3.0 Other IETMs

3.1 Introduction

The AIM program extracts hierarchical information from other types of IETMs that are not based on an SGML file (either authored with SGML or able to provide an SGML file rendition of the database) and formats the information for import into the AIM database. The extraction program is written in Visual Basic 5.0 and requires a 32-bit operating system for execution. The extraction program requires various files to be available based on the particular type of IETM.

3.2 ARCI IETM

The Acoustic Rapid COTS Insertion (ARCI) IETM is built upon a relational database. Therefore, the extraction program examines the appropriate tables within the database to build the structure of the IETM. The extraction program requires the use of ODBC drivers in order to access and work with the relational database. These (32-bit) ODBC drivers are installed when the ARCI IETM is installed from the CD. The extraction can be completed for either IETM display using the proprietary viewer or HTML viewer.

3.2.1 Introduction

The ARCIEXTR.EXE program extracts hierarchical information from an IETM based on a Sybase relational database and formats the information for import into the AIM database. The extraction program is written in Visual Basic 5.0 and requires a 32-bit operating system for execution. In addition, 32-bit “Sybase SQL Anywhere 5.0” ODBC drivers are required for accessing the Sybase database. The extraction program requires that the database be registered with the 32-bit ODBC driver (which automatically is completed when installing the IETM).

3.2.2 Installing the ARCI IETM Extraction Program

A setup program has been created to install the ARCI extraction program and all related necessary files into appropriate directories. Run the setup program provided. The “arciextr.exe” and “arciextr.mdb” files will be installed in the AIM II program directory.

Note that it is assumed that the ARCI IETM is already installed from the ARCI IETM CD. If not, the ARCI IETM should also be installed at this point. This installation process will install the ARCI IETM as well as all (32-bit) ODBC drivers necessary for interfacing with the database, and will register the ARCI database with the ODBC driver.
3.2.3 Running the ARCI IETM Extraction Program

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “ARCI” option, and click on the Next button. The “IETM Extraction Utility / Extraction Output” screen will be displayed, which prompts the user to name the resulting output file created by the extraction program. (These initial screens are discussed and shown in “Running the SGML IETM extraction program.”) After the user types in a name and hits the Next button, the first screen for the ARCI Extraction program will appear. This screen is shown below.

![Screen showing ARCI IETM Extraction Utility](image)

This screen initially informs the user that it is expected that the ARCI database has already been registered with ODBC. (If the ARCI IETM was installed from the ARCI CD, this registration will already have been completed. If the ARCI IETM has not been installed, complete this process prior to attempting to run the extraction program.)

The user should click the “Extract” button to initiate the extraction process. A “Select Data Source” screen will appear, prompting the user to choose the appropriate database from which to extract the IETM structural information.
The user should select the “Machine Data Source” tab, highlight the data source name, and then click the OK button.

A screen that prompts for the type of viewer used for this IETM will be displayed. The viewer for the various IETMs may either be the PowerBuilder viewer or an HTML viewer (IETM is viewed via Internet Explorer). Select the appropriate type of viewer. If the viewer is HTML, a location for the HTML files must be selected. This should be the main directory for the HTML files, where the index is located; there may be other subdirectories within this main directory. In addition, the IETM may use some other types of files, so the location of files for AIMSS, AVI, PDF, and PCU files must be specified. (These directories are typically labeled clearly for the individual types of files.)

The extraction program will then complete the analysis of the ARCI database and the extraction of appropriate structural data of the IETM that should be imported into the AIM database. When this process is complete, a message box will appear informing the user that the ARCI IETM has been successfully extracted.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)
3.3 PDF Documents

3.3.1 Introduction

To allow Related Instructor Activities to be linked to individual pieces of a PDF document, a “PDF extraction” routine has been created. The PDF document is rendered through Adobe Acrobat. Typically a PDF contains a Table of Contents that is described by bookmarks. However, communicating with a PDF file from an external program can only be accomplished using named destinations that are established in the PDF files. These named destinations are destination paths that are not sensitive to specific page numbering. In some cases, these named destinations are set up to be the same name as bookmarks. The AIM IIETM / PDF extraction routine extracts the named destinations to allow links to be made from the Related Instructor Activities to the corresponding pieces of the PDF document. If only bookmarks are included in the PDF, then a conversion process needs to be made to save a copy of the bookmarks as named destinations. The resulting extraction is a flat list of named destinations, with no hierarchical information such as is seen when using bookmarks.
Note: The PDF document could have been rendered as a result of a process based on all information contained in an SGML file. In this case, the SGML extraction in section 2.0 should be used, with the appropriate Messaging information set to utilizing a “viewer type” of PDF. In this case, the node IDs in the SGML file must be carried forward as named destinations into the PDF file (or bookmarks which can be converted to named destinations via the proprietary product discussed below).

3.3.2 Installing the PDF Extraction Routine

The PDF extraction routine is part of the AIM module “IETM Extraction.exe”. No special installation is required beyond the normal AIM IInstallation.

3.3.3 Running the PDF Extraction Routine

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “PDF” option, and click on the Next button. The first screen specifically for the PDF Extraction program will appear. This screen requests the user to find the location of the PDF files to be extracted. After locating the file by using the Browse button, click on the Next button.

If the user checked the box indicating that a separate file is used to list all named destinations, then a screen will appear to prompt the user for this file. Browse to find the file, and then click on the Next button.
A screen will appear, prompting the user for the location of the result of the extraction process.
A screen will now appear indicating that all necessary information has been entered to complete the extraction. Click on the Extract button.

When this process is complete, a message box will appear informing the user that the PDF file has been successfully extracted.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)

3.4 PMS Documents

3.4.1 Introduction

To allow Related Instructor Activities to be linked to individual MIPs/MRCs, a “PMS Documents extraction” routine has been created. The PMS database is a Microsoft Access database. The routine extracts all MIPs/MRCs. If the extraction is performed on a “hull specific” CD, then the MIP/MRCs will be tied back to the work center, hull, etc. If the extraction is performed on a “reference” CD, then the extraction of the MIPs/MRCs is simply a list without a hierarchical structure tied to an activity.

3.4.2 Installing the PMS Documents Extraction Routine

The PMS documents extraction routine is part of the AIM module “IETM Extraction.exe”. No special installation is required beyond the normal AIM IInstallation.

3.4.3 Running the PMS documents Extraction Routine

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “PMS Documents” option, and click on the Next button. The first screen specifically for the PMS Documents Extraction program will appear. This screen requests the user to find the location of the PMS documents database to be extracted (*.pms). After locating the file by using the Browse button, click on the Next button.
A screen will appear, prompting the user for the location of the PMS Viewer. After locating the PMS Viewer by using the Browse button, click on the Next button.
A screen will appear, prompting the user for the location of the result of the extraction process.

A screen will now appear indicating that all necessary information has been entered to complete the extraction. Click on the Extract button. When this process is complete, a message box will appear informing the user that the PMS document file has been successfully extracted. After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)

3.5 Raster Technical Manuals

3.5.1 Introduction

To allow Related Instructor Activities to be linked to individual pages in an ATIS Raster Technical Manual, a “Raster Tech Manuals extraction” routine has been created.
3.5.2 Installing the Raster Technical Manuals Extraction Routine

The Raster Technical Manuals extraction routine is part of the AIM module “IETM Extraction.exe”. No special installation is required beyond the normal AIM installation. However, there are two files that are required as input to this extraction process: 1) a file listing individual documents and references within those documents which is created from the ATIS database using a SQL query; 2) a file listing all documents and their titles that were referenced in the previously mentioned file.

3.5.3 Running the Raster Technical Manuals Extraction Routine

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “Raster Tech Manuals” option, and click on the Next button. The first screen specifically for the Raster Tech Manuals Extraction program will appear. This screen requests the user to find the location of the SQL data file and document title file. After locating the files by using the Browse buttons, click on the Next button.

A screen will appear, prompting the user for the location of the ATIS Interface program, which is used for viewing individual Raster Tech Manuals. After locating the program by using the Browse button, click on the Next button.
A screen will appear, prompting the user for the location of the result of the extraction process. This creates a directory under which all individual Raster Tech Manual document extraction files will be stored.
A screen will now appear indicating that all necessary information has been entered to complete the extraction. Click on the Extract button. When this process is complete, a message box will appear informing the user that the Raster Technical Manual file has been successfully extracted.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.) Note that only the individual Raster Tech Manuals that are necessary should be imported into AIM.

3.6 XML-Based IETMs

3.6.1 Introduction

To allow Related Instructor Activities to be linked to XML-authored / HTLM-delivered IETMs, an “XML-based extraction” routine has been created.

3.6.2 Installing the XML-Based IETM Extraction Routine

The XML-based extraction routine is part of the AIM module “IETM Extraction.exe”. No special installation is required beyond the normal AIM Installation. However, there are two files that are required as input to this extraction process: 1) the XML IETM file; 2) the DTD/IETM “registration” file.

This extraction program works in a similar manner as the SGML extraction routine. The extraction program traverses the hierarchical nature of the XML IETM and writes out each pertinent node’s information to a flat file; the resulting flat file is then used to import the hierarchy information into the AIM database. This hierarchy essentially mimics the table of contents used in the IETM.

The extraction program utilizes functions to parse the XML file, based on the specified registration file. The extraction program traverses the hierarchy of the XML file and extracts pertinent elements and information. Because of the interactive nature of the IETM, not all elements in the XML file will be included in the AIM hierarchy. Elements that are included in the IETM solely for the interactive nature of the IETM are ignored by the extraction program (as dictated by the registration file) and are, therefore, not included in the “flat file”.
As each element is analyzed during the extraction process, it is determined if the element has an ID. Typically, an element is included in the AIM hierarchy if the element has an ID and it is not solely involved in the interactive nature of the IETM. If an element has an ID, then the AIM program can automatically position to the node in the IETM, utilizing browser-based technology. However, in some cases, the element is only a “container” for other elements in the SGML file and must be traversed and/or included even if there is no ID. An element with no ID is traversed if it is a container with sub-elements that should be included in the AIM hierarchy.

An element with no ID can be included in the AIM hierarchy if it is a “placeholder” in the IETM table of contents. However, the corresponding node information in the flat file indicates that there is no ID present and no messaging / attempt to launch will be completed for the node.

The program utilizes a “registration file” (ex. *.inf) that describes the IETM and those elements that will be included in the AIM hierarchy. This “registration” file describes the elements that are included in the hierarchy, the elements that should be included even if no ID, the elements that should be traversed, etc. This registration file is critical to the successful extraction of the IETM’s hierarchical content, which will be imported into the AIM database. The XML files (and the schema upon which the XML file is based, if necessary) should be examined carefully when setting up the “registration” file. (Note: With the XML file, case (uppercase/lowercase) is very important when indicating elements that should be included, excluded, etc.) The “registration” file should be able to be set up for a particular schema and utilized for any XML IETMs that make use of that specific schema. (Please see Section 2.3.1 under the SGML extraction description for a complete description of the registration file.)

3.6.3 Running the XML-Based IETM Extraction Routine

From the IETM Admin screen, choose the Extract option from the File menu. The “IETM Extraction Utility / Select an IETM type” screen will be displayed, which prompts you to select the type of IETM that you are extracting. Select the “XML-based” option, and click on the Next button. The first screen specifically for the XML-Based IETMs extraction program will appear. This screen requests the user to find the location of the XML file and the registration file. After locating the files by using the Browse buttons, click on the Next button.
A screen will appear, prompting the user to indicate how the IETM is viewed. Typically the XML-Based IETMs are viewed via the browser, but the option to view IETMs developed and delivered in AIMSS 4.x is available. After selecting the option for viewing the IETM, click on the Next button.
A screen will appear asking the user to indicate whether the IETM should be viewed via a browser or via alternative methods (ex. ATIS). (Note: This is currently set up in preparation for viewing through ATIS, but has not been practically used as of yet.) After selecting the option for viewing the IETM via a browser (or alternative), click on the Next button.
A screen will appear, prompting the user for the location of the HTML files that are delivered as the IETM package. After locating the directory by using the Browse buttons, click on the Next button.
A screen will appear, prompting the user for the location of the result of the extraction process. This creates a directory under which all individual XML extraction files will be stored.

![IETM Extraction Utility](image)

**HTML Files Directory**

Where is the main directory for the package of HTML files?

Use the Browse button or enter the directory where the HTML files (or subdirectories containing HTML files) are located, and then click Next.

Location: `C:\IETM\XML\Q70`

A screen will now appear indicating that all necessary information has been entered to complete the extraction. Click on the Extract button. When this process is complete, a message box will appear informing the user that the XML file has been successfully extracted.

After the extraction file has been created, the user should choose to Import the IETM to the AIM database in the Admin (IETM) module. (Please see the Administration Utilities section for complete details on importing the IETM into the AIM database.)
(This Page Intentionally Left Blank)
APPENDIX E
SCORM AND NILARS

1.0 Sharable Content Object Reference Model (SCORM) Overview ...................................E-1
1.1 SCORM Content Model Components ........................................................................E-1
2.0 Navy Integrated Learning Asset Repository System (NILARS) Overview .....................E-2
2.1 Potential Uses of AIM Data in NILARS Repository System ....................................E-2
3.0 Developing SCORM Data .............................................................................................E-4
3.1 SCORM Data Content ..................................................................................................E-4
3.2 Creating a SCORM Output for an Approved Course .................................................E-9
3.3 Detailed Contents of the AIM-to-SCORM Output Package .....................................E-10
(This Page Intentionally Left Blank)
1.0 SHARABLE CONTENT OBJECT REFERENCE MODEL (SCORM) OVERVIEW

SCORM is a set of specifications published by Advanced Distributed Learning (ADL) for developing, packaging and delivering high-quality education and training materials wherever and whenever they are needed. SCORM compliant courses leverage course development investments by ensuring that compliant courses are Reusable, Accessible, Interoperable and Durable.

- Reusable: easily modified and used by different developing tools.
- Accessible: can be searched and made available as needed by both learners and content developers.
- Interoperable: operates across a wide variety of hardware, operating systems, and Web browsers.
- Durable: does not require significant modifications with new versions of system software.

In the SCORM the Learning Management System (LMS) has the ability to determine what to deliver and when, and tracks student progress through the learning content through its Application Program Interface (API).

1.1 SCORM Content Model Components

SCORM Content Model Components define how the lower-level sharable, reusable, learning resources are aggregated to compose higher-level units of instruction.

Assets, Sharable Content Objects (SCOs), and Content Aggregations are components that are considered specifications of learning resources.

- Assets: electronic representations of media, text, images, sound, Web pages, assessment objects or other pieces of data that can be delivered to a Web client. The mechanism for binding Assets to Asset Metadata (data about data) is the Content Package. In the current AIM-to-SCORM output, the graphics used in TG sheets, Transparencies, and Test Items are the assets that are the output along with the entire course package. The repository will be able to identify these as separate assets and store them for reuse, independent of the course package (aggregation) or any of the SCOs (Topics) in which they are used.

- Sharable Content Object (SCO): SCO represents a collection of one or more Assets that include a specific launchable asset that utilizes the SCORM Run-time Environment to communicate with Learning Management Systems (LMSs). A SCO represents the lowest level of granularity of learning resource that can be tracked by an LMS using the SCORM Run-Time Environment. The Topic for a course and Lesson/Sections for Learning Objects are the SCO in the current SCORM output from AIM.
• Content Aggregation: A content aggregation is a map (content structure) that can be used to aggregate learning resources into a cohesive unit of instruction. AIM aggregates all the Topics (SCOs) in a course into the output package (aggregation), which has course level metadata as per SCORM v1.2 and 2004 requirements.

2.0 NAVY INTEGRATED LEARNING ASSET REPOSITORY SYSTEM (NILARS) OVERVIEW

NILARS is an initiative of the Office of Training Technology to obtain and employ state-of-the-industry content management systems for use by DoD.

• The object is to reduce costs by making individual data assets readily accessible and easily shared within DoD.
• The approach is to use commercially available learning content management software or remove individual data assets from their current packages (lessons, courses, IETMs, Etc.), standardize naming of the assets, restore them as individual assets, and make them accessible for reuse.
• The purpose of the NILARS is to provide a learning content object repository used by multiple developers at multiple sites and enable an environment where developers can create, store, reuse, manage, deliver and share learning content.

2.1 Potential Uses of AIM Data in NILARS Repository System

The goal of the Authoring Instructional Materials (AIM)-to-SCORM utility, funded jointly by the ADL CoLab Orlando and NAVAIR Orlando, is to leverage the huge body of existing classroom-based curricula for multiple additional uses in e-Learning and other areas. Refer to Figure 1.
The SCORM-compliant output of AIM (XML-based SCOs packaged at the course topic level) is designed to leverage that existing content as:

1) Input to emerging Electronic Performance Support Systems (EPSSs), such as Interactive Electronic Technical Manuals (IETMs)
2) The “70%” solution as input to Web-based Training (WBT) authoring tools for repurposing as asynchronous, just-in-time training opportunities – to support classroom training, as a parallel path for students unable to attend classroom training, or as a replacement for the traditional course
3) For delivery “as is” via a Learning Management System (LMS), particularly to support structured onboard training as envisioned by the Executive Review of Navy Training (ERNT)
4) As the baseline input to various Electronic Classroom Integration Software (ECIS) applications, such as General Dynamics Elite software used by the submarine community and the Electronic Lesson Plan (ELP) software used by Aegis Training and Readiness Center (ATRC) in their Automated Electronic Classrooms (AECs)

The NILARS Repository should eventually be the lynchpin of all this reuse of AIM-generated curricula data – the primary input from AIM being to NILARS, with automated configuration management, rights management, and user notification occurring via the repository system.

NOTE: To view the SCORM output in Internet Explorer 5.0 or 5.5 you need to install the Microsoft XML software.

To view the Topic files or Lesson/Sections (SCOs) created in the SCORM Output, extract the files contained in the zip file to a temporary directory and double click on the desired Topic XML files. The files will open in Windows Explorer.

3.0 Developing SCORM Data

3.1 SCORM Data Content

The SCORM Data represent the information required for development of Metadata (data about data) files. Metadata files provide a common nomenclature enabling learning resources to be described in a common way. Metadata can be collected in a catalog, as well as directly packaged with the learning resource it describes. Learning resources that are described with Metadata can be systematically searched for and retrieved for use and reuse. Aggregation (course) and SCO (topic) have certain metadata fields that are required. Asset (TG graphic) has only a small subset of those same fields required. The following categories contain mandatory elements (identified with an asterisk by the data entry box) and optional information.

AIM provides default information for the mandatory fields in the categories to develop Metadata files. When developing the course, the categories for the course, topics, and graphics can be edited by the developer from the SCORM Data window, which is accessible by selecting the desired course in the Course Select menu and selecting the Document main menu item and the SCORM Data sub-menu item or by clicking on the SCORM icon. The browser in the left pane allows you to open the desired folder to edit the categories. The course information can also be edited from Lesson Plan window (Cover Page) by selecting the Contents menu item and the SCORM Metadata sub-item. The information for individual Topics (SCOs) can be edited from the Lesson Plan (LP) window (COI) by highlighting the desired Topic, selecting the Contents menu item and clicking on the SCORM Metadata sub-menu item.
The information required for metadata depends on the Metadata Specification (NSCORM or SCORM) and the SCORM version (V1.2 or 2004) selected.

The metadata information is required if the metadata category is bolded.

When *NSCORM/2004, SCORM/2004, or SCORM/v1.2 Metadata Specification/Version* is selected for task-based Curriculum development, in accordance with NAVEDTRA 103A methodology, the following metadata categories will appear. Items in blue identify the v1.2 differences.

1.0 General - Provides administrative details on the learning object
   1.1 Identifier - Unique ID
      1.1.1 Catalog - Specify the classification system used to assign a unique ID
      1.1.2 Catalog Entry - Specify the value of the ID in the classification system
   1.2 Title - Give name to object
   1.3 Description - Provide a description of the key characteristics and issues associated with the object from the perspective of the developer for another developer to read
   1.4 Keywords - Provide keywords to aid in searching and browsing of content objects in a repository

2.0 Lifecycle - Provides a history of changes to an object through stages of development especially status of workflow processes
   2.1 Version - Specify the current version of an object. Should be updated as the object is modified over its lifecycle
   2.2 Status - Specify the completion status of an object along its lifecycle. Update this value as the object's status changes during workflow processes

3.0 metaMetadata - Describe the source and nature of the information in the metadata record itself. This information describes the metadata not the learning object. Thus, it is a record of who filled out the metadata for the learning object.
   3.1 Identifier - Identify metadata record with a unique ID. This is not the same as identifying the learning object
      3.1.1 Catalog - Specify the classification system used to assign a unique ID
      3.1.2 Catalog Entry - Specify the value of the ID in the classification system
   3.2 metadataSchema - Enter names of metadata schema used to create metadata for learning object
   3.3 metadataSchema - Enter names of metadata schema used to create metadata for learning object

   NOTE: Second metadataSchema not required for v1.2

4.0 Technical - Specify the technical details and technical requirements for an object
   4.1 Format - Specify the file formats used in the object
   4.2 Location - State the physical location of the objection
5.0 Rights - Specify the cost of use or copyright information for the object

5.1 Cost - Specify whether or not the object requires payment

5.2 Copyright and other Restrictions - Specify whether or not the object has any restrictions on use

When *NSCORM Specifications* is selected the SCORM 2004 version is selected automatically for Learning Object development. The following metadata categories will appear.

**NOTE:** When SCORM Specification is selected with version 2004 or v1.2 the Security Classification portion (10.0) is absent and different items are bolded for required entry. Also, the Location (4.3) is added for v1.2.

1.0 General - Provides administrative details on the learning object

1.1 Identifier - Unique ID

1.1.1 Catalog - Specify the classification system used to assign a unique ID

1.1.2 Catalog Entry - Specify the value of the ID in the classification system

1.2 Title - Give name to object

1.3 Language - Specify primary language of object

1.4 Description - Provide a description of the key characteristics and issues associated with the object from the perspective of the developer for another developer to read

1.5 Keywords - Provide keywords to aid in searching and browsing of content objects in a repository

1.7 Structure - Specify the relationship between object components

2.0 Lifecycle - Provides a history of changes to an object through stages of development especially status of workflow processes

2.1 Version - Specify the current version of an object. Should be updated as the object is modified over its lifecycle

2.2 Status - Specify the completion status of an object along its lifecycle. Update this value as the object's status changes during workflow processes

2.3 Contribute - Specify the person or organization that contributed to the object

2.3.1 Role - Describe the role that the contributor played in the object's development

2.3.2 Entity - Specify the name of the person or group working on the object

Role Name - Specify the name of the person or group working on the object
Role Address
Role Email

2.3.3 Date – Specify a date for a contribution

Date - Specify a date for a contribution
Date Description - Specify a date for a contribution
3.0 metaMetadata - Describe the source and nature of the information in the metadata record itself. This information describes the metadata not the learning object. Thus, it is a record of who filled out the metadata for the learning object.

3.1 Identifier - Identify metadata record with a unique ID. This is not the same as identifying the learning object

3.1.1 Catalog - Specify the classification system used to assign a unique ID
3.1.2 Catalog Entry - Specify the value of the ID in the classification system

3.2 Contribute - States who developed the metadata for the object. This is not necessarily the same person or group who developed the learning object

3.2.1 Role - States the workflow process role of the person creating the metadata record (not the learning object)
3.2.2 Entity - Name of the person or group creating the metadata record

Role Name - Name of the person or group creating the metadata record
Role Address
Role Email

3.2.3 Date – State the date the metadata record is created or changed

3.2.3.1 Date - Enter value of the date
3.2.3.2 Date Description - Enter text description of issues or activities relating to the date this metadata record is made

3.3 metadataSchema - Enter names of metadata schema used to create metadata for learning object

4.0 Technical - Specify the technical details and technical requirements for an object

4.1 Format - Specify the file formats used in the object

4.7 Duration - Specify the average time it takes to complete an object

Time(HH:MM:SS) - Specify the average time it takes to complete an object
Description - Specify the average time it takes to complete an object

5.0 Educational - Provides information on the educational nature of the object

5.1 Interactivity Type – Specify the learning mode intended when using the object
5.2 Learning Resource Type - Specify the type of learning object from a learning event perspective

5.3 Interactivity Level – Describe the degree of user interactivity while using the object in a learning event
5.5 Intended End Use Role - Describe the type of user intended for object
5.6 Context - Describe the type of environment intended for using the object
5.8 Difficulty - Specifies how hard the learning material is in the object
5.9 Typical Learning Time - Specifies an estimated amount of time for the learner to go through the material in the object
  5.9.1 Duration (Days)
  5.9.2 Duration(HH:MM:SS) – Specifies time value
5.9.2 Typical Learning Time Default- Describe characteristics or issues associated with the time value assigned
5.10 Description - Describe how the learning object should be used in a learning event
5.11 Language - Specify primary language of intended user of object
6.0 Rights - Specify the cost of use or copyright information for the object
  6.1 Cost - Specify whether or not the object requires payment
  6.2 Copyright and other Restrictions - Specify whether or not the object has any restrictions on use
  6.3 Description - Describe issues or provide context details on copyright information for the object
7.0 Relation - Specify relationships among this learning object and other learning objects. These are strong relationships not the ordering of objects for a learning event which is handled by the Sequencing and Navigation data model.
  7.1 Kind - Specify nature of the relationship between this learning object and another object.
  7.2 Resource - Defines the second object
    7.2.1 Identifier - Defines unique ID for the second object.
      7.2.1.1 Catalog - Defines the classification system for the ID of the second object.
      7.2.1.2 Catalog Entry - Defines the value of the ID of the second object.
    7.2.2 Resource Description - Identify metadata record with a unique ID. This is not the same as identifying the learning object
8.0 Annotation - Provides comments on the educational use of the object to enable better understanding among developers of how to best use the object.
  8.1 Entity - States the name of the person(s) creating the annotation
    Role Name - States the name of the person(s) creating the annotation
  8.2 Annotation Date - States the date the annotation was created
    8.2.1 Date - States the date the annotation was created
    8.2.2 Date Description - Enter text description of the date
  8.3 Annotation Description - Enter text description of the annotation
9.0 Classification - Describe object using external classification systems
  9.1 Purpose - Describe the reason for classifying the object with an external classification system
9.2 TaxonPath - Defines the taxonomy nodes used from the external classification systems
  9.2.1 Source - Defines the name of the taxonomy used
  9.2.2 Taxon - Defines the value of the taxonomy node(s) used. Multiple nodes can be assigned from one taxonomy.
    9.2.2.1 Taxon ID - ID value used in the external taxonomy
    9.2.2.2 Taxon Entry - Text value of the ID value used in the external taxonomy

9.3 Classification Description - Comments on why external classification systems used or associated issues

9.4 Keywords - Keywords to describe the external classification system or why it is used

10.0 Security Classification – Provide security classification for learning object
  10.1 Type - Describe the type of the classification whether for US, nonUS, joint, foreign, dissemination, SCI, or others
  10.2 Classified By – Provide security classification that meets US and additional requirements
    10.2.1 Name - Provide the name of the individual who classifies the content
    10.2.2 Agency - Provides the controlling authority for the classification of the content
    10.2.3 Date – Provides the date for the original classification of the content
    10.2.4 Reason – Provides the reason for classifying content at a given level
  10.3 Marking – Provides the actual security marking for the type of classification designated in the Classification Type Element

3.2 Creating a SCORM Output for an Approved Course

The SCORM Generated Data Output can be created for either SCORM version 1.2 or SCORM 2004.

To select the desired SCORM output version:

Step 1 Log into AIM II.

Step 2 From the AIM main menu click on the Options menu item and the Preferences option.

Step 3 From the User Preferences window click on the Advanced tab.
Step 4 Select the desired Metadata Specification by clicking on the down arrow in the **Metadata Spec** field. Select either NSCORM, or SCORM Metadata Specification.

Step 5 If SCORM was selected as the Metadata Spec, select the desired version of SCORM (1.2 or 2004) by clicking on the down arrow in the **SCORM Version** field. 2004 is automatically selected for NSCORM.

Step 6 Click on the **Apply** button and then the **OK** button to close the User Preferences window.

**NOTE:** SCORM output can be generated for an Approved course using the SCORM Utility.

Step 7 Select the **Course** menu item and the **Select** sub-menu item.

Step 8 From the Course Select menu: highlight the Approved course that you want to create the SCORM files for and click on the **Select** menu item.

Step 9 Click on the Document menu item and the **SCORM Data** sub-menu item or click on the SCORM icon.

Step 10 The SCORM output can be created for the entire course by opening the course folder in the browser and selecting the **File** menu item and the **Generate SCORM Output** sub-menu item. AIM will output the Topic SCOs to a directory titled by CIN, Rev and Change, which will contain a zip file. This zip file can be sent to NILARS to import the aggregation, SCOs, and assets. The key element is the Package Identification File (PIF) that enables the repository, i.e., NILARS, to understand the contents.

Step 11 To view the Topic files (SCOs) created in the SCORM Output, extract the files contained in the zip file to a temporary directory and double click on the desired Topic XML files. The files will open in Windows Internet Explorer.

### 3.3 Detailed Contents of the AIM-to-SCORM Output Package

The files contained in the AIM-to-SCORM output package are generated to conform to SCORM Version 1.2 or 2004 and include:
1. imsmanifest file…which contains the “structure” or organization of the course. The content of this file includes references and locations of all SCOs, raw media files, metadata files, and supporting files. It also lists dependencies between the files.

2. SCOs…are associated with each Topic of the course or Lesson/Sections in the Learning Object Module and are generated as XML content. A corresponding XSL stylesheet is referenced in each SCO in order to have the XML rendered to HTML by the Internet Explorer 5.0 browser (with MSXML 3.0 installed in “replace” mode). (Ex. 1-1.xml) If Internet Explorer 6.0 or later is used, MSXML does not have to be installed in replace mode.

3. Graphics files (Raw media files)… are stored in the graphics directory of the package. AIM-to-SCORM output process converts the PCX files used in AIM to JPEG files that can be viewed through the Web browser.

4. Metadata files for the course, SCOs, and graphics files. (Ex. 1-1_meta.xml; 20000001_meta.xml). These metadata files correspond to the IMS spec.

5. API files…which are necessary for communication with the LMS. These files are referenced in the rendered HTML files.

6. DTD and entity files… specifically related to the SCOs. Because the SCO content is in XML format, there are corresponding DTD and entity files associated with the SCOs. (Topic.dtd, TaskandMaterial.ent, TestInfo.ent, TextContent.ent)

7. XSL stylesheet (Topic.xsl) and Cascading Style Sheet (SCORMTopic.css)… Because the SCOs are generated as XML content, there is an XSL stylesheet referenced with the SCO in order to allow the XML content to be rendered as HTML and displayed in the IE 5.0 browser (as described previously). A Cascading Style Sheet (CSS) is associated with the rendered HTML document.

The AIM II-to-SCORM output does validate against the final SCORM v1.2 and 2004 Conformance Suite software posted at ADLnet.org.
APPENDIX F
CNATT TPP AND TCCD DEVELOPMENT

1.0 TRAINING PROJECT PLAN (TPP) ................................................................. F-1
  1.1 ELEMENTS OF A TPP .................................................................................. F-1
  1.2 USING THE AIM II TPP MODULE ............................................................... F-2
    1.2.1 Overview of the AIM II TPP Module .................................................. F-2
  1.3 CREATING A NEW, REVISION, OR CANCELLATION TPP ......................... F-4
    1.3.1 Development of a New TPP ................................................................. F-4
    1.3.2 Development of a Revision TPP .......................................................... F-8
    1.3.3 Development of a Cancellation TPP ..................................................... F-11
  1.4 SELECTING A TPP ..................................................................................... F-13
  1.5 TPP CONTENTS .......................................................................................... F-14
    1.5.1 Compensation ....................................................................................... F-14
    1.5.2 Course Overview/Comments ............................................................... F-17
    1.5.3 Development Method .......................................................................... F-18
    1.5.4 Justification .......................................................................................... F-19
    1.5.5 Milestones ........................................................................................... F-20
    1.5.6 Safety Risks and Hazardous Materials .............................................. F-21
    1.5.7 Summary of Differences ...................................................................... F-22
    1.5.8 Selecting Learning Sites ....................................................................... F-23
  1.6 TPP OPTIONS ............................................................................................. F-37
    1.6.1 Lock/Unlock ....................................................................................... F-37
    1.6.2 Grant Privilege ..................................................................................... F-38
    1.6.3 Importing CNATT Course and ERL Data ............................................ F-38
    1.6.4 Print Preview ...................................................................................... F-40
    1.6.5 Print .................................................................................................... F-41
  2.0 TRAINING COURSE CONTROL DOCUMENT (TCCD) ................................. F-42
  2.1 ELEMENTS OF A TCCD ............................................................................. F-42
    2.1.1 Elements of TCCD Front Matter ......................................................... F-42
    2.1.2 Elements of TCCD Annexes ................................................................ F-43
  2.2 USING THE AIM II TCCD MODULE ........................................................ F-43
    2.2.1 Overview of the AIM II TCCD Module .............................................. F-44
  2.3 SELECTING A TCCD .................................................................................. F-45
  2.4 TCCD CONTENTS ...................................................................................... F-46
    2.4.1 Foreword ............................................................................................. F-47
    2.4.2 Course Overview/Comments ............................................................... F-47
    2.4.3 Supplying Trainee Data ....................................................................... F-48
    2.4.4 Summary of Differences ...................................................................... F-50
    2.4.5 Selecting a Learning Site ...................................................................... F-51
  2.5 TCCD OPTIONS ........................................................................................ F-56
    2.5.1 Lock and Unlock Options .................................................................... F-56
    2.5.2 Grant Privileges .................................................................................. F-58
    2.5.3 Importing CNATT ERL Data ............................................................... F-58
    2.5.4 Print Preview and Print Options ......................................................... F-59
  2.6 COURSE MAINTENANCE ........................................................................ F-61
1.0 TRAINING PROJECT PLAN (TPP)

A curriculum development project is a complex undertaking, bringing together a wide range of human and material resources to create quality training. The task based curriculum development process, in accordance with NAVEDTRA 130B, consists of six phases, beginning with the Plan Phase. This phase consists of gathering information and building the plan for training material development, revision, or cancellation. The output product of this phase is the Training Project Plan (TPP). When approved, the TPP becomes the authorization to undertake a course revision or cancellation, or a new course development project, and initiate resource requisitions.

Course development and, often, course revisions require the identification of resources to develop or implement the proposed course. Resources fall into four broad categories: (1) facilities, (2) funding, (3) personnel, and (4) equipment. All four categories require long lead-time planning. An approved TPP is the authority to submit requests for resources.

In the case of a course cancellation, the approved TPP provides justification for the action and identification of resources for reallocation.

1.1 ELEMENTS OF A TPP

Specific elements of data and information shall include the following items where applicable:

- Cover Page
- Table of Contents
- Course Data
- Course Overview
- Justification
- Safety Risks and Hazardous Materials exposure
- Curriculum Development Method
- Resources Requirements
- Compensation
- Milestones
- Summary of Differences

**NOTE:** When the TPP is locked, work can begin on the next step in the project, the Analyze Phase.
1.2 USING THE AIM II TPP MODULE

The AIM II TPP Module provides all of the tools to develop New, Revision, and Cancellation TPPs for CNATT curricula. The program will present a series of windows starting with the AIM II window. These windows have a menu across the top and a tool bar below the menu. The tool bar contains icons that represent different program features.

You can select options from the menu in two ways, by pressing the ALT key and the underlined letter, or by clicking on the option with the left mouse button. With either method, selecting an option from the menu or the button bar brings up windows that allow you to enter the data necessary to complete a TPP.

If you are working on a new TPP, the fields presented in the window will be blank. You must provide the appropriate information by either typing the information in the correct field or selecting from a series of drop-down menus. If you are working on a TPP that is in progress or completed, you can edit existing data and/or provide new data as necessary. Each window is explained in this user's manual with instructions on how to fill in the necessary data.

1.2.1 Overview of the AIM II TPP Module

Each of the following steps is explained in further detail in this guide. These paragraphs are meant as a quick reference for getting around the software.

You can start a new TPP by selecting the Course menu item and the New sub-menu item on the AIM II main menu bar, or clicking on the "New" icon from the tool bar. If you are working on an existing TPP, choose the Course menu item and the Select sub-menu item from the main menu bar or click on the "Select Course" icon. A list of available courses will appear. Select the course to work on from the list by either highlighting the desired course and then clicking on the Select menu item, or by double clicking on the desired course.

From the Course Select window you can select the Options menu item and the Copy option to copy an existing TPP or Course. Copying a TPP or Course will open the Course Information window, where you can enter the CIN, Revision, Change, and Title of the Course that will be Developed, Revised, or Canceled, provided the CIN does not exist in the AIM II database.

Copying a TPP produces an Incomplete TPP with all the data of the TPP copied, no associated CTTL or TCCD, and allows the user to select either Revision or Cancellation TPP. Copying a Course produces a complete TPP with a copy of all the training materials contained in the Course that was copied. This option allows you to create a New or Cancellation TPP for the CIN entered in the Course Information window.
From the Course Select window, highlighting the desired course and selecting the Options menu item and the Maintain/Revision option allows you to create a Revision TPP and Course for the highlighted course.

Selecting the New sub-menu item opens the TPP window and allows you to create a New, Revision or Cancellation TPP. If you select a course from the Course Select window, AIM II will return you to the main menu and the TPP through TG icons will be enabled for the selected course. A new course will have blank fields in the TPP window, while an existing course will have data in the fields. If you enter a Revision letter in the Rev field of the new TPP the TPP type will change from New to Revision. After completing or modifying the data in the window, you must select the Edit menu item and the Save sub-menu item to save the changes. If you do not wish to save your changes, you can select Cancel. You must either save or cancel before proceeding further.

AIM develops a course tree structure when the TPP cover page is saved to the database. From this browser you can open folders of the various elements of the course. Clicking on a folder and selecting the Options menu item and the GoTo sub-menu item will open the desired portion of the course. If a folder contains sub-elements, the contents will be displayed on the upper right hand side of the grid. Double clicking on the desired folder in the upper right hand grid will open the desired window. The lower right hand portion of the grid displays Summary data contained in the folder or sub-element item highlighted. A check block is provided for each folder in the course tree. As you complete development of each folder, click on the check block to identify that this item is complete. Private or public notes can be added to the training material items for management of the curriculum by clicking on the desired folder, selecting the Options menu item and the Edit Note option.

You can also access the different portions of the course selected by clicking on the Document menu item and clicking on the desired sub-menu item. This method allows you to access all elements contained within the document. Each document also has an associated icon. For ease of explaining the steps involved in developing the different portions of each training material item this User’s manuals directs you to use the Document sub-menu item or associated icons.

To identify where the proposed course will be taught, you will select the TPP window Contents menu item and the Learning Sites sub-menu item. You will be provided with a "Learning Site Summary" window. Here you can enter the Course Data Processing (CDP) code, course length in calendar days, class minimum and maximum capacity, class convenings per year, and student throughput per year for each selected site.
NOTE: A CDP code denotes a course and a location for NITRAS processing. This code may not be available at this point in the development process. This entry is optional.

After you have entered the data for the Learning Site Summary window, you can select RRL to access the TPP Resource Requirements List (RRL) for the site highlighted. From here you can select RRL items to be used in the course. Selecting Resource allows you to select RRL types as well as input manpower, funding, and facility data.

NOTE: The first Learning Site selected will provide the default RRL items available. AIM II will allow you to use the RRL data from the first site selected for subsequent sites. This option will become available when another site is selected.

Returning to the TPP window, you can select Contents to provide the information for safety risks and hazardous materials, justification, development method, compensation, milestones, and course overview/comments.

You can lock your TPP from the Options menu item when all the data required has been added.

NOTE: When the TPP is locked for the first time, shared data will be copied to the TCCD Module. This will only happen the first time a New or Revision TPP is locked.

1.3 CREATING A NEW, REVISION, OR CANCELLATION TPP

There are three types of TPPs: New, Revision, and Cancellation. There are different methods to develop each type, depending on whether you desire to use existing data in the database or not. The AIM II software can be installed to support either NAVEDTRA 130B, which uses a Resource Requirements List, or to support Center for Naval Aviation Technical Training (CNATT), which uses an Equipment Requirement List (ERL). If the software has been installed to support CNATT the associated block will contain a check mark on the TPP and TCCD cover pages.

1.3.1 Development of a New TPP

If you need to develop a new TPP for a course, you will either select the Course menu item and the New sub-menu item, which will open a TPP window with blank fields, or highlight a course which contains a TPP similar to the TPP to be developed in the Course Select window and select the Options menu item and the Copy TPP/Course option.
NOTE: Learning Sites and Agency information must be included in the database prior to the development of the first TPP. This information is provided through the AIM II Utilities menu item and the Learning Site and Agency sub-menu items. For more information refer to Appendix B.

Figure 1. Training Project Plan (TPP) Window

To create a New TPP using the Course menu item and the New sub-menu item:

Step 1 From the AIM II window, select the **Course** menu item and the **New** sub-menu item, or click on the New Course icon.
You will be presented with the Training Project Plan (TPP) window (Figure 1). If CNATT is selected in the TPP this means that your database has been enabled for importing and exporting CNATT data for your courses and the Site RRL will contain the ERL data. ERL Data can be imported for a course as long as the TPP is present.

The cursor will now be in the first field that will be blank. Use the Tab key to move from field to field, or position the cursor in the desired field.

**NOTE:** As a safety precaution, Tabbing between fields does not take you to the Revision or Change fields, you have to click in them explicitly to modify the contents. The ability to modify the Rev and Chg has been provided to permit development of a revision for a course that does not exist in the AIM II database or re-development of a course that exists in a different medium. When the cover page of the TPP is saved these fields can no longer be edited.

---

**Step 2** If CNATT extract files are available Import CNATT Course Data and ERL Data in accordance with paragraph 1.6.3 below. If CNATT Data is currently unavailable type the Course Identification Number (CIN). The CIN can be modified for the New course until the TPP has been approved.

**Step 3** Select "Prepared By" and "Prepared For" from the drop-down menus.

Clicking on the down arrows will scroll the available options. Select the correct item by clicking the left mouse button.

**Step 4** Type the complete Course Title. Do not use abbreviations.

**Step 5** Type the Short Title of the course. Recognized acronyms can be used.

**Step 6** Identify the Training Type.

**Step 7** Identify the Work Center.

**Step 8** Type in the Purpose of Course with respect to the following questions:

a. Who is to be trained?

b. What job will the person be trained to perform?

c. What is the degree of qualification, or how well will the person be able to perform the job?

d. Where will the person utilize the training?

e. What are the conditions under which the graduate will perform on the job?
Step 9  Type in the Occupational Classification/prerequisites for the course.

You can use the **TAB** key to advance forward through the fields or use the mouse to position the cursor. To go backwards through the fields, press **Shift + Tab**.

---

**CAUTION:** When the TPP is completed and locked the TPP information is copied to the Training Course Control Document (TCCD). The copy function is only executed when the TPP is initially locked and will not be accomplished when the TPP is unlocked, edited, and locked again. Do not lock the TPP until all data required has been entered. The CIN can be edited in the TCCD after the TPP has been locked.

---

Step 10  Click on the **Edit** menu item and the **Save** sub-menu item.

If you do not want to save the TPP information that you have entered, you can select **Cancel**.

Step 11  Refer to paragraphs 3.5 and 3.6 to complete the TPP.

**To create a New TPP from an existing TPP:**

Step 1  From the AIM II window, select the **Course** menu item and the **Select Course** sub-menu item.

Step 2  From the Course Select window, highlight the Course that will be copied and select the **Options** menu item and the **Copy** option.

Step 3  To copy the TPP only, select the **TPP** sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN and edit the Title of the new course.
   b. Click on the **Edit** menu item and the **Save** sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the course select window.

Step 4  To copy the entire Course, select the **Course** sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, and Chg of the new course and edit the Title.
   b. Click on the **Edit** menu item and the **Save** sub-menu item.
   c. Click on Yes to confirm you want to copy the Course. AIM II will copy the Course and return you to the course select window.
Step 5 From the Course Select window highlight the new course and click on the Select menu item.

Step 6 From the AIM II menu click on the TPP icon.

Step 7 Refer to paragraphs 1.5 and 1.6 to complete the TPP.

1.3.2 Development of a Revision TPP

Development of a Revision TPP can be undertaken to develop a revision for a course that exists in the AIM II database or does not exist in the AIM II database. Re-development of a revised course that exists in a different medium will also result in a Revision, whether the developer initially selects the New menu item or utilizes the copy option because entry in the Rev field is required.

To create a Revision TPP for a course contained in the AIM II database using the Course menu item and the Select Course sub-menu item:

Step 1 From the AIM II window; select the Course menu item and the Select Course sub-menu item.

Step 2 From the Course Select window highlight the Course that you want to revise and select the Options menu item and the Maintain/Revision option.

Step 3 At the prompt "Are you sure you want to create a Revision for this Course?" click on the Yes button to proceed or the No button to return to the Course Select window.

Step 4 At the prompt "Copy LP/TG information with Course?" click on the Yes button to copy the entire LP/TG of the current baseline for the revision or click on No to copy the approved course less the user developed Discussion Points (DPs) and Related Instructor Activities (RIAs).

NOTE: If the LP/TG Information is not copied, the Instruction Sheets, developed for the baseline course, are available for selection for the RIAs when developing the new LP.

Step 5 After AIM II creates the revision for the course, it will return you to the Course Select window and the revision created will be highlighted. Click on the Select menu item and AIM II will return you to the AIM II menu.
Step 6  Select the **Document** menu item and the **Training Project Plan (TPP)** sub-menu item or click the TPP icon to open the TPP window.

Step 7  Refer to paragraphs 1.5 and 1.6 to edit the TPP for the Revision.

**To create a Revision TPP for a course not contained in the AIM II database using the Course menu item and the New sub-menu item:**

Step 1  From the AIM II window; select the **Course** menu item and the **New** sub-menu item.

You will be presented with the Training Project Plan (TPP) window and your cursor will be in the first field, which will be blank. Use the **Tab** key to move from field to field.

Step 2  If CNATT extract files are available Import CNATT Course Data and ERL Data in accordance with paragraph 1.6.3 below. If CNATT Data is currently unavailable type the Course Identification Number (CIN). The CIN can be modified for the New course until the TPP has been approved.

**NOTE:** As a safety precaution, Tabbing between fields does not take you to the Revision or Change fields, you have to click in them explicitly to modify the contents. The ability to modify the Rev and Chg has been provided to permit development of a revision for a course that does not exist in the AIM II database or re-development of a course that exists in a different medium. When the cover page of the TPP is saved these fields can no longer be edited.

Step 3  Click on the Rev field and enter the alpha character for the Revision. The TPP type will change from New to Revision when the alpha character is entered into the field.

Step 4  If you are re-developing a revised course that does not exist in the AIM II database and this course has undergone change(s) enter the change number in the Chg field.

Step 5  Select "Prepared By" and "Prepared For" from the drop-down menus. Clicking on the down arrows will scroll the available options. Select the correct item by clicking the left mouse button.

Step 6  Type the complete course title. Do not use abbreviations.
Step 7  Type the Short Title of the course. Recognized acronyms can be used.

Step 8  Identify the Training Type.

Step 9  Identify the Work Center.

Step 10  Type in the Purpose of Course with respect to the following questions:
    a. Who is to be trained?
    b. What job will the person be trained to perform?
    c. What is the degree of qualification, or how well will the person be able to perform the job?
    d. Where will the person utilize the training?
    e. What are the conditions under which the graduate will perform on the job?

Step 11  Type in the Occupational Classification/prerequisites for the course.

CAUTION: When the TPP is completed and locked the TPP information is copied to the Training Course Control Document (TCCD). The copy function is only executed when the TPP is initially locked and will not be accomplished when the TPP is unlocked, edited, and locked again. Do not lock the TPP until all data required has been entered.

Step 12  Click on the **Edit** menu item and the **Save** sub-menu item.

If you do not want to save the TPP information that you have entered, you can select **Cancel**.

Step 13  Refer to paragraphs 1.5 and 1.6 to complete the TPP.

**To create a Revision TPP for a course not contained in the AIM II database using the Course menu item and the Select Course sub-menu item:**

Step 1  From the AIM II window; select the **Course** menu item and the **Select Course** sub-menu item.

Step 2  From the Course Select window, highlight the Course that will be copied and select the **Options** menu item and the **Copy** option.
Step 3 To copy the TPP only, select the TPP sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Type the Course Identification Number (CIN), Rev, and Chg as appropriate and edit the Title of the new course.
   b. Click on the Edit menu item and the Save sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the course select window.

Step 4 To copy the entire Course, select the Course sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, Chg of the course and edit the Title.
   b. Click on the Edit menu item and the Save sub-menu item.
   c. Click on Yes to confirm you want to copy the Course. AIM II will copy the Course and return you to the course select window.

Step 5 From the Course Select window highlight the new course and click on the Select menu item.

Step 6 From the AIM II menu click on the TPP icon.

**NOTE:** The TPP has a Complete Status when Copy/Course is performed and an Incomplete Status when Copy/TPP is performed.

Step 7 Refer to paragraphs 1.5 and 1.6 to complete the TPP.

1.3.3 Development of a Cancellation TPP

To develop a Cancellation TPP for a course contained in the AIM II database:

Step 1 From the AIM II window; select the Course menu item and the Select Course sub-menu item.

Step 2 From the Course Select window, highlight the Course that the Cancellation TPP will be developed for and select the Options menu item and the Copy option.

Step 3 Select the Training Project Plan sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN and append CAN to the end of the CIN for the development of the Cancellation TPP.
Step 4 From the Course Select window highlight the Cancellation course and click on the **Select** menu item.

**NOTE:** When the TPP is identified as a Cancellation TPP by the software the Course Select window will contain dashes in the Rev and Chg columns.

Step 6 Refer to paragraphs 1.5 and 1.6 to complete the appropriate portions of the Cancellation TPP.

There are two methods to develop a Cancellation TPP for a course not contained in the AIM II database:

1. The first method is to use paragraph 1.3.1 (Development of a New TPP) using the Course menu item and the New sub-menu item and click on the Training Project Plan (TPP) window Cancellation button.
2. The second method is to use the Course Select window Copy option to copy an existing TPP and edit the fields for the TPP you are developing.

To develop a Cancellation TPP for a course not contained in the AIM II database using the Copy TPP option:

Step 1 From the AIM II window; select the **Course** menu item and the **Select Course** sub-menu item.

Step 2 From the Course Select window, highlight the Course that will be copied and select the **Options** menu item and the **Copy** option.

Step 3 To copy the TPP, select the **TPP** sub-menu item. AIM II will open the Course Information window. Perform the following:

a. Enter the CIN, Rev, and Chg as appropriate and edit the Title of the course for the development of the Cancellation TPP.

b. Click on the **Edit** menu item and the **Save** sub-menu item.

c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the course select window.

Step 4 From the Course Select window highlight the new course and click on the **Select** menu item.
Step 5 From the AIM II menu click on the TPP icon.

**NOTE:** When the TPP is identified as a Cancellation TPP by the software the Course Select window will contain dashes in the Rev and Chg columns.

Step 6 Refer to paragraphs 1.5 and 1.6 to complete the appropriate portions of the Cancellation TPP.

### 1.4 SELECTING A TPP

Once the TPP window fields have been saved to the AIM II database, you can exit the TPP and return to it later for editing or modification.

There are four different ways to access a TPP window after the course has been selected from the Course Select menu:

1. From the AIM II main menu select the **Document** menu item and the **Training Project Plan (TPP)** sub-menu item.
2. Click on the TPP icon.
3. From the course tree structure click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TPP element in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.
4. From the course tree structure click on the TPP folder, select the **Options** menu item and the **GoTo** sub-menu item. Opening the TPP folder can provide Summary or Note data on the right hand portion of the course tree grid if the **View** menu sub-items (**Note** or **Summary**) have been checked. Summary data includes the information contained in the TPP window and Note data contains Personal and/or Private Notes recorded by developers.

If the TPP window cover page is complete and you desire to work on an element within the TPP you can either select the element from the Contents menu item in the TPP window or double-click on the TPP folder in the course tree structure. Double-clicking the TPP folder or clicking on the “+” box next to the TPP will expand the tree information to include the contents of the TPP. Once the tree has been expanded you can click on the element desired and can exercise **Options** menu sub-items (**Edit Note** and **GoTo**) and **View** menu sub-items (**Note** and **Summary**).
If the Status field of the course selected from the Course Select window is Incomplete you can modify all of the data in the window except the Rev, Chg, and Status fields. If the status of the course selected is Locked, you will have to select the TPP window Options menu item and the Unlock option to edit the fields. Once Unlocked, the Status field will change to Complete which signifies the TPP can be edited but the information will not be copied to the TCCD. To save your changes to the TPP window you must select the Edit menu item and the Save sub-menu item. (If you do not save the cover page data after editing, you will not be able to access the Options or Contents menu.)

1.5 TPP CONTENTS

After saving the data in the TPP window fields and selecting a TPP, you can edit or create the TPP Contents.

The elements of the TPP contents are:

- Compensation
- Course Overview/Comments
- Development Method
- Justification
- Milestones
- Safety Risks and Hazardous Materials
- Summary of Differences
- Learning Sites

1.5.1 Compensation

Use this window to provide recommended source of compensation for both manpower and funding. Identify possible course cancellations/reductions, cross utilization of instructors, etc.

To enter TPP Compensation:

From the TPP window; select the Contents menu item and the Compensation sub-menu item. From the drop-down menu you will have two options: Manpower and Funding.
To enter the TPP Manpower data:

Step 1  Click on **Manpower** from the TPP Compensation drop-down menu. This will open the TPP Manpower Compensation window.

Step 2  In the **Site Name** field either select the Learning Site from the drop-down list or type in the name of the Learning Site.

*After each entry press the TAB key to advance to the next field. You can use Shift+Tab to move backwards. The mouse can also be used to select the desired field.*

**NOTE:** You will only be allowed to enter each site once. To enter more than one entry in the Number/Type Billets category, position your cursor at the end of the first entry in that field. Hold down the <Ctrl> key and press <Enter>.

Step 3  Enter the Number/Type of Billets e.g., 2/E-6 4245. Use <CTRL> and <ENTER> to add additional Number/Type of Billets entries to the same field.

Step 4  Type in the source of the funding, by positioning the cursor in the Source field and typing in the information.

Step 5  Estimate the manpower shortfall, if any, and enter the shortfall.

**NOTE:** The TAB key will allow you to advance to the next field or line without having to save each entry.

Step 6  Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries.

Step 7  Click on the **Exit** menu item to return to the TPP window.

To enter the TPP Funding Compensation data:

Step 1  From the TPP window select the **Contents** menu item and the **Compensation/Funding** sub-menu items. This will open the TPP Funding Compensation window, *Figure 2*. 
Step 2  In the *Site Name* field either select the Learning Site from the drop-down list or type in the name of the Learning Site.

Step 3  Enter the Dollar Amount. You can enter whole numbers. The program will automatically format the number to a currency entry including two decimal places.

Step 4  Type in the name of the funding source.

Step 5  Estimate the funding shortfall, if any, and enter the amount. The number entered will be formatted into currency as in Step 3 above.

Step 6  Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries.

Step 7  Select the **Options** menu item and the **Add** option and perform Steps 2 through 7 above for each additional entry required.

---

<table>
<thead>
<tr>
<th>Site Name</th>
<th>Dollar</th>
<th>Source</th>
<th>Shortfall</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Chief of Naval Education and Training</strong></td>
<td>$5,000.00</td>
<td>CNET Ltr. 1500 Ser 123 20 MAR 98</td>
<td>$0.00</td>
</tr>
</tbody>
</table>

*Figure 2. TPP Funding Compensation Window*
Step 8   Click on the Exit menu item to return to the TPP window.

To delete a TPP Funding Compensation entry:

Step 1   From the TPP window select the Contents menu item and the Compensation/Funding sub-menu items. This will open the TPP Funding Compensation window.

Step 2   Use your mouse and highlight the entry that you want to delete.

Step 3   Select the Options menu item and the Delete option. The program will ask you to confirm your choice.

Step 4   Click on Yes.

Step 5   Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries.

Step 6   Click on the Exit menu item to return to the TPP window.

1.5.2  Course Overview/Comments

In the course overview/comments of the TPP, list course subjects. Note any changes from any previous project plan. For a new course, this will be a description of the skills and knowledge to be attained. This is not intended to be the equivalent of a curriculum outline or to contain objectives. The overview will help the Training Agency understand what the course will actually contain.

To enter the Course Overview/Comments:

Step 1   From the TPP window; select the Contents menu item and the Course Overview/Comments sub-menu item. AIM II will open the Course Overview/Comments window, which contains the AIM Text Editor menu items.

Step 2   If the Course Overview/Comments exist in an ASCII file, you can select the Options menu item and the Import Text File option to select the file and import the contents of the file into the AIM text editor. If a text file doesn't exist, type in the Course Overview/Comments.
Step 3  Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries.

Step 4  Click on the **Exit** menu item to return to the TPP window.

### 1.5.3 Development Method

The Navy uses different systems for developing training programs. The AIM II program is based on the task-based system. This software is programmed to the specifications in NAVEDTRA 130B: *Task Based Curriculum Development Manual*, and the options presented are tailored to this method.

**To select the Course Development Methods:**

Step 1  From the TPP window; select the **Contents** menu item and the **Course Development Method** sub-menu item. AIM II will open the TPP Development Method window.

Step 2  Use the mouse to double click in the Sel/Unsel column next to the training materials documents that you will use.

   *An "X" will appear after each document that you select to indicate that it should be included in the TPP. You can use the Tab key to advance through the documents without changing the selection. You can also use Shift+Tab to back up.*

Step 3  Type in the mode of instruction. This should be a description of how the instruction should best be implemented. Address such issues as the use of lecture, group paced or individualized instruction, laboratory periods, problem solving sessions, and any other instructional methodology, which will be used in the proposed course. **AIM II will automatically precede the text you enter with: "The primary mode of instruction:..."**

Step 4  Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries.

Step 5  Click on the **Exit** menu item to return to the TPP window.
1.5.4 Justification

There must be a reason (or reasons) to undertake the development of a new course or the revision of an existing course. The justification for initiating the development of a new course or the revision of existing training materials can come from:

- Navy Training Plans (NTPs) (OPNAVINST 1500.8)
- Tasking by higher authority
- Internal course reviews and local command initiatives
- External course reviews
- Surveillance and external feedback
- Training appraisal.

To enter a TPP Justification:

Step 1 Select the Contents menu item and the Justification sub-menu item from the TPP window. AIM II will open the Justification window (refer to Figure 3).

After each entry, press the TAB key to advance to the next field.

![Figure 3. TPP Justification Window](image)

Step 2 Enter the References.
Step 3 Enter the reasons/sources of information.

Step 4 Enter the impact if not approved.

Step 5 Select the **Edit** menu item and the **Save** sub-menu item to save your entries.

Step 6 Select the **Exit** menu item to return to the TPP window.

### 1.5.5 Milestones

**Milestones** are a time-phased narrative commencing with TPP approval. Your milestones should include identification of major developmental products or events relating to the training materials development method selected, and end with implementation. For each event, you will enter a start date and a projected completion date.

The initial list of Milestones is provided for you. You may edit this list by adding, modifying, or deleting the default list. All initial dates supplied will be the computer date the TPP was initiated and any new milestones added would be the computer date of when the milestone was added.

Dates can be added automatically by selecting the calendar icon or manually as day, month, year (dd. mmm, yy) or month/day/year. AIM II will convert entries to day, month, and year.

**To enter/add TPP Milestones:**

Step 1 From the TPP window; select the **Contents** menu item and the **Milestones** sub-menu item. AIM II will open the TPP Milestones window.

Step 2 The milestones are automatically numbered. Using the mouse, highlight the content field of the first milestone you would like to edit.

Step 3 Edit the description of the milestone.

Step 4 Today's date will be entered as the default start date. You can Tab to the next field or type over/select another start date. To enter a different date using the calendar icon:
   a. Click on the Date Start field and a calendar icon will appear.
   b. Click on the calendar icon and the currently selected calendar will appear.
   c. Click on the month down arrow and select the desired month.
   d. Click on the year down arrow and select the desired year.
   e. Click on the desired day and the date will be entered into the Start Date field.
Step 5 Type in the projected end date in the Date Complete field. To enter a different date using the calendar icon:
   a. Click on the Date Complete field and a calendar icon will appear.
   b. Click on the calendar icon and the currently selected calendar will appear.
   c. Click on the month down arrow and select the desired month.
   d. Click on the year down arrow and select the desired year.
   e. Click on the desired day and the date will be entered into the Date Complete field.

Step 6 You can continue to edit milestones in this manner.

NOTE: Once you have entered milestones and saved them, to add additional milestones you must selection **Options** from the menu and **Add** from the drop-down menu. The new milestones will be added below the current cursor position.

**To delete a milestone:**

Step 1 Using the mouse, click anywhere on the milestone that you want to delete.

Step 2 Select the **Options** menu item and the **Delete** option. The program will ask you to confirm your choice.

Step 3 Click on **Yes**. The milestones will automatically be renumbered.

Step 4 You may continue to delete milestones in this manner.

Step 5 Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries.

Step 6 Click on the **Exit** menu item to return to the TPP window.

### 1.5.6 Safety Risks and Hazardous Materials

**To enter data in the Safety Risks and Hazardous Materials field:**

Step 1 From the TPP window; select the **Contents** menu item and the **Safety Risks and Hazardous Materials** sub-menu item. AIM II will open the Safety Risks and Hazardous Materials window, which contains the AIM Text Editor menu items.
Step 2 Enter in the identified Safety Risks and Hazardous Materials or type in a statement to the effect that there is none identified for this course.

**NOTE:** If the information required exists in a text file in a Windows editor, rather than retype all of the information required into the AIM Editor, you can use the Options menu item and the Import Text File option to retrieve the text file for the TPP.

Step 3 Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries.

Step 4 Click on the **Exit** menu item to return to the TPP window.

### 1.5.7 Summary of Differences

The Summary of Differences sub-menu item is used when you are developing a TPP for a revision to a course. It allows you to summarize the differences between the current baseline of the TCCD, LP, and TG and the planned revision of the course.

**To enter Summary of Differences:**

**Step 1** Open the Summary of Differences window by performing one of the following:
- a. With the TPP folder open in the Course Tree Structure; double click on the Summary of Differences folder in the upper right hand panel,
- b. Expand the TPP and open the Summary of Differences folder in the Course Tree Structure and click on the **Go** button on the toolbar,
- c. After selecting the course, access the TPP window by either selecting the **Document** menu item and the **Training Project Plan (TPP)** sub-menu item or click on the TPP icon. Select the **Contents** menu item and the **Summary of Differences** sub-menu item.

**Step 2** From the Styled Text Editor enter the desired text.

**Step 3** After entering/modifying the text you can choose one of two ways to exit:

**First Method:**
- Select the **Edit** menu bar item.
- Select **Save** to save your text and/or select **Cancel** to delete your new data entries and return to the Styled Text Editor window.
- Select the Exit menu bar item. AIM II will return you to the TPP window or the Course Tree Structure.
Second Method:
- Select the Exit menu bar item. If the text has been entered/modified, AIM II will prompt, "Edit Text has been modified. Would you like to save new data?"

If there is no new data, selecting this item will return you to the TPP main window or the Course Tree Structure.

1.5.8 Selecting Learning Sites

When developing a TPP, you must select all Learning Sites where the proposed course will be taught. You must select and save a Learning Site before you can add items to the resource requirements list or import CNATT ERL data for that site.

To select a Learning Site:

Step 1 From the TPP window; select the Contents menu item and the Learning Sites sub-menu item. AIM II will open the Learning Site Summary window (Figure 4), which contains a list of all the Learning Sites in the database.
Figure 4. Learning Site Summary Window

**NOTE:** Learning Sites are added to the list through the AIM Utilities. If you do not see the Learning Site that you want to select, it can be added through the AIM Utilities Module. Contact your AIM Administrator to add the desired sites.

**Step 2** Click on the desired Learning Site. The first Learning Site selected will also be identified as the Course Curriculum Model Manager (CCMM) when the course data for the site is saved to the database.
Step 3 From the Learning Site Summary Options menu item (Figure 5) select the **Options** menu item and the **Select Site** option.

An "X" will appear in the Sel column next to the site that you selected to indicate that it should be included in the TPP. If it is the first site selected an “X” will also appear in the CCMM column for that site.

![Figure 5. Learning Site Summary Window Options Menu Item](image)

Step 4 The cursor will appear in the CDP (Course Data Processing Code) field. Enter the CDP if known. You will be allowed to enter four characters. The software will check for duplicate entries. A CDP entry is not required.

**After each entry press the TAB key to advance to the next field.**

Step 5 Type in the course length in days, which includes weekends. Fields are provided for both the current and planned course lengths and both should be completed. For a new TPP the Current fields should contain zeroes (0).

Step 6 For Class, Lab, and PA fields enter the number of hours that will be spent for each, both current and planned.

Step 7 Type in the number of classes per year for each site, both current and planned.

Step 8 Type in the minimum and maximum class capacity, both current and planned.

Step 9 Type in the class convenings, both current and planned.

Step 10 Type in the annual student throughput (up to 5 digits).

Step 11 Fill in Site Consideration data with any training unique site information that is not contained elsewhere.
NOTE: The average on board is automatically calculated.

You can use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. Once you are satisfied with the Learning Site Summary data, as you have entered it, you must **Save** it.

Entering that information in the Site Considerations field can identify any unique site items.

**Step 12** Select the **Edit** menu item and the **Save** sub-menu item.

If you do not want to save the Learning Site information that was entered you can select **Cancel**.

AIM II will verify the following data:
- The student throughput must be equal to or greater than the Class min. Capacity multiplied by the Class Convenings, and
- Less than or equal to the Class max. Capacity multiplied by the Class Convenings.

**Step 13** Select **Exit** to return to the TPP window.

NOTE: You must repeat this procedure for each Learning Site that you select. The RRL information from the first site selected can be used as default information for all subsequent sites. Therefore, it is recommended that you complete paragraph 3.5.7.2 "Identifying Resources for a Learning Site" for the original site selected before selecting additional sites. You will be asked if you would like to use the first selected site data as the default for each additional site selected. For CNATT courses, all Learning Sites MUST contain the same ERL data.

**To select an additional Learning Site:**

NOTE: If only the selected Learning Site(s) appear in the Learning Sites window select the **Options** menu item and click on the **Show Selected Sites Only** option to remove the check mark. All sites available from the Learning Site Utility will appear for selection.

**Step 1** From the TPP window; select the **Contents** menu item and the **Learning Sites** sub-menu item. AIM II will open the Learning Site Summary window, which contains a list of all the Learning Sites in the database.
NOTE: Learning Sites are added to the list through the AIM Utilities. If you do not see the Learning Site that you want to select, it can be added through the AIM Utilities Module. Contact your AIM Administrator to add the desired sites.

Step 2 Click on the desired Learning Site.

Step 3 Select the **Options** menu item and the **Select Site** option.

NOTE: For CNATT courses, all Learning Sites MUST contain the same ERL data.

Step 4 An “X” will appear in the Select column for the site selected. The cursor will appear in the CDP (Course Data Processing Code) field. Enter the CDP if known. You will be allowed to enter four alphanumeric characters. The software will check for duplicate entries. A CDP entry is not required.

**After each entry press the TAB key to advance to the next field. If you copied the original site information the Course Data fields and RRL can be edited for the new site.**

Step 5 Edit/type in the course length in days, which includes weekends. For a new TPP the Current fields will contain zeroes (0).

Step 6 For Class, Lab, and PA fields enter the number of hours that will be spent for each, both current and planned.

Step 7 Edit/type in the number of classes per year for each site, both current and planned.

Step 8 Edit/type in the minimum and maximum class capacity, both current and planned.

Step 9 Edit/type in the class convenings, both current and planned.

Step 10 Edit/type in the annual student throughput (up to 5 digits).

Step 11 Fill in Site Consideration data with any training unique site information that is not contained elsewhere.

NOTE: The average on board is automatically calculated.
You can use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. Once you are satisfied with the Learning Site Summary data, as you have entered it, you must **Save** it. Entering that information in the Site Considerations field can identify any unique site items.

**Step 12** Select the **Edit** menu item and the **Save** sub-menu item.

If you do not want to save the Learning Site information that was entered, you can select **Cancel**.

AIM II will verify the following data:
- The student throughput must be equal to or greater than the Class min. Capacity multiplied by the Class Convenings, and
- Less than or equal to the Class max. Capacity multiplied by the Class Convenings.

**Step 13** Select **Exit** to return to the TPP window.

### 1.5.8.1 Unselecting a Learning Site

**Step 1** From the TPP window; select the **Contents** menu item and the **Learning Sites** sub-menu item. AIM II will open the Learning Site Summary window, which contains a list of all the Learning Sites in the database.

**Step 2** Click on the Learning Site that you want to deselect. It will be highlighted.

**NOTE:** If the Learning Site selected is the CCMM another site will have to be selected as the CCMM before using the Unselect Site option is enabled.

**Step 3** Select the **Options** menu item and the **Unselect Site** option.

The program will ask you to confirm your choice.

**Step 4** Click on **Yes**.

You will be asked to verify the deletion, *Figure 6.*
Step 5 Click on Yes.

After you verify that the correct site will be deleted, the Learning Site will be deselected.

### 1.5.8.2 Identifying Resources for Learning Sites

For each Learning Site that you select, you will provide a best estimate of the known and anticipated resources necessary to implement the training. This part of the TPP is the Resource Requirements List (RRL). The ERL data provided as a CNATT ERL Export file and is not editable. Site RRL Resources, not provided as part of the CNATT ERL Export file for the course, can be added/modified, deleted from the Learning Site as desired.

#### To build a Resource Requirements List:

- **Step 1** From the TPP window; select the Contents menu item and the Learning Sites sub-menu item. The Learning Site Summary window will open which contains a list of Learning Sites in the database.

- **Step 2** Use your mouse to highlight the Learning Site that you want to work on. The site must have an "X" in the Sel column, which indicates that it has been selected.

  **NOTE:** If you need to include a new site that is not currently available for selection, you must add it through the AIM Utilities. To select a site, see paragraph 1.5.7.

- **Step 3** Select the RRL menu item. AIM II will open the TPP RRL window. From here you can select items from the site RRL to add to your TPP RRL.
1.5.8.2.1 Identifying Resources

All material items added to a Learning Site RRL will be reflected in all Learning Sites selected to teach the course. Editing accomplished in one site will also be reflected in all. Therefore, only one Learning Site RRL needs to be developed. If you have already imported the CNATT ERL Data required (refer to paragraph 1.6.3), additional material items not under CNATT cognizance can be selected.

**NOTE:** You must select RRL items in this module or the TCCD module in order for them to be available in the LP and TG Modules. You may print each site's RRL in the TCCD Module.

From the Learning Site Summary window, after you have selected RRL, you can begin to create the RRL for the Learning Site selected.

To add resources for the Learning Site:

1. From the Learning Site Summary window select the RRL menu item.
2. From the TPP RRL window, click on Resources. This will bring up a drop-down menu, which includes all of the types of resources available to include in the TPP. The first three elements of the Resource drop-down menu require additional input.

   *These elements are:*  
   - Manpower
   - Funding
   - Facilities

1.5.8.2.2 Manpower

For new courses or revisions, you should identify officer, enlisted, and civilian billets required, the number of billets authorized, the number of compensated billets that can be provided, and the difference (if any). For cancellations, identify all billets that will be offered up. Specify differences if there are any.

To enter the Manpower data for the Learning Site:

1. On the Learning Site Summary window; select the desired site by clicking on that site one time.
Step 2: Select the **RRL** menu item. AIM II will open the TPP RRL window.

Step 3: Select the **Resources** menu item. A drop-down menu will appear which contains all the resources of the TPP RRL.

Step 4: Select **Manpower** on the drop-down menu. AIM II will open the TPP Manpower window. The cursor will default to the Officer Billets Required field.

Step 5: Use your mouse to highlight the field in which you will enter data.

Step 6: For Officer, Enlisted, and Civilian personnel, type in the number of billets required, the number of billets authorized, and the number of compensated billets that can be provided. Type in the differences in the delta field.

Step 7: In the bottom pane of the window there is a Note field where you can add comments about the manpower entries.

Step 8: When you have completed entering the data, select the **Edit** menu item and the **Save** sub-menu item to update the database with your entries.

Step 9: Select the **Exit** menu item to return to the TPP RRL window.

### 1.5.8.2.3 Funding

For your Learning Site you should identify the appropriation source (e.g., O&MN or OPN), AG/SAG, and the initial or recurring costs. For development of a Revision to an existing course identify only the additional costs required to implement training.

**To enter the Funding data for the Learning Site:**

Step 1: On the Learning Site Summary window; select the desired site by clicking on that site one time.
Step 2 Select the **RRL** menu item, which will open the TPP RRL window.

Step 3 Select the **Resources** menu item.

Step 4 Select **Funding** on the drop-down menu, which will open the TPP Funding window.

Step 5 Type in the appropriation (up to 15 characters).

Step 6 Type in the AG/SAG (Activity Group/Sub Activity Group) and the expense.

**NOTE:** The appropriation, AG/SAG, and expense are required entries, which you can find in NAVSUP 437 or the MILSTRIP/MILSTRAP Desk Guide.

Step 7 Enter the Dollar Amount under the year. You can enter whole numbers. The program will automatically format the number to a currency entry including two decimal places.

Step 8 When you have completed entering the data, select the **Edit** menu item and either the **Save** or **Cancel** sub-menu item to update your entries.

Step 9 In the bottom pane of the window there is a Note field where you can add comments about the funding entries.

Step 10 Select the **Options** menu item and the **Add** option and repeat Steps 5 through 9 to make additional funding entries.

Step 11 Select the **Exit** menu item to return to the TPP RRL window.

### 1.5.8.2.4 Facilities

Identify requirements for MILCON (Military Construction) or special projects for facilities modification. These requirements are highly situation-specific. See OPNAVINST 11102.1 and CNETINST 11102.2 for detailed facilities documentation requirements.

**To enter Facility Data for the Learning Site:**

Step 1 From the Learning Site Summary window; select the **RRL** menu item. This will open the TPP RRL window.
Step 2  Select the **Resources** menu item.

Step 3  Select **Facility** on the drop-down menu. This will open the TPP Facility window for text entry in the AIM II Text editor.

Step 4  Enter the facility information.

Step 5  When you are finished, select the **Edit** menu item and either the **Save** or **Cancel** sub-menu item to update your entry.

Step 6  Click on **Exit** to return to the TPP RRL window.

### 1.5.8.2.5 Select Site RRL Materials

Resource data is course specific and will be the same for all Sites. Data edited for one Learning Site will be reflected in all Learning Sites selected. If CNATT Data exists and is required for the course it can be imported using the **Import CNATT ERL Data** option from the TPP/TCCD windows **Options** menu item or by your AIM II Administrator from the Import/Export utility. In addition, the AIM Administrator can also **Import CNATT Publications** from the Import/Export Utility. If CNATT Data does not exist you can create the RRL as stipulated below and have the AIM Administrator export the data to CNATT for approval. Once approved and CNATT ERL data is imported for a course, it cannot be modified. You may add/modify/delete items from the Site RRL that are not CNATT ERL data types. The following is a list of all the RRL types. An asterisk (*) denotes the RRL headings, which are not CNATT controlled:
To add an RRL Item to the Learning Sites selected:

Step 1  From the Learning Site Summary window; select the RRL menu item. This will open the TPP RRL window.

Step 2  Select the Resources menu item.

Step 3  Click on the desired resource type from the drop-down menu listed.

On the lower portion of the window, you will see the items that exist in the Site RRL.

Step 4  Highlight the desired Site RRL item. If the Site RRL Identifier does not provide enough information on the item, select the Options menu item and the View RRL option. AIM II will retrieve the Site RRL record for your inspection. Select the Exit menu item to return to the TPP RRL window.

Step 5  Select the Options menu item and the Select TPP RRL option or double click on the desired item from those available in the Site RRL Identifier (lower portion of
the window).
The item will appear in the upper portion of the window.

Step 6 Click in the Qty Req'd field. Enter the quantity required to tech the course. AIM II will check that the quantity required is greater than zero when the entry is saved.

**NOTE:** The Quantity Required cannot be edited for an imported ERL item.

Use the **TAB** key or click with the mouse to advance to the next field.

Step 7 Highlight the field for Qty On Hand and enter the quantity on hand at the Learning Site.

Step 8 When you have completed adding RRL items of this type from the Site RRL to your TPP RRL, select the **Edit** menu item and the **Save** sub-menu item to update your entries. The RRL item(s) will be added to all Learning Sites.

Step 9 Repeat Steps 2 through 8 to enter other resource types/items.

Step 10 Select the **Exit** menu item to return to the main Learning Site Summary window.

### 1.5.8.2.6 Unselect TPP RRL Items

**NOTE:** An imported ERL item cannot be deselected from a course.

**From the TPP RRL Window:**

Step 1 Click on the desired TPP RRL item for deletion.

Step 2 Select the **Options** menu item and the **Unselect TPP RRL** option.

Step 3 Confirm the deletion by selecting **Yes** when prompted.

Step 4 After all desired TPP RRL deletions have been made; you will receive a message stating that the TPP RRL has been modified. You must click on Yes to save your changes.
1.5.8.2.7 Explain Flag

The TPP RRL window contains a Flag column that will display a flag (X) for a TPP RRL item if the item has a maintenance record entry from the Site RRL. The Options menu item in the Site RRL contains a Flag Related Material option with sub-menu items for selection of TPP or Courses. Maintenance records can inform developers/maintainers of the status of the item, (e.g., superseded, change received, etc.).

To review the maintenance record for a flagged TPP RRL item:

Step 1  Click on the flagged TPP RRL item.

Step 2  Select the Options menu item and the Explain Flag option. AIM II will retrieve the maintenance record.

Step 3  Select the Exit menu item to return to the TPP RRL window.

1.5.8.2.8 Remove Flag

The TPP RRL window contains a Flag column that will display a flag (X) for a TPP RRL item if the item has a maintenance record entry from the Site RRL. The Options menu item in the Site RRL contains a Flag Related Material option with sub-menu items for selection of TPP or Courses. Maintenance records can inform developers/maintainers of the status of the item, (e.g., superseded, change received, etc.). Before a TPP can be approved, all flags must be removed from the TPP RRL. Individuals with Remove Flags privilege, as well as the AIM Administrator, can exercise the Remove Flag option. Removing a flag from an item in the TPP RRL does not remove the maintenance record from the item in the Site RRL.

To remove a flag from a TPP RRL item:

Step 1  Highlight the TPP RRL item that is flagged.

Step 2  Select the Options menu item and the Remove Flag option. If you do not have Remove Flag privilege this option will not be enabled.
1.6 TPP OPTIONS

After selecting a TPP to work on and saving the TPP window required entries, you can access the TPP Options menu item. The elements of the TPP options are:

- **Lock**
- **Unlock**
- **Grant Privilege**
- **Import CNATT Course Data or Import CNATT ERL Data***
- **Print Preview**
- **Print**

* Options present only if CNATT is selected for the TPP. Until the TPP Cover Page information is saved to the database, **Import CNATT Course Data** is present. Once the TPP Cover Page is saved, the **Import CNATT ERL Data** option will be present.

1.6.1 Lock/Unlock

When you have completed the TPP, and you are ready to use the TPP information to develop other training materials, you must "lock" the TPP. "Locking" the TPP maintains the integrity of the baseline data from which all other related training materials are built.

**The first time the TPP is locked, shared data is copied to the TCCD.** This data will be used as the foundation of the TCCD.

**To Lock the TPP:**

From the TPP window select the **Options** menu item and the **Lock** option. The TPP is now locked and no changes may be made to it unless you "unlock" the TPP. The first time the TPP is locked, the Status field will change from Incomplete to Locked. Subsequently, when the TPP is unlocked, the Status field will change from Locked to Complete. This indicates the information contained in the TPP has already been copied to the TCCD and any further editing of the TPP must also be performed in the TCCD.

**To Unlock the TPP:**

1. Step 1 From the TPP window; select the **Options** menu item.

2. Step 2 Select the **Unlock** option from the drop down menu. The Status field will change from Locked to Complete.
1.6.2 Grant Privilege

Selection of the Grant Privilege option allows an AIM User who is the developer of the TPP to assign Edit, Lock, and Grant privileges to other AIM Users. The AIM Administrator can grant Edit, Lock, Grant, Approve, Remove Flag, and Clear In Use privileges to AIM Users.

1.6.3 Importing CNATT Course and ERL Data

To import CNATT data, the TPP window for the course must be open. The Import CNATT ERL Data option can also be accomplished from either the TPP or TCCD Options menu item or in the Import/Export Utility.

The AIM II software prevents the approval of a CNATT Course until ERL data is imported and the Course's ERL data matches the imported version.

The differences between importing ERL data into a TPP/TCCD and from the Import/Export Utility are:

In TPP
   a. You can only import the data if you have privilege on the TPP you are editing.
   b. When importing the data, it verifies it is for your current Course. You won't accidentally import the data for another Course.
   c. You can import data into the TPP, even if you’ve already locked and unlocked it. You cannot do this from the Import/Export Utility because it will default the data to the TCCD.

In Import/Export
   a. The AIM Administrator does not have to select the Course because the import function will determine that information from the .txt file itself.
   b. If the TPP the ERL data belongs to is INCOMPLETE, then the data will be imported into the TPP. Otherwise it will be imported into the TCCD.

To Import CNATT Course Data:

Importing CNATT Course Data extracts the CIN, Rev, and Title from a CNATT ERL extract file and loads this information into the appropriate fields. The **Options** menu item, **Import CNATT Course Data**, is only present as an option until you save the TPP Cover Page. Thereafter, the **Options** menu item will be **Import CNATT ERL Data**.
Step 1 From the AIM II main menu select the **Course** menu item and the **New** submenu item.

Step 2 From the TPP window select the **Options** menu item and the **Import CNATT Course Data** option.

Step 3 From the Select Course File window, identify the drive, directory, and CNATT data base file (ERL text file which contains the CIN designator desired) to import and click on the OK button.

**NOTE:** The current directory is displayed under Directories: (upper, middle of the window), and the contents of the directory are displayed in the left column.

The types of files displayed can be changed by clicking in the "List Files of Type" field and dragging the mouse to the desired file type.

Step 4 If the CIN or Title is different than what is contained in the text file for the Course data the software will prompt you with “Course Data for TPP X-YYY-YYYY will be updated. Do you want to continue?” click on the **Yes** button.

**To Import CNATT ERL Data:**

**NOTE:** A Learning Site has to be selected for the TPP before CNATT ERL data can be imported into the Learning Site RRL.

Step 1 From the TPP window select the **Options** menu item and the **Import CNATT ERL Data** option.

Step 2 From the Select file to Import window, identify the drive, directory, and CNATT ERL text file to import and click on the Open button.

**NOTE:** The current directory is displayed under Directories: (upper, middle of the window), and the contents of the directory are displayed in the left column. The types of files displayed can be changed by clicking in the "List Files of Type" field and dragging the mouse to the desired file type.

**NOTE:** If the CIN of the TPP and the CIN of the CNATT Export File do not match you will prompted of the difference and asked whether to update the Title. If the answer is Yes it will update the CIN Rev and Title fields as applicable.

Step 3 At the prompt “ERL for TPP X-YYY-YYYY will be updated. Do you want to continue?” click on the **Yes** button.
Step 4 At the prompt “CNATT data merged with AIM Site RRL successfully. XXX records imported.” click on the OK button.

1.6.4 Print Preview

Selection of Print Preview will open the Printer Setup window where you have the functionality to add:
- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:
- Options - contains the options to Print or Save to PDF. Print opens the Print window, which allows you to print a page, range of pages, the whole document, print to file, and number of copies. Save to PDF saves the document as a PDF file to the desired location.
- Go To - moves to the previous, next, first, last, or desired page.
- Exit - returns to the TPP window.
- Help - provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:
- Previous - moves to the previous page.
- Next - moves to the next page.
- Find – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- Page _ of Page - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Accesses the page desired by typing in the page number in the first field and depressing Enter.
- Actual Page - displays the actual page number, as shown on the page. Typing the page number in this field and depressing Enter accesses the page number desired.
Double clicking the left mouse zooms in and double clicking the right mouse zooms out. Clicking the arrow to the right of the zoom icon (magnifying glass) presents a sub-menu from which you can select Whole Page, Page Width, Two Pages, Thumbnail, and present the page in 25% increments to 100% and also select 150%.

To print preview the TPP:

Step 1 From the Training Project Plan (TPP) window select the Options menu item and the Print Preview option. AIM II will open the Printer Setup window.

Step 2 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3 Click on the OK to print preview.

1.6.5 Print

Selection of the Print option allows the entire document to be printed:

To print the entire TPP:

Step 1 Select the Options menu item and the Print option. AIM II will open the Printer Setup window.

Step 2 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

Step 3 Click on the OK button. While the software is preparing the TPP for print, you can select Cancel to terminate the print job.
2.0 TRAINING COURSE CONTROL DOCUMENT (TCCD)

The Training Course Control Document (TCCD) is a collection of products that express, in summary form, the content, structure, and essential management information for a course. You have already supplied most of the information for the TCCD while working through the AIM II Modules TPP, CTTL, LO, COI, and CMS. The TCCD is a consolidation of much of the information on a course into a single document.

2.1 ELEMENTS OF A TCCD

The TCCD consists of the following items:
- Front Matter
- Curriculum Outline of Instruction
- Annexes

2.1.1 Elements of TCCD Front Matter

The front matter of the TCCD contains:
- Cover Page. This information is copied from the TPP module.
- Letter of Promulgation. This is issued after successful course pilot. The AIM II Module reserves a place marker for the Letter of Promulgation.
- Summary of Differences. Copied from the TPP module for a Revision TPP or developed in the TCCD when creating a Change for a curriculum to identify the differences between the baseline curriculum and the Revision or Change.
- Table of Contents.
- Foreword. The foreword is not required but serves as a place to explain to reviewers any unique aspect of the course, which may not be apparent from the basic data.
- Course Data. Course data is copied from the TPP module and may be updated.
- Trainee Data. This data consists of personnel physical requirements, security clearances, obligated service, and NOBC/NEC earned.
- Outline of Instruction. Lists the Unit and Topic titles, hours and tenths of hours for class, lab, special, and practical application periods.
- Curriculum Outline of Instruction. From the COI module.
2.1.2 Elements of TCCD Annexes

- **Resource Requirements List (RRL).** The RRL is a composite listing of all the materials needed to conduct training. The RRL in the TCCD may be updated from the original RRL composed in the TPP module.

- **Equipment Requirement List (ERL).** AIM II displays ERL headings for CNATT controlled resources in the RRL when the database is installed, accessed the first time, and identified as a CNATT database. The RRL is a composite listing of all the materials needed to conduct training. The ERL items supplied by CNATT and imported into the TPP/TCCD cannot be edited. However, items added that are not under CNATT control can be edited as necessary.

- **Master Schedule Summary Sheet and Course Master Schedule.** See CMS Module.

The Site RRL includes the following Resources. An asterisk (*) denotes the ERL headings, which are not CNATT controlled:

- *Manpower*: Maintenance Trainers
- *Funding*: Miscellaneous Materials
- *Facility*: Ordnance/Ammunition/Pyrotechnics
- Audio/Visual Devices *Photographs
- Calibration Standards *Publications
- Common Hand Tools *Slides
- Consumables *Software
- *Equipment*: Special Tools
- Equipment Refurbished Stand-alone Computer Systems and Peripherals
- Faulted/Pre-faulted Modules Support Equipment (Non-avionic)
- *Films*: Test Equipment
- *IETM*: Trainer Peculiar Materials
- *IMI*: Training Devices
  - Animation Training Equipment
  - Audio *Transparencies
  - Graphic *Video
  - Internet *Wall Charts
  - Power Point
  - Video

2.2 USING THE AIM II TCCD MODULE

The AIM II TCCD Module provides the tools to produce a TCCD. The program will present a series of windows. These windows will have a menu across the top.
You select an option by highlighting the option with a mouse and clicking the left mouse button. Selecting an option from the menu will bring up windows, which will allow you to enter the data necessary to complete a TCCD.

If you are working on a new TCCD, some of the fields presented may be blank. You must provide the appropriate information by either typing the information in the space or selecting from a series of drop-down menus. If you are working on a TCCD, which is in progress or completed, you can edit existing data and/or provide new data as necessary. Each window is explained in this User's Manual with instructions on how to fill in the necessary data.

On all forms where data is entered into grids/tables, Tab/Return moves the cursor from one row to the next, allowing you to enter data in all fields before saving the information to the database.

2.2.1 Overview of the AIM II TCCD Module

Each of the following steps is explained in further detail in this manual. These paragraphs are meant as a quick reference for getting around the software.

You can start a new TCCD by selecting the Course menu item and the Select sub-menu item from the AIM II main menu bar or by clicking on the "Select Course" icon. The Course Select window will open which contains a list of available courses. Click on the desired course and click on the Select menu item. The Course Select window will close and the AIM II window will contain the CIN of the course selected in the title bar.

Select the Document menu item and the Training Course Control Document (TCCD) sub-menu item or click on the TCCD icon. The TCCD window has data in the fields that you supplied in the TPP module. After completing or modifying the data in the window, you must select the Edit menu item and then the Save sub-menu item to save the changes. If you do not wish to save your changes, you can select Cancel. You must either save or cancel before proceeding further. From this TCCD main window you can select the Options or Contents menu item to continue developing the TCCD.

To identify where the proposed course will be taught, you will select the Contents menu item and the Learning Sites sub-menu item. You will be provided with a "Learning Site" window. Click on the desired site, select the Options menu item and the Modify/View option to edit the Course Data copied from the TPP: the Course Data Processing (CDP) code, course length requirements, class minimum and maximum capacity, class convenings, student throughput for each site, site considerations, and RRL data.
After entering the data for the Course Data window, select the RRL menu item to access the Learning Site RRL for the selected Learning Site. From here you can select RRL Resources menu item and the RRL type/items to be used in the course. Selecting Resources also allows you to update manpower, funding, and facility data.

The TCCD window Options menu item also includes Lock, Unlock, Import CNATT ERL Data, Grant Privileges, Print Preview and Print options. The Contents menu item includes the Foreword and Course Overview/Comments, Trainee Data, Summary of Differences, and Learning Sites sub-menu items. Course Overview/Comments and Learning Sites data will be the data copied from the TPP module and are editable. Summary of Differences will be data copies from a Revision TPP or data entered into the TCCD for a Course Change.

When you have finished providing data for the TCCD, you must select the Edit menu item and the Save sub-menu item to save your data to the database. You can also Cancel your input from the Edit menu item. You can lock your TCCD from the Options menu.

### 2.3 SELECTING A TCCD

There are four different ways to access a TCCD window after the course has been selected from the Course Select menu:

1. From the AIM II main menu select the Document menu item and the Training Course Control Document (TCCD) sub-menu item.
2. Click on the TCCD icon.
3. From the course tree structure, click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TCCD element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.
4. From the course tree structure click on the TCCD folder, select the Options menu item and the GoTo sub-menu item. Opening the TCCD folder can provide Summary or Note data on the right hand portion of the course tree grid if the View menu sub-items (Note or Summary) have been checked. Summary data includes all the information contained in the TCCD window. Note data contains Personal and/or Private Notes recorded by developers.
If the TCCD window cover page is complete and you desire to work on an element within the TCCD you can either select the element from the Contents menu item in the TCCD window or double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the element desired and can exercise Options menu sub-items (Edit Note and GoTo) and View menu sub-items (Note and Summary).

The main window of the TCCD that you selected will be presented. You can click on and edit all of the fields in the window except Change, Rev, Status, and CNATT ERL fields. To save the changes, select the Edit menu item and the Save sub-menu item.

**To edit the TCCD from the TCCD Main Window:**

**NOTE:** All of the information in the TCCD can be edited by clicking in the desired field and typing in the new data.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Enter the new/updated information. The Instructor/Support Manning, Trainee Data, and Foreword will be blank the first time that you enter the TCCD.</td>
</tr>
<tr>
<td>2</td>
<td>Click on Edit.</td>
</tr>
<tr>
<td>3</td>
<td>Select Save.</td>
</tr>
</tbody>
</table>

If you do not want to save the TCCD information that you have entered, you can select Cancel.

### 2.4 TCCD CONTENTS

After selecting a TCCD, you can edit the TCCD Contents. The elements of the TCCD contents are:

- Foreword
- Course Overview/Comments
- Trainee data
- Summary of Differences
- Learning Sites
2.4.1 Foreword

The foreword is not required but is a place to explain to reviewers any unique aspect of the course, which may not be apparent from the basic data.

There are three different ways to access the TCCD Course Foreword window after selecting the Course from the Course Select window:

1. Select the Document menu item and the Training Course Control Document (TCCD) sub-menu item or click on the TCCD icon to open the TCCD window. From the TCCD window select the Contents menu item and the Foreword sub-menu item.
2. From the course tree structure, double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the Foreword folder and can exercise Options menu sub-items (Edit Note and GoTo) and View menu sub-items (Note and Summary).
3. From the course tree structure click on the TCCD folder. This will identify the elements of the TCCD in the upper right hand grid. Either double-click on the Foreword folder in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.

To enter the TCCD Foreword:

Step 1 The TCCD Course Foreword window allows you to select the Options menu item and the Import Text File option or type/edit the Foreword directly.

Step 2 Edit the foreword as necessary

Step 3 Click on Edit.

Step 4 Select Save to update your entries or Cancel to delete the changes to your entries. To return to the TCCD main window or the course tree, click on Exit.

2.4.2 Course Overview/Comments

In the TPP you supplied this information. For a new course it was a description of the skills and knowledge to be attained. The overview will help the Training Agency see what the course will actually contain.
There are three different ways to access the TCCD Course Overview/Comments window after selecting the Course from the Course Select window:

1. Select the **Document** menu item and the **Training Course Control Document (TCCD)** sub-menu item or click on the TCCD icon to open the TCCD window. From the TCCD window select the **Contents** menu item and the **Course Overview/Comments** sub-menu item.

2. From the course tree structure, double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the Course Overview/Comments folder and can exercise **Options** menu sub-items (**Edit Note** and **GoTo**) and **View** menu sub-items (**Note** and **Summary**).

3. From the course tree structure click on the TCCD folder. This will identify the elements of the TCCD in the upper right hand grid. Either double-click on the Course Overview/Comments folder in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.

**To enter the TCCD Course Overview/Comments:**

- **Step 1** The TCCD Course Overview/Comments window allows you to select the **Options** menu item and the **Import Text File** option or type/edit the Course Overview/Comments directly.

- **Step 2** Edit the Course Overview/Comments as necessary

- **Step 3** Click on **Edit**.

- **Step 4** Select **Save** to update your entries or **Cancel** to delete the changes to your entries. To return to the TCCD main window or the course tree, click on **Exit**.

**2.4.3 Supplying Trainee Data**

The Trainee Data consists of personnel physical requirements, security clearances, obligated service, and NOBC/NEC/MOS earned, *Figure 7*. 
To enter trainee data:

Step 1  Perform one of the following to identify the trainee data required for the course:
  a. From the TCCD window, select the **Contents** menu item and the **Trainee Data** sub-menu item. The Trainee Data window will open.
  b. From the course structure tree click on the TCC folder and expand the tree by clicking on the ‘+’ block. Click on the Trainee Data folder and select the **Options** menu item and the **GoTo** option or double-click on the Trainee Data folder on the upper right hand grid.

Use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. You can also use the arrow keys.

Step 2  Enter the Personnel Physical requirements.

Step 3  Enter the Security Clearances.

Step 4  Enter the Obligated Service.
Step 5 Enter the NOBC/NEC/MOS.

Step 6 When you have completed entering the data, select the Edit menu item and the Save sub-menu item to update your entries or Cancel to delete the changes to your entries.

Step 7 To return to the TCCD main or the course tree, click on Exit.

2.4.4 Summary of Differences

The Summary of Differences sub-menu item is used when you are maintaining a TCCD for a Revision or a Change. It allows you to summarize the differences between the current baseline of the TCCD, LP, and TG and the planned Revision or Change.

To enter Summary of Differences:

Step 1 Open the Summary of Differences window by performing one of the following:
   a. With the TCCD folder open in the Course Tree Structure; double click on the Summary of Differences folder in the upper right hand panel,
   b. Expand the TCCD and open the Summary of Differences folder in the Course Tree Structure and click on the Go button on the toolbar,
   c. After selecting the course, access the TCCD window by either selecting the Document menu item and the Training Course Control Document (TCCD) sub-menu item or click on the TCCD icon. Select the Contents menu item and the Summary of Differences sub-menu item.

Step 2 From the Styled Text Editor add/edit the desired text.

Step 3 After entering/modifying the text you can choose one of two ways to exit:

First Method:
   • Select the Edit menu bar item.
   • Select Save to save your text and/or select Cancel to delete your new data entries and return to the Styled Text Editor window.
   • Select the Exit menu bar item. AIM II will return you to the TCCD window or the Course Tree Structure.
Second Method:
- Select the Exit menu bar item. If the text has been entered/modified, AIM II will prompt, *Edit Text has been modified. Would you like to save new data?*

If there is no new data, selecting this item will return you to the TCCD main window or the Course Tree Structure.

2.4.5 Selecting a Learning Site

When completing the TCCD, select all Learning Sites where the course will be taught. After selecting a Learning Site and saving it to the database, you can update information that you supplied by selecting the Modify/View option if necessary.

There are three different ways to access the Learning Site window, *Figure 8*, of the TCCD after the TCCD window has been selected:

1. Select the Document menu item and the Training Course Control Document (TCCD) sub-menu item or click on the TCCD icon to open the TCCD window. From the TCCD window select the Contents menu item and the Learning Sites sub-menu item.

2. Double-click on the TCCD folder in the course tree structure. Double-clicking the TCCD folder or clicking on the “+” box next to the TCCD will expand the tree information to include the contents of the TCCD. Once the tree has been expanded you can click on the Learning Sites folder and can exercise Options menu sub-items (Edit Note and GoTo) and View menu sub-items (Note and Summary).

3. From the course tree structure click on the TCCD folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TCCD element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.

**NOTE:** Learning Sites are added to the list through the AIM Utilities program. If you do not see the Learning Site that you want, it can be added through Site Administration in the Utilities module.
Step 1  Click on the desired Learning Site.

Step 2  Select the **Options** menu item and the **Select** option. This option will be available only when selecting a site that was not previously selected in the TPP.

Step 3  The Course Data window will open.

The site summary data was copied from the TPP module to the Course Data window, *(Figure 9)*. To modify this data:
Step 4 Using the mouse, click on the CDP field. Type the Course Data Processing code. After each entry press the TAB key to advance to the next field.

Step 5 Modify the course length in calendar days (as required).

Step 6 Instructional Days is not a required field; therefore the TAB key skips this field. To modify, click on the field and edit as necessary.

Step 7 Modify the minimum and maximum class capacity. When changing the Max Class Capacity you will be asked if you want to update all CMS periods with the new Instructor/Student ratio for the course.
Step 8  Modify the number of Class Convenings Required per year for the selected site.

Step 9  Modify the annual student throughput, as necessary.

**NOTE:** The average on board is automatically calculated.

Use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. Once you are satisfied with the Learning Site summary data, as you have entered it, you **must** **Save** it.

Step 10 Modify Site Consideration field as necessary.

Step 11 Select the **Edit** menu item and the **Save** sub-menu item.

If you do not want to save the Learning Site information that you have entered, you can select **Cancel**.

Step 12 To return to the Learning Site window, click on **Exit**.

### 2.4.5.1 Identifying Resources for a Learning Site

Provide a best estimate of the known and anticipated resources necessary to implement the training in the TPP Resource Requirements List (RRL). In the TCCD, you have an opportunity to complete the data. If this is a new development, you may use this opportunity to update the resources needed to conduct the course. ERL Data that was imported cannot be edited. Editing performed for any Learning Site will be reflected in all Learning Sites selected.

**To modify the Resources for a Learning Site:**

**Step 1**  Select the Learning Site desired (Refer to paragraph 2.4.4). The site must have an "X" in the Sel column, which indicates that it has been selected.

**Step 2**  Perform one of the following to select the resources of a Learning Site:

a. From the Learning Site window select the **Options** menu item and the **Modify/View** option. This will open the Course Data window. The Course data can be edited if required. An additional field, not present in the TPP, for Instructional Days is included to note how many days the course requires less weekends and holidays. If the Course data has been edited select the **Edit** menu item and the **Save** sub-menu item.
b. Select the RRL menu item. This will open the Learning Site RRL window. Select Resources from the menu. This will provide a drop down menu of all the RRL types available as well as Manpower, Funding, and Facility data.

c. From the course tree structure expand the TCCD and Learning Sites folders and click on the desired sites. The upper right hand portion of the grid will contain the Resource folders.

NOTE: The procedure for selecting RRL items in the TCCD is identical to the procedure used in the TPP. For a detailed description of this procedure, refer to the TPP paragraphs in this Appendix.

From the Learning Site RRL window, after you have selected Resources, you can begin to select additional items for the RRL.

The first three elements of this drop-down menu require no additional input and are presented for reference of what was developed in the TPPP. Editing this information does not change the information in the TPP and they do not print out as part of the TCCD. These elements are:

- Manpower
- Funding
- Facilities

To add Resources into the Learning Site RRL:

Step 1 Perform one of the following to identify the resources required for the Learning Site:
   a. From the Learning Site RRL window Resources menu click on any discrete resource type from the drop down menu listed below Facility.
   b. From the course structure tree click on the TCCD folder and expand the tree by clicking on the ‘+’ block. Click on the Learning Sites folder and expand the tree by clicking on the ‘+’ block. Click on the folder for the desired Learning Site and expand the tree by clicking on the ‘+’ block. Open the RRL folder and select the Options menu item and the GoTo option or double-click on the RRL folder on the upper right hand grid.

   On the lower portion of the window, you will see the items that exist in the Site RRL.

   Step 2 Use your mouse to highlight the item in the Site RRL.
Step 3  Select the Options menu item and the Select Course RRL option to select the item for your Course, or double click on the Site RRL Identifier and the item will move to the Course RRL.

Step 4  Repeat Step 4 for each additional resource items required of the type selected.

Step 5  Enter the quantity required for each item selected from the Site RRL.

Step 6  You must save your entries before you can select another type of resource. Select the Edit menu item and the Save sub-menu item.

Step 7  To add more items from a different type of resource, repeat Steps 1 through 6. To return to the Course Data window or course tree, click on Exit.

Step 8  To return to the Learning Site window from the Course Data window, click on Exit.

2.5  TCCD OPTIONS

After selecting a TCCD, you can access the TCCD Options. The elements of the TCCD options are:

- **Lock**
- **Unlock**
- **Grant Privileges**
- **Import CNATT ERL Data**
- **Print Preview**
- **Print**

*  Options that only appear if AIM II installation was accomplished by selecting CNATT ERL.

2.5.1  Lock and Unlock Options

When the TCCD is locked for the first time, the developer can proceed to the Lesson Plan (LP). When the LP cover page is initially saved AIM II will create a lesson plan based on the structure established in the Curriculum Outline of Instruction (COI). The developer can unlock and edit the TCCD as long as no one is logged into the LP or Trainee Guide (TG).
Prior to the LP being developed, the COI option of Copy Unit/Topic from another course will only allow management materials from the CTTL through the COI to be copied. Once the software has developed the LP, the Copy Unit/Topic from another course option will allow all materials from the CTTL through the TG to be copied from another course.

The developer can re-sequence Units and Topics in the COI after the LP has been created, and these changes will be carried forward to the LP. However, re-sequencing of the EOs within a Topic will not re-sequence the Discussion Points in the LP.

There are four different ways to access a TCCD window after the course has been selected from the Course Select menu:

1. From the AIM II main menu select the **Document** menu item and the **Training Course Control Document (TCCD)** sub-menu item.
2. Click on the TCCD icon.
3. From the course tree structure click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TCCD element in the upper right hand grid or single click on it and select the **Options** menu item and the **GoTo** sub-menu item.
4. From the course tree structure click on the TCCD folder, select the **Options** menu item and the **GoTo** sub-menu item. Opening the TCCD folder can provide Summary or Note data on the right hand portion of the course tree grid if the **View** menu sub-items (**Note** or **Summary**) have been checked. Summary data includes; CIN, Rev, Change, Title, AIM II Status, and Date obtained from the information contained in the TPP window. Note data contains Personal and/or Private Notes recorded by developers.

**To Lock the TCCD:**

Step 1  Select the TCCD window.

Step 2  Select the **Options** menu item and the **Lock** option. The Status field will change from Complete to Locked.

Step 3  Select the Exit menu item to return to the AIM II main menu and course tree structure.

**To Unlock the TCCD:**

Step 1  Select the TCCD window.
Step 2 Select the **Options** menu item and the **Unlock** option. The Status field will change from Locked to Complete.

Step 3 Select the Exit menu item to return to the AIM II main menu and course tree structure.

### 2.5.2 Grant Privileges

The Grant Privileges option can be used by the developing AIM User to assign Edit, Lock and Grant privilege levels to other AIM Users. It can also be used by an AIM Administrator to assign the same privilege levels plus Approve, Remove Flag, Clear In Use, and Maintain/Delete Course to AIM Users.

### 2.5.3 Importing CNATT ERL Data

To import CNATT data, a TCCD for the course must already exist and at least one Learning Site selected. This option can also be accomplished from the Import/Export Utility.

The differences between importing ERL data into a TCCD and from the Import/Export Utility are:

**In TCCD:**
- a. You can only import the data if you have privilege on the TCCD you are editing.
- b. When importing the data, it verifies it is for your current Course. You won’t accidentally import the data for another Course.

**In Import:**
- a. The AIM Administrator can import the ERL data into any Course, as long as it is not approved.
- b. The AIM Administrator does not have to select the Course because the import function will determine that information from the text file itself.
- c. If the TPP that the ERL data belongs to is INCOMPLETE, then the data will be imported into the TPP. Otherwise it will be imported into the TCCD.

**To Import CNATT ERL Data:**

Step 1 From the TCCD window select the **Options** menu item and the **Import CNATT ERL Data** option.
Step 2 From the Select file to Import window, identify the drive, directory, and CNATT text file to import and click on the Open button.

**NOTE:** The current directory is displayed under Directories: (upper, middle of the window), and the contents of the directory are displayed in the left column.

The types of files displayed can be changed by clicking in the "List Files of Type" field and dragging the mouse to the desired file type.

**NOTE:** If the CIN of the TPP and the CIN of the CNATT Export File do not match AIM will not Import CNATT ERL Data.

Step 3 At the prompt “ERL for TPP X-YYY-YYYY will be updated. Do you want to continue?” click on the Yes button.

Step 4 At the prompt “CNATT data merged with AIM Site RRL successfully. XXX records imported.” click on the OK button.

2.5.4 Print Preview and Print Options

After selecting a Course, you can print or preview the TCCD using the TCCD window Option menu item. Printing and previewing the entire TCCD can also be accomplished by opening the TCCD folder in the course tree structure, selecting the Options menu item and the Preview/Print options.

The TCCD window Print Options are:

- **Print Preview** - View TCCD of All Sites or View TCCD of Selected Site
- **Print** - Print TCCD of All Sites or Print TCCD of Selected Site

**Print Preview of a TCCD**

Selection of **Print Preview** will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.
Selecting **OK** will present the default printer selected. Selecting **OK** from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- **Options** - contains the options to **Print** or **Save to PDF**. **Print** opens the Print window, which allows you to print a page, range of pages, the whole document, print to file, and number of copies. **Save to PDF** saves the document as a PDF file to the desired location.
- **Go To** - moves to the previous, next, first, last, or desired page.
- **Exit** - returns to the TCCD window.
- **Help** - provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- **Previous** - moves to the previous page.
- **Next** - moves to the next page.
- **Find** – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- **Page _ of Page** - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Access the page desired by typing in the page number in the first field and depressing **Enter**.
- **Actual Page** - displays the actual page number, as shown on the page. Access the page desired by typing in the page number in the field and depressing **Enter**.

The right and left mouse buttons allow you to zoom in and out by double clicking on the page and allows you to view multiple pages. Double click the left mouse button to zoom in to a single page display and double click the right mouse button to zoom out.

Bellow the main menu, on the left side, there are arrows and icons to turn pages, inspect, and print your document.

**To print preview all sites:**

**Step 1** Select the **Options** menu item and the **Print Preview** option.

**Step 2** Select the **View TCCD of All Sites** sub-menu item. Click on the **OK** button AIM II will open the Print Preview window where you can select the printer desired. AIM II will prepare the TCCD for print preview and display the first page of the TCCD in the window.

**Step 3** Exercise the Print Preview options noted above and when completed select the **Exit** menu item to return to the TCCD window.
To print preview selected sites:

Step 1  Select the **Options** menu item and the **Print Preview** option.

Step 2  Select the **View TCCD of Selected Site** sub-menu item. AIM II will open the Learning Site window for the TCCD.

Step 3  Double click on the desired Learning Site for print preview.

Step 4  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the **OK** button AIM II will open the Print Preview window where you can select the printer desired. AIM II will prepare the TCCD for print preview and display the first page of the TCCD in the window.

Step 5  Exercise the Print Preview option noted above, as desired and when complete select the **Exit** menu item to return to the TCCD window.

To print all sites:

Step 1  Select the **Options** menu item and the **Print** option.

Step 2  Select the **Print TCCD of All Sites** sub-menu item.

Step 3  From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the **OK** button AIM II will open the Print window where you can select the printer desired.

Step 4  After the printer selection has been made click on the **OK** button. AIM II will prepare the TCCD for printing and send the printout to the printer.

To print selected sites:

Step 1  Select the **Options** menu item and the **Print** option.

Step 2  Select the **Print TCCD of Selected Site** sub-menu item.
Step 3 From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material. Click on the OK button AIM II will open the Print window where you can select the printer desired.

Step 4 Highlight the desired site and click on the Select menu item for print. AIM II will open the Print window where you can select the printer desired.

Step 5 After the printer selection has been made click on the OK button. AIM II will prepare the TCCD for printing and send the printout to the printer.

2.6 COURSE MAINTENANCE

After the AIM Administrator has approved the Course (TPP through TG), a Revision or a Change can be created for the Course. When required, you can initiate a Change or Revision by performing the following.

To create a revision:

When a Revision is created for a course in the AIM II database, the TPP must be completed and Locked before the TCCD can be maintained.

Step 1 From the AIM II window; select the Course menu item and the Select Course sub-menu item.

Step 2 From the Course Select window highlight the Course that you want to revise and select the Options menu item and the Maintain/Revision option.

Step 3 At the prompt "Are you sure you want to create a Revision for this Course?" click on the Yes button to proceed or the No button to return to the Course Select window.

Step 4 At the prompt "Copy LP/TG information with Course?" click on the Yes button to copy the entire LP/TG of the current baseline for the revision or click on No to copy the approved course less the user developed Discussion Points (DPs) and Related Instructor Activities (RIAs).
NOTE: If the LP/TG information is not copied, the Instruction Sheets, developed for the baseline course, are available for selection for the RIAs when developing the new LP.

Step 5 After AIM II creates the revision for the course, it will return you to the Course Select window and the revision created will be highlighted. Click on the Select menu item and AIM II will return you to the AIM II menu.

To create a change:

When a Change is created the TCCD must be completed and Locked before the LP/TG can be maintained.

Step 1 Select the AIM II Course menu item and the Select sub-menu item.

Step 2 From the Course Select window highlight the approved course that requires maintenance and select the Options menu item and the Maintain option.

Step 3 Select the Change sub-menu item. AIM II will create a change for the course by copying the approved course. When completed the next sequential change to the course will be identified in the Course Select menu. Highlight the Change, click on the Select menu item, and AIM II will return you to the AIM II menu.

To add a later version of an IETM to a Learning Site RRL in the TCCD:

A later version of IETM for the course can be added during the development of a course or during Maintenance.

Step 1 Select the Course menu item and the Select sub-menu item.

Step 2 Highlight the desired course and click on the Select menu item.

Step 3 From the AIM main menu select the Document menu item and the Training Course Control Document (TCCD) sub-menu item.

Step 4 From the TCCD cover page select the Options menu item and the Unlock option.

Step 5 Select the Contents menu item and the Learning Sites sub-menu item.
Step 6  From the Learning Site window, click on the desired site and select the Options menu item and the Modify/View option.

Step 7  From the Course Data window select the RRL menu item.

Step 8  From the Learning Site RRL window click on the Resources menu item and the IETM sub-menu item.

Step 9  Click on the new IETM identifier in the Site RRL (bottom pane) and select the Options menu item and the Select Later IETM option.

Step 10 When prompted with "During the Select Later IETM process all RIA/TG Sheets will be updated to reflect the use of the new IETM. These changes will be saved now and you will not be able to undo this action. Continue?" click on the Yes button. AIM will flag the updated RIAs and TG Sheets with System Flags to indicate the reference has been updated to a later version IETM and the IETM has been modified or deleted.

Step 11 Exit to the TCCD cover page select the Options menu item and the Lock option. Select the Exit menu item to return to the AIM main menu.
Appendix G

NAVSPECWAR TRAINING PROJECT PLAN (TPP) MODULE

1.0 TRAINING PROJECT PLAN (TPP) ................................................................. G-1
1.1 ELEMENTS OF A TPP ............................................................................. G-1
1.2 USING THE AIM II TPP MODULE ......................................................... G-2
  1.2.1 Overview of the AIM II TPP Module .............................................. G-2
1.3 CREATING A NEW, REVISION, OR CANCELLATION TPP .................... G-4
  1.3.1 Development of a New TPP .............................................................. G-4
  1.3.2 Development of a Revision TPP ...................................................... G-8
  1.3.3 Development of a Cancellation TPP ............................................... G-11
1.4 SELECTING A TPP ............................................................................... G-13
1.5 TPP CONTENTS .................................................................................... G-14
  1.5.1 Compensation ................................................................................ G-14
  1.5.2 Course Overview/Comments .......................................................... G-17
  1.5.3 Justification .................................................................................... G-19
  1.5.4 Milestones ..................................................................................... G-21
  1.5.5 Safety Risks and Hazardous Materials .......................................... G-22
  1.5.6 Summary of Differences ............................................................... G-23
  1.5.7 Selecting Learning Sites ................................................................ G-24
  1.5.7.1 Unselecting a Learning Site ...................................................... G-27
  1.5.7.2 Identifying Resources for a Learning Site .................................. G-28
  1.5.7.2.1 Identifying Resources ....................................................... G-29
  1.5.7.2.2 Manpower .......................................................................... G-31
  1.5.7.2.3 Funding ............................................................................... G-32
  1.5.7.2.4 Facility ................................................................................. G-33
  1.5.7.2.5 Select RRL Items ............................................................... G-33
  1.5.7.2.6 Unselect RRL Items ............................................................ G-35
  1.5.7.2.7 Explain Flag ......................................................................... G-36
  1.5.7.2.8 Remove Flag ....................................................................... G-36
1.6 TPP OPTIONS .......................................................................................... G-37
  1.6.1 Lock/Unlock ................................................................................ G-37
  1.6.2 Grant Privilege ............................................................................... G-38
  1.6.3 Print Preview .................................................................................. G-38
  1.6.4 Print ............................................................................................... G-39
1.7 ON-LINE HELP ...................................................................................... G-39
1.0 TRAINING PROJECT PLAN (TPP)

A curriculum development project is a complex undertaking, bringing together a wide range of human and material resources to create quality training. The task based curriculum development process, in accordance with NAVEDTRA 130B, consists of six phases, beginning with the Plan Phase. This phase consists of gathering information and building the plan for training material development, revision, or cancellation. The output product of this phase is the Training Project Plan (TPP). When approved, the TPP becomes the authorization to undertake a course revision or cancellation, or a new course development project, and initiate resource requisitions. For development of a TCCD to support a CNATT curriculum refer to Appendix F.

Course development and, often, course revisions require the identification of resources to develop or implement the proposed course. Resources fall into four broad categories: (1) facilities, (2) funding, (3) personnel, and (4) equipment. All four categories require long lead-time planning. An approved TPP is the authority to submit requests for resources.

In the case of a course cancellation, the approved TPP provides justification for the action and identification of resources for reallocation.

1.1 ELEMENTS OF A TPP

Specific elements of data and information shall include the following items where applicable:

- Cover Page
- Table of Contents
- Course Data for each Learning Site
- Course Overview/Comments
- Justification/Summary of Differences (for a Revision TPP)
- Safety Risks and Hazardous Materials exposure
- Resources Requirements for each Learning Site
- Compensation Manpower and Funding
- Milestones

NOTE: When the TPP is locked, work can begin on the next step in the project, the Analyze Phase.
1.2 USING THE AIM II TPP MODULE

The AIM II TPP Module provides all of the tools to develop New, Revision, and Cancellation TPPs. The program will present a series of windows starting with the AIM II window. These windows have a menu across the top and a tool bar below the menu. The tool bar contains icons that represent different program features.

You can select options from the menu in two ways; by pressing the ALT key and the underlined letter, or by clicking on the option with the left mouse button. With either method, selecting an option from the menu or the button bar brings up windows that allow you to enter the data necessary to complete a TPP.

If you are working on a new TPP, the fields presented in the window will be blank. You must provide the appropriate information by either typing the information in the correct field or selecting from a series of drop-down menus. If you are working on a TPP that is in progress or completed, you can edit existing data and/or provide new data as necessary. Each window is explained in this user's manual with instructions on how to fill in the necessary data.

1.2.1 Overview of the AIM II TPP Module

Each of the following steps is explained in further detail in this guide. These paragraphs are meant as a quick reference for getting around the software.

You can start a new TPP by selecting the Course menu item and the New sub-menu item on the AIM II main menu bar, or clicking on the "New" icon from the tool bar. If you are working on an existing TPP, choose the Course menu item and the Select sub-menu item from the main menu bar or click on the "Select Course" icon. A list of available courses will appear. Select the course to work on from the list by either highlighting the desired course and then clicking on the Select menu item, or by double clicking on the desired course.

From the Course Select window you can select the Options menu item and the Copy option to copy an existing TPP or Course. Copying a TPP or Course will open the Course Information window, where you can enter the CIN, Revision, Change, and Title of the Course that will be developed, revised, or cancelled, provided the CIN does not exist in the AIM II database.

Copying a TPP produces an Incomplete TPP with all the data of the TPP copied, no associated CTTL or TCCD, and allows the user to develop a New (Rev 0 Chg 0), Revision or Cancellation TPP. Copying a Course produces a complete TPP with a copy of all the training materials contained in the Course that was copied. This option allows you to create a New or Cancellation TPP for the CIN entered in the Course Information window.
The Course Select window provides the option to maintain an approved curriculum. Highlighting the desired course and selecting the **Options** menu item and the **Maintain/Revision** option allows you to create a Revision TPP and Course for the highlighted course.

Selecting the **New** sub-menu item opens the TPP window and allows you to create a New, Revision or Cancellation TPP. If you select a course from the Course Select window, AIM II will return you to the main menu and the TPP through TG icons will be enabled for the selected course. A new course will have blank fields in the TPP window, while an existing course will have data in the fields. If you enter a Revision letter in the Rev field of the new TPP the TPP type will change from New to Revision. To develop a Cancellation TPP for a course not contained in the AIM II database click on the menu arrow of the Type field and select Cancellation. After completing or modifying the data in the window, you must select the **Edit** menu item and the **Save** sub-menu item to save the changes. If you do not wish to save your changes, you can select **Cancel**. You must either save or cancel before proceeding further. Once the cover page is saved the Rev and Chg fields cannot be edited.

AIM develops a course tree structure when the TPP cover page is saved to the database. From this browser you can open folders of the various elements of the course. Clicking on a folder and selecting the **Options** menu item and the **GoTo** sub-menu item will open the desired portion of the course. If a folder contains sub-elements, the contents will be displayed on the upper right hand side of the grid. Double clicking on the desired folder in the upper right hand grid will open the desired window. The lower right hand portion of the grid displays Summary data contained in the folder or sub-element item highlighted. A check block is provided for each folder in the course tree. As you complete development of each folder, click on the check block to identify that this item is complete. Private or public notes can be added to the training material items for management of the curriculum by clicking on the desired folder, selecting the **Options** menu item and the **Edit Note** option.

You can also access the different portions of the course selected by clicking on the **Document** menu item and clicking on the desired sub-menu item. This method allows you to access all elements contained within the document. Each document also has an associated icon. For ease of explaining the steps involved in developing the different portions of each training material item this User’s manuals directs you to use the Document sub-menu item or associated icons.

To identify where the proposed course will be taught, you will select the TPP window **Contents** menu item and the **Learning Sites** sub-menu item. You will be provided with a "Learning Site Summary" window. Here you can enter the Course Data Processing (CDP) code, course length in calendar days, class minimum and maximum capacity, class convenings per year, and student throughput per year for each selected site.
NOTE: A CDP code denotes a course and a location for NITRAS processing. This code may not be available at this point in the development process. This entry is optional.

After you have entered the data for the Learning Site Summary window, you can select RRL to access the TPP Resource Requirements List (RRL) for the site highlighted. From here you can select RRL items to be used in the course by the Learning Site. Selecting Resource allows you to select RRL types as well as input manpower, funding, and facility data.

NOTE: The first Learning Site selected will be the Course Curriculum Model Manager (CCMM) and provide the default RRL items available. AIM II will allow you to use the RRL data from the first site selected for subsequent sites. This option will become available when another site is selected.

Returning to the TPP window, you can select Contents to provide the information for compensation, course overview/comments, justification, milestones, safety risks and hazardous materials, summary of differences for a Revision TPP, and Learning Sites.

You can lock your TPP from the Options menu item when all the data required has been added.

NOTE: When the TPP is locked for the first time, shared data will be copied to the TCCD Module.

1.3 CREATING A NEW, REVISION, OR CANCELLATION TPP

There are three types of TPPs: New, Revision, and Cancellation. There are different methods to develop each type, depending on whether you desire to use existing data in the database or not.

1.3.1 Development of a New TPP

If you need to develop a new TPP for a course, you will either select the Course menu item and the New sub-menu item, which will open a TPP window with blank fields, or highlight a course which contains a TPP similar to the TPP to be developed in the Course Select window and select the Options menu item and the Copy TPP/Course option.

NOTE: Learning Sites and Agency information must be included in the database prior to the development of the first TPP. This information is provided through the AIM II Utilities menu item and the Learning Site and Agency sub-menu items. For more information refer to Appendix B.
To create a New TPP using the Course menu item and the New sub-menu item:

Step 1  From the AIM II window, select the Course menu item and the New sub-menu item, or click on the New Course icon.

You will be presented with the Training Project Plan (TPP) window *(Figure 3-1)*.

The cursor will now be in the first field that will be blank. Use the Tab key to move from field to field, or position the cursor in the desired field.

Step 2  Enter the Course Identification Number (CIN). The CIN can be modified for the New course until the TPP has been approved.
NOTE: As a safety precaution, Tabbing between fields does not take you to the Revision or Change fields, you have to click in them explicitly to modify the contents. The ability to modify the Rev and Chg has been provided to permit development of a revision for a course that does not exist in the AIM II database or re-development of a course that exists in a different medium. The Rev and Chg fields cannot be edited after the cover page of the TPP is saved.

Step 3 Select "Prepared By" and "Prepared For" from the drop-down menus.

Clicking on the down arrows will scroll the available options. Select the correct item by clicking the left mouse button.

Step 4 Type the complete course title. Do not use abbreviations.

Step 5 Type in the Short Title if applicable. Use of recognized acronyms is permitted.

Step 6 Type in the Training Type if applicable.

Step 7 Type in the Work Center if applicable.

Step 8 Type in the Purpose of Course with respect to the following questions:
  a. Who is to be trained?
  b. What job will the person be trained to perform?
  c. What is the degree of qualification, or how well will the person be able to perform the job?
  d. Where will the person utilize the training?
  e. What are the conditions under which the graduate will perform on the job?

Step 9 Type in the Occupational Classification/prerequisites for the course.

You can use the Tab key to advance forward through the fields or use the mouse to position the cursor. To go backwards through the fields, press Shift + Tab.

CAUTION: When the TPP is completed and locked the TPP information is copied to the Training Course Control Document (TCCD). Do not lock the TPP until all data required has been entered.

Step 10 Click on the Edit menu item and the Save sub-menu item.
If you do not want to save the TPP information that you have entered, you can select Cancel.

Step 11 Refer to paragraphs 3.5 and 3.6 to complete the TPP.

To create a New TPP from an existing TPP:

Step 1 From the AIM II window, select the Course menu item and the Select Course sub-menu item.

Step 2 From the Course Select window, highlight the Course that will be copied and select the Options menu item and the Copy option.

Step 3 To copy the TPP only, select the TPP sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN and edit the Title of the new course.
   b. Click on the Edit menu item and the Save sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the Course Select window.

Step 4 To copy the entire Course, select the Course sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, and Chg of the new course and edit the Title.
   b. Click on the Edit menu item and the Save sub-menu item.
   c. Click on Yes to confirm you want to copy the Course. AIM II will copy the Course and return you to the Course Select window.

Step 5 From the Course Select window highlight the new course and click on the Select menu item.

Step 6 From the AIM II menu click on the TPP icon.

Step 7 Refer to paragraphs 3.5 and 3.6 to complete the TPP.
1.3.2 Development of a Revision TPP

Development of a Revision TPP can be undertaken to develop a revision for a course that exists in the AIM II database or does not exist in the AIM II database. Re-development of a revised course that exists in a different medium will also result in a Revision, whether the developer initially selects the New menu item or utilizes the copy option because entry in the Rev field is required.

To create a Revision TPP for a course contained in the AIM II database using the Course menu item and the Select Course sub-menu item:

Step 1 From the AIM II window; select the Course menu item and the Select Course sub-menu item.

Step 2 From the Course Select window highlight the Course that you want to revise and select the Options menu item and the Maintain/Revision option.

Step 3 At the prompt "Are you sure you want to create a Revision for this Course?" click on the "Yes" button to proceed or the "No" button to return to the Course Select window.

Step 4 At the prompt "Copy LP/TG information with Course?" click on the "Yes" button to copy the entire LP/TG of the current baseline for the revision or click on "No" to copy the approved course less the user developed Discussion Points (DPs) and Related Instructor Activities (RIAs).

NOTE: If the LP/TG Information is not copied, the Instruction Sheets, developed for the baseline course, are available for selection for the RIAs when developing the new LP.

Step 5 After AIM II creates the revision for the course, it will return you to the Course Select window and the revision created will be highlighted. Click on the Select menu item and AIM II will return you to the AIM II menu.

Step 6 Select the Document menu item and the Training Project Plan (TPP) sub-menu item or click the TPP icon to open the TPP window.

Step 7 Refer to paragraphs 3.5 and 3.6 to edit the TPP for the Revision.
To create a Revision TPP for a course not contained in the AIM II database using the Course menu item and the New sub-menu item:

Step 1  From the AIM II window select the Course menu item and the New sub-menu item.

You will be presented with the Training Project Plan (TPP) window and your cursor will be in the first field, which will be blank. Use the Tab key to move from field to field.

Step 2  Type the Course Identification Number (CIN). The CIN can be modified for the course until the TPP has been approved.

**NOTE:** As a safety precaution, Tabbing between fields does not take you to the Revision or Change fields, you have to click in them explicitly to modify the contents. The ability to modify the Rev and Chg has been provided to permit development of a revision for a course that does not exist in the AIM II database or re-development of a course that exists in a different medium. When the cover page of the TPP is saved these fields can no longer be edited.

Step 3  Click on the Rev field and enter the alpha character for the Revision. The TPP type will change from New to Revision when the alpha character is entered into the field.

Step 4  If you are re-developing a revised course that does not exist in the AIM II database and this course has undergone change(s) enter the change number in the Chg field.

Step 5  Select "Prepared By" and "Prepared For" from the drop-down menus. Clicking on the down arrows will scroll the available options. Select the correct item by clicking the left mouse button.

Step 6  Type the complete course title. Do not use abbreviations.

Step 7  Type in the Short Title if applicable. Use of recognized acronyms is permitted.

Step 8  Type in the Training Type if applicable.

Step 9  Type in the Work Center if applicable.
Step 10  Type in the Purpose of Course with respect to the following questions:
   a. Who is to be trained?
   b. What job will the person be trained to perform?
   c. What is the degree of qualification, or how well will the person be able to perform the job?
   d. Where will the person utilize the training?
   e. What are the conditions under which the graduate will perform on the job?

Step 11  Type in the Occupational Classification/prerequisites for the course.
         You can use the TAB key to advance forward through the fields or use the mouse to position the cursor. To go backwards through the fields, press Shift + Tab.

         **CAUTION:** When the TPP is completed and locked the TPP information is copied to the Training Course Control Document (TCCD). Do not lock the TPP until all data required has been entered.

Step 12  Click on the **Edit** menu item and the **Save** sub-menu item.

         If you do not want to save the TPP information that you have entered, you can select **Cancel**.

Step 13  Refer to paragraphs 3.5 and 3.6 to complete the TPP.

**To create a Revision TPP for a course not contained in the AIM II database using the Course menu item and the Select Course sub-menu item:**

Step 1  From the AIM II window; select the **Course** menu item and the **Select Course** sub-menu item.

Step 2  From the Course Select window, highlight the Course that will be copied and select the **Options** menu item and the **Copy** option.

Step 3  To copy the TPP only, select the **TPP** sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, and Chg as appropriate and edit the Title of the new course.
   b. Click on the **Edit** menu item and the **Save** sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the course select window.
Step 4 To copy the entire Course, select the **Course** sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, Chg of the course and edit the Title.
   b. Click on the **Edit** menu item and the **Save** sub-menu item.
   c. Click on Yes to confirm you want to copy the Course. AIM II will copy the Course and return you to the course select window.

Step 5 From the Course Select window highlight the new course and click on the **Select** menu item.

Step 6 From the AIM II menu click on the TPP icon.

---

**NOTE:** The TPP has a Complete Status when Copy/Course is performed and an Incomplete Status when Copy/TPP is performed.

Step 7 Refer to paragraphs 3.5 and 3.6 to complete the TPP.

### 1.3.3 Development of a Cancellation TPP

**To develop a Cancellation TPP for a course contained in the AIM II database:**

Step 1 From the AIM II window; select the **Course** menu item and the **Select Course** sub-menu item.

Step 2 From the Course Select window, highlight the Course that the Cancellation TPP will be developed for and select the **Options** menu item and the **Copy** option.

Step 3 Select the **Training Project Plan** sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN and append CAN to the end of the CIN for the development of the Cancellation TPP.
   b. Click on the **Edit** menu item and the **Save** sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the course select window.

Step 4 From the Course Select window highlight the Cancellation course and click on the **Select** menu item.

Step 5 From the AIM II menu click on the TPP icon.
Step 6 Refer to paragraphs 3.5 and 3.6 to complete the appropriate portions of the Cancellation TPP.

There are two methods to develop a Cancellation TPP for a course not contained in the AIM II database:

1. The first method is to use paragraph 3.3.1 (Development of a New TPP) using the Course menu item and the New sub-menu item and click on the Training Project Plan (TPP) window Cancellation button.
2. The second method is to use the Course Select window Copy option to copy an existing TPP and edit the fields for the TPP you are developing.

To develop a Cancellation TPP for a course not contained in the AIM II database using the Copy TPP option:

Step 1 From the AIM II window; select the Course menu item and the Select Course sub-menu item.

Step 2 From the Course Select window, highlight the Course that will be copied and select the Options menu item and the Copy option.

Step 3 To copy the TPP, select the TPP sub-menu item. AIM II will open the Course Information window. Perform the following:
   a. Enter the CIN, Rev, and Chg as appropriate and edit the Title of the course for the development of the Cancellation TPP.
   b. Click on the Edit menu item and the Save sub-menu item.
   c. Click on Yes to confirm you want to copy the TPP. AIM II will copy the TPP and return you to the course select window.

Step 4 From the Course Select window highlight the new course and click on the Select menu item.

Step 5 From the AIM II menu click on the TPP icon.

Step 6 Refer to paragraphs 3.5 and 3.6 to complete the appropriate portions of the Cancellation TPP.
1.4 SELECTING A TPP

Once the TPP window fields have been saved to the AIM II database, you can exit the TPP and return to it later for editing or modification.

There are four different ways to access a TPP window after the course has been selected from the Course Select menu:

1. From the AIM II main menu select the Document menu item and the Training Project Plan (TPP) sub-menu item.
2. Click on the TPP icon.
3. From the course tree structure click on the CIN folder. This will identify the elements of the course on the upper right hand grid. Either double-click on the TPP element in the upper right hand grid or single click on it and select the Options menu item and the GoTo sub-menu item.
4. From the course tree structure click on the TPP folder, select the Options menu item and the GoTo sub-menu item. Opening the TPP folder can provide Summary or Note data on the right hand portion of the course tree grid if the View menu sub-items (Note or Summary) have been checked. Summary data includes the information contained in the TPP window and Note data contains Personal and/or Private Notes recorded by developers.

If the TPP window cover page is complete and you desire to work on an element within the TPP you can either select the element from the Contents menu item in the TPP window or double-click on the TPP folder in the course tree structure. Double-clicking the TPP folder or clicking on the “+” box next to the TPP will expand the tree information to include the contents of the TPP. Once the tree has been expanded you can click on the element desired and can exercise Options menu sub-items (Edit Note and GoTo) and View menu sub-items (Note and Summary).

If the Status field of the course selected from the Course Select window is Incomplete you can modify all of the data in the window except the Rev, Chg, and Status fields. If the status of the course selected is Locked, you will have to select the TPP window Options menu item and the Unlock option to edit the fields. Once Unlocked, the Status field will change to Complete which signifies the TPP can be edited but the information will not be copied to the TCCD. To save your changes to the TPP window you must select the Edit menu item and the Save sub-menu item. (If you do not save the cover page data after editing, you will not be able to access the Options or Contents menu.)

From this window you can select the Options or Contents menu sub-items.
1.5 TPP CONTENTS

After saving the data in the TPP window fields and selecting a TPP, you can edit or create the TPP Contents.

The elements of the TPP contents are:
- Compensation
- Course Overview/Comments
- Justification
- Milestones
- Safety Risks and Hazardous Materials
- Summary of Differences
- Learning Sites

1.5.1 Compensation

Use this window to provide recommended source of compensation for both manpower and funding. Identify possible course cancellations/reductions, cross utilization of instructors, etc.

To enter TPP Compensation:

Step 1 From the TPP window; select the Contents menu item and the Compensation sub-menu item. From the drop-down menu you will have two options: Manpower and Funding.

To enter the TPP Manpower data:

Step 1 Click on Manpower from the TPP Compensation drop-down menu. This will open the TPP Manpower Compensation window.

Step 2 In the Site Name field either select the Learning Site from the drop-down list or type in the name of the Learning Site.

After each entry press the TAB key to advance to the next field. You can use Shift+Tab to move backwards. The mouse can also be used to select the desired field.
Step 3 Enter the Number/Type of Billets e.g., 2/E-6 4245. Use <CTRL> and <ENTER> to add additional Number/Type of Billets entries to the same field.

Step 4 Type in the source of the funding, by positioning the cursor in the Source field and typing in the information.

Step 5 Estimate the manpower shortfall, if any, and enter the shortfall.

Step 6 Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries.

Step 7 Click on the Exit menu item to return to the TPP window.

To enter the TPP Funding Compensation data:

Step 1 From the TPP window select the Contents menu item and the Compensation/Funding sub-menu items. This will open the TPP Funding Compensation window, Figure 3-2.
Step 2  In the O&M, Procurement, Total Funding, and Shortfall fields enter the appropriate amounts. Enter the Dollar Amount. You can enter whole numbers. The program will automatically format the number to a currency entry including two decimal places.

Step 3  Select the Source of Compensation from the Source of Compensation drop-down menu.
1.5.2 Course Overview/Comments

In the course overview/comments of the TPP, list course subjects. Note any changes from any previous project plan. For a new course, this will be a description of the skills and knowledge to be attained. This is not intended to be the equivalent of a curriculum outline or to contain objectives. The overview will help the Training Agency understand what the course will actually contain.

To enter the Course Overview/Comments:

Step 1 From the TPP window; select the Contents menu item and the Course Overview/Comments sub-menu item. AIM II will open the Course Overview/Comments window, which contains the AIM Text Editor menu items.

Step 2 If the Course Overview/Comments exist in an ASCII file, you can select the Options menu item and the Import Text File option to select the file and import the contents of the file into the AIM text editor. If a text file doesn't exist, type in the Course Overview/Comments.

Step 3 Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries.

Step 4 Click on the Exit menu item to return to the TPP window.
1.5.3 Justification

There must be a reason (or reasons) to undertake the development of a new course or the revision of an existing course. The justification for initiating the development of a new course or the revision of existing training materials can come from:

- Navy Training Plans (NTPs) (OPNAVINST 1500.8)
- Tasking by higher authority
- Internal course reviews and local command initiatives
- External course reviews
- Surveillance and external feedback
- Training appraisal.

To enter a TPP Justification:

Step 1 Select the Contents menu item and the Justification sub-menu item from the TPP window. AIM II will open the Justification window (refer to Figure 3-3).

After each entry, press the TAB key to advance to the next field.
Step 2   Enter the References.

Step 3   Enter the reasons/sources of information.

Step 4   Enter the impact if not approved.

Step 5   Select the **Edit** menu item and the **Save** sub-menu item to save your entries.

Step 6   Select the **Exit** menu item to return to the TPP window.
1.5.4 Milestones

**Milestones** are a time-phased narrative commencing with TPP approval. Your milestones should include identification of major developmental products or events relating to the training materials development method selected, and end with implementation. For each event, you will enter a start date and a projected completion date.

The initial list of Milestones is provided for you. You may edit this list by adding, modifying, or deleting the default list. All initial dates supplied will be the computer date the TPP was initiated and any new milestones added would be the computer date of when the milestone was added.

Dates can be added automatically by selecting the calendar icon or manually as day, month, year (dd. mmm, yy) or month/day/year. AIM II will convert entries to day, month, and year.

**To enter/add TPP Milestones:**

- **Step 1** From the TPP window; select the **Contents** menu item and the **Milestones** sub-menu item. AIM II will open the TPP Milestones window.

- **Step 2** The milestones are automatically numbered. Using the mouse, highlight the content field of the first milestone you would like to edit.

- **Step 3** Edit the description of the milestone.

- **Step 4** Today's date will be entered as the default start date. You can Tab to the next field or type over/select another start date. To enter a different date using the calendar icon:

  - **NOTE:** To delete a Start/Completion dates double-click in the field to get an edit background and either use the Backspace key or highlight the date and delete it with the Delete key.

    a. Click on the Date Start field and a calendar icon will appear.
    b. Click on the calendar icon and the currently selected calendar will appear.
    c. Click on the month down arrow and select the desired month.
    d. Click on the year down arrow and select the desired year.
    e. Click on the desired day and the date will be entered into the Start Date field.
Step 5  Type in the projected end date in the Date Complete field. To enter a different date using the calendar icon:
   a. Click on the Date Complete field and a calendar icon will appear.
   b. Click on the calendar icon and the currently selected calendar will appear.
   c. Click on the month down arrow and select the desired month.
   d. Click on the year down arrow and select the desired year.
   e. Click on the desired day and the date will be entered into the Date Complete field.

Step 6  You can continue to edit milestones in this manner.

NOTE: Once you have entered milestones and saved them, to add additional milestones you must select Options from the menu and Add from the drop-down menu. The new milestones will be added below the current cursor position.

To delete a milestone:

Step 1  Using the mouse, click anywhere on the milestone that you want to delete.

Step 2  Select the Options menu item and the Delete option. The program will ask you to confirm your choice.

Step 3  Click on Yes. The milestones will automatically be renumbered.

Step 4  You may continue to delete milestones in this manner.

Step 5  Select the Edit menu item and the Save or Cancel sub-menu item with regard to your entries.

Step 6  Click on the Exit menu item to return to the TPP window.

1.5.5 Safety Risks and Hazardous Materials

To enter data in the Safety Risks and Hazardous Materials field:

Step 1  From the TPP window; select the Contents menu item and the Safety Risks and Hazardous Materials sub-menu item. AIM II will open the Safety Risks and Hazardous Materials window, which contains the AIM Text Editor menu items.
Step 2 Enter in the identified Safety Risks and Hazardous Materials or type in a statement to the effect that there is none identified for this course.

**NOTE:** If the information required exists in a text file in a Windows editor, rather than retype all of the information required into the AIM Editor, you can use the Options menu item and the Import Text File option to retrieve the text file for the TPP.

Step 3 Select the **Edit** menu item and the **Save** or **Cancel** sub-menu item with regard to your entries.

Step 4 Click on the **Exit** menu item to return to the TPP window.

### 1.5.6 Summary of Differences

The Summary of Differences sub-menu item is used when you are developing a TPP for a revision to a course. It allows you to summarize the differences between the current baseline of the TCCD, LP, and TG and the planned revision of the course. The Summary of Differences will print with the Justification of the TPP prior to the Impact if not approved portion of the Justification.

**To enter Summary of Differences:**

Step 1 Open the TPP Summary of Differences window by performing one of the following:

a. With the TPP folder open in the Course Tree Structure; double click on the Summary of Differences folder in the upper right hand panel,

b. Expand the TPP and open the Summary of Differences folder in the Course Tree Structure and click on the Go button on the toolbar,

c. After selecting the course, access the TPP window by either selecting the **Document** menu item and the **Training Project Plan (TPP)** sub-menu item or click on the TPP icon. Select the **Contents** menu item and the **Summary of Differences** sub-menu item.

Step 2 From the Styled Text Editor add the desired text.

Step 3 After entering the text you can choose one of two ways to exit:
First Method:
- Select the **Edit** menu bar item.
- Select **Save** to save your text and/or select **Cancel** to delete your new data entries and return to the AIM I Text Editor window.
- Select the Exit menu bar item. AIM I will return you to the TPP window or the Course Tree Structure.

Second Method:
- Select the **Exit** menu bar item. If the text has been entered/modified, AIM I will prompt, *Edit Text has been modified. Would you like to save new data?*

If there is no new data, selecting this item will return you to the TPP main window or the Course Tree Structure.

1.5.7 Selecting Learning Sites

When developing a TPP, you must select all Learning Sites where the proposed course will be taught. You must select and save a Learning Site before you can add items to the resource requirements list.

**NOTE:** The option to print each site's RRL individually or all sites is provided in the TCCD Module.

To select a Learning Site:

**Step 1** From the TPP window; select the **Contents** menu item and the **Learning Sites** sub-menu item. AIM II will open the Learning Site Summary window, which contains a list of all the Learning Sites in the database.

**NOTE:** Learning Sites are added to the list through the AIM Utilities. If you do not see the Learning Site that you want to select, it can be added through the AIM Utilities Module. Contact your AIM Administrator to add the desired sites.

**Step 2** Click on the desired Learning Site.

**Step 3** Select the **Options** menu item and the **Select** option. An ‘X’ will appear in the Select column for the site selected.

**Step 4** The cursor will appear in the CDP (Course Data Processing Code) field. Enter the CDP if known. You will be allowed to enter four characters. The software will
check for duplicate entries. A CDP entry is not required. After each entry press the TAB key to advance to the next field.

Step 5 Type in the course length in days, which includes weekends. Fields are provided for both the current and planned course lengths and both should be completed. For a new TPP the Current fields should contain zeroes (0).

Step 6 For Class, Lab, and PA (Practical Application) hours enter the number of hours appropriate for each.

Step 7 Type in the number of classes per year for each site, both current and planned.

Step 8 Type in the minimum and maximum class capacity, both current and planned.

Step 9 Type in the class convenings, both current and planned.

Step 10 Type in the annual student throughput (up to 5 digits).

Step 11 Fill in Site Consideration data with any training unique site information that is not contained elsewhere.

NOTE: The average on board is automatically calculated.

You can use the TAB key to advance forward through the fields. To go backwards through the fields, press Shift + Tab. Once you are satisfied with the Learning Site Summary data, as you have entered it, you must Save it.

Entering that information in the Site Considerations field can identify any unique site items.

Step 12 Select the Edit menu item and the Save sub-menu item. If this is the first site that has been selected an "X" will appear in the CCMM (Course Curriculum Model Manager) column next to the site that you selected.

If you do not want to save the Learning Site information that was entered, you can select Cancel.

AIM II will verify that the student throughput is less than or equal to the Class max. Capacity multiplied by the Class Convenings.

Step 13 Select Exit to return to the TPP window.
NOTE: You must repeat this procedure for each Learning Site that you select. The RRL information from the first site selected can be used as default information for all subsequent sites. Therefore, it is recommended that you complete paragraph 3.5.8.2 "Identifying Resources" for the original site selected before selecting additional sites. You will be asked if you would like to use the CCMM data as the default for each additional site selected.

To select an additional Learning Site:

Step 1 From the TPP window; select the Contents menu item and the Learning Sites sub-menu item. AIM II will open the Learning Site Summary window, which contains a list of all the Learning Sites in the database.

NOTE: Learning Sites are added to the list through the AIM Utilities. If you do not see the Learning Site that you want to select, it can be added through the AIM Utilities Module. Contact your AIM Administrator to add the desired sites.

Step 2 Select the Options menu item and the Show Selected Sites Only if it has a check mark next to it to view all the Learning Sites in the Learning Site Utility. Click on the desired Learning Site.

Step 3 Select the Options menu item and the Select option. The prompt “Would you like to use (CCMM data) as default?” will appear.

Step 4 Select Yes or No as appropriate. If yes was selected you will be asked if you would like to update the database with the default data. If you selected Yes an "X" will appear in the Sel column next to the site that you selected to indicate that it should be included in the TPP, the Course Data and RRL data entered for the CCMM will be reflected in the new site selected.

Step 5 The cursor will appear in the CDP (Course Data Processing Code) field. Enter the CDP if known. You will be allowed to enter four alphanumeric characters. The software will check for duplicate entries. A CDP entry is not required.

After each entry press the TAB key to advance to the next field. If you copied the original site information the Course Data fields and RRL can be edited for the new site.

Step 6 Type in the course length in days, which includes weekends. Fields are provided for both the current and planned course lengths and both should be completed. For a new TPP the Current fields should contain zeroes (0).
Step 7 For Class, Lab, and PA (Practical Application) hours enter the number of hours appropriate for each.

Step 8 Edit/type in the number of classes per year for each site, both current and planned.

Step 9 Edit/type in the minimum and maximum class capacity, both current and planned.

Step 10 Edit/type in the class convenings, both current and planned.

Step 11 Edit/type in the annual student throughput (up to 5 digits).

Step 12 Fill in Site Consideration data with any training unique site information that is not contained elsewhere.

**NOTE:** The average on board is automatically calculated.

You can use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. Once you are satisfied with the Learning Site Summary data, as you have entered it, you **must Save** it.

Entering that information in the Site Considerations field can identify any unique site items.

Step 13 Select the **Edit** menu item and the **Save** sub-menu item.

If you do not want to save the Learning Site information that was entered, you can select **Cancel**.

AIM II will verify the student throughput is less than or equal to the Class max. Capacity multiplied by the Class Convenings.

Step 14 Select **Exit** to return to the TPP window.

### 1.5.7.1 Unselecting a Learning Site

Step 1 From the TPP window select the **Contents** menu item and the **Learning Sites** sub-menu item. AIM II will open the Learning Site Summary window, which contains a list of all the Learning Sites in the database.
1.5.7.2 Identifying Resources

For each Learning Site that you select, you will provide a best estimate of the known and anticipated resources necessary to implement the training. This part of the TPP is the Resource Requirements List (RRL).

To build a Resource Requirements List:

Step 1 From the TPP window select the Contents menu item and the Learning Sites sub-menu item. The Learning Site Summary window will open which contains a list of Learning Sites in the database.

Step 2 Use your mouse to highlight the Learning Site that you want to work on. The site must have an "X" in the Sel column, which indicates that it has been selected.
Step 3  Select the RRL menu item. AIM II will open the TPP RRL window. From here you can select the resources for your Learning Site.

1.5.7.2.1  Identifying Resources for a Learning Site

Although the training resources required to teach a course *might* be the same from site to site, each Learning Site will at least be different with respect to the resources on hand. For each Learning Site, the AIM II program will contain a master database for the Site RRL. This is an inventory of all of the types of resource requirement items that reside at the site. To convey what resources will be required to teach the course at each site, you would build a separate RRL for each site.

NOTE: You must select RRL items in this module or the TCCD module in order for them to be available in the CTTL, Testing, LP and TG Modules. You may print each site's RRL in the TCCD Module.

From the Learning Site Summary window, after you have selected RRL, you can begin to select items for the Learning Site RRL from those available in the Site RRL, *Figure 3-5.*
To add RRL items to the Learning Site:

Step 1  From the Learning Site Summary window select the **RRL** menu item.

Step 2  From the TPP RRL window, click on **Resources**. This will bring up a drop-down menu, which includes all of the types of resources available to include in the TPP.

The first three elements (Manpower, Funding, and Facility) from the Resource drop-down menu require additional input.
1.5.7.2.2 Manpower

For new courses or revisions, you should identify officer, enlisted, and civilian billets required, the number of billets authorized, the number of compensated billets that can be provided, and the difference (if any). For cancellations, identify all billets that will be offered up. Specify differences if there are any. Space is also available to enter Notes.

To enter the Learning Site Manpower data:

Step 1 On the Learning Site Summary window; select the desired site by clicking on that site one time.

Step 2 Select the **RRL** menu item. AIM II will open the TPP RRL window.

Step 3 Select the **Resources** menu item. A drop-down menu will appear which contains all the resources of the TPP RRL.

Step 4 Select **Manpower** on the drop-down menu. AIM II will open the TPP Manpower window. The cursor will default to the Officer Billets Required field.

Step 5 Use your mouse to highlight the field in which you will enter data.

Step 6 For Officer, Enlisted, and Civilian personnel, type in the number of billets authorized (BA), number of billets currently onboard (COB), and the number of billets available (Delta).

Step 7 In the bottom pane of the window there is a Note field where you can add comments about the manpower entries.

Step 8 When you have completed entering the data, select the **Edit** menu item and the **Save** sub-menu item to update the database with your entries.
Step 9 Select the **Exit** menu item to return to the TPP RRL window.

### 1.5.7.2.3 Funding

For your TPP you should identify the appropriation source (e.g., O&MN or OPN), AG/SAG, and the initial or recurring costs. For development of a Revision to an existing course identify only the additional costs required to implement training.

**To enter the Learning Site Funding data:**

1. **Step 1** On the Learning Site Summary window; select the desired site by clicking on that site one time.

2. **Step 2** Select the **RRL** menu item, which will open the TPP RRL window.

3. **Step 3** Select the **Resources** menu item.

4. **Step 4** Select **Funding** on the drop-down menu, which will open the TPP Funding window.

   You can use the **TAB** key to advance forward through the fields. To go backwards through the fields, press **Shift + Tab**. You can also use the arrow keys.

5. **Step 5** Enter the Dollar Amount under the year for each funding category. You can enter whole numbers. The program will automatically format the number to a currency entry including two decimal places.

6. **Step 6** To add a funding category select **Add** from the **Options** menu. The cursor will be located in the Description column of the first blank line.

7. **Step 7** In the bottom pane of the window there is a Note field where you can add comments about the funding entries.

8. **Step 8** When you have completed entering the data, select the **Edit** menu item and either the **Save** or **Cancel** sub-menu item to update your entries.
Step 11 Select the Exit menu item to return to the TPP RRL window.

1.5.7.2.4 Facility

Identify requirements for MILCON (Military Construction) or special projects for facilities modification. These requirements are highly situation-specific. See OPNAVINST 11102.1 andNETCINST 11102.2 for detailed facilities documentation requirements.

To enter Learning Site Facility Data:

Step 1 From the Learning Site Summary window; select the RRL menu item. This will open the TPP RRL window.

Step 2 Select the Resources menu item.

Step 3 Select Facility on the drop-down menu. This will open the TPP Facility window for text entry in the AIM II Text editor.

Step 4 Enter the facility information.

Step 5 When you are finished, select the Edit menu item and either the Save or Cancel sub-menu item to update your entry.

Step 6 Click on Exit to return to the TPP RRL window.

1.5.7.2.5 Select RRL Items

The AIM II software lists the types of resources, which can be entered in a Site Resource Requirements List. The following RRL headings can be selected to identify the resources required for the Learning Site:
To add an RRL Item to the Learning Site:

Step 1  From the Learning Site Summary window highlight the desired Learning Site and select the RRL menu item. This will open the TPP RRL window.

Step 2  Select the Resources menu item.

Step 3  Click on the desired RRL type from the drop-down menu listed.

On the lower portion of the window, you will see the items that exist in the Site RRL.

Step 4  Highlight the desired Site RRL item. If the Site RRL Identifier does not provide enough information on the item, select the Options menu item and the View RRL option. AIM II will retrieve the Site RRL record for your inspection. Select the Exit menu item to return to the TPP RRL window.

Step 5  Select the Options menu item and the Select TPP RRL option or double click on the desired item from those available in the Site RRL Identifier (lower portion of
the window). The item will appear in the upper portion of the window, TPP RRL Identifier.

Step 6 Click in the Qty Req'd field. Enter the quantity required to tech the course. AIM II will check that the quantity required is greater than zero when the entry is saved.

Use the TAB key or click with the mouse to advance to the next field.

Step 7 Highlight the field for Qty On Hand and enter the quantity on hand at the Learning Site.

Step 8 When you have completed adding RRL items of this type from the Site RRL to your TPP RRL, select the Edit menu item and the Save sub-menu item to update your entries. You will be prompted with the question "Would you like to add the RRL item(s) to all Sites?" if there has been more than one site selected in the TPP. Click on Yes to add the item to all sites or No to add the item to the site selected.

Step 9 Repeat Steps 2 through 8 to enter other RRL types/items for the Learning Site.

Step 10 Select the Exit menu item to return to the main TPP RRL window.

1.5.7.2.6 Unselect RRL Items

From the TPP RRL Window:

Step 1 Click on the desired TPP RRL item for deletion.

Step 2 Select the Options menu item and the Unselect TPP RRL option.

Step 3 Confirm the deletion by selecting Yes when prompted.

Step 4 After all desired Learning Site RRL deletions have been made and you try to save your editing you will receive a message stating that the TPP RRL has been modified. You must click on Yes to save your changes.
1.5.7.2.7 Explain Flag

The TPP RRL window contains a Flag column that will display a flag (X) for a TPP RRL item if the item has a maintenance record entry from the Site RRL. The Options menu item in the Site RRL contains a Flag Related Material option with sub-menu items for selection of TPP or Courses. Maintenance records can inform developers/maintainers of the status of the item, (e.g., superseded, change received, etc.).

To review the maintenance record for a flagged TPP RRL item:

- Step 1 Click on the flagged TPP RRL item.
- Step 2 Select the Options menu item and the Explain Flag option. AIM II will retrieve the maintenance record.
- Step 3 Select the Exit menu item to return to the TPP RRL window.

1.5.7.2.8 Remove Flag

The TPP RRL window contains a Flag column that will display a flag (X) for a TPP RRL item if the item has a maintenance record entry from the Site RRL. The Options menu item in the Site RRL contains a Flag Related Material option with sub-menu items for selection of TPP or Courses. Maintenance records can inform developers/maintainers of the status of the item, (e.g., superseded, change received, etc.). Before a TPP can be approved, all flags must be removed from the TPP RRL. Individuals with Remove Flags privilege, as well as the AIM Administrator, can exercise the Remove Flag option. Removing a flag from an item in the TPP RRL does not remove the maintenance record from the item in the Site RRL.

To remove a flag from a TPP RRL item:

- Step 1 Highlight the TPP RRL item that is flagged.
- Step 2 Select the Options menu item and the Remove Flag option. If you do not have Remove Flag privilege this option will not be enabled.
1.6 TPP OPTIONS

After selecting a TPP to work on and saving the TPP window required entries, you can access the TPP Options menu item. The elements of the TPP options are:

- Lock
- Unlock
- Grant Privilege
- Print Preview
- Print.

1.6.1 Lock/Unlock

When you have completed the TPP, and you are ready to use the TPP information to develop other training materials, you must "lock" the TPP. "Locking" the TPP, maintains the integrity of the baseline data from which all other related training materials are built.

The each time the TPP is locked, shared data is copied to the TCCD. This data will be used as the foundation of the TCCD.

To Lock the TPP:

From the TPP window select the Options menu item and the Lock option. The TPP is now locked and no changes may be made to it unless you "unlock" the TPP. The first time the TPP is locked the Status field will change from Incomplete to Locked. Subsequently, when the TPP is unlocked the Status field will change from Locked to Complete. This indicates the information contained in the TPP has already been copied to the TCCD and any further editing of the TPP, with the exception of the Cover Page, must also be performed in the TCCD.

To Unlock the TPP:

Step 1 From the TPP window; select the Options menu item.

Step 2 Select the Unlock option from the drop down menu. The Status field will change from Locked to Complete.
1.6.2 Grant Privilege

Selection of the Grant Privilege option allows an AIM User who is the developer of the TPP to assign Edit, Lock, and Grant privileges to other AIM Users. The AIM Administrator can grant Edit, Lock, Grant, Approve, Remove Flag, and Clear In Use privileges to AIM Users.

1.6.3 Print Preview

Selection of Print Preview will open the Printer Setup window where you have the functionality to add:

- Page X of Y on each page of the document for page accountability when printing classified training management material,
- One line of text in the header and up to three lines of text in the footer to add classification information on all pages of the document, and
- Select the desired orientation of Portrait or Landscape for applicable documents.

Selecting OK will present the default printer selected. Selecting OK from this window causes the software to prepare the document for Print Preview. When prepared it displays the first page of the document and allows you to select the following menu items:

- Options - contains the options to Print or Save to PDF. Print opens the Print window, which allows you to print a page, range of pages, the whole document, print to file, and number of copies. Save to PDF saves the document as a PDF file to the desired location.
- Go To - moves to the previous, next, first, last, or desired page.
- Exit - returns to the TPP window.
- Help - provides text to explain how to use the Print Preview option.

The following buttons and fields are available on the control bar:

- Previous - moves to the previous page.
- Next - moves to the next page.
- Find – Provides a field to enter key word(s) and allows you to search through the document by clicking on the Find button.
- Page _ of Page - displays the current page number and the total number of pages from the beginning of the document in Arabic numerals. Accesses the page desired by typing in the page number in the first field and depressing Enter.
- Actual Page - displays the actual page number, as shown on the page. Typing the page number in this field and depressing Enter accesses the page number desired.
Double clicking the left mouse zooms in and double clicking the right mouse zooms out. Clicking the arrow to the right of the zoom icon (magnifying glass) presents a sub-menu from which you can select **Whole Page, Page Width, Two Pages, Thumbnail**, and present the page in 25% increments to 100% and also select 150%.

**To print preview the TPP:**

1. **Step 1** From the Training Project Plan (TPP) window select the **Options** menu item and the **Print Preview** option. AIM II will open the Printer Setup window.

2. **Step 2** From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

3. **Step 3** Click on the **OK** to print preview.

**1.6.4 Print**

Selection of the **Print** option allows the entire document to be printed:

**To print the entire TPP:**

1. **Step 1** Select the **Options** menu item and the **Print** option. AIM II will open the Printer Setup window.

2. **Step 2** From the Printer Setup window select the desired orientation (Portrait or Landscape), Page X of Y page accountability if desired, and enter additional Header and Footer information as required for classified material.

3. **Step 3** Click on the OK button. While the software is preparing the TPP for print, you can select Cancel to terminate the print job.

**1.7 ON-LINE HELP**

The help option allows you to go directly to the AIM II On-line Help Window. This help option is a hypertext help tool that allows you to find the information that you desire.